There are various reasons why Adobe Captivate or an Adobe Captivate Project doesn't work as expected. This document gives you some advise on how to troubleshoot some unexpected behavior.

Consider these general questions when you troubleshoot unexpected behavior:

  • Does the issue happen with just one project, or all projects.?
  • Does the issue happen with projects you created from scratch?
  • Does it happen to anybody else in your workgroup, or just you?
  • Was the file created in your version of Adobe Captivate, or was it imported from a different version?

1.  Re-create the Adobe Captivate Preference file

Preference files can become corrupt. A preference file can be damaged, for example, because of many external resource usage or copy and paste actions. Re-creating the preference file sets the configuration back to the application's default settings. It deletes potential corrupt data that hinders Adobe Captivate from functioning properly.

Note: Renaming or moving the preference file or folder  is a safer option. If you find that the unexpected behavior didn't change with the new preference file, revert to the original preference file or folder by moving it back.

To re-create the Adobe Captivate Preference file:

Adobe Captivate 4 (Windows only)

  1. Close Adobe Captivate.
  2. Locate the preference file:
    • Windows Vista and Windows 7: C:\Users\[user name]\AppData\Roaming\Adobe\Adobe Captivate\Adobe Captivate_v40.dat
    • Windows XP: C:\Documents and Settings\[user name]\Application Data\Adobe\Adobe Captivate\Adobe Captivate_v40.dat

  3. Rename the preference file, for example OLDAdobe Captivate_v40.dat.
  4. Restart Adobe Captivate. A new preference file is automatically created.

Adobe Captivate 5:

  1. Close Adobe Captivate.
  2. Locate the preference folder:
    • Windows Vista and Windows 7: C:\Users\[user name]\AppData\Local\Adobe\Adobe Captivate 5 folder 
    • Windows XP:  C:\Documents and Settings\[user name]\Local Settings\Application Data\Adobe\Adobe Captivate 5 folder
    • Mac:  /Users/[user name]/Library/Preferences/Adobe Captivate 5 folder
  3. Rename the preference folder.
  4. Restart Adobe Captivate. A new configuration folder is automatically created.

2. Clear the cache (Adobe Captivate 5)

The project cache in Adobe Captivate 5 helps you save and open projects faster. When you create a project in Adobe Captivate 5, a corresponding project cache folder is automatically created. This folder is saved in the project cache root folder specified in the project Preferences.

Clear the cache for a project by clicking Clear Cache in Adobe Captivate > Preferences > Global > General Settings (Mac OS), or Edit > Preferences > Global > General Settings (Windows).

Adobe has created a utility that helps you itentify which cache refers the corresponding project. The utility identifies name, size, status of the project (opened or closed), and other important data.

For more details, see New utility for deleting cache folders | Clear Cache Application (86513).

Note: If your project suddenly doesn't work and you can't open the backup file, you can open the cached version. (For information about opening a backup, see Open Backup Project.)

3.  Copy and paste slides into a new project

Sometimes, elements in a slide can cause unexpected behaviour. Copy a number of slides into a new project and test the workflow again.

4. Import a number of slides into a new project (Adobe Captivate 4)

With Adobe Captivate 4 you can also narrow down a potential problematic slide or element, by using the import option. 

  1. Create a project.
  2. Choose File > Import > Slides and Objects.
  3. Select the Adobe Captivate project.
  4. Select only a few slides to import into the new project (set the other slides to [Do not import] under the import options)
  5. Click OK.
  6. Test your workflow again.

Unopenable files

Open backup project 

Adobe Captivate creates a backup file for your project when you save it. When you resave the project, the changes are saved to the backup file too. The backup file is saved with a .bak extension.

If your project file is corrupted, use the backup file to recover your project. Rename the backup file using a .cp extension (Adobe Captivate 4) or *.cptx (Adobe Captivate 5), and open it in the relevant version.

To set the backup option:

  1. Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).
  2. In the Preferences dialog box, select General Settings from the Global menu.
  3. Select Generate Project Backup.

Notes:

  • Changes that you made after the last save are not reflected in the backup file. 
  • The size of the backup file can be larger than size of your main project.
  • The provision to create a backup file is enabled by default in the Preferences dialog box. You can choose to disable the option if it interferes with the speed of saving the project.

Open a project from a cached file (Adobe Captivate 5)

If you cannot open or locate your backup file, try the following steps to recover full data (up to the latest state of the project). If the data files in the project cache are intact, then this workaround could restore your full project.

  1. Go to New utility for deleting cache folders | Clear Cache Application (cpsid_86513). Download the dcache.zip and install the Adobe AIR app inside the zip file.
  2. Start the AIR app and select your project cache location using the Browse button. (The default location is My Documents\Adobe Captivate Cached Projects). Click Refresh. 
  3. Check if you can see your project (which is not opening in Adobe Captivate) listed in the dialog box. If yes, then double-click that row in the Adobe AIR app to display a dialog box containing the Cache Path as shown in the image below.
    • cache path screen shot
  4. Open the Cache Path folder and then open the db folder. Check whether the following exist in it:
    • compressed_data (folder)
    • objects (folder, this contains an objects.cpo file and its size must be > 0 KB
    •  uncompressed_data (folder)
    •  audio.cpad (file, size > 0 KB)
    • info.cpi (file, size > 0 KB)
    • text.cptd (file, size > 0 KB)
    •  thumbnails.cpth (file, size > 0 KB)
  5. If these folders and files are present, then select them and create a zip file.
  6. Rename the filename extension from .zip  to .cptx.
    • Note: There can be other files or folders inside the db folder (for example, already_in_use.lock, backup_data, and so on). Don’t include them while creating the zip file; include only the ones mentioned above.
  7. Open the .cptx file in Adobe Captivate 5.

Notes:

  • This workaround doesn't always work.
  • In some scenarios the newly created cptx (created in step 4 above) could have some unsaved changes also. (For example, when the project had some unsaved changes and Adobe Captivate crashed, you could see those unsaved changes in the cptx.)

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy