Utilizzare il pannello Cronologia in Dreamweaver per riprodurre e automatizzare le operazioni. Creare, utilizzare e salvare comandi basati sui passaggi della Cronologia.

Nota:

In Dreamweaver CC 2017 e versioni successive, il pannello Cronologia è obsoleto. 

Automatizzare le operazioni

Il pannello Cronologia registra i passaggi effettuati per eseguire un'operazione. Per automatizzare un'operazione eseguita di frequente, potete ripetere quei passaggi dal pannello Cronologia oppure creare un nuovo comando che li esegua automaticamente.

Alcuni movimenti del mouse, come la selezione di un oggetto nella finestra del documento mediante un clic, non possono essere ripetuti o salvati. Quando eseguite un movimento di questo tipo, nel pannello Cronologia viene visualizzata una linea nera (che non diventa visibile fino a quando non si esegue un'altra operazione). Per evitare questo inconveniente, utilizzate i tasti freccia anziché il mouse per spostare il punto di inserimento all'interno della finestra del documento.

Anche altri passaggi, come l'azione di trascinare un elemento di pagina in una posizione diversa, non sono ripetibili. Quando vengono eseguiti, nel pannello Cronologia viene visualizzata un'icona con una piccola X rossa.

I comandi salvati vengono memorizzati in modo permanente (fino a quando non vengono esplicitamente eliminati), mentre quelli registrati vengono eliminati quando uscite da Adobe Dreamweaver; le sequenze di passaggi copiate vengono invece eliminate quando copiate un altro elemento.

Utilizzare il pannello Cronologia

Il pannello Cronologia (Finestra > Cronologia) mostra un elenco di tutti i passaggi eseguiti nel documento attivo dalla sua creazione o apertura (non invece i passaggi effettuati in altri frame, in altre finestre del documento o nel pannello Sito). Il pannello Cronologia consente di annullare più passaggi contemporaneamente e di automatizzare le operazioni.

Pannello Cronologia
Pannello Cronologia

A. Dispositivo di scorrimento (cursore) B. Passaggi C. Pulsante Riproduci D. Pulsante Copia passaggi E. Pulsante Salva come comando 

Il dispositivo di scorrimento, o cursore, del pannello Cronologia inizialmente indica l'ultimo passaggio eseguito.

Nota:

non è possibile riorganizzare l'ordine dei passaggi nel pannello Cronologia. Il pannello Cronologia non va considerato come una raccolta arbitraria di comandi, bensì come uno strumento per visualizzare le azioni eseguite, in base al loro ordine di esecuzione.

Annullare l'ultimo passaggio

  1. Effettuate una delle operazioni seguenti:
    • Selezionate Modifica > Annulla.

    • Trascinando il cursore del pannello Cronologia, salite di un passaggio all'interno dell'elenco.

    Nota:

    per scorrere automaticamente fino a un determinato passaggio, dovete fare clic alla sua sinistra. Se invece si fa clic sul passaggio, quest'ultimo viene selezionato. Selezionare un passaggio è un'operazione diversa rispetto a tornare indietro nella cronologia di annullamento.

Annullare più passaggi

  1. Trascinate il cursore su un passaggio o fate clic a sinistra di un passaggio sul tracciato del cursore.

    Il cursore scorre automaticamente fino a quel passaggio, annullando tutti i passaggi intermedi.

    Nota:

    come per l'annullamento di un singolo passaggio, se annullate una serie di passaggi e successivamente effettuate una nuova operazione nel documento, non potete più ripetere i passaggi annullati, poiché sono stati eliminati dal pannello Cronologia.

Impostare il numero di passaggi memorizzati e visualizzati dal pannello Cronologia

Il numero di passaggi predefinito è adeguato per le esigenze della maggior parte degli utenti. Più alto è il numero, maggiore è la quantità di memoria utilizzata dal pannello Cronologia e di conseguenza l'impatto su prestazioni e velocità del computer.

  1. Selezionate Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Macintosh).
  2. Selezionate Generali nell'elenco Categoria visualizzato sulla sinistra.
  3. Inserite un numero nel campo Numero massimo di passaggi di Cronologia.

    Quando il pannello Cronologia raggiunge il numero massimo di passaggi, i passaggi meno recenti vengono eliminati.

Cancellare l'elenco del pannello Cronologia per il documento corrente

  1. Nel menu di scelta rapida del pannello Cronologia, selezionate Cancella Cronologia.

    Questo comando cancella anche tutte le informazioni di annullamento per il documento corrente: dopo aver scelto Cancella Cronologia, non è più possibile annullare i passaggi che sono stati cancellati. Il comando Cancella Cronologia non annulla i passaggi, bensì ne elimina semplicemente la registrazione dalla memoria.

Ripetere i passaggi

Il pannello Cronologia consente di ripetere l'ultimo passaggio eseguito, una serie di passaggi adiacenti o una serie di passaggi non adiacenti. Eseguite la ripetizione dei passaggi direttamente dal pannello Cronologia.

Ripetere un singolo passaggio

  1. Effettuate una delle operazioni seguenti:
    • Selezionate Modifica > Ripeti.

    • Nel pannello Cronologia, selezionate il passaggio e fate clic sul pulsante Riproduci. Il passaggio viene riprodotto e una sua copia viene visualizzata nel pannello Cronologia.

Ripetere una serie di passaggi

  1. Selezionate i passaggi desiderati nel pannello Cronologia:
    • Per selezionare più passaggi adiacenti, trascinate dal primo all'ultimo (non trascinate il cursore, bensì il puntatore del mouse dall'etichetta di testo del primo passaggio a quella dell'ultimo), oppure selezionate il primo passaggio e poi fate clic sull'ultimo tenendo premuto il tasto Maiusc.

    • Per selezionare passaggi non adiacenti, selezionate un passaggio, quindi selezionate o deselezionate gli altri passaggi facendo clic su di essi tenendo premuto il tasto Ctrl (Windows) o il tasto Comando (Macintosh).

      I passaggi riprodotti sono quelli selezionati (evidenziati) e non comprendono necessariamente quello sul quale è posizionato il cursore.

    Nota:

    benché sia possibile selezionare una serie di passaggi che include la linea nera che indica un passaggio non registrabile, quest'ultimo viene ignorato durante la riproduzione dei passaggi.  

  2. Fate clic su Riproduci.

    I passaggi vengono riprodotti in ordine e un nuovo passaggio, Riproduci passaggi, viene visualizzato nel pannello Cronologia.

Definire o estendere una selezione

  1. Premete un tasto freccia tenendo premuto il tasto Maiusc.

    Nota:

    Se mentre eseguite un'operazione che desiderate ripetere in seguito viene visualizzata la linea nera che indica il movimento del mouse, potete annullare tale passaggio e provare un approccio diverso (ad esempio utilizzando i tasti freccia).

Applicare passaggi del pannello Cronologia a oggetti

Potete applicare una serie di passaggi contenuti nel pannello Cronologia a qualunque oggetto presente nella finestra Documento.

Se selezionate più oggetti in un documento e quindi applicate a essi dei passaggi del pannello Cronologia, gli oggetti vengono considerati come un'unica selezione e Dreamweaver tenta di applicare i passaggi a tale selezione combinata; tuttavia, potete applicare una serie di passaggi a un solo oggetto alla volta.

Per applicare i passaggi a ogni oggetto facente parte di un gruppo, occorre specificare come ultimo passaggio della serie la selezione dell'oggetto successivo del gruppo. La seconda procedura illustra tale principio in uno scenario particolare: l'impostazione della spaziatura verticale e orizzontale di una serie di immagini:

Applicare passaggi a un altro oggetto

  1. Selezionate l'oggetto.
  2. Selezionate i passaggi desiderati nel pannello Cronologia, quindi fate clic su Riproduci.

Applicare passaggi a più oggetti

  1. Iniziate con un documento in cui la prima riga sia costituita da un'immagine di piccole dimensioni (ad esempio, il punto grafico di un elenco o un'icona) seguita da un testo.

    Lo scopo è quello di distanziare le immagini dal testo e dalle altre immagini che si trovano sopra e sotto di esse.

    Ogni riga è costituita da una piccola immagine
    Ogni riga è costituita da una piccola immagine

  2. Aprite la finestra di ispezione Proprietà (Finestra > Proprietà), se non è già aperta.
  3. Selezionate la prima immagine.
  4. Nella finestra di ispezione Proprietà, impostate la spaziatura dell'immagine inserendo i numeri nelle caselle Spazio V e Spazio O.
  5. Per rendere attiva la finestra del documento senza spostare il cursore, fate nuovamente clic sull'immagine.
  6. Premete il tasto freccia sinistra per spostare il punto di inserimento a sinistra dell'immagine.
  7. Premete il tasto freccia giù per far scendere di una riga il punto di inserimento, lasciandolo a sinistra della seconda immagine della serie.
  8. Premete contemporaneamente il tasto freccia destra e il tasto Maiusc per selezionare la seconda immagine.

    Nota:

    non selezionate l'immagine con il mouse, altrimenti non sarà possibile riprodurre tutti i passaggi.

  9. Nel pannello Cronologia, selezionate i passaggi corrispondenti alle azioni di modifica della spaziatura dell'immagine e di selezione dell'immagine successiva. Fate clic sul pulsante Riproduci per riprodurre i passaggi.
    Fate clic sul pulsante Riproduci per riprodurre i passaggi
    Fate clic sul pulsante Riproduci per riprodurre i passaggi

    La spaziatura dell'immagine corrente viene modificata e viene selezionata l'immagine successiva.

    Modifiche alla spaziatura dell'immagine corrente
    Modifiche alla spaziatura dell'immagine corrente

  10. Continuate a fare clic su Riproduci fino a quando tutte le immagini presentano una spaziatura corretta.

Copiare e incollare passaggi tra documenti

Ogni documento aperto dispone di una propria cronologia di passaggi. Potete copiare dei passaggi da un documento e incollarli in un altro.

La chiusura di un documento ne cancella la cronologia. Se prevedete di riutilizzare i passaggi di un documento, copiateli o salvateli prima di chiuderlo.

  1. Nel documento che contiene i passaggi da riutilizzare, selezionate i passaggi desiderati nel pannello Cronologia.
  2. Selezionate Copia passaggi nel pannello Cronologia .

    Nota:

    il pulsante Copia passaggi del pannello Cronologia è diverso dal comando Copia del menu Modifica. Per copiare i passaggi non potete selezionare Modifica > Copia, ma potete utilizzare il comando Modifica > Incolla per incollarli.

    Quando copiate passaggi che includono un comando Copia o Incolla, osservate le seguenti raccomandazioni:

    • Non utilizzate Copia passaggi se uno dei passaggi è un comando Copia, poiché la successiva applicazione del comando Incolla a tali passaggi potrebbe produrre effetti indesiderati.

    • Se i passaggi comprendono un comando Incolla, non potete incollarli, a meno che non includano anche un comando Copia prima del comando Incolla.

  3. Aprite l'altro documento.
  4. Spostate il punto di inserimento nella posizione desiderata oppure selezionate un oggetto a cui applicare i passaggi.
  5. Selezionate Modifica > Incolla.

    I passaggi vengono riprodotti mentre vengono copiati nel pannello Cronologia del documento. che li visualizza sotto forma di un unico passaggio chiamato Incolla passaggi.

    Se incollate dei passaggi in un editor di testo, nella vista Codice o nella finestra di ispezione Codice, essi vengono visualizzati sotto forma di codice JavaScript e possono essere utili per imparare a creare degli script personalizzati.

Creare e utilizzare comandi basati su passaggi della Cronologia

Potete salvare una serie di passaggi della Cronologia sotto forma di comando con nome e renderla quindi disponibile nel menu Comandi. Questo tipo di operazione è utile se prevedete di riutilizzare una serie di passaggi, ad esempio in una successiva sessione di lavoro in Dreamweaver.

Creare un comando

  1. Selezionate un passaggio o una serie di passaggi dal pannello Cronologia.
  2. Fate clic sul pulsante Salva come comando o selezionate Salva come comando dal menu di scelta rapida del pannello Cronologia.
  3. Inserite un nome per il comando e fate clic su OK.

    Il comando viene visualizzato nel menu Comandi.

    Nota:

    il comando viene salvato come file JavaScript (o in alcuni casi come file HTML) nella cartella Dreamweaver/Configuration/Commands. Se utilizzate Dreamweaver in un sistema operativo multiutente, il file viene salvato nella cartella Comandi specifica dell'utente.

Utilizzare un comando salvato

  1. Selezionate un oggetto a cui applicare il comando oppure spostate il punto di inserimento nella posizione di applicazione.
  2. Selezionate il comando dal menu Comandi.

Modificare il nome di un comando

  1. Selezionate Comandi > Modifica elenco comandi.
  2. Selezionate il comando da rinominare, inserite il nuovo nome e fate clic su Chiudi.

Eliminare un nome dal menu Comandi

  1. Selezionate Comandi > Modifica elenco comandi.
  2. Selezionate un comando.
  3. Fate clic su Elimina, quindi su Chiudi.

Registrare e salvare i comandi

Potete registrare un comando temporaneo per utilizzarlo a breve termine, oppure registrarlo e salvarlo per un utilizzo futuro. Dreamweaver memorizza un solo comando registrato per volta; di conseguenza, quando iniziate a registrare un nuovo comando, quello precedente viene perso, a meno che non sia stato preventivamente salvato.

Registrare temporaneamente una serie passaggi

  1. Selezionate Comandi > Avvia registrazione oppure premete Ctrl+Maiusc+X (Windows) o Comando+Maiusc+X (Macintosh).

    Il puntatore cambia di aspetto per indicare che è in corso la registrazione di un comando.

  2. Una volta terminata la registrazione, scegliete Comandi > Interrompi registrazione oppure premete Ctrl+Maiusc+X (Windows) o Comando+Maiusc+X (Macintosh).

Riprodurre un comando registrato

  1. Selezionate Comandi > Riproduci comando registrato.

Salvare un comando registrato

  1. Selezionate Comandi > Riproduci comando registrato.
  2. Selezionate il passaggio Esegui comando (nell'elenco dei passaggi del pannello Cronologia) e fate clic sul pulsante Salva come comando.
  3. Inserite un nome per il comando e fate clic su OK.

    Il comando viene visualizzato nel menu Comandi.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online