Scopri come alternare le diverse viste, sovrapporre, affiancare e ridimensionare la finestra Documento in Dreamweaver.

Nota:

l'interfaccia utente di Dreamweaver CC e versioni successive è stata semplificata. Di conseguenza, potreste non trovare alcune delle opzioni descritte in questo articolo in Dreamweaver CC e versioni successive. Per ulteriori informazioni, consultate questo articolo.

Passare da una vista all'altra nella finestra del documento

Potete visualizzare un documento nella finestra del documento nelle viste Codice, Codice divisa, Progettazione e Codice e Progettazione (vista combinata) o Dal vivo. Potete anche visualizzare la vista Codice divisa o la vista Codice e Progettazione in senso orizzontale o verticale. (La visualizzazione orizzontale è quella predefinita).

Nota:

l'opzione Vista Progettazione non è disponibile per i documenti a griglia fluida.

Passare alla vista Codice

  1. Effettuate una delle operazioni seguenti:
    • Selezionate Visualizza > Codice.

    • Nella barra degli strumenti Documento, fate clic sul pulsante Codice.

       

       

Passare alla vista Codice divisa

La vista Codice divisa suddivide il documento in due per consentirvi di lavorare in due sezioni del codice contemporaneamente.

  1. Selezionate Visualizza > Dividi codice.

Passare alla vista Progettazione

Nella barra degli strumenti Documento, fate clic sull'elenco a discesa accanto all'opzione Dal vivo, quindi su Progettazione. Per passare alla vista Progettazione completa, fate clic sul pulsante Progettazione.

Visualizzare contemporaneamente le viste Codice e Progettazione

 

Nella barra degli strumenti Documento, fate clic sul pulsante Dividi. Quindi, fate clic sull'elenco a discesa accanto all'opzione Dal vivo e poi su Progettazione.

 

Dividere viste verticalmente o orizzontalmente

  1. Assicuratevi di essere nella vista Dividi (Dividi Codice o vista combinata Progettazione/Dal Vivo).

  2. Per dividere la vista verticalmente, selezionate Visualizza > Dividi in verticale. Per dividere la vista orizzontalmente, deselezionate Visualizza > Dividi in verticale.

Sovrapporre o affiancare le finestre dei documenti

Se avete molti documenti aperti contemporaneamente, potete disporli affiancati o sovrapposti.

Sovrapporre le finestre dei documenti

  1. Selezionate Finestra > Sovrapponi.

Affiancare le finestre dei documenti

  • In ambiente Windows, selezionate Finestra > Affianca orizzontalmente o Finestra > Affianca verticalmente.
  • In ambiente Macintosh, selezionate Finestra > Affianca.

Ridimensionare la finestra del documento

La barra di stato visualizza le dimensioni correnti della finestra del documento (in pixel). Per progettare una pagina che dia risultati ottimali a dimensioni specifiche, potete adattare la finestra del documento a una delle dimensioni predeterminate, modificare tali dimensioni oppure crearne di nuove.

Quando modificate le dimensioni della vista di una pagina nella vista Progettazione o Dal vivo, vengono modificate solo le dimensioni della vista. Le dimensioni del documento rimangono invariate.

Oltre alle dimensioni predeterminate o personalizzate, Dreamweaver elenca anche le dimensioni specificate in una media query. Quando selezionate le dimensioni corrispondenti a una media query, Dreamweaver utilizza la media query per visualizzare la pagina. Potete inoltre modificare l'orientamento della pagina per visualizzarla in anteprima per i dispositivi mobili in cui il layout di pagina cambia in base alla posizione del dispositivo.

Per ridimensionare la finestra del documento, selezionate una delle opzioni visualizzate nel menu a comparsa Dimensioni finestra situato nella parte inferiore della finestra del documento.

Ripristinare le dimensioni predefinite della finestra del documento

  1. Selezionate una delle opzioni visualizzate nel menu a comparsa Dimensioni finestra situato nella parte inferiore della finestra del documento. Dreamweaver CS5.5 e versioni successive offrono un elenco esteso di scelte, comprese le opzioni specifiche per i più diffusi dispositivi mobili (come descritto di seguito).
    Ridimensionare la finestra del documento

    Le dimensioni della finestra si riferiscono alle dimensioni interne della finestra del browser (senza i bordi). Le dimensioni del monitor o del dispositivo mobile sono indicate sulla destra.

    Nota:

    Per un ridimensionamento meno preciso, utilizzate i metodi consueti del sistema operativo in uso, ad esempio il trascinamento dell'angolo inferiore destro di una finestra.

    Nota:

    (solo per Windows) i documenti nella finestra del documento sono ingranditi per impostazione predefinita; non potete ridimensionare un documento quando è ingrandito. Per annullare l'ingrandimento del documento, fate clic sul pulsante corrispondente  nell'angolo superiore destro del documento.

Modificare i valori elencati nel menu a comparsa Dimensioni finestra

  1. Selezionate Modifica dimensioni dal menu a comparsa Dimensioni finestra.
  2. Fate clic su uno dei valori di larghezza o altezza dell'elenco Dimensioni finestra e digitate un nuovo valore.

    Per modificare solo la larghezza della finestra del documento (lasciando invariata l'altezza), selezionate un valore di altezza e cancellarlo.

  3. Fate clic nella casella di testo Descrizione se desiderate inserire un testo descrittivo per una dimensione specifica.

Aggiungere una nuova opzione al menu a comparsa Dimensioni finestra

  1. Selezionate Modifica dimensioni dal menu a comparsa Dimensioni finestra.
  2. Fate clic nello spazio vuoto situato sotto l'ultimo valore della colonna Larghezza.
  3. Inserite una larghezza e un'altezza.

    Per impostare solo la larghezza o solo l'altezza, è sufficiente lasciare vuoto uno dei due campi.

  4. Fate clic nel campo Descrizione se desiderate inserire un testo descrittivo per la dimensione aggiunta.

    Ad esempio, digitate SVGA o PC normale accanto alla voce relativa a un monitor da 17 pollici con risoluzione 800 x 600 pixel. Mac accanto alla voce relativa a un monitor con risoluzione di 832 x 624 pixel. La maggior parte dei monitor supporta più dimensioni in pixel.

  5. Fate clic su Applica e chiudete la finestra di dialogo.

    La nuova dimensione della finestra è ora disponibile per essere utilizzata nel menu a comparsa Dimensioni finestra.

Impostare le dimensioni delle finestre e della velocità di connessione

  1. Selezionate Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Macintosh).
  2. Selezionate Dimensioni finestra dall'elenco Categoria visualizzato sulla sinistra.

  3. Personalizzate le Dimensioni finestra come richiesto.

Rapporti di Dreamweaver

Potete eseguire i rapporti in Dreamweaver per trovare i contenuti, testarli o risolverne i problemi. Potete generare i tipi di rapporti seguenti:

Cerca

Consente di cercare tag, attributi e testo specifico nei tag.

Riferimenti

Consente di consultare utili informazioni di riferimento.

Convalida

Consente di controllare la presenza di errori nel codice o di sintassi.

Compatibilità browser

Consente di controllare il codice HTML nei documenti per verificare se sono presenti tag o attributi non supportati dai browser di destinazione.

Controllo collegamenti

Consente di trovare e correggere i collegamenti interrotti, esterni o orfani.

Rapporti sito

Consente di migliorare il flusso di lavoro e verificare gli attributi HTML nel sito. I rapporti Flusso di lavoro includono Ritirato da, Flash e Design Notes. I rapporti HTML includono Tag Font nidificati combinabili, Accessibilità, Testo Alt mancante, Tag nidificati superflui, Tag vuoti eliminabili e Documenti senza titolo.

Registro FTP

Consente di visualizzare tutte le attività di trasferimento file FTP.

Debug server

Consente di visualizzare informazioni per il debug di un'applicazione Adobe® ColdFusion®.

Nota:

il supporto per ColdFusion è stato rimosso in Dreamweaver CC e versioni successive.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online