Informazioni sull'area di lavoro di Dreamweaver, le diverse viste e aree di lavoro disponibili e tutti i vari pannelli e barre degli strumenti in Dreamweaver.

Primi passi con Dreamweaver

Dopo l'installazione di Dreamweaver, al primo avvio dell'applicazione, un menu di Avvio rapido viene visualizzato; in questo menu sono riportate tre domande che consentono di personalizzare l'area di lavoro di Dreamweaver in base alle esigenze.

In base alle risposte alle domande, Dreamweaver si apre in un'area di lavoro Sviluppatore (un layout minimale incentrato sul codice) o in un'area di lavoro Standard (un layout suddiviso con strumenti visivi e un'anteprima in app quando scrivete codice). 

Dopo aver scelto l'area di lavoro, scegliete il tema di colore desiderato. Ora potete iniziare.

Nota:

Le preferenze dell'area di lavoro possono essere cambiate successivamente in qualsiasi momento selezionando Modifica > Preferenze.

Schermata Inizio migliorata

La schermata Inizio in Dreamweaver consente di accedere rapidamente ai file utilizzati di recente, ai tipi di file e ai modelli per iniziare.

A seconda dello stato dell’abbonamento, questa area di lavoro può anche presentare contenuti personalizzati in base alle vostre esigenze.

Dreamweaver visualizza la schermata Inizio all’avvio o quando non è aperto nessun documento.

Area di lavoro Inizio in Dreamweaver
Area di lavoro Inizio in Dreamweaver

Opzioni dell'esperienza iniziale di Dreamweaver

Scopri

Fate clic su Scopri per avere accesso immediato da questa schermata alle esercitazioni di Dreamweaver.

Avvio rapido

Iniziate a creare i documenti in Dreamweaver facendo clic su uno dei tipi di file visualizzato.

Modelli per iniziare

Aprite uno dei modelli per iniziare inclusi in Dreamweaver. 

Inizio

Fate clic su Inizio per tornare alla schermata Inizio. 

Nella schermata Inizio, sono visualizzati i file su cui stavate lavorando di recente. Se non sono presenti file recenti, questa scheda è vuota.

Potete anche utilizzare la funzionalità di ricerca facendo clic sull’icona Ricerca nell’angolo superiore destro di questa schermata. Quando immettete una query di ricerca, l’applicazione visualizza i file recenti, le risorse Creative Cloud, i collegamenti dell’aiuto e le immagini stock che corrispondono alla query di ricerca immessa.

Nota:

La schermata iniziale è attivata ed è aperta per impostazione predefinita. 

Se la schermata iniziale non è necessaria, deselezionate Mostra schermata iniziale nella finestra di dialogo Preferenze > Generali.

Per iniziare a creare nuovi file di Dreamweaver, potete fare clic su Crea nuovo. Se nel sistema sono già disponibili dei file, fate clic su Apri. Per informazioni sulla creazione e sull'apertura di documenti in Dreamweaver, consultate Creare e aprire file.

Panoramica dell’area di lavoro

L'area di lavoro di Dreamweaver consente di esaminare le proprietà dei documenti e degli oggetti. Include anche la maggior parte delle operazioni comuni nelle barre degli strumenti in modo da poter modificare velocemente i documenti.

Area di lavoro di Dreamweaver (CC)
Area di lavoro di Dreamweaver

A. Barra applicazione B. Barra degli strumenti Documento C. Finestra del documento D. Commutatore area di lavoro E. Pannelli F. Vista Codice G. Barra di stato H. Selettore di tag I. Vista Dal vivo J. Barra strumenti 

Panoramica sugli elementi dell'area di lavoro

L'area di lavoro comprende i seguenti elementi:

Barra applicazione

Si trova nella parte superiore della finestra dell'applicazione e contiene un commutatore dell'area di lavoro, dei menu (solo per Windows) e altri controlli dell'applicazione.

Barra degli strumenti Documento

Contiene i pulsanti che consentono di passare a viste diverse della finestra Documento (ad esempio, Progettazione, Dal vivo e Codice).

Barra degli strumenti Standard

Per visualizzare la barra degli strumenti Standard, selezionate Finestra > Barre degli strumenti > Standard. La barra degli strumenti contiene i pulsanti per le operazioni comuni da eseguire dai menu File e Modifica: Nuovo, Apri, Salva, Salva tutto, Stampa codice, Taglia, Copia, Incolla, Annulla e Ripeti.

Barra degli strumenti

Si trova a sinistra della finestra dell'applicazione e contiene i pulsanti delle viste.

Finestra del documento

Visualizza il documento corrente durante le operazioni di creazione e modifica.

Finestra di ispezione Proprietà

Consente di visualizzare e modificare una serie di proprietà dell'oggetto o del testo selezionato. Per ogni oggetto sono disponibili diverse proprietà.

Selettore di tag

Situato nella barra di stato nella parte inferiore della finestra del documento. Visualizza la gerarchia dei tag che contengono la selezione corrente. Fate clic su qualsiasi tag nella gerarchia per selezionare il tag specifico e il relativo contenuto.

Pannelli

Consentono di monitorare e modificare il lavoro. Alcuni esempi di pannelli sono il pannello Inserisci, il pannello CSS Designer e il pannello File. Per espandere un pannello, fate doppio clic sulla relativa linguetta.

Pannello Extract

Consente di caricare e visualizzare i file PSD su Creative Cloud. Utilizzando questo pannello, potete estrarre codice CSS, testo, immagini, caratteri, colori, gradienti e misure dalle composizioni PSD e inserire questi elementi nel documento.

Pannello Inserisci

Contiene i pulsanti che consentono di inserire in un documento vari tipi di oggetti, ad esempio immagini, tabelle ed elementi multimediali. Ogni oggetto consiste in una porzione di codice HTML che consente di impostare i diversi attributi mano a mano che lo inserite. Ad esempio, potete inserire una tabella facendo clic sul pulsante Tabella del pannello Inserisci. Se preferite, potete inserire gli oggetti utilizzando il menu Inserisci invece del pannello Inserisci.

Pannello File

Consente di gestire i file e le cartelle, indipendentemente dal fatto che facciano parte di un sito Dreamweaver oppure risiedano su un server remoto. Il pannello File consente anche di accedere a tutti i file presenti sul disco locale. Per ulteriori informazioni, consultate Gestire file e cartelle.

Pannello Snippet

Consente di salvare e riutilizzare gli snippet di codice tra pagine Web diverse, siti diversi e installazioni di Dreamweaver diverse (utilizzando le impostazioni di sincronizzazione). Per ulteriori informazioni, consultate Riutilizzo del codice con gli snippet.

Pannello CSS Designer

È una finestra di ispezione Proprietà per CSS che consente di creare “visivamente” stili e file CSS e di impostarne le proprietà, nonché di definire media query.

Nota:

Dreamweaver fornisce molti altri pannelli, finestre di ispezione e finestre di opzioni. Per aprire i pannelli, le finestre di ispezione e le finestre, utilizzate il menu Finestra.

Panoramica sulla finestra del documento

La finestra del documento mostra il documento corrente. Per passare a una vista diversa del documento, utilizzate la barra degli strumenti Documento. 

Potete anche passare a una vista diversa utilizzando le opzioni di visualizzazione del menu Visualizza.

Vista Dal vivo

Riproduce una rappresentazione più realistica dell'aspetto che avrà il documento in un browser, consentendovi di interagire con il documento esattamente come in un browser. Potete modificare gli elementi HTML direttamente nella vista Dal vivo e visualizzare istantaneamente l'anteprima delle modifiche nella stessa vista. Per ulteriori informazioni sulla modifica nella vista Dal vivo, consultate Modificare elementi HTML nella vista Dal vivo.

Vista Progettazione

Un ambiente per il layout di pagina visivo, la modifica visiva e lo sviluppo rapido di applicazioni. In questa vista, Dreamweaver offre una rappresentazione visiva e modificabile del documento, simile a quella che si otterrebbe guardando la pagina in un browser.

Vista Codice

Un ambiente di codifica manuale per scrivere e modificare codice HTML, JavaScript e di qualunque altro tipo.

Codice - Codice

Una versione divisa della vista Codice, che vi consente di scorrere per lavorare contemporaneamente su sezioni diverse del documento. 

Codice - Dal vivo

Consente di visualizzare sia la vista Codice sia la vista Dal vivo per un documento nella stessa finestra.

Codice - Progettazione

Consente di visualizzare sia la vista Codice sia la vista Progettazione per un documento nella stessa finestra.

Codice dal vivo

Viene visualizzato il codice effettivo utilizzato da un browser per il rendering della pagina, che può cambiare in modo dinamico mentre interagite con la pagina nella vista Dal vivo.

Quando una finestra documento è ingrandita (impostazione predefinita), nella parte superiore vengono visualizzate delle linguette che mostrano i nomi di file di tutti i documenti aperti. Dreamweaver visualizza un asterisco dopo il nome di file se avete apportato delle modifiche che non sono ancora state salvate.

Dreamweaver visualizza anche la barra degli strumenti File correlati al di sotto della scheda del documento (o sotto la barra del titolo del documento se state visualizzando i documenti in finestre separate). I documenti correlati sono documenti associati al file corrente, quali i file CSS o JavaScript. Per aprire uno di questi file correlati nella finestra del documento, fate clic sul nome del file desiderato nella barra degli strumenti File correlati.

Passare da una vista all’altra

Utilizzate la barra degli strumenti Documento per passare rapidamente tra le diverse viste. Per ulteriori informazioni, consultate Panoramica sulla barra degli strumenti Documento.

Potete anche passare tra le viste utilizzando le opzioni seguenti del menu Visualizza:

  • Solo vista Codice: selezionate Codice
  • Vista Dividi: selezionate Dividi e una delle opzioni di divisione
  • Modalità visualizzazione: alterna tra le viste Progettazione e Dal vivo
  • Cambia viste: per alternare le viste da una vista all'altra.
Alternare le viste utilizzando le opzioni del menu Visualizza
Alternare le viste utilizzando le opzioni del menu Visualizza

Sovrapporre, affiancare o ridisporre le finestre dei documenti

Se avete molti documenti aperti contemporaneamente, potete disporli affiancati o sovrapposti.

Per sovrapporre le finestre dei documenti: selezionate Finestra > Disponi > Sovrapponi.

Per affiancare le finestre dei documenti: 

  • In ambiente Windows, selezionate Finestra Disponi > Affianca orizzontalmente o Affianca verticalmente.
  • In ambiente Macintosh, selezionate Finestra > Disponi > Affianca.

Quando aprite più file, le finestre dei documenti sono presentate sotto forma di schede. Per modificare l'ordine delle schede, trascinate la scheda di una finestra fino alla posizione desiderata nel gruppo di schede.

Ridimensionare la finestra del documento

La barra di stato visualizza le dimensioni correnti della finestra del documento (in pixel). Per progettare una pagina che dia risultati ottimali a dimensioni specifiche, potete adattare la finestra del documento a una delle dimensioni predeterminate, modificare tali dimensioni oppure crearne di nuove.

Quando modificate le dimensioni della vista di una pagina nella vista Progettazione o Dal vivo, vengono modificate solo le dimensioni della vista. Le dimensioni del documento rimangono invariate.

Oltre alle dimensioni predeterminate o personalizzate, Dreamweaver elenca anche le dimensioni specificate in una media query. Quando selezionate le dimensioni corrispondenti a una media query, Dreamweaver utilizza la media query per visualizzare la pagina. Potete inoltre modificare l'orientamento della pagina per visualizzarla in anteprima per i dispositivi mobili in cui il layout di pagina cambia in base alla posizione del dispositivo.

Per ridimensionare la finestra del documento, selezionate una delle opzioni visualizzate nel menu a comparsa Dimensioni finestra situato nella parte inferiore della finestra del documento.

Opzioni di ridimensionamento del documento
Opzioni di ridimensionamento del documento

Le dimensioni della finestra si riferiscono alle dimensioni interne della finestra del browser (senza i bordi). Le dimensioni del monitor o del dispositivo mobile sono indicate sulla destra.

Nota:

Per un ridimensionamento meno preciso, utilizzate i metodi consueti del sistema operativo in uso, ad esempio il trascinamento dell'angolo inferiore destro di una finestra.

Nota:

(solo per Windows) I documenti nella finestra del documento sono ingranditi per impostazione predefinita; non potete ridimensionare un documento quando è ingrandito. Per annullare l'ingrandimento del documento, fate clic sul pulsante corrispondente nell'angolo superiore destro del documento.

Modificare i valori elencati nel menu a comparsa Dimensioni finestra

  1. Selezionate Modifica dimensioni dal menu a comparsa Dimensioni finestra.

  2. Fate clic su uno qualsiasi dei valori di larghezza o altezza dell'elenco Dimensioni finestra e digitate un nuovo valore. Per modificare solo la larghezza della finestra del documento (lasciando invariata l'altezza), selezionate un valore di altezza e cancellatelo.

  3. Fate clic nella casella di testo Descrizione se desiderate inserire un testo descrittivo per una dimensione specifica.

Aggiungere una nuova opzione al menu a comparsa Dimensioni finestra

  1. Selezionate Modifica dimensioni dal menu a comparsa Dimensioni finestra.

    Aggiungere dimensioni di finestra al menu a comparsa Dimensioni finestra
    Aggiungere dimensioni di finestra al menu a comparsa Dimensioni finestra

  2. Fate clic nello spazio vuoto situato sotto l'ultimo valore della colonna Larghezza.

  3. Inserite una larghezza e un'altezza.

    Per impostare solo la larghezza o solo l'altezza, è sufficiente lasciare vuoto uno dei due campi.

  4. Fate clic nel campo Descrizione se desiderate inserire un testo descrittivo per la dimensione aggiunta.

    Ad esempio, digitate SVGA o PC normale accanto alla voce relativa a un monitor da 17 pollici con risoluzione 800 x 600 pixel. Mac accanto alla voce relativa a un monitor con risoluzione di 832 x 624 pixel. La maggior parte dei monitor supporta più dimensioni in pixel.

  5. Fate clic su Applica e chiudete la finestra di dialogo.

    La nuova dimensione della finestra è ora disponibile per essere utilizzata nel menu a comparsa Dimensioni finestra.

Panoramica sulla barra degli strumenti Documento

La barra degli strumenti Documento contiene i pulsanti che consentono di passare velocemente da una vista all'altra del documento. Questa barra degli strumenti contiene inoltre alcuni comandi e opzioni comuni relativi alla visualizzazione del documento e al suo trasferimento tra i siti locale e remoto.

Barra degli strumenti Documento (CC)
Barra degli strumenti Documento

Nella barra degli strumenti Documento sono visualizzate le seguenti opzioni:

Vista Codice

Mostra solo la vista Codice nella finestra del documento.

Vista combinata

Suddivide la finestra del documento fra le viste Codice e Dal vivo/Progettazione. L'opzione Vista Progettazione non è disponibile per i documenti a griglia fluida.

Vista Dal vivo

Si tratta di un'anteprima interattiva che riproduce accuratamente i progetti HTML5 e si aggiorna in tempo reale per visualizzare le modifiche apportate. Potete anche modificare gli elementi HTML nella vista Dal vivo. L'elenco a discesa accanto alle opzioni Dal vivo permette di alternare tra le viste Dal vivo e Progettazione. Questo elenco a discesa non è disponibile nei documenti a griglia fluida.

Vista Progettazione

Visualizza una rappresentazione del documento che mostra come l'utente lo vede in un browser Web. 

Panoramica sulla barra degli strumenti Standard

Barra degli strumenti Standard

Per visualizzare la barra degli strumenti Standard, selezionate Finestra > Barre degli strumenti > Standard. La barra degli strumenti contiene i pulsanti per le operazioni comuni da eseguire dai menu File e Modifica: Nuovo, Apri, Salva, Salva tutto, Stampa codice, Taglia, Copia, Incolla, Annulla e Ripeti.

Panoramica sulla barra degli strumenti Navigazione browser

La barra degli strumenti Navigazione browser si attiva nella vista Dal vivo (solo se è stata attivata selezionando Finestra->Barre degli strumenti->Standard) e mostra l'indirizzo della pagina che state visualizzando nella finestra Documento. La vista Dal vivo si comporta come un normale browser. Pertanto, anche se accedete a un sito che si trova all'esterno del vostro sito locale (ad esempio http://www.adobe.com/it), Dreamweaver carica la pagina nella finestra del documento.

Barra degli strumenti Navigazione browser (CC)
Barra degli strumenti Navigazione browser

A. Controlli del browser B. Casella dell'indirizzo 

Per impostazione predefinita, i collegamenti non sono attivi nella vista Dal vivo. Questo consente di selezionare o fare clic sul testo di un collegamento nella finestra del documento senza accedere automaticamente alla pagina di destinazione. Per verificare il corretto funzionamento dei collegamenti nella vista Dal vivo, potete attivarli uno alla volta oppure tutti insieme selezionando Visualizza > Opzioni vista Dal vivo > Segui collegamento (Ctrl+clic sul collegamento) o Segui collegamenti continuamente.

Panoramica sulla barra degli strumenti

La barra degli strumenti è visualizzata verticalmente sul lato sinistro della finestra del documento ed è visibile in tutte le viste: Codice, Dal vivo e Progettazione. I pulsanti della barra degli strumenti sono specifici alla vista e sono visualizzati solo se sono pertinenti alla vista in cui state lavorando. Ad esempio, se state lavorando nella vista Dal vivo, le opzioni specifiche alla vista Codice quali Formatta codice di origine, non sono visualizzate. 

Personalizza barra strumenti

Potete scegliere di personalizzare la barra degli strumenti secondo necessità aggiungendovi opzioni di menu o rimuovendovi quelle non desiderate.

Per personalizzare la barra degli strumenti, effettuate le seguenti operazioni:

  1. Fate clic su  nella barra degli strumenti per aprire la finestra di dialogo Personalizza barra strumenti.

    Personalizzare le barre degli strumenti
    Personalizzare le barre degli strumenti

  2. Selezionate o deselezionate le opzioni di menu che desiderate avere nella barra degli strumenti, quindi fate clic su Fine per salvare la barra degli strumenti.

Per ripristinare i pulsanti predefiniti della barra degli strumenti, fate clic su Ripristina predefiniti nella finestra di dialogo Personalizza barra degli strumenti.

Panoramica sulla barra di stato

La barra di stato presente nella parte inferiore della finestra del documento fornisce informazioni supplementari sul documento in fase di creazione.

Barra di stato (CC)
Barra di stato

A. Selettore di tag B. Pannello Output C. Colorazione codice D. Alternare inserimento e sovrascrittura E. Numero di riga e colonna 

Selettore di tag

Visualizza la gerarchia dei tag che contengono la selezione corrente. Fate clic su qualsiasi tag nella gerarchia per selezionare il tag specifico e il relativo contenuto. Fate clic su <body> per selezionare tutto il corpo del documento. Per selezionare gli attributi class o ID di un tag nel selettore di tag, fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul tag e selezionate una classe o un ID dal menu di scelta rapida.

Pannello Output

Fate clic su questa icona per visualizzare il pannello Output, che mostra gli errori di codifica presenti nel documento.

Colorazione codice

(Disponibile solo nella vista Codice)

Selezionate uno dei linguaggi di codifica da questo menu a comparsa per cambiare la colorazione del codice da visualizzare in base al linguaggio di programmazione.

Alternare inserimento e sovrascrittura

(Disponibile solo nella vista Codice)

Consente di alternare tra le modalità di inserimento e sovrascrittura durante la scrittura nella vista Codice.

Numero di riga e colonna

(Disponibile solo nella vista Codice)

Visualizza il numero di riga e di colonna in cui si trova il cursore.

Panoramica sulla finestra di ispezione Proprietà

La finestra di ispezione Proprietà (Finestra > Proprietà) consente di verificare e modificare le proprietà più comuni dell'elemento di pagina (oggetto inserito o testo) attualmente selezionato.

Il contenuto della finestra di ispezione Proprietà varia a seconda dell'elemento selezionato. Ad esempio, se selezionate un'immagine nella pagina, la finestra di ispezione Proprietà si modifica per visualizzare le proprietà dell'immagine (ad esempio il percorso del file relativo, la larghezza e l'altezza dell'immagine, il bordo intorno all'immagine, se disponibile, e così via).

Finestra di ispezione Proprietà (CC)
Finestra di ispezione Proprietà

Per impostazione predefinita, la finestra di ispezione Proprietà è posizionata nella parte inferiore dell'area di lavoro, ma potete sganciarla e utilizzarla come pannello mobile nell'area di lavoro.

Nota:

Usate la finestra di ispezione Tag per visualizzare e modificare gli attributi associati a una determinata proprietà di tag.

Per accedere alla Guida di una particolare finestra di ispezione Proprietà, fate clic sul pulsante Aiuto nell'angolo superiore destro della finestra, oppure selezionate Aiuto dal menu Opzioni della finestra.

Visualizzare e modificare le proprietà di un elemento pagina

  1. Selezionate l'elemento di pagina nella finestra del documento.

    Potrebbe essere necessario espandere la finestra di ispezione Proprietà per visualizzare tutte le proprietà dell'elemento selezionato.

  2. Modificate le proprietà desiderate nella finestra di ispezione Proprietà.

    Nota:

    Per ottenere informazioni su proprietà specifiche, selezionate un elemento nella finestra del documento e fate clic sull'icona della Guida nell'angolo superiore destro della finestra di ispezione Proprietà.

  3. Se le modifiche non vengono applicate immediatamente nella finestra del documento, applicatele effettuando una delle operazioni seguenti:

    • Fate clic all'esterno dei campi di modifica testo della proprietà.
    • Premete Invio.
    • Premete Tab per passare a un'altra proprietà.

I menu di scelta rapida garantiscono l'accesso rapido ai principali comandi e proprietà dell'oggetto o della finestra con cui si sta lavorando. I menu di scelta rapida contengono solo i comandi pertinenti alla selezione corrente.

Per aprire un menu di scelta rapida, fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto Ctrl (Mac) su una sezione di codice nella vista Codice oppure su un oggetto nelle viste Progettazione o Dal vivo.

Modifica della disposizione dei pannelli di Dreamweaver

Potete personalizzare il posizionamento e l'aspetto di tutti i pannelli di Dreamweaver in base alle vostre esigenze.

Ancorare e disancorare i pannelli

  • Per ancorare un pannello, trascinatelo dalla linguetta nell'ancoraggio, in alto, in basso o in mezzo ad altri pannelli.
  • Per ancorare un gruppo di pannelli, trascinatelo dalla barra del titolo (quella vuota sopra le linguette) nell'ancoraggio.
  • Per rimuovere un pannello o un gruppo di pannelli, trascinatelo fuori dell’ancoraggio puntando il mouse sulla sua linguetta o barra del titolo. Potete trascinarlo in un altro ancoraggio o lasciarlo mobile.

Spostare i pannelli

Quando spostate i pannelli, vengono evidenziate le zone di rilascio blu in cui è possibile spostare il pannello. Ad esempio, potete spostare un pannello in alto o in basso in un ancoraggio trascinandolo nella zona di rilascio stretta e blu che si trova sopra o sotto un altro pannello. Se lo trascinate in un’area che non è una zona di rilascio, il pannello resta mobile nell’area di lavoro.

  • Per spostare un pannello, trascinatelo dalla linguetta.
  • Per spostare un gruppo di pannelli, trascinatene la barra del titolo.

Nota:

Tenete premuto Ctrl (Windows) o Comando (Mac OS) mentre spostate un pannello per evitare che venga ancorato. Premete Esc mentre spostate il pannello per annullare l’operazione.

Aggiungere e rimuovere i pannelli

Se rimuovete tutti i pannelli da un’area di ancoraggio, questa scompare. Per creare un’area di ancoraggio, portate i pannelli fino al bordo destro dell’area di lavoro, fino a visualizzare una zona di rilascio.

  • Per rimuovere un pannello, fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Control (Mac OS) sulla sua linguetta e selezionate Chiudi; in alternativa, deselezionatelo nel menu Finestra.
  • Per aggiungere un pannello, selezionatelo dal menu Finestra e ancoratelo dove desiderate.

Modificare i gruppi di pannelli

  • Per spostare un pannello e inserirlo in un gruppo, trascinatene la linguetta fino alla zona di rilascio evidenziata nel gruppo.
  • Per ridisporre i pannelli in un gruppo, trascinate la linguetta di un pannello fino alla nuova posizione desiderata all’interno del gruppo.
  • Per rimuovere un pannello da un gruppo, così da renderlo mobile, trascinatelo dalla linguetta all'esterno del gruppo.
  • Per spostare un gruppo, trascinatene la barra del titolo (l'area sopra le linguette).

Impilare i pannelli mobili

Se trascinate un pannello fino a un’area che non è una zona di rilascio, il pannello resta mobile nell’area di lavoro. Un pannello mobile può essere posizionato ovunque nell’area di lavoro. Potete impilare pannelli mobili o gruppi di pannelli in modo che si muovano come una singola unità se trascinate la barra del titolo superiore.

  • Per impilare i pannelli mobili, trascinate un pannello dalla linguetta fino alla zona di rilascio nella parte inferiore di un altro pannello.
  • Per cambiare l'ordine di sovrapposizione, trascinate un pannello in alto o in basso dalla linguetta.
  • Per rimuovere un pannello o un gruppo di pannelli dall'impilatura, in modo che diventi mobile, trascinatelo fuori dalla la linguetta o dalla barra del titolo.

Ridimensionare i pannelli

  • Per ridurre o espandere un pannello, gruppo di pannelli o una pila di pannelli mobili, fate doppio clic su una scheda. In alternativa, fate doppio clic sull’area delle linguette (nello spazio vuoto accanto alle linguette).
  • Per ridimensionare un pannello, trascinatene un bordo. 

Ridurre a icona ed espandere i pannelli

Per limitare il numero di elementi visualizzati nell’area di lavoro, conviene ridurre i pannelli a icona. In alcuni casi i pannelli sono ridotti a icona nell’area di lavoro predefinita.

  • Per ridurre a icona o espandere tutti i pannelli di una colonna, fate clic sulla doppia freccia nella parte superiore dell’ancoraggio.
  • Fate clic sull'icona di un singolo pannello per espanderlo.
  • Per ridimensionare le icone dei pannelli in modo da visualizzare solo le icone (senza etichette di testo), regolate la larghezza dell’ancoraggio fino a far scomparire il testo. Per visualizzare nuovamente il testo delle icone, allargate l’ancoraggio.
  • Per ridurre di nuovo a icona un pannello espanso, fate clic sulla linguetta, sull'icona o sulla doppia freccia nella barra del titolo del pannello.

Creare aree di lavoro personalizzate

Potete personalizzare l'area di lavoro aggiungendo o rimuovendo i pannelli in base alle vostre esigenze. Potete quindi salvare le modifiche apportate all'area di lavoro salvandola per accedervi in seguito dal commutatore dell'area di lavoro nella barra degli strumenti del documento.

Salvate le dimensioni attuali e la disposizione dei pannelli assegnando un nome all’area di lavoro, così da ripristinarla anche se spostate o chiudete un pannello.

Per salvare un'area di lavoro personalizzata:

  1. Scegliete Finestra > Layout area di lavoro > Nuova area di lavoro.
  2. Immettete un nome per l'area di lavoro.

L'area di lavoro viene salvata e sarà visibile nel commutatore dell'area di lavoro nella barra degli strumenti del documento.

Per eliminare un'area di lavoro personalizzata:

Selezionate Gestisci area di lavoro dal commutatore dell'area di lavoro nella barra dell'applicazione per aprire la finestra di dialogo Gestisci aree di lavoro. Selezionate l'area di lavoro e fate clic su Elimina.

Visualizzare o cambiare area di lavoro

Selezionate un’area di lavoro dal controllo per l’impostazione dell’area di lavoro, nella barra degli strumenti del documento.

Personalizzare Dreamweaver in sistemi multiutente

Potete personalizzare Dreamweaver in base alle vostre necessità anche in un sistema operativo multiutente quale Windows XP o Mac OS X.

Dreamweaver non altera le configurazioni personalizzate dei singoli utenti. Per raggiungere questo obiettivo, la prima volta che Dreamweaver viene eseguito su uno dei sistemi operativi multiutente che è in grado di riconoscere, viene creata la copia di alcuni file di configurazione. Questi file di configurazione utente vengono memorizzati in una cartella che appartiene a un utente.

Se reinstallate o aggiornate Dreamweaver, Dreamweaver esegue automaticamente la copia di backup dei file di configurazione utente esistenti; pertanto, se avete personalizzato tali file manualmente, potete sempre accedere alle modifiche apportate.

Visualizzazione di documenti a schede (solo Mac)

Potete visualizzare più documenti in un'unica finestra del documento mediante schede che identificano ogni documento. Potete inoltre visualizzarli all'interno di un'area di lavoro mobile, in cui ogni documento viene visualizzato in una finestra propria.

Aprire un documento a schede in una finestra distinta

Tenete premuto il tasto Ctrl mentre fate clic sulla scheda e selezionate Sposta nella nuova finestra dal menu di scelta rapida.

Modificare l'impostazione predefinita per i documenti a schede

  1. Selezionate Dreamweaver > Preferenze, quindi selezionate la categoria Generali.
  2. Selezionate o deselezionate Apri documenti in schede, quindi fate clic su OK.

Quando modificate le preferenze, la visualizzazione dei documenti già aperti rimane inalterata, I documenti aperti dopo che è stata selezionata una nuova preferenza vengono tuttavia visualizzati in base alla preferenza selezionata.

La schermata di benvenuto viene visualizzata all'avvio di Dreamweaver e quando non ci sono documenti aperti. Potete scegliere di nascondere la schermata di benvenuto e di visualizzarla, se necessario, in seguito. Quando la schermata di benvenuto è nascosta e non vi sono documenti aperti, viene visualizzata la finestra del documento vuota.

Pannelli comuni di Dreamweaver

In Dreamweaver sono disponibili diversi pannelli. Alcuni dei pannelli utilizzati con maggior frequenza sono descritti di seguito.

Panoramica sul pannello Inserisci

Il pannello Inserisci (Finestra > Inserisci) contiene una serie di pulsanti che consentono di creare e inserire oggetti, quali le tabelle, le immagini e i collegamenti. I pulsanti sono organizzati in diverse categorie, che potete alternare selezionando la categoria desiderata dall'elenco a discesa in alto.

Pannello Inserisci
Pannello Inserisci

Alcune categorie dispongono di pulsanti con menu a comparsa. Quando selezionate un'opzione da un menu a comparsa, l'opzione diventa l'azione predefinita del pulsante. Se, ad esempio, selezionate Interruzione riga dal menu a comparsa del pulsante Carattere, la volta successiva che fate clic sul pulsante Carattere, Dreamweaver inserisce un'interruzione di riga. Ogni volta che selezionate una nuova opzione dal menu a comparsa, l'azione predefinita del pulsante cambia.

Il pannello Inserisci è organizzato nelle categorie seguenti:

HTML

Consente di creare e inserire gli elementi HTML utilizzati più comunemente, come i tag div e oggetti quali immagini e tabelle.

Modulo

Contiene i pulsanti per la creazione e l'inserimento di elementi modulo, ad esempio ricerca, mese e password.

Modelli

Consente di salvare il documento come modello e contrassegnare aree specifiche come modificabili, opzionali, ripetute o opzionali modificabili.

Componenti Bootstrap

Contiene i componenti Bootstrap per fornire navigazione, contenitori, menu a discesa e altro da utilizzare nei progetti reattivi.

jQuery Mobile

Contiene i pulsanti per realizzare siti che utilizzano jQuery Mobile.

Interfaccia utente jQuery

Consente di inserire elementi di interfaccia jQuery quali pannelli a soffietto, cursori e pulsanti.

Preferiti

Consente di raggruppare e organizzare i pulsanti del pannello Inserisci più utilizzati in un'unica area.

Nota:

 Durante le operazioni su taluni tipi di file, ad esempio XML, JavaScript, Java e CSS, il pannello Inserisci e l'opzione Vista Progettazione risultano inattive, poiché non è possibile inserire elementi in questi file di codice.

Inserisci oggetto

Per inserire un oggetto utilizzando il pannello Inserisci:

  1. Selezionate la categoria appropriata dal menu a comparsa Categoria del pannello Inserisci.

  2. Effettuate una delle operazioni seguenti:

    • Fate clic su un pulsante di oggetto o trascinate l'icona del pulsante nella finestra del documento (nella vista Progettazione, Dal vivo o Codice).

    • Fate clic sulla freccia su un pulsante e selezionate un'opzione dal menu.

      A seconda dell'oggetto, può essere visualizzata una specifica finestra di dialogo che richiede la selezione di un file o l'inserimento dei parametri dell'oggetto. È anche possibile che Dreamweaver inserisca il codice nel documento o apra un editor di tag o un pannello in cui inserire informazioni specifiche prima dell'inserimento del codice.

      Per determinati oggetti inseriti in vista Progettazione, non viene visualizzata alcuna finestra di dialogo, ma se l'oggetto viene inserito in vista Codice, viene visualizzato un editor di tag. Quando alcuni oggetti particolari vengono inseriti in vista Progettazione, Dreamweaver passa alla vista Codice prima di inserire l'oggetto.

Modificare le preferenze del pannello Inserisci

  1. Selezionate Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Macintosh).

  2. Nella categoria Generali della finestra di dialogo Preferenze, deselezionate l'opzione Mostra finestra di dialogo per inserimento oggetti per sopprimere le finestre di dialogo quando inserite oggetti, quali le immagini, le tabelle, gli script e gli elementi HEAD, oppure per evitare di dover premere il tasto Ctrl (Windows) o Opzione (Macintosh) durante la creazione di un oggetto.

Nota:

Quando questa opzione è disattivata, per gli oggetti inseriti vengono utilizzati gli attributi predefiniti. Dopo aver inserito un oggetto, utilizzate la finestra di ispezione Proprietà per modificarne le proprietà.

Aggiungere, eliminare o gestire gli elementi nella categoria Preferiti del pannello Inserisci

  1. Selezionate una categoria qualsiasi nel pannello Inserisci.

  2. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) nell'area in cui è visualizzato il pulsante, quindi selezionate Personalizza oggetti preferiti.

  3. Nella finestra di dialogo Personalizza oggetti preferiti, apportate le modifiche desiderate, quindi fate clic su OK.

    Per aggiungere un oggetto, selezionatene uno nel riquadro Oggetti disponibili sulla sinistra, quindi fate clic sulla freccia tra i due riquadri; in alternativa, fate doppio clic sull'oggetto nel riquadro Oggetti disponibili.

    Personalizzare i preferiti nel pannello Inserisci
    Personalizzare i preferiti nel pannello Inserisci

    Nota:

    Potete aggiungere un oggetto per volta. Non è possibile selezionare un nome di categoria, ad esempio Comune, per aggiungere un'intera categoria all'elenco Preferiti.

    • Per eliminare un oggetto o un separatore, selezionate un oggetto nel riquadro Oggetti preferiti sulla destra, quindi fate clic sul pulsante Elimina oggetto selezionato dall'elenco Oggetti preferiti sopra il riquadro.
    • Per spostare un oggetto, selezionate un oggetto nel riquadro Oggetti preferiti sulla destra e fate clic sui pulsanti freccia su o freccia giù sopra il riquadro.
    • Per aggiungere un separatore sotto un oggetto, selezionate l'oggetto nel riquadro Oggetti preferiti sulla destra, quindi fate clic sul pulsante Aggiungi separatore sotto il riquadro.
  4. Se la selezione attiva nel pannello Inserisci non è la categoria Preferiti, selezionate la categoria per vedere le modifiche.

Panoramica sul pannello File

Utilizzate il pannello File per visualizzare e gestire i file nel vostro sito Dreamweaver.

Potete utilizzare il pannello File per visualizzare file e cartelle, verificare se sono associati o meno a un sito di Dreamweaver ed eseguire operazioni standard di gestione dei file quali l'apertura e lo spostamento di file.

Il pannello File semplifica inoltre la gestione e il trasferimento di file da/a un server remoto. 

Pannello File
Pannello File

Per ulteriori informazioni su tutte le operazione che possono essere eseguite con il pannello File, consultate Gestire file e cartelle.

CSS Designer

Il pannello CSS Designer (Finestra > CSS Designer) è una finestra di ispezione Proprietà per CSS che consente di creare “visivamente” stili e file CSS e di impostarne le proprietà, nonché di definire media query.

Potete usare la combinazione di tasti Ctrl/Cmd + Z per annullare o Ctrl/Cmd + Y per ripetere tutte le azioni eseguite in CSS Designer. Le modifiche vengono riportate automaticamente nella vista Dal vivo e anche il file CSS corrispondente viene aggiornato. Per segnalare che il file correlato è stato modificato, la scheda del file interessato viene evidenziata per qualche istante (circa 8 secondi).

Pannello CSS Designer (CC)
Pannello CSS Designer

Il pannello CSS Designer è costituito dai seguenti riquadri e opzioni:

Tutto Elenca tutto il codice CSS, le media query e i selettori associati al documento corrente. Potete filtrare per le regole CSS richieste e modificare le proprietà. Potete anche utilizzare questa modalità per iniziare a creare selettori o media query.

Questa modalità non distingue la selezione. Questo significa che, quando selezionate un elemento nella pagina, il selettore, la media query o il codice CSS associato non è evidenziato in CSS Designer.

Corrente Elenca tutti gli stili calcolati per qualsiasi elemento selezionato nella vista Progettazione o Dal vivo del documento corrente. Quando utilizzate questa modalità per un file CSS nella vista Codice, tutte le proprietà del selettore attivo sono visualizzate.

Questa modalità è sensibile al contesto. Utilizzate questa opzione per modificare le proprietà dei selettori associati con gli elementi selezionati nel documento.

Origini Elenca tutti i fogli di stile CSS associati al documento. Utilizzando questo pannello, potete creare e associare un CSS al documento, oppure definire stili nel documento.

@Oggetto multimediale Elenca tutte le media query presenti nell'origine selezionata nel riquadro Origini. Se non selezionate un CSS specifico, nel riquadro sono elencate tutte le media query associate al documento.

Selettori Elenca tutti i selettori presenti nell'origine selezionata nel riquadro Origini. Se selezionate anche una media query, il riquadro limita l'elenco dei selettori alla media query selezionata. Se non selezionate né un CSS né una media query, il riquadro visualizza tutti i selettori del documento.

Quando selezionate Globale nel riquadro @Oggetto multimediale, vengono visualizzati tutti i selettori che non sono inclusi in una media query dell'origine selezionata.

Proprietà Visualizza le proprietà che potete impostare per il selettore specificato. Per ulteriori informazioni, consultate Impostare le proprietà.

Se comprimete o espandete i riquadri in CSS Designer, le dimensioni dei riquadri vengono memorizzate all'interno di una sessione. I riquadri Origini e Oggetto multimediale si attengono alle dimensioni personalizzate finché queste non vengono nuovamente modificate.

Nota: quando selezionate un elemento di pagina, il selettore più specifico viene selezionato nel riquadro Selettori. Per visualizzare le proprietà di un determinato selettore, fate clic sul suo nome nel riquadro.

Per visualizzare tutti i selettori, potete scegliere Tutte le origini nel riquadro Origini. Per visualizzare i selettori dell'origine selezionata che non appartengono a nessuna media query, fate clic su Globale nel riquadro @Oggetto multimediale.

Panoramica sui riferimenti visivi

Dreamweaver fornisce diversi tipi di riferimenti visivi utili per la progettazione dei documenti e per la previsione approssimativa del loro aspetto nei browser. Potete:

  • Bloccare istantaneamente la finestra del documento su una dimensione desiderata per verificare la collocazione dei vari elementi rispetto alla pagina.

  • Utilizzare un'immagine di ricalco come sfondo della pagina per riprodurre una struttura creata in un'applicazione grafica come Adobe® Photoshop® o Adobe® Fireworks®.

  • Utilizzare i righelli e le guide come riferimento visivo per posizionare e ridimensionare con precisione gli elementi di pagina.

  • Utilizzare la griglia per posizionare e ridimensionare con precisione gli elementi con posizione assoluta (elementi PA).

    Le linee che compongono la griglia facilitano l'allineamento degli elementi PA; inoltre, se la funzione di aggancio è attivata, gli elementi PA vengono automaticamente agganciati al punto più vicino della griglia quando vengono spostati o ridimensionati. Gli altri oggetti (ad esempio, le immagini e i paragrafi) non vengono agganciati alla griglia, I livelli vengono agganciati alla griglia indipendentemente dal fatto che questa sia visualizzata o nascosta.

Ingrandire e ridurre una pagina

Con Dreamweaver potete ingrandire un documento (aumentarne il livello di zoom) in modo da poter verificare la precisione dei pixel di un'immagine, selezionare più facilmente elementi di piccole dimensioni, realizzare pagine con testo piccolo o pagine di grandi dimensioni e così via.

Per ingrandire o ridurre una pagina, selezionate Visualizza > Opzioni vista Progettazione > Ingrandimento e scegliete una delle opzioni di ingrandimento disponibili.

Potete scegliere tra diverse opzioni di ingrandimento. Potete scegliere:

  • Adatta selezione: selezionate un oggetto o del testo, quindi scegliete questa opzione per riempire la finestra del documento con la selezione.
  • Adatta tutto: riempie la finestra del documento con un'intera pagina.
  • Adatta larghezza: riempie la finestra del documento con la larghezza completa di una pagina.

Nota:

Potete inoltre ingrandire le dimensioni senza utilizzare lo strumento Zoom premendo Control+= (Windows) o Comando+= (Macintosh). Potete inoltre ridurre le dimensioni senza utilizzare lo strumento Zoom premendo Control+- (Windows) o Comando+- (Macintosh).

Impostare le preferenze generali di Dreamweaver

  1. Selezionate Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Macintosh).

  2. Impostate le opzioni desiderate tra le seguenti:

    Apri documenti in schede Apre tutti i documenti in un'unica finestra a schede, con la possibilità di passare da un documento all'altro (solo Mac).

    Mostra schermata iniziale Visualizza la finestra di benvenuto di Dreamweaver all'avvio di Dreamweaver o quando non ci sono documenti aperti.

    Riapri documenti all'avvio Apre tutti i documenti che erano aperti quando si è chiuso Dreamweaver. Se questa opzione non è selezionata, all'avvio Dreamweaver visualizza la schermata di benvenuto oppure una schermata vuota, a seconda dell'impostazione di Mostra schermata di benvenuto.

    Segnala apertura file di sola lettura Visualizza un avvertimento quando si apre un file di sola lettura (protetto). Scegliete se sbloccare/ritirare il file, visualizzare il file o annullare l'operazione.

    Attiva file correlati Consente di individuare quali file sono collegati al documento corrente (ad esempio, i file CSS o JavaScript). Dreamweaver visualizza un pulsante per ogni file correlato nella parte superiore del documento e apre il file se fate clic su tale pulsante.

    Individua file correlati dinamicamente Consente di specificare se i file correlati dinamicamente appaiono automaticamente nella barra degli strumenti File correlati o solo in seguito a un'interazione manuale. Potete anche scegliere di disattivare l'individuazione dei file correlati dinamicamente.

    Aggiorna collegamento durante lo spostamento dei file Determina l'azione che viene eseguita quando spostate, rinominate o eliminate un documento all'interno del sito. Impostate questa preferenza in modo che aggiorni sempre i collegamenti automaticamente, non li aggiorni mai o che visualizzi una richiesta di conferma per l'aggiornamento. (Consultate Aggiornare automaticamente i collegamenti).

    Mostra finestra di dialogo per inserimento oggetti Determina se Dreamweaver deve chiedere informazioni aggiuntive quando inserite immagini, tabelle, filmati Shockwave e altri oggetti utilizzando il pannello Inserisci o il menu Inserisci. Se questa opzione non è selezionata, non viene visualizzata alcuna finestra di dialogo e dovete utilizzare la finestra di ispezione Proprietà per specificare il file di origine dell'immagine, il numero di righe della tabella e così via. Per le immagini di rollover e i file HTML di Fireworks, viene sempre visualizzata una finestra di dialogo quando inserite l'oggetto, indipendentemente dall'impostazione di questa opzione. Per ignorare temporaneamente questa impostazione, fate clic tenendo premuto il tasto Ctrl (Windows) o Comando (Macintosh) quando create o inserite un oggetto.

    Abilita input DBCS in linea Consente di inserire caratteri a doppio byte direttamente nella finestra del documento se utilizzate un ambiente di sviluppo o un kit linguistico che supporta il testo a doppio byte (ad esempio, i caratteri giapponesi). Se questa opzione non è selezionata, viene visualizzata una finestra che consente di inserire e convertire il testo; una volta accettato, il testo viene visualizzato nella finestra del documento.

    Passa a paragrafo normale dopo l'intestazione Indica che quando si preme Invio (Windows o Macintosh) alla fine di un paragrafo di intestazione in vista Progettazione o Dal vivo viene creato un nuovo paragrafo che ha il tag p. (Il paragrafo di intestazione ha un tag di intestazione come h1 o h2.) Quando questa opzione non è selezionata, la pressione del tasto Invio alla fine di un paragrafo di intestazione determina la creazione di un nuovo paragrafo con lo stesso tag; potete così inserire più intestazioni di seguito, quindi tornare indietro e inserire ulteriori dettagli.

    Consenti spazi consecutivi multipli Indica che inserendo due o più spazi in vista Progettazione o Dal vivo vengono creati spazi unificatori che nel browser vengono visualizzati come spazi multipli. Ad esempio, potete inserire due spazi tra due frasi, come fareste su una macchina da scrivere. Questa opzione è destinata principalmente alle persone abituate a inserire testo nei programmi di elaborazione di testo. Quando questa opzione non è selezionata, gli spazi multipli vengono considerati come un solo spazio, come normalmente accade nei browser.

    Usa <strong> e <em> invece di <b> e <i> Specifica che Dreamweaver applica il tag strong ogni volta che si effettua un'azione che normalmente comporterebbe l'uso del tag b, e applica il tag em ogni volta che si effettua un'azione che normalmente comporterebbe l'uso del tag i. Tali azioni includono la selezione dei tasti del grassetto o del corsivo nella finestra di ispezione Proprietà in modalità HTML e la selezione di Formato > Stile > Grassetto oppure Formato > Stile > Corsivo. Per usare i tag b e i nei documenti, deselezionate questa opzione.

    Nota: il World Wide Web Consortium sconsiglia l'uso dei tag b e i; i tag strong e em forniscono maggiori informazioni semantiche dei tag b e i.

    Avvisa dell'inserimento di aree modificabili nei tag <p> o <h1> - <h6> Specifica se deve essere visualizzato un messaggio di avviso quando salvate un modello di Dreamweaver che contiene un'area modificabile all'interno di un tag di paragrafo o di intestazione. Il messaggio comunica che gli utenti non potranno creare altri paragrafi nell'area in questione. Per impostazione predefinita, è attivato.

    Limita azioni di annullamento al documento attivo Limita le azioni di annullamento al file che state modificando. Ad esempio, se state modificando un file CSS, potete solo annullare le modifiche effettuate al file CSS.

    Tuttavia, se questa casella di controllo è deselezionata, il codice HTML di origine e tutti i file CSS correlati utilizzano un’unica cronologia di annullamento, quindi potrete annullare le azioni sia che lavoriate sul codice HTML, che sui file CSS correlati.

    Numero massimo di passaggi di Cronologia Determina il numero di passaggi memorizzati da Dreamweaver. Il valore predefinito dovrebbe essere sufficiente per la maggior parte degli utenti. Se superate il numero impostato, i passaggi meno recenti vengono eliminati.

    Dizionario ortografico Elenca i dizionari disponibili. Le eventuali varianti previste per la stessa lingua (ad esempio inglese britannico e inglese americano) vengono elencate separatamente nel menu Dizionario.

Impostare le preferenze caratteri per i documenti in Dreamweaver

La codifica di un documento determina il modo in cui esso appare all'interno di un browser. Le preferenze di carattere di Dreamweaver permettono di vedere una determinata codifica nel carattere e nelle dimensioni preferite. Tuttavia, i caratteri selezionati nella finestra di dialogo Preferenze caratteri influiscono solo sul modo in cui i caratteri vengono visualizzati in Dreamweaver e non sull'aspetto del documento nel browser di un visitatore. Per modificare il modo in cui i caratteri vengono visualizzati in un browser, dovete modificare il testo nella finestra di ispezione Proprietà o applicare una regola CSS.

Per ulteriori informazioni sull'impostazione della codifica predefinita dei nuovi documenti, consultate Creazione e apertura dei documenti.

  1. Selezionate Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Mac).

  2. Selezionate Caratteri nell'elenco Categoria visualizzato sulla sinistra.

  3. Selezionate un tipo di codifica, ad esempio Occidentale o Giapponese, dal menu Impostazioni dei caratteri.

    Nota:

    Per poter visualizzare le lingue asiatiche dovete disporre di un sistema operativo che supporti i caratteri DBCS.

  4. Selezionate un carattere e una dimensione per ciascuna categoria della codifica selezionata.

    Nota:

    Questi menu elencano solo i caratteri installati sul sistema. Il testo giapponese, ad esempio, può essere visualizzato solo se sono stati installati i caratteri giapponesi.

    Carattere proporzionale

    È il carattere che viene utilizzato da Dreamweaver per visualizzare il testo normale, ad esempio il testo dei paragrafi, delle intestazioni e delle tabelle. L'impostazione predefinita dipende dai caratteri installati sul proprio sistema. L'impostazione predefinita in genere corrisponde a Times New Roman 12 pt (medio) in Windows e Times 12 pt in Mac OS.

    Carattere a larghezza fissa

    Il font utilizzato da Dreamweaver per visualizzare il testo compreso nei tag pre, code e tt. L'impostazione predefinita dipende dai caratteri installati sul proprio sistema. L'impostazione predefinita in genere corrisponde a Courier New 10 pt (piccolo) in Windows e Monaco 12 pt in Mac OS.

    Vista Codice

    È il carattere utilizzato per tutto il testo che appare nella vista Codice e nella finestra di ispezione Codice. L'impostazione predefinita dipende dai caratteri installati sul proprio sistema.

Personalizzare i colori di evidenziazione di Dreamweaver

Utilizzate le preferenze Evidenziazione per personalizzare i colori che identificano le regioni dei modelli, le voci di libreria, i tag di terze parti, gli elementi di layout e il codice in Dreamweaver.

  1. Selezionate Modifica > Preferenze e scegliete la categoria Evidenziazione.

  2. Accanto all'oggetto di cui volete cambiare il colore di evidenziazione, fate clic sulla casella colore e utilizzate il selettore colori per scegliere un nuovo colore, oppure inserite un valore esadecimale.

  3. Per attivare o disattivare l'evidenziazione di una determinata opzione, selezionate o deselezionate l'opzione Mostra.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online