Modificare l'area di lavoro Dreamweaver per soddisfare le vostre esigenze. Spostare, ridimensionare, ancorare, rendere mobili, comprimere o espandere finestre e pannelli.

Per personalizzare l’area di lavoro, potete spostare e manipolare le finestre di documento e i pannelli. Potete inoltre salvare aree di lavoro personalizzate e passare dall’una all’altra.

Ancorare e disancorare i pannelli

Per ancoraggio si intende un set di pannelli o gruppi di pannelli visualizzati insieme, generalmente con un orientamento verticale. Potete ancorare o disancorare i pannelli spostandoli all’interno o all’esterno dell’ancoraggio.

  • Per ancorare un pannello, trascinatelo dalla linguetta nell'ancoraggio, in alto, in basso o in mezzo ad altri pannelli.

  • Per ancorare un gruppo di pannelli, trascinatelo dalla barra del titolo (quella vuota sopra le linguette) nell'ancoraggio.

  • Per rimuovere un pannello o un gruppo di pannelli, trascinatelo fuori dell’ancoraggio puntando il mouse sulla sua linguetta o barra del titolo. Potete trascinarlo in un altro ancoraggio o lasciarlo mobile.

Spostare i pannelli

Quando spostate i pannelli, vengono evidenziate le zone di rilascio blu in cui è possibile spostare il pannello. Ad esempio, potete spostare un pannello in alto o in basso in un ancoraggio trascinandolo nella zona di rilascio stretta e blu che si trova sopra o sotto un altro pannello. Se lo trascinate in un’area che non è una zona di rilascio, il pannello resta mobile nell’area di lavoro.

Nota:

la posizione del mouse (anziché la posizione del pannello) attiva la zona di rilascio, pertanto se questa non è visibile, provate a trascinare il mouse nella posizione in cui questa dovrebbe trovarsi.

  • Per spostare un pannello, trascinatelo dalla linguetta.

  • Per spostare un gruppo di pannelli, trascinatene la barra del titolo.

Nota:

Tenete premuto Ctrl (Windows) o Comando (Mac OS) mentre spostate un pannello per evitare che venga ancorato. Premete Esc mentre spostate il pannello per annullare l’operazione.

Aggiungere e rimuovere i pannelli

Se rimuovete tutti i pannelli da un’area di ancoraggio, questa scompare. Per creare un’area di ancoraggio, portate i pannelli fino al bordo destro dell’area di lavoro, fino a visualizzare una zona di rilascio.

  • Per rimuovere un pannello, fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Control (Mac OS) sulla sua linguetta e selezionate Chiudi; in alternativa, deselezionatelo nel menu Finestra.

  • Per aggiungere un pannello, selezionatelo dal menu Finestra e ancoratelo dove desiderate.

Modificare i gruppi di pannelli

  • Per spostare un pannello e inserirlo in un gruppo, trascinatene la linguetta fino alla zona di rilascio evidenziata nel gruppo.

Aggiunta di un pannello a un gruppo di pannelli
Aggiunta di un pannello a un gruppo di pannelli

  • Per ridisporre i pannelli in un gruppo, trascinate la linguetta di un pannello fino alla nuova posizione desiderata all’interno del gruppo.

  • Per rimuovere un pannello da un gruppo, così da renderlo mobile, trascinatelo dalla linguetta all'esterno del gruppo.

  • Per spostare un gruppo, trascinatene la barra del titolo (l'area sopra le linguette).

Impilare i pannelli mobili

Se trascinate un pannello fino a un’area che non è una zona di rilascio, il pannello resta mobile nell’area di lavoro. Un pannello mobile può essere posizionato ovunque nell’area di lavoro. Potete impilare pannelli mobili o gruppi di pannelli in modo che si muovano come una singola unità se trascinate la barra del titolo superiore.

Pannelli mobili impilati
Pannelli mobili impilati

  • Per impilare i pannelli mobili, trascinate un pannello dalla linguetta fino alla zona di rilascio nella parte inferiore di un altro pannello.

  • Per cambiare l'ordine di sovrapposizione, trascinate un pannello in alto o in basso dalla linguetta.

Nota:

Rilasciate la linguetta sopra la zona di rilascio stretta che si trova tra i pannelli, invece che su quella più larga nella barra del titolo.

  • Per rimuovere un pannello o un gruppo di pannelli dall'impilatura, in modo che diventi mobile, trascinatelo fuori dalla la linguetta o dalla barra del titolo.

Ridimensionare i pannelli

  • Per ridurre o espandere un pannello, gruppo di pannelli o una pila di pannelli mobili, fate doppio clic su una scheda. In alternativa, fate doppio clic sull’area delle linguette (nello spazio vuoto accanto alle linguette).

  • Per ridimensionare un pannello, trascinatene un bordo. Alcuni pannelli, come il pannello Controllo di Photoshop, non possono essere ridimensionati mediante trascinamento.

Ridurre a icona ed espandere i pannelli

Per limitare il numero di elementi visualizzati nell’area di lavoro, conviene ridurre i pannelli a icona. In alcuni casi i pannelli sono ridotti a icona nell’area di lavoro predefinita.

Pannelli ridotti a icona
Pannelli ridotti a icona

Pannelli espansi
Pannelli espansi

  • Per ridurre a icona o espandere tutti i pannelli di una colonna, fate clic sulla doppia freccia nella parte superiore dell’ancoraggio.

  • Fate clic sull'icona di un singolo pannello per espanderlo.

  • Per ridimensionare le icone dei pannelli in modo da visualizzare solo le icone (senza etichette di testo), regolate la larghezza dell’ancoraggio fino a far scomparire il testo. Per visualizzare nuovamente il testo delle icone, allargate l’ancoraggio.

  • Per ridurre di nuovo a icona un pannello espanso, fate clic sulla linguetta, sull'icona o sulla doppia freccia nella barra del titolo del pannello.

Nota:

In alcuni prodotti, se selezionate Comprimi automaticamente pannelli a icone nelle preferenze Interfaccia o Opzioni interfaccia utente, l'icona di un pannello espanso si riduce automaticamente a icona quando fate clic lontano dall'icona.

  • Per aggiungere un pannello o un gruppo di pannelli mobili a un ancoraggio di icone, trascinatene la linguetta o la barra del titolo. I pannelli aggiunti a un ancoraggio di icone vengono ridotti automaticamente a icona.
  • Per spostare l’icona di un pannello (o un gruppo di icone di pannelli), trascinatela. Potete trascinare le icone dei pannelli in alto o in basso nell’ancoraggio, all’interno di altri ancoraggi (dove compaiono nello stile dei pannelli di quell’ancoraggio) o all’esterno dell’ancoraggio (dove compaiono come icone mobili).

Creare aree di lavoro personalizzate

Salvate le dimensioni attuali e la disposizione dei pannelli assegnando un nome all’area di lavoro, così da ripristinarla anche se spostate o chiudete un pannello. I nomi delle aree di lavoro salvate sono elencate nel controllo per l’impostazione dell’area di lavoro, nella barra degli strumenti del documento.

Per salvare un'area di lavoro personalizzata:

  1. Scegliete Finestra > Layout area di lavoro > Nuova area di lavoro.
  2. Immettete un nome per l'area di lavoro.
L'area di lavoro viene salvata e sarà visibile nel commutatore dell'area di lavoro nella barra degli strumenti del documento.

Per eliminare un'area di lavoro personalizzata:

Selezionate Gestisci area di lavoro dal commutatore dell'area di lavoro nella barra dell'applicazione per aprire la finestra di dialogo Gestisci aree di lavoro. Selezionate l'area di lavoro e fate clic su Elimina.

Visualizzare o cambiare area di lavoro

  1. Selezionate un’area di lavoro dal controllo per l’impostazione dell’area di lavoro, nella barra dell’applicazione.

Visualizzazione di documenti a schede (solo Mac)

Potete visualizzare più documenti in un'unica finestra del documento mediante schede che identificano ogni documento. Potete inoltre visualizzarli all'interno di un'area di lavoro mobile, in cui ogni documento viene visualizzato in una finestra propria.

Aprire un documento a schede in una finestra distinta

Tenete premuto il tasto Ctrl mentre fate clic sulla scheda e selezionate Sposta nella nuova finestra dal menu di scelta rapida.

Modificare l'impostazione predefinita per i documenti a schede

  1. Selezionate Dreamweaver > Preferenze, quindi selezionate la categoria Generali.
  2. Selezionate o deselezionate Apri documenti in schede, quindi fate clic su OK.

Quando modificate le preferenze, la visualizzazione dei documenti già aperti rimane inalterata, I documenti aperti dopo che è stata selezionata una nuova preferenza vengono tuttavia visualizzati in base alla preferenza selezionata.

La schermata di benvenuto viene visualizzata all'avvio di Dreamweaver e quando non ci sono documenti aperti. Potete scegliere di nascondere la schermata di benvenuto e di visualizzarla, se necessario, in seguito. Quando la schermata di benvenuto è nascosta e non vi sono documenti aperti, viene visualizzata la finestra del documento vuota.

Informazioni sulla personalizzazione di Dreamweaver in sistemi multiutente

Potete personalizzare Dreamweaver in base alle vostre necessità anche in un sistema operativo multiutente quale Windows XP o Mac OS X.

Dreamweaver non altera le configurazioni personalizzate dei singoli utenti. Per raggiungere questo obiettivo, la prima volta che Dreamweaver viene eseguito su uno dei sistemi operativi multiutente che è in grado di riconoscere, viene creata la copia di alcuni file di configurazione. Questi file di configurazione utente vengono memorizzati in una cartella che appartiene a un utente.

In Windows XP, ad esempio, sono archiviati nella cartella C:\Documents and Settings\nome utente\Dati applicazioni\Adobe\Dreamweaver\it_IT\Configuration, che è nascosta per impostazione predefinita. Per visualizzare file e cartelle nascosti, selezionate Strumenti > Opzioni cartella in Esplora risorse, fate clic sulla scheda Visualizzazione e selezionate l'opzione Visualizza cartelle e file nascosti.

In Windows Vista, sono archiviati nella cartella C:\Utenti\nome utente\AppData\Roaming\Adobe\Dreamweaver\it_IT\Configuration, che è nascosta per impostazione predefinita. Per visualizzare file e cartelle nascosti, selezionate Strumenti > Opzioni cartella in Esplora risorse, fate clic sulla scheda Visualizzazione e selezionate l'opzione Visualizza cartelle e file nascosti.

In Mac OS X, sono archiviati nella cartella principale; in particolare, in Utenti/nome utente/Libreria/Application Support/Adobe/Dreamweaver/Configuration.

Se reinstallate o aggiornate Dreamweaver, Dreamweaver esegue automaticamente la copia di backup dei file di configurazione utente esistenti; pertanto, se avete personalizzato tali file manualmente, potete sempre accedere alle modifiche apportate.

Impostare le preferenze generali di Dreamweaver

  1. Selezionate Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Macintosh).
  2. Impostate le opzioni desiderate tra le seguenti:

    Apri documenti in schede

    Apre tutti i documenti in un'unica finestra a schede, con la possibilità di passare da un documento all'altro (solo Macintosh).

    Mostra schermata di benvenuto

    Visualizza la finestra di benvenuto di Dreamweaver all'avvio di Dreamweaver o quando non ci sono documenti aperti.

    Riapri documenti all'avvio

    Apre tutti i documenti che erano aperti quando si è chiuso Dreamweaver. Se questa opzione non è selezionata, all'avvio Dreamweaver visualizza la schermata di benvenuto oppure una schermata vuota, a seconda dell'impostazione di Mostra schermata di benvenuto.

    Segnala apertura file di sola lettura

    Visualizza un avvertimento quando si apre un file di sola lettura (protetto). Scegliete se sbloccare/ritirare il file, visualizzare il file o annullare l'operazione.

    Attiva file correlati

    Consente di individuare quali file sono collegati al documento corrente (ad esempio, i file CSS o JavaScript). Dreamweaver visualizza un pulsante per ogni file correlato nella parte superiore del documento e apre il file se fate clic su tale pulsante.

    Individuare i file correlati dinamicamente

    Consente di specificare se i file correlati dinamicamente appaiono automaticamente nella barra degli strumenti File correlati o solo in seguito a un'interazione manuale. Potete anche scegliere di disattivare l'individuazione dei file correlati dinamicamente.

    Aggiorna collegamento durante lo spostamento dei file

    Determina l'azione che viene eseguita quando spostate, rinominate o eliminate un documento all'interno del sito. Impostate questa preferenza in modo che aggiorni sempre i collegamenti automaticamente, non li aggiorni mai o che visualizzi una richiesta di conferma per l'aggiornamento. (Vedete Aggiornamento automatico dei collegamenti.)

    Mostra finestra di dialogo per inserimento oggetti

    Determina se Dreamweaver deve chiedere informazioni aggiuntive quando inserite immagini, tabelle, filmati Shockwave e altri oggetti utilizzando il pannello Inserisci o il menu Inserisci. Se questa opzione non è selezionata, non viene visualizzata alcuna finestra di dialogo e dovete utilizzare la finestra di ispezione Proprietà per specificare il file di origine dell'immagine, il numero di righe della tabella e così via. Per le immagini di rollover e i file HTML di Fireworks, viene sempre visualizzata una finestra di dialogo quando inserite l'oggetto, indipendentemente dall'impostazione di questa opzione. Per ignorare temporaneamente questa impostazione, fate clic tenendo premuto il tasto Ctrl (Windows) o Comando (Macintosh) quando create o inserite un oggetto.

    Abilita input DBCS in linea

    Consente di inserire caratteri a doppio byte direttamente nella finestra del documento se utilizzate un ambiente di sviluppo o un kit linguistico che supporta il testo a doppio byte (ad esempio, i caratteri giapponesi). Se questa opzione non è selezionata, viene visualizzata una finestra che consente di inserire e convertire il testo; una volta accettato, il testo viene visualizzato nella finestra del documento.

    Passa a paragrafo normale dopo l'intestazione

    Indica che quando si preme Invio (Windows o Macintosh) alla fine di un paragrafo di intestazione in vista Progettazione o Dal vivo viene creato un nuovo paragrafo che ha il tag p. (Il paragrafo di intestazione ha un tag di intestazione come h1 o h2.) Quando questa opzione non è selezionata, la pressione del tasto Invio alla fine di un paragrafo di intestazione determina la creazione di un nuovo paragrafo con lo stesso tag; potete così inserire più intestazioni di seguito, quindi tornare indietro e inserire ulteriori dettagli.

    Consenti spazi consecutivi multipli

    Indica che inserendo due o più spazi in vista Progettazione o Dal vivo vengono creati spazi unificatori che nel browser vengono visualizzati come spazi multipli. Ad esempio, potete inserire due spazi tra due frasi, come fareste su una macchina da scrivere. Questa opzione è destinata principalmente alle persone abituate a inserire testo nei programmi di elaborazione di testo. Quando questa opzione non è selezionata, gli spazi multipli vengono considerati come un solo spazio, come normalmente accade nei browser.

    Usa <strong> e <em> invece di <b> e <i>

    Specifica che Dreamweaver applica il tag strong ogni volta che si effettua un'azione che normalmente comporterebbe l'uso del tag b, e applica il tag em ogni volta che si effettua un'azione che normalmente comporterebbe l'uso del tag i. Tali azioni includono la selezione dei tasti del grassetto o del corsivo nella finestra di ispezione Proprietà in modalità HTML e la selezione di Formato > Stile > Grassetto oppure Formato > Stile > Corsivo. Per usare i tag b e i nei documenti, deselezionate questa opzione.

    Nota:

    il World Wide Web Consortium sconsiglia l'uso dei tag b e i; i tag strong e em forniscono maggiori informazioni semantiche dei tag b e i.

    Avvisa dell'inserimento di aree modificabili nei tag <p> o <h1> - <h6>

    Specifica se deve essere visualizzato un messaggio di avviso quando salvate un modello di Dreamweaver che contiene un'area modificabile all'interno di un tag di paragrafo o di intestazione. Il messaggio comunica che gli utenti non potranno creare altri paragrafi nell'area in questione. Per impostazione predefinita, è attivato.

    Centratura

    Specifica se gli elementi devono essere centrati utilizzando il tag divalign="center" o il tag center quando si fa clic sul pulsante Allinea al centro nella finestra di ispezione Proprietà.

    Nota:

    entrambi gli approcci di centratura sono stati dichiarati ufficialmente obsoleti in base alla specifica HTML 4.01; per centrare il testo è necessario utilizzare gli stili CSS. Tutti e due gli approcci sono ancora validi tecnicamente in base alla specifica XHTML 1.0 transitoria, ma non sono più validi nella rigida specifica XHTML 1.0.

    Numero massimo di passaggi di Cronologia

    Determina il numero di passaggi memorizzati e visualizzati dal pannello Cronologia. Il valore predefinito dovrebbe essere sufficiente per la maggior parte degli utenti. Se superate il numero impostato, i passaggi meno recenti vengono eliminati.

    Per ulteriori informazioni, consultate Automatizzazione delle operazioni.

    Dizionario ortografico

    Elenca i dizionari disponibili. Le eventuali varianti previste per la stessa lingua (ad esempio inglese britannico e inglese americano) vengono elencate separatamente nel menu Dizionario.

Impostare le preferenze caratteri per i documenti in Dreamweaver

La codifica di un documento determina il modo in cui esso appare all'interno di un browser. Le preferenze di carattere di Dreamweaver permettono di vedere una determinata codifica nel carattere e nelle dimensioni preferite. Tuttavia, i caratteri selezionati nella finestra di dialogo Preferenze caratteri influiscono solo sul modo in cui i caratteri vengono visualizzati in Dreamweaver e non sull'aspetto del documento nel browser di un visitatore. Per modificare il modo in cui i caratteri vengono visualizzati in un browser, dovete modificare il testo nella finestra di ispezione Proprietà o applicare una regola CSS.

Per ulteriori informazioni sull'impostazione della codifica predefinita dei nuovi documenti, consultate Creazione e apertura dei documenti.

  1. Selezionate Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Macintosh).
  2. Selezionate Caratteri nell'elenco Categoria visualizzato sulla sinistra.
  3. Selezionate un tipo di codifica, ad esempio Occidentale o Giapponese, dal menu Impostazioni dei font.

    Nota:

    per poter visualizzare le lingue asiatiche dovete disporre di un sistema operativo che supporti i caratteri DBCS.

  4. Selezionate un carattere e una dimensione per ciascuna categoria della codifica selezionata.

    Nota:

    questi menu elencano solo i caratteri installati sul sistema. Il testo giapponese, ad esempio, può essere visualizzato solo se sono stati installati i caratteri giapponesi.

    Carattere proporzionale

    È il carattere che viene utilizzato da Dreamweaver per visualizzare il testo normale, ad esempio il testo dei paragrafi, delle intestazioni e delle tabelle. L'impostazione predefinita dipende dai caratteri installati sul proprio sistema. L'impostazione predefinita in genere corrisponde a Times New Roman 12 pt (medio) in Windows e Times 12 pt in Mac OS.

    Carattere a larghezza fissa

    Il carattere utilizzato da Dreamweaver per visualizzare il testo compreso nei tag pre, code e tt. L'impostazione predefinita dipende dai caratteri installati sul proprio sistema. L'impostazione predefinita in genere corrisponde a Courier New 10 pt (piccolo) in Windows e Monaco 12 pt in Mac OS.

    Vista Codice

    È il carattere utilizzato per tutto il testo che appare nella vista Codice e nella finestra di ispezione Codice. L'impostazione predefinita dipende dai caratteri installati sul proprio sistema.

Personalizzare i colori di evidenziazione di Dreamweaver

Utilizzate le preferenze Evidenziazione per personalizzare i colori che identificano le regioni dei modelli, le voci di libreria, i tag di terze parti, gli elementi di layout e il codice in Dreamweaver.

Modificare un colore di evidenziazione

  1. Selezionate Modifica > Preferenze e scegliete la categoria Evidenziazione.
  2. Accanto all'oggetto di cui volete cambiare il colore di evidenziazione, fate clic sulla casella colore e utilizzate il selettore colori per scegliere un nuovo colore, oppure inserite un valore esadecimale.

Attivare o disattivare l'evidenziazione di un oggetto

  1. Selezionate Modifica > Preferenze e scegliete la categoria Evidenziazione.
  2. Accanto all'oggetto di cui desiderate attivare o disattivare il colore di evidenziazione, selezionate o deselezionate l'opzione Mostra.

Ripristinare le preferenze predefinite

Per le procedure relative al ripristino delle preferenze predefinite di Dreamweaver, consultate Tech Note 83912.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online