Nota:

l'interfaccia utente di Dreamweaver CC e versioni successive è stata semplificata. Di conseguenza, potreste non trovare alcune delle opzioni descritte in questo articolo in Dreamweaver CC e versioni successive. Per ulteriori informazioni, consultate questo articolo.

Funzionamento dei frame e dei set di frame

Il frame è un'area della finestra del browser nella quale è possibile visualizzare un documento HTML indipendente dagli elementi visualizzati nel resto della finestra del browser. I frame vengono utilizzati per suddividere una finestra del browser in più aree, in ciascuna delle quali è possibile visualizzare un documento HTML diverso. In genere, un frame viene utilizzato per visualizzare un documento contenente i controlli di navigazione, mentre un altro frame visualizza il contenuto del documento

Il set di frame è un file HTML che definisce il layout e le proprietà di una serie di frame, quali il numero di frame, la dimensione e la posizione dei frame e l'URL della pagina da visualizzare inizialmente in ciascun frame. Il file del set di frame non presenta contenuto HTML da visualizzare in un browser, ad eccezione della sezione noframes. Il file del set di frame indica semplicemente al browser come visualizzare un set di frame e quali documenti visualizzare nei frame.

Per visualizzare una serie di frame in un browser, inserite l'URL del file del set di frame. I documenti da visualizzare nei frame vengono aperti automaticamente dal browser. Il file del set di frame di un sito viene in genere denominato index.html, in modo che venga visualizzato come impostazione predefinita anche quando il visitatore non specifica un nome di file.

L'esempio seguente illustra un layout composto da tre frame: un frame laterale stretto contenente una barra di navigazione, un frame verticale lungo la parte superiore della pagina contenente il logo e il titolo del sito Web e un frame di grandi dimensioni che occupa il resto della pagina ed è riservato al contenuto. Ciascuno di questi frame visualizza un documento HTML distinto.

Layout di frame
Layout di frame

In questo esempio, il documento visualizzato nel frame superiore non cambia mai durante la navigazione nel sito. La barra di navigazione del frame laterale contiene dei collegamenti. Quando si fa clic su uno di essi, il contenuto del frame principale viene modificato, mentre il contenuto del frame laterale rimane statico. Nel frame del contenuto principale a destra viene visualizzato il documento corrispondente al collegamento sul quale l'utente ha fatto clic a sinistra.

Un frame non è un file; il documento visualizzato in un frame non è parte integrante del frame. Il frame è un contenitore che ospita il documento.

Nota:

la parola “pagina” indica un singolo documento HTML oppure l'intero contenuto di una finestra del browser in un determinato momento, anche se sono visualizzati più documenti HTML contemporaneamente. L'espressione “una pagina che utilizza dei frame”, ad esempio, si riferisce in genere a una serie di frame e ai documenti che vengono visualizzati inizialmente in tali frame.

Un sito visualizzato in un browser come pagina singola comprendente tre frame è costituito in realtà da almeno quattro documenti HTML: il file del set di frame e tre documenti con il contenuto che viene visualizzato inizialmente nei frame. Quando in Dreamweaver progettate una pagina mediante i set di frame, è necessario salvare ciascuno di questi quattro file per garantire che la pagina funzioni correttamente nel browser.

Decidere se usare i frame

Adobe sconsiglia l'uso dei frame per il layout di pagine Web. Di seguito sono elencati alcuni svantaggi legati all'uso dei frame:

  • Può risultare difficoltoso allineare in modo preciso gli elementi grafici dei diversi frame.

  • La verifica della navigazione può richiedere molto tempo.

  • Gli URL delle singole pagine suddivise in frame non vengono visualizzati nel browser rendendo difficoltoso per l'utente assegnare un segnalibro a una pagina specifica (se non viene indicato un codice server per caricare la versione suddivisa in frame di una pagina specifica).

Per informazioni complete sul perché è meglio non utilizzare i frame, consultate l'esposizione di Gary White all'indirizzo http://apptools.com/rants/framesevil.php.

Nel caso in cui decidiate di utilizzare i frame, il loro utilizzo più comune è associato alla navigazione. I set di frame comprendono spesso un frame contenente una barra di navigazione e un altro frame per la visualizzazione delle pagine del contenuto principale. Questo tipo di uso dei frame presenta due svantaggi:

  • Il browser non richiede il ricaricamento della grafica di navigazione per ogni pagina.

  • Ogni frame dispone di una propria barra di scorrimento che, se il contenuto è troppo esteso per essere contenuto in una finestra, consente al visitatore di scorrere i frame in modo indipendente. Ad esempio, se la barra di navigazione è contenuta in un frame diverso da quello del contenuto, quando si scorre una pagina di contenuto fino in fondo, non è necessario scorrere di nuovo fino in alto per utilizzare la barra di navigazione.

Spesso potete creare una pagina Web senza frame in grado di produrre lo stesso effetto di una pagina che utilizza una serie di frame. Ad esempio, se desiderate visualizzare una barra di navigazione sul lato sinistro della pagina, potete sostituire la pagina con una serie di frame oppure includere la barra di navigazione in ogni pagina del sito. (Dreamweaver consente di creare più pagine con lo stesso layout.) L'esempio che segue mostra una struttura di pagina con un layout simile ai frame ma che in realtà non utilizza i frame.

Layout simile ai frame senza frame
Un layout simile ai frame senza frame

I siti progettati male utilizzano i frame in modo inopportuno, ad esempio nel caso di un set di frame che ricarica il contenuto dei frame di navigazione a ogni clic dell'utente su un pulsante di navigazione. L'uso appropriato dei frame può rivelarsi molto utile per un sito, ad esempio per mantenere statici i controlli di navigazione in un frame e consentire la modifica del contenuto di un altro frame.

Non tutti i browser sono in grado di supportare i frame in modo soddisfacente e l'utilizzo dei frame può risultare difficoltoso per gli utenti con problemi visivi. Di conseguenza, se si decide di utilizzare i frame, è opportuno inserire sempre nel set di frame una sezione noframes per i visitatori che non sono in grado di visualizzare i frame. Può inoltre essere opportuno fornire un collegamento a una versione del sito priva di frame.

Set di frame nidificati

Un set di frame nidificato è un set creato all'interno di un altro set di frame. Il file di un singolo set di frame può contenere più set di frame nidificati. La maggior parte delle pagine web che utilizzano i frame e dei set di frame predefiniti di Dreamweaver utilizza i frame nidificati. I set di frame nidificati sono necessari per le serie di frame che contengono un numero diverso di frame in righe o colonne diverse.

Ad esempio, il layout di frame più comune presenta un frame nella riga superiore (dove in genere viene visualizzato il logo della società) e due frame nella riga inferiore (un frame di navigazione e un frame del contenuto). Questo layout richiede un set di frame nidificato: un set di frame composto da due righe con un set di frame di due colonne nidificato nella seconda riga.

Un set di frame nidificati
Un set di frame nidificati

A. Set di frame principale B. Il frame del menu e il frame del contenuto sono nidificati nel set di frame principale. 

La nidificazione dei set di frame viene gestita automaticamente in Dreamweaver. Se si utilizzano gli strumenti di divisione dei frame di Dreamweaver, non occorre preoccuparsi di quali frame sono nidificati e quali non lo sono.

Il linguaggio HTML prevede due modi per nidificare un set di frame: è possibile definire il set di frame interno nello stesso file del set di frame esterno oppure in un file distinto. Ogni set di frame predefinito in Dreamweaver definisce tutti i propri set di frame nello stesso file.

Entrambi i tipi di nidificazione danno lo stesso risultato visivo, al punto che non è possibile distinguere il tipo di nidificazione utilizzato senza analizzare il codice. Il caso in cui si rivela più opportuno utilizzare un file di set di frame esterno in Dreamweaver si verifica, ad esempio, quando si apre un file del set di frame all'interno di un frame utilizzando il comando Apri in frame, con possibili problemi nell'impostazione delle destinazioni dei collegamenti. In genere, risulta più semplice mantenere tutti i set di frame definiti in un singolo file.

Operazioni con i set di frame nella finestra del documento

Dreamweaver consente di visualizzare e modificare in una singola finestra del documento tutti i documenti associati a un set di frame. In questo modo potete visualizzare, durante la modifica, l'aspetto che assumeranno le pagine suddivise in frame in un browser. Tuttavia, alcuni aspetti di questo metodo possono risultare complessi, almeno inizialmente. In particolare, ciascun frame visualizza un documento HTML distinto. Anche se i documenti sono vuoti, è necessario salvarli per poterne visualizzare un'anteprima: il set di frame può essere visualizzato in anteprima solo se contiene l'URL del documento da visualizzare in ogni frame.

Per verificare che il set di frame venga visualizzato correttamente nei browser, osservate le seguenti indicazioni generali:

  1. Create il set di frame e specificate il documento da visualizzare in ciascun frame.
  2. Salvate ogni file che dovrà essere visualizzato in un frame. Tenete presente che ogni frame visualizza un documento HTML separato, quindi è necessario salvare ogni documento con il file del set di frame.
  3. Impostate le proprietà di ciascun frame e del set di frame (ad esempio, assegnate un nome a ciascun frame e impostate le opzioni di scorrimento e non scorrimento).
  4. Impostate la proprietà Destinazione della finestra di ispezione Proprietà per tutti i collegamenti, in modo che il contenuto collegato appaia nell'area corretta.

Creare frame e set di frame

Esistono due modi per creare un set di frame in Dreamweaver: potete selezionare uno dei numerosi set di frame predefiniti oppure progettarli autonomamente.

La scelta di un set di frame predefinito costituisce il modo più semplice per creare un layout basato sui frame, poiché i set di frame e i frame necessari per creare il layout vengono impostati automaticamente. Il set di frame predefinito può essere inserito solo nella vista Progettazione della finestra del documento.

Potete anche creare un vostro set di frame in Dreamweaver aggiungendo dei comandi di divisione alla finestra del documento.

Nota:

Prima di creare un set di frame o di lavorare con i frame, attivate la visualizzazione dei bordi dei frame nella vista Progettazione della finestra del documento selezionando Visualizza > Riferimenti visivi > Bordi frame.

Creare un set di frame predefinito e visualizzare un documento esistente in un frame

  1. Posizionate il punto di inserimento in un documento ed effettuate una delle seguenti operazioni:
    • Selezionate Inserisci > HTML > Frame e selezionate un set di frame predefinito.

    • Nella categoria Layout del pannello Inserisci, fate clic sulla freccia del pulsante Frame, quindi selezionate un set di frame predefinito.

      Le icone dei set di frame forniscono una rappresentazione visiva del tipo di set di frame che verrà applicato al documento corrente. All'interno dell'icona di un set di frame, l'area azzurra rappresenta il documento corrente e l'area bianca indica i frame nei quali vengono visualizzati gli altri documenti.

  2. Se Dreamweaver è impostato per richiedere gli attributi di accessibilità dei frame, selezionate un frame dal menu a comparsa, inserite un nome per il frame e fate clic su OK. (Lo screen reader utilizzato dai visitatori leggerà questo nome quando incontrerà il frame in una pagina.)

    Nota:

    se fate clic su OK senza inserire un nome, Dreamweaver assegna al frame un nome corrispondente alla sua posizione (frame sinistro, frame destro e così via) all'interno del set di frame.

    Nota:

    se fate clic su Annulla, l'oggetto set di frame viene visualizzato nel documento ma Dreamweaver non associa i relativi tag e attributi di accessibilità.

    Nota:

    Selezionate Finestra > Frame per visualizzare uno schema dei frame ai quali state assegnando i nomi.

Creare un set di frame predefinito vuoto

  1. Selezionate File > Nuovo.
  2. Nella finestra di dialogo Nuovo documento, selezionate la categoria Pagina da esempio.
  3. Selezionate la cartella Set di frame nella colonna Cartella di esempio.
  4. Selezionate un set di frame nella colonna Pagina di esempio e fate clic su Crea.
  5. Se avete attivato gli attributi di accessibilità dei frame nelle Preferenze, viene visualizzata la finestra di dialogo Attributi di accessibilità tag Frame; impostate la finestra di dialogo per ciascun frame e fate clic su OK.

    Nota:

    se fate clic su Annulla, l'oggetto set di frame viene visualizzato nel documento ma Dreamweaver non associa i relativi tag e attributi di accessibilità.

Creare un set di frame

  1. Selezionate Elabora > Set di frame, quindi selezionate dal sottomenu un comando di divisione quale Dividi frame a sinistra o Dividi frame a destra.

    Dreamweaver suddivide la finestra in frame. Se è aperto un documento esistente, viene visualizzato in uno dei frame.

Dividere un frame in frame più piccoli

  • Per suddividere il frame in corrispondenza del punto di inserimento, selezionate un comando di divisione dal sottomenu visualizzato scegliendo Elabora > Set di frame.
    • Per suddividere un frame o una serie di frame in verticale o in orizzontale, trascinatene il bordo dal margine della vista Progettazione verso il centro della stessa.

    • Per suddividere un frame utilizzando il bordo di un frame che non si trova in corrispondenza del margine della vista Progettazione, trascinate il bordo del frame tenendo premuto il tasto Alt (Windows) oppure Opzione (Macintosh).

    • Per suddividere un frame in quattro frame, trascinate un bordo da un angolo della vista Progettazione verso il centro del frame.

Nota:

Per creare tre frame, create innanzi tutto due frame, quindi suddividete uno di essi. Notate che non è facile unire due frame adiacenti senza modificare il codice del set di frame; di conseguenza, passare da quattro frame a tre frame è più difficoltoso rispetto a suddividere due frame in tre frame.

Eliminare un frame

  1. Trascinate il bordo del frame fuori dalla pagina o fino al bordo del frame principale.

    Se il contenuto del documento del frame da eliminare non è stato salvato, in Dreamweaver viene visualizzata la richiesta di salvare il documento.

    Nota:

    non è possibile eliminare un set di frame solo trascinandone i bordi. Per eliminare un set di frame, chiudete la finestra del documento nel quale è visualizzato. Se il file del set di frame è stato salvato, eliminate il file.

Ridimensionare un frame

  • Per definire le dimensioni approssimative di un frame, trascinatene il bordo nella vista Progettazione della finestra del documento.
  • Utilizzate la finestra di ispezione Proprietà per specificare le dimensioni esatte e indicare come deve essere assegnato lo spazio a una riga o colonna del frame quando non è possibile visualizzare tutti i frame a grandezza intera nei browser.

Selezionare frame e set di frame

Per modificare le proprietà di un frame o di un set di frame, dovete innanzi tutto selezionare il frame o il set di frame da modificare. Potete selezionare un frame o un set di frame nella finestra del documento o utilizzando il pannello Frame.

Il pannello Frame fornisce una rappresentazione visiva dei frame di un set di frame. In questo pannello, la gerarchia dei set di frame risulta molto più chiara che nella finestra del documento. In questo pannello, il set di frame è racchiuso da un bordo molto spesso; ogni frame è racchiuso da una sottile linea grigia ed è identificato da un nome.

Pannello Frame
Pannello Frame

Quando selezionate un frame, i bordi del frame vengono visualizzati sotto forma di linea punteggiata nella vista Progettazione della finestra del documento. Quando selezionate un set di frame, tutti i bordi dei singoli frame del set vengono visualizzati sotto forma di una sottile linea punteggiata.

Nota:

il posizionamento del punto di inserimento in un documento visualizzato in un frame non equivale alla selezione di un frame. La selezione di un frame è richiesta per diverse operazioni, ad esempio l'impostazione delle proprietà del frame.

Selezionare un frame o un set di frame nel pannello Frame

  1. Selezionate Finestra > Frame.
  2. Nel pannello Frame:
    • Per selezionare un frame, fate clic su di esso. (Attorno ad esso viene visualizzato un bordo di selezione sia nel pannello Frame che nella vista Progettazione della finestra del documento.)

    • Per selezionare un set di frame, fate clic sul bordo che lo racchiude.

Selezionare un frame o un set di frame nella finestra del documento

  • Per selezionare un frame, fate clic al suo interno nella vista Progettazione tenendo premuto il tasto Maiusc+Alt (Windows) o i tasti Maiusc+Opzione (Macintosh).
  • Per selezionare un set di frame, fate clic su uno dei suoi bordi interni nella vista Progettazione. Per eseguire questa operazione, è necessario che i bordi siano visualizzati. A tale scopo, selezionate Visualizza > Riferimenti visivi > Bordi frame.

Nota:

la selezione di un set di frame risulta in genere più semplice nel pannello Frame anziché nella finestra del documento. Per ulteriori informazioni, consultate gli argomenti precedenti.

Selezionare un frame o un set di frame diverso

  • Per selezionare il frame o il set di frame successivo o precedente sullo stesso livello gerarchico della selezione corrente, premete Alt+freccia sinistra o Alt+freccia destra (Windows) oppure Comando+freccia sinistra o Comando+freccia destra (Macintosh). In questo modo, potete passare da un frame o set di frame all'altro nell'ordine in cui sono definiti nel file del set di frame.
  • Per selezionare il set di frame principale, ovvero il set di frame che contiene la selezione corrente, premete Alt+freccia su (Windows) o Comando+freccia su (Macintosh).
  • Per selezionare il primo frame o set di frame subordinato rispetto al set di frame attualmente selezionato (il primo rispetto all'ordine in cui sono definiti nel file del set di frame), premete Alt+freccia giù (Windows) o Comando+freccia giù (Macintosh).

Aprire un documento in un frame

Potete specificare il contenuto iniziale di un frame inserendo un nuovo contenuto in un documento vuoto incluso in un frame o aprendo un documento esistente in un frame.

  1. Posizionate il punto di inserimento in un frame.
  2. Selezionate File > Apri in frame.
  3. Selezionate un documento da aprire nel frame, quindi fate clic su OK (Windows) o su Scegli (Macintosh).
  4. Per impostare il documento come il documento predefinito da visualizzare nel frame all'apertura del set di frame in un browser, salvate il set di frame (opzionale).

Salvare i file di frame e di set di frame

Per visualizzare un'anteprima di un set di frame in un browser, è necessario innanzi tutto salvare il file del set di frame e tutti i documenti da visualizzare nei frame. Potete salvare ogni file del set di frame e ogni documento incluso in un frame singolarmente oppure salvare il file del set di frame e tutti i documenti visualizzati nei frame contemporaneamente.

Nota:

se una serie di frame è stata creata utilizzando gli strumenti visivi di Dreamweaver, a ogni nuovo documento visualizzato in un frame viene assegnato un nome di file predefinito. Ad esempio, il primo file del set di frame è denominato UntitledFrameset1, mentre il primo documento di un frame è denominato UntitledFrame1.

Salvare il file di un set di frame

  1. Selezionate il set di frame nel pannello Frame della finestra del documento.
    • Per salvare il file del set di frame, selezionate File > Salva set di frame.

    • Per salvare il file del set di frame in un nuovo file, selezionate File > Salva set di frame con nome.

    Nota:

    se il file del set di frame non è stato già salvato in precedenza, i due comandi si equivalgono.

Salvare un documento visualizzato in un frame

  1. Fate clic nel frame, quindi selezionate File > Salva frame oppure File > Salva frame con nome.

Salvare tutti i file associati a un set di frame

  1. Selezionate File > Salva tutti i frame.

    Questo comando salva tutti i documenti aperti nel set di frame, compresi il file del set di frame e tutti i documenti suddivisi in frame. Se il file del set di frame non è ancora stato salvato, il set di frame (o il frame non salvato) appare racchiuso da un bordo spesso nella vista Progettazione e potete selezionare un nome di file.

    Nota:

    se avete aperto il documento nel frame scegliendo File > Apri in frame, quando salvate il set di frame, il documento viene impostato come documento predefinito da aprire in quel frame. Se non desiderate impostare il documento come visualizzazione predefinita, non salvate il file del set di frame.

Visualizzare e impostare le proprietà e gli attributi dei frame

La finestra di ispezione Proprietà consente di visualizzare e impostare la maggior parte delle proprietà dei frame, come i bordi, i margini e le eventuali barre di scorrimento. Le impostazioni specificate per i singoli frame hanno la precedenza rispetto a quelle definite per il set di appartenenza.

Per migliorare l'accessibilità, potete anche impostare alcuni attributi per il frame, ad esempio l'attributo title, da non confondere con l'attributo name. Potete attivare l'opzione di authoring di accessibilità per i frame per impostare gli attributi dei frame nel momento in cui vengono creati oppure impostare gli attributi dopo avere inserito un frame. Per modificare gli attributi per un frame, utilizzate la finestra di ispezione Tag e modificate direttamente il codice HTML.

Visualizzare o impostare le proprietà di un frame

  1. Selezionate il frame effettuando una delle seguenti operazioni:
    • Fate clic all'interno di un frame nella vista Progettazione della finestra del documento tenendo premuto il tasto Alt (Windows) o i tasti Maiusc+Opzione (Macintosh).

    • Fate clic su un frame nel pannello Frame (Finestra > Frame).

  2. Per visualizzare tutte le proprietà del frame, fate clic sulla freccia di espansione situata nell'angolo inferiore destro della finestra di ispezione Proprietà (Finestra > Proprietà).
  3. Impostate le opzioni della finestra di ispezione Proprietà del frame.

    Nome frame

    Il nome utilizzato dall'attributo target di un collegamento o da uno script per fare riferimento al frame. i nomi di frame devono essere costituiti da una sola parola. Potete utilizzare i caratteri di sottolineatura (_), ma non i trattini (-), i punti (.) e gli spazi. I nomi dei frame devono iniziare con una lettera e non con un numero. I nomi dei frame fanno distinzione tra lettere maiuscole e minuscole. Non utilizzate termini corrispondenti a parole riservate di JavaScript, quali top o navigator.

    Nota:

    Per impostare un collegamento in modo da modificare il contenuto di un altro frame, è necessario assegnare un nome al frame di destinazione. Per semplificare la creazione successiva di collegamenti tra più frame, assegnate un nome a ciascun frame durante la fase di creazione.

    Orig.

    Indica il documento di origine da visualizzare nel frame. Fate clic sull'icona della cartella per cercare e selezionare il file desiderato.

    Scorrimento

    Specifica se nel frame vengono visualizzate delle barre di scorrimento. L'impostazione di questa opzione su Predefinito non comporta l'impostazione di un valore per l'attributo corrispondente e consente quindi a ogni browser di utilizzare il proprio valore predefinito. L'impostazione predefinita per la maggior parte dei browser è Automatica, in base alla quale le barre di scorrimento vengono visualizzate solo se lo spazio della finestra del browser non è sufficiente a visualizzare l'intero contenuto del frame corrente.

    Non ridimensionare

    Impedisce ai visitatori di trascinare i bordi del frame per ridimensionarlo in un browser.

    Nota:

    Dreamweaver consente di ridimensionare i frame in qualsiasi momento. Questa opzione è valida solo per i visitatori che visualizzano i frame in un browser.

    Bordi

    Mostra o nasconde i bordi del frame corrente quando viene visualizzato in un browser. Questa impostazione ha la precedenza rispetto alle impostazioni del bordo definite per il set di frame.

    Le opzioni disponibili per Bordo sono Sì (Mostra bordi), No (Nascondi bordi) e Predefinito. Per impostazione predefinita, la maggior parte dei browser visualizza i bordi, a condizione che la visualizzazione dei bordi non sia stata disattivata per il set di frame principale. Il bordo viene nascosto solo quando, per tutti i frame che condividono il bordo, la proprietà Bordi è stata impostata su No, oppure quando la proprietà Bordi è impostata su No per il set di frame principale e su Predefinito per i frame che condividono il bordo.

    Colore bordo

    Consente di impostare il colore di tutti i bordi del frame. Il colore viene applicato a tutti i bordi a contatto con il frame e ha la precedenza sul colore del bordo specificato per il set di frame.

    Larghezza margine

    Consente di impostare la larghezza in pixel dei margini sinistro e destro (ovvero la distanza tra i bordi del frame e il contenuto).

    Altezza margine

    Consente di impostare l'altezza in pixel del margine superiore e inferiore (ovvero la distanza tra i bordi del frame e il contenuto).

    Nota:

    l'impostazione della larghezza e dell'altezza dei margini di un frame non equivale all'impostazione dei margini nella finestra di dialogo che viene visualizzata scegliendo Elabora > Proprietà di pagina.

    Nota:

    Potete modificare il colore di sfondo di un frame cambiando il colore di sfondo del documento contenuto nel frame nelle proprietà della pagina.

Impostare i valori di accessibilità di un frame

  1. Nel pannello Frame (Finestra > Frame), selezionate un frame posizionando il punto di inserimento in uno dei frame.
  2. Selezionate Elabora > Modifica Tag <frameset>.
  3. Selezionate Foglio di stile/Accessibilità nell'elenco delle categorie visualizzato sulla sinistra, inserite i valori e fate clic su OK.

Modificare i valori di accessibilità di un frame

  1. Attivate la vista Codice o la vista Codice e Progettazione del documento, se state lavorando nella vista Progettazione.
  2. Nel pannello Frame (Finestra > Frame), selezionate un frame posizionando il punto di inserimento in uno dei frame. Dreamweaver evidenzia i tag di frame nel codice.
  3. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul codice, quindi selezionate Modifica Tag.
  4. Nell'editor di tag, apportate le modifiche e fate clic su OK.

Modificare il colore di sfondo di un documento contenuto in un frame

  1. Posizionate il punto di inserimento nel frame.
  2. Selezionate Elabora > Proprietà di pagina.
  3. Nella finestra di dialogo Proprietà di pagina, fate clic sul menu Colore sfondo e selezionate un colore.

Visualizzare e impostare le proprietà di un set di frame

La finestra di ispezione Proprietà consente di visualizzare e impostare la maggior parte delle proprietà dei set di frame, come il titolo, i bordi e le dimensioni dei frame.

Impostare un titolo per un documento di un set di frame

  1. Selezionate il set di frame effettuando una delle seguenti operazioni:
    • Fate clic sul bordo tra due frame del set di frame nella vista Progettazione della finestra del documento.

    • Fate clic sul bordo che racchiude un set di frame nel pannello Frame (Finestra > Frame).

  2. Nella casella Titolo della barra degli strumenti Documento, digitate il nome del documento del set di frame.

    Quando un visitatore visualizza il set di frame in un browser, il titolo appare nella barra del titolo del browser.

Visualizzare o impostare le proprietà di un set di frame

  1. Selezionate il set di frame effettuando una delle seguenti operazioni:
    • Fate clic sul bordo tra due frame del set di frame nella vista Progettazione della finestra del documento.

    • Fate clic sul bordo che racchiude un set di frame nel pannello Frame (Finestra > Frame).

  2. Nella finestra di ispezione Proprietà (Finestra > Proprietà), fate clic sulla freccia di espansione situata nell'angolo inferiore destro e impostate le proprietà del set di frame.

    Bordi

    Determina la visualizzazione dei bordi dei frame quando il documento viene visualizzato in un browser. Selezionate Sì per visualizzare i bordi oppure No per fare in modo che non vengano visualizzati dal browser. Per consentire al browser di determinare la modalità di visualizzazione dei bordi, selezionate Predefinito.

    Spessore bordo

    Consente di definire lo spessore di tutti i bordi del set di frame.

    Colore bordo

    Consente di impostare il colore dei bordi. Utilizzate il selettore colore per selezionare un colore o digitate il valore esadecimale di un colore.

    Selezione RigaCol

    Consente di impostare le dimensioni dei frame per le righe e le colonne del set di frame selezionato. Fate clic sulle linguette visualizzate rispettivamente a sinistra o nella parte superiore dell'area Selezione RigaCol, quindi inserite l'altezza o la larghezza desiderata nella casella di testo Valore.

    Selezione RigaCol
    Selezione RigaCol

  3. Per specificare la quantità di spazio assegnata dal browser a ogni frame, selezionate una delle seguenti opzioni dal menu Unità:

    Pixel

    Imposta le dimensioni della colonna o della riga selezionata su un valore assoluto. Scegliete questa opzione per i frame che devono conservare sempre le stesse dimensioni, ad esempio quelli associati alle barre di navigazione. Nell'assegnazione dello spazio, questi frame vengono presi in considerazione prima dei frame impostati su Percentuale o Relativa. In genere, le dimensioni dei frame vengono definite impostando un frame sinistro su una larghezza fissa in pixel e un frame destro su una larghezza relativa. Ciò consente il ridimensionamento del frame destro che assume in questo modo tutto lo spazio rimanente dopo l'assegnazione della larghezza in pixel.

    Nota:

    se tutte le larghezze sono specificate in pixel e un visitatore visualizza il set di frame in un browser troppo largo o troppo stretto per la larghezza specificata, i frame si estendono o si riducono proporzionalmente in modo da occupare lo spazio disponibile. Lo stesso si verifica per le altezze specificate in pixel. Di conseguenza, è in genere buona norma specificare almeno una larghezza e un'altezza come relative.

    Percentuale

    Specifica che la colonna o la riga selezionata corrisponde a una percentuale della larghezza o altezza totale del set di frame. Nell'assegnazione dello spazio, questi frame vengono presi in considerazione dopo i frame impostati su Pixel, ma prima dei frame impostati su Relativa.

    Relativa

    Specifica che alla colonna o alla riga selezionata viene assegnato lo spazio rimanente dopo l'assegnazione dello spazio ai frame impostati su Pixel e Percentuale. Lo spazio rimanente viene suddiviso proporzionalmente tra i frame con le dimensioni impostate su Relativa.

    Nota:

    quando selezionate Relativa dal menu Unità, qualsiasi numero inserito nel campo Valore scompare. Se desiderate specificare un numero, dovete inserirlo di nuovo. Tuttavia, se solo una riga o una colonna è impostata su Relativa, non è necessario inserire un numero, poiché alla riga o colonna viene assegnato tutto lo spazio rimanente dall'assegnazione dello spazio alle altre righe e colonne. Per assicurare la compatibilità completa con più browser, potete inserire 1 nel campo Valore (equivale a non specificare alcun valore).

Per utilizzare un collegamento situato in un frame per aprire un documento in un altro frame, è necessario impostare la destinazione del collegamento. L'attributo target di un collegamento specifica il frame o la finestra nella quale viene aperto il contenuto collegato.

Ad esempio, se la barra di navigazione si trova nel frame sinistro e desiderate visualizzare il materiale collegato nel frame del contenuto principale a destra, è necessario specificare il nome del frame del contenuto principale come destinazione per ciascun collegamento della barra di navigazione. Quando un visitatore fa clic su un collegamento della barra di navigazione, il contenuto specificato viene aperto nel frame principale.

  1. Nella vista Progettazione, selezionate un testo o un oggetto.
  2. Nel campo Collegam della finestra di ispezione Proprietà (Finestra > Proprietà), effettuate una delle seguenti operazioni:
    • Fate clic sull'icona della cartella e selezionate il file da collegare.

    • Trascinate nel pannello File l'icona Scegli file per selezionare il file da collegare.

  3. Nel menu Destinazione della finestra di ispezione Proprietà, selezionate il frame o la finestra in cui desiderate visualizzare il documento collegato:
    • _blank apre il documento collegato in una nuova finestra del browser mantenendo invariata la finestra corrente.

    • _parent apre il documento collegato nel set di frame principale del frame contenente il collegamento, sostituendo l'intero set di frame.

    • _self apre il collegamento nel frame corrente sostituendone il contenuto.

    • _top apre il documento collegato nella finestra del browser corrente sostituendo tutti i frame.

      In questo menu vengono visualizzati anche i nomi dei frame. Selezionate un frame associato a un nome per aprire il documento collegato nel frame selezionato.

    Nota:

    i nomi dei frame vengono visualizzati solo quando si modifica un documento all'interno di un set di frame. Quando modificate un documento nella relativa finestra del documento, i nomi dei frame non vengono visualizzati nel menu a comparsa Destinazione. Se il documento che state modificando è esterno al set di frame, potete digitare il nome del frame di destinazione nella casella di testo Destinazione.

    Nota:

    Se create un collegamento a una pagina esterna al sito, è opportuno utilizzare sempre target="_top" o target="_blank" per assicurarsi che la pagina non venga visualizzata come parte del proprio sito.

Impostare il contenuto per i browser che non supportano i frame

Dreamweaver consente di specificare il contenuto da visualizzare nei browser basati su testo o in browser meno recenti che non supportano i frame. Il contenuto viene memorizzato nel file del set di frame, racchiuso in un tag noframes. Quando il file del set di frame viene caricato da un browser che non supporta i frame, il browser visualizza solo il contenuto racchiuso tra i tag noframes.

Nota:

si consiglia pertanto di inserire nell'area noframes un contenuto più esteso della semplice nota “È opportuno passare a un browser in grado di gestire i frame”. Alcuni visitatori del sito potrebbero utilizzare sistemi che non consentono la visualizzazione dei frame.

  1. Selezionate Elabora > Set di frame > Modifica contenuto senza frame.

    Dreamweaver cancella il contenuto della vista Progettazione e nella parte superiore della vista viene visualizzata la nota “Contenuto senza frame”.

  2. Effettuate una delle operazioni seguenti:
    • Nella finestra del documento, digitate o inserite il contenuto come in un normale documento.

    • Selezionate Finestra > Finestra di ispezione Codice, e collocate il punto di inserimento tra i tag body visualizzati all'interno dei tag noframes e digitate il codice HTML per il contenuto.

  3. Selezionate nuovamente Elabora > Set di frame > Modifica contenuto senza frame per tornare alla vista normale del documento del set di frame.

Usare i comportamenti JavaScript con i frame

Numerosi comportamenti JavaScript e comandi di navigazione si rivelano particolarmente adatti ad essere utilizzati con i frame.

Imposta testo del frame

Sostituisce il contenuto e la formattazione di un determinato frame con il contenuto specificato dall'utente. Tale contenuto può essere costituito da qualsiasi codice HTML valido. Utilizzate questa azione per visualizzare le informazioni in modo dinamico in un frame.

Vai a URL

Apre una nuova pagina nella finestra corrente o nel frame specificato. Utilizzando questa azione potete modificare il contenuto di due o più frame con un semplice clic.

Inserisci menu di collegamento

Consente di impostare un menu di collegamento che apre i file selezionati in una finestra del browser. Potete anche fare in modo che i documenti vengano aperti in una finestra o in un frame specifico.

Per ulteriori informazioni, consultate Aggiunta di comportamenti JavaScript.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online