Dreamweaver 8 pro Windows ztrácí nastavení přihlášení FTP

Naposledy aktualizováno 27. 4. 2021

Problém

Někteří uživatelé Windows hlásí, že jejich uživatelská jména a hesla FTP v definicích webů Dreamweaver jsou smazána při zavření a opětovném otevření Dreamweaver 8 nebo při restartování počítače.Tento problém se nevyskytuje v dřívějších verzích aplikace Dreamweaver.(Viz 205051, 210466)

Příčina

Existují dvě známé příčiny tohoto problému:

  • Nejčastější příčinou je instalace Internet Explorer 7 (IE 7) na stejném počítači jako Dreamweaver 8.

  • Méně pravděpodobnou příčinou je chybějící nebo prázdný následující klíč registru:



    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\User Shell Folders\AppData

Řešení

Pokud máte nainstalován Internet Explorer 7

Pokud máte nainstalován Internet Explorer 7, pak by instalace aktualizace Dreamweaver 8.0.2 měla tento problém vyřešit.Před instalací aktualizace Dreamweaver 8.0.2 se doporučuje zkontrolovat technickou poznámku k novým problémům Dreamweaver 8 kvůli změnám, které mohou ovlivnit váš pracovní postup, zejména pokud vytváříte stránky na straně serveru (ASP, PHP, ColdFusion atd.)nebo vložte obsah Flash.

Poznámka: Po instalaci aktualizace Dreamweaver 8.0.2 ověřte, že se aktualizace úspěšně nainstalovala. Někteří uživatelé si myslí, že nainstalovali verzi 8.0.2, ale ve skutečnosti se instalace aktualizace nezdařila. V aplikaci Dreamweaver přejděte na Nápověda > O aplikaci Dreamweaver > a klikněte na posouvající se text, čímž zobrazíte číslo verze. Mělo by tam být uvedeno Dreamweaver 8.0.2. Pokud tam stále svítí Dreamweaver 8.0 nebo 8.0.1, přečtěte si článek Nelze nainstalovat aktualizace Dreamweaver 8 pro Windows po zrušení instalačního programu aktualizace (technická poznámka 785362aa).

Poznámka: Internet Explorer 7 byl vydán po aplikaci Dreamweaver 8, a proto nebyl s Dreamweaver 8 a staršími verzemi testován.

Pokud nemáte nainstalován Internet Explorer 7 nebo pokud aktualizátor Dreamweaver 8.0.2 problém nevyřeší

Pokud jste v době, kdy se tento problém vyskytl, neměli Internet Explorer 7, nainstalujte aktualizaci Dreamweaver 8.0.2 Updater podle výše uvedeného popisu a poté proveďte následující kroky, pokud se bez obav orientujete v upravování registru Windows.

Varování: Nesprávné upravování registru Windows může způsobit vážné problémy, které mohou vyžadovat přeinstalování operačního systému. Adobe nezaručuje, že problémy způsobené nesprávným upravováním registru lze vyřešit. Úpravu registru provádíte na vlastní nebezpečí.

Spusťte Editor registru kliknutím na tlačítko Start, zvolte Spustit a poté zadejte "regedit". V Editoru registru přejděte do této složky:



HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\User Shell Folders\
Zjistěte, zda existuje klíč s názvem AppData, jak je znázorněno na snímku obrazovky níže:



Zkontrolovat klíč AppData

Zálohujte větev registru Users Shell Folders následovně:
Klikněte pravým tlačítkem na složku Users Shell Folders a vyberte možnost „Export".
V části „Rozsah exportu" vyberte „Vybraná větev".
Uložte soubor .reg na plochu.
Pokud se po úpravě registru vyskytnou problémy, dvojitým kliknutím na soubor .reg se daná větev registru znovu nainstaluje.
Pokud klíč AppData chybí, proveďte následující kroky.Pokud klíč AppData existuje, pokračujte krokem 5.
Na pravé straně podokna Editoru registru klikněte pravým tlačítkem do prázdné oblasti kdekoli pod posledním klíčem v seznamu.Měla by se zobrazit kontextová nabídka s nápisem „New" a rozbalovací nabídkou.
V rozbalovací nabídce vyberte „Expandable String Value" a pojmenujte nový klíč AppData.
Klikněte pravým tlačítkem na nový klíč AppData (nebo na stávající, pokud už tam byl), vyberte možnost Upravit a do pole Hodnota údajů zadejte následující: %USERPROFILE%\Application Data.Pokud hodnoty ostatních klíčů ve vašem adresáři User Shell Folders nezačínají na %USERPROFILE%, použijte hodnotu, kterou používají vaše ostatní klíče. Například pokud váš klíč Local Settings má hodnotu u:\Local Settings, zkuste použít u:\Application Data.
Otevřete Dreamweaver, znovu zadejte přihlašovací informace FTP pro jednu ze svých stránek a zjistěte, zda se nyní přihlášení FTP uloží při zavření a opětovném otevření aplikace Dreamweaver.

Pokud výše uvedená řešení problém nevyřeší, kontaktujte technickou podporu společnosti Adobe nebo zašlete hlášení o chybě a uveďte, že se u vás vyskytuje problém popsaný v technické poznámce 3491671c.