Řešení problémů s ukládáním souborů

Potýkáte se při ukládání souborů v aplikaci Illustrator s problémy? Zde je několik postupů pro odstraňování problémů, které můžete vyzkoušet.

Pokud je soubor .ai nahlášen jako poškozený, zkuste obnovit obsah dotčeného souboru pomocí následujících řešení:

Řešení

Postup 

Uložení souboru v jiném formátu

  • Změňte soubor .ai na jiný formát (.svg, .png, .jpg) a pak zkuste tento soubor uložit znovu.
  • Uložení souboru ve formátu Post-Script (PS)
    1. Zvolte možnost Soubor Tisk.
    2. Zadejte požadované nastavení tisku.
    3. V nabídce Tiskárna zvolte možnost Soubor Adobe PostScript a klikněte na tlačítko Uložit.
    4. Zadejte název souboru, který obsahuje příponu .ps (například Filename.ps), a pak klikněte na tlačítko OK (Windows) nebo Uložit (macOS).
    5. Otevřete soubor jazyka PostScript v aplikaci Illustrator a pak jej zkuste uložit ve formátu .ai.

Poznámka: Chcete-li provést toto řešení, musíte mít nainstalován ovladač tiskárny s podporou jazyka PostScript. Informace o instalaci tiskáren s podporou jazyka PostScript v systému Windows naleznete v nápovědě systému Windows.

Zkopírování obsahu do nového souboru

  • Odeberte z kresby nepotřebné položky, například osamocené body, nevybarvené objekty a prázdné textové cesty. Zvolte možnost Objekt > Cesta > Vyčistit.
  • Zachovejte v novém souboru vrstvy pro kresbu. Na panelu Vrstvy > Více voleb zvolte možnost Vkládat do stejné vrstvy.
  • Vyberte kresbu a zvolte možnost Úpravy > Kopírovat.
  • Výběrem možnosti Soubor > Nový vytvořte nový soubor.
  • V novém souboru zvolte možnost Úpravy > Vložit dopředu, aby se kresba vložila na stránce na správnou pozici.

Zjištění a odebrání poškozených součástí

Chcete-li zjistit, zda je objekt poškozen, odstraňte jej z nového souboru a pak tento soubor uložte a znovu otevřete. 

  • Identifikace poškozeného vzorku, přechodu nebo vlastní barvy
    • Vyberte možnost Úpravy > Vybrat vše a změňte výplň a tah na výtažkovou černou barvu.
    • Pokud se v novém souboru daný problém už neobjevuje, vytvořte znovu vzorek, přechod nebo přímou barvu v původním souboru.
      Poznámka: Může dojít ke ztrátě informací o průhlednosti a vrstvách.
  • Odstranění nepoužitých vzorníků, vlastních barev, skupin barev, štětců, symbolů nebo stylů
    Vyberte možnost Vybrat všechny nepoužité z nabídky panelu Vzorníky, z nabídky panelu Štětce, z nabídky panelu Symboly a z nabídky panelu Styly. Pak stiskněte tlačítko Odstranit.
  • Převod poškozeného textového objektu na obrysy nebo změna jeho písma
    • Vyberte možnost Objekt > Odemknout vše.
    • Vyberte možnost Úpravy > Vybrat vše.
    • Vyberte možnost Text > Písmo a vyberte písmo, které se v dokumentu nepoužívá.
      Poznámka: Chcete-li zabránit poškození textových objektů v budoucnu, přeinstalujte problematické písmo na původním disku.

Problém stále není vyřešen?

  • Pokud žádné řešení nefunguje, po opětovném uložení nebo vytvoření grafiky, šablon a vlastních barev použitých v původním souboru vytvořte daný soubor v aplikaci Illustrator znovu. 
  • Může se jednat o jiný problém, který souvisí například s pamětí, oprávněními pro přístup, sítí nebo vyměnitelnými médii. Pokud se chcete o tomto problému dozvědět více, přečtěte si článek Zjišťování a řešení problémů se soubory.

Zapojte se do konverzace

Ask the community

Pokud se chcete na něco zeptat nebo chcete sdílet nějaký nápad, zapojte se do komunity věnované aplikaci Adobe Illustrator. Vašeho názoru si ceníme.

Logo Adobe

Přihlaste se ke svému účtu.