Seskupení objektů a rozdělení skupiny

Když několik objektů zkombinujete do skupiny, bude se s nimi zacházet jako s jedním celkem. Pak můžete posunout nebo transformovat objekty bez ovlivnění jejich individuálních poloh nebo atributů. Můžete například seskupit objekty v návrhu loga, a pak změnit velikost loga jako jednoho celku.

Skupiny mohou být také vnořené – seskupené do podskupin uvnitř větších skupin. Pomocí nástrojů pro výběr, přímý výběr nebo výběr skupiny můžete vybrat různé úrovně v hierarchii vnořené skupiny.

Pokud pracujete s více navzájem se překrývajícími objekty a seskupíte některé objekty, které spolu nesousedí v pořadí překrývání, vybrané objekty se seřadí za sebe v pořadí překrývání, za nejvrchnější vybraný objekt. (Pokud jsou například objekty navrstvené odpředu dozadu jako A, B, C, D a seskupíte objekty B a D, pořadí překrývání se změní na A, B, D, C). Pokud seskupíte objekty, které jsou v různých pojmenovaných vrstvách, všechny objekty se přesunou do nejvrchnější vrstvy, ve které jste vybrali objekt. Vybrané objekty musí být buď všechny zamknuté nebo všechny odemknuté.

Seskupený objekt
Seskupený objekt

  1. Vyberte více objektů, které chcete seskupit, nebo pro které chcete rozdělit skupinu.

    Pokud výběr zahrnuje část objektu (například bod kotvy), operace seskupení nebo rozdělení skupiny celý objekt zahrne do skupiny, nebo ho z ní vyčlení.

  2. Chcete-li seskupit vybrané objekty, zvolte možnost Objekt > Seskupit.

    Chcete-li zrušit seskupení vybraných objektů, zvolte možnost Objekt > Rozdělit skupinu.

Poznámka:

Pokud si nejste jisti, zda je objekt součástí skupiny, vyberte ho nástrojem pro výběr a podívejte se do nabídky Objekt. Pokud je dostupný příkaz Objekt > Rozdělit skupinu, vybrali jste skupinu.

Seskupení nebo vyčlenění objektů v různých vrstvách

K seskupení objektů umístěných v různých vrstvách dokumentu lze také využít panel Vrstvy. Další informaci o vrstvách získáte kliknutím sem.

Při seskupování objektů v různých vrstvách aplikace InDesign seskupí objekty v nejhořejší vrstvě obsahující nejméně jeden objekt ve skupině. Aplikace InDesign si však pamatuje, ke kterým vrstvám každý objekt patří. To v podstatě znamená, že pokud rozdělíte skupinu objektů, všechny se obnoví zpět ve svých původních vrstvách.

Můžete se také rozhodnout nechat neseskupené objekty v nejhořejší vrstvě. V tom případě zrušte výběr Rozdělit a pamatovat vrstvy v rozbalovací nabídce nabídky Vrstvy.

Poznámka:

Tato volba je nastavením na úrovni aplikace. To znamená, že se používá u všech dokumentů.

Zamknutí nebo odemknutí objektů

Pomocí příkazu Zamknout můžete nastavit, aby se určité objekty v dokumentu nemohly posunout. Zamknuté objekty zůstanou zamknuté i po uložení dokumentu, jeho zavření a dalším otevření.

Dokud je objekt zamknutý, nelze ho přesunout. Zamknuté objekty však můžete vybírat, jestliže ve všeobecných předvolbách vypnete volbu Zabránit výběru zamknutých objektů. Když vyberete zamknutý objekt, můžete změnit atributy jako například barvu.

  1. Vyberte objekt nebo objekty, jejichž polohu chcete zamknout.
  2. Proveďte libovolný z následujících úkonů:
    • Chcete-li objekty zamknout, zvolte Objekt > Zamknout.

    • Chcete-li objekt odemknout, klikněte na ikonu zámku.

    • Chcete-li odemknout objekty na aktuální dvojstránce, vyberte Objekt > Odemknout vše na dvojstránce.

Poznámka:

Objekty a vrstvy můžete zamknout nebo odemknout také pomocí panelu Vrstvy. Když zamknete vrstvu, zamknou se polohy všech objektů na vrstvě a objekty nelze vybírat. Viz téma Vrstvy.

Skrytí objektů

Skryté objekty se netisknou ani neexportují a nelze je vybírat.

  1. Proveďte libovolný z následujících úkonů:

    • Chcete-li skrýt objekt, vyberte jej a zvolte Objekt > Skrýt.

    • Chcete-li zobrazit skryté objekty, zvolte Objekt > Zobrazit vše na dvojstránce.

Duplikování objektů

Objekty můžete duplikovat pomocí několika různých metod.

Duplikování objektu pomocí příkazu Duplikovat

Pomocí příkazu Duplikovat můžete vybraný objekt okamžitě zkopírovat. Nová kopie se na stránce objeví mírně odsazena směrem dolů a doprava od originálu.

  1. Vyberte objekt nebo objekty a zvolte Úpravy > Duplikovat.

Duplikování vybraného objektu při transformaci

Můžete duplikovat objekt pokaždé, když změníte jeho polohu, orientaci nebo proporce. Můžete například vytvořit květinu nakreslením jednoho okvětního lístku, nastavením referenčního bodu do počátku lístku a opakovaným otáčením s duplikováním přidat nové kopie lístku s postupně se měnícími úhly.

  1. Při transformaci proveďte jeden z následujících úkonů:

    • Pokud táhnete nástrojem pro výběr , otáčení , změnu velikosti nebo zkosení , začněte táhnout a pak stiskněte při tažení klávesu Alt (Windows) nebo Option (Mac OS). Chcete-li omezit transformaci kopie, táhněte se stisknutými klávesami Alt+Shift (Windows) nebo Option+Shift (Mac OS).

    • Pokud zadáváte hodnotu v panelu Transformace nebo v ovládacím panelu, po zadání hodnoty stiskněte Alt+Enter (Windows) nebo Option+Return (Mac OS).

    • Pokud posunujete objekty pomocí kláves se šipkami, podržte Alt (Windows) nebo Option (Mac OS) při stisknutí klávesy.

Použití funkce Krok a opakovat pro duplikaci objektů

Pro rychlé vytvoření řad nebo sloupců kopií použijte příkaz Krok a opakovat. Můžete například vyplnit stránku rovnoměrně rozmístěnými kopiemi návrhu jedné vizitky.

  1. Vyberte objekt nebo objekty, které chcete duplikovat.

  2. Zvolte Úpravy > Krok a opakovat.

  3. Pro Počet opakování zadejte, kolik kopií chcete vytvořit (originál se nepočítá).

  4. Pro Vodorovný posun a Svislý posun zadejte, jak daleko chcete posunout polohu každé nové kopie od předcházející kopie podél osy x a y a klikněte na OK.

Poznámka:

Chcete-li vytvořit stránku plnou kopií, použijte nejdříve Krok a opakovat se svislým posunem nastaveným na 0 (nula); tím vytvoříte jednu řadu kopií. Pak vyberte celou tuto řadu a použijte Krok a opakovat s vodorovným posunem nastaveným na 0; tím zopakujete řádek směrem dolů na stránce.

Duplikace objektů do mřížky

Přetažením za současného stisknutí modifikačních kláves můžete vytvořit mřížku objektu totožného s duplikovaným objektem.

  1. Vyberte objekt.

  2. Použijte nástroj pro výběr, stiskněte Alt (Windows) nebo Option (Mac OS) a začněte přetahovat.

  3. Během přetahování uvolněte klávesu Alt nebo Option. Pomocí šipkové klávesy Doleva a Doprava můžete změnit počet sloupců. Pomocí šipkové klávesy Nahoru a Dolů můžete změnit počet řádků. Roztáhněte obdélník na požadovanou velikost mřížky.

  4. Uvolněte tlačítko myši.

Vytváření netištěných objektů

Někdy můžete chtít vytvořit objekty, které se zobrazí na obrazovce, ale které se nebudou tisknout ani se neobjeví v distribuovaných verzích dokumentu.

Poznámka:

K výběrovému skrývání nebo zobrazování elementů dokumentu můžete použít také vrstvy a těmto vrstvám můžete přiřadit netištěný stav.

  1. Vyberte objekt nebo textový rámeček, který nechcete tisknout.
  2. Otevřete panel Atributy (Okna > Výstup > Atributy).
  3. V panelu Atributy vyberte Netištěný.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online