O vrstvách

Každý dokument obsahuje alespoň jednu pojmenovanou vrstvu. Použitím více vrstev můžete vytvořit a upravovat určité oblasti nebo typy obsahu v dokumentu, aniž byste ovlivnili jiné oblasti nebo jiné typy obsahu. Pokud se například dokument tiskne pomalu, protože obsahuje příliš mnoho velkých grafik, můžete použít jednu vrstvu v dokumentu pouze pro text a pak, když je třeba provést korekturu textu, můžete všechny ostatní vrstvy skrýt a rychle vytisknout pouze vrstvu s textem. Pomocí vrstev můžete také zobrazit alternativní představy pro jeden návrh nebo různé verze reklamy pro různé oblasti.

Vrstvy si můžete představit jako průhledné fólie položené na sobě. Pokud vrstva neobsahuje objekty, můžete skrz ni vidět jiné objekty ve vrstvách pod ní.

Další poznámky k vrstvám:

  • Každá vrstva dokumentu má popisný trojúhelník, který lze rozbalit a zobrazit tak pro aktivní dvojstránku objekty a jejich pořadí překrývání na vrstvě. Skupiny, tlačítka a objekty s několika stavy mají rovněž popisné trojúhelníky, které lze rozbalit a zobrazit obsažené objekty. Můžete měnit pořadí těchto objektů, zamykat a odemykat je a přidávat nebo odebírat je za skupiny.

  • Objekty na vzorech se zobrazují v každé vrstvě vzadu. Vzorové položky se mohou zobrazit před objekty na stránce dokumentu, když jsou ve vyšší vrstvě. (Viz O vzorech, pořadí překrývání a vrstvách.)

  • Vrstvy se uplatňují na všech stránkách dokumentu, včetně vzorů. Pokud například skryjete vrstvu 1 při úpravách stránky 1 dokumentu, bude vrstva skrytá na všech stránkách, dokud se nerozhodnete ji opět zobrazit.

  • Informace o tom, jak převést vrstvy aplikace Adobe PageMaker® nebo QuarkXPress, najdete v části Převádění dokumentů aplikací QuarkXPress a PageMaker.

Panel Vrstvy
Panel Vrstvy zobrazuje seznam vrstev a vrstva nejvíce vpředu je v panelu nahoře.

Vytváření vrstev

Vrstvy můžete kdykoli přidat pomocí příkazu Nová vrstva v nabídce panelu Vrstvy nebo pomocí tlačítka Nová vrstva dole v panelu Vrstvy. Maximální počet vrstev v dokumentu je omezen pouze pamětí dostupnou pro InDesign.

Vytváření vrstev

  1. Zvolte Okna > Vrstvy.
  2. Chcete-li vytvořit novou vrstvu, proveďte libovolný z následujících úkonů:
    • Chcete-li vytvořit novou vrstvu nad vybranou vrstvou, klikněte na tlačítko Nová vrstva.

    • Chcete-li vytvořit novou vrstvu pod vybranou vrstvou, podržte při kliknutí na tlačítko Nová vrstva klávesu Ctrl (Windows) nebo Command (Mac OS).

    • Chcete-li vytvořit novou vrstvu na začátku seznamu, podržte při kliknutí na tlačítko Nová vrstva klávesy Ctrl+Alt (Windows) nebo Command+Shift (Mac OS).

    • Chcete-li vytvořit novou vrstvu a otevřít dialogové okno Nová vrstva, podržte při kliknutí na tlačítko Nová vrstva klávesu Alt (Windows) nebo Option (Mac OS).

Určení voleb vrstvy

  1. Zvolte Nová vrstva z nabídky v panelu Vrstvy nebo dvojitě klikněte na existující vrstvu.
  2. Určete volby vrstvy a pak klikněte na OK.

    Barva

    Přiřaďte barvu, která označuje objekty v této vrstvě.

    Zobrazit vrstvu

    Vyberte tuto volbu, aby byla vrstva viditelná. Zapnutí této volby je stejné jako zviditelnění ikony oka v panelu Vrstvy.

    Zobrazovat vodítka

    Vyberte tuto volbu, aby byla vodítka v této vrstvě viditelná. Pokud tato volba není pro vrstvu vybraná, vodítka nelze zobrazit, i když vyberete Zobrazení > Zobrazovat vodítka pro dokument.

    Zamknout vrstvu

    Vyberte tuto volbu, abyste zabránili změnám jakýchkoliv objektů v této vrstvě. Zapnutí této volby je stejné jako zviditelnění ikony přeškrtnuté tužky v panelu Vrstvy.

    Zamknout vodítka

    Vyberte tuto volbu, abyste zabránili změnám všech vodítek ve vrstvě.

    Tisknout vrstvu

    Vyberte tuto volbu, chcete-li umožnit zakázání tisku vrstvy. Při tisku nebo exportu do PDF můžete určit, zda tisknout skryté a netisknutelné vrstvy.

    Zastavit obtékání textu, když je vrstva skrytá

    Vyberte tuto volbu, pokud chcete, aby text na ostatních vrstvách natékal normálně, když je vrstva skrytá a obsahuje objekty s nastaveným obtékáním textu.

Přiřazení barvy vrstvy

Přiřazení barvy vrstvě usnadňuje rozlišení vrstev různých vybraných objektů. Pro každou vrstvu, která obsahuje vybraný objekt, se v panelu Vrstvy zobrazí čtvereček v barvě vrstvy. Na stránce se v barvě vrstvy zobrazují u každého objektu táhla výběru, ohraničovací rámeček, vstupní a výstupní body textu, hranice obtékání textu (je-li použita), okraje rámečku (včetně X zobrazeného v prázdném grafickém rámečku) a skryté znaky. Barevná vrstva se nezobrazuje u odznačeného rámečku, pokud jsou jeho okraje skryté.

  1. V panelu Vrstvy dvojitě klikněte na vrstvu nebo vyberte vrstvu a zvolte Volby vrstvy pro [název vrstvy].
  2. V poli Barva vyberte barvu nebo zvolte Vlastní, chcete-li určit vlastní barvu v systémovém dialogu pro výběr barvy.

Přidávání objektů do vrstev

Každý nový objekt je umístěn do cílové vrstvy, to znamená do vrstvy, u které se zobrazuje ikona pera v panelu Vrstvy. Nastavením vrstvy za cílovou ji také vyberete. Pokud je více vybraných vrstev, určení jedné z nich jako cílové nezmění výběr, ale nastavení cílové vrstvy mimo výběr odznačí ostatní vrstvy.

Objekty můžete do cílové vrstvy přidat jednou z následujících metod:

  • Vytvořením nových objektů pomocí textového nástroje nebo kreslicích nástrojů.

  • Importem, umístěním nebo vložením textu nebo grafiky.

  • Výběrem objektů v jiných vrstvách a pak jejich přesunutím do nové vrstvy.

    Na skrytou nebo zamknutou vrstvu nemůžete nakreslit ani umístit nový objekt. Když vyberete kreslicí nástroj, textový nástroj nebo umísťujete soubor, když je cílová vrstva skrytá nebo zamknutá, ukazatel se změní na ikonu přeškrtnuté tužky, když je umístěný nad oknem dokumentu. Buď zobrazte nebo odemkněte cílovou vrstvu nebo nastavte jako cíl viditelnou odemknutou vrstvu. Pokud zvolíte Úpravy > Vložit, když je cílová vrstva skrytá nebo zamknutá, výstražná zpráva vám nabídne možnost cílovou vrstvu zobrazit nebo odemknout.

Když kliknete na vrstvu v panelu Vrstvy, abyste ji nastavili jako cílovou vrstvu, u vrstvy, na kterou jste kliknuli, se objeví ikona pera a vrstva se také zvýrazní, což označuje, že je nastavena jako cílová vrstva.

Změna cílové vrstvy pro další nový objekt
Změna cílové vrstvy pro další nový objekt

Výběr, přemístění a kopírování objektů ve vrstvách

Standardně můžete vybrat kterýkoliv objekt v libovolné vrstvě. V panelu Vrstvy označují tečky vrstvy, které obsahují vybrané objekty. Barva výběru na vrstvě vám pomáhá identifikovat vrstvu objektu. Chcete-li zakázat výběru objektů v určité vrstvě, zamkněte ji.

  1. Proveďte libovolný z následujících úkonů:

    • Chcete-li ve vrstvě vybrat jednotlivé objekty, klikněte na trojúhelníkovou ikonu vedle vrstvy a zobrazte všechny objekty. Poté vyberte cílový objekt. Cílový objekt je rovněž možné přetáhnout do jiného umístění, aniž by byl vybrán.


      Přetažení objektů z jedné vrstvy do druhé

    • Chcete-li vybrat všechny objekty na určité vrstvě, podržte Alt (Windows) nebo Option (Mac OS) při kliknutí na vrstvu v panelu Vrstvy.

    • Chcete-li přemístit nebo zkopírovat objekty do jiné vrstvy, vyberte nástrojem pro výběr jeden nebo více objektů na stránce nebo vzoru dokumentu. V panelu Vrstvy přetáhněte barevnou tečku na pravé straně seznamu vrstev, abyste přesunuli vybrané objekty do jiné vrstvy.


      Přesunutí objektu do nové vrstvy

Poznámka:

Chcete-li přesunout vybrané objekty do zamknuté vrstvy, podržte Ctrl (Windows) nebo Command (Mac OS) při tažení barevné tečky. Chcete-li vybrané objekty zkopírovat do jiné vrstvy, podržte Alt (Windows) nebo Option (Mac OS) při tažení barevné tečky na pravé straně seznamu vrstev do jiné vrstvy. Chcete-li zkopírovat vybrané objekty do zamknuté vrstvy, podržte Ctrl+Alt (Windows) nebo Command+Option (Mac OS) při tažení barevné tečky.

Vkládání objektů do různých vrstev

Příkaz Vkládat do stejné vrstvy ovlivní, jak se objekty z jiných míst vloží do existujících vrstev.

Pokud je příkaz Vkládat do stejné vrstvy vybraný, objekty vyjmuté nebo zkopírované z jiných vrstev si zachovají přiřazení do svých vrstev při vložení do nové stránky nebo polohy. Pokud vložíte objekty do dokumentu, ve kterém nejsou stejné vrstvy jako v dokumentu, z kterého byly kopírovány, InDesign přidá názvy vrstev objektů do panelu Vrstvy v druhém dokumentu a vloží objekty do příslušných vrstev.

Pokud příkaz Vkládat do stejné vrstvy není vybraný, objekty vyjmuté nebo zkopírované z jiných vrstev se vloží společně do cílové vrstvy.

  1. Odznačte příkaz Vkládat do stejné vrstvy v nabídce panelu Vrstvy.

  2. Vyberte objekty a zvolte Úpravy > Kopírovat nebo Úpravy > Vyjmout.

  3. V panelu Vrstvy kliknutím na jinou vrstvu nastavte cílovou vrstvu.

  4. Zvolte Úpravy > Vložit.

Duplikování vrstvy

Když duplikujete vrstvu, kopírujete její obsah a nastavení. Duplikovaná vrstva se pak objeví nad původní vrstvou v panelu Vrstvy. Všechny duplikované rámečky, které byly zřetězené s jinými rámečky ve vrstvě, zůstávají zřetězené. Duplikované rámečky, jejichž originály byly zřetězené s rámečky v jiných vrstvách, již nebudou s těmito rámečky zřetězené.

  1. V panelu Vrstvy proveďte jeden z následujících úkonů:
    • Vyberte název vrstvy a zvolte Duplikovat vrstvu [název vrstvy] v nabídce panelu Vrstvy.

    • Přetáhněte název vrstvy a pusťte ho na tlačítko Nová vrstva.

Změna pořadí vrstev

Změnou uspořádání vrstev v panelu Vrstvy změníte pořadí překrývání vrstev v dokumentu. Změna uspořádání vrstev změní pořadí vrstev na každé stránce, nejen na cílové dvojstránce.

Můžete také změnit pořadí překrývání objektů na vrstvě změnou polohy objektů na vrstvě. Viz Uspořádání objektů v pořadí překrývání.

  1. V panelu Vrstvy přetáhněte vrstvu nahoru nebo dolů v seznamu. Můžete také přetáhnout více vybraných vrstev.
Změna uspořádání vrstev
Změna uspořádání vrstev

Zobrazení nebo skrytí vrstev a objektů

Vrstvu můžete kdykoli skrýt nebo zobrazit a můžete skrýt nebo zobrazit objekty na vrstvě. Skryté vrstvy a objekty nelze upravovat a neobjeví se na obrazovce ani při tisku. Skrytí vrstev může být užitečné, když chcete provést některé z následujících úkonů:

  • Skrýt části dokumentu, které nejsou určené k tomu, aby se objevily ve výsledném dokumentu.

  • Skrýt alternativní verze dokumentu.

  • Zjednodušit zobrazení dokumentu, aby se usnadnily úpravy jiných částí dokumentu.

  • Zabránit tisku vrstvy.

  • Urychlit překreslování obrazovky, když vrstva obsahuje grafiky s vysokým rozlišením.

Poznámka:

Standardně text dále obtéká i kolem objektů ve skrytých vrstvách. Chcete-li ignorovat nastavení obtékání textu pro skryté objekty, zvolte Volby vrstvy z nabídky panelu Vrstvy a pak vyberte volbu Zastavit obtékání textu, když je vrstva skrytá.

  1. Proveďte libovolný z následujících úkonů:
    • Chcete-li skrýt nebo zobrazit jednu vrstvu, klikněte v panelu Vrstvy na čtvereček zcela vlevo od názvu vrstvy, abyste skryli nebo zobrazili ikonu oka vrstvy.

    • Chcete-li zobrazit nebo skrýt jednotlivé objekty ve vrstvě, zobrazte kliknutím na popisný trojúhelník všechny objekty ve vrstvě a potom kliknutím na ikonu oka zobrazte nebo skryjte objekt.

    • Chcete-li skrýt všechny vrstvy kromě vybrané vrstvy nebo skrýt všechny objekty na vrstvě kromě vybraného objektu, vyberte volbu Skrýt ostatní v nabídce panelu Vrstvy. Nebo klikněte se stisknutou klávesou Alt (Windows) nebo Option (Mac OS) na čtvereček zcela vlevo na vrstvě nebo objektu, který má zůstat viditelný.

    • Chcete-li zobrazit všechny vrstvy, zvolte Zobrazit všechny vrstvy v nabídce panelu Vrstvy. Nebo klikněte se stisknutou klávesou Alt (Windows) nebo Option (Mac OS) na čtvereček zcela vlevo na viditelné vrstvě nebo objektu a zobrazte všechny vrstvy nebo všechny objekty na vrstvě.

Nastavení vrstvy jako netištěné

  1. Vyberte vrstvu v panelu Vrstvy.
  2. Z nabídky panelu Vrstvy zvolte Volby vrstvy.
  3. Chcete-li zabránit, aby se vrstva tiskla, vypněte volbu Tisknout vrstvu a pak klikněte na OK.

Poznámka:

Při tisku nebo exportu do PDF budete mít stále volbu, zda tisknout skryté a netisknutelné vrstvy.

Zamknutí nebo odemknutí vrstev

Zamknutí je užitečné, když chcete zabránit náhodným změnám ve vrstvě. U zamknuté vrstvy se v panelu Vrstvy zobrazuje ikona přeškrtnutého pera. Objekty v zamknutých vrstvách nelze přímo vybrat nebo upravovat; pokud ale objekty v zamknutých vrstvách mají atributy, které lze upravit nepřímo, mohou se změnit. Pokud například upravíte vzorek odstínu, objekty v zamknutých vrstvách, které používají tento vzorek ze Vzorníku, tato změna ovlivní. Podobně když vložíte řadu zřetězených textových rámečků do zamknutých i odemknutých vrstev, nezabrání zamknutí vrstvy změnám natékání textu v zamknutých vrstvách.

Pro zamykání a odemykání objektů ve vrstvě můžete také použít panel Vrstvy. Viz Zamknutí nebo odemknutí objektů.

  1. Proveďte libovolný z následujících úkonů:
    • Chcete-li zamknout nebo odemknout jednu vrstvu, klikněte v panelu Vrstvy na čtvereček v druhém sloupci zleva, abyste zobrazili (zamknuli) nebo skryli (odemknuli) vrstvu.

    • Chcete-li zamknout všechny vrstvy kromě cílové vrstvy, zvolte Zamknout ostatní v nabídce panelu Vrstvy. Nebo klikněte se stisknutou klávesou Alt (Windows) nebo Option (Mac OS) na čtvereček zcela vlevo na vrstvě, kterou chcete ponechat odemčenou.

    • Chcete-li odemknout všechny vrstvy, zvolte Odemknout všechny vrstvy v nabídce panelu Vrstvy.

Odstranění vrstev

Uvědomte si, že každá vrstva je přes celý dokument – zobrazuje se na každé stránce dokumentu. Před odstraněním vrstvy byste měli nejprve skrýt všechny ostatní vrstvy a ověřit na každé stránce dokumentu, že je bezpečné odstranit zbývající objekty.

  1. Proveďte libovolný z následujících úkonů:
    • Chcete-li odstranit vrstvu, přetáhněte vrstvu z panelu Vrstvy na ikonu Odstranit nebo zvolte Odstranit vrstvu [název vrstvy] z nabídky panelu Vrstvy.

    • Chcete-li odstranit více vrstev, podržte Ctrl (Windows) nebo Command (Mac OS) při kliknutí na vrstvy, které chcete vybrat. Potom přetáhněte vrstvy z panelu Vrstvy na ikonu Odstranit nebo zvolte Odstranit vrstvy z nabídky panelu Vrstvy.

    • Chcete-li odstranit všechny prázdné vrstvy, zvolte Odstranit nepoužité vrstvy v nabídce panelu Vrstvy.

    • Chcete-li odstranit objekt na vrstvě, vyberte objekt v panelu Vrstvy a potom klikněte na ikonu Odstranit.

Sloučení vrstev v dokumentu

Počet vrstev v dokumentu můžete omezit bez odstranění objektů sloučením vrstev. Když sloučíte vrstvy, objekty ze všech vybraných vrstev se přesunou do cílové vrstvy. Ze všech slučovaných vrstev zůstane v dokumentu pouze cílová vrstva, ostatní vybrané vrstvy se odstraní. Také můžete dokument převést do jedné vrstvy sloučením všech vrstev.

Poznámka:

Pokud sloučíte vrstvy obsahující různé objekty stránky a vzorové položky, vzorové položky se přesunou ve výsledné sloučené vrstvě dozadu.

  1. V panelu Vrstvy vyberte libovolnou kombinaci vrstev. Vybraná musí být i vrstva, kterou chcete použít jako cílovou vrstvu pro sloučení. Pokud chcete dokument sloučit do jedné vrstvy, vyberte všechny vrstvy v panelu.
  2. Kliknutím na kteroukoliv vybranou vrstvu ji nastavte jako cílovou, označenou ikonou pera.
  3. V nabídce panelu Vrstvy zvolte Sloučit vrstvy.

Můžete také sloučit stejně pojmenované vrstvy pro export knihy do PDF.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online