Přehled metod vybírání

V aplikaci InDesign můžete k vybírání použít následující metody a nástroje:

Nástroj pro výběr 

Umožňuje vybrat textové a grafické rámečky a pracovat s objekty pomocí jejich ohraničovacích rámečků. Když kliknete na nástroj pro zachycení obsahu (kobliha), který se zobrazuje při zastavení ukazatele myši nad obrazem, můžete manipulovat s obrazem v rámečku, aniž byste přepínali na nástroj pro přímý výběr.

Uchopení obsahu

Nástroj pro přímý výběr 

Umožňuje vybrat obsah rámečku, například umístěnou grafiku, nebo pracovat přímo s objekty, které je možné upravovat, jako jsou cesty, obdélníky nebo text, který byl převeden na obrysy.

Textový nástroj 

Umožňuje vybrat text v textovém rámečku, na cestě nebo v tabulce.

Podnabídka Vybrat

Umožňuje vybrat kontejner objektu (neboli rámeček) a jeho obsah. Podnabídka Vybrat také umožňuje vybrat objekty na základě jejich relativní polohy vzhledem k jiným objektům. Chcete-li zobrazit podnabídku Vybrat, zvolte Objekt > Vybrat. Můžete také kliknout na objekt pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac OS), abyste zobrazili kontextovou nabídku, a pak zvolit Vybrat.

Tlačítka pro výběr v ovládacím panelu

Umožňuje vybrat obsah pomocí tlačítka Vybrat obsah  nebo kontejner pomocí tlačítka Vybrat kontejner . Můžete také použít tlačítka Vybrat následující objekt nebo Vybrat předcházející objekt a tím vybrat následující či předcházející objekty ve skupině nebo dvojstránce.

Příkazy Vybrat vše a Odznačit vše

Umožňují vybrat nebo odznačit všechny objekty na dvojstránce a pracovní ploše, v závislosti na tom, který nástroj je aktivní a co je již vybrané. Zvolte Úpravy > Vybrat vše nebo Úpravy > Odznačit vše.

Poznámka:

Dvojitým kliknutím na objektu přepínáte mezi výběrem rámečku a objektu. Dvojitě klikněte na textový rámeček, chcete-li umístit textový kurzor a přepnout na textový nástroj.

Vybírání objektů

Objekt je libovolný tištěný prvek na stránce nebo na pracovní ploše, například cesta nebo importovaná grafika. Rámeček nebo cesta je tvar, který nakreslíte, nebo kontejner pro text nebo grafiku. Ohraničovací rámeček je obdélník s osmi táhly výběru, která představují svislé a vodorovné rozměry objektu. Dříve než budete moci objekt upravit, musíte ho vybrat pomocí nástroje pro výběr.

Objekt můžete v aplikaci InDesign vybrat dvěma způsoby:

Cesta s vybraným ohraničovacím rámečkem (vlevo), vybraná cesta (uprostřed) a cesta s vybraným kotevním bodem (vpravo)
  • Nástroj pro výběr  můžete použít k výběru ohraničovacího rámečku objektu pro provádění obecných úloh rozvržení, například nastavení polohy a velikosti objektů. Když vyberete obraz, můžete pomocí nástroje pro výběr vybrat, zda se vybere rámeček nebo obraz v rámečku.

Použití nástroje pro výběr k úpravě obrazů

A. Když přejíždíte myší přes obraz, zobrazí se nástroj pro zachycení obsahu. B. Kliknutím na nástroj pro zachycení obsahu se vybere obsah. C. Kliknutím mimo nástroj pro zachycení obsahu se vybere rámeček. 
  • Nástroj pro přímý výběr  můžete použít pro výběr obsahu kontejneru (například importované grafiky) nebo jednotlivých bodů na cestě a provádění úkonů, jako je změna velikosti importované grafiky, kreslení a úpravy cest nebo úpravy textu.

Poznámka:

Importovaná grafika je vždy obsažena v rámečku. Můžete vybrat grafiku i její rámeček, pouze grafiku nebo pouze rámeček. Rámeček a ohraničovací rámeček importované grafiky mohou mít různou velikost. Popis způsobu, kterým InDesign vyznačuje aktuální výběr, najdete v heslu Úpravy objektů pomocí grafických rámečků.

Vybraný ohraničovací rámeček (vlevo) a vybraná obdélníková cesta (vpravo)

U obdélníkových objektů může být obtížné určit rozdíl mezi ohraničovacím rámečkem objektu a vlastní cestou objektu. Ohraničovací rámeček se vždy zobrazuje s osmi velkými prázdnými kotevními body. Obdélníková cesta se vždy zobrazuje se čtyřmi malými kotevními body (které mohou být prázdné nebo plné).

Vybírání ohraničovacího rámečku

U libovolného objektu můžete vybrat jeho ohraničovací rámeček – obdélník představující vodorovné a svislé rozměry objektu (Pro seskupené objekty se ohraničovací rámeček zobrazuje jako čárkovaný obdélník). Ohraničovací rámeček se také nazývá kontejner. Ohraničovací rámeček umožňuje rychlé přesunutí, duplikování a změnu velikosti objektu, aniž byste museli použít jiný nástroj. Pro cesty ohraničovací rámeček usnadňuje práci s celým objektem, aniž by došlo k neúmyslné změně kotevních bodů, které určují tvar cesty.

Poznámka:

Pro přesnější přemísťování a změnu velikosti a pro ostatní úpravy, například natočení, použijte ovládací panel nebo panel Transformace.

  1. S nástrojem pro výběr proveďte jeden z následujících úkonů:
    • klikněte na objekt. Pokud je objekt nevyplněná cesta, klikněte na její okraj. Je-li objektem obraz, můžete vybrat ohraničující rámeček obrazu kliknutím na nástroj pro zachycení obsahu nebo můžete vybrat vyberte rámeček kliknutím mimo nástroj pro zachycení obsahu.

    • Tažením nakreslete tečkovaný rámeček výběru kolem části nebo celého objektu.

    • Je-li vybrán grafický objekt nebo vnořený obsah, klikněte na tlačítko Vybrat kontejner  na řídicím panelu.

Když vyberete nástrojem pro výběr jeden nebo více objektů, zobrazí se ohraničovací rámeček, který vyznačuje velikost objektu. Pokud se nezobrazí ohraničovací rámeček, když je objekt vybraný, možná jste vybrali objekt pomocí nástroje pro přímý výběr .

Jestliže kliknete na rámeček, ale ten se nevybere, může být rámeček zamknutou položkou, může být na zamknuté vrstvě nebo může být položkou vzorové stránky. Viz Nelze vybírat objekty.

Vybírání cesty nebo bodů na cestě

Cesty jsou v aplikaci InDesign určené pomocí kotevních bodů, koncových bodů a směrových úseček. Kotevní body a koncové body můžete vybrat pomocí nástroje pro přímý výběr.

Cesta s jedním vybraným bodem (vlevo) a s více vybranými body (vpravo)
  1. Pomocí nástroje pro přímý výběr  kliknutím vyberte cestu.

    Všimněte si, jak se nástroj změní, když je nad cestou  nebo nad bodem .

  2. Proveďte libovolný z následujících úkonů:
    • Chcete-li vybrat jednotlivý bod, klikněte na něj.

    • Chcete-li vybrat více bodů na cestě, stiskněte Shift a klikněte na jednotlivé body.

    • Chcete-li vybrat všechny body cesty najednou, klikněte na bod ve středu objektu nebo podržte stisknutou klávesu Alt (Windows) nebo Option (Mac OS) a klikněte na cestu. Pokud přímo vyberete libovolnou část objektu, příkaz Vybrat vše také vybere všechny body.

Vybírání textu uvnitř rámečku

  • Chcete-li vybrat text tažením, klikněte na textový rámeček textovým nástrojem. Objeví se textový kurzor.
  • Chcete-li vložit textový kurzor do textu, dvojitě klikněte na textový rámeček libovolným nástrojem pro výběr. InDesign automaticky přepne na textový nástroj.

Vybírání objektu uvnitř rámečku

  1. Proveďte libovolný z následujících úkonů:
    • klikněte na objekt nástrojem pro přímý výběr . Nástroj pro přímý výběr se automaticky změní na nástroj ručička při umístění nad grafický objekt uvnitř rámečku (ale ne při umístění nad objekt, který není grafický objekt, například nad cestu).

    • Je-li objekt v rámečku obrazem, vyberte obraz kliknutím na nástroj pro zachycení obsahu.

    Poznámka:

    Pokud si nepřejete, aby se při přejíždění myši přes obraz nástroj pro uchopení obsahu zobrazoval, vyberte Zobrazení > Netištěné > Skrýt nástroj pro uchopení obsahu.

    • Když je vybraný rámeček, zvolte Vybrat > Obsah z nabídky Objekt nebo z kontextové nabídky rámečku.
    • Když je vybraný rámeček, klikněte na tlačítko Vybrat obsah  v ovládacím panelu.
       

Vybírání více objektů

  • Chcete-li vybrat všechny objekty v obdélníkové oblasti, použijte nástroj pro výběr  a tažením vytvořte ohraničovací rámeček kolem objektů, které chcete vybrat.
  • Chcete-li vybrat nesousedící objekty, vyberte jeden objekt nástrojem pro výběr, a pak klikněte na další objekty se stisknutou klávesou Shift. Kliknutím na vybrané objekty tyto objekty odznačíte.
  • Chcete-li do výběru přidat více objektů, podržte Shift a tažením nástrojem pro výběr vytvořte ohraničovací rámeček kolem dalších objektů. Tažením přes vybrané objekty je odznačíte.

Poznámka:

Stejné postupy můžete použít, když chcete pomocí nástroje pro přímý výběr vybrat objekty vnořené dovnitř skupin nebo rámečků.

Vybírání nebo odznačování všech objektů

Chcete-li odznačit všechny objekty na dvojstránce a její pracovní ploše, zvolte Úpravy > Odznačit vše. Nebo nástrojem pro výběr nebo pro přímý výběr klikněte ve vzdálenosti nejméně 3 obrazové body od jakéhokoliv objektu.

Příkaz Vybrat vše má různý účinek v závislosti na situaci:

  • Pokud je aktivní nástroj pro výběr  , vyberou se všechny cesty a rámečky na dvojstránce a pracovní ploše a budou aktivní jejich ohraničovací rámečky.

  • Pokud je aktivní nástroj pro přímý výběr  a objekt je přímo vybraný, příkaz Vybrat vše vybere všechny kotevní body tohoto objektu, ale nevybere žádný další objekt. Pokud není vybráno nic, příkaz Vybrat vše vybere všechny objekty cest na dvojstránce a pracovní ploše.

  • Pokud je aktivní textový nástroj a v textovém rámečku je textový kurzor (vyznačený blikající svislou čarou), příkaz Vybrat vše vybere všechen text v textovém rámečku a ve všech textových rámečcích s ním zřetězených, ale nevybere žádné další objekty.

  • Pokud je vybraný objekt ve skupině, příkaz Vybrat vše vybere zbytek objektů ve skupině, ale žádné další objekty na dvojstránce.

  1. Vyberte nástroj, který chcete používat. Pokud chcete, vyberte objekt nebo umístěte textový kurzor do textového rámečku.
  2. Zvolte Úpravy > Vybrat vše.

    Poznámka:

    Příkaz Vybrat vše nevybere vnořené objekty, objekty umístěné ve skrytých nebo zamknutých vrstvách, položky vzorové stránky, které nejsou lokálně změněné na stránkách dokumentu, nebo objekty na jiných dvojstránkách a pracovních plochách (s výjimkou zřetězeného textu).

Nelze vybírat objekty

Nemožnost vybrat objekt může být způsobena následujícími problémy:

  • Objekt je překrytý jiným objektem ve stohu. Stiskněte klávesu Ctrl (Windows) nebo Command (Mac OS) a pak opakovaně klikejte na stejné místo, dokud nevyberete požadovaný rámeček nebo skupinu. Viz Vybírání vnořených nebo překrývajících se objektů.

  • Objekt je položkou vzorové stránky, jak naznačuje tečkovaný okraj. Chcete-li vybrat položku vzorové stránky, přejděte na vzorovou stránku aplikovanou na dokument anebo přepište lokálně položku vzorové stránky. Viz Lokální změna vzorové položky.

  • Objekt je zamknutý pomocí příkazu Objekt > Zamknout. Vyberte Objekt > Odemknout vše na dvojstránce. Viz Zamknutí nebo odemknutí objektů.

  • Objekt je na zamknuté vrstvě. Vrstva se odemkne, když kliknete na ikoně zamknutí vedle vrstvy v panelu Vrstvy. Viz Zamknutí nebo odemknutí vrstev.

Vybírání vnořených nebo překrývajících se objektů

Když rámeček obsahuje objekt, obsažený objekt se označuje jako vnořený uvnitř kontejneru neboli rámečku. Běžné jsou tři druhy vnoření: cesty uvnitř rámečků, rámečky uvnitř rámečků a skupiny uvnitř skupin. Vždy si dejte pozor, které objekty nebo atributy objektů potřebujete vybrat, které jsou právě vybrané, a které nástroje pro výběr použijete pro úpravu výběrů.

Výběry ve vnořených skupinách můžete nastavit pomocí nástrojů pro přímý výběr a pro výběr a také tlačítky Vybrat obsah a Vybrat kontejner. Znaky textu můžete kdykoliv vybrat pomocí textového nástroje, bez ohledu na to, jak hluboko je textový rámeček vnořený.

Vybírání vnořených, seskupených nebo překrývajících se objektů

Když vytvoříte vnořené objekty, nebo když umístíte objekty přes sebe v jedné vrstvě, může být pak obtížné vybrat určitý objekt nebo rámeček. Nabídka Objekt a kontextová nabídka obsahují volby pro vybírání, které vám usnadní výběr požadovaného objektu.

Vybírání vnořených objektů

A. Vybraný obraz B. Vybraná cesta rámečku obsahujícího obraz C. Vybraná skupina obsahující rámeček 

Poznámka:

Když otevřete panel Informace, můžete lépe zjistit, který objekt je vybraný.

  1. klikněte na vnořený nebo seskupený objekt nástrojem pro přímý výběr.
  2. Pokud nemůžete vybrat požadovaný objekt, použijte jeden z následujících postupů:
    • Zvolte Objekt > Vybrat a zvolte jednu z voleb výběru.
    • Umístěte ukazatel nad objekt, který chcete vybrat, a klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac OS), abyste zobrazili kontextovou nabídku. Pak zvolte Vybrat a požadovanou volbu výběru.

    Poznámka:

    Vybírání objektů pomocí příkazů kontextové nabídky není stejné jako použití příkazů nabídky Objekt > Vybrat. U kontextové nabídky je vybírání odvozeno od přesného bodu, na který jste kliknuli, abyste kontextovou nabídku zobrazili. To znamená, že by se vybral další objekt pod nebo nad aktuálním výběrem v místě kliknutí myší, a ne následující objekt v pořadí překrývání.

    • Stiskněte klávesu Ctrl (Windows) nebo Command (Mac OS) a pak opakovaně klikejte na stejné místo, dokud nevyberete požadovaný rámeček nebo skupinu. (Neklikněte na kotevní bod.)

    • Chcete všechny objekty ve skupině vybrat jednotlivě, použijte k výběru skupiny nástroj pro výběr, klikněte na tlačítko Vybrat obsah  na ovládacím panelu a poté zvolte možnost Úpravy > Vybrat vše.

  3. Chcete-li postupně procházet směrem dolů nebo nahoru v pořadí překrývání objektů, proveďte jeden z následujících úkonů:
    • klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac OS) a pak z kontextové nabídky Vybrat zvolte příslušnou volbu.

    • Opakovaně zvolte Objekt > Vybrat > Další objekt pod nebo Další objekt nad, dokud nevyberete požadovaný objekt. Když se dostanete na začátek nebo na konec pořadí překrývání, výběr se nezmění.

    • Stiskněte klávesu Ctrl (Windows) nebo Command (Mac OS) a klikněte na objekty, abyste je vybírali v pořadí překrývání odshora dolů. Když dosáhnete konce pořadí překrývání, výběr začne znovu nahoře. Chcete-li vybírat v pořadí překrývání odspodu, podržte stisknuté klávesy Alt+Ctrl (Windows) nebo Option+Command (Mac OS) a klikněte na překryté objekty nástrojem pro výběr.

    Poznámka:

    Volby kontextové nabídky jsou závislé na poloze ukazatele.

Vybírání více vnořených objektů

  1. klikněte na vnořený objekt nástrojem pro přímý výběr .
  2. Podržte stisknutou klávesu Shift při kliknutí na každý další vnořený objekt, který chcete vybrat.

Volby vybírání

Volby v podnabídce Vybrat (zvolte Objekt > Vybrat nebo zvolte Vybrat z kontextové nabídky) pomáhají při výběru překrývajících se, vnořených nebo seskupených objektů. Dostupnost některých voleb závisí na typu objektů, se kterými pracujete. Když použijete kontextovou nabídku, závisí vybraný objekt na poloze ukazatele.

První objekt nad

Vybere vrchní objekt v pořadí překrývaní.

Další objekt nad

Vybere objekt, který je bezprostředně nad současným objektem.

Další objekt pod

Vybere objekt, který je bezprostředně pod současným objektem.

Poslední objekt pod

Vybere spodní objekt v pořadí překrývaní.

Obsah

Vybere obsah vybraného grafického rámečku, nebo když je vybraná skupina, vybere objekt uvnitř skupiny. Můžete také kliknout na tlačítko Vybrat obsah v ovládacím panelu.

Kontejner

Vybere rámeček, ve kterém je uzavřený vybraný objekt, nebo když je vybraný objekt uvnitř skupiny, vybere skupinu, která objekt obsahuje. Můžete také kliknout na tlačítko Vybrat kontejner v ovládacím panelu.

Předcházející objekt / Následující objekt

Vybere další nebo předcházející objekt ve skupině, pokud je vybraný objekt součást skupiny, nebo pokud je vybraný neseskupený objekt, vybere další nebo předcházející objekt na dvojstránce. klikněte se stisknutou klávesou Shift, chcete-li přeskočit o pět úrovní. Chcete-li vybrat první nebo poslední objekt v pořadí překrývání, klikněte se stisknutou klávesou Ctrl (Windows) nebo Command (Mac OS).

Uspořádání objektů v pořadí překrývání

Překrývající se objekty se vrství na sebe v pořadí, ve kterém je vytváříte nebo importujete. Chcete-li změnit pořadí překrývání objektů, můžete použít podnabídku Uspořádat.

Panel Vrstvy také umožňuje určit pořadí překrývání objektů. Pořadí každé vrstvy v panelu Vrstvy určuje, zda se objekty ve vrstvě zobrazí před objekty nebo za objekty na jiných vrstvách. Pořadí objektů v každé vrstvě určuje pořadí překrývání těchto objektů ve vrstvě. Objekty lze v rámci vrstvy přetáhnout nebo ovládat překrývání v každé vrstvě pomocí příkazů nabídky Objekt > Uspořádat. Pokud jste nevytvořili žádné vrstvy, dokument obsahuje pouze jednu posloupnost objektů v jedné výchozí vrstvě. Objekty ve vzorech jsou v každé pojmenované vrstvě vzadu.

Poznámka:

Seskupení objektů může změnit jejich pořadí překrývání (vzhledem k objektům, které nebudou ve skupině).

  1. Vyberte objekt, který chcete posunout dopředu nebo dozadu v pořadí překrývání.
  2. Proveďte libovolný z následujících úkonů:
    • Chcete-li posunout vybraný objekt zcela dopředu nebo dozadu v pořadí překrývání, zvolte buď Objekt > Uspořádat > Zcela dopředu nebo Objekt > Uspořádat > Zcela dozadu.

    • Chcete-li posunout vybraný objekt před nebo za sousední objekt v pořadí překrývání, zvolte buď Objekt > Uspořádat > Posunout dopředu nebo Objekt > Uspořádat > Posunout dozadu.

    • V panelu Vrstvy klikněte na popisný trojúhelník vedle vrstvy a potom přetažením objektů v rámci vrstvy změňte jejich pořadí překrývání.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online