Learn what's new in the latest release of Photoshop CC.
Photoshop_CC_icon

The October 2018 release of Photoshop CC (version 20.0) rolls out exciting new features for designers, digital photographers, and illustrators. Read on for a quick introduction to these features and links to resources offering more information.


Märkus.

  • Beginning with the October 2018 release of Photoshop CC (version 20.0), the 32-bit version of Windows is no longer supported. For support with 32-bit drivers and plug-ins, use earlier versions of Photoshop. Links to prior version installers and updates.
  • With the new Auto-update feature, your Creative Cloud apps are now automatically upgraded whenever a new version is available. You can manage the update preferences using the Creative Cloud desktop app. Learn more.
  • If you're upgrading from an earlier version of Photoshop CC, see these considerations and tips.

Frame Tool for easy masking

Easily mask images by placing them into frames. Use the Frame Tool (K) to quickly create rectangular or elliptical placeholder frames. You can also convert any shape or text into frames and fill it with images.

Frame Tool for easy masking

To place an image into a frame, simply drag an Adobe Stock asset or a libraries asset from the Libraries panel or from your local disk — the image automatically scales to fit the frame. Content placed in frames is always placed as Smart Objects so that it can be scaled non-destructively.

For detailed information, see Place images into frames.

Content-Aware Fill reimagined

Powered by Adobe Sensei

A new, dedicated Content-Aware Fill workspace provides you an interactive editing experience to achieve seamless fill results. You can now choose which source pixels to use and rotate, scale, and mirror the source pixels thanks to Adobe Sensei technology. You also get a live full-resolution preview of the changes and an option to save the result to a new layer.

Content-Aware Fill workspace in Photoshop CC 2019

To launch the Content-Aware Fill workspace:

  1. Open an image in Photoshop. Using any selection tool, create an initial selection of the area you want to fill.
  2. From the menu bar, choose Edit > Content-Aware Fill.
In the Content-Aware Fill workspace, the document window displays the default sampling area as an overlay mask on the image. You can use the tools provided in the Tools panel (at the left of the screen) to modify the sampling area and your initial selection of the fill area. In the Content-Aware Fill panel (at the right of the screen), you can specify sampling options, fill settings, and output settings to get the desired fill result in the image. As you make changes, the Preview panel displays a live full-resolution preview of the output.

New multiple undo mode

You can now use Control + Z (Win) / Command + Z (Mac) to undo multiple steps in your Photoshop document, just like in other Creative Cloud apps. The new multiple undo mode is enabled by default.  

Use Control / Command + Z to undo multiple steps

With the new multiple undo mode, the Edit menu displays the following commands:

  • Undo: Moves one step back in the undo chain. Use the shortcut keys: Control + Z (Win) / Command + Z (Mac).
  • Redo: Moves one step forward. Use the shortcut keys: Shift + Control + Z (Win) / Shift + Command + Z (Mac).
  • Toggle Last State works the same as in the legacy undo mode. Use the shortcut keys: Control + Alt + Z (Win) / Command + Option + Z (Mac).

How do I switch back to the legacy undo shortcuts?

(Photoshop)

To switch back to the legacy undo mode in Photoshop, do the following:

  1. From the menu bar, choose Edit > Keyboards Shortcuts.
  2. In the Keyboard Shortcuts And Menus dialog, select Use Legacy Undo Shortcuts and click OK.
  3. Restart Photoshop.

(Adobe Camera Raw)

To switch back to the legacy undo mode in Adobe Camera Raw, do the following:

  1. From the menu bar in Photoshop, choose Edit > Preferences > File Handling.
  2. In the File Compatibility section, click Camera Raw Preferences.
  3. In the Camera Raw Preferences dialog, select Use Legacy Undo Shortcuts and click OK.
  4. Restart Photoshop.
The Edit menu also displays the name of the step that will be undone next to the Undo and Redo commands.
For example, Edit > Undo Edit Type.

The commands Step Forward and Step Backward have been removed from the Edit menu. These commands are still available from the fly-out menu  in the History panel. Additionally, the layer visibility changes are now undoable by default. When you click a visibility icon  in the Layers panel, a history state is created. You can control this behavior using the Make Layer Visibility Changes Undoable option from the History Options dialog, accessible from the fly-out menu in the History panel.

For related helpful information, see Undo and History.

Usability improvements

Reference Point hidden by default

While transforming items, you can now easily move items on the canvas. The reference point that appeared while transforming items is now hidden by default. You can select the Toggle Reference Point check box in the Options bar if you want the reference point to appear.

Toggle reference point

Double-click to edit text

You can now double-click a Type layer with the Move tool to quickly begin editing the text in your document. You do not need to switch tools anymore to edit text.  

Double-click to edit Type

For related helpful information, see Edit text.

Auto-commit

Efficiently crop, transform, and place or enter text with auto-commit. You no longer need to press Enter (Win) / Return (macOS) or click the Commit button in the Options bar to commit your changes.

When applying crop or transforming, perform any of the following actions to auto-commit your changes:

  • Select a new tool.
  • Click a layer in the Layers panel. (This action auto-commits changes and also selects the layer.)
  • Click outside the canvas area in the document window.
  • Click outside the bounding box in the canvas area.

When entering text in a Type layer, perform any of the following actions to auto-commit your changes:

  • Select a new tool.
  • Click a layer in the Layers panel. (This action auto-commits changes and also selects the layer.)

For related helpful information, see the following links:

Transform proportionally by default

Photoshop now transforms most layer types (such as pixel layers, type layers, bitmaps, Placed Smart Objects) proportionally by default. Shapes and paths, that is vectors, still transform non-proportionally by default. 

When transforming a layer, you no longer need to hold down the Shift key while dragging a corner handle to resize a selected layer to constrain its proportions. Anytime you drag a corner handle during transform and move it, the layer resizes proportionally. Holding down the Shift key now resizes non-proportionally when you drag a corner handle during transform.

To resize a layer proportionally during transform, do the following:

  1. Select the layer(s) you want to resize in the Layers panel.
  2. Press Command + T (Mac) / Control + T (Win). Alternatively, choose Edit > Free Transform.
  3. Drag a corner handle on the bounding box to resize the layer.
  4. Commit the changes.

How do I turn off the new proportional scaling by default behavior while transforming layers?

To revert to the legacy transform behavior, do the following:

  1. Use Notepad (Windows) or a text editor on Mac OS to create a plain text file (.txt).
  2. Type the text below in the text file:

    TransformProportionalScale 0

  3. (Windows) Save the file as "PSUserConfig.txt" to your Photoshop settings folder. [Installation Drive]:\Users\[User Name]\AppData\Roaming\Adobe\Adobe Photoshop CC 2019\Adobe Photoshop CC 2019 Settings\

    (macOS) Do the following:
    1. Save the file as "PSUserConfig.txt" to the desktop.
    2. Control-click PSUserConfig.txt saved at the desktop and choose Copy from the pop-up menu.
    3. In the Finder, choose Go > Go To Folder. In the Go To Folder dialog box, type ~/Library/Preferences/Adobe Photoshop CC 2019 Settings/
    4. Paste the copied file at this location.
  4. Restart Photoshop.

For related helpful information, see the following links:

Prevent accidental panel moves with Lock Workspace

Use the new Lock Workspace option to prevent accidentally moving workspace panels, particularly when you’re using Photoshop on a tablet/stylus. To access this option, choose Window > Workspace > Lock Workspace.

Lock Workspace option in Photoshop
Lock Workspace option in Photoshop

For more helpful information about the workspace options, see Workspace basics.

Live blend mode preview

You can now scroll over different blend mode options to see how they look on your image. Photoshop displays a live preview of blend modes on the canvas when you scroll over different blend mode options in the Layers panel and the Layer Style dialog.

Live blend mode preview
Scrolling over blend mode options in the Layers panel.

For related helpful information, see the following links:

Symmetry mode

Paint your brush strokes in a perfectly symmetrical pattern. While using the Paint Brush, Mixer Brush, Pencil, or Eraser tools, click the butterfly icon () in the Options bar. Choose from the several available types of symmetry - Vertical, Horizontal, Dual Axis, Diagonal, Wavy, Circle, Spiral, Parallel Lines, Radial, Mandala. As you paint, the strokes are reflected live across the line of symmetry, allowing you to easily create intricate symmetrical patterns.

Mandala artwork
Pattern created with Mandala symmetry. (Artwork designed by Mike Shaw.)

For detailed information, see Paint symmetrical patterns.

Color Wheel to choose colors

Use the Color Wheel to visualize the color spectrum and easily choose colors based on harmonies such as complementary colors and analogous colors. From the Color panel fly-out menu, choose Color Wheel.   

Use the Color Wheel to choose colors
Use the Color Wheel to choose colors

Home screen

Get started quickly with the Photoshop Home screen. Access it at any time to find out about new features, connect to learning content, and jump right to your open documents. Click the new Home icon  in the Options bar to access the Home screen at any point.

Photoshop Home screen
Photoshop Home screen

For more information, see Workspace basics.

Improved in-app learning

After completing an in-app tutorial (Learn panel), you can now use your own images to get the looks you want in less time.

Learn with your own images
Learn with your own images

Top customer-requested features

Distribute spacing (like Adobe Illustrator)

You can now distribute the spacing between the objects. Photoshop can already distribute objects by evenly spacing their center points. If your objects are different sizes, you now get an even spacing between them. For related helpful information, see Align and distribute layers.

Distribute spacing horizontally or vertically between objects
(Left) Distribute Spacing options in Photoshop. (Right) Spacing distributed horizontally between objects.

Math in number fields

You can also perform simple math in any input box that accepts numeric values. For example, you can now type in simple math operations like 200/2, which gets calculated as 100 and inputs that final value into the field. This is very useful when trying to quickly get to a multiple of a value, or divide something up. For more information, see Use simple math in number fields.  

Perform simple math in any numeric field in Photoshop
Image showing simple math in the Canvas Size dialog.

Ability to see long layer names

For long layer names, Photoshop now retains the beginning and end of the layer name and puts ellipses (...) in the middle of the name. Previously, the layer name used to get cut off at the end with ellipses (...).

Ability to see long layer names
Photoshop now puts ellipses (...) in the middle of long layer names.

Match Font now support Japanese fonts

You can now search Japanese fonts with Match Font. Using Adobe Sensei, Match Font allows you to detect text included in the selected area of an image and match it to licensed fonts on your computer or on Adobe Fonts, suggesting similar fonts. For more information, see Match Fonts.

Search Japanese fonts with Match Font.
Search Japanese fonts with Match Font.

Flip document view

Quickly flip your canvas horizontally. Choose View > Flip Horizontal.   

Lorem Ipsum placeholder text

Get 'Lorem Ipsum' as placeholder text while placing new type layers in your document. In Type preferences (Edit > Preferences > Type), select Fill New Type Layers With Placeholder Text.

Customize keyboard shortcuts for Select and Mask

You can now modify the shortcut keys for Select and Mask workspace. Choose Edit > Keyboards Shortcuts. In the Keyboard Shortcuts And Menus dialog, choose Taskspaces from the Shortcuts For menu. In the Taskspace command column, expand the Select and Mask set to edit the shortcuts as required. For related information, see Customize keyboard shortcuts.

Preference to increase UI size

Get more control when scaling the Photoshop UI, and adjust it independent of your other apps to get the font size just right. In the Interface preferences (Edit >Preferences > Interface), a new setting Scale UI To Font has been introduced. When you select this new setting, the entire Photoshop UI scales based on the UI Font Size drop-down value you've chosen - Tiny, Small, Medium, or Large.

Scale UI To Font setting in the Interface preferences
Scale UI To Font setting in the Interface preferences

Support for South East Asian scripts

Photoshop now includes the support for five new South East Asian languages, so your documents can include text in these scripts: Thai, Burmese, Lao, Sinhalese, and Khmer.

Märkus.

To use these languages properly on Windows, you must install the Language and Font packs for the particular language you want to use. For details, see Microsoft's Help documentation: Language Packs.

To create a document using one of these new languages, do the following:

  1. Choose Edit > Preferences > Type.
  2.  Select the Middle Eastern and South Asian option.
  3. Open a document.
  4. Create a Type layer.
  5. In the Character panel, set your Language to any of the new languages: Thai, Burmese, Lao, Sinhalese, or Khmer.
  6. Based on the language you select, set an appropriate font. For example, if you choose Thai language, set a Thai font such as Adobe Thai or Noto Sans Thai.
  7. Copy and paste the text composed in the language that you choose. If you have a language-specific keyboard set up, simply type the text.

For more information, see Composers for Asian scripts.

Modernized compositing engine

This release of Photoshop CC introduces a new compositing engine, which provides a more modern compositing architecture that is easier to optimize on all platforms (macOS, Windows, and iOS/mobile).

Camera Raw | New features

For details of new features introduced in Adobe Camera Raw, see What's new in Camera Raw.

What's changed

The CC Files tab provided in the Start workspace of earlier versions is no longer available. You can browse your assets by navigating to the Creative Cloud Files directory on your desktop. To open the Creative Cloud Files directory from the Creative Cloud desktop app, select Assets > Files and click Open Folder. See Browse, sync, and manage assets.

See töö on litsentseeritud Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported litsentsiga  Süsteemi Creative Commons tingimused ei kehti Twitter™-i ja Facebooki postitustele.

Juriidilised märkused   |   Privaatsuspõhimõtted veebis