Creación de una capa de cámara y cambio de los ajustes de la cámara

Las capas 3D se pueden ver desde cualquier ángulo y distancia mediante capas de cámara. Igual que en mundo real es más fácil mover las cámaras de un lado a otro de una escena que mover y girar la propia escena, frecuentemente es más fácil obtener diferentes vistas de una composición configurando una capa de cámara y moviéndola en una composición.

Los ajustes de la cámara se pueden modificar y animar para configurar la cámara de forma que coincida con la cámara y los ajustes reales utilizados para grabar material de archivo con el que está realizando la composición. También se pueden utilizar ajustes de la cámara para agregar comportamientos de cámara, desde desenfoque de profundidad de campo a panorámicas y travelins, a efectos y animaciones sintéticos.

Las cámaras solo afectan a las capas 3D y 2D a las que se haya aplicado un efecto con un atributo Cámara comp. Los efectos que tienen el atributo Cámara comp. permiten utilizar la cámara o las luces de la composición activa para ver o iluminar un efecto desde distintos ángulos para simular efectos 3D más sofisticados.

Puede elegir ver una composición a través de la cámara activa o a través de una cámara personalizada con nombre. La cámara activa es la cámara más alta del panel Línea de tiempo en el tiempo actual para el que se ha seleccionado el definidor Vídeo . La vista de la cámara activa es el punto de vista utilizado para crear el resultado final y las composiciones anidadas. Si no ha creado una cámara personalizada, la cámara activa coincide con la vista de composición predeterminada.

Todas las cámaras están enumeradas en el menú Vista 3D, en la parte inferior del panel Composición, accesible en cualquier momento.

Lo más sencillo suele ser ajustar una cámara al usar una de las vistas 3D personalizadas. Obviamente, no se puede ver la cámara para manipularla cuando se está mirando a través de la propia cámara.

Ejemplo de cámara
Ejemplo de cámara

A. Punto de interés B. Fotograma C. Cámara 

Creación de una capa de cámara

  1. Elija Capa > Nueva > Cámara, o bien, presione Ctrl + Alt + Mayús + C (Windows) o Comando + Opción + Mayús + C (Mac OS).

    Nota:

    De forma predeterminada, las nuevas capas comienzan al principio de la composición. Para que las capas nuevas comiencen en el momento actual, deseleccione la preferencia Crear capas en el tiempo de inicio de la composición (Editar > Preferencias > General (Windows) o After Effects > Preferencias > General (Mac OS)).

Cambio de ajustes de cámara

Puede modificar los ajustes de cámara en cualquier momento.

  1. Haga doble clic en la capa de la cámara en el panel Línea de tiempo o seleccione la capa y, a continuación, elija Capa > Ajustes de cámara.

Nota:

De forma predeterminada, se selecciona la opción de previsualización del cuadro de diálogo Ajustes de cámara. Esta opción muestra los cambios en la composición conforme se realizan en el cuadro de diálogo Ajuste de cámara.

Ajustes de la cámara

Puede cambiar los ajustes de cámara en cualquier momento; para hacerlo, haga doble clic en la capa en el panel Línea de tiempo o seleccione la capa y elija Capa > Ajustes de cámara.

Nota:

Seleccione Previsualización en el cuadro de diálogo Configuración de la cámara para ver los resultados en el panel Composición conforme modifica la configuración del cuadro de diálogo.

Nota:

Los tres aspectos que afectan a la profundidad del campo son la distancia focal, la apertura y las distancia de enfoque. La profundidad (pequeña) del campo es un resultado de la distancia focal larga, la distancia de enfoque corta y de una apertura mayor (valor para detener F más pequeño). Una menor profundidad del campo implica un resultado de desenfoque de profundidad de campo mayor. Lo contrario a una profundidad menor del campo es el enfoque profundo, lo que supone un menor desenfoque de profundidad de campo porque el enfoque es superior.  

Las propiedades de la cámara relacionadas con el desenfoque y la forma de la lente son Forma del iris, Rotación del iris, Redondez del iris, Proporción de píxeles del iris, Halo de difracción del iris, Resaltar ganancia, Umbral de resaltado y Saturación de resaltado.

Tipo

Cámara de un nodo o Cámara de dos nodos. Una cámara de un nodo se orienta alrededor de sí misma, mientras que una cámara de dos nodos tiene un punto de interés y se orienta alrededor de ese punto. El proceso para que una cámara sea de dos nodos es el mismo que para establecer la opción de orientación automática de una cámara (Capa > Transformar > Orientación automática) para orientarse hacia el punto de interés. (Consulte Opciones de orientación automática).

Nombre

El nombre de la cámara. De forma predeterminada, Cámara 1 es el nombre de la primera cámara que se crea en una composición; todas las cámaras posteriores se enumeran en orden ascendente. Seleccione nombres característicos para las distintas cámaras para que sea más fácil distinguirlas.

Ajuste preestablecido

El tipo de ajustes de cámara que desea emplear. El nombre de los ajustes preestablecidos está relacionado con las distancias focales. Cada ajuste preestablecido representa el comportamiento de una cámara de 35 mm con una lente de distancia focal determinada. Por tanto, el ajuste preestablecido también define el Ángulo de visión, el Zoom, la Distancia focal, Distancia de enfoque y los valores de apertura. El ajuste preestablecido de forma predeterminada es 50 mm. También puede crear una cámara personalizada y especificar nuevos valores para cualquiera de los ajustes.

Zoom

La distancia desde la lente al plano de imagen. En otras palabras, una capa a la distancia del Zoom aparece en su tamaño completo, una capa que es dos veces la distancia del Zoom aparece como la mitad de alta y ancha, etc.

Ángulo de visión

El ancho de la escena capturada en la imagen. Los valores Distancia focal, Tamaño de la película y Zoom determinan el ángulo de visión. Un ángulo de visión más ancho produce el mismo resultado que una lente de ángulo ancho.

Profundidad de campo

Aplica variables personalizadas a los ajustes Distancia de enfoque, Apertura, Detener F y Nivel de desenfoque. Con el uso de estas variables puede manipular la profundidad de campo para crear efectos de enfoque de cámara más realistas. (La profundidad de campo es el rango de distancia en que la imagen está enfocada. Las imágenes que sobrepasan este rango están desenfocadas.)

Distancia de enfoque

La distancia existente entre la cámara y el plano con un enfoque perfecto.

Nota:

Para bloquear el plano focal en el punto de interés de la cámara de tal modo que este punto se encuentre enfocado, añada esta expresión a la propiedad Distancia de enfoque: length(position, pointOfInterest)

Bloquear zoom

Hace que el valor de la Distancia de enfoque coincida con el valor de Zoom.

Nota:

Cuando se cambian los ajustes de las opciones Zoom o Distancia de enfoque en el panel Línea de tiempo, el valor de la Distancia de enfoque se desbloquea desde el valor Zoom. Si necesita cambiar los valores y desea que permanezcan bloqueados, utilice el cuadro de diálogo Ajustes de la cámara en lugar del panel Línea de tiempo. De forma alternativa, puede agregar una expresión a la propiedad Distancia de enfoque en el panel Línea de tiempo. Seleccione la propiedad Distancia de enfoque y elija Animación > Agregar expresión (MS Windows) o Añadir expresión (Mac OS) y, a continuación, arrastre la expresión icono espiral hasta la propiedad Zoom. (Consulte Conceptos básicos sobre expresiones).

Apertura

El tamaño de apertura de la lente. El ajuste Apertura también afecta a la profundidad de campo, si se aumenta la apertura se incrementa el desenfoque de la profundidad de campo. Cuando se modifica Apertura, los valores de Detener F cambian para que coincidan.

Nota:

En una cámara real, el aumento de la apertura también permite la entrada de más luz, lo que afecta a la exposición. Al igual que la mayoría de las aplicaciones de composición y animación 3D, After Effects ignora este resultado del cambio en los valores de apertura

Detener F

Representa la proporción entre la distancia focal y la apertura. La mayoría de las cámaras especifican el tamaño de apertura a través de la medida Detener F, por este motivo, muchos fotógrafos prefieren definir el tamaño de apertura en unidades Detener F. Cuando se modifica Detener F, Apertura cambia para que coincidan.

Nivel de desenfoque

La cantidad de desenfoque de la profundidad de campo en una imagen. Un ajuste de 100% crea un desenfoque natural en función de los ajustes de la cámara. Los valores inferiores reducen el desenfoque.

Tamaño de la película

El tamaño de la zona expuesta de la película, que está directamente relacionada con el tamaño de la composición. Cuando se modifica Tamaño de la película, el valor Zoom cambia para ajustarse a la perspectiva de una cámara real.

Distancia focal

La distancia existente entre el plano de la película y la lente de la cámara. En After Effects, la posición de la cámara representa el centro de la lente. Cuando se modifica Distancia focal, el valor Zoom cambia para ajustarse a la perspectiva de una cámara real. Además, los valores Ajuste preestablecido, Ángulo de visión y Apertura también cambian.

Unidades

Las unidades de medida en que se expresan los valores de ajuste de la cámara.

Medir tamaño de la película

Las dimensiones utilizadas para representar el tamaño de la película.

Nota:

Para obtener el mejor resultado, trabaje en 32 bpc con Alinear el espacio de trabajo activado en los ajustes del proyecto.

Comandos de cámara

After Effects dispone de comandos de cámara que se pueden utilizar por separado o con la función Crear rig 3D estéreo. Para utilizar los comandos de cámara, seleccione una capa de cámara y, a continuación, seleccione Capa > Cámara.

Vincular distancia de enfoque con punto de interés

Crea una expresión en la propiedad Distancia de enfoque de la capa de cámara seleccionada y define el valor de la propiedad a la distancia entre la cámara y su punto de interés.

Vincular distancia de enfoque con capa

Crea una expresión en la propiedad Distancia de enfoque de la capa de la cámara seleccionada para que sea la distancia entre la posición de la cámara y otra capa. Este método permite que el enfoque siga la otra capa automáticamente.

Establecer distancia de enfoque con capa

Define el valor de la propiedad Distancia de enfoque en ese momento a la distancia en ese momento entre la cámara y la capa seleccionada.

Recursos en línea sobre las cámaras

Para ver un tutorial de vídeo que muestra cómo crear y modificar una cámara y utilizar las herramientas de cámara, consulte el sitio web de Adobe.

Dale Bradshaw ofrece una secuencia de comandos y un proyecto de ejemplo para automatizar el aparejo de una cámara en el sitio web de Creative Workflow Hacks.

Mark Christiansen ofrece sugerencias y técnicas detalladas para el trabajo con cámaras en el capítulo “Virtual Cinematography in After Effects” (Cinematografía virtual en After Effects) perteneciente a After Effects Studio Techniques, en el sitio web Peachpit Press. En este capítulo se incluye información sobre la distorsión de lentes coincidentes, la realización de movimientos de cámara, la proyección de cámara (asignación de cámara), el uso del enfoque de bastidor, la creación de desenfoque roto, el uso del granulado y la selección de una velocidad de fotogramas para que coincida con la narración.

Trish y Chris Meyer proporcionan un tutorial para el uso de capas 3D, luces y cámaras en una sección en PDF de su libro After Effects Apprentice, en el sitio web Focal Press.

Andrew Kramer proporciona un tutorial en vídeo de dos partes en su sitio web Video Copilot donde se muestra la asignación de cámara básica y la proyección de cámara. En este tutorial, muestra cómo proyectar una imagen en capas 3D utilizando luces y propiedades de transmisión de luz.

Creación de una luz y cambio de ajustes

Una capa de luz puede afectar a los colores de la capa 3D sobre la que brilla, dependiendo de los ajustes de la luz y de las propiedades Opciones de material de las capas 3D. De manera predeterminada, cada luz está orientada a su punto de interés.

Las luces se pueden emplear para iluminar capas 3D y para proyectar sombras. Las luces se pueden utilizar para adaptarse a las condiciones de iluminación de la escena en la que se está realizando la composición o para crear unos resultados visuales más interesantes. Por ejemplo, las capas de luz se pueden usar para crear la apariencia de transmisión de luz a través de una capa de vídeo como si fuera una vidriera.

Se pueden animar todos los ajustes de una luz, excepto el tipo de luz y la propiedad Proyecta sombras.

Tipos de luz: Luz concentrada (superior izquierda); Punto (superior derecha); Paralelo (inferior izquierda); Ambiente (inferior derecha)
Tipos de luz: Luz concentrada (superior izquierda); Punto (superior derecha); Paralelo (inferior izquierda); Ambiente (inferior derecha)

A. Punto de interés B. Icono de luz 

Puede especificar a qué capas 3D desea que afecte una luz, designando la luz como capa de ajuste: sitúe la luz en el panel Línea de tiempo sobre las capas que desee iluminar. Las capas situadas sobre una capa de ajuste de luz en el orden de apilamiento de capas del panel Línea de tiempo no reciben la luz, independientemente de las posiciones de las capas en el panel Composición.

Creación de una luz

  1. Elija Capa > Nueva > Luz, o presione Ctrl + Alt + Mayús + L (Windows) o Comando + Opción + Mayús + L (Mac OS).

    La luz que se crea incluye el nombre del tipo de luz. Por ejemplo, si se añade una luz focal, esta se denomina “luz focal 1”.

    Si modifica el tipo de luz, el nombre del tipo de luz se cambiará automáticamente. El nombre de la luz se cambia si dicho nombre no se modifica, y únicamente si el tipo de luz no se ha modificado en el panel Línea de tiempo. Por ejemplo, si se cambia la “luz focal 1” a una luz puntual, After Effects modifica automáticamente el nombre de la luz a “luz puntual 1”.

    Nota:

    De forma predeterminada, las nuevas capas comienzan al principio de la composición. Para que las capas nuevas comiencen en el momento actual, deseleccione la preferencia Crear capas en el tiempo de inicio de la composición (Editar > Preferencias > General (Windows) o After Effects > Preferencias > General (Mac OS)).

Cambio de ajustes de luz

  1. Haga doble clic en una capa de luz en el panel Línea de tiempo o seleccione la capa y elija Capa > Ajustes de luz.

    Nota:

    Seleccione Previsualización en el cuadro de diálogo Configuración de la luz para ver los resultados en el panel Composición conforme modifica los ajustes del cuadro de diálogo.

Ajustes de luz

Tipo de luz

Paralelo emite luz direccional e ilimitada desde un origen infinitamente distante, aproximando la luz desde un origen como el sol. Luz concentrada emite luz desde un origen limitado por un cono, como los focos empleados en los decorados. Punto emite una luz ilimitada y omnidireccional, como los rayos que emite una bombilla. Ambiente no tiene origen, simplemente ayuda a aportar luminosidad general a la escena y no proyecta sombras.

Nota:

Debido a que la posición en el espacio de una luz ambiental no afecta a su influencia en las demás capas, la luz ambiental no tiene ningún icono en el panel Composición.

Intensidad

El brillo de la luz. Los valores negativos crean ausencia de luz. La ausencia de luz resta color a la capa. Por ejemplo, si una capa ya está iluminada, la creación de una luz direccional con valores negativos también orientada hacia esa capa, oscurece un área de la capa.

Color

El color de la luz.

Ángulo de cono

El ángulo del cono que rodea el origen de una luz, que determina la anchura del rayo a una distancia. Este control está activo únicamente si se selecciona Luz concentrada como tipo de luz. El ángulo de cono de una luz concentrada se indica mediante la forma del icono de luz en el panel Composición.

Nota:

En After Effects CS6 o versiones posteriores, se puede ampliar un cono de luz concentrada hasta el punto de interés.

Calado de cono

El suavizado del borde de una luz concentrada. Este control está activo únicamente si se selecciona Luz concentrada como tipo de luz.

Difuminación

Tipo de difuminación para una luz de punto, concentrada o paralela. La difuminación describe el modo en que una intensidad de la luz disminuye con la distancia.

Para obtener más información, tutoriales y recursos sobre la difuminación de luz, consulte este artículo en el sitio Web de Adobe.

Entre los tipos de difuminación se incluyen:

Ninguno

La iluminación no se reduce a medida que aumenta la distancia entre la capa y la luz.

Suave

Indica una difuminación lineal suave que comienza en el radio Inicio de difuminación y aumenta la longitud especificada mediante la Distancia de difuminación.

Cuadrado inverso fijado

Indica una difuminación físicamente precisa que comienza en el radio Inicio de difuminación y disminuye proporcionalmente al cuadrado inverso de la distancia.

Radio

Especifica el radio de difuminación desde una luz. Dentro de esta distancia, la luz es constante. Fuera de esta distancia, se difumina.

Distancia de difuminación

Especifica la distancia en que la luz se difumina desde la luz.

Proyecta sombras

Indica si el origen de la luz hace que la capa proyecte una sombra. La opción de material Acepta sombras debe estar activada para que una capa reciba sombras; es el valor predeterminado. La opción de material Proyecta sombras debe estar activada para que una capa proyecte sombras; no es el valor predeterminado.

Nota:

Presione Alt + Mayús + C (Windows) u Opción + Mayús + C (Mac OS) para conmutar la opción Proyecta sombras para las capas seleccionadas. Para ver las propiedades Opciones de material en el panel Línea de tiempo, presione AA

Oscuridad de la sombra

Define el nivel de oscuridad de la sombra. Este control está activo únicamente si se selecciona la opción Proyecta sombras.

Difusión de la sombra

Define la suavidad de la sombra en función de la distancia aparente entre esta y la capa que la proyecta. Los valores más altos crean sombras más suaves. Este control está activo únicamente si se selecciona la opción Proyecta sombras.

Recursos en línea sobre las luces

Eran Stern incluye un tutorial en vídeo en el sitio web Creative COW que muestra el uso de luces como capas de ajuste, para controlar de forma precisa a qué capas se aplican los efectos de diferentes luces.

Chris y Trish Meyer ofrecen sugerencias sobre las sombras y las luces en 3D en un artículo en el sitio web de ProVideo Coalition.

Trish y Chris Meyer proporcionan un tutorial para el uso de capas 3D, luces y cámaras en una sección en PDF de su libro After Effects Apprentice, en el sitio web Focal Press.

Chris y Trish Meyer proporcionan un tutorial en el sitio web Artbeats que muestra cómo utilizar las luces y las capas 3D para proyectar un proyecto en otras capas como, por ejemplo, en un muro.

Ajuste de una vista 3D o movimiento de una cámara, luz o punto de interés

Todas las capas de cámara y de luz tienen una propiedad Punto de interés que especifica el punto de la composición hacia el que está orientada la cámara o la luz. De manera predeterminada, el punto de interés se encuentra en el centro de la composición. Puede mover el punto de interés en cualquier momento.

Una cámara de un nodo ignora el punto de interés. (Consulte Ajustes de la cámara).

Para que una luz omita su punto de interés, seleccione una opción distinta de Orientar hacia el punto de interés en las opciones de Orientación automática de la luz. (Consulte Opciones de orientación automática).

Nota:

Al igual que todas las propiedades, las propiedades de luz de una cámara también se pueden modificar directamente en el panel Línea de tiempo.

Movimiento de una cámara, luz o punto de interés con las herramientas Selección y Rotación

  1. Seleccione una capa de cámara o de luz.
  2. Mediante la herramienta Selección o Giro, realice uno de los siguientes pasos:
    • Para mover la cámara o la luz y su punto de interés, coloque el puntero sobre el eje que desea ajustar y arrastre.

    • Para mover la cámara o la luz a lo largo de un único eje sin mover el punto de interés, presione Ctrl (Windows) o Comando (Mac OS) mientras arrastra el eje.

    • Para mover la cámara o la luz libremente sin mover el punto de interés, arrastre el icono de cámara o de luz.

    • Para mover el punto de interés, arrastre el icono de punto de interés .

Movimiento o ajuste de una cámara o una vista 3D de trabajo con las herramientas de cámara

Las propiedades Posición y Punto de interés de una capa de cámara se pueden ajustar utilizado la herramientas de cámara en el panel Composición.

Asimismo, estas herramientas se pueden emplear para ajustar una vista 3D de trabajo, una vista 3D que no está asociada a una capa de cámara. Las vistas 3D se pueden considerar como cámaras virtuales con las que se puede ver y previsualizar una composición. Entre las vistas 3D de trabajo se incluyen las vistas personalizadas y las vistas ortográficas fijas (Frente, Izquierda, Superior, Atrás, Derecha o Inferior). Las vistas 3D de trabajo resultan útiles para colocar y previsualizar elementos en una escena 3D. Si se utiliza una herramienta de cámara para ajustar una vista 3D de trabajo, los valores de propiedad de la capa no se verán afectados.

Una vez modificada la vista 3D, puede restablecerla seleccionando Vista > Restablecer vista 3D.

En las vistas ortográficas fijas no se puede utilizar la herramienta Cámara orbital.

Para obtener información sobre la selección y el uso de las vistas 3D, consulte Selección de una vista 3D.

  1. En el menú Vista 3D situado en la parte inferior del panel Composición, seleccione la vista 3D de cámara para ajustar.
  2. Active una herramienta de cámara.

    Para ello, selecciónela en el panel Herramientas o presione C para recorrer las diferentes herramientas. La forma más sencilla de cambiar entre las herramientas de cámara es seleccionar la Herramienta de cámara unificada y usar los botones de un ratón de tres botones.

    Cámara orbital

    Gira la cámara o vista 3D moviéndose alrededor del punto de interés. (Para activar esta herramienta temporalmente cuando la herramienta de cámara unificada esté seleccionada, mantenga presionado el botón izquierdo del ratón.)

    Nota:

    Al presionar Mayús y arrastrar con la herramienta de cámara unificada seleccionada, se activa temporalmente la herramienta Cámara orbital y se restringe la rotación hacia un eje.

    Seguir cámara XY

    Ajusta la vista 3D o la cámara horizontal o verticalmente. (Para activar esta herramienta temporalmente cuando la herramienta de cámara unificada esté seleccionada, mantenga pulsado el botón central del ratón.)

    Rastrear cámara Z

    Ajusta la cámara o vista 3D a lo largo de la línea hacia el punto de interés. Si está utilizando una vista ortográfica, esta herramienta ajusta la escala de la vista. (Para activar esta herramienta temporalmente cuando la Herramienta de cámara unificada esté seleccionada, mantenga presionado el botón derecho del ratón.)

  3. Arrástrela al panel Composición. Se puede continuar una operación de arrastre fuera del panel una vez se haya comenzado a arrastrar dentro del panel.

Una vez modificada la vista 3D, puede restablecerla seleccionando Vista > Restablecer vista 3D.

Movimiento o ajuste de una cámara o una vista 3D de trabajo para ver las capas

También se puede mover una cámara o ajustar una vista 3D para ver las capas seleccionadas o todas las capas. After Effects cambia el punto de vista y la dirección para incluir las capas que se han seleccionado.

  • Para ajustar una vista 3D o mover una cámara para ver las capas seleccionadas, seleccione Vista > Ver las capas seleccionadas.
  • Para ajustar una vista 3D o mover una cámara para ver todas las capas, seleccione Vista > Ver todas las capas.

Para conocer los métodos abreviados de teclado de estos comandos, consulte Capas 3D (métodos abreviados de teclado).

Sugerencias y recursos en línea sobre el movimiento y animación con cámaras y luces

Antes de mover una cámara, seleccione una vista distinta a Cámara activa. Si se está utilizando la vista de cámara activa, se está viendo a través de la cámara, lo que dificulta el manejo.

De forma predeterminada, una estructura metálica de la cámara solo es visible cuando se selecciona la cámara. Para mostrar siempre la estructura metálica de la cámara, defina las opciones de vista para el panel Composición (Vista > Opciones de vista). (Consulte Mostrar u ocultar los controles de capa en el panel Composición).

Al trabajar con una capa de luz o cámara, cree una capa de objeto nulo y utilice una expresión para vincular la propiedad Punto de interés de la cámara o luz con la propiedad Posición de la capa nula. A continuación, puede animar la propiedad Punto de interés moviendo el objeto nulo. A menudo es más fácil seleccionar y ver un objeto nulo que seleccionar y ver el punto de interés.

En After Effects hay un nuevo comando de cámara, “Crear giro nulo”. Asocia la capa de cámara seleccionada con una nueva capa nula. La nueva capa nula se cambia de nombre, en función del nombre de la cámara añadido a Giro nulo

Trish y Chris Meyer muestran cómo utilizar el comando de cámara Crear giro nulo en este tutorial de vídeo de Adobe TV.

Para ver un tutorial de vídeo que muestra cómo crear y modificar una cámara y utilizar las herramientas de cámara, consulte el sitio web de Adobe.

Trish y Chris Meyer proporcionan un tutorial para el uso de capas 3D, luces y cámaras en una sección en PDF de su libro After Effects Apprentice, en el sitio web Focal Press.

Mark Christiansen ofrece sugerencias y técnicas detalladas para el trabajo con cámaras en el capítulo “Virtual Cinematography in After Effects” (Cinematografía virtual en After Effects) perteneciente a After Effects Studio Techniques, en el sitio web Peachpit Press. En este capítulo se incluye información sobre la distorsión de lentes coincidentes, la realización de movimientos de cámara, la proyección de cámara (asignación de cámara), el uso del enfoque de bastidor, la creación de desenfoque roto, el uso del granulado y la selección de una velocidad de fotogramas para que coincida con la narración.

Rich Young ofrece un conjunto de expresiones en su sitio web AE Portal (en inglés) que utilizan el método toWorld para vincular una cámara y luz a una capa con el efecto Esfera CC.

Andrew Devis de Creative COW ha creado una serie de tres tutoriales sobre la animación de cámaras:

Este vídeo de Video2brain muestra el comando para crear un giro de cámara nulo.

Propiedades de las opciones de material

Las capas 3D tienen propiedades Opciones de material, que determinan cómo interactúa una capa 3D con la luz y la sombra.

Proyecta sombras

Especifica si una capa proyecta sombras sobre otras capas. La dirección y el ángulo de las sombras están determinados por la dirección y el ángulo de los orígenes de la luz. Defina la opción Proyecta sombras en Solo si desea que la capa sea invisible pero que proyecte una sombra.

Nota:

Utilice el ajuste Solo y un ajuste Transmisión de luz distinto de cero para proyectar los colores de una capa invisible sobre otra capa. Steve Holmes incluye un tutorial de vídeo en el sitio web Artbeats en el que muestra cómo utilizar capas con la opción Proyectar sombras establecida para solo proyectar sombras de formas específicas en una escena 3D.

Transmisión de la luz

Porcentaje de luz que brilla a través de la capa, proyectando los colores de la capa sobre otras capas como una sombra. 0% especifica que ninguna luz pasa a través de la capa, proyectando una sombra negra. 100% especifica que los valores completos de los colores de la capa que proyecta sombra se proyectan en la capa que la acepta.

Nota:

Utilice la transmisión parcial de luz para crear la apariencia de la luz cuando atraviesa una vidriera.

Acepta sombras

Especifica si la capa muestra sombras proyectadas sobre ella por otras capas. La opción “Solo” en Acepta sombras permite procesar solo una sombra en una capa.

Acepta luces

Especifica si la luz que la alcanza afecta al color de una capa. Este ajuste no afecta a las sombras.

Ambiente

Reflectividad ambiente (no direccional) de la capa. 100% especifica la mayor reflectividad; 0% especifica que no existe reflectividad ambiente.

Difuso

Reflectividad difusa (omnidireccional) de la capa. Cuando se aplica la reflectividad difusa en una capa, es como si esta se cubriera con una hoja de plástico mate. La luz que cae sobre esta capa se refleja de la misma forma en todas las direcciones. 100% especifica la mayor reflectividad; 0% especifica que no existe reflectividad difusa.

Especular

Reflectividad especular (direccional) de la capa. La luz especular se refleja desde la capa como si fuera un espejo. 100% especifica la mayor reflectividad; 0% especifica que no existe reflectividad especular.

Brillar

Determina el tamaño del resaltado especular. Este valor solo está activo cuando el ajuste Especular es mayor que cero. 100% especifica una reflexión con un pequeño resaltado especular. 0% especifica una reflexión con un gran resaltado especular.

Metal

La contribución del color de la capa al color del resaltado especular. 100% especifica que el color del resaltado es el color de la capa. Por ejemplo, con un valor de Metal de 100%, la imagen de un anillo de oro refleja luz dorada. 0% especifica que el color del resaltado especular es el color del origen de la luz. Por ejemplo, una capa con un valor de Metal de 0% bajo una luz blanca tiene un resaltado blanco.

Especificar la resolución que se utilizará en el procesamiento de sombras

El plugin de procesamiento 3D avanzado (predeterminado) se utiliza para procesar composiciones que contienen capas 3D de intersecado. Para procesar sombras, el plugin utiliza mapas de sombras, que son imágenes procesadas desde el punto de vista de cada fuente de luz. Normalmente, la resolución de la sombra se calcula de forma automática en función de la resolución de la composición y los ajustes de calidad de las capas. Si la resolución normal no crea la calidad que desea o se procesa con demasiada lentitud, puede ajustar la resolución del mapa de sombras. Por ejemplo, si las sombras se desenfocan y la opción del material Difusión de la sombra se define como 0, aumente la resolución del mapa de sombras. O, si las sombras se procesan con demasiada lentitud, reduzca la resolución del mapa de sombras.

Cuando una capa con proyección de sombras se cruza con otra capa, a veces existe un pequeño espacio detrás de la intersección donde se supone que hay una sombra. Para reducir el tamaño de este espacio, aumente la resolución del mapa de sombras.

3D estereoscópico

Puede crear vídeos 3D estereoscópicos con Adobe After Effects.

Para ver tutoriales, detalles y recursos sobre 3D estereoscópico, consulte este artículo en el sitio web de Adobe.

Para obtener una descripción general del flujo de trabajo 3D estereoscópico en After Effects, consulte Información general sobre 3D estereoscópico en After Effects.

Mark Christiansen muestra la composición de material de archivo 3D estereoscópico (con un clipgratuitode Art Beats).

Rig de cámara 3D estereoscópico

After Effects tiene un comando de menú Crear rig 3D estéreo que le permite convertir una composición 3D en una composición 3D estereoscópica. La función Rig 3D estéreo crea todos los elementos por sí misma, incluyendo el efecto Gafas 3D.

Para crear un rig de cámara 3D estereoscópico, cree primero una composición con elementos 3D. Una composición que contiene elementos, como una precomposición 3D contraída o elementos 3D en la composición misma, funciona bien. Si ya está utilizando una cámara, puede seleccionarla al crear el rig de cámara 3D estereoscópico. Si no se ha seleccionado ninguna cámara, se creará una cámara nueva, denominada Cámara maestra. Seleccione Capa > Cámara > Crear rig 3D estéreo. El rig solo funciona con cámaras de dos nodos.

El rig se produce creando una cámara maestra o utilizando la cámara seleccionada existente en la composición. Hay composiciones de ojo izquierdo [comparar Ojo izquierdo] y ojo derecho [comparar Ojo derecho]. Cada composición tiene una cámara vinculada a la cámara maestra, la composición original anidada en ella y una composición 3D estéreo de salida [comparar 3D Estéreo]. La composición 3D estéreo de salida anida las composiciones de ambos ojos y contiene una capa denominada Controles 3D estéreo. Esta capa contiene un efecto Controles 3D estéreo para controlar el rig y un efecto Gafas 3D que combina las composiciones de los ojos derecho e izquierdo en una imagen estéreo. (Consulte Efecto Gafas 3D).

Nota:

El efecto Controles 3D estéreo forma parte del rig 3D estéreo y no reside en el panel Efectos y ajustes preestablecidos.

El efecto Controles 3D estéreo cuenta con los siguientes ajustes para Separación de la cámara y Convergencia:

Configuración

Centro sitúa la cámara izquierda y derecha a cada lado de la cámara maestra. Héroe izquierda sitúa la cámara izquierda en el mismo punto que la cámara maestra con la cámara derecha a la derecha. A la inversa, Héroe derecha sitúa la cámara derecha en la posición de la cámara maestra con la cámara izquierda a la izquierda.

Profundidad de escena estéreo

Controla la separación interaxial entre las cámaras como porcentaje de la anchura de la composición. Así, si se cambia el tamaño de la composición, la separación se mantiene constante. Este ajuste empieza con un valor bajo de 3% para que el efecto sea sutil. Normalmente, este valor no tiene que aumentarse a más de 14%-30% para material de archivo de 3D en buenas condiciones. No obstante, puede ser mayor según el contenido de la escena (si los objetos están muy cerca los unos de los otros) y según el campo visual de la cámara, por ejemplo.

Nota:

Los cambios en este valor afectan a la profundidad a la que entra y sale de la escena el 3D estéreo. Si el valor es demasiado alto, puede causar fatiga ocular.  

Convergencia de cámaras

Cuando están desconectadas, las cámaras permanecen paralelas a la cámara maestra pero con la posición central en cualquier lado. Cuando están conectadas, la posición permanecerá desplazada. No obstante, el punto de interés de las cámaras izquierda y derecha se une en la ubicación basada en las dos propiedades siguientes.

Convergencia en y Desplazam. Z de convergencia

Determina la distancia Z a la que la pantalla parece estar de la cámara cuando se mira a través de las gafas 3D. Los elementos que estén más alejados en el espacio Z aparecerán empujados en la pantalla y los que estén más cerca parecerá que salgan de la pantalla. Cuando se trabaje sin marcar la casilla de verificación de convergencia de cámaras y las cámaras estén paralelas, si se cambia la convergencia de la escena, el efecto será el mismo que cambiar el desplazamiento Z. En ese caso, use el modo Diferencia para definir elementos diferentes de la escena en el espacio de la pantalla. (Consulte Efecto Gafas 3D).

Introducción a 3D estereoscópico

Si trabaja con 3D estereoscópico, no necesita un televisor 3D. Por ejemplo, puede usar gafas anaglifo 3D (cian y rojo) y ver el material de archivo 3D estereoscópico en el panel Composición. No obstante, también puede usar un televisor 3D para editar en directo con un televisor 3D y gafas con obturador activo. Para este flujo de trabajo, necesitará varios elementos antes de empezar:

  • Un monitor o televisor que admita la visualización estereoscópica 3D.
  • Gafas para ver televisión 3D estereoscópica.

Nota:

Para este flujo de trabajo, use gafas de obturador activo que requieran un dispositivo emisor. Asegúrese de usar las gafas recomendadas por el fabricante del televisor.

  • Material de archivo estereoscópico o una composición 3D.

Cuando tenga estos elementos, haga lo siguiente:

  1. Conecte el televisor 3D al equipo con un cable HDMI (o DVI si HDMI no está disponible).

  2. Cree una composición 3D en After Effects. Compruebe que el tamaño de la composición coincida con la resolución actual de su monitor de salida.

  3. Cree un nuevo panel Composición para su composición 3D estéreo. Bloquee la composición y arrástrela al monitor de TV 3D.

  4. Compruebe que el panel Composición esté definido en 100%.

  5. Escriba Control + \(barra inversa) dos veces para establecer la composición en pantalla completa para TV 3D. Defina las dimensiones de la composición y las de la TV 3D para que coincidan.

  6. Cambie la vista 3D del efecto Gafas 3D a uno de los valores siguientes:

    • Par estéreo

    • Superior inferior

    • Entrelazado

  7. Active el modo 3D de su TV 3D y haga coincidir el formato con el que se definió para la Vista 3D del efecto Gafas 3D. (La mayoría de televisores 3D admiten Par estéreo y Superior inferior.)

  8. Póngase las gafas 3D y edite la composición en 3D estereoscópico verdadero.

Sugerencias sobre 3D estereoscópico

  • Si trabaja con material de archivo 3D estereoscópico en el panel Composición y no dispone de un televisor 3D, puede trabajar con el formato anaglifo. Para este flujo de trabajo de 3D estereoscópico, lo mejor son gafas 3D anaglifo cian y rojo ordinarias.

  • Aumente o disminuya la Profundidad de escena estéreo para cambiar la sensación de profundidad del entorno 3D.

  • Active Convergencia de cámaras y cambie el Desplazam. Z de convergencia para mover diferentes objetos detrás y delante de la pantalla. Los objetos que estén más cercanos a la cámara que el desplazamiento Z aparecerán delante de la pantalla; los objetos que estén más alejados, aparecerán detrás.

  • Puede hacer coincidir la profundidad de campo de su composición con la convergencia de la cámara estereoscópica mediante una de las acciones siguientes:

    • Cuando utilice “Vincular distancia de enfoque con punto de interés” en la cámara maestra y las cámaras converjan para el rig, la profundidad de campo y la convergencia de 3D estereoscópico coincidirán.

    • Si quiere variar la profundidad del campo durante la grabación, puede animar la distancia de enfoque de la cámara maestra. A continuación, defina el punto de convergencia para que converja a partir de la “Posición de cámara” y defina una expresión que vincule el desplazamiento Z de convergencia con la Distancia de enfoque de la cámara maestra

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea