Guía del usuario Cancelar

Dynamic Link y After Effects

  1. Guía del usuario de After Effects
  2. Versiones beta
    1. Descripción general del programa beta
    2. Comunidad beta de After Effects
    3. Funciones de la versión beta
      1. Panel Propiedades (beta)
      2. Capas mate de pista de selección (Beta)
      3. Codificación H.264 nativa (Beta)
  3. Introducción
    1. Introducción a After Effects
    2. Novedades de After Effects 
    3. Notas de la versión | After Effects
    4. Requisitos del sistema para After Effects
    5. Métodos abreviados de teclado en After Effects
    6. Formatos de archivo admitidos | After Effects
    7. Recomendaciones de hardware
    8. After Effects para Apple Silicon
    9. Planificación y configuración
    10. Configuración e instalación
  4. Espacios de trabajo
    1. Elementos generales de la interfaz de usuario
    2. Familiarización con la interfaz de After Effects
    3. Flujos de trabajo
    4. Espacios de trabajo, paneles y visores
  5. Proyectos y composiciones
    1. Proyectos
    2. Conceptos básicos sobre composiciones
    3. Precomposición, anidamiento y preprocesamiento
    4. Ver información de rendimiento detallada con el Perfilador de composición
    5. Procesador de composición de Cinema 4D
  6. Importación de material de archivo
    1. Preparación e importación de imágenes fijas
    2. Importación desde After Effects y Adobe Premiere Pro
    3. Importación e interpretación de vídeo y de audio
    4. Preparación e importación de archivos de imagen 3D
    5. Importación e interpretación de elementos de material de archivo
    6. Uso de elementos de material de archivo
    7. Detección de puntos de edición con Detección de edición de escena
    8. Metadatos XMP
  7. Texto y gráficos
    1. Texto
      1. Formato de caracteres y el panel Carácter
      2. Efectos de texto
      3. Creación y edición de capas de texto
      4. Aplicación de formato a párrafos y el panel Párrafo
      5. Extrusión de capas de texto y formas
      6. Animación del texto
      7. Ejemplos y recursos para animación de texto
      8. Plantillas de texto interactivo
    2. Gráficos animados
      1. Trabajar con plantillas de gráficos animados en After Effects
      2. Uso de expresiones para crear listas desplegables en plantillas de gráficos animados
      3. Trabajo con propiedades esenciales para crear plantillas de gráficos animados
      4. Reemplazo de imágenes y vídeos en plantillas de gráficos animados y propiedades esenciales
  8. Dibujo, pintura y trazados
    1. Descripción general de las capas de forma, trazados y gráficos vectoriales
    2. Herramientas de pintura: Pincel, Tampón de clonar y Borrador
    3. Estrechar trazos de forma
    4. Atributos de forma, operaciones de pintura y operaciones de trazado para capas de forma
    5. Uso del efecto de forma Desplazar trazados para modificar formas
    6. Creación de formas
    7. Creación de máscaras
    8. Elimine objetos de sus vídeos desde el panel Relleno según el contenido
    9. Pincel tipo rotoscopia y Perfeccionar mate
  9. Capas, marcadores y cámara
    1. Selección y organización de capas
    2. Modos de fusión y estilos de capas
    3. Capas 3D
    4. Propiedades de capa
    5. Creación de capas
    6. Administración de capas
    7. Marcadores de capa y marcadores de composición
    8. Cámaras, luces y puntos de interés
  10. Animación, fotogramas clave, seguimiento del movimiento y efecto de clave
    1. Animación
      1. Conceptos básicos sobre animaciones
      2. Animación con herramientas de marioneta
      3. Administración y animación de trazados de formas y máscaras
      4. Animación de formas de Sketch y Capture con After Effects
      5. Herramientas de animación varias
      6. Trabajo con animación basada en datos
    2. Fotograma clave
      1. Interpolación de fotogramas clave
      2. Ajuste, selección y eliminación de fotogramas clave
      3. Edición, desplazamiento y copia de fotogramas clave
    3. Seguimiento de movimiento
      1. Seguimiento y estabilización del movimiento
      2. Seguimiento de caras
      3. Seguimiento de máscara
      4. Referencia de máscara
      5. Velocidad
      6. Ampliación del tiempo y reasignación del tiempo
      7. Unidades de visualización de tiempo y código de tiempo
    4. Incrustación
      1. Incrustación
      2. Efectos de incrustación
  11. Transparencia y composición
    1. Descripción general y recursos sobre composición y transparencia
    2. Canales alfa y mates
  12. Ajuste del color
    1. Conceptos básicos sobre colores
    2. Gestión de color
    3. Efectos de corrección de color
  13. Ajustes preestablecidos de animación y efectos
    1. Información general de efectos y ajustes preestablecidos de animación
    2. Lista de efectos
    3. Efectos de simulación
    4. Efectos de Estilizar
    5. Efectos de audio
    6. Efectos de distorsión
    7. Efectos de perspectiva
    8. Efectos de canal
    9. Efectos de generación
    10. Efectos de transición
    11. El efecto Reparación de obturación de desplazamiento
    12. Efectos Desenfocar y Enfocar
    13. Efectos de canal 3D
    14. Efectos de utilidad
    15. Efectos mate
    16. Efectos Ruido y Granulado
    17. Efecto Mejora de conservación de detalles
    18. Efectos obsoletos
  14. Expresiones y automatización
    1. Expresión
      1. Conceptos básicos sobre expresiones
      2. Comprensión del lenguaje de expresión
      3. Uso de los controles de expresión
      4. Diferencias de sintaxis entre los motores de expresiones de JavaScript y ExtendScript heredado
      5. Edición de expresiones
      6. Errores de expresiones
      7. Uso del editor de expresiones
      8. Uso de expresiones para editar y acceder a las propiedades de texto
      9. Referencia del lenguaje de expresión
      10. Ejemplos de expresiones
    2. Automatización
      1. Automatización
      2. Scripts
  15. Vídeo inmersivo, RV y 3D
    1. Construcción de entornos de RV en After Effects
    2. Aplicar efectos de vídeo envolvente
    3. Herramientas de composición para vídeos de VR/360
    4. Seguimiento del movimiento de la cámara 3D
    5. Trabajo en espacios de diseño 3D
    6. Herramientas de transformación Gizmo 3D
    7. Haga más cosas con la animación 3D
    8. Previsualización de los cambios en diseños 3D en tiempo real con el motor en tiempo real
    9. Adición de diseño interactivo a los gráficos 
  16. Vistas y previsualizaciones
    1. Previsualización
    2. Previsualización de vídeo con Mercury Transmit
    3. Modificación y utilización de vistas
  17. Procesamiento y exportación
    1. Principios básicos del procesamiento y la exportación
    2. Exportación de un proyecto de After Effects como un proyecto de Adobe Premiere Pro
    3. Conversión de películas
    4. Procesamiento de varios fotogramas
    5. Procesamiento automático y en red
    6. Procesamiento y exportación de imágenes fijas y secuencias de imágenes fijas
    7. Uso del códec de GoPro CineForm en After Effects
  18. Uso de otras aplicaciones
    1. Dynamic Link y After Effects
    2. Uso de After Effects y otras aplicaciones
    3. Sincronización de la configuración en After Effects
    4. Bibliotecas Creative Cloud en After Effects
    5. Plugins
    6. Cinema 4D y Cineware
  19. Colaboración: Frame.io y Team Projects
    1. Colaboración en Premiere Pro y After Effects
    2. Frame.io
      1. Instalar y activar Frame.io
      2. Utilizar Frame.io con Premiere Pro y After Effects
      3. Preguntas frecuentes
    3. Team Projects
      1. Introducción a Team Projects
      2. Creación de un proyecto de equipo
      3. Colaboración con Team Projects
  20. Memoria, almacenamiento y rendimiento
    1. Memoria y almacenamiento
    2. Cómo maneja After Effects los problemas de poca memoria durante la previsualización
    3. Mejora del rendimiento
    4. Preferencias
    5. Requisitos de la GPU y del controlador de la GPU para After Effects

Acerca de Dynamic Link

Anteriormente, para compartir recursos de medios entre aplicaciones de postproducción era necesario procesar y exportar el trabajo desde una aplicación antes de importarlo en otra. Se trataba de un flujo de trabajo poco eficaz y en el que se perdía mucho tiempo. Si deseaba hacer cambios en el recurso original, era preciso volver a procesar y exportar el recurso. Múltiples versiones procesadas y exportadas de un recurso consumen espacio del disco y pueden generar dificultades para gestionar los archivos.

Dynamic Link ofrece una alternativa a este flujo de trabajo. Se pueden crear vínculos dinámicos entre After Effects y Adobe Premiere Pro. Crear un vínculo dinámico es tan sencillo como importar cualquier otro tipo de recurso. Los recursos con vínculos dinámicos aparecen con iconos únicos y colores de etiquetas que ayudan a identificarlos. Los vínculos dinámicos se guardan en proyectos generados por dichas aplicaciones.

Creación y vinculación de composiciones de After Effects con Dynamic Link

Se pueden crear nuevas composiciones de After Effects y vincularlas de forma dinámica desde Adobe Premiere Pro. Asimismo, puede vincularlas dinámicamente a composiciones existentes de After Effects desde Adobe Premiere Pro.

Creación de una composición a partir de clips en Adobe Premiere Pro

Puede sustituir los clips seleccionados en Adobe Premiere Pro con una composición de After Effects enlazada dinámicamente basada en esos clips. La nueva composición hereda la configuración de la secuencia de Adobe Premiere Pro.

  1. Abra Premiere Pro y seleccione los clips que desee reemplazar.

  2. Haga clic con el botón secundario en cualquiera de los clips seleccionados.
  3. Seleccione Reemplazar con composición de After Effects.

    Se abre After Effects (si no estaba ya abierto) y se crea una nueva composición enlazada.

Creación de una composición enlazada dinámicamente desde Adobe Premiere Pro

Al crear una nueva composición vinculada dinámicamente desde Adobe Premiere Pro, se inicia After Effects. A continuación, After Effects crea un proyecto y una composición con las dimensiones, la proporción de píxeles, la velocidad de fotogramas y la frecuencia de muestreo de audio del proyecto original. (Si After Effects ya se está ejecutando, crea una nueva composición en el proyecto actual.) El nombre de la nueva composición está basado en el nombre del proyecto de Adobe Premiere Pro, seguido de Comp. enlazada [x].

  1. En Adobe Premiere Pro, seleccione Archivo > Adobe Dynamic Link > Nueva composición de After Effects. En la versión de 2014 de Premiere Pro se pueden importar composiciones con el Navegador de medios. Consulte las siguientes secciones en Premiere Pro para obtener más información:

  2. Si aparece el cuadro de diálogo Guardar como de After Effects, introduzca un nombre y una ubicación para el proyecto de After Effects, y haga clic en Guardar.

    Nota:

    Al crear una composición vinculada dinámicamente en After Effects, la duración de la composición se fija en 30 segundos. Para modificar la duración, seleccione la composición en After Effects y elija Composición > Ajustes de composición. Haga clic en la pestaña Básico y especifique un nuevo valor para Duración.

Para obtener resultados óptimos, haga que los ajustes de composición (como las dimensiones, la proporción de aspecto de píxeles y la velocidad de fotogramas) coincidan con los de Adobe Premiere Pro.

  1. Realice una de las operaciones siguientes:
    • En Adobe Premiere Pro, seleccione Archivo > Adobe Dynamic Link > Importar composición de After Effects. Seleccione un archivo de proyecto de After Effects (.aep) y, a continuación, una o varias composiciones.

    • En Adobe Premiere Pro, seleccione un archivo de proyecto de After Effects y Abrir. A continuación, seleccione una composición en el cuadro de diálogo que aparece y Aceptar.

    • Arrastre una o más composiciones del panel Proyecto de After Effects al panel Proyecto de Adobe Premiere Pro.

    • Arrastre un archivo de proyecto de After Effects al panel Proyecto de Premiere Pro. Si el archivo de proyecto de After Effects contiene varias composiciones, se abre el cuadro de diálogo Importar composición.

Nota:

Puede enlazar una sola composición de After Effects en un solo proyecto de Adobe Premiere Pro varias veces.

Modificación de una composición vinculada dinámicamente en After Effects

En Adobe Premiere Pro, utilice el comando Editar original para modificar una composición vinculada de After Effects. Una vez que la composición esté abierta en After Effects, puede cambiarla sin tener que volver a usar el comando Editar original.

  1. Seleccione la composición de After Effects en Adobe Premiere Pro, o bien elija un clip enlazado en la línea de tiempo y haga clic en Editar > Editar original.

  2. Cambie la composición en After Effects. A continuación, vuelva a Adobe Premiere Pro para ver los cambios.

Los cambios realizados en After Effects aparecerán en Adobe Premiere Pro. Adobe Premiere Pro deja de utilizar los archivos de previsualización procesados para el clip antes de los cambios.

Nota:

Puede cambiar el nombre de la composición en After Effects después de crear un vínculo dinámico a esta desde Adobe Premiere Pro. Adobe Premiere Pro no actualizará el nombre de la composición vinculada en el panel Proyecto. Sin embargo, Adobe Premiere Pro conserva el vínculo dinámico.

Eliminación de una composición o un clip enlazado dinámicamente

Se puede eliminar una composición enlazada de un proyecto de Adobe Premiere Pro en cualquier momento, aunque se esté utilizando la composición.

Los clips enlazados desde la línea de tiempo se pueden eliminar en cualquier momento de una secuencia o línea de tiempo de Adobe Premiere Pro.

  1. En Adobe Premiere Pro, seleccione la composición o el clip enlazados y pulse la tecla Delete.

Creación de una secuencia enlazada en Adobe Premiere Pro con Dynamic Link

Al crear una secuencia de Adobe Premiere Pro en After Effects se inicia Adobe Premiere Pro. A continuación, Adobe Premiere Pro crea un proyecto y una secuencia con las dimensiones, la proporción de píxeles, la frecuencia de fotogramas y la velocidad de muestreo de audio del proyecto original. (Si Adobe Premiere Pro ya está en ejecución, crea una secuencia en el proyecto actual).

  1. En After Effects, seleccione Archivo > Adobe Dynamic Link > Nueva secuencia de Premiere Pro.

Para obtener mejores resultados, haga coincidir la configuración de la secuencia y del proyecto en Adobe Premiere Pro (como las dimensiones, la proporción de píxeles y la velocidad de fotogramas) con los del proyecto de After Effects.

Realice una de las operaciones siguientes:

  • En After Effects, seleccione Archivo > Adobe Dynamic Link > Importar secuencia de Premiere Pro. Elija un proyecto de Adobe Premiere Pro y, a continuación, una o más secuencias.

  • Arrastre una o varias secuencias desde el panel Proyecto de Adobe Premiere Pro al de Proyecto de After Effects.

Rendimiento de Dynamic Link

Un clip vinculado puede hacer referencia a una composición de origen compleja. Las acciones que se llevan a cabo en la composición de origen requieren tiempo de procesamiento adicional según la complejidad. After Effects aplica las acciones y coloca los datos finales a disposición de Adobe Premiere Pro con la caché de rendimiento global y las funciones de la caché de disco persistente. Estas funciones mejoran el rendimiento de After Effects con los fotogramas almacenados en caché cuando Premiere Pro los solicita.

Para reducir los retardos en la reproducción, siga uno de estos procedimientos:

  • Pase la composición enlazada a sin conexión.

  • Inhabilite un clip enlazado para que no haga referencia a una composición temporalmente.

  • Sustituya la composición enlazada dinámicamente por el archivo procesado mediante la función Procesar y reemplazar de Premiere Pro (Clip > Procesar y reemplazar).

Si suele trabajar con composiciones de origen complejas, añada más RAM a su ordenador o actualícelo con un procesador más rápido.

Exportación a Adobe Media Encoder

Para codificar composiciones de After Effects, es necesario agregarlas a la cola de codificación de Adobe Media Encoder y, a continuación, seleccionar los ajustes preestablecidos de codificación o crear sus propios ajustes personalizados para procesamiento. En After Effects, puede agregar una composición a la cola de Media Encoder con una de las siguientes opciones:

  • Archivo > Exportar > Añadir a la cola de Media Encoder
  • Composición > Añadir a la cola de Media Encoder

Cuando agrega una composición o un proyecto a la cola de Adobe Media Encoder, After Effects ejecuta Adobe Media Encoder con las composiciones de la cola.

En los siguientes artículos se explica el proceso de codificación:

Logotipo de Adobe

Inicia sesión en tu cuenta