Adobe Flash Builder 4.7 known issues

Welcome to Adobe® Flash® Builder™ 4.7. This document contains known issues and troubleshooting tips not covered in the Flash Builder documentation.

See http://www.adobe.com/go/flex46_sdk_releasenotes for Flex 4.6 SDK known issues 

Installation and launch

FB-33500: IllegalArgumentException is thrown when you run/debug an application on a mobile device using Flash Builder as a plug-in to eclipse Juno 4.2.1 build. Flash Builder 4.7 is certified with Eclipse 4.2.0.

FB-35630: Flash Buidler 4.7 installer throws a long path error when the installation path has more than 29 characters.

FB-33417: Installing Flash Builder 4.7 as a plug-in to Eclipse shows install completed with Warnings. This is unlikely to cause any impact on your installation. Please verify the logs for further details.

Mobile: Run / Debug / Package

FB-33478: Debugger connection dialog pops up from Flash Builder although the IPA file is not installed on iOS device through USB on some machines. Use iTunes when it doesn't install.

FB-35827: With Java 1.7 iOS packaging fails on Mac. To workaround create simlink from lib/aot/lib/x64. Please refer to the bug for specific details.

Flash Builder general

FB-33402: Subversion installation fails if you try to install incompatible SVN connectors on Flash Builder 64 bit. Install a platform-independent pure-Java SVNKit connector to work with Flash Builder / Eclipse 64 bit Architecture . Refer Installing Subversion on Eclipse 64 bit.

FB-33409: SourceMate does not appear in the Flash Builder menu after installation. SourceMate 3.0 is not compatible with ASC 2.0 which ships with Flash Builder 4.7.

FB-22429: Large embedded images do not show up at runtime for mobile applications.

FB-34189: Runtime errors are thrown when FB is plugged in to Eclipse 4.2.0 intermittently. To workaround close the perspective and reopen.

FB-34203: AS and MXML editors are not shown in updated Eclipse. Updating Eclipse from Flash Builder update is not supported.

Tech Note issues

FB-35577: FB 4.7 Flex automation restricts to 30 lines even with FB 4.7 premium licenses. Refer Technote

FB-30132: Flash perspectives not present after plugging FB into external eclipse, when FB is installed in Hi-ASCII folder. Refer Technote

FB-35834: Flash Builder 4.7 doesn't work with workspaces created in previous versions as changing default workspace removes reference to AIR SDK. Refer Technote

© 2012 Adobe Systems Incorporated. All rights reserved.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy