指南建立和管理

上次更新時間 2026年9月30日

了解如何在 Adobe After Effects 中建立、編輯、整理和共用 Guides,以在專案中精確對齊元素。

After Effects 中的 Guides 可協助您在 合成、圖層和 影片片段面板中精確對齊圖層、文字和其他元素。您可以依據像素或百分比定位 Guides、將其圖釘至任何邊緣、指定色彩以便整理,並隨時編輯。

After Effects 中的指南與 Adobe Premiere 中的行為密切配合,讓您在應用程式間移動時擁有一致的體驗。

After Effects 支援以下功能:

  • 百分比式指南:允許指南相對於合成或檢視定位,而非固定像素值,讓配置能適應解析度和寬高比變更。
  • 圖釘指南:允許將指南圖釘至底部或右側邊緣 (除了頂部和左側),確保配置在尺寸變化時保持穩定。
  • 個別指南色彩控制:透過允許個別指南使用色彩編碼,改善可見度和整理。
  • 指南編輯:可透過右鍵點擊來調整其位置、在像素和百分比之間變更單位、修改圖釘行為,以及指定色彩。此外,匯入和匯出 Guides 不再將百分比式 Guides 轉換為像素值,讓您更容易在應用程式間重複使用回應式配置。

指南的最新更新引入了百分比式定位、邊緣圖釘、自訂指南色彩和增強的指南編輯控制。

在 After Effects 中,參考線是檢視特定的,因此它們可以在合成、影片片段和圖層面板中分別存在。以下範例顯示如何在同一專案內的不同檢視和面板中使用不同 Guides 來支援特定工作:

構成面板中的 Guides

圖層面板已加入 Guides,並顯示尺標。

「圖層」面板已加入 Guides,以協助僅在該特定圖層內對齊元素。

影片片段面板中的 Guides

影片片段面板已加入 Guides,並顯示尺規。

影片片段面板已加入 Guides,以對齊來源影片片段而不影響合成面板。

備註

新的指南指令碼存取器現已可用。了解如何在您的指令碼中控制指南可見度和行為,包括 目前 Beta 版新增功能和原始指令碼支援。

新增指南至檢視

開啟您要新增參考線的面板,例如 Composition、Layer 或 Footage 面板。

選取 View > Show Rulers 以顯示尺規。 

若要建立參考線,請從上方尺標拖曳以新增水平參考線,或從左方尺標拖曳以新增垂直參考線。您可以使用 Selection 工具拖曳來移動指南。

在指南上按一下滑鼠右鍵,然後選取 Edit Guide 以開啟 Edit Guide 對話框。 

 

或者,您也可以前往 View > Add Guide 來存取 Add Guide 對話框。

調整 Position 值以指定指南在檢視內的確切位置,從選取的參考邊緣以 Pixels 或 Percentage 為單位進行測量。Orientation 下拉選單中的選擇會影響可用選項。

適用於垂直指南:

  • Left:當垂直指南設定為 Left 時,其距離是從畫面左邊緣開始測量。即使畫面變寬或變窄,它都會與左側保持相同的距離。
  • Right:當垂直指南設定為 Right 時,其距離是從畫面右邊緣開始測量。即使畫面大小變更,它都會與右側保持相同的距離。

適用於水平指南:

  • Top:當水平指南設定為 Top 時,其距離是從畫面上邊緣開始測量。即使畫面變高或變低,它都會與頂部保持相同的距離。
  • Bottom:當水平指南設定為 Bottom 時,其距離是從畫面下邊緣開始測量。即使畫面大小變更,它都會與底部保持相同的距離。

使用 Unit 下拉選單選取指南位置的測量方式,然後選擇下列其中一個選項:

  • Pixels:用於固定數值放置
  • Percent:用於相對於畫面大小的比例放置
「編輯指南」對話框已開啟,且「單位」下拉選單也已開啟,其中提供「像素」或「百分比」的選取選項。

選取「像素」或「百分比」作為單位,以定義相對於合成如何測量指南位置。

使用 Color 選項來設定所選指南的顯示色彩,以提升可見度和組織性。

使用 Orientation 下拉選單來指定指南的繪製方向:

  • 水平:由左至右執行的參考線,可用來沿著 y 軸對齊物件 (由上至下定位)
  • 垂直:由上至下延伸的參考線,用來沿著 x 軸對齊物件 (由左至右定位)。

選取確定。

以下是使用參考線時需要了解的事項:

  • 參考線位置一律顯示單位:值顯示為 150 像素或 50%,因此您一律能知道參考線是以像素或百分比放置,而無需猜測。
  • 切換單位不會移動參考線:如果您在「新增參考線」或「編輯參考線」對話框中從像素變更為百分比 (或反之),參考線會維持在原來的位置。只有位置的表達方式會變更,實際的位置不會改變。
  • 拖曳時會出現即時讀數:當您拖曳參考線時,螢幕上會出現小標籤,顯示其確切位置 (例如 150 像素或 50%)。如果參考線已圖釘至邊緣,也會顯示「已圖釘」標籤,表示已錨定。
  • 拖曳時使用鍵盤快捷鍵:
    • 拖曳時按住 Alt (Windows) / Option (macOS) 可立即在像素和百分比之間切換。
    • 拖曳時按住 Ctrl (Windows) / Command (macOS),可切換參考線的釘選與未釘選狀態。參考線在視覺上保持在原位,只有錨點邊緣會變更。

可見度控制

  • 若要顯示或隱藏安全區域、拼貼、參考線或尺標,請選取選擇拼貼與參考線選項按鈕並選擇適當項目,或在檢視選單中使用選單指令或鍵盤快速鍵。
  • 若要在顯示和隱藏安全區域之間切換,請 Alt+按一下 (Windows) 或 Option+按一下 (macOS)選擇拼貼與參考線選項按鈕。

貼齊行為

選取檢視 > 貼齊至格點或檢視 > 貼齊至參考線,讓圖層邊緣和遮色片邊緣貼齊至格點或參考線。

尺標控制

  • 若要設定尺標的零點 (原點),請從兩個尺標的交叉點 (左上角) 將十字準線拖曳至合成區域。
  • 按兩下尺標交叉點可重設零點。 

從新零點測量的指標位置會在資訊面板中顯示為X和Y座標。

匯入和匯出參考線

After Effects 可讓您儲存參考線並匯入至其他 After Effects 合成、專案和圖層。您也可以將這些參考線匯出至 Premiere,編輯者可使用它們來維持專案的一致性。

若要將現有的 Guides 匯入 After Effects,請選取檢視 > 匯入 Guides。若要匯出 Guides,請選取檢視 > 匯出 Guides。

當您匯出指南時,它會建立一個範本檔案 (.guides),您可以共用該檔案或將其匯入到另一個專案,或匯入到同一個專案中的不同合成、圖層或影片片段檢視。指南範本檔案包含記錄指南屬性的 JSON 資料。After Effects 會匯出目前視圖中的所有 Guides。匯入指南會將指南新增到目前的檢視。它會保留檢視中任何現有的指南。 

您可以將 After Effects 指南匯入 Premiere 13.1,也可以將 Premiere 指南匯入 After Effects。最新的 After Effects 26.5x 版本現在可以保留來自 Premiere 的參考線色彩,並保留參考線的像素或百分比定位模式,包括已釘選和未釘選的行為。

指南色彩會變更為偏好設定 > 拼貼與指南中定義的色彩。

  • 以百分比定義或圖釘到相對側 (右側或底部) 的指南,會放置在目前檢視器的適當像素值,但如果合成、圖層或影片片段尺寸發生變更,則不會以百分比為基礎或圖釘。