關於補間動畫

開始之前

註解:

與 Animate (先前稱為 Flash Professional CC) 中的多數項目相同,動畫也不需要任何 ActionScript。不過,您可以選擇使用 ActionScript 來建立動畫。

在建立補間動畫之前,若能瞭解下列 Animate 概念,將會非常有幫助:

  • 在舞台上繪圖

  • 單一圖層和跨圖層中的物件時間軸圖層和堆疊順序

  • 在「舞台」上和「屬性」檢測器中移動及轉換物件

  • 使用「時間軸」,包括物件存留期間並根據時間點選取物件。請參閱影格與關鍵影格瞭解基本概念。

  • 元件和元件屬性。可補間的元件類型包括影片片段、按鈕及圖像。文字也可補間。

  • 巢狀元件。元件實體可以插到其他元件內。

  • 選擇性:使用「選取」和「選取細部」工具來編輯貝茲曲線。這些工具可用來編輯補間動畫移動路徑。如需詳細資訊,請參閱使用移動編輯器編輯移動補間動畫

如需有關這些概念的詳細資訊,請參閱此頁面底部的連結清單。

瞭解移動補間動畫

移動補間動畫是針對不同影格中的某個物件屬性指定不同的值所建立的動畫。Animate 會計算該屬性在這兩個影格之間的值。「補間動畫」這個術語是來自於「在兩者之間」。

例如,您可在影格 1 中的「舞台」左邊放置一個元件,然後將它移動到影格 20 中的「舞台」右邊。當您建立補間動畫後,Animate 會計算影片片段中間的所有位置。結果會是一個元件由左邊移動至右邊 (從影格 1 至影格 20) 的動畫。在中間的每個影格裡,Animate 會將影片片段移動「舞台」二十分之一的距離。

「補間動畫範圍」是「時間軸」中的一組影格,在這組影格中,物件含有一或多個會隨時間改變的屬性。在「時間軸」中,補間動畫範圍會顯示為一組影格,位於具有藍色背景的單一圖層中。這些補間動畫範圍能以單一物件的方式選取,並在「時間軸」中從某個位置拖曳至另一個位置,包括拖曳至另一個圖層。在每個補間動畫範圍內,只能針對「舞台」上的一個物件製作動畫。此物件稱為補間動畫範圍的「目標物件」

「屬性關鍵影格」是補間動畫範圍內的一個影格,在這個補間動畫範圍內,您可以為補間動畫的目標物件明確定義一個或多個屬性值。這些屬性可能包括位置、Alpha (透明度)、色調等。您所定義的每一個屬性都有自己的屬性關鍵影格。如果您在某一個影格中設定了多個屬性,則這些屬性的屬性關鍵影格都會位於該影格中。您可以在「移動編輯器」中,檢視補間動畫範圍的每一個屬性及其屬性關鍵影格,也可以在補間動畫範圍的快顯選單中,選擇要在「時間軸」中顯示哪些類型的屬性關鍵影格。

將影格 1 至影格 20 的影片片段製成補間動畫的前述範例中,影格 1 與 20 是屬性關鍵影格。您可使用 Animate 中的「屬性檢測器」、「移動編輯器」及其他工具來定義您想製成動畫的屬性值。您可以在選擇的影格中指定這些屬性值,Animate 會將所需的屬性關鍵影格加入至補間動畫範圍。Animate 會為位於所建立屬性關鍵影格間的影格補上每個屬性值。

註解:

「關鍵影格」一詞指的是「時間軸」中,元件實體第一次出現在「舞台」上的所在影格。另一個詞彙「屬性關鍵影格」指的是針對移動補間動畫中,位於特定時間或影格的物件屬性所定義的值。

如果某個補間動畫物件在補間時移動了在「舞台」上的位置,就表示有一個移動路徑與補間動畫範圍產生關聯。這個移動路徑會顯示補間動畫物件在「舞台」上移動期間的路徑。您可以使用「選取」、「選取細部」、「轉換錨點」、「移除錨點」和「自由變形」工具,以及「修改」選單中的命令,編輯「舞台」上的移動路徑。如果您沒有對位置進行補間處理,「舞台」上就不會顯示移動路徑。此外,您也可以將現有的路徑貼至「時間軸」內的補間動畫範圍,以將該路徑套用為移動路徑。

補間動畫是一種建立運動的有效方法,不但會隨著時間變化,還能將檔案大小降到最低。在補間動畫中,只有您指定的屬性關鍵影格值會儲存在 FLA 檔和已發佈的 SWF 檔中。

可補間的物件與屬性

可補間動畫的物件類型包括影片片段、圖像和按鈕元件,以及文字欄位。這些可補間之物件的屬性包括下列各項:

  • 2D X 和 Y 位置

  • 3D Z 位置 (僅限影片片段)

  • 2D 旋轉 (圍繞 Z 軸)

  • 3D X、Y 和 Z 旋轉 (僅限影片片段)

    3D 移動需要在發佈設定中,設定 FLA 檔以 ActionScript 3.0 和 Flash Player 10 或更新版本為目標。Adobe AIR 也支援 3D 移動。

  • 傾斜 X 和 Y

  • 縮放 X 和 Y

  • 顏色特效

    顏色特效包括:Alpha (透明度)、亮度、色調和進階顏色設定。只能對元件和 TLF 文字進行顏色特效的補間動畫。透過將這些屬性製成移動補間動畫,您可以使物件呈現淡入或從一種顏色淡出至另一種顏色的效果。

    若要對傳統文字進行顏色特效的補間動畫,請將文字轉換為元件。

  • 濾鏡屬性 (濾鏡無法套用到圖像元件)

移動補間動畫與傳統補間動畫的差別

Animate 支援兩種不同產生移動效果的補間動畫類型。移動補間動畫容易建立而且效能強大。移動補間動畫可供用來精確地控制補間動畫。「傳統補間動畫」包含使用舊版 Animate 建立的所有補間動畫,在建立時更為複雜。移動補間動畫可提供對補間動畫更完整的控制,而傳統補間動畫則可提供部分使用者所需的特殊功能。

移動補間動畫和傳統補間動畫之間的差異包括:

  • 傳統補間動畫會使用關鍵影格。物件的新實體會出現在關鍵影格中。移動補間動畫只能與一個物件實體有關聯,而且使用的是屬性關鍵影格而不是關鍵影格。

  • 移動補間動畫是由整個補間動畫範圍內的一個目標物件所組成。傳統補間動畫允許在兩個關鍵影格 (包含相同或不同元件的實體) 之間建立補間動畫。

  • 兩者都能讓特定物件類型成為補間動畫。當您將移動補間動畫套用到不允許的物件類型時,Animate 可讓您選擇在建立補間動畫時將這些物件類型轉換為影片片段。套用傳統補間動畫會將這些物件類型轉換為圖像元件。

  • 移動補間動畫會將文字視為可補間的類型,而且不會將文字物件轉換為影片片段;而傳統補間動畫則會將文字物件轉換為圖像元件。

  • 移動補間動畫範圍不允許使用影格指令碼。傳統補間動畫可以使用影格指令碼。

  • 補間動畫目標上的任何物件程式碼,在移動補間動畫範圍的過程中都不會改變。

  • 移動補間動畫範圍可以在「時間軸」中延伸及調整大小,而且會被視為單一物件。傳統補間動畫是由「時間軸」中可選取的個別影格群組所組成。

  • 若要選取移動補間動畫範圍中的個別影格,請按住 Ctrl 並按一下 (Windows) 或按住 Command 並按一下 (Macintosh) 要選取的影格。

  • 使用傳統補間動畫,加/減速可以套用至補間動畫中關鍵影格之間的影格群組。使用移動補間動畫時,加/減速會套用至移動補間動畫範圍的全長。您必須建立自訂的加/減速曲線,才能針對移動補間動畫的特定影格套用加/減速。

  • 您可以使用傳統補間動畫,在兩個不同的顏色效果 (例如色調和 Alpha 透明度) 之間建立動畫。針對每一個補間動畫,移動補間動畫只能套用一種顏色效果。

  • 只有移動補間動畫可以用來為 3D 物件建立動畫。您無法使用傳統補間動畫為 3D 物件建立動畫。

  • 只有移動補間動畫可以另存成移動預設效果。

  • 使用移動補間動畫時,您無法替換元件,也無法設定圖像元件在屬性關鍵影格中顯示的影格數。必須使用傳統補間動畫,製成的動畫才能包含這些技術。

  • 同一個圖層上可以有一個以上的傳統或移動補間動畫,但這兩種補間動畫不能同時存在於同一個圖層上。

額外的資源

下列文章與資源是說明移動補間動畫與傳統補間動畫之間的差異:

套用移動預設效果

移動預設效果是預先設定的移動補間動畫,可套用至「舞台」上的物件。您只要選取物件,然後按一下「移動預設效果」面板上的「套用」按鈕即可。

使用移動預設效果可讓您快速學習在 Animate 加入動畫的相關基礎。了解預設效果的運作方式後,製作自己的動畫就可以變得更為輕鬆。

您可以建立及儲存專屬的自訂預設效果。這些效果可以是您修改過的現有移動預設效果,或者是您自行建立的自訂補間動畫。

「移動預設效果」面板也可以讓您匯入及匯出預設效果。您可以與一同合作的人共用預設效果,或者利用由 Animate 設計社群成員共用的預設效果。

使用預設效果可以在專案設計及開發過程中節省大量的製作時間,特別是在經常使用相似補間動畫的情況下。

註解:

移動預設效果只能包含移動補間動畫。傳統補間動畫無法另存成移動預設效果。

預覽移動預設效果

Animate 中所含的每一個移動預設效果都有預覽功能,可讓您在「移動預設效果」面板上觀看。預覽功能可以讓您感受將預設效果套用至文件中的物件時,動畫的呈現方式。對於您建立或匯入的自訂預設效果,您可以加入自己的預覽。

  1. 開啟「移動預設效果」面板。

  2. 從清單中選取移動預設效果。

    預覽會在面板上方的「預覽」窗格中播放。

  3. 若要停止播放預覽,請按一下「移動預設效果」面板以外的地方。

套用移動預設效果

當您在「舞台」上選取可補間物件 (元件實體或文字欄位) 時,可以按一下「套用」按鈕以套用預設效果。每個物件僅可以套用一個預設效果。如果您將第二個預設效果套用至同一物件上,第二個預設效果便會取代第一個預設效果。

在「舞台」上對某個物件套用預設效果後,在「時間軸」中建立的補間動畫和「移動預設效果」面板之間便不再有任何關聯。刪除或重新命名「移動預設效果」面板中的某個預設效果,並不會影響之前以該預設效果建立的補間動畫。如果您在面板中於現有的預設效果上儲存新的預設效果,並不會對以原始預設效果建立的補間動畫造成任何影響。

每個移動預設效果都包含特定數目的影格。當您套用預設效果時,在「時間軸」中建立的補間動畫範圍會包含這些影格。如果目標物件已套用不同長度的補間動畫,則補間動畫範圍就會調整為符合移動預設效果的長度。您可以在套用預設效果後,調整「時間軸」中補間動畫範圍的長度。

內含 3D 移動的移動預設效果只能套用至影片片段實體。補間動畫的 3D 屬性不適用於圖像或按鈕元件,也不適用於傳統文字欄位。您可以將 2D 或 3D 移動預設效果套用至任何 2D 或 3D 影片片段。

註解:

移動預設效果若將 3D 影片片段的 z 軸位置製作成動畫,會導致影片片段的 x 和 y 位置看似亦發生變更。這是因為沿著 z 軸的移動會跟隨自 3D 消失點 (設定於 3D 元件實體的「屬性」檢測器) 向外散射的隱藏透視線延展至「舞台」邊緣。

若要套用移動預設效果:

  1. 在「舞台」上選取一個可補間物件。如果您將移動預設效果套用至不可補間的物件,會顯示一個對話方塊讓您將物件轉換為元件。

  2. 在「移動預設效果」面板中選取預設效果。

  3. 按一下面板中的「套用」按鈕,或選擇面板選單中的「套用於目前位置」。

    此時會套用移動,而移動會從「舞台」上影片片段的目前位置開始。如果預設效果具有與其關聯的移動路徑,「舞台」上便會顯示移動路徑。

    若要套用預設效果,讓效果移動停在「舞台」上物件目前的位置,請按住 Shift 鍵,然後按一下「套用」按鈕,或選取面板選單中的「結束於目前位置」。

您也可以將移動預設效果套用於不同圖層上多個選取的影格,只要每個選取的影格都僅包含單一可補間物件。

將補間動畫另存為自訂的移動預設效果

如果您自己建立一個補間動畫,或變更從「移動預設效果」面板上套用的補間動畫,便可以將它另存為新的移動預設效果。新的預設效果會出現在「移動預設效果」面板的「自訂的預設效果」資料夾裡。

若要將自訂的補間動畫另存為預設效果:

  1. 選取下列其中一個項目:
    • 「時間軸」中的補間動畫範圍
    • 「舞台」上已套用自訂補間動畫的物件
    • 「舞台」上的移動路徑
  2. 在「移動預設效果」面板中按一下「另存選取項目為預設效果」按鈕,或從選取項目的快顯選單中選擇「另存成移動預設效果」。

    新的預設效果便會出現在「移動預設效果」面板中。Animate 會將預設效果儲存為 XML 檔案。這些檔案會儲存在下列目錄:

    • Windows:<硬碟>\Documents and Settings\<使用者>\Local Settings\Application Data\Adobe\Animate CC\<語言>\Configuration\Motion Presets\

    • Macintosh:<硬碟>/Users/<使用者>/Library/Application Support/Adobe/Animate CC/<語言>/Configuration/Motion Presets/

註解:

儲存、刪除或重新命名自訂預設效果等動作將無法還原。

匯入移動預設效果

移動預設效果會儲存為 XML 檔案。匯入 XML 補間動畫檔案,便可以將其加入「移動預設效果」面板。請注意,以 XML 檔案形式匯入的移動預設效果只能加入傳統補間動畫。

  1. 從「移動預設效果」面板選單中選擇「匯入」。

  2. 在「開啟」對話方塊中,瀏覽至您要匯入的 XML 檔案,然後按一下「開啟」。

Animate 會開啟 XML 檔案,並將移動預設效果新增至面板。

匯出移動預設效果

您可以將移動預設效果匯出為 XML 檔案,以便與其他 Animate 使用者共享。

  1. 在「移動預設效果」面板中選取預設效果。

  2. 從面板選單選擇「匯出」。

  3. 在「另存新檔」對話方塊中,選擇 XML 檔案的名稱和位置,並按一下「存檔」。

刪除移動預設效果

您可以從「移動預設效果」面板移除預設效果。當您移除某個預設效果時,Animate 會從磁碟刪除該預設效果的 XML 檔案。您可以先匯出這些預設效果的副本做為備份,以便再次使用這些預設效果。

  1. 在「移動預設效果」面板中選取要刪除的預設效果。

  2. 請執行下列其中一項:
    • 從面板選單選取「移除」。
    • 在面板中按一下「移除項目」按鈕。

為自訂的預設效果建立預覽

您可以為自己所建立的任何自訂移動預設效果建立預覽。如果要這麼做,請儲存一個 SWF 檔案,這個檔案會在與移動預設效果的 XML 檔案相同的目錄中,示範補間動畫。

  1. 建立補間動畫並將其儲存為自訂的預設效果。
  2. 建立僅包含一個補間動畫示範的 FLA 檔。使用與自訂預設效果完全相同的名稱儲存 FLA 檔。
  3. 使用「發佈」命令,從 FLA 檔案建立 SWF 檔案。

  4. 將 SWF 檔案放置在與儲存自訂移動預設效果之 XML 檔案相同的目錄中。這些檔案會儲存在下列目錄:
    • Windows:<硬碟>\Documents and Settings\<使用者>\Local Settings\Application Data\Adobe\Animate CC\<語言>\Configuration\Motion Presets\
    • Macintosh:<硬碟>/Users/<使用者>/Library/Application Support/Adobe/Animate CC/<語言>/Configuration/Motion Presets/

現在,當您在「移動預設效果」面板中選取自訂的補間動畫時,預覽便會顯示。

建立補間動畫

建立補間動畫的步驟。

開始之前

開始將屬性製成動畫之前,請記住下列事項:

ActionScript 並非必要。與 Animate 中的許多項目相同,動畫也不需要任何 ActionScript。不過,您可以選擇使用 ActionScript 來建立動畫。

時間軸與編輯屬性的基本概念。在開始使用移動補間動畫之前,請熟悉時間軸與編輯屬性的基本用法。請參閱影格與關鍵影格瞭解基本概念。

您可以在「舞台」上、「屬性」檢測器或「移動編輯器」中編輯個別屬性關鍵影格。請注意,許多簡單的移動補間動畫類型不一定要使用「移動編輯器」來建立。

移動編輯器已於 Animate CC 中被取代。

僅限元件實體與文字欄位。Animate 只會將元件實體與文字欄位製成補間動畫。對它們套用補間動畫時,便會將所有的其他物件類型包覆在元件中。元件實體可以包含巢狀元件,而巢狀元件可以在本身的時間軸上製作補間動畫。

每一補間動畫一個物件。補間動畫圖層中最小的建構區塊即是補間動畫範圍。補間動畫圖層中的補間動畫範圍僅可以包含一個元件實體或文字欄位。元件實體為補間動畫範圍的目標。不過,單一元件可以包含許多物件。

變更目標。將第二個元件或文字欄位加入至補間動畫範圍內會取代補間動畫中的原始元件。您可以透過將元件庫中的不同元件拖曳到「時間軸」中的補間動畫範圍,或是使用「修改 > 元件 > 替換元件」命令,以變更補間動畫的目標物件。您可以從補間動畫圖層刪除元件,不需移除或打散補間動畫。稍後,您還能再將另一個元件實體加入至補間動畫。您也可以隨時變更目標元件的類型或是編輯元件。

編輯移動路徑。補間動畫包含移動時,「舞台」上便會顯示移動路徑。移動路徑會顯示每個影格中補間動畫物件的位置。您可以拖曳移動路徑的控制點,以編輯「舞台」上的移動路徑。您不能將移動導引線加入至補間動畫/反向運動圖層。

如需有關以反向運動進行補間動畫的資訊,請參閱將骨架製作成動畫

如何將補間動畫新增至時間軸

當您將補間動畫新增至圖層上的物件時,Animate 便會執行下列動作:

  • 將圖層轉換為補間動畫圖層。

  • 建立新圖層以維持物件在圖層上的原始堆疊順序。

圖層會依據下列規則加以新增:

  • 如果圖層上除選取的物件外並無其他物件,該圖層將變更為補間動畫圖層。

  • 若選取範圍在圖層堆疊順序的底部 (在其他所有物件下方),Animate 會在原始圖層上方建立一個圖層。這個新圖層會保存未選取的項目。原始圖層會成為補間動畫圖層。

  • 若選取範圍在圖層堆疊順序的頂層 (在其他所有物件上方),Animate 會建立新圖層。選取範圍會移至新圖層,而該圖層會成為補間動畫圖層。

  • 若選取範圍在圖層堆疊順序的中間 (選取範圍上方及下方都有物件),Animate 會建立兩個圖層。一個圖層會保存新的補間動畫,另一個在其上方的圖層則會將未選取的項目保存在堆疊順序的頂層。位於堆疊順序最底層的未選取項目仍將放在原始圖層上,置於新插入的圖層之下。

補間動畫圖層可以包含補間動畫範圍,以及靜態影格和 ActionScript。然而,包含補間動畫範圍的補間動畫圖層,其影格不得包含補間動畫物件以外的物件。若要在同一個影格中加入額外的物件,請將各物件分置於不同圖層上。

使用補間動畫將位置製成動畫

使物件在「舞台」上移動或滑動:

  1. 選取要在「舞台」上製成補間動畫的元件實體或文字欄位。物件可以位於下列任何圖層類型:一般、導引、遮色片或被遮色。

    若選取範圍包含其他物件,或包含一個圖層中的多個物件,Animate 可讓您將選取範圍轉換成影片片段元件。

    若要反選,請以滑鼠右鍵按一下物件並選取「反選」。

     
  2. 請執行下列其中一項:

    • 選擇「插入 > 移動補間動畫」。

    • 以滑鼠右鍵按一下 (Windows) 或 Ctrl+按一下 (Macintosh) 選取範圍或目前的影格,然後在快顯選單中選擇「建立移動補間動畫」。

    若顯示「將選取項目轉換為元件以做為補間動畫」對話方塊,請按一下「確定」以將選取範圍轉換成影片片段元件。

    如果補間動畫物件是圖層上的唯一項目,Animate 會將包含該物件的圖層轉換為補間動畫圖層。若圖層中有其他物件,Animate 會插入圖層以維持堆疊順序。Animate 會將補間動畫物件放在其專屬圖層中。

    如果原始物件只位在「時間軸」的第一個影格中,補間動畫範圍的長度就等於一秒的長度。如果原始物件出現在一個以上的連續影格中,則補間動畫範圍會包含由原始物件所佔用的影格數。

  3. 在「時間軸」中拖曳補間動畫範圍的任何一端,將範圍縮短或延長至所需的影格數目。補間動畫中的任何現有屬性關鍵影格都會隨著此範圍尾端而等比例移動。

    若要移動範圍的尾端而不移動任何現有關鍵影格,請按 Shift+拖曳補間動畫範圍的尾端。

  4. 若要新增移動至補間動畫,請在補間動畫範圍內的影格上放置播放磁頭,然後將物件拖曳至新的位置。

    移動路徑會顯示在「舞台」上,顯示從補間動畫範圍內第一個影格的位置至新位置的路徑。因為您已明確定義了物件的 X 與 Y 屬性,所以就會為內含播放磁頭的影格中的 X 和 Y 加入屬性關鍵影格。屬性關鍵影格在補間動畫範圍中就會顯示為小菱形。

    註解:

    根據預設,「時間軸」會顯示所有屬性類型的屬性關鍵影格。您可以用滑鼠右鍵按一下 (Windows) 或 Command+按一下 (Macintosh) 補間動畫範圍,然後選擇「檢視關鍵影格 > 屬性類型」,以選擇要顯示哪些類型的屬性關鍵影格。

  5. 若要指定物件的另一個位置,請在補間動畫範圍內的另一個影格中放置播放磁頭,並在「舞台」上將物件拖曳至另一個位置。

    此時會調整移動路徑,以包含您指定的所有位置。

  6. 若要將 3D 旋轉或位置製成補間動畫,請使用「3D 旋轉」或「3D 轉譯」工具。請確定先將播放磁頭置於您要在其中加入 3D 屬性關鍵影格的影格內。

註解:

若要同時建立多個補間動畫,請在多個圖層上放置可補間物件,選取所有可補間物件,並選擇「插入 > 移動補間動畫」。此外,您也能以同樣的方式將移動預設效果套用於多個物件。

使用屬性檢測器補間其他屬性

「建立移動補間動畫」命令可讓您將元件實體或文字欄位的多數屬性 (例如旋轉、縮放、透明度或著色 (僅限元件和 TLF 文字)) 製成動畫。例如,您可以編輯元件實體的 Alpha (透明度) 屬性,使其淡入畫面。如需可使用移動補間動畫製成動畫的屬性清單,請參閱可補間的物件與屬性

  1. 選取「舞台」上的元件實體或文字欄位。

    若選取範圍包含其他物件,或包含一個圖層中的多個物件,Animate 可讓您將其轉換成影片片段元件。

  2. 選擇「插入 > 移動補間動畫」。

    若顯示「將選取項目轉換為元件以做為補間動畫」對話方塊,請按一下「確定」以將選取範圍轉換成影片片段元件。

    當您將補間動畫套用至只存在於一個關鍵影格中的物件時,播放磁頭就會移至新的補間動畫的最後一個影格。否則,播放磁頭就不會移動。

  3. 請將播放磁頭放置在補間動畫範圍內,您要指定屬性值的影格中。

    您也可以將播放磁頭放置在補間動畫範圍內的任何其他影格中。補間動畫會以補間動畫範圍第一個影格中的數值啟動,該影格一定會是屬性關鍵影格。

  4. 選取「舞台」上的物件,然後設定非位置屬性 (例如 Alpha (透明度)、旋轉或傾斜) 的值。請使用「屬性」檢測器或「工具」面板中的工具來設定值。

    範圍中目前的影格就會變成屬性關鍵影格。

    註解:

    您可在補間動畫範圍顯示不同類型的屬性關鍵影格。以滑鼠右鍵按一下 (Windows) 或 Ctrl+按一下 (Macintosh) 補間動畫範圍,從快顯選單中選擇「檢視關鍵影格 > 屬性類型」。

  5. 拖曳「時間軸」中的播放磁頭,預覽「舞台」上的補間動畫。

  6. 若要加入其他屬性關鍵影格,請將播放磁頭移至範圍內所需的影格,然後在「屬性」檢測器中設定屬性值。

將其他補間動畫加入至現有的補間動畫圖層

您可以將其他補間動畫加入至現有的補間動畫圖層。當您使用動畫建立 Animate 內容時,這樣可以使用較少的圖層。

  1. 請執行下列其中一項:
    • 在圖層上加入空白關鍵影格 (「插入 > 時間軸 > 空白關鍵影格」)、將項目加入關鍵影格,然後將項目製作成補間動畫。
    • 在另一個圖層上建立補間動畫,然後再將範圍拖曳至所需的圖層。
    • 將靜態影格從另一個圖層拖曳至補間動畫圖層,然後再將補間動畫加入至靜態影格中的某個物件。
    • 按 Alt+拖曳 (Windows) 或按 Option+拖曳 (Macintosh) 可重製相同圖層或不同圖層中的現有範圍。
    • 從相同或不同圖層複製並貼上補間動畫範圍。

註解:

您可以在補間動畫範圍的任何影格上,將移動補間動畫的目標物件複製至剪貼簿。

編輯補間動畫的移動路徑

您可以下列方式編輯或變更移動補間動畫的移動路徑:

  • 在補間動畫範圍的任何影格中變更物件的位置。

  • 將整個移動路徑移動至「舞台」上不同的位置。

  • 使用「選取」、「選取細部」或「自由變形」工具變更路徑的形狀或大小。

  • 使用「變形」面板或「屬性」檢測器變更路徑的形狀或大小。

  • 使用「修改 > 變形」選單中的命令。

  • 將自訂筆畫套用為移動路徑。

  • 使用「移動編輯器」。

您可以使用「永遠顯示移動路徑」選項,同時顯示「舞台」上所有圖層上的所有移動路徑。當您在彼此交集的不同移動路徑上設計多個動畫時,這個方法會非常有幫助。選取移動路徑或補間動畫範圍時,您可以選取「屬性」檢測器選項選單中的這個選項。

使用選取和選取細部工具編輯移動路徑的形狀

您可以使用「選取」和「選取細部」工具來調整移動路徑的形狀。您可以使用「選取」工具,透過拖曳方式來調整線段的形狀。補間動畫中的屬性關鍵影格會出現在路徑中,成為控制點。您可以使用「選取細部」工具來顯示路徑上的控制點和貝茲控制點,這些控制點會對應至每個位置屬性關鍵影格。您可以使用這些控制點來調整屬性關鍵影格點周圍的路徑形狀。

當您建立非線性移動路徑 (例如圓圈) 時,您可能要讓補間動畫物件一邊旋轉,一邊沿著路徑移動。若要保持相對於路徑的固定方向,請在「屬性」檢測器中選取「沿向路徑」選項。

未導向至移動路徑的補間動畫物件 (左圖) 以及導向至移動路徑的補間動畫物件 (右圖)。

  1. 按一下「工具」面板中的「選取」工具。

  2. 按一下補間動畫目標實體,讓移動路徑出現在「舞台」上。

  3. 使用「選取」工具拖曳任何移動路徑的線段,以重新調整。請不要按一下並先選取線段。

  4. 若要顯示路徑上某個屬性關鍵影格點的貝茲控制點,請按一下「選取細部」工具然後按一下路徑。

    屬性關鍵影格點在移動路徑上會以控制點的形式 (小菱形) 顯示。

  5. 若要移動控制點,請使用「選取細部」工具拖曳該控制點。

  6. 若要調整控制點周圍的路徑曲線,請使用「選取細部」工具拖曳控制點的貝茲控制點。

    如果控制點沒有延長,只要按住 Alt (Windows) 或 Option (Macintosh) 不放並拖曳控制點,就能延長。

  7. 若要刪除錨點,請使用「刪除錨點」工具按一下該錨點。大多數以「選取」工具產生的錨點都是平滑點。若要轉換錨點,請使用「轉換錨點」工具按一下錨點。錨點會變成角點。

  8. 您也可以從某個點拉出新的貝茲控制點並調整位置,就像使用一般錨點一樣。

    註解:

    您無法使用「增加錨點」工具將錨點增加至路徑。

變更補間動畫物件的位置

編輯移動路徑的最簡單方式,便是在補間動畫範圍的任何影格中,移動「舞台」上該補間動畫的目標實體。如果目前影格尚不包含屬性關鍵影格,Animate 就會增加一個關鍵影格。

  1. 在您要移動目標實體的影格中放置播放磁頭。
  2. 使用「選取」工具,將目標實體拖曳至「舞台」上的新位置。

此時,移動路徑會更新,以包含新的位置。移動路徑中的所有其他屬性關鍵影格都會留在其原始位置。

變更移動路徑在舞台上的位置

您可以在「舞台」上拖曳整個移動路徑,或使用「屬性」檢測器設定路徑的位置。

  1. 按一下「工具」面板中的「選取」工具。
  2. 請進行下列其中一種操作,以選取移動路徑:
    • 按一下「時間軸」中的補間動畫範圍,然後按一下「舞台」上的移動路徑。
    • 按一下「舞台」上的補間動畫物件,然後按一下移動路徑。
    • 在移動路徑和目標實體周圍拖曳出圈選範圍,同時選取兩者。
  3. 請進行下列其中一種操作,以移動移動路徑:
    • 將路徑拖曳至「舞台」上所需的位置。
    • 在「屬性」檢測器中,為路徑設定 X 和 Y 值。X 與 Y 值代表的是移動路徑範圍框的左上角。
    • 使用方向鍵來移動移動路徑。

註解:

若要為移動路徑指定一個位置,以移動補間動畫目標實體和移動路徑,請選取實體和路徑,然後在「屬性」檢測器中輸入 X 和 Y 的位置。若要移動沒有移動路徑的補間動畫物件,請選取該物件,並在「屬性」檢測器中輸入 X 和 Y 值。

使用自由變形工具編輯移動路徑

  1. 按一下「工具」面板中的「自由變形」工具。

  2. 使用「自由變形」工具按一下移動路徑。請不要按一下補間動畫目標實體。

  3. 使用「自由變形」工具縮放、傾斜或旋轉路徑。

註解:

您也可以透過使用「選取細部」工具選取移動路徑,然後按 CTRL (Windows) 或 Command (Macintosh) 鍵,在移動路徑上執行自由變形。按一下按鍵便會顯示和「自由變形」工具相同的控制點。接著,您就可以在按下按鍵時進行拖曳,以執行變形。

因為播放頭位於補間動畫的第一個影格中,所以縮放會套用到所有補間動畫影格。不會建立新的屬性關鍵影格。

刪除補間動畫中的移動路徑

  1. 使用「選取」工具按一下以選取「舞台」上的移動路徑。

  2. 按下 Delete 鍵。

複製移動路徑為筆畫

  1. 按一下以選取「舞台」上的移動路徑。

  2. 選擇「編輯 > 複製」。

然後,您就可以將路徑貼入其他圖層做為筆畫,或做為其他移動補間動畫的移動路徑。

將自訂筆畫套用為移動路徑

您可以為補間動畫套用來自不同圖層或不同時間軸的筆畫,以做為移動路徑。

  1. 從另一個補間動畫圖層選取筆畫,並將其複製至剪貼簿。

    筆畫必須為非封閉狀態。只能使用未中斷的筆畫。

  2. 在「時間軸」中選取補間動畫範圍。

  3. 讓補間動畫保持為選取狀態,並貼上筆畫。

    Animate 會為選取的補間動畫範圍,將筆畫套用為新的移動路徑。現在,補間動畫的目標實體會沿著新的筆畫移動。

  4. 若要反轉補間動畫的起始點和結束點,請以滑鼠右鍵按一下 (Windows) 或 Ctrl+按一下 (Macintosh) 補間動畫範圍,再從補間動畫範圍的快顯選單中選取「移動路徑 > 反轉路徑」。

使用漫遊屬性關鍵影格

漫遊屬性關鍵影格是未連結至「時間軸」中特定影格的關鍵影格。Animate 會調整漫遊關鍵影格的位置,如此在補間動畫中移動時就具有一致的速度。

漫遊關鍵影格只適用於空間屬性 X、Y 和 Z。當您已經將補間動畫物件拖曳至不同影格中的不同位置,藉以編輯「舞台」上的移動路徑時,漫遊關鍵影格便非常有用。以這種方式編輯移動路徑通常可以建立路徑區段,在這些區段中移動會快於或慢於其他區段。這是因為路徑區段中的影格數大於或小於其他區段的緣故。

若要讓動畫在補間動畫中移動時具有一致的速度,使用漫遊屬性關鍵影格是很好的方式。將屬性關鍵影格設定為漫遊時,Flash 會調整屬性關鍵影格在補間動畫範圍中的位置,如此一來,補間動畫物件在補間動畫的每個影格中的移動距離都相同。接著,您可以使用加/減速來調整移動狀態,如此在補間動畫的開頭和結束時的加速度可以讓動畫呈現更具真實感。

當您將自訂路徑貼在補間動畫上時,Animate 預設會將屬性關鍵影格設定為漫遊。

若要為整個補間動畫啟用漫遊關鍵影格:

  • 以滑鼠右鍵按一下 (Windows) 或 Command+按一下 (Macintosh)「時間軸」中的補間動畫範圍,再從快顯選單中選擇「移動路徑 > 將關鍵影格切換為漫遊」。

若要為補間動畫中的個別屬性關鍵影格啟用漫遊:

  • 以滑鼠右鍵按一下 (Windows) 或 Command+按一下 (Macintosh)「移動編輯器」面板中的屬性關鍵影格,然後在快顯選單中選擇「漫遊」。如需有關「移動編輯器」的詳細資訊,請參閱使用移動編輯器編輯屬性曲線

將屬性關鍵影格設定為漫遊時,這些屬性關鍵影格會在「移動編輯器」中顯示為圓點,而非正方形。

註解:

如果您為某個補間動畫範圍啟用漫遊關鍵影格,然後再停用這些關鍵影格,則它們會保有在範圍中因為啟用漫遊而產生的位置。

已關閉漫遊關鍵影格的移動路徑。請注意此圖中不平均的影格分佈,這會產生不平均的移動速度。

已開啟漫遊關鍵影格的相同移動路徑,會沿著路徑產生平均的影格分佈,並且具有一致的移動速度。

檢視與編輯補間動畫範圍的屬性關鍵影格

  • 若要在某個範圍中,檢視內含屬性關鍵影格之影格的不同屬性,請選取範圍並從範圍的快顯選單中選擇「檢視關鍵影格」,然後再從子選單中選擇屬性類型。

  • 若要從範圍移除某個屬性關鍵影格,請按 Ctrl+按一下 (Windows) 或 Command+按一下 (Macintosh) 以選取屬性關鍵影格,再以滑鼠右鍵按一下 (Windows) 或 Ctrl+按一下 (Macintosh) 屬性關鍵影格,然後針對關鍵影格所要刪除的屬性類型選擇「清除關鍵影格」。

  • 若要為特定屬性類型新增屬性關鍵影格至某範圍,請按 Ctrl+按一下 (Windows) 或 Command+按一下 (Macintosh) 以選取該範圍內的一或多個影格。接著,以滑鼠右鍵按一下 (Windows) 或 Ctrl+按一下 (Macintosh),再從範圍的快顯選單中選擇「插入關鍵影格 > 屬性類型」。Animate 會將屬性關鍵影格新增至選取的影格。您也可以在選取的影格中為目標實體設定屬性,以新增屬性關鍵影格。

  • 若要為所有屬性類型新增屬性關鍵影格至某範圍,請將播放磁頭放置在您要新增關鍵影格的影格中,然後選擇「插入 > 時間軸 > 關鍵影格」或按 F6。

  • 若要反轉補間動畫的移動方向,請從範圍的快顯選單中選擇「移動路徑 > 反轉路徑」。

  • 若要將補間動畫範圍變更為靜態影格,請選取範圍,並從範圍的快顯選單中選擇「移除補間動畫」。

  • 若要將補間動畫範圍轉換成逐格動畫,請選取範圍,然後從範圍的快顯選單中選擇「轉換成逐格動畫」。

  • 若要將屬性關鍵影格移至相同補間動畫範圍內的不同影格,或是不同的補間動畫範圍中,請按住 Ctrl (Windows) 或 Command (Macintosh) 並按一下以選取該屬性關鍵影格,然後將它拖曳至新的位置。

  • 若要將屬性關鍵影格複製至補間動畫範圍內的其他位置,請按住 Ctrl (Windows) 或 Command (Macintosh) 並按一下以選取該屬性關鍵影格,然後按住 Alt (Windows) 或 Option (Macintosh) 並將它拖曳至新的位置。

在補間動畫中新增或移除 3D 屬性關鍵影格

  1. 請執行下列其中一項:
    • 使用「工具」面板中的 3D 工具來增加 3D 屬性。
    • 以滑鼠右鍵按一下 (Windows) 或 Ctrl+按一下 (Macintosh)「時間軸」中的補間動畫範圍,然後從快顯選單中選擇「3D 補間動畫」。
    • 如果補間動畫範圍不含任何 3D 屬性關鍵影格,Animate 會將這些屬性關鍵影格加入每個現有的 X 和 Y 位置以及旋轉屬性關鍵影格。如果補間動畫範圍已經包含 3D 屬性關鍵影格,Animate 便會移除這些屬性關鍵影格。

移動或重製補間動畫範圍

您可以在「時間軸」面板中拖曳,以重製或移動補間動畫範圍和補間動畫範圍的個別部分。

  • 在「時間軸」中拖曳補間動畫範圍,可將範圍移動到不同位置。

  • 在「時間軸」中按 Alt+拖曳補間動畫範圍,可將範圍重製到新位置。

複製並貼上移動補間動畫

您可以將補間動畫屬性從某個補間動畫複製到另一個補間動畫。補間動畫屬性會套用到新的目標物件,但是目標物件的位置不變。如此一來,您就可以將「舞台」上某個區域的補間動畫套用到另一區域的物件,不用將調整新目標物件的位置。

  1. 選取包含要複製之補間動畫屬性的補間動畫範圍。
  2. 選取「編輯 > 時間軸 > 複製移動」。

  3. 選取補間動畫範圍,以接收複製的補間動畫。
  4. 選取「編輯 > 時間軸 > 貼上移動」。

    Animate 會將補間動畫屬性套用至目標補間動畫範圍,並且調整補間動畫範圍的長度,以符合複製的補間動畫範圍。

    若要將移動補間動畫複製到「動作」面板,或用於其他如 ActionScript® 的專案,請使用「將移動複製為 ActionScript 3.0」命令。

複製和貼上移動補間動畫屬性

您可以在相同或不同的補間動畫範圍,從選定的影格將屬性複製至另一個影格。貼上屬性時,屬性值只會新增至選定的影格。位於該影格的補間動畫物件若套用了顏色特效、濾鏡或 3D 屬性,才會貼上這些顏色特效、濾鏡和 3D 屬性已複製的屬性值。2D 位置屬性無法貼至 3D 補間動畫。

這些指示假設偏好設定 (「編輯 > 偏好設定」) 中已開啟「合併式選取範圍」。

  1. 若要選取補間動畫範圍中的單一影格,請按 Ctrl+Alt+按一下 (Windows) 或按 Command+Option+按一下 (Macintosh) 影格。
  2. 以滑鼠右鍵按一下 (Windows) 或 Command+按一下 (Macintosh) 選取的影格,然後從快顯選單中選擇「複製屬性」。

  3. 按 Ctrl+Alt+按一下 (Windows) 或按 Command+Option+按一下 (Macintosh) 影格,以選取單一影格來接收所複製的屬性。

    目的影格必須位於補間動畫範圍內。

  4. 若要將已複製的屬性貼入選定的影格,請執行下列其中一項:
    • 若要貼上所有已複製的屬性,請以滑鼠右鍵按一下 (Windows) 或 Command+按一下 (Macintosh) 目標補間動畫範圍中選取的影格,然後從快顯選單中選擇「貼上屬性」。
    • 若要貼上某些已複製的屬性,請以滑鼠右鍵按一下 (Windows) 或 Command+按一下 (Macintosh) 目標補間動畫範圍中選取的影格,然後從快顯選單中選擇「選擇性貼上屬性」。在顯示的對話方塊中,選取要貼上的屬性,然後按一下「確定」。

Animate 會在選取的影格中,為貼上的每一個屬性建立一個屬性關鍵影格,並重新補上移動補間動畫。

將補間動畫範圍轉換成逐格動畫

您可以將傳統補間動畫或移動補間動畫範圍轉換成逐格動畫。在逐格動畫中,每個影格都包含了不同的關鍵影格 (並非屬性關鍵影格),而其中每一個關鍵影格則都包含了不同的動畫元件實體。逐格動畫不包含內插補屬性值。如需詳細資訊,請參閱逐格動畫

  1. 以滑鼠右鍵按一下 (Windows) 或 Ctrl+按一下 (Macintosh) 要轉換的補間動畫範圍,然後從快顯選單中選擇「轉換成逐格動畫」。

編輯「時間軸」中的動畫補間動畫範圍

當您在 Animate 中建立動畫時,比較適當的做法是在「時間軸」內先設定補間動畫範圍。只要在圖層和影格中建立物件的原始排列方式,然後在「屬性」檢測器或「移動編輯器」中變更補間動畫屬性值,您就可以完成補間動畫。

若要在「時間軸」中選取補間動畫範圍和影格,請執行下列其中一個步驟:請確定「一般偏好設定」(「編輯 > 偏好設定」) 中已開啟「合併式選取範圍」。

  • 若要選取整個補間動畫範圍,請按一下範圍。

  • 若要選取多個補間動畫範圍 (包括非連續性的範圍),請按 Shift+按一下每個範圍。

  • 若要選取補間動畫範圍中的單一影格,請在範圍內按 Ctrl+Alt+按一下 (Windows) 或按 Command+Option+按一下 (Macintosh) 影格。

  • 若要選取範圍內多個連續影格,請於範圍內按 Ctrl+Alt+拖曳 (Windows) 或按 Command+Option+拖曳 (Macintosh) 所需的影格。

  • 若要選取不同圖層上的多個補間動畫範圍內的影格,請按 Ctrl+Alt-拖曳 (Windows) 或按 Command+Option+拖曳 (Macintosh) 越過多個圖層。

  • 若要選取補間動畫範圍中的個別屬性關鍵影格,請按 Ctrl+Alt+按一下 (Windows) 或按 Command+Option+按一下 (Macintosh) 屬性關鍵影格。接著,您即可將其拖曳到新的位置。

鍵盤修改選項的完整清單,用於處理「時間軸」中的補間動畫範圍,此清單可在 Flashthusiast.com 中取得。

移動、複製或刪除補間動畫範圍

  • 若要將某個範圍移動至相同圖層中的新位置,請拖曳該範圍。

    注意:鎖定圖層可避免在「舞台」上而不是在「時間軸」上編輯。在另一個範圍上方移動某個範圍將會耗用第二個範圍的重疊影格。

  • 若要將補間動畫範圍移至不同的圖層,請將範圍拖曳至該圖層,或將範圍複製並貼至新的圖層。

    您可以將補間動畫範圍拖曳至現有的一般圖層、補間動畫圖層、導引線圖層、遮色片圖層,或被遮色的圖層。如果新的圖層是一般的空白圖層,則該圖層會變成補間動畫圖層。

  • 若要複製範圍,請按住 Alt (Windows) 或 Command (Macintosh) 並將範圍拖曳至「時間軸」中的新位置,或複製並貼上範圍。

  • 若要刪除範圍,請選取範圍,並從範圍快顯選單中選擇「移除影格」或「清除影格」。

編輯相鄰的補間動畫範圍

  • 若要移動兩個連續補間動畫範圍間的中斷行,請拖曳該中斷行。

    每個補間動畫都會重新計算。

  • 若要分離兩個連續補間動畫範圍的相鄰起始影格和結束影格,請按住 Alt (Windows) 或 Command (Macintosh) 並拖曳第二個範圍的起始影格。

    這可讓您為兩個範圍間的影格提供空間。

  • 若要將某個補間動畫範圍分割為兩個不同的範圍,請按 Ctrl+按一下 (Windows) 或 Command+按一下 (Macintosh) 選取範圍內的單一影格,然後再從範圍的快顯選單中選擇「分割移動」。

    此時,兩個補間動畫範圍會具有相同的目標實體。

    注意:如果選取了一個以上的影格,便不能進行分割移動。分割的補間動畫若已套用加/減速,較小的兩個補間動畫可能無法以原來的方式移動。

  • 若要組合兩個連續的補間動畫範圍,請選取這兩個範圍,並從範圍的快顯選單選擇「接合移動」。

編輯補間動畫範圍的長度

  • 若要變更動畫的長度,請拖曳補間動畫範圍的左邊緣或右邊緣。

    將某個範圍的邊緣拖曳至另一個範圍的影格中,會取代第二個範圍中的影格。

  • 若要延長補間動畫物件在「舞台」上顯示的時間,請按住 Shift 鍵,然後拖曳其補間動畫範圍最左邊或最右邊的影格。Animate 會將影格加入範圍的末端,但這些影格並未製作補間動畫。

    您也可以選取相同圖層中補間動畫範圍之後的影格,然後按 F6。Animate 會擴充補間動畫範圍,並且將所有屬性的屬性關鍵影格都加入至選定的影格。如果您按 F5,Animate 只會加入影格,而不會將屬性關鍵影格加入至選定的影格。

    注意:若要將靜態影格加入至範圍的邊緣,緊接著另一個範圍,請先移動緊接在旁的範圍以挪出空間給新的影格。

在補間動畫範圍內新增或移除影格

  • 若要從範圍內移除影格,請按 Ctrl+拖曳 (Windows) 或 Command+拖曳 (Macintosh) 以選取影格,並從範圍的快顯選單中選擇「移除影格」。

  • 若要從範圍內剪下影格,請按 Ctrl+拖曳 (Windows) 或 Command+拖曳 (Macintosh) 以選取影格,然後從範圍的快顯選單中選擇「剪下影格」。

  • 若要將影格貼至現有的補間動畫範圍內,請按 Ctrl+拖曳 (Windows) 或 Command+拖曳 (Macintosh) 以選取要取代的影格,然後從範圍的快顯選單中選擇「貼上影格」。

    將整個範圍貼至另一個範圍,將會取代整個第二個範圍。

取代或移除補間動畫的目標實體

若要取代補間動畫範圍的目標實體,請執行下列其中一個步驟:

  • 選取範圍並將新元件從「元件庫」面板拖曳至「舞台」上。

  • 在「元件庫」面板中選取新元件,並在「舞台」上選取補間動畫的目標實體,然後選擇「修改 > 元件 > 替換元件」。

  • 選取範圍,然後從剪貼簿貼上元件實體或文字。

若要移除補間動畫範圍的目標實體,但不移除補間動畫,請選取範圍並按 Delete 鍵。

(Animate CC 不建議使用) 將移動複製為 ActionScript 3.0

ActionScript 3.0

針對使用 ActionScript 3.0 的 Animate 文件,複製「時間軸」中將移動補間動畫定義為 ActionScript 3.0 的屬性,並將該移動套用到「動作」面板或原始檔案 (例如類別檔案) 中的另一個元件。

對您的特定專案,使用 fl.motion 類別來自訂 Animate 所產生的 ActionScript。如需詳細資訊,請參閱「ActionScript 3.0 語言和組件參考」中的 fl.motion 類別。

「將移動複製為 ActionScript 3.0」命令可以擷取移動補間動畫的下列屬性:

  • 位置

  • Scale

  • 傾斜

  • 旋轉

  • 變形點

  • 顏色

  • 混合模式

  • 路徑方向

  • 快取為點陣圖設定

  • 加/減速

  • 濾鏡

  • 3D 旋轉與位置。

  1. 選取「時間軸」內的補間動畫範圍或「舞台」上的物件,其中包含所要複製的移動補間動畫。

    您只能選取一個補間動畫範圍或補間動畫物件,將其複製為 ActionScript 3.0。

  2. 請執行下列其中一項:
    • 選取「編輯 > 時間軸 > 將移動複製為 ActionScript 3.0」。
    • 以滑鼠右鍵按一下 (Windows) 或 Control+按一下 (Macintosh)「舞台」上的補間動畫範圍或補間動畫實體,然後選擇「將移動複製為 ActionScript 3.0」。

使用儲存為 XML 檔案的移動補間動畫

Animate 可讓您以 XML 檔案形式使用移動補間動畫。本質上,Animate 可讓您在任何移動補間動畫上套用下列命令:

  • 將移動複製為 XML
  • 將移動匯出為 XML
  • 將移動匯入為 XML
將移動複製為 XML
 
讓您可以在上述影格中,複製套用到「舞台」上任何物件的移動屬性。
  1. 建立移動補間動畫。
  2. 選取「時間軸」上的任何關鍵影格。
  3. 前往「命令 > 將移動複製為 XML」。
移動屬性隨即會以 XML 資料形式複製到剪貼簿,然後,您可以使用任何文字編輯器來處理 XML 檔案。
 
將移動匯出為 XML
 
讓您可以將套用到舞台上任何物件的移動屬性匯出到可以儲存的 XML 檔案。
  1. 建立移動補間動畫。
  2. 前往「命令 > 將移動匯出為 XML」。
  3. 瀏覽到您要儲存檔案的適當位置。
  4. 為 XML 檔案提供名稱,並按一下「儲存」。
移動補間動畫隨即會在指定的位置匯出為 XML 檔案。
 
將移動匯入為 XML
 
讓您可以匯入已定義移動屬性的現有 XML 檔案。
  1. 選取「舞台」上的任何物件。
  2. 前往「命令 > 將移動匯入為 XML」。
  3. 瀏覽至位置,並選取 XML 檔案。按一下「確定」。
  4. 在「選擇性貼上移動」對話方塊中,選取您要在選取的物件上套用的屬性。
  5. 按一下「確定」。
 

移動補間動畫簡介

使用補間動畫將位置製成動畫

使物件在「舞台」上移動或滑動:

  1. 選取要在「舞台」上製成補間動畫的元件實體或文字欄位。物件可以位於下列任何圖層類型:一般、導引、遮色片或被遮色。

    若選取範圍包含其他物件,或包含一個圖層中的多個物件,Animate 可讓您將選取範圍轉換成影片片段元件。

    若要反選,請以滑鼠右鍵按一下物件並選取「反選」。

     
  2. 請執行下列其中一項:

    • 選擇「插入 > 移動補間動畫」。

    • 以滑鼠右鍵按一下 (Windows) 或 Ctrl+按一下 (Macintosh) 選取範圍或目前的影格,然後在快顯選單中選擇「建立移動補間動畫」。

    若顯示「將選取項目轉換為元件以做為補間動畫」對話方塊,請按一下「確定」以將選取範圍轉換成影片片段元件。

    如果補間動畫物件是圖層上的唯一項目,Animate 會將包含該物件的圖層轉換為補間動畫圖層。若圖層中有其他物件,Animate 會插入圖層以維持堆疊順序。Animate 會將補間動畫物件放在其專屬圖層中。

    如果原始物件只位在「時間軸」的第一個影格中,補間動畫範圍的長度就等於一秒的長度。如果原始物件出現在一個以上的連續影格中,則補間動畫範圍會包含由原始物件所佔用的影格數。

  3. 在「時間軸」中拖曳補間動畫範圍的任何一端,將範圍縮短或延長至所需的影格數目。補間動畫中的任何現有屬性關鍵影格都會隨著此範圍尾端而等比例移動。

    若要移動範圍的尾端而不移動任何現有關鍵影格,請按 Shift+拖曳補間動畫範圍的尾端。

  4. 若要新增移動至補間動畫,請在補間動畫範圍內的影格上放置播放磁頭,然後將物件拖曳至新的位置。

    移動路徑會顯示在「舞台」上,顯示從補間動畫範圍內第一個影格的位置至新位置的路徑。因為您已明確定義了物件的 X 與 Y 屬性,所以就會為內含播放磁頭的影格中的 X 和 Y 加入屬性關鍵影格。屬性關鍵影格在補間動畫範圍中就會顯示為小菱形。

    註解:

    根據預設,「時間軸」會顯示所有屬性類型的屬性關鍵影格。您可以用滑鼠右鍵按一下 (Windows) 或 Command+按一下 (Macintosh) 補間動畫範圍,然後選擇「檢視關鍵影格 > 屬性類型」,以選擇要顯示哪些類型的屬性關鍵影格。

  5. 若要指定物件的另一個位置,請在補間動畫範圍內的另一個影格中放置播放磁頭,並在「舞台」上將物件拖曳至另一個位置。

    此時會調整移動路徑,以包含您指定的所有位置。

  6. 若要將 3D 旋轉或位置製成補間動畫,請使用「3D 旋轉」或「3D 轉譯」工具。請確定先將播放磁頭置於您要在其中加入 3D 屬性關鍵影格的影格內。

建立補間動畫

建立補間動畫的步驟。

開始之前

開始將屬性製成動畫之前,請記住下列事項:

ActionScript 並非必要。與 Animate 中的許多項目相同,動畫也不需要任何 ActionScript。不過,您可以選擇使用 ActionScript 來建立動畫。

時間軸與編輯屬性的基本概念。在開始使用移動補間動畫之前,請熟悉時間軸與編輯屬性的基本用法。請參閱影格與關鍵影格瞭解基本概念。

您可以在「舞台」上、「屬性」檢測器或「移動編輯器」中編輯個別屬性關鍵影格。請注意,許多簡單的移動補間動畫類型不一定要使用「移動編輯器」來建立。

移動編輯器已於 Animate CC 中被取代。

僅限元件實體與文字欄位。Animate 只會將元件實體與文字欄位製成補間動畫。對它們套用補間動畫時,便會將所有的其他物件類型包覆在元件中。元件實體可以包含巢狀元件,而巢狀元件可以在本身的時間軸上製作補間動畫。

每一補間動畫一個物件。補間動畫圖層中最小的建構區塊即是補間動畫範圍。補間動畫圖層中的補間動畫範圍僅可以包含一個元件實體或文字欄位。元件實體為補間動畫範圍的目標。不過,單一元件可以包含許多物件。

變更目標。將第二個元件或文字欄位加入至補間動畫範圍內會取代補間動畫中的原始元件。您可以透過將元件庫中的不同元件拖曳到「時間軸」中的補間動畫範圍,或是使用「修改 > 元件 > 替換元件」命令,以變更補間動畫的目標物件。您可以從補間動畫圖層刪除元件,不需移除或打散補間動畫。稍後,您還能再將另一個元件實體加入至補間動畫。您也可以隨時變更目標元件的類型或是編輯元件。

編輯移動路徑。補間動畫包含移動時,「舞台」上便會顯示移動路徑。移動路徑會顯示每個影格中補間動畫物件的位置。您可以拖曳移動路徑的控制點,以編輯「舞台」上的移動路徑。您不能將移動導引線加入至補間動畫/反向運動圖層。

如需有關以反向運動進行補間動畫的資訊,請參閱將骨架製作成動畫

將補間動畫加入時間軸

當您將補間動畫新增至圖層上的物件時,Animate 便會執行下列動作:

  • 將圖層轉換為補間動畫圖層。

  • 建立新圖層以維持物件在圖層上的原始堆疊順序。

圖層會依據下列規則加以新增:

  • 如果圖層上除選取的物件外並無其他物件,該圖層將變更為補間動畫圖層。

  • 若選取範圍在圖層堆疊順序的底部 (在其他所有物件下方),Animate 會在原始圖層上方建立一個圖層。這個新圖層會保存未選取的項目。原始圖層會成為補間動畫圖層。

  • 若選取範圍在圖層堆疊順序的頂層 (在其他所有物件上方),Animate 會建立新圖層。選取範圍會移至新圖層,而該圖層會成為補間動畫圖層。

  • 若選取範圍在圖層堆疊順序的中間 (選取範圍上方及下方都有物件),Animate 會建立兩個圖層。一個圖層會保存新的補間動畫,另一個在其上方的圖層則會將未選取的項目保存在堆疊順序的頂層。位於堆疊順序最底層的未選取項目仍將放在原始圖層上,置於新插入的圖層之下。

補間動畫圖層可以包含補間動畫範圍,以及靜態影格和 ActionScript。然而,包含補間動畫範圍的補間動畫圖層,其影格不得包含補間動畫物件以外的物件。若要在同一個影格中加入額外的物件,請將各物件分置於不同圖層上。

使用屬性檢測器補間其他屬性

「建立移動補間動畫」命令可讓您將元件實體或文字欄位的多數屬性 (例如旋轉、縮放、透明度或著色 (僅限元件和 TLF 文字)) 製成動畫。例如,您可以編輯元件實體的 Alpha (透明度) 屬性,使其淡入畫面。如需可使用移動補間動畫製成動畫的屬性清單,請參閱可補間的物件與屬性

  1. 選取「舞台」上的元件實體或文字欄位。

    若選取範圍包含其他物件,或包含一個圖層中的多個物件,Animate 可讓您將其轉換成影片片段元件。

  2. 選擇「插入 > 移動補間動畫」。

    若顯示「將選取項目轉換為元件以做為補間動畫」對話方塊,請按一下「確定」以將選取範圍轉換成影片片段元件。

    當您將補間動畫套用至只存在於一個關鍵影格中的物件時,播放磁頭就會移至新的補間動畫的最後一個影格。否則,播放磁頭就不會移動。

  3. 請將播放磁頭放置在補間動畫範圍內,您要指定屬性值的影格中。

    您也可以將播放磁頭放置在補間動畫範圍內的任何其他影格中。補間動畫會以補間動畫範圍第一個影格中的數值啟動,該影格一定會是屬性關鍵影格。

  4. 選取「舞台」上的物件,然後設定非位置屬性 (例如 Alpha (透明度)、旋轉或傾斜) 的值。請使用「屬性」檢測器或「工具」面板中的工具來設定值。

    範圍中目前的影格就會變成屬性關鍵影格。

    註解:

    您可在補間動畫範圍顯示不同類型的屬性關鍵影格。以滑鼠右鍵按一下 (Windows) 或 Ctrl+按一下 (Macintosh) 補間動畫範圍,從快顯選單中選擇「檢視關鍵影格 > 屬性類型」。

  5. 拖曳「時間軸」中的播放磁頭,預覽「舞台」上的補間動畫。

  6. 若要加入其他屬性關鍵影格,請將播放磁頭移至範圍內所需的影格,然後在「屬性」檢測器中設定屬性值。

將其他補間動畫加入至現有的補間動畫圖層

您可以將其他補間動畫加入至現有的補間動畫圖層。當您使用動畫建立 Animate 內容時,這樣可以使用較少的圖層。

  1. 請執行下列其中一項:
    • 在圖層上加入空白關鍵影格 (「插入 > 時間軸 > 空白關鍵影格」)、將項目加入關鍵影格,然後將項目製作成補間動畫。
    • 在另一個圖層上建立補間動畫,然後再將範圍拖曳至所需的圖層。
    • 將靜態影格從另一個圖層拖曳至補間動畫圖層,然後再將補間動畫加入至靜態影格中的某個物件。
    • 按 Alt+拖曳 (Windows) 或按 Option+拖曳 (Macintosh) 可重製相同圖層或不同圖層中的現有範圍。
    • 從相同或不同圖層複製並貼上補間動畫範圍。

Animate 會將描述選定之移動補間動畫的 ActionScript 3.0 程式碼,複製到系統的剪貼簿。這個程式碼將補間動畫描述為逐格動畫。

若要使用複製的程式碼,請將程式碼貼至 Animate 文件的「動作」面板,此面板內含您要接收複製的補間動畫的元件實體。將呼叫 addTarget() 函數的程式碼取消註解,並以您要製作動畫的元件實體的名稱,取代該行內的 <實體名稱位於此> 文字。

若要用貼上的 ActionScript 為您要製成動畫的元件實體命名,請選取「舞台」上的實體,然後在「屬性」檢測器中輸入名稱。

您也可以選取「時間軸」內的補間動畫範圍,然後在「屬性」檢測器中輸入移動補間動畫的名稱,為移動補間動畫實體命名。接著,便能在 ActionScript 3.0 程式碼內參考該補間動畫範圍。

如需有關使用 ActionScript 3.0 製作動畫的詳細資訊,請參閱「Adobe® Flash® Professional CS5 的 ActionScript® 3.0 參考」中的 fl.motion 類別。

請參閱

 

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策