SVG fájlok importálása

Utoljára frissítve: 2026. szept. 29.

Ismerje meg, hogyan importálhat SVG fájlokat natív, szerkeszthető alakzatrétegként, amelyek azonnal animálhatók, konverzió nélkül.

Kattintson duplán a Projekt panelen belül, vagy használja a Fájl > Importálás > Fájl menüt az SVG fájl tallózásához és importálásához.

Jegyzet

Az After Effects legújabb verziója lehetővé teszi, hogy importálja a fájlt felvételként vagy kompozícióként.

Húzza át az importált SVG fájlt az Idővonal panelre.

Válassza ki a réteget, hogy a Réteg tartalma szakaszt használja a Tulajdonságok panelen az SVG szerkezetének megtekintéséhez.

A Tulajdonságok panel nyitva van, és a Réteg tartalma alatt az SVG-tartalmak fel vannak sorolva.
Használja a Tulajdonságok panelt az SVG fájl tartalmának megtekintéséhez és tulajdonságainak módosításához.

Az is lehetséges, hogy a réteg melletti nyílra kattintva kibontsa, majd bővítse ki a Tartalom szakaszt.Látni fogja az összes egyedi elemet és tulajdonságaikat, mint például a Útvonal, Kitöltés és Transzforálás.

Az SVG fájlt tartalmazó réteg ki van választva, és a Tartalom szakasz ki van bontva, hogy megjelenítse tulajdonságait, beleértve az Útvonal, Kitöltés és Transzformálás elemeket.
Bontsa ki az SVG réteg Tartalom szakaszát a tulajdonságok eléréséhez és szerkesztéséhez, beleértve az Útvonal, Kitöltés és Transzformálás elemeket.

Ezeket a tulajdonságokat ugyanúgy animálhatja, mint bármely más alakzatréteget.Például:

  • Animálja az Útvonalat morfing effektek létrehozásához
  • Változtassa a kitöltés színét az idő múlásával dinamikus átmenetek érdekében
  • Használja a Transzformálás tulajdonságokat az elemek független méretezéséhez, forgatásához vagy mozgatásához

Ha a rétegek színátmenet-kitöltésekkel és körvonalakkal rendelkeznek, használhatja a Méretezés és Forgatás tulajdonságokat a színátmenet animálásához.

Az egyik, színátmenet-elemet tartalmazó réteg ki van választva, és a Színátmenet-kitöltés 1 kiemelve látható.
A színátmenet-kitöltés tulajdonságaival állíthatja be a színátmenetet vagy animálhatja őket.

SVG fájl importálása felvételként vagy kompozícióként

Az SVG importálás az After Effectsben rugalmas és jobb kontrollt biztosít az SVG fájlok projektbe történő importálása felett.A legújabb verzióval SVG fájl importálásakor választhatja, hogy felvételként vagy kompozícióként szeretné behozni.

Importálás felvételként

Importálás kompozícióként

Az SVG-t egyetlen, folyamatosan raszterizálható vektorrétegként importálja.

Az SVG-t szerkeszthető alakzatrétegekből álló kompozícióként importálja.

Fenntartja a kapcsolatot a külső SVG-fájllal.

Minden elemet saját szerkeszthető alakzattá alakít.

Jó választás egyrétegű vektorgrafikai elemekhez, amikor nincs szükség az alkotás részeire bontására.

Jó választás útvonalak, alakzatok és rétegszintű részletek szerkesztéséhez, amikor az egyes elemeket külön-külön kell animálni.

Az SVG-fájlok importálásakor alapértelmezés szerint használt importálási módszert a Több fájlelem húzása mint beállítás módosításával szabályozhatja az Importálás beállítások alatt.

  • macOS: After Effects > Beállítások > Importálás > Több fájlelem húzása mint
  • Windows: Szerkesztés > Beállítások > Importálás > Több fájlelem húzása mint
A Beállítások párbeszédpanel nyitva van. Az Importálás lapon a Több fájlelem húzása mint legördülő menü nyitva van, amely lehetőségeket kínál az importálási módszer kiválasztásához.
Állítsa be az alapértelmezett beállítást az SVG-fájl importálásához, és válassza ki, hogy felvételként vagy kompozícióként importálja.

Kattintson duplán a Projekt panelben, vagy használja a Fájl > Importálás > Fájl menüpontot az SVG-fájl tallózásához és importálásához.

Használja az Importálás mint legördülő menüt az Fájl importálása párbeszédpanelen a következők egyikének kiválasztásához:

  • Felvétel
  • Kompozíció - Rétegméretek megtartása

A Felvétel kiválasztása a fájlt egyetlen lapított rétegként importálja, az egyes elemekhez való hozzáférés nélkül, így alkalmas statikus használatra vagy amikor nincs szükség animációra. A Kompozíció – Rétegméretek megtartása kiválasztása új kompozíciót hoz létre, ahol minden forrásnatet külön-külön, a valódi tartalom méretében importál, így a szerkesztőpontok tisztábbak, és az átalakítások könnyebbek az animáláshoz.

macOS

A Fájl importálása párbeszédpanel nyitva van, és lehetőség van a fájl felvételként vagy kompozícióként való importálására.

Windows

A Fájl importálása párbeszédpanel nyitva van, és lehetőség van a fájl felvételként vagy kompozícióként való importálására.

Válassza ki a következő beállításokat, ha szükséges:

  • Kompozíció létrehozása: Új kompozíciót hoz létre az alapértelmezett beállítások használatával, és automatikusan elhelyezi az importált SVG-t, akár felvételként, akár alakzatrétegekkel rendelkező kompozícióként, az idővonalra, így nem kell manuálisan kompozíciót létrehoznia és az SVG-fájlt belehúznia.
  • Skálázható vektorgrafikai sorozat: Több számozott SVG-fájlt importál, és képkockánként vektoros képsorozatként kezeli őket.

Ha az SVG-fájlt kompozícióként importálta, az egyes elemek és azok tulajdonságainak megtekintéséhez és kezeléséhez használja a Tulajdonságok panel Réteg tartalma szakaszát, vagy az idővonalon a réteg Tartalom szakaszát.Ha felvételként importálja, normál rétegként viselkedik, és a szokásos Átalakítás tulajdonságokkal módosítható.

Az Illustrator-fájlokhoz hasonlóan, ha a vektorfájlt felvételként importálja, kijelölheti a réteget az idővonalon, majd kattintson rá a jobb egérgombbal, és válassza a Létrehozás > Alakzatok és szöveg létrehozása vektorrétegből lehetőséget, hogy szerkeszthető rétegekké alakítsa, lehetővé téve az egyes útvonalak, körvonalak és kitöltések animálását. A legújabb After Effects Beta verzióban a forrásfájlban lévő szöveg szerkeszthető szövegrétegekké alakul át, amelyek megőrzik a betűtípust, a méretet, a kitöltést, a pozíciót, a stílusokat, a körvonalakat és a változó betűtípus beállításait. 

Ha egy SVG-t felvételként importál, az After Effects élő kapcsolatot tart fenn az eredeti fájllal, így az adott SVG-n az alkalmazáson kívül végzett módosítások automatikusan frissülnek a projektben is.

Illustrator-szöveg átalakítása szerkeszthető szövegrétegekké

Használja az új Beta funkciókat

Az Illustrator-fájlokból származó szerkeszthető szöveg mostantól tesztelésre és visszajelzésre is elérhető. Próbálja ki most az After Effectsben (beta).

A legújabb After Effects Beta verzióban, amikor egy Illustrator-réteget felvételként importál, a forrásfájlban lévő szöveg saját szerkeszthető szövegréteggé alakul ahelyett, hogy alakzati körvonalakká lapulna.Ez azt jelenti, hogy a betűtípus, a méret, a kitöltés, a pozíció, a stílusok (például a félkövér és a dőlt), a körvonalak és a változó betűtípus beállításai mind megmaradnak, így közvetlenül az After Effectsben szerkesztheti tovább a szöveget ahelyett, hogy újra létrehozná a semmiből, vagy visszatérne az Illustratorba a módosítások elvégzéséhez.

Válassza a Fájl > Importálás > Fájl lehetőséget, majd az importálni kívánt Illustrator-fájlt.

A(z) Fájl importálása párbeszédpanelen a fájl kiválasztásakor győződjön meg arról, hogy a(z) Importálás típusa beállítása Felvétel legyen.

Az importálási párbeszédpanelen erősítse meg, hogy az Importálás típusa beállítás értéke Felvétel, majd válassza ki a(z) Rétegbeállítások lehetőséget annak alapján, hogy mit szeretne importálni az Illustrator-fájlból.

Húzza az importált fájlt az Idővonal panelre.

Kattintson jobb gombbal az Illustrator-rétegre, és válassza a Létrehozás > Alakzatok és szöveg létrehozása vektorrétegből lehetőséget, vagy használja a(z) Réteg > Létrehozás > Alakzatok és szöveg létrehozása vektorrétegből elemet.

Réteg > Létrehozás almenü, benne kiemelve az Alakzatok és szöveg létrehozása vektorrétegből lehetőséget, amely a vektorszöveget szerkeszthető szövegrétegekké alakítja.
Válassza az Alakzatok és szöveg létrehozása vektorrétegből lehetőséget, hogy az Illustrator-szöveget alakzatok helyett szerkeszthető After Effects szövegrétegekké alakítsa.

A szöveg szerkeszthető szövegréteggé alakul, amely nagyon hasonlít az eredeti fájl betűtípusára, méretére, kitöltésére és pozíciójára.Ezután közvetlenül az After Effectsben szerkesztheti és módosíthatja a szöveget.

Fényesség szövegréteg egy lánggrafika fölött, a Karakter panelen Adobe Clean Italic betűtípus, 74 képpontos méret és bekapcsolt Kitöltés látható.
Az átalakítás után a szöveg teljes mértékben szerkeszthető marad — a betűtípus, a stílus, a méret és a kitöltés továbbra is módosítható a Karakter panelen.

Jegyzet

A csak körvonalas szöveg továbbra is görbékként alakul át, nem pedig szerkeszthető szövegréteggé. 

A nem szöveges vektortartalom továbbra is alakzatrétegekké alakul, mint korábban, és ha az Illustrator-fájl mindkettőt tartalmazza, akkor szöveg- és alakzatrétegek keverékét kapja.

Csatlakozzon a beszélgetéshez az After Effects (Beta) közösségében az Illustrator fájlok szerkeszthető szövegének támogatásáról.

Illustrator és SVG tartalom másolása és beillesztése

A vágólapon lévő SVG tartalom mostantól beilleszthető After Effects alkalmazásba a Szerkesztés > Beillesztés használatával.A tartalom natív, szerkeszthető alakzatrétegként kerül importálásra, amely készen áll az animálásra, közbenső importálás nélkül.

Tartalom másolása az Illustratorból

Nyissa meg alkotását Adobe Illustratorban.

Győződjön meg róla, hogy az SVG kód hozzáadása beállítás ki van választva.

  • macOS: Válassza az Illustrator > Beállítások > Vágólap kezelése menüt, és válassza az SVG kód hozzáadása lehetőséget.
  • Windows: Válassza a Szerkesztés > Beállítások > Vágólap kezelése menüt, és válassza az SVG kód hozzáadása lehetőséget.
A Beállítások párbeszédpanel meg van nyitva az Illustratorban, és az SVG kód hozzáadása opció ki van választva.
Engedélyezze az SVG kód hozzáadása funkciót, hogy alkotása szerkeszthető és jó minőségű maradjon más Adobe alkalmazásokban.

Válassza ki a másolni kívánt alkotást.

Tipp

Az SVG szöveget görbékké kell alakítani másolás előtt, mivel az SVG szöveg nem támogatott beillesztéskor.

Válassza a Szerkesztés > Másolás menüt.

Váltson az After Effects alkalmazásra, és tegye az alábbiak egyikét a projekt állapotától függően:

  • Ha nincs projekt megnyitva, válassza a Szerkesztés > Beillesztés menüt új projekt létrehozásához az SVG tartalmat alakzatrétegként tartalmazó kompozícióval.
  • Ha egy projekt meg van nyitva, de nincs kompozíció kiválasztva, válassza a Szerkesztés > Beillesztés menüt új kompozíció létrehozásához az aktuális projektben a beillesztett tartalommal.
Válassza a Szerkesztés > Beillesztés lehetőséget, és a tartalom natív, szerkeszthető alakzatrétegként importálódik, animálásra készen.
A Szerkesztés > Beillesztés szerkeszthető alakzatrétegként hozza be a tartalmat, készen az animálásra.

Ha egy kompozíció ki van választva After Effects alkalmazásban, válassza a Szerkesztés > Beillesztés menüt az SVG tartalom új alakzatrétegként való hozzáadásához abban a kompozícióban.

SVG beillesztése más alkalmazásokból

Bármely alkalmazásból másolt SVG tartalom, amely SVG-t ír a rendszervágólapra, beilleszthető ugyanazzal a Szerkesztés > Beillesztés munkafolyamattal.A támogatás attól függ, hogy a forrás alkalmazás érvényes SVG adatokat helyez-e el a vágólapon.