Adobe Illustrator AI 파일

Animate에서는 Adobe® Illustrator® AI 파일을 가져오고 아트워크의 편집 가능성과 시각적 품질을 대부분 유지할 수 있습니다. 또한 AI 가져오기 프로그램은 Illustrator 아트워크를 Animate로 가져오는 방법을 결정하는 뛰어난 수준의 제어 기능을 제공하므로 특정 객체를 AI 파일로 가져오는 방법을 지정할 수 있습니다.

Animate AI 가져오기 프로그램은 다음 주요 기능을 제공합니다.

  • 가장 일반적으로 사용하는 Illustrator 효과의 편집 가능성을 Animate 필터로 유지합니다.

  • Animate 및 Illustrator에서 공통으로 가지는 블렌드 모드의 편집 가능성을 유지합니다.

  • 그래디언트 채우기의 품질과 편집 가능성을 유지합니다.

  • RGB(빨강, 녹색, 파랑) 색상의 모양을 유지합니다.

  • Illustrator 심볼을 Animate 심볼로 가져옵니다.

  • 베지어 제어점의 수와 위치를 유지합니다.

  • 클립 마스크의 품질을 유지합니다.

  • 패턴 획과 채우기의 품질을 유지합니다.

  • 객체 투명도를 유지합니다.

  • AI 파일 레이어를 개별 Animate 레이어, 키프레임 또는 단일 Animate 레이어로 변환합니다. 또한 AI 파일을 단일 비트맵 이미지로 가져올 수 있으며 이 경우 Animate는 파일을 병합(래스터화)합니다.

  • Illustrator와 Animate 간의 향상된 복사하여 붙여넣기 작업 과정을 제공합니다. 복사하여 붙여넣기 대화 상자에는 Animate 스테이지에 붙여넣는 AI 파일에 적용할 설정이 있습니다.

Animate와 Illustrator 간 호환성

특정 시각적 특성은 정확하게 가져올 수 없거나, 가져왔다 하더라도 Animate 제작 환경에서 추가로 편집할 수 없을 수 있습니다. AI 가져오기 프로그램은 시각적 모양과 편집 가능성을 최대한 유지하기 위해 아트워크를 가져와 배치하는 여러 옵션을 제공합니다. 그러나 특정 시각적 특성은 유지할 수 없습니다. 다음 지침에 따라 Animate로 가져오는 AI 파일의 모양을 향상시킵니다.

  • Animate에서는 RGB 색상 영역만 지원되고 인쇄에 일반적으로 사용되는 CMYK 색상 영역은 지원되지 않습니다. Animate에서 CMYK 이미지를 RGB로 변환할 수 있지만 Illustrator에서 색상을 RGB로 변환할 경우 색상이 더욱 잘 유지됩니다.

  • 그림자, 내부 광선, 외부 광선, 가우시안 흐림 AI 효과를 편집 가능한 Animate 필터로 유지하기 위해 Animate는 이러한 효과가 Animate 동영상 클립으로 적용되는 객체를 가져옵니다. 이러한 특성의 객체를 동영상 클립이 아닌 다른 항목으로 가져오려고 하면 Animate에 비호환성 경고가 표시되며 객체를 동영상 클립으로 가져오는 것이 좋다는 메시지가 나타납니다.

Illustrator 및 Animate를 사용한 작업

Illustrator 아트워크를 Animate 편집 환경으로 이동하거나 Flash Player로 직접 이동할 수 있습니다. 아트워크를 복사하여 붙여 넣고 파일을 SWF 형식으로 저장하거나 아트워크를 Animate로 직접 내보낼 수 있습니다. 또한 Illustrator에서는 Animate 동적 텍스트 및 동영상 클립 심볼을 지원합니다.

Illustrator 아트워크 붙여넣기

Illustrator에서 그래픽이 풍부한 아트워크를 만들고 Animate에 간단하고, 빠르고, 매끄럽게 복사하여 붙여넣을 수 있습니다.

Illustrator 아트워크를 Animate에 붙여넣는 경우 다음 특성이 유지됩니다.

  • 패스 및 모양

  • 크기 조절

  • 획 두께

  • 그래디언트 정의

  • 텍스트(OpenType 글꼴 포함)

  • 연결된 이미지

  • 심볼

  • 혼합 모드

또한 Illustrator와 Animate는 붙여넣은 아트워크를 다음 방법으로 지원합니다.

  • Illustrator 아트워크에서 전체 최상위 레이어를 선택하여 Animate에 붙여넣는 경우 속성(가시성 및 잠금)과 함께 레이어가 유지됩니다.

  • 비 RGB Illustrator 색상(CMYK, 회색 음영 및 사용자 정의)은 Animate에서 RGB로 변환됩니다. RGB 색상은 예상대로 붙여넣어집니다.

  • Illustrator 아트워크를 가져오거나 붙여넣을 때 다양한 옵션을 사용하여 텍스트의 그림자와 같은 효과를 Animate 필터로 유지할 수 있습니다.

  • Animate에서는 Illustrator 마스크가 유지됩니다.

Illustrator에서 SWF 파일 내보내기

Animate에서 내보낸 SWF 파일의 품질 및 압축과 일치하는 SWF 파일을 Illustrator에서 내보낼 수 있습니다.

내보낼 때 다양한 사전 설정을 선택하여 최적의 출력을 확인할 수 있고 여러 대지, 심볼, 레이어, 텍스트 및 마스크 처리 방법을 지정할 수 있습니다. 예를 들어, Illustrator 심볼을 동영상 클립으로 내보낼지 또는 그래픽으로 내보낼지 지정할 수 있고 Illustrator 레이어에서 SWF 심볼을 만들도록 선택할 수 있습니다.

Illustrator 파일을 Animate로 가져오기

Illustrator에서 전체 레이아웃을 만든 다음 한번에 Animate로 가져오려는 경우, Animate에서 [파일] > [스테이지로 가져오기] 또는 [파일] > [라이브러리로 가져오기] 명령을 사용하여 아트워크를 기본 Illustrator 형식(AI)으로 저장하고 높은 정확도를 유지하면서 Animate로 가져올 수 있습니다.

Illustrator 파일에 대지가 여러 개 포함되어 있는 경우 Animate의 [가져오기] 대화 상자에서 가져올 대지를 선택한 다음 해당 대지에서 모든 레이어에 대한 설정을 지정합니다. 선택한 대지의 모든 객체를 Animate에서 단일 또는 여러 Animate 레이어 또는 키프레임으로 가져올 수 있습니다.

Illustrator 아트워크를 AI, EPS 또는 PDF 파일로 가져오는 경우 Animate에서는 붙여넣은 Illustrator 아트워크와 동일한 특성이 유지됩니다. 또한 가져온 Illustrator 파일에 레이어가 포함되어 있으면 다음 방법 중 하나로 레이어를 가져올 수 있습니다.

  • Illustrator 레이어를 Animate 레이어로 변환

  • Illustrator 레이어를 Animate 프레임으로 변환

  • 모든 Illustrator 레이어를 단일 Animate 레이어로 변환

심볼 작업 과정

Illustrator의 심볼 작업 과정은Animate의 심볼 작업 과정과 비슷합니다.

텍스트 변환

AI 파일에 텍스트가 있을 경우 텍스트를 다음으로 변환할 수 있습니다.

  • 편집 가능한 텍스트 
  • 벡터 외곽선
  • 병합된 비트맵 이미지

레이어 변환

Animate CC에서 가져온 AI 파일의 레이어를 다음으로 변환할 수 있습니다.

  • 단일 병합 비트맵 파일
  • 편집 가능한 경로 및 효과

(Flash Professional CS6 이하 버전만 해당) 심볼 속성 및 링크

[심볼] 패널 또는 [컨트롤] 패널을 사용하여 심볼 인스턴스에 이름을 할당하고, 인스턴스와 심볼 간의 링크를 끊고, 심볼 인스턴스와 다른 심볼을 교환하거나 심볼의 복사본을 만드는 작업을 쉽게 할 수 있습니다. Animate에서 [라이브러리] 패널의 편집 기능은 비슷한 방식으로 작동합니다.

(Flash Professional CS6 이하 버전만 해당) 정적, 동적 및 입력 텍스트 객체

정적 텍스트를 Illustrator에서 Animate로 가져오는 경우 Animate에서 텍스트가 외곽선으로 변환됩니다. 또한 텍스트를 Illustrator에서 동적 텍스트로 설정할 수 있습니다. 동적 텍스트를 사용하면 Animate에서 텍스트 내용을 프로그래밍 방식으로 편집하고 여러 언어로 번역해야 하는 프로젝트를 간편하게 관리할 수 있습니다.

Illustrator에서 개별 텍스트 오브젝트를 정적, 동적 또는 입력 텍스트로 지정할 수 있습니다. Illustrator 및 Animate의 동적 텍스트 오브젝트는 비슷한 속성을 가집니다. 예를 들어, Illustrator와 Flash 모두 개별적인 문자가 아닌 텍스트 블록의 모든 문자에 영향을 주는 커닝을 사용하고, 앤티 앨리어스 텍스트도 같은 방식으로 작동하며, 텍스트를 포함하는 외부 XML 파일에 연결할 수 있습니다.

Animate 라이브러리로 AI 파일 가져오기

AI 파일을 라이브러리로 가져오는 작업은 스테이지로 가져오는 작업과 비슷하지만 전체 AI 파일이 Animate 심볼로 캡슐화된다는 점에서 다릅니다. 내용을 라이브러리로 가져온 다음 AI 파일의 레이어 및 그룹화 구조에 따라 구성합니다.

AI 파일을 라이브러리로 가져올 경우 루트 폴더는 AI 파일의 이름을 사용합니다. AI 파일을 라이브러리로 가져오면 루트 폴더의 이름을 변경하거나 레이어를 폴더 밖으로 이동할 수 있습니다.

참고: [라이브러리] 패널에는 가져온 AI 파일의 내용이 알파벳 순서로 나열됩니다. 계층적 그룹화 및 폴더 구조는 그대로 유지되지만 라이브러리에서 해당 파일을 알파벳 순서로 다시 나열합니다.

 

AI 레이어를 키프레임으로 변환하면 AI 파일을 동영상 클립으로 가져오게 되며 AI 레이어를 Flash 레이어 또는 단일 Flash 레이어로 변환하면 AI 파일을 그래픽 심볼로 가져오게 됩니다. 결과 동영상 클립 또는 그래픽 심볼은 스테이지로 내용을 가져온 경우처럼 해당 타임라인으로 가져온 AI 파일의 모든 내용을 포함합니다. 거의 모든 동영상 클립은 연관된 비트맵 또는 다른 에셋을 가집니다. 혼동 및 이름 충돌을 최소화하기 위해 이러한 에셋이 동영상 클립과 동일한 폴더의 Assets 폴더에 저장됩니다.

참고: 라이브러리로 가져올 경우 AI 파일의 내용을 기본 Animate 타임라인이 아닌 동영상 클립의 타임라인으로 가져오게 됩니다.

 

AI 파일을 가져온 후의 라이브러리 패널

(Flash Professional CS6 이하 버전만 해당) AI 파일 가져오기 프로그램 환경 설정

Animate [환경 설정] 대화 상자를 사용하면 AI 파일 및 [AI 파일 가져오기 프로그램] 대화 상자의 가져오기 환경 설정을 지정할 수 있습니다. AI 파일을 가져오기 위해 지정한 환경 설정은 Illustrator 객체 유형에 대해 초기 [AI 가져오기] 대화 상자를 채우는 옵션에 영향을 줍니다.

참고:

객체별로 객체의 다른 레이어 유형에 대해 지정된 환경 설정을 무시하려면 [AI 가져오기] 대화 상자를 사용합니다. 가져오기 옵션을 변경할 레이어, 객체 또는 그룹을 선택하고 필요한 옵션을 지정하십시오.

일반

AI 파일을 가져올 때 AI 가져오기 프로그램이 수행할 작업에 영향을 주는 환경 설정입니다.

가져오기 대화 상자 표시

[AI 파일 가져오기 프로그램] 대화 상자가 표시되도록 지정합니다.

자르기 영역 밖의 객체 제외

대지 또는 자르기 영역 밖에 있는 Illustrator 캔버스의 객체를 제외합니다.

숨겨진 레이어 불러오기

숨겨진 레이어를 기본적으로 가져오도록 지정합니다.

텍스트를 다음 형식으로 가져오기

텍스트 객체에 대해 다음과 같은 가져오기 환경 설정을 지정할 수 있습니다.

편집 가능한 텍스트

가져온 Illustrator 텍스트가 편집 가능한 Animate Pro 텍스트이도록 지정합니다. 텍스트의 편집 가능성을 유지하기 위해 텍스트의 모양이 손상될 수 있습니다.

벡터 외곽선

텍스트를 벡터 패스로 변환합니다. 텍스트의 시각적 모양을 유지하려면 이 옵션을 사용합니다. 지원되지 않는 블렌드 모드 및 필터와 같은 일부 시각적 효과가 손상될 수 있지만 텍스트를 동영상 클립으로 가져올 경우 패스에 있는 텍스트와 같은 시각적 특성은 유지됩니다. 텍스트 자체는 더 이상 편집할 수 없지만 불투명도 및 호환되는 블렌드 모드는 편집 가능성을 유지합니다.

참고: 텍스트에 적용된 그림자, 내부 광선, 외부 광선 및 가우시안 흐림과 같은 AI 효과를 편집 가능한 Animate 필터로 유지하려면 [동영상 클립 가져오기 만들기]를 선택하여 텍스트를 동영상 클립으로 가져옵니다.

비트맵

텍스트의 모양을 Illustrator에서와 동일하게 유지하려면 텍스트를 비트맵으로 래스터화합니다. Animate와 호환되지 않는 필터 또는 다른 효과가 적용된 경우 텍스트를 비트맵으로 가져오면 시각적 모양이 유지됩니다. 래스터화된 텍스트는 더 이상 편집할 수 없습니다.

동영상 클립 만들기

텍스트 객체를 동영상 클립 안으로 가져오도록 지정합니다. Illustrator와 Animate 간에 지원되는 블렌드 모드, AI 효과 및 100% 미만의 투명도를 유지하려면 텍스트 객체를 동영상 클립으로 가져오도록 지정합니다.

패스를 다음 형식으로 가져오기

다음과 같은 패스 가져오기 환경 설정을 지정할 수 있습니다.

편집할 수 있는 패스

편집 가능한 벡터 패스를 만듭니다. 지원되는 블렌드 모드, 효과 및 객체 투명도는 유지되지만 Animate에서 지원되지 않는 특성은 손실됩니다.

비트맵

패스의 모양을 Illustrator에서와 동일하게 유지하려면 패스를 비트맵으로 래스터화합니다. 래스터화된 이미지는 더 이상 편집할 수 없습니다.

동영상 클립 만들기

패스 객체를 동영상 클립 안으로 가져오도록 지정합니다.

이미지

이미지에 대한 다음과 같은 가져오기 환경 설정을 지정할 수 있습니다.

비트맵을 병합하여 모양 유지

Animate에서 지원하지 않는 블렌딩 모드 및 효과의 모양을 유지하려면 이미지를 비트맵으로 래스터화합니다. 래스터화된 이미지는 더 이상 편집할 수 없습니다.

동영상 클립 만들기

이미지를 동영상 클립 안으로 가져오도록 지정합니다.

그룹

그룹에 대한 다음과 같은 가져오기 환경 설정을 지정할 수 있습니다.

비트맵으로 가져오기

객체의 모양을 Illustrator에서와 동일하게 유지하려면 그룹을 비트맵으로 래스터화합니다. 그룹을 비트맵으로 변환하면 해당 객체를 선택하거나 이름을 바꿀 수 없습니다.

동영상 클립 만들기

그룹의 모든 객체를 단일 동영상 클립으로 캡슐화하도록 지정합니다.

레이어

레이어에 대한 다음과 같은 가져오기 환경 설정을 지정할 수 있습니다.

비트맵으로 가져오기

객체의 모양을 Illustrator에서와 동일하게 유지하려면 레이어를 비트맵으로 래스터화합니다.

동영상 클립 만들기

레이어가 동영상 클립으로 캡슐화되도록 지정합니다.

동영상 클립 등록

만든 동영상에 대한 전역 등록 포인트를 지정합니다. 이 설정은 모든 객체 유형의 등록 포인트에 적용됩니다. 이 옵션은 모든 객체 유형에 대한 초기 설정으로, [AI 파일 가져오기 프로그램] 대화 상자에서 객체별로 변경할 수 있습니다. 동영상 클립 등록에 대한 자세한 내용은 심볼 편집을 참조하십시오.

Adobe Illustrator 파일 가져오기

Illustrator에서 전체 레이아웃을 만든 다음 한 번에 Animate로 가져오려는 경우, Animate에서 [파일&]nbsp;> [스테이지로 가져오기] 또는 [파일&]nbsp;> [라이브러리로 가져오기] 명령을 사용하여 아트워크를 기본 Illustrator 형식(AI)으로 저장하고 높은 정확도를 유지하면서 Animate로 가져올 수 있습니다.

Illustrator 파일에 대지가 여러 개 포함되어 있는 경우 Animate의 [가져오기] 대화 상자에서 가져올 대지를 선택한 다음 해당 대지에서 모든 레이어에 대한 설정을 지정합니다. 선택한 대지의 모든 객체를 Animate에서 단일 또는 여러 Flash 레이어 또는 키프레임으로 가져올 수 있습니다.

Illustrator 아트워크를 AI, EPS 또는 PDF 파일로 가져오는 경우 Animate에서는 붙여넣은 Illustrator 아트워크와 동일한 특성이 유지됩니다. 또한 가져온 Illustrator 파일에 레이어가 포함되어 있으면 다음 방법 중 하나로 레이어를 가져올 수 있습니다.

  • Illustrator 레이어를 Flash 레이어로 변환
  • Illustrator 레이어를 Flash 프레임으로 변환
  • 모든 Illustrator 레이어를 단일 Flash 레이어로 변환

심볼 작업 과정

Illustrator의 심볼 작업 과정은Animate의 심볼 작업 과정과 비슷합니다.

텍스트 변환

AI 파일에 텍스트가 있을 경우 텍스트를 다음으로 변환할 수 있습니다.

  • 편집 가능한 텍스트 
  • 벡터 외곽선
  • 병합된 비트맵 이미지

레이어 변환

Animate CC에서 가져온 AI 파일의 레이어를 다음으로 변환할 수 있습니다.

  • 단일 병합 비트맵 파일
  • 편집 가능한 경로 및 효과

(Flash Professional CS6 이하 버전만 해당) 심볼 속성 및 링크

[심볼] 패널 또는 [컨트롤] 패널을 사용하여 심볼 인스턴스에 이름을 할당하고, 인스턴스와 심볼 간의 링크를 끊고, 심볼 인스턴스와 다른 심볼을 교환하거나 심볼의 복사본을 만드는 작업을 쉽게 할 수 있습니다. Animate에서 [라이브러리] 패널의 편집 기능은 비슷한 방식으로 작동합니다.

(Flash Professional CS6 이하 버전만 해당) 정적, 동적 및 입력 텍스트 객체

정적 텍스트를 Illustrator에서 Animate로 가져오는 경우 Animate에서 텍스트가 외곽선으로 변환됩니다. 또한 텍스트를 Illustrator에서 동적 텍스트로 설정할 수 있습니다. 동적 텍스트를 사용하면 Animate에서 텍스트 내용을 프로그래밍 방식으로 편집하고 여러 언어로 번역해야 하는 프로젝트를 간편하게 관리할 수 있습니다.

Illustrator에서 개별 텍스트 오브젝트를 정적, 동적 또는 입력 텍스트로 지정할 수 있습니다. Illustrator 및 Animate의 동적 텍스트 오브젝트는 비슷한 속성을 가집니다. 예를 들어, Illustrator와 Flash 모두 개별적인 문자가 아닌 텍스트 블록의 모든 문자에 영향을 주는 커닝을 사용하고, 앤티 앨리어스 텍스트도 같은 방식으로 작동하며, 텍스트를 포함하는 외부 XML 파일에 연결할 수 있습니다.

AI 가져오기 고급 옵션: 스테이지

  1. AI 가져오기 고급 옵션: 라이브러리

    파일 > 스테이지로 가져오기 또는 라이브러리로 가져오기를 선택합니다.

  2. 가져올 AI 파일을 찾아 선택하고 [확인]을 클릭합니다. [스테이지로 Illustrator 문서 가져오기] 또는 [라이브러리로 Illustrator 문서 가져오기] 대화 상자가 나타납니다.

    이 대화 상자에는 Illustrator 파일을 가져오기 위한 옵션이 있습니다. 가져오는 Illustrator 파일에 있는 객체의 유형에 따라 사용할 수 있는 옵션이 달라집니다.

  3. (선택 사항) Animate와 호환되지 않는 AI 파일에서 항목 목록을 생성하려면 비호환성 보고를 클릭합니다. [비호환성 보고] 버튼은 AI 파일에 Animate와의 비호환성이 존재할 경우에만 표시됩니다.

    [비호환성 보고]는 Illustrator와 Animate 간의 비호환 가능성을 분석합니다. [AI 가져오기] 대화 상자의 [가져오기 옵션] 영역([경고] 버튼 옆에 있음)에 호환되지 않는 항목에 대해 최대한의 호환성을 확보하기 위한 권장 사항이 표시됩니다.

    [비호환성 보고]에는 [가져오기 권장 설정 사용] 체크 상자가 있습니다. 이 상자를 선택하면 Animate가 AI 파일 내의 모든 비호환 객체에 권장 가져오기 옵션을 자동으로 적용합니다. AI 문서가 Animate에서 지원되는 것보다 크고 CMYK 색상 모드를 사용할 경우는 예외입니다. 이러한 비호환성을 해결하려면 Illustrator CS3에서 문서를 다시 열고 문서의 크기를 조정하거나 색상 모드를 RGB로 변경합니다.

  4. 가져오기 스크린에서 다음 옵션을 선택합니다.

    • Illustrator 대지 선택: 가져올 대지를 선택할 수 있습니다.
    • 비트맵으로 가져오기: 가져온 AI asset.c3의 비트맵을 만듭니다.
    • 동영상 클립 만들기: Animate로 가져올 때 이미지 레이어가 동영상 클립으로 변환되도록 지정합니다. 일부 이미지 레이어를 동영상 클립으로 변환하지 않으려는 경우 [AI 가져오기] 대화 상자에서 레이어별로 이 옵션을 변경할 수 있습니다.
    • 등록: 동영상 클립에 대한 등록 포인트를 설정할 수 있습니다.
    • Animate 레이어, 단일 Animate 레이어 및 키프레임으로 레이어 변환:
      • Animate 레이어: Photoshop 레이어 선택 목록에서 선택한 레이어가 고유한 레이어에 배치됩니다. 각 레이어는 Photoshop 파일에 있는 레이어의 이름으로 레이블이 지정됩니다.
      • 단일 Animate 레이어: 모든 AI 레이어가 단일 Animate 레이어에 배치됩니다.
      • 키프레임: Illustrator 레이어 선택 목록에서 선택한 모든 레이어가 새 레이어의 개별 키프레임에 배치됩니다.
    • 원래 위치에 객체 배치: AI 파일의 내용이 Illustrator에서와 동일한 위치에 유지됩니다. 예를 들어, 객체가 Illustrator에서 X = 100 Y = 50에 위치한 경우 Animate 스테이지에서도 동일한 좌표에 있는 것으로 간주됩니다. [라이브러리로 가져오기] 옵션에는 표시되지 않습니다.
    • 단일 비트맵 이미지로 가져오기: AI 레이어를 단일 비트맵으로 병합합니다.
    • 사용하지 않은 심볼 가져오기: 사용하지 않은 심볼도 가져옵니다.
    • Illustrator 대지와 같은 크기로 스테이지 크기 설정: Illustrator 대지의 크기와 동일한 크기로 스테이지를 설정합니다. 선택한 대지의 크기도 함께 표시됩니다.
    • 가져오기를 선택하여 파일을 가져오거나, 취소를 선택하여 프로세스를 취소하거나, 고급 옵션 숨기기를 선택하여 기본 옵션을 표시합니다.
    AI 기본 옵션: 라이브러리

    AI 기본 옵션: 스테이지

  5. 기본 옵션에서 다음과 같이 레이어 변환, 텍스트 변환 및 다음으로 레이어 변환의 옵션을 선택합니다.

    • Illustrator 대지 선택: 가져올 대지를 선택할 수 있습니다. 기본 옵션에서 대지를 변경하는 경우, 선택한 대지에 따라 [고급 옵션]의 트리 레이아웃이 업데이트됩니다.
    • 비트맵으로 가져오기: 가져온 AI 에셋의 비트맵을 만듭니다.
    • 편집 가능한 경로 및 효과 유지: 벡터 내부에 잘린 비트맵이 있는 편집 가능한 벡터 모양을 만듭니다. 지원되는 블렌드 모드, 필터 및 불투명도가 유지됩니다.
    • 단일 병합 이미지: 모양을 비트맵으로 래스터화하여 모양 레이어의 모양을 Illustrator에서와 동일하게 유지합니다.
    • 편집 가능한 텍스트: 선택한 Illustrator 레이어의 텍스트에서 편집 가능한 텍스트 객체를 만듭니다. 텍스트의 편집 가능성을 유지하기 위해 텍스트의 모양이 손상될 수 있습니다.
    • 벡터 외곽선: 텍스트의 시각적 모양을 유지하기 위해 텍스트를 벡터 경로로 변환합니다.
    • 병합 비트맵 이미지: 텍스트를 비트맵으로 래스터화하여 텍스트 레이어의 모양을 Illustrator에서와 동일하게 유지합니다. 래스터화된 텍스트는 더 이상 편집할 수 없습니다.
    • Animate 레이어: Illustrator 레이어 선택 목록에서 선택한 레이어가 고유한 레이어에 배치됩니다. 각 레이어는 Illustrator 파일에 있는 레이어의 이름으로 레이블이 지정됩니다.
    • 단일 Animate 레이어: 모든 AI 레이어가 단일 Animate 레이어에 배치됩니다.
    • 키프레임: Illustrator 레이어 선택 목록에서 선택한 모든 레이어가 새 레이어의 개별 키프레임에 배치됩니다.
    • 원래 위치에 객체 배치: Illustrator에서와 동일한 위치가 유지됩니다. 예를 들어, 객체가 Illustrator에서 X = 100 Y = 50에 위치한 경우 Animate 스테이지에서도 동일한 좌표에 있는 것으로 간주됩니다. [라이브러리로 가져오기] 옵션에는 표시되지 않습니다.
    • 단일 비트맵 이미지로 가져오기: AI 레이어를 단일 비트맵으로 병합합니다.
    • 사용하지 않은 심볼 가져오기: 사용하지 않은 심볼도 가져옵니다.
    • Illustrator 대지와 같은 크기로 스테이지 크기 설정(612x792): 선택한 경우, Illustrator 대지의 크기로 스테이지를 설정합니다. [라이브러리로 가져오기]의 경우에는 표시되지 않습니다.
  6. 단계 텍스트
  7. 가져오기를 선택하여 파일을 가져오거나, 취소를 선택하여 프로세스를 취소하거나, 고급 옵션 표시를 선택하여 고급 옵션을 표시합니다.

    라이브러리의 AI 파일

Illustrator 객체 가져오기 옵션

레이어는 Illustrator 아트워크를 구성하는 모든 항목을 관리합니다. 기본적으로 모든 항목은 하나의 상위 레이어로 구성됩니다. 지정된 부모 레이어의 모든 항목을 병합된 단일 비트맵으로 가져오거나 각 객체를 개별적으로 선택하고 객체 유형(텍스트, 패스, 그룹 등)에 대한 특정 가져오기 옵션을 지정할 수 있습니다. AI 가져오기 프로그램에서는 가져오는 아트워크의 레이어를 선택하고 Animate에서 객체의 시각적 모양과 해당 편집 가능성을 유지하는 것에 기초한 개별 가져오기 옵션을 지정하는 옵션을 제공합니다.

호환되지 않는 그래픽 효과 수정

  1. 비호환성 보고를 생성하려면 [비호환성 보고]를 클릭합니다. 비호환성 보고에는 AI 파일에서 Animate와 호환되지 않는 항목이 나열됩니다.

  2. [객체 비호환성을 해결하기 위해 가져오기 설정을 변경합니다.]를 선택합니다. Illustrator와 Animate 간에 존재하는 대부분의 비호환성은 비호환성 보고와 [AI 가져오기] 대화 상자의 [가져오기] 옵션 영역에 제공되는 가져오기 권장 사항을 사용하여 자동 수정할 수 있습니다.

개별 객체 선택

  1. 가져오기 옵션을 지정할 객체를 선택합니다. 선택할 수 있는 Illustrator 객체에는 레이어, 그룹, 개별 패스, 텍스트 및 이미지가 있습니다.
  2. 대화 상자의 객체 옵션 섹션에서 선택한 객체의 유형에 사용할 수 있는 가져오기 옵션을 검토합니다. 비호환성이 나열되는지 여부와 객체를 가져오기 위해 권장되는 수정 사항을 확인합니다.
  3. 원하는 가져오기 옵션을 선택하고 가져오기 옵션을 지정할 다른 객체를 선택하거나 [확인]을 클릭합니다.

(Flash Professional CS6 이하 버전만 해당) 레이어 선택

[레이어] 패널에는 문서의 객체가 나열됩니다. 기본적으로 모든 Illustrator 문서에는 최소한 하나의 레이어가 포함되어 있고 지정된 파일의 각 객체가 해당 레이어 아래에 나열됩니다.

[레이어] 패널에 있는 항목에 다른 항목이 들어 있는 경우 그 항목의 이름 왼쪽에 삼각형이 나타납니다. 내용을 표시하거나 숨기려면 삼각형을 클릭합니다. 삼각형이 나타나지 않으면 레이어에 추가 항목이 들어 있지 않은 것입니다.

참고: AI 가져오기 프로그램 컨텍스트 메뉴를 사용하여 모든 그룹 및 레이어를 확장하거나 축소할 수 있습니다. 마우스 오른쪽 버튼을 클릭하여 컨텍스트 메뉴를 표시한 다음 [모두 확장] 또는 [모두 축소]를 선택하십시오.

선택 열

가져올 항목을 선택할지 여부를 제어합니다. 이 항목을 선택한 경우 해당 레이어를 선택하고 가져오기 옵션을 지정할 수 있습니다. [편집]을 선택하지 않은 경우 레이어가 흐리게 표시되고 해당 레이어의 항목에 가져오기 설정을 지정할 수 없습니다.

객체 유형 열

가져오기 작업 시 해당 레이어의 Animate 객체 유형이 아이콘으로 표시되며 항목을 볼 수 있는 경우 해당 항목이 선택되어 있음을 나타냅니다. 객체 유형은 다음과 같습니다.

  • 텍스트

  • 패스

  • 그룹

  • 동영상 클립

  • 그래픽 심볼

  • 이미지

텍스트 가져오기 옵션

Animate에서는 텍스트를 편집 가능한 텍스트, 벡터 외곽선 또는 병합된 비트맵으로 가져올 수 있습니다. Illustrator와 Animate 간에 지원되는 블렌드 모드, AI 효과 및 100% 미만의 투명도를 유지하려면 텍스트를 동영상 클립으로 가져옵니다. 텍스트를 동영상 클립으로 가져오면 호환되는 시각적 효과의 편집 가능성이 유지됩니다.

편집 가능한 텍스트

기본적으로 Illustrator 텍스트는 편집 가능한 Animate 텍스트로 가져오게 됩니다. 텍스트의 편집 가능성을 유지하기 위해 텍스트의 모양이 손상될 수 있습니다.

벡터 외곽선

텍스트를 벡터 패스로 변환합니다. 텍스트의 시각적 모양을 유지하려면 이 옵션을 사용합니다. 지원되지 않는 블렌드 모드 및 필터와 같은 일부 시각적 효과가 손상될 수 있지만 텍스트를 동영상 클립으로 가져올 경우 패스에 있는 텍스트와 같은 시각적 특성은 유지됩니다. 텍스트 자체는 더 이상 편집할 수 없지만 불투명도 및 호환되는 블렌드 모드는 편집 가능성을 유지합니다.

참고: 텍스트에 적용된 그림자, 내부 광선, 외부 광선 및 가우시안 흐림과 같은 AI 효과를 편집 가능한 Animate 필터로 유지하려면 [동영상 클립 가져오기 만들기]를 선택하여 텍스트를 동영상 클립으로 가져옵니다.

 

비트맵

텍스트의 모양을 Illustrator에서와 동일하게 유지하려면 텍스트를 비트맵으로 래스터화합니다. Animate와 호환되지 않는 필터 또는 다른 효과가 적용된 경우 텍스트를 비트맵으로 가져오면 시각적 모양이 유지됩니다. 래스터화된 텍스트는 더 이상 편집할 수 없습니다.

패스 가져오기 옵션

패스는 Illustrator에서 드로잉의 결과로 얻어진 선입니다. 패스는 호처럼 열려 있거나 원처럼 닫혀 있습니다. 열린 패스의 시작 및 끝 고정점을 끝점이라고 합니다. 편집 가능한 패스를 Animate로 가져올 수 있지만 특정 블렌드 모드, 필터 또는 다른 효과가 패스에 적용된 경우 해당 효과는 Animate와 호환되지 않을 수 있습니다.

비트맵

패스의 모양을 Illustrator에서와 동일하게 유지하려면 패스를 비트맵으로 래스터화합니다. 래스터화된 이미지는 더 이상 편집할 수 없습니다.

편집할 수 있는 패스

편집 가능한 벡터 패스를 만듭니다. 지원되는 블렌드 모드, 효과 및 객체 투명도는 유지되지만 Animate에서 지원되지 않는 특성은 손실됩니다.

이미지 가져오기 옵션

비트맵 이미지는 사진 또는 디지털 페인팅과 같은 연속 톤 이미지를 위한 가장 일반적인 전자 미디어입니다. Illustrator에서는 필터, 효과 및 그래픽 스타일을 사용하여 비트맵 효과를 만듭니다. 이러한 효과는 대부분 Animate와 호환되지만 일부는 시각적 모양을 유지하기 위해 병합하거나 래스터화해야 할 수 있습니다.

참고: Illustrator의 래스터 파일이 링크된 경우 JPEG, GIF 및 PNG만 기본 형식을 유지한 상태로 가져오게 됩니다. 다른 모든 파일 유형은 Animate에서 PNG 형식으로 변환됩니다. 또한 PNG로의 변환은 컴퓨터에 설치된 QuickTime®의 버전에 따라 다릅니다.

 

모양을 유지하기 위해 비트맵 병합

Animate에서 지원하지 않는 블렌딩 모드 및 효과의 모양을 유지하려면 이미지를 비트맵으로 래스터화합니다. 래스터화된 이미지는 더 이상 편집할 수 없습니다.

동영상 클립 만들기

Illustrator 이미지를 동영상 클립으로 가져옵니다.

(Flash Professional CS6 이하 버전만 해당) 그룹 가져오기 옵션

그룹은 단일 단위로 처리되는 그래픽 객체의 컬렉션입니다. 그룹화를 사용하면 각각의 특성이나 상대적 위치에는 영향을 주지 않으면서 여러 객체를 이동하거나 변형할 수 있습니다. 예를 들어, 로고 디자인의 객체를 그룹으로 만들면 로고를 하나의 단위로 이동하고 크기를 조절할 수 있습니다. 그룹을 중첩할 수도 있습니다. 즉, 다른 객체나 그룹에 그룹화하여 더 큰 그룹을 형성할 수 있습니다.

그룹은 [가져오기] 패널에 <그룹> 항목으로 표시됩니다. 그룹과 같은 항목에 다른 항목이 들어 있는 경우 그 항목의 이름 왼쪽에 삼각형이 나타납니다. 그룹의 내용을 표시하거나 숨기려면 삼각형을 클릭합니다. 삼각형이 나타나지 않으면 그 항목에 추가 항목이 들어 있지 않은 것입니다.

비트맵으로 가져오기

객체의 모양을 Illustrator에서와 동일하게 유지하려면 그룹을 비트맵으로 래스터화합니다. 그룹을 비트맵으로 변환하면 해당 객체를 선택하거나 이름을 바꿀 수 없습니다.

동영상 클립 만들기

그룹의 모든 객체를 단일 동영상 클립으로 캡슐화합니다.

Illustrator와 Animate 간에 복사하여 붙여넣기

Illustrator와 Animate 간에 아트워크를 복사하여 붙여넣거나 드래그 앤 드롭할 경우 복사하거나 붙여넣는 AI 파일에 대한 가져오기 설정을 제공하는 [붙여넣기] 대화 상자가 나타납니다.

비트맵으로 붙여넣기

복사하는 파일을 단일 비트맵 객체로 병합합니다.

AI 파일 가져오기 프로그램의 환경 설정을 사용하여 붙여넣기

Animate 환경 설정([편집] > [환경 설정])에 지정된 AI 파일 가져오기 프로그램 설정을 사용하여 파일을 가져옵니다.

비호환성 문제를 해결하기 위해 가져오기 권장 설정 사용

[AI 파일 가져오기 프로그램의 환경 설정을 사용하여 붙여넣기]를 선택한 경우 기본적으로 활성화됩니다. AI 파일에서 감지된 모든 비호환성을 자동으로 수정합니다.

레이어 유지

[AI 파일 가져오기 프로그램의 환경 설정을 사용하여 붙여넣기]를 선택한 경우 기본적으로 활성화됩니다. AI 파일의 레이어를 Animate 레이어로 변환하도록 지정합니다. 이는 [AI 가져오기] 대화 상자에서 [Flash 레이어로 변환]을 선택한 경우와 같습니다. 선택하지 않을 경우 모든 레이어가 하나의 레이어에 병합됩니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책