참고:

Photoshop CS6에서 3D 기능은 Photoshop Extended의 일부입니다. Photoshop Extended의 모든 기능은 Photoshop의 일부입니다. Photoshop에는 별도의 Extended 제공 기능이 없습니다.

이미지 스택 정보

이미지 스택은 이미지 그룹을 유사한 참조 프레임과 결합합니다. 하지만 품질이나 내용은 그룹 전반에서 차이가 납니다. 스택으로 결합한 후에는 원하지 않는 내용이나 노이즈가 제거된 합성 보기로 나타나도록 여러 이미지를 처리할 수 있습니다.

이미지 스택을 사용하면 여러 가지 방법으로 이미지를 향상시킬 수 있습니다.

  • 법의학용 사진, 의료용 사진 또는 천체 사진용 이미지의 노이즈 및 왜곡 감소

  • 일련의 정적 사진 또는 비디오 프레임에서 원하지 않거나 우발적으로 나타난 개체 제거 예를 들어, 이미지를 통과하는 어떤 형상을 제거하거나 주요 피사체 앞을 지나가는 차를 제거할 수 있습니다.

이미지 스택은 고급 개체로 저장됩니다. 스택에 적용할 수 있는 처리 옵션을 스택 모드라고 합니다. 스택 모드를 이미지 스택에 적용하는 것은 비파괴 편집입니다. 스택 모드를 변경하여 다른 효과를 만들 수 있습니다. 이때 스택에 있는 원본 이미지 정보는 그대로 유지됩니다. 스택 모드를 적용한 다음 변경 내용을 유지하려면 결과를 새 이미지로 저장하거나 고급 개체를 래스터화합니다. 이미지 스택은 수동으로 또는 스크립트를 사용하여 만들 수 있습니다.

이미지 스택 만들기

이미지 스택에 들어있는 이미지는 시점을 고정한 상태로 촬영한 스틸 이미지 세트 또는 비디오 카메라를 고정한 상태로 촬영한 여러 프레임 등과 같이 치수가 같고 내용이 거의 비슷해야 최적의 결과를 얻을 수 있습니다. 이미지의 내용이 충분히 비슷해야 세트의 다른 이미지와 맞춰찍거나 정렬할 수 있습니다.

  1. 개별 이미지를 하나의 다중 레이어 이미지로 결합합니다. 자세한 내용은 레이어 복제를 참조하십시오.

    참고:

    이미지 스택에는 레이어가 두 개 이상 포함되어 있어야 합니다.

    스크립트를 사용하여 이미지를 결합할 수도 있습니다([파일] > [스크립트] > [스택으로 파일 불러오기]).

  2. [선택] > [모든 레이어]를 선택합니다.

    참고:

    [모든 레이어] 명령으로 배경 레이어를 선택할 수 있도록 하려면 먼저 배경 레이어를 일반 레이어로 변환해야 합니다.

  3. [편집] > [레이어 자동 정렬]을 선택하고 정렬 옵션으로 [자동]을 선택합니다. [자동] 옵션을 사용하여 원하는 레이어 맞춰찍기 결과를 얻지 못한 경우에는 [위치 변경] 옵션을 사용해 보십시오.
  4. [레이어] > [고급 개체] > [고급 개체로 변경]을 선택합니다.
  5. [레이어] > [고급 개체] > [스택 모드]를 선택하고 하위 메뉴에서 스택 모드를 선택합니다.
    • 노이즈를 줄이려면 [평균] 또는 [중간값] 플러그인을 사용하십시오.

    • 이미지에서 개체를 제거하려면 [중간값] 플러그인을 사용하십시오.

      출력물은 원본 이미지 스택과 동일한 크기의 합성 이미지입니다. 이미지에 따라 다른 플러그인을 사용해 보면서 최적의 품질을 찾아야 할 수도 있습니다.

      렌더링 효과를 변경하려면 하위 메뉴에서 다른 스택 모드를 선택합니다. 스택 렌더링은 누적되지 않습니다. 그러므로 각 렌더링 효과는 스택에 있는 원본 이미지 데이터에 적용되어 이전 효과를 대체합니다.

스택 모드

스택 모드는 채널당 비트 수 및 불투명 픽셀로만 작동합니다. 예를 들어, 최대값 모드는 하나의 픽셀 횡단면에 대해 빨강, 녹색, 파랑 채널의 최대값을 반환하고 렌더링된 이미지에서 이 값들을 하나의 합성 픽셀 값으로 병합합니다.

플러그인 이름 렌더링

결과

설명

엔트로피

엔트로피 = - 합계( (값의 확률) * log2(값의 확률) )

값의 확률 = (값의 발생 빈도) / (총 불투명 픽셀 수)

이진 엔트로피 또는 0차 엔트로피는 세트의 정보를 손실 없이 인코딩하는 데 필요한 비트 수의 하한값을 정의합니다.

첨도

첨도 = ( 불투명 픽셀에 대한 합계( (값 - 평균)4 ) ) / ( ( 불투명 픽셀 수 - 1 ) * (표준 편차)4 )

정규 분포와 비교한 첨도 또는 평탄도 측정값입니다. 표준 정규 분포의 첨도는 3.0입니다. 정규 분포와 비교하여 3보다 큰 첨도는 뾰족한 분포를 나타내고 3보다 작은 첨도는 편평한 분포를 나타냅니다.

최대

모든 불투명 픽셀의 최대 채널 값

평균

모든 불투명 픽셀의 평균 채널 값

노이즈 감소에 효과적입니다.

중간값

모든 불투명 픽셀의 중간 채널 값

이미지의 노이즈 감소 및 원하지 않는 내용 제거에 효과적입니다.

최소

모든 불투명 픽셀의 최소 채널 값

범위

불투명 픽셀의 최대값 -최소값

왜도

왜도 = (불투명 픽셀에 대한 합계( (값 - 평균)3 )) / ( ( 불투명 픽셀 수 - 1 ) * (표준 편차)3 )

왜도란 통계적 평균을 중심으로 대칭 또는 비대칭을 측정하는 것입니다.

표준 편차

표준 편차 = 제곱근(분산)

합계

모든 불투명 픽셀의 채널 값 합계

분산

분산 = (불투명 픽셀에 대한 합계( (값-평균)2 ) ) / ( 불투명 픽셀 수 - 1)

스택 렌더링 제거

  1. [레이어] > [고급 개체] > [스택 모드] > [없음]을 선택하여 이미지 스택에서 렌더링을 제거한 다음 이를 다시 일반 고급 개체로 변환합니다.

이미지 스택 편집

이미지 스택은 고급 개체이므로 언제든지 스택 레이어를 구성하는 원본 이미지를 편집할 수 있습니다.

  1. [레이어] > [고급 개체] > [내용 편집]을 선택하거나 레이어 축소판을 두 번 클릭합니다. 편집된 고급 개체를 저장하고 나면 스택은 마지막으로 적용된 렌더링 옵션으로 자동 렌더링됩니다.

이미지 스택 변환

이미지 스택에서 렌더링 효과를 유지하려면 고급 개체를 일반 레이어로 변환합니다. 나중에 이미지 스택을 다시 렌더링할 경우에 대비하여, 변환하기 전에 고급 개체를 복사할 수 있습니다.

  1. [레이어] > [고급 개체] > [래스터화]를 선택합니다.

스크립트를 사용하여 이미지 스택 만들기

통계 스크립트를 사용하여 이미지 스택을 만들고 렌더링하는 작업을 자동화할 수 있습니다.

  1. [파일] > [스크립트] > [통계]를 선택합니다.
  2. [스택 모드 선택] 메뉴에서 스택 모드를 선택합니다.
  3. 현재 열려 있는 파일에 스택 모드를 적용하거나, 폴더나 개별 파일을 찾아서 선택합니다.

    선택한 파일은 대화 상자에 나열됩니다.

  4. 필요한 경우 [소스 이미지 자동 정렬 시도]를 선택합니다([편집] > [레이어 자동 정렬]을 선택하는 것과 동일). 그런 다음 [확인]을 클릭합니다.

    Photoshop에서는 여러 이미지를 하나의 다중 레이어 이미지로 결합하거나 레이어를 고급 개체로 변환하거나 선택된 스택 모드를 적용할 수 있습니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책