Selección de capas

Las capas seleccionadas que también tienen propiedades seleccionadas se indican con un resalte hundido en el panel Línea de tiempo. Una capa seleccionada que no tiene propiedades seleccionadas se indica con un resaltado sólido.

Capa superior seleccionada, pero sin propiedades seleccionadas; capa inferior seleccionada con propiedades seleccionadas
Capa superior seleccionada, pero sin propiedades seleccionadas; capa inferior seleccionada con propiedades seleccionadas.

Nota:

Para desplazar la capa seleccionada situada más arriba hasta la parte superior del panel Línea de tiempo, presione X.

  • Para seleccionar una capa, haga clic en ella en el panel Composición, haga clic en su nombre o en la barra de duración en el panel Línea de tiempo, o bien, haga clic en el nombre de la capa en el panel Diagrama de flujo.
  • Para seleccionar una capa oscurecida en el panel Composición, haga clic con el botón derecho (Windows) o haga clic mientras pulsa Control (Mac OS) sobre la capa en el panel Composición y elija Selección > [nombre de la capa].
  • Para seleccionar una capa que se encuentra abierta en su propio panel Capa, elija el nombre de la capa en el menú Ventana o en el menú del visor del panel Capa.
  • Para seleccionar una capa por su número de posición, escriba el número de capa en el teclado numérico. Si el número de capa tiene más de un dígito, escriba los dígitos rápidamente, de forma que After Effects pueda reconocerlos como un número.
  • Para seleccionar la capa siguiente en el orden de apilamiento, presione Ctrl+Flecha abajo (Windows) o Comando+Flecha abajo (Mac OS). Para seleccionar la capa anterior, presione Ctrl+Flecha arriba (Windows) o Comando+Flecha arriba (Mac OS).
  • Para ampliar la selección a la siguiente capa en el orden de apilamiento, presione Ctrl+Mayús+Flecha abajo (Windows) o Comando+Mayús+Flecha abajo (Mac OS). Para ampliar la selección a la capa anterior en el orden de apilamiento, presione Ctrl+Mayús+Flecha arriba (Windows) o Comando+Mayús+Flecha arriba (Mac OS).
  • Para seleccionar todas las capas, elija Editar > Seleccionar todas mientras el panel Línea de tiempo o Composición está activo. Para eliminar la selección de todas las capas, elija Editar > Anular selección. Si se selecciona el definidor Ocultar capas tímidas de la composición, las capas tímidas no se seleccionarán cuando se utilice la opción de selección de todas las capas con el panel Línea de tiempo activo. (Consulte Visualización u ocultación de capas en el panel Línea de tiempo).
  • Para cancelar la selección de cualquier capa actualmente seleccionada y seleccionar las demás capas, seleccione al menos una capa y elija Invertir selección en el menú contextual del panel Composición o Línea de tiempo.
  • Para seleccionar todas las capas que utilizan la misma etiqueta de color, haga clic en la etiqueta de color en el panel Línea de tiempo y elija Seleccionar grupo de etiquetas, o bien, seleccione una capa con esa etiqueta de color y elija Editar > Etiqueta > Seleccionar grupo de etiquetas.
  • Para seleccionar todas las capas secundarias asignadas a una capa principal, seleccione esta última y elija Seleccionar secundarios en el menú contextual del panel Composición o Línea de tiempo. Las capas secundarias se agregan a la selección existente.
  • Se pueden seleccionar varias capas en el panel Composición. Arrastre con la herramienta Selección para crear un cuadro de selección (recuadro) alrededor de las capas para seleccionarlas. Mantenga presionada la tecla Mayús mientras hace clic o arrastra para seleccionar capas adicionales o anular la selección de algunas de ellas.

Lloyd Alvarez incluye una secuencia de comandos en su sitio Web de After Effects Scripts con la que puede etiquetar capas y seleccionar capas tímidas y solo según sus etiquetas. Las etiquetas se agregan a los comentarios en el campo Comentarios del panel Línea de tiempo.

Cambio del orden de apilamiento de las capas seleccionadas

La organización vertical de las capas en el panel Línea de tiempo es el orden de apilamiento de las capas, que está directamente relacionado con el orden de procesamiento. Para cambiar el orden de composición de las capas por otro, cambie el orden de apilamiento de las capas.

Nota:

Debido a sus propiedades de profundidad, el orden de apilamiento de las capas 3D en el panel Línea de tiempo no refleja necesariamente su posición espacial en la composición.  

  • En el panel Línea de tiempo, arrastre los nombres de las capas hasta otra posición del orden de apilamiento.
  • Para subir las capas seleccionadas un nivel en el orden de apilado de las capas, presione Ctrl+Alt+Flecha Arriba (Windows) o Comando+Opción+Flecha Arriba (Mac OS); para bajar las capas seleccionadas un nivel, presione Ctrl+Alt+Flecha Abajo (Windows) o Comando+Opción+Flecha Abajo (Mac OS).
  • Para mover las capas seleccionadas al nivel más alto en el orden de apilado de las capas, presione Ctrl+Alt+Mayús+Flecha Arriba (Windows) o Comando+Opción+Mayús+Flecha Arriba (Mac OS); para mover las capas seleccionadas al último nivel, pulsar Ctrl+Alt+Mayús+Flecha Abajo (Windows) o Comando+Opción+Mayús+Flecha Abajo (Mac OS).
  • Seleccione Capa > Organizar y, a continuación, elija Traer capa hacia delante, Enviar capa hacia atrás, Traer capa al frente o Enviar capa al fondo.

Nota:

Cuando copia (o corta) y pega capas, estas se pegan de forma que aparezcan de arriba a abajo en el panel Línea de tiempo, en el mismo orden en que se seleccionaron antes de la operación de copia (o corte). Puede hacer clic mientras mantiene presionada la tecla Ctrl (Windows) o la tecla Comando (Mac OS) en las capas para seleccionarlas en cualquier orden arbitrario, cortarlas y luego pegarlas de inmediato para reordenar las capas en el orden en que fueron seleccionadas.

Jeff Almasol incluye una secuencia de comandos en su sitio web redefinery con la que puede cambiar el orden de apilamiento de las capas en una composición mediante la ordenación en función del punto de inicio, punto final, orden de selección, nombre de la capa u orden aleatorio.

Sistema de coordenadas: espacio de composición y espacio de capa.

El sistema de coordenadas de cada capa es su espacio de capa. El sistema de coordenadas de cada composición es su espacio de composición. Los valores de propiedad de los elementos que existen en una capa como, por ejemplo, los puntos de control de efecto y puntos de anclaje, se encuentran en el espacio de capa y se miden desde el origen en el espacio de capa de dicha capa. No obstante, la propiedad Posición de una capa, describe la posición de la capa en una composición y por lo tanto se mide en el espacio de composición de dicha composición.

A medida que se desplaza el puntero sobre un fotograma de la capa en el panel Capa, el panel Información muestra las coordenadas del píxel situado bajo el puntero en el espacio de la capa. La coordenada X representa la posición en el eje horizontal, mientras que la coordenada Y representa la posición en el eje vertical. Los valores de dichas coordenadas están en píxeles. Las coordenadas X e Y se miden respecto al origen (0,0), que está fijado en la esquina superior izquierda de la capa.

El punto cero de las reglas se puede modificar, pero no el origen del espacio de la capa. Si el punto cero es distinto del origen, las coordenadas X' e Y' aparecerán en el panel Información por debajo de las coordenadas X e Y, para indicar que las coordenadas se basan en el punto cero de las reglas.

Al desplazar el puntero sobre el fotograma de la composición en el panel Composición, el panel Información muestra las coordenadas en el espacio de composición. A medida que se arrastra una capa, la parte inferior del panel Información muestra las coordenadas del punto de anclaje de la capa.

Mover capas en el espacio

Al desplazar una capa en el espacio, se modifica su propiedad Posición.

Los componentes de una propiedad Posición se pueden separar en propiedades individuales: Posición X, Posición Y, y (para las capas 3D) Posición Z , de modo que se pueda modificar y animar cada una de ellas de forma independiente. (Consulte Separación de las dimensiones de Posición para animar componentes individualmente).

Jeff Almasol proporciona una secuencia de comandos en su sitio web redefinery que coloca una nueva capa nula en la línea que hay entre los puntos de anclaje de las dos capas seleccionadas; puede usar un control deslizante en la capa nula para volver a colocar la capa nula a lo largo de esta línea.

Nota:

Para mover las capas seleccionadas de forma que sus puntos de anclaje se encuentren en el centro en la vista actual, elija Capa > Transformar > Centrar en vista, o bien, presione Ctrl + Inicio (Windows) o Comando + Inicio (Mac OS).

Nota:

Para mover una capa de forma que su punto de anclaje esté en el centro de la composición, haga clic con el botón derecho (Windows) o presione la tecla Control y haga clic (Mac OS) en la propiedad Posición, elija Editar valor, seleccione % de la composición en el menú Unidades e indique 50 para todos los componentes de la propiedad Posición.

Para evitar el suavizado de una imagen que no esté en movimiento, compruebe que los valores de posición de la capa sean no fraccionarios. Con esto se evita el remuestreo que se utiliza cuando una capa con una calidad de imagen establecida en Óptima se sitúa en subpíxeles.

Movimiento de capas arrastrándolas en el panel Composición

Nota:

Para ajustar los bordes de una capa a las cuadrículas o guías a medida que se arrastra, elija Ver > Ajustar a la cuadrícula o Ver > Ajustar con las guías.

  • Seleccione una o varias capas y, a continuación, arrastre una capa seleccionada mediante la herramienta Selección .

    Al desplazar una capa arrastrándola en el panel Composición, el panel Información muestra el cambio en la propiedad Posición a medida que se arrastra.

Mover capas modificando directamente la propiedad Posición

  1. Seleccione una o más capas.
  2. Presione P para que se muestre la propiedad Posición en el panel Línea de tiempo.
  3. Modifique la propiedad Posición en el panel Línea de tiempo.

Mover capas con las teclas de dirección

  1. Seleccione una o más capas.
  2. Para desplazar una capa un píxel a la izquierda, a la derecha, hacia arriba o hacia abajo, presione una tecla de dirección. Para desplazar la capa 10 píxeles, mantenga presionada la tecla Mayús mientras pulsa la tecla de dirección.

    Nota:

    Las teclas de flecha mueven la capa un píxel en el aumento actual. Para mover una capa de forma más precisa con las teclas de flecha, aplique en zoom para acercar en panel Composición. (Consulte Aplicación de zoom a una imagen para previsualización).

Separación de las dimensiones de Posición para animar componentes individualmente

De forma predeterminada, cada propiedad Posición dispone de dos o tres componentes y cada uno de ellos incluye el valor de una de las dimensiones espaciales (ejes). Puede separar los componentes de una propiedad Posición en propiedades independientes: Posición X, Posición Y y (para capas 3D) Posición Z. La separación de las dimensiones permite modificar o animar la posición de una capa a lo largo de los ejes x , y y z de forma independiente.

Para descomponer las propiedades de posición seleccionadas en propiedades Posición X, Posición Y, y (para capas 3D) Posición Z individuales, realice lo siguiente:

  • Seleccione Animación > Separar dimensiones.
  • Haga clic con el botón derecho (Windows) o presione la tecla Control y haga clic (Mac OS) en una propiedad Posición y seleccione Separar dimensiones en el menú contextual.
  • Haga clic en el botón Separar dimensiones en la parte inferior del Editor de gráficos.

Para recomponer un conjunto de propiedades de posición individuales en una sola propiedad Posición con varios componentes, utilice los mismos comandos que se emplean para separar dimensiones.  

Nota:

Cuando se recomponen las propiedades de posición independientes en una sola propiedad Posición, se pierde información sobre el trazado de movimiento y la velocidad, ya que las distintas curvas Bézier utilizadas para representar los componentes individuales se contraen en una sola curva en cada fotograma clave. Cuando se separan dimensiones, se pierde información sobre velocidad, pero el trazado de movimiento no cambia. Se debe trabajar con dimensiones independientes o sin dimensiones individuales para cada propiedad en un proyecto completo, en lugar de ir alternando constantemente.

La decisión de trabajar o no con dimensiones independientes depende del resultado que se desee obtener. El uso de una propiedad por posición tiene la ventaja de ofrecer un movimiento suave de forma más fácil. Asimismo, el uso de una sola propiedad por posición permite la utilización de fotogramas clave itinerantes, con lo que se logra una velocidad uniforme. El trabajo con dimensiones independientes por posición sacrifica parte de este suavizado automático para ganar un mayor control de la animación espacial. El trabajo con dimensiones independientes también facilita algunas animaciones, especialmente en casos en los que las fuerzas simuladas que actúan en un capa son ortogonales (perpendiculares) entre sí.

Por ejemplo, si está animando una pelota que se desplaza horizontalmente y bota verticalmente, puede facilitar la animación separando las dimensiones. La propiedad Posición X se puede animar con dos fotogramas clave, uno para la posición de inicio y otro para la posición final. Esta animación horizontal representa la velocidad del lanzamiento. La propiedad Posición Y se puede animar con una sola expresión que simule la aceleración debido a la gravedad y al bote vertical desde el suelo. Un ejemplo similar es el de un barco bajando por el río empujado por la corriente con un viento de través variable.

Nota:

After Effects CS3 incluía el ajuste preestablecido de animación Separar posición de XYZ con el que se lograba algo similar a la función Separar dimensiones, aunque el ajuste preestablecido de animación no fuera tan sólido.

Alineación o distribución de capas en espacio 2D

Utilice el panel Alinear para alinear o espaciar a intervalos regulares las capas seleccionadas. Puede alinear o distribuir capas de forma vertical u horizontal.

  1. Seleccione las capas que va a alinear o distribuir.
  2. Elija Selección o Composición en el menú Alinear capas para.

    Selección

    Alinea las capas seleccionadas en función de los límites de la capa de las capas seleccionadas.

    Composición

    Alinea las capas seleccionadas en función de los límites del fotograma de la composición.

  3. En el panel Alinear, haga clic en el botón que representa el tipo de alineación o distribución deseado.
  • Para la distribución, se deben seleccionar tres o más capas. Cuando se elige Selección en el menú Alinear capas para, se deben seleccionar dos o más capas para alinear. Cuando se elige Composición en el menú Alinear capas para, se deben seleccionar una o varias capas para alinear.

  • Cuando se elige Selección en el menú Alinear capas para, cada opción de alineación alinea las capas seleccionadas con la capa que mejor represente la nueva alineación. Por ejemplo, en una alineación al borde derecho, todas las capas seleccionadas se alinean en la capa seleccionada con el borde que esté más a la derecha.

  • Una opción de distribución espacia a intervalos regulares las capas seleccionadas, entre las dos capas de los extremos. Por ejemplo, para una opción de distribución vertical, las capas seleccionadas se distribuyen entre las capas superior e inferior seleccionadas.

  • Cuando se distribuyen capas de distintos tamaños, los espacios entre las capas pueden no ser uniformes. Por ejemplo, la distribución de capas por sus centros crea espacios iguales entre los centros, aunque las capas de distintos tamaños se extenderán en cantidades diferentes en el espacio entre capas.

  • Las opciones de alineación y distribución no pueden mover capas bloqueadas.

  • El panel Alinear no afecta a la alineación de los caracteres en una capa de texto.

Nota:

Para mover las capas seleccionadas de forma que sus puntos de anclaje se encuentren en el centro en la vista actual, elija Capa > Transformar > Centrar en vista, o bien, presione Ctrl + Inicio (Windows) o Comando + Inicio (Mac OS).

Charles Bordenave (nab) incluye una secuencia de comandos en el sitio web de scripts de After Effects (en inglés), con la que se pueden distribuir capas en un espacio 3D.

Recortar, ampliar o editar desplazamiento de una capa

El comienzo de la duración de una capa es su Punto de inicio y el final es su Punto final. La duración es el espacio entre el punto de Entrada y el punto de Salida y la barra que se extiende desde el punto de Entrada al punto de Salida es la barra de duración de la capa.

Para recortar una capa se modifican sus puntos de Entrada y Salida de tal manera que la capa tenga una duración distinta. Cuando recorte una capa que está basada en el material de archivo de origen en movimiento, afectará a qué fotogramas del elemento de material de archivo de origen se visualizan en la capa; el primer fotograma aparece en el punto de Entrada y el último aparece en el punto de Salida. Con el recorte de una capa no se cortan los fotogramas del elemento de material de archivo; solo afecta a qué fotogramas se reproducen para la capa.

Recorte de capas en el panel Línea de tiempo
Recorte de capas en el panel Línea de tiempo

A. Punto de entrada original B. Indicador de tiempo de capa negativo para una capa de imagen fija C. Punto de entrada original D. Barra de edición de desplazamiento, que representa fotogramas excluidos para una capa de material de archivo de movimiento E. Puntos de entrada nuevos 

Cuando utilice un elemento de material de archivo como origen para distintas capas, puede recortar cada capa de manera diferente para mostrar diferentes fragmentos del origen. Al recortar una capa no se altera el elemento de material de archivo ni el archivo original de origen.

Puede recortar una capa cambiando el punto de Entrada y Salida en el panel Capa o en el panel Línea de tiempo. (También puede recortar un elemento de material de archivo antes de utilizarlo para crear una capa. Consulte Creación de capas desde elementos de material de archivo o cambio del origen de capa).

Los valores de punto de Entrada , punto de Salida y duración de una capa se muestran en la parte inferior del panel Capa. Para mostrar esta información de todas las capas en el panel Línea de tiempo, haga clic sobre el botón de Entrada/Salida/Duración/Estirar en la esquina inferior izquierda de dicho panel. La duración, el punto de entrada y el punto de salida de la capa seleccionada también se muestran en el panel Información.

En el panel Capa, los puntos de Entrada y Salida se expresan en el tiempo de capa. En el panel Línea de tiempo, los puntos de Entrada y Salida se expresan en el tiempo de composición. La duración es la misma en ambos casos (a menos que la reasignación o la ampliación de tiempo esté habilitada para la capa).

Puede ampliar muchos tipos de capas hasta cualquier duración, ampliando sus puntos de entrada y salida fuera de sus tiempos originales. Esta capacidad se aplica a las capas con reasignación de tiempo, capas de forma, capas basadas en elementos de material de archivo de imágenes fijas, capas de cámara, capas de luz y capas de texto. Si extiende una capa hacia atrás en el tiempo de manera que la capa se extienda a valores negativos de tiempo de capa (sobrepasando el tiempo de capa cero), una serie de líneas interiores en la parte inferior de la barra de capa indicarán los fragmentos de capa que están en tiempo de capa negativo. Esta indicación resulta útil cuando se han aplicado efectos a la capa como, por ejemplo, Animación del objeto o Dispersión, que utilizan tiempo de capa para calcular los resultados.

Recursos en línea para el recorte, ampliación y edición de capas

Jeff Almasol incluye una secuencia de comandos en su sitio web redefinery que crea un panel con controles para mover distintas combinaciones de elementos en el tiempo: punto de inicio de la capa, punto final de la capa, fotogramas de origen de capas, fotogramas clave y marcadores.

Recortar o ampliar capas en el panel Línea de tiempo

Arrastre del punto de salida de la barra de duración de una capa
Arrastre del punto de salida de la barra de duración de una capa.

  1. Seleccione una o varias capas en el panel Línea de tiempo.
  2. Realice una de las acciones siguientes:
    • Arrastre cualquier extremo de una barra de duración de capa.

    • Mueva el indicador de tiempo actual hasta el tiempo en que desea establecer el punto de entrada o punto de salida. Para establecer el punto de entrada en el tiempo actual, presione Alt+[ (Windows) u Opción+[ (Mac OS). Para establecer el punto de salida en el tiempo actual, presione Alt+] (Windows) u Opción+] (Mac OS).

Recortar o ampliar una capa en el panel Capa

  • Abra la capa en el panel Capa y arrastre cualquier extremo de la barra de duración de la capa.
  • Mueva el indicador de tiempo actual en el panel Capa hasta el momento en el que desee que comience o termine el material de archivo y, a continuación, haga clic en el botón Entrada o Salida para definir el punto de entrada o salida en la hora actual.

Edición de desplazamiento de una capa

Una vez recortada una capa basándose en un material de archivo en movimiento, una barra de edición de desplazamiento pálida representará los fotogramas del elemento de material de archivo que se van a excluir de la composición. Este rectángulo pálido no aparece para una capa recortada basada en un elemento de material de archivo de imagen fija. Puede escoger qué fotogramas se reproducen dentro de una duración recortada arrastrando la barra de edición de desplazamiento. Los puntos de inicio y final de la capa no se ven afectados.

Al mover únicamente el punto final o de inicio de una capa no se mueven los fotogramas clave. Al arrastrar la barra de duración de capa se mueven todos los fotogramas clave. Al arrastrar la barra de edición de desplazamiento se mueven los fotogramas clave pero no los fotogramas clave no seleccionados.

Nota:

Cuando realice una edición de desplazamiento, probablemente querrá mover algunos fotogramas clave con el material de archivo de origen, como los fotogramas clave de máscara. Otros fotogramas clave deberán permanecer en el tiempo donde se encuentran. Presione Mayús+F2 para anular la selección de fotogramas clave y dejar seleccionada la capa.

  • Arrastre la barra de edición de desplazamiento a la izquierda o a la derecha.
  • Arrastre la capa a la izquierda o la derecha con la herramienta Panorámica trasera (Punto de anclaje).

Eliminación de parte de la duración de una capa

  1. En el panel Línea de tiempo, defina el entorno de trabajo para incluir solo la parte de las capas que desee eliminar: mueva el indicador de tiempo actual hasta el valor en que va a empezar el entorno de trabajo y presione B; mueva el indicador de tiempo actual hasta el valor en que va a finalizar el entorno de trabajo y presione N.
  2. Realice una de las acciones siguientes:
    • Seleccione las capas de las que desee eliminar una sección.

    • Seleccione el definidor de bloqueo  de las capas a las que no desee que afecte la extracción. Presione F2 para deseleccionar todas las capas.

    Nota:

    Si no hay seleccionada ninguna capa, el siguiente paso elimina la sección de todas las capas desbloqueadas.

  3. Realice una de las acciones siguientes:
    • Para eliminar la sección y dejar un hueco de la misma duración que la sección eliminada, elija Editar > Elevar entorno de trabajo.

    • Para eliminar la sección, elija Editar > Extraer entorno de trabajo. El hueco se cierra por eliminación de rizo.

Situación o movimiento de una capa en el tiempo

La barra de duración representa visualmente la duración de la capa. Las columnas Entrada, Salida y Duración en el panel de Línea de tiempo representan numéricamente la duración de la capa.

Nota:

Para elegir las columnas que serán visibles en el panel de Línea de tiempo, elija Columnas del menú del panel o haga clic con el botón derecho (Windows) o mientras pulsa Control (Mac OS) la sobre cabecera de una columna.

Estos procedimientos mueven la capa entera en el tiempo.

  • Para ajustar numéricamente los puntos de Entrada o Salida, haga clic sobre el número en la columna Entrada o Salida de la capa en el panel Línea de tiempo.
  • Para mover los puntos de Entrada o Salida al tiempo actual, presione Alt (Windows) u Opción (Mac OS) mientras hace clic sobre el número en la columna Entrada o Salida de la capa en el panel Línea de tiempo.
  • Para mover los puntos de Entrada de las capas seleccionadas al comienzo de la composición, presione Alt+Inicio (Windows) u Opción+Inicio (Mac OS).
  • Para mover los puntos de las capas seleccionadas al final de la composición, presione Alt+Fin (Windows) u Opción+Fin (Mac OS).
  • Para mover las capas seleccionadas a un fotograma después, presione Alt+Av Pág (Windows) u Opción+Av Pág (Mac OS). Para mover las capas seleccionadas 10 fotogramas después, pulsar Alt+Mayús+Av Pág (Windows) u Opción+Mayús+Av Pág ( Mac OS).
  • Para mover las capas seleccionadas un fotograma antes, pulsar Alt+Re Pág (Windows) u Opción+Re Pág (Mac OS). Para mover las capas seleccionadas 10 fotogramas antes, presione Alt+Mayús+Re Pág (Windows) u Opción+Mayús+Re Pág ( Mac OS).
  • Para mover la capa entera en el tiempo mediante arrastre, arrastre la barra de duración de la capa a la izquierda o la derecha. Para ajustar la barra de duración de la capa a los puntos significativos en el tiempo (como marcadores, el inicio o fin de la composición), presione Mayús mientras arrastra la barra de duración de la capa.

Nota:

Cuando arrastre una capa en el panel Línea de tiempo, el panel Información muestra el nombre, la duración, el cambio en el tiempo y los puntos de Entrada y Salida de la capa.  

Antes y después de mover la barra de duración
Antes y después de mover la barra de duración

Jeff Almasol proporciona una secuencia de comandos en su sitio web redefinery con la que puede mover capas seleccionadas como grupo, alineando el grupo en un tiempo concreto de la composición.

Organizar capas en el tiempo secuencialmente

Utilice el Asistente de fotogramas clave de capas de secuencia para disponer automáticamente las capas en una secuencia. Cuando se aplica el Asistente de fotogramas clave, la primera capa que se selecciona permanece en su posición inicial y las otras capas seleccionadas se mueven a nuevas posiciones en el panel Línea de tiempo de acuerdo con el orden en que fueron seleccionadas.

Capas seleccionadas en el panel Línea de tiempo
Capas seleccionadas en el panel Línea de tiempo (superior) y capas dispuestas en secuencia mediante la aplicación del Asistente de fotogramas clave de capas de secuencia (inferior)

Capas superpuestas
La superposición de capas puede tener como resultado el ajuste automático de los fotogramas clave de opacidad para crear una disolución cruzada.

Para que una capa se sitúe en una secuencia, su duración debe de ser inferior a la longitud de la composición, de forma que quede tiempo para el resto de las capas. (Consulte Recortar, ampliar o editar desplazamiento de una capa).

  1. En el panel Línea de tiempo, mantenga presionada Ctrl (Windows) o Comando (Mac OS) y seleccione las capas en orden secuencial, comenzando por la capa que aparecerá en primer lugar.
  2. Elija Animación > Asistente de fotogramas clave > Capas de secuencia.
  3. En el cuadro de diálogo Capas de secuencia, realice una de las acciones siguientes:
    • Para disponer las capas de un extremo a otro, deje la opción Superponer sin seleccionar.

    • Para superponer capas, seleccione Superponer, introduzca un valor de duración para la superposición y seleccione una transición. Seleccione Disolución cruzada de las capas delantera y trasera para utilizar la transparencia de las capas seleccionadas; de otro modo, elija Disolución de capa delantera.

    • Para dejar huecos entre las capas, seleccione Superponer e introduzca un valor de duración negativo.

Copiar o duplicar una capa

Al copiar una capa, se copian todas sus propiedades, incluidos efectos, fotogramas clave, expresiones y máscaras.

La duplicación de una capa es un método abreviado con el que puede copiar y pegar una capa con un comando. La duplicación de una capa con una pista mate conserva el orden relativo de la capa y su pista mate.

Cuando se pegan capas, se colocan en el orden en que se seleccionaron antes de copiarlas. La primera capa seleccionada será la última que se coloque, así, terminará estando encima en el orden de apilamiento de capas. Si en primer lugar selecciona capas de la parte superior, terminarán en el mismo orden de apilamiento cuando se peguen.

Nota:

Si al copiar hay seleccionado un componente de una capa, como una máscara o un fotograma clave, solo se copiará el componente seleccionado. Antes de copiar, presione Mayús+F2 para anular la selección de todos los componentes de una capa y dejar la propia capa seleccionada.

  • Para copiar las capas seleccionadas y situar los puntos de entrada de las copias en el tiempo actual, elija Editar > Copiar y, a continuación, presione Ctrl+Alt+V (Windows) o Comando+Opción+V (Mac OS).
  • Para copiar las capas seleccionadas y situar las copias en los mismos tiempos que los originales, elija Editar > Copiar y, a continuación, elija Editar > Pegar.

Nota:

Para situar copias en la parte superior de la pila de capas en la Línea de tiempo en vez de inmediatamente encima de los originales, presione F2 para anular la selección de los originales antes de pegar.

  • Para duplicar las capas seleccionadas, elija Editar > Duplicar o presione Ctrl+D (Windows) o Comando+D (Mac OS).

División de una capa

En el panel Línea de tiempo, puede dividir una capa en cualquier momento y crear así dos capas independientes. La división de una capa es una alternativa que ahorra tiempo respecto a la duplicación y el recorte (algo que se puede realizar si desea cambiar la posición de la capa dentro del orden de apilamiento en el centro de la composición).

Nota:

Para que las nuevas capas divididas aparezcan encima de la capa original en el panel Línea de tiempo, seleccione Crear capas divididas por encima de la capa original (Editar > Preferencias > General (Windows) o After Effects > Preferencias > General [Mac OS]). Deseleccione esta opción para que las capas aparezcan debajo de la capa original.

  1. Seleccione una o más capas.
  2. Desplace el indicador de tiempo actual hasta la posición en que se van a dividir las capas.
  3. Elija Editar > Dividir capa.

Cuando se divide una capa, las dos capas resultantes contienen todos los fotogramas clave que estaban en la capa original, en sus posiciones originales. Cualquier pista mate aplicada conservará su orden en la parte superior de la capa.

Después de dividir una capa, la duración de la capa original termina en el punto de la división y la nueva capa empieza en ese punto del tiempo.

Si cuando se elige Editar > Dividir no hay seleccionada ninguna capa, todas las capas se dividen en el tiempo actual.

Paul Tuersley incluye una secuencia de comandos en el foro de AE Enhancers para dividir capas en marcadores de capa.

Lloyd Alvarez proporciona una secuencia de comandos en su sitio web After Effects Scripts que detecta automáticamente ediciones en una capa de material de archivo y la divide en una capa independiente para cada edición (o sitúa un marcador de capa en cada edición).

Opciones de orientación automática

Las opciones de orientación automática de cada capa (Capa > Transformar > Orientación automática) especifican cómo depende su orientación de los trazados de movimiento, puntos de interés y cámaras.

Desactivado

La capa gira libremente, independientemente del trazado de movimiento, del punto de interés o de las demás capas.

Orientar en el trazado

La capa está orientada en la dirección del trazado de movimiento. Por ejemplo, utilice esta opción para que la cámara represente la perspectiva del conductor cuando mira a la carretera mientras conduce.

Orientar hacia la cámara

La capa siempre está orientada hacia la cámara activa. Esta opción está disponible para capas 3D; no está disponible para capas 2D, cámaras ni luces. Las capas de texto 3D cuentan con una opción adicional, Orientar cada carácter por separado, que orienta cada carácter alrededor de su punto de anclaje independiente. Al seleccionar Orientar cada carácter por separado, se habilitan las propiedades 3D por carácter de la capa de texto si no lo estaban. (Consulte Propiedades de texto 3D por carácter).

Orientar hacia el punto de interés

La cámara o la luz siempre está orientada hacia su punto de interés. Esta opción no está disponible en capas que no sean cámaras ni luces. (Consulte Cámaras, luces y puntos de interés).

Nota:

Si se especifica una opción de orientación automática para una capa y, a continuación, se cambian las propiedades de Orientación o de Rotación X, Y o Z, serán los nuevos valores los que la desplacen. Por ejemplo, se puede definir una cámara con Orientar en el trazado y, a continuación, girar la cámara 90 grados hacia la derecha para representar la perspectiva de un pasajero que mira por la ventana de un automóvil mientras este se mueve.

La orientación automática para señalar el punto de interés tiene lugar antes de que se apliquen las transformaciones de las propiedades Rotación y Orientación. Para animar una cámara o luz con la opción Orientar hacia el punto de interés para que se centren temporalmente fuera de ese punto, anime las propiedades de transformación Rotación y Orientación.

Dan Ebberts incluye una expresión en su sitio web MotionScript que orienta automáticamente una capa a lo largo de un solo eje. Por ejemplo, esto resulta útil a la hora de cambiar de posición los caracteres de lado a lado de modo que sigan a la cámara mientras permanecen verticales.

Recursos en línea para la selección y organización de capas

Jeff Almasol incluye una secuencia de comandos en su sitio web redefinery que crea un panel con controles para mover distintas combinaciones de elementos en el tiempo: punto de inicio de la capa, punto final de la capa, fotogramas de origen de capas, fotogramas clave y marcadores.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea