Problem przy tworzeniu połączenia z bazą danych: kod błędu HTTP 404 — nie znaleziono pliku (Dreamweaver Developer Toolbox)

Ostatnia aktualizacja 27 kwi 2021

Problem

Podczas próby utworzenia nowego połączenia z bazą danych w programie Dreamweaver pojawia się komunikat o błędzie: kod błędu HTTP 404 — nie znaleziono pliku

Przyczyna

Istnieje kilka możliwych przyczyn tego problemu:

Serwer testowy nie jest prawidłowo skonfigurowany w definicji witryny programu Dreamweaver.Program Dreamweaver próbuje przesłać niektóre pliki na serwer testowy do folderu wskazanego w definicji witryny, a następnie próbuje je wywołać za pomocą protokołu HTTP przy użyciu podanego podstawowego adresu URL.Jeśli ścieżki nie są poprawnie skonfigurowane, otrzymasz ten błąd.
Serwer internetowy nie jest uruchomiony na komputerze serwera testowego.
Serwer proxy skonfigurowany w przeglądarcejest używany nawet w przypadku adresów lokalnych, takich jak localhost, serwer testowy, z którym chcesz się połączyć.
Twoja przeglądarka jest ustawiona na „Work Offline".

Rozwiązanie

Istnieje kilka rozwiązań, które można wypróbować:

Przejdź do definicji witryny w programie Dreamweaver i ponownie sprawdź wszystkie wybrane ścieżki (zarówno foldery, jak i adresy URL).
Sprawdź status serwera internetowego — możesz nawet uruchomić go ponownie, aby mieć pewność.
Należy zmienić konfiguracje serwera proxy w przeglądarce, aby ominąć adresy lokalne, takie jak localhost.