3D layers

  1. After Effects User Guide
  2. Beta releases
    1. Beta Program Overview
    2. After Effects Beta Home
  3. Getting started
    1. Get started with After Effects
    2. What's new in After Effects 
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Supported File formats | After Effects
    7. Hardware recommendations
    8. Planning and setup
    9. Setup and installation
  4. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  5. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. View detailed performance information with the Composition Profiler
    5. CINEMA 4D Composition Renderer
  6. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. XMP metadata
  7. Working with text and graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
  8. Drawing, painting, and paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. How to taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  9. Working with layers
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  10. Animation, keyframing, motion tracking, and keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  11. Transparency and compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels, masks, and mattes
  12. Adjusting color
    1. Color basics
    2. Use the Adobe Color Themes extension
    3. Color management
    4. Color Correction effects
  13. Effects and animation presets
    1. Effects and animation presets overview
    2. Effect list
    3. Simulation effects
    4. Stylize effects
    5. Audio effects
    6. Distort effects
    7. Perspective effects
    8. Channel effects
    9. Generate effects
    10. Transition effects
    11. The Rolling Shutter Repair effect
    12. Blur and Sharpen effects
    13. 3D Channel effects
    14. Utility effects
    15. Matte effects
    16. Noise and Grain effects
    17. Detail-preserving Upscale effect
    18. Obsolete effects
  14. Expressions and automation
    1. Expression
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  15. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. Preview changes to 3D designs real time with the Real-Time Engine
    7. Add responsive design to your graphics 
  16. Views and previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  17. Rendering and exporting
    1. Basics of rendering and exporting
    2. Export an After Effects project as an Adobe Premiere Pro project
    3. Converting movies
    4. Multi-frame rendering
    5. Automated rendering and network rendering
    6. Rendering and exporting still images and still-image sequences
    7. Using the GoPro CineForm codec in After Effects
  18. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Collaborate with Team Projects
    5. Share and manage changes with Team Project collaborators
    6. Creative Cloud Libraries in After Effects
    7. Plug-ins
    8. CINEMA 4D and Cineware
  19. Memory, storage, performance
    1. Memory and storage
    2. Improve performance
    3. Preferences
    4. GPU and GPU driver requirements for After Effects
Notă:

The content in this article applies in general to the Classic 3D renderer. For information on the Ray-traced 3D renderer, see Extruding text and shape layers and watch this video tutorial.

3D layers overview and resources

When you make a layer a 3D layer, the layer itself remains flat, but it gains additional properties: Position (z), Anchor Point (z), Scale (z), Orientation, X Rotation, Y Rotation, Z Rotation, and Material Options properties. Material Options properties specify how the layer interacts with light and shadows. Only 3D layers interact with shadows, lights, and cameras.

2D layers and layers with 3D properties
2D layers (left) and layers with 3D properties (right)

Individual characters within text layers can optionally be 3D sublayers, each with their own 3D properties. A text layer with Enable Per-character 3D selected behaves just like a precomposition that consists of a 3D layer for each character. All camera and light layers have 3D properties.

By default, layers are at a depth (z-axis position) of 0. In After Effects, the origin of the coordinate system is at the upper-left corner; x (width) increases from left to right, y (height) increases from top to bottom, and z (depth) increases from near to far. Some video and 3D applications use a coordinate system that is rotated 180 degrees around the x axis ; in these systems, y increases from bottom to top, and z increases from far to near.

You can transform a 3D layer relative to the coordinate space of the composition, the coordinate space of the layer, or a custom space by selecting an axis mode.

You can add effects and masks to 3D layers, composite 3D layers with 2D layers, and create and animate camera and light layers to view or illuminate 3D layers from any angle. When rendering for final output, 3D layers are rendered from the perspective of the active camera. (See Create a camera layer and change camera settings.)

All effects are 2D, including effects that simulate 3D distortions. For example, viewing a layer with the Bulge effect from the side does not show a protrusion.

As with all masks, mask coordinates on a 3D layer are in the 2D coordinate space of the layer.

Convert 3D layers

When you convert a layer to 3D, a depth (z) value is added to its Position, Anchor Point, and Scale properties, and the layer gains Orientation, Y Rotation, X Rotation, and Material Options properties. The single Rotation property is renamed Z Rotation.

When you convert a 3D layer back to 2D, the Y Rotation, X Rotation, Orientation, and Material Options properties are removed, including all values, keyframes, and expressions. (These values cannot be restored by converting the layer back to a 3D layer.) The Anchor Point, Position, and Scale properties remain, along with their keyframes and expressions, but their z values are hidden and ignored.

Convert a layer to a 3D layer

  1. Select the 3D Layer switch for the layer in the Timeline panel, or select the layer and choose Layer > 3D Layer.

Convert a text layer to a 3D layer with per-character 3D properties enabled

  1. Choose Animation > Animate Text > Enable Per-Character 3D, or choose Enable Per-Character 3D from the Animate menu for the layer in the Timeline panel.

Convert a 3D layer to a 2D layer

  1. Deselect the 3D Layer switch for the layer in the Timeline panel, or select the layer and choose Layer > 3D Layer.

Show or hide 3D axes and layer controls

3D axes are color-coded arrows: red for x, green for y, and blue for z.

  • To show or hide 3D axes, camera and light wireframe icons, layer handles, and the point of interest, choose View > Show Layer Controls.
Notă:

If the axis that you want to manipulate is difficult to see, try a different setting in the Select View Layout menu at the bottom of the Composition panel.

  • To show or hide a set of persistent 3D reference axes, click the Grid And Guides Options button at the bottom of the Composition panel, and choose 3D Reference Axes.

Chris and Trish Meyer provide a video tutorial on the ProVideo Coalition website that demonstrates the use of the 3D axis layer controls.

Move a 3D layer

  1. Select the 3D layer that you want to move.
  2. Do one of the following:
    • In the Composition panel, use the Selection tool to drag the arrowhead of the 3D axis layer control corresponding to the axis along which you want to move the layer. Shift-drag to move the layer more quickly.
    • In the Timeline panel, modify the Position property values.
    Notă:

    Press P to show Position.

    • To move selected layers so that their anchor points are at the center in the current view, choose Layer > Transform > Center In View or press Ctrl+Home (Windows) or Command+Home (Mac OS).

Rotate or orient a 3D layer

You can turn a 3D layer by changing its Orientation or Rotation values. In both cases, the layer turns around its anchor point. The Orientation and Rotation properties differ in how the layer moves when you animate them.

When you animate the Orientation property of a 3D layer, the layer turns as directly as possible to reach the specified orientation. When you animate any of the X, Y, or Z Rotation properties, the layer rotates along each individual axis according to the individual property values. In other words, Orientation values specify an angular destination, whereas Rotation values specify an angular route. Animate Rotation properties to make a layer turn multiple times.

Animating the Orientation property is often better for natural, smooth motion, whereas animating the Rotation properties provides more precise control.

Rotate or orient a 3D layer in the Composition panel

  1. Select the 3D layer that you want to turn.
  2. Select the Rotation tool , and choose Orientation or Rotation from the Set menu to determine whether the tool affects Orientation or Rotation properties.
  3. In the Composition panel, do one of the following:
    • Drag the arrowhead of the 3D axis layer control corresponding to the axis around which you want to turn the layer.
    • Drag a layer handle. Dragging a corner handle turns the layer around the z axis; dragging a left or right center handle turns the layer around the y axis; dragging a top or bottom handle turns the layer around the x axis.
    • Drag the layer.
    Notă:

    Shift-drag to constrain your manipulations to 45-degree increments.

Rotate or orient a 3D layer in the Timeline panel

  1. Select the 3D layer that you want to turn.
  2. In the Timeline panel, modify the Rotation or Orientation property values.
    Notă:

    Press R to show Rotation and Orientation properties.

Online resources about rotating and orienting 3D layers

Donat Van Bellinghen provides some expressions on the AE Enhancers forum for placing and orienting a 3D layer in the plane defined by three points.

Axis modes

Axis modes specify on which set of axes a 3D layer is transformed. Choose a mode in the Tools panel.

Local Axis mode

Aligns the axes to the surface of a 3D layer.

World Axis mode

Aligns the axes to the absolute coordinates of the composition. Regardless of the rotations you perform on a layer, the axes always represent 3D space relative to the 3D world.

View Axis mode

Aligns the axes to the view you have selected. For example, suppose that a layer has been rotated and the view changed to a custom view; any subsequent transformation made to that layer while in View Axis mode happens along the axes corresponding to the direction from which you are looking at the layer.

Differences between the axis modes are only relevant when you have a 3D camera in a composition.

The Tools panel remembers the last-used 3D axis mode when you quit and restart After Effects.

Notă:

The Camera tools always adjust along the local axes of the view, so the action of the Camera tools is not affected by the axis modes.

Angie Taylor explains 3D axis modes in this tutorial.

3D layer interactions, render order, and collapsed transformations

The positions of certain kinds of layers in the layer stacking order in the Timeline panel prevent groups of 3D layers from being processed together to determine intersections and shadows.

A shadow cast by a 3D layer does not affect a 2D layer or any layer that is on the other side of the 2D layer in the layer stacking order. Similarly, a 3D layer does not intersect with a 2D layer or any layer that is on the other side of the 2D layer in the layer stacking order. No such restriction exists for lights.

3D layer interactions, render order, and collapsed transformations
3D layers intersecting (left), and 3D layers prevented from intersecting by intervening 2D layer (right)

Just like 2D layers, other types of layers also prevent 3D layers on either side from intersecting or casting shadows on one another:

  • An adjustment layer

  • A 3D layer with a layer style applied

  • A 3D precomposition layer to which an effect, closed mask (with mask mode other than None), or track matte has been applied

  • A 3D precomposition layer without collapsed transformations

A precomposition with collapsed transformations (Collapse Transformations switch selected) does not interfere with the interaction of 3D layers on either side—as long as all of the layers in the precomposition are themselves 3D layers. Collapsing transformations exposes the 3D properties of the layers that compose the precomposition. Essentially, collapsing transformations in this case allows each 3D layer to be composited into the main composition individually, rather than creating a single 2D composite for the precomposition layer and compositing that into the main composition. The tradeoff is that this setting removes your ability to specify certain layer settings for the precomposition as a whole—such as blending mode, quality, and motion blur.

Shadows cast by continuously rasterized 3D layers (including text layers) are not affected by effects applied to that layer. If you want the shadow to show the results of the effect, then precompose the layer with the effect.

Notă:

To ensure that the shadow remains where expected on a 3D layer with a track matte, precompose the 3D layer and the track matte layer together (but don’t collapse transformations), and then apply the shadow to the precomposition.

Effects on continuously rasterized vector layers with 3D properties are rendered in 2D and then projected onto the 3D layer. This projection does not occur for compositions with collapsed transformations.

Sigla Adobe

Conectați-vă la cont