Image Trace lets you convert raster images (JPEG, PNG, PSD etc.) to vector artwork. Using this feature, you can easily base a new drawing on an existing piece of artwork by tracing it. For example, you can convert the image of a pencil sketch you've drawn on paper into vector artwork using Image Trace. You can choose from a set of tracing presets to get the desired result quickly.

Example_Image-Trace-1
Before and after tracing a raster image using tracing presets

A. Original image B. Tracing results using different presets 

Trace an image

  1. Open or place a raster image in your Illustrator document.

  2. With the placed image selected, do one of the following:

    • Choose Object > Image Trace > Make to trace with default parameters. Illustrator converts the image to black and white tracing result by default.
    • Click the Image Trace button in the Control panel or the Properties panel, or select a preset from the Tracing Presets button ().
    • Choose Window > Image Trace or switch to the Tracing workspace to open the Image Trace panel, and do one of the following:

    Notă:

    • In the Image Trace panel, enable Preview to see the results of your modifications. 
    • The resolution of your placed image determines the speed of the tracing.

  3. (Optional) Adjust the results of the tracing in the Image Trace panel (Window > Image Trace).

  4. To convert the tracing object to paths and to manually editing the vector artwork, choose Object > Image Trace > Expand.

Specify tracing options

When the image is selected, you can see that the options in the Image Trace panel become available. At the top of the panel are the basic options; you can expose additional options by turning the triangle next to the Advanced label.

Basic controls

.
Specify the basic options in the Image Trace panel to get the desired tracing result.

Preset

Specifies a tracing preset. The icons located across the top of the panel are shortcuts named according to popular workflows. Choosing one of these presets sets all the variables needed to produce that related tracing result.

default-presets
Examples of tracing presets available in Image Trace panel
Icon Name of the preset Definition
Auto-Color Creates a posterized image from photo or artwork
High Color Creates photorealistic artwork of high fidelity
Low Color Creates simplified photorealistic artwork
Grayscale Traces the artwork to shades of gray
Black And White Simplifies the image to black-and-white artwork
Outline Simplifies the image to black outlines

Additional presets are accessible in the top drop-down menu.

drop-down-presets_color
Examples of tracing presets available in the Preset drop-down menu.

A. 3 Colors B. 6 Colors C. High Fidelity Photo 

Click the menu icon () to save the current settings as a new preset, or to delete or rename existing presets. For details, see Save a tracing preset.

View

Specifies the view of the traced object. A tracing object is made up of two components: the original source image and the tracing result (which is the vector artwork). You can choose to view the tracing result, source image, outlines, and other options. You can click the eye icon to overlay the selected view over the source image.

view
Choose a view of the traced object

A. Tracing Result B. Tracing Result With Outlines C. Outlines D. Outlines With Source Image E. Source Image 

Mode

Specifies a color mode for the tracing result. The available options define basic color versus grayscale modes for your traced artwork.

The following color settings appear based on the settings in the Mode option:

Colors

Specifies the number of colors to use in a color tracing result. If you have selected Document Library as the palette, you can choose a swatch. (This option is available only when Mode is set to Color.)

Mode_color
Adjust the number of colors in the tracing result when Mode is set to Color.

Grays

Specifies the number of grays to use in a grayscale tracing result. (This option is available only when Mode is set to Grayscale.)

Mode_grey
Adjust the number of grays in the tracing result when Mode is set to Grayscale.

Threshold

Specifies a value for generating a black and white tracing result from the original image. All pixels lighter than the Threshold value are converted to white; all pixels darker than the Threshold value are converted to black. (This option is available only when Mode is set to Black And White.)

Mode_blacknwhite
Adjust the threshold value to convert the pixels to black or white in the tracing result when Mode is set to Black And White.

Palette

Specifies a palette for generating a color or grayscale tracing from the original image. (This option is available only when Mode is set to Color or Grayscale.)

You can choose one of the following options:

Automatic

Automatically switches between the limited palette and full tone for the tracing, depending on the input image. When you select Automatic for your palette, you can adjust the Colors slider to alter vector simplicity and accuracy in the tracing. The value 0 means simplified at the expense of accuracy and the value 100 means accurate or photorealistic at the expense of simplicity.

Palette_automatic
Example: Tracing result when you choose Automatic

Limited

Uses a small set of colors for the tracing palette. You can use the Color slider to further reduce the colors selected.

Limited
Example: Tracing result when you choose Limited

Full Tone

Uses the entire set of colors for the tracing palette. This option is the best for tracing photos and creates photorealistic artwork. With this option selected, the Color slider determines the variability of the pixels that make up each of the fill regions. When the Color slider is to the right, the variability is smaller, resulting in more paths defined by smaller areas of color. On the other hand, when the slider is to the left, the fill areas are fewer and larger.

Palette_full-tone
Example: Tracing result when you choose Full Tone

Document Library

Uses an existing color group for the tracing palette. This option allows you to define the exact colors you want in your traced artwork. You can choose any color library you’ve loaded via the Swatches panel for your tracing palette.

P_Document-lib_colors
Example: Tracing result when you choose Document Library

Add color libraries to the Swatches panel from the Swatch Libraries menu

  1. To open the Swatches panel, choose Window > Swatches.
  2. Click the Swatch Libraries Menu icon () on the lower-left of the Swatches panel. Alternatively, choose Open Swatch Library from the panel menu.
  3. Choose a library from the list.
  4. To add the desired color group to the Swatches panel, click the Save Color Group To Swatches Panel button (). For details, see Use swatch libraries.
P_Swatch-lib_add
Add color libraries to the Swatches panel from the Swatch Libraries menu.
P_Swatch-library
Choose any color library you’ve loaded via the Swatches panel for your tracing palette.

Add color libraries to the Swatches panel using the Adobe Color Themes panel

  1. To open the Adobe Color Themes panel, choose Window > Color Themes.
  2. Explore the many public color themes available in the Explore tab or create your own color themes. Then, add the selected color theme to the Swatches panel. For details, see Use the Adobe Color Themes panel.
P_Document-lib_add-color-theme
Add color libraries to the Swatches panel from the Adobe Color Themes panel.
P_Swatch-lib_colors
Choose any color library you’ve loaded via the Adobe Color Themes panel for your tracing palette.

Advanced controls

Image-Trace-advanced-controls
Fine-tune your tracing result using advanced options in the Image Trace options.

Paths

Controls the distance between the traced shape and the original pixel shape. Lower values create a tighter path fitting; higher values create a looser path fitting.

Corners

Specifies the emphasis on corners and the likeliness that a sharp bend will turn into a corner point. A higher value results in more corners.

Noise

Specifies an area in pixels that is ignored while tracing. A higher value results in less noise.

Tip: For a high-resolution image, move the Noise slider to a higher value (for example in the 20–50 range) to have some effect. For a low-resolution image, set it lower (1–10).

Method

Specifies a method for tracing. You can choose one of the following options:

Icon Name of the preset Definition
Abutting Creates cutout paths. The edge of one path is exactly the same as the edge of its neighboring path.
Overlapping Creates stacked paths. Each path slightly overlaps its neighbor.

Fills

Creates filled regions in the tracing result.

Strokes

Creates stroked paths in the tracing result.

Stroke

Specifies the maximum width of features in the original image that can be stroked. Features larger than the maximum width become outlined areas in the tracing result.

Snap Curves To Lines

Specifies if slightly curved lines are replaced with straight lines and if lines near to 0 or 90 degrees are snapped to absolute 0 or 90 degrees.

Tip: You can choose this option for geometric artwork or if shapes in your source image are slightly rotated.

Ignore White

Specifies if white fills areas are replaced with no fills.

Save a tracing preset

  1. Open the Image Trace panel by choosing Window > Image Trace.

  2. Set tracing options for the preset using the Image Trace panel.

    Notă:

    You can’t edit or delete the default presets (default presets appear in brackets []). However, you can make an editable copy of a default preset by selecting the preset and choosing Save As New Preset from the panel menu.

  3. Click the menu icon () and choose Save As New Preset.

  4. Enter a name for the preset, and click OK.

  5. (Optional) To rename your saved preset, click the menu icon () and choose Rename. Enter a name for the preset, and click OK.

  6. (Optional) To delete your saved preset, click the menu icon () and choose Delete.

Edit the tracing result

When you are satisfied with the results of a tracing, you can convert the tracing object to paths. This final step allows you to work with the tracing result as you do other vector artwork. Once you convert the tracing object, you can no longer adjust the tracing options.

  1. Select the tracing result.

  2. To convert the tracing result to paths, do one of the following:

    • Click Expand in the Control panel or the Properties panel.
    • Choose Object > Image Trace > Expand

    The resulting paths are grouped together.

  3. To ungroup the grouped paths, click Ungroup in the Properties panel. Alternatively, choose Object > Ungroup.

  4. (Optional) To simplify paths by removing excess anchor points, choose Object > Path > Simplify. For details, see Simplify a path

    You can also reshape or edit paths. For details, see Adjust path segments.

  5. To color your tracing result, convert it to Live Paint Groups by selecting the desired paths and choosing Object > Live Paint > Make. For details, see Live Paint groups.

     

Release a tracing object

To discard a tracing but keep the original placed image, release the tracing object.

  1. Select the tracing object.

  2. Choose Object > Image Trace > Release.

Această lucrare este oferită sub licență Atribuire-Necomercial-FărăModificări 3.0 Ne-adaptată Creative Commons  Postările pe Twitter™ şi Facebook nu sunt acoperite de condiţiile de licenţiere Creative Commons.

Prevederi legale   |   Politică de confidențialitate online