Work with Smart Objects

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Migrate presets, actions, and settings
    8. Get to know Photoshop
  3. Photoshop and Adobe services
    1. Photoshop and Adobe Stock
    2. Creative Cloud Libraries
    3. Creative Cloud Libraries in Photoshop
    4. Grid and guides
    5. Creating actions
    6. Undo and history
    7. Default keyboard shortcuts
    8. Touch capabilities and customizable workspaces
    9. Use the Touch Bar with Photoshop
    10. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export cloud documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. System requirements 1.x | Photoshop on the iPad
    23. System requirements 2.x | Photoshop on the iPad
    24. Edit your image size
    25. Livestream as you create in Photoshop on the iPad
    26. Correct imperfections with the Healing Brush
    27. Create brushes in Capture and use them in Photoshop
  5. Cloud documents
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud doc sync logs
    8. Share access and edit your cloud documents
  6. Workspace
    1. Workspace basics
    2. Create documents
    3. Use the Touch Bar with Photoshop
    4. Microsoft Dial support in Photoshop
    5. Tool galleries
    6. Performance preferences
    7. Use tools
    8. Touch gestures
    9. Touch capabilities and customizable workspaces
    10. Technology previews
    11. Metadata and notes
    12. Quickly share your creations
    13. Place Photoshop images in other applications
    14. Preferences
    15. Default keyboard shortcuts
    16. Rulers
    17. Show or hide non-printing Extras
    18. Specify columns for an image
    19. Undo and history
    20. Panels and menus
    21. Place files
    22. Position elements with snapping
    23. Position with the Ruler tool
    24. Presets
    25. Customize keyboard shortcuts
    26. Grid and guides
  7. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Export files in Photoshop
    4. Device Preview
    5. Copy CSS from layers
    6. Slice web pages
    7. HTML options for slices
    8. Modify slice layout
    9. Work with web graphics
    10. Create web photo galleries
  8. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  9. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
    26. Layer
    27. Flattening
    28. Composite
    29. Background
  10. Selections
    1. Select and Mask workspace
    2. Make quick selections
    3. Get started with selections
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Select a color range in an image
    7. Adjust pixel selections
    8. Convert between paths and selection borders
    9. Channel basics
    10. Move, copy, and delete selected pixels
    11. Create a temporary quick mask
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
    16. Selection
    17. Bounding box
  11. Image adjustments
    1. Perspective warp
    2. Reduce camera shake blurring
    3. Healing brush examples
    4. Export color lookup tables
    5. Adjust image sharpness and blur
    6. Understand color adjustments
    7. Apply a Brightness/Contrast adjustment
    8. Adjust shadow and highlight detail
    9. Levels adjustment
    10. Adjust hue and saturation
    11. Adjust vibrance
    12. Adjust color saturation in image areas
    13. Make quick tonal adjustments
    14. Apply special color effects to images
    15. Enhance your image with color balance adjustments
    16. High dynamic range images
    17. View histograms and pixel values
    18. Match colors in your image
    19. How to crop and straighten photos
    20. Convert a color image to black and white
    21. Adjustment and fill layers
    22. Curves adjustment
    23. Blending modes
    24. Target images for press
    25. Adjust color and tone with Levels and Curves eyedroppers
    26. Adjust HDR exposure and toning
    27. Filter
    28. Blur
    29. Dodge or burn image areas
    30. Make selective color adjustments
    31. Replace object colors
  12. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. How to make non-destructive edits in Camera Raw
    10. Radial Filter in Camera Raw
    11. Manage Camera Raw settings
    12. Open, process, and save images in Camera Raw
    13. Repair images with the Enhanced Spot Removal tool in Camera Raw
    14. Rotate, crop, and adjust images
    15. Adjust color rendering in Camera Raw
    16. Feature summary | Adobe Camera Raw | 2018 releases
    17. New features summary
    18. Process versions in Camera Raw
    19. Make local adjustments in Camera Raw
  13. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  14. Image transformations
    1. Transform objects
    2. Adjust crop, rotation, and canvas size
    3. How to crop and straighten photos
    4. Create and edit panoramic images
    5. Warp images, shapes, and paths
    6. Vanishing Point
    7. Use the Liquify filter
    8. Content-aware scaling
    9. Transform images, shapes, and paths
    10. Warp
    11. Transform
    12. Panorama
  15. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Fill and stroke selections, layers, and paths
    14. Draw with the Pen tools
    15. Create patterns
    16. Generate a pattern using the Pattern Maker
    17. Manage paths
    18. Manage pattern libraries and presets
    19. Draw or paint with a graphics tablet
    20. Create textured brushes
    21. Add dynamic elements to brushes
    22. Gradient
    23. Paint stylized strokes with the Art History Brush
    24. Paint with a pattern
    25. Sync presets on multiple devices
  16. Text
    1. Work with OpenType SVG fonts
    2. Format characters
    3. Format paragraphs
    4. How to create type effects
    5. Edit text
    6. Line and character spacing
    7. Arabic and Hebrew type
    8. Fonts
    9. Troubleshoot fonts
    10. Asian type
    11. Create type
    12. Text Engine error using Type tool in Photoshop | Windows 8
    13. World-Ready composer for Asian Scripts
    14. How to add and edit text in Photoshop
  17. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  18. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  19. Saving and exporting
    1. Save files in graphics formats
    2. Save your files in Photoshop
    3. File formats
    4. Save and export video and animations
    5. Save PDF files
    6. Digimarc copyright protection
  20. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Duotones
    8. Print images to a commercial printing press
    9. Improve color prints from Photoshop
    10. Troubleshoot printing problems | Photoshop
  21. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  22. 3D and technical imaging
    1. Creative Cloud 3D Animation (Preview)
    2. Print 3D objects
    3. 3D painting
    4. 3D panel enhancements | Photoshop
    5. Essential 3D concepts and tools
    6. 3D rendering and saving
    7. Create 3D objects and animations
    8. Image stacks
    9. 3D workflow
    10. Measurement
    11. DICOM files
    12. Photoshop and MATLAB
    13. Count objects in an image
    14. Combine and convert 3D objects
    15. 3D texture editing
    16. Adjust HDR exposure and toning
    17. 3D panel settings
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Work with color profiles
    5. Color-managing documents for online viewing
    6. Color-managing documents when printing
    7. Color-managing imported images
    8. Proofing colors

Understand Smart Objects

Smart Objects are layers that contain image data from raster or vector images, such as Photoshop or Illustrator files. Smart Objects preserve an image's source content with all its original characteristics, enabling you to perform nondestructive editing to the layer.

In Photoshop, you can embed the contents of an image into a Photoshop document. In Photoshop, you can also create Linked Smart Objects whose contents are referenced from external image files. The contents of a Linked Smart Object are updated when its source image file changes.

Linked Smart Objects are distinct from duplicated instances of a Smart Object within a Photoshop document. With Linked Smart Objects, you can use a shared source file across multiple Photoshop documents which is a familiar and welcome concept for web designers.

Smart Object benefits

With Smart Objects, you can:

  • Perform nondestructive transforms. You can scale, rotate, skew, distort, perspective transform, or warp a layer without losing original image data or quality because the transforms don't affect the original data.

  • Work with vector data, such as vector artwork from Illustrator, that otherwise would be rasterized in Photoshop.

  • Perform nondestructive filtering. You can edit filters applied to Smart Objects at any time.

  • Edit one Smart Object and automatically update all its linked instances.

  • Apply a layer mask that's either linked or unlinked to the Smart Object layer.

  • Try various designs with low-resolution placeholder images that you later replace with final versions.

You can't perform operations that alter pixel data—such as painting, dodging, burning, or cloning—directly to a Smart Object layer, unless it is first converted into a regular layer, which will be rasterized. To perform operations that alter pixel data, you can edit the contents of a Smart Object, clone a new layer above the Smart Object layer, edit duplicates of the Smart Object, or create a new layer.

Notă:

When you transform a Smart Object that has a Smart Filter applied to it, Photoshop turns off filter effects while the transform is being performed. Filter effects are applied again after the transform is complete. See Apply Smart Filters.

Photoshop smart object benefits
Regular layer and a Smart Object in the Layers panel. The icon in the lower-right corner of the thumbnail indicates a Smart Object.

Photoshop Smart Object in the Layers panel
(Photoshop) A linked Smart Object in the Layers panel

Create embedded Smart Objects

You can create embedded Smart Objects using several methods: by using the Open As Smart Object command; placing a file (Photoshop CS6) or placing a file as embedded (Photoshop, and Photoshop CS6), pasting data from Illustrator; or converting one or more Photoshop layers to Smart Objects.

  1. Do any of the following:
    • (Photoshop) Choose File > Place Embedded to import files as Smart Objects into an open Photoshop document.
    • Choose File > Open As Smart Object, select a file, and click Open.
    • (Photoshop CS6) Choose File> Place to import files as Smart Objects into an open Photoshop document.
    Notă:

    Although you can place JPEG files, it's better to place PSD, TIFF, or PSB files because you can add layers, modify pixels, and resave the file without loss. (Saving a modified JPEG file requires you to flatten new layers and recompress the image, causing image quality degradation).

    • Choose Layer > Smart Object > Convert to Smart Object to convert a selected layer into a Smart Object.
    • In Bridge, choose File > Place > In Photoshop to import a file as a Smart Object into an open Photoshop document.
    • Select one or more layers and choose Layer > Smart Objects > Convert To Smart Object. The layers are bundled into one Smart Object.

    • Drag PDF or Adobe Illustrator layers or objects into a Photoshop document.

    • Paste artwork from Illustrator into a Photoshop document, and choose Smart Object in the Paste dialog box. For the greatest flexibility, enable both PDF and AICB (No Transparency Support) in the File Handling & Clipboard section of the Preferences dialog box in Adobe Illustrator.

Create Linked Smart Objects | Photoshop

Notă:

The Linked Smart Object feature is available in Photoshop CC version 14.2 (January 2014) and later.

In Photoshop, you can create Linked Smart Objects. The contents of Linked Smart Objects are updated when the source image file changes. Linked Smart Objects are particularly useful for teams or in cases where assets must be reused across designs.

Follow these steps to create a Linked Smart Object:

  1. Choose File > Place Linked.
  2. Select an appropriate file and click Place.

The Linked Smart Object is created and is displayed in the Layers panel with a link icon ().

Notă:

You can also create a Linked Smart Object in an open document by dragging and dropping the appropriate file while keeping the following key pressed:

(Windows) Alt key
(Mac OS) Option key

To change this default behavior, turn off Preferences > General > Always Create Smart Objects While Placing.

File size savings using Linked Smart Objects

Since Linked Smart Objects maintain a dependency on an external file rather than embedding a source file within the containing document, they often result in significantly smaller file sizes. While Linked Smart Objects do not store the original file in the containing document, they still store a flattened and scaled version of the image data from the original file. In some cases, the size of this data may be much larger than the size of the original file, making the file size savings seem negligible.

Update Linked Smart Objects

If an external source file changes while a Photoshop document referencing it is open, the relevant Linked Smart Object is automatically updated. However, when you open a Photoshop document containing out-of-synch Linked Smart Objects, you can update the Smart Objects:

  • Right-click a Linked Smart Object layer and choose Update Modified Content.
  • Choose Layer > Smart Objects > Update Modified Content.

Linked Smart Objects whose source images have changed are visually highlighted in the Layers panel:

Photoshop Out-of-sync Linked Smart Objects highlighted in the Layers panel
Out-of-sync Linked Smart Objects are highlighted in the Layers panel.

Notă:

You can update all linked Smart Objects in the current Photoshop document by choosing Layer > Smart Objects > Update All Modified Content.

Photoshop Linked Smart Objects with missing external source files highlighted in the Layers panel
Linked Smart Objects with missing external source files are highlighted in the Layers panel.

Notă:

While detecting changes to Linked Smart Objects or updating a Linked Smart Object, Photoshop looks only at the immediate linked file. Links nested inside Smart Objects are not updated.

To resolve a Linked Smart Object with a missing external source, follow these steps:

  1. Right-click the Linked Smart Object layer icon and choose Resolve Broken Link.
  2. Navigate to the new location of the missing object.
  3. Click Place.

View Linked Smart Object properties

With a Linked Smart Object layer selected in the Layers panel, choose Window > Properties.

The following properties are displayed:

  • The path of the external source file for the Linked Smart Object
  • The Linked Smart Object size and positional coordinates (X, Y)

You can perform the following actions directly from within the Properties panel:

  • Edit the contents of the external image file. If necessary, Photoshop opens an external application that can handle the source image file. For example, Photoshop opens Adobe Illustrator if the external source image is a .ai file.
  • Embed the Linked Smart Object within the current document.

Embed Linked Smart Objects

Do one of the following:

  • Right-click a Linked Smart Object layer in the Layers panel and choose Embed Linked.
  • Choose Layer > Smart Objects > Embed Linked.
  • In the Properties panel, click Embed.
Notă:

Choose Layer > Smart Objects > Embed All Linked to embed all Linked Smart Objects in the Photoshop document.

Package Linked Smart Objects

You can package the Linked Smart Objects in a Photoshop document, such that their source files are saved to a folder on your computer. A copy of the Photoshop document is saved along with the source files in the folder.

  1. Choose File > Package.
  2. Select a location where you want to place the source files and a copy of the Photoshop document.

Any audio or video Linked Smart Objects in the document are packaged as well.

Notă:

You must save a file before packaging the Linked Smart Objects that it contains.

How Photoshop locates linked files

Photoshop always looks for linked files in the last-known relative location. If the linked file is not found in that location, Photoshop looks for it:

  • In the last-known absolute location
  • Using a saved alias (Mac OS only)
  • In the same folder as the containing document

This behavior allows you to move, copy, and share project folders and files with minimal risk of encountering broken links.

Notă:

The Resolve Missing Assets dialog always displays the last-known absolute path of missing source files.

Convert an embedded Smart Object to a Linked Smart Object

You can convert an embedded Smart Object to a Linked Smart Object. Transforms, filters, and other effects applied to the embedded Smart Object are preserved when it is converted.

Do the following:

  1. Select an embedded Smart Object layer in the Photoshop document.
  2. Choose Layer > Smart Object > Convert To Linked.
  3. Select the location on your computer where you want to save the source file. Enter a name for the file, including a supported extension. For example, link_file.jpg.

Filter the Layers panel by Smart Objects | Photoshop

  1. In the Layers panel, select Smart Object from the filtering pop-up menu.
Photoshop Filter layers by Smart Objects
Filter layers by Smart Objects

  1. Click one of the following icons:
  •     Filter for up-to-date Linked Smart Objects
  •     Filter for out-of-synch Linked Smart Objects
  •     Filter for missing Linked Smart Objects
  •     Filter for embedded Smart Objects
Notă:

You can use the toggle switch () to turn off layer filtering.

Duplicate an embedded Smart Object

  1. In the Layers panel, select a Smart Object layer, and do one of the following:
    • To create a duplicate Smart Object that is linked to the original, choose Layer > New > Layer Via Copy, or drag the Smart Object layer to the Create A New Layer icon at the bottom of the Layers panel. Edits you make to the original affect the copy and vice versa.

    • To create a duplicate Smart Object that isn't linked to the original, choose Layer > Smart Objects > New Smart Object Via Copy. Edits you make to the original don't affect the copy.

    A new Smart Object appears in the Layers panel with the same name as the original and "copy" as a suffix.

Edit the contents of a Smart Object

When you edit a Smart Object, the source content is opened in either Photoshop (if the content is raster data or a camera raw file) or the application that handles the placed format by default (for example, Adobe Illustrator or Adobe Acrobat). When you save changes to the source content, the edits appear in all linked instances of the Smart Object in the Photoshop document.

  1. Select the Smart Object from the Layers panel, and do one of the following:
    • Choose Layer > Smart Objects > Edit Contents.
    • Double-click the Smart Objects thumbnail in the Layers panel.
    • In the Properties panel, click Edit Contents.
  2. Click OK to close the dialog box.
  3. Make edits to the source content file, then choose File > Save.

    Photoshop updates the Smart Object to reflect the changes you made. (If you don't see the changes, make the Photoshop document containing the Smart Object active.)

Replace the contents of a Smart Object

You can replace the image data in one Smart Object or multiple linked instances. This feature lets you quickly update a visual design, or replace low-resolution placeholder images with final versions.

Notă:

When you replace a Smart Object, any scaling, warping, or effects that you applied to the first Smart Object are maintained.

  1. Select the Smart Object, and choose Layer > Smart Objects > Replace Contents.
  2. Navigate to the file you want to use, and click Place.
  3. Click OK.

    The new content is placed in the Smart Object.

Convert an embedded or linked Smart Object to layers

Introduced in Photoshop 21.0 (November 2019 release)

You can convert an embedded or linked smart object back into its component layers directly into a Photoshop document. If there are multiple layers in the Smart Object, the layers are unpacked into a new layer group within the Layers panel. Transforms and Smart Filters on Smart Objects containing more than a single layer are not retained when you unpack. 

Convert a Smart Object back into its component layers
Convert a Smart Object back into its component layers

  1. Select the Smart Object layer from the Layers panel.

  2. Do any of the following:

    • Right-click (Win) / Control-click (Mac) the Smart Object layer and select Convert To Layers from the context menu. 
    • From the menu bar, choose Layer > Smart Objects > Convert To Layers.
    • In the Properties panel, click Convert To Layers.
    • From the Layers panel's options menu, choose Convert To Layers
  3. The layers are unpacked into a layer group in the Layers panel.

Rasterize an embedded or linked Smart Object

You can rasterize the contents of a Smart Object to a regular layer if you no longer need to edit the Smart Object data. Transforms, warps, and filters applied to a Smart Object are no longer editable after the Smart Object is rasterized.

Select the Smart Object, and choose Layer > Smart Objects > Rasterize.  

Notă:

If you want to re-create the Smart Object, reselect its original layers and start from scratch. The new Smart Object won't retain transforms you applied to the original Smart Object.

Export the contents of an embedded Smart Object

  1. Select the Smart Object from the Layers panel, and choose Layer > Smart Objects > Export Contents.

  2. Choose a location for the contents of the Smart Object, then click Save.

    Photoshop exports the Smart Object in its original placed format (JPEG, AI, TIF, PDF, or other formats). If the Smart Object was created from layers, it is exported in PSB format.

Reset Smart Object transforms

If you've transformed a Smart Object, you can reset all transformations you've previously applied by doing one of the following: 

  • Right-click the Smart Object layer and choose Reset Transform
  • Choose Layer > Smart Objects > Reset Transform
Sigla Adobe

Conectați-vă la cont