Uvoz datotek SVG

Zadnja posodobitev 11. sep. 2026

Naučite se, kako uvoziti datoteke SVG kot izvorne, urejljive plasti oblik, ki so pripravljene za animacijo brez kakršne koli pretvorbe.

Dvokliknite v podokno Projekt ali uporabite Datoteka > Uvoz > Datoteka za brskanje in uvoz datoteke SVG.

Opomba

Najnovejša različica programa After Effects vam omogoča, da uvozite datoteko kot posnetek ali sestavo.

Povlecite in spustite uvoženo datoteko SVG v podokno časovnica.

Izberite plast in uporabite razdelek Vsebina plasti v podoknu Lastnosti za ogled strukture SVG.

Podokno Lastnosti je odprto in pod vsebino plasti so navedene vsebine SVG.
Uporabite podokno Lastnosti za ogled vsebine datoteke SVG in prilagajanje njihovih lastnosti.

Lahko tudi izberete puščico poleg plasti, da jo razvijete, nato razširite razdelek Vsebina.Videli boste vse posamezne elemente in njihove lastnosti, kot so Pot, Zapolnitev in Pretvorba.

Plast z datoteko SVG je izbrana, razdelek vsebina pa je razširjen za prikaz njenih lastnosti, vključno s potjo, zapolnitvijo in pretvoritvijo.
Razširite razdelek Vsebina plasti SVG za dostop do njenih lastnosti in njihovo urejanje, vključno s potjo, zapolnitvijo in pretvoritvijo.

Te lastnosti lahko uporabite za animacijo kot katero koli drugo plast oblike.Primer:

  • Animirajte Pot za ustvarianje učinkov preoblikovanja
  • Spremenite barvo zapolnitve skozi čas za dinamične prehode
  • Uporabite lastnosti Preoblikovanje za neodvisno spreminjanje velikosti, vrtenje ali premikanje elementov

Če imajo plasti prelivne zapolnitve in poteze, lahko uporabite lastnosti Velikost in Vrtenje za animacijo preliva.

Ena od plasti z elementom preliva je izbrana, poudarjen pa je preliv zapolnitev 1.
Uporabite lastnosti prelivne zapolnitve za prilagajanje preliva ali njihovo animacijo.

Uvozite datoteko SVG kot posnetek ali kot sestavo

Uvoz SVG v programu After Effects ponuja prilagodljiv in boljši nadzor nad tem, kako so datoteke SVG uvožene v vaš projekt.Z najnovejšo različico lahko ob uvozu datoteke SVG izberete, da jo uvozite kot posnetek ali kot sestavo.

Uvoz kot posnetek

Uvoz kot kompozicija

Uvozi SVG kot enoten, nepretrgano rasterizabilen vektorski plast.

Uvozi SVG kot kompozicijo, sestavljeno iz plasti oblik, ki jih je mogoče urejati.

Ohranja povezavo z zunanjo datoteko SVG.

Vsak element se pretvori v svojo plast oblike, ki jo je mogoče urejati.

Primerno za enoplastno vektorsko grafiko, kadar umetnine ni treba razdeliti na dele.

Primerno za urejanje poti, oblik in podrobnosti na ravni plasti, ko morate animirati posamezne elemente.

Nadzirate lahko, kateri pristop uvoza se privzeto uporablja pri uvozu datotek SVG, z nastavitvijo možnosti Povleci več elementov datotek kot pod nastavitvami Uvoz.

  • macOS: After Effects > Nastavitve > Uvoz > Povleci več elementov datotek kot
  • Windows: Uredi > Nastavitve > Uvoz > Povleci več elementov datotek kot
Pogovorno okno Nastavitve je odprto. Na zavihku Uvoz je odprto spustno menu Povleci več elementov datotek kot, ki ponuja možnosti za izbiro načina uvoza.
Nastavite privzeto nastavitev za uvoz datoteke SVG in izberite, ali se uvozi kot posnetek ali kot kompozicija.

Dvokliknite v podokno Projekt ali uporabite Datoteka > Uvoz > Datoteka, da pobrskate in uvozite datoteko SVG.

Uporabite spustni meni Uvozi kot v pogovornem oknu Uvozi datoteko in izberite eno od naslednjih možnosti:

  • Posnetek
  • Kompozicija - Ohrani velikosti plasti

Izbira Posnetek uvozi datoteko kot enotno sploščeno plast brez dostopa do posameznih elementov, kar je primerno za statično uporabo ali kadar animacija ni potrebna.Izbira Kompozicija – Ohrani velikosti plasti ustvari novo kompozicijo, kjer se vsaka izvorna plast uvozi ločeno, prilagojena njeni dejanski vsebini, kar omogoča čistejše sidrne točke in lažje pretvorbe za animacijo.

macOS

Pogovorno okno Uvozi datoteko je odprto in na voljo so možnosti za uvoz datoteke kot posnetek ali kot kompozicija.

Windows

Pogovorno okno Uvozi datoteko je odprto in na voljo so možnosti za uvoz datoteke kot posnetek ali kot kompozicija.

Po potrebi izberite naslednje možnosti:

  • Ustvari kompozicijo: Ustvari novo kompozicijo z uporabo privzetih nastavitev in samodejno postavi uvoženi SVG, bodisi kot posnetek ali kot kompozicijo s plastmi oblik, na časovnico, kar vam prihrani ročno ustvarjanje kompozicije in vlečenje datoteke SVG vanjo.
  • Zaporedje skalabilne vektorske grafike: Uvozi več oštevilčenih datotek SVG in jih obravnava kot zaporedje vektorskih slik po sličicah.

Uporabite razdelek Vsebina plasti v podoknu Lastnosti ali razdelek Vsebina plasti v časovnici za ogled in delo z posameznimi elementi ter njihovimi lastnostmi, če ste uvozili datoteko SVG kot kompozicijo. Če je uvožena kot posnetek, se obnaša kot običajna plast in jo lahko prilagodite z uporabo standardnih lastnosti Transform.

Tako kot pri datotekah programa Illustrator lahko, če je vektorska datoteka uvožena kot posnetek, izberete plast v časovnici, nato z desno tipko miške kliknete in izberete Ustvari > Ustvari oblike in besedilo iz vektorske plasti, da jo pretvorite v plasti, ki jih je mogoče urejati, kar vam omogoča animiranje posameznih poti, potez in zapolnitev. V najnovejši različici Beta programa After Effects se besedilo v izvorni datoteki pretvori v plasti besedila, ki jih je mogoče urejati in ohranjajo pisavo, velikost, polnilo, položaj, sloge, poteze in nastavitve spremenljivih pisav. 

Ko uvozite SVG kot posnetke, After Effects ohrani živo povezavo z izvirno datoteko, tako da se vse spremembe, ki jih naredite v tem SVG-ju zunaj programa, samodejno posodobijo v vašem projektu.

Pretvorite besedilo programa Illustrator v plasti besedila, ki jih je mogoče urejati

Uporabite nove funkcije beta

Besedilo, ki ga je mogoče urejati, iz datotek programa Illustrator je zdaj na voljo za testiranje in povratne informacije. Preizkusite zdaj v programu After Effects (beta).

V najnovejši beta različici programa After Effects se, ko je plast programa Illustrator uvožena kot posnetek, vse besedilo v izvorni datoteki pretvori v svojo plast besedila, ki jo je mogoče urejati, namesto da bi bilo sploščeno v obrise oblik.To pomeni, da se pisava, velikost, polnilo, položaj, slogi (kot sta krepko in ležeče), poteze in nastavitve spremenljivih pisav prenesejo, tako da lahko besedilo še naprej urejate neposredno v programu After Effects, namesto da bi ga ustvarjali znova ali se za spremembe vračali v program Illustrator.

Izberite Datoteka > Uvoz > Datoteka in nato datoteko programa Illustrator, ki jo želite uvoziti.

V pogovornem oknu Uvozi datoteko se prepričajte, da je Uvozi kot nastavljeno na Footage, ko izbirate datoteko za uvoz.

V pogovornem oknu za uvoz potrdite, da je Vrsta uvoza nastavljena na Posnetki in izberite Možnosti plasti glede na to, kaj želite uvoziti iz datoteke programa Illustrator.

Povlecite uvoženo datoteko v podokno Časovnica.

Z desno tipko miške kliknite plast programa Illustrator in izberite Ustvari > Ustvari oblike in besedilo iz vektorske plasti ali uporabite Plast > Ustvari > Ustvari oblike in besedilo iz vektorske plasti.

Podmeni Plast > Ustvari z označeno možnostjo Ustvari oblike in besedilo iz vektorske plasti, ki pretvarja vektorsko besedilo v plasti besedila, ki jih je mogoče urejati.
Izberite Ustvari oblike in besedilo iz vektorske plasti, da pretvorite besedilo programa Illustrator v plasti besedila programa After Effects, ki jih je mogoče urejati, namesto v oblike.

Besedilo se pretvori v plast besedila, ki jo je mogoče urejati in tesno ujema pisavo, velikost, polnilo in položaj izvirne datoteke. Nato lahko urejate in prilagajate besedilo neposredno v programu After Effects.

Plast besedila svetlosti nad grafiko plamena s podoknom Znak, ki prikazuje pisavo Adobe Clean Italic, velikost 74 px in omogočeno polnilo.
Po pretvorbi ostane besedilo popolnoma uredljivo — pisavo, slog, velikost in polnilo lahko še vedno spremenite v podoknu Znak.

Opomba

Besedilo samo s potezami se še vedno pretvori kot poti in ne kot plast besedila, ki jo je mogoče urejati. 

Vektorska vsebina, ki ni besedilo, se še vedno pretvori v plasti oblik kot prej, in če datoteka programa Illustrator vsebuje oboje, boste dobili mešanico plasti besedila in oblik.

Pridružite se pogovoru v naši skupnosti After Effects (Beta) o podpori za uredljivo besedilo iz datotek programa Illustrator.

Kopirajte in prilepite vsebino iz programa Illustrator in SVG

Vsebino SVG v odložišču lahko sedaj prilepite v After Effects z uporabo Uredi > Prilepi. Vsebina se uvozi kot matične, uredljive plasti oblik, ki so pripravljene za animacijo, brez vmesnega koraka uvoza.

Kopirajte vsebino iz programa Illustrator

Odprite svojo grafiko v programu Adobe Illustrator.

Preverite, ali je izbrana nastavitev Vključi kodo SVG.

  • macOS: Izberite Illustrator > Nastavitve > Ravnanje z odložiščem in izberite Vključi kodo SVG.
  • Windows: Izberite Uredi > Nastavitve > Ravnanje z odložiščem in izberite Vključi kodo SVG.
Pogovorno okno Nastavitve je odprto v programu Illustrator in izbrana je možnost Vključi kodo SVG.
Omogočite možnost Vključi kodo SVG, da ostane vaša grafika uredljiva in visokokakovostna v drugih programih Adobe.

Izberite grafiko, ki jo želite kopirati.

Namig

Pred kopiranjem pretvorite besedilo SVG v krivulje, ker besedilo SVG pri prilepljenju ni podprto.

Izberite Uredi > Kopiraj.

Preklopite na After Effects in naredite eno od naslednjega glede na stanje vašega projekta:

  • Če ni odprt noben projekt, izberite Uredi > Prilepi, da ustvarite nov projekt s kompozicijo, ki vsebuje vsebino SVG kot plast oblike.
  • Če je projekt odprt, vendar ni izbrana nobena kompozicija, izberite Uredi > Prilepi, da ustvarite novo kompozicijo v trenutnem projektu, ki vsebuje prilepljeno vsebino.
Izbrana je možnost Uredi > Prilepi in vsebina se uvozi kot matične, uredljive plasti oblik, pripravljene za animacijo.
Uredi > Prilepi uvozi vsebino kot uredljive plasti oblik, pripravljene za animacijo.

Če je v programu After Effects izbrana kompozicija, izberite Uredi > Prilepi, da dodate vsebino SVG kot novo plast oblike v to kompozicijo.

Prilepite SVG iz drugih programov

Vsebino SVG, kopirano iz katerega koli programa, ki zapiše SVG v sistemsko odložišče, lahko prilepite z enakim potekom dela Uredi > Prilepi. Podpora je odvisna od tega, ali izvorni program postavi veljavne podatke SVG v odložišče.