Informatie over geluiden en Animate CC

In Adobe Animate kunt u geluid op verschillende manieren toepassen. U kunt geluiden maken die, onafhankelijk van de tijdlijn, continu worden afgespeeld of de tijdlijn gebruiken om animatie met een geluidsspoor te synchroniseren. U kunt geluiden aan knoppen toevoegen om ze interactiever te maken en geluiden laten in- en uitfaden om een mooier geluidsspoor te maken.

Animate werkt met twee soorten geluid: gebeurtenisgeluiden en streaming geluiden. Een gebeurtenisgeluid moet volledig worden gedownload voordat het wordt afgespeeld en het blijft afspelen totdat het expliciet wordt gestopt. Streaming geluiden worden afgespeeld zodra voldoende gegevens voor de eerste paar frames zijn gedownload; streaming geluiden worden met de tijdlijn gesynchroniseerd om op een website te worden afgespeeld.

Wanneer u Animate-inhoud voor mobiele apparaten maakt, kunt u met Animate ook apparaatgeluiden in uw gepubliceerd SWF-bestand opnemen. Apparaatgeluiden worden gecodeerd in de native ondersteunde audio-indeling van het apparaat, zoals MIDI, MFi of SMAF.

U kunt gezamenlijke bibliotheken gebruiken om een geluid aan meerdere documenten te koppelen. U kunt ook de ActionScript® 2.0-gebeurtenis onSoundComplete of de ActionScript® 3.0-gebeurtenis soundComplete gebruiken om een gebeurtenis te activeren op basis van de voltooiing van een geluid.

U kunt geluiden laden en het afspelen van geluid besturen met vooraf geschreven gedragingen of mediacomponenten; de laatste bieden tevens een bediening voor stoppen, pauzeren, terugspoelen, enzovoort. U kunt ook ActionScript 2.0 of 3.0 gebruiken om geluiden dynamisch te laden.

Raadpleeg attachSound (methode Sound.attachSound) en loadSound (methode Sound.loadSound) in de Naslaggids voor ActionScript 2.0 of Klasse Sound in de Naslaggids voor ActionScript 3.0 en ActionScript 3.0-componenten voor meer informatie.

Opmerking:

(Alleen Animate Professional CC) ActionScript 2.0 en ActionScript 1.0 worden niet ondersteund in Animate CC.

Opmerking:

(Alleen Animate CC) Om te werken met geluiden in Animate CC, is een voorinstallatie van QuickTime of iTunes niet nodig.

De volgende video's en artikelen bieden gedetailleerde instructies voor het gebruik van geluid in Animate.

Geluiden importeren

U plaatst geluidsbestanden in Animate door deze in de bibliotheek te importeren, of rechtstreeks op het werkgebied te importeren.

Met de menuoptie Bestand > Importeren > Importeren naar bibliotheek plaatst u de audiobestanden alleen in de bibliotheek, en niet op de tijdlijn.

Wanneer u een audiobestand importeert met Bestand > Importeren > Importeren naar werkgebied, of wanneer u het audiobestand sleept en rechtstreeks neerzet op de tijdlijn, wordt de audio op het actieve frame van de actieve laag geplaatst.Als u meerdere audiobestanden sleept en neerzet, wordt er slechts één audiobestand geïmporteerd, aangezien elk frame slechts één audiobestand kan bevatten.  

Gebruik een van de volgende methoden om audio te importeren:

  • Als u een audiobestand naar de bibliotheek wilt importeren, selecteert u Bestand > Importeren > Importeren naar bibliotheek. Selecteer vervolgens het audiobestand dat u wilt importeren.
  • Als u een audiobestand naar het werkgebied wilt importeren, selecteert u Bestand > Importeren > Importeren naar werkgebied. Selecteer vervolgens het audiobestand dat u wilt importeren. 
  • Sleep het audiobestand en zet het rechtstreeks neer op het werkgebied.

Opmerking:

U kunt ook een geluid uit een algemene bibliotheek naar de bibliotheek voor het huidige document slepen.

Animate slaat geluiden samen met bitmaps en symbolen op in de bibliotheek. U hebt maar een enkele kopie van een geluidsbestand nodig om dat geluid op meerdere manieren in uw document te gebruiken.

Wanneer u geluiden wilt delen tussen Animate-documenten, kunt u de geluiden in gezamenlijke bibliotheken opnemen.

Animate bevat een geluidenbibliotheek met allerlei handige geluiden voor de effecten die u maakt. Kies Venster > Algemene bibliotheken > Geluiden om de geluidenbibliotheek te openen. Als u een geluid uit de geluidenbibliotheek wilt importeren in uw Animate-bestand, sleept u het geluid uit de geluidenbibliotheek naar het deelvenster Bibliotheek van uw Animate-bestand. U kunt ook geluiden van de geluidenbibliotheek naar andere gedeelde bibliotheken slepen.

Geluiden kunnen veel schijfruimte en RAM in beslag nemen. MP3-geluidsgegevens zijn echter gecomprimeerd en kleiner dan WAV- of AIFF-geluidsgegevens. Over het algemeen is het bij gebruik van WAV- of AIFF-bestanden aan te raden 16-22 kHz monogeluid te gebruiken (stereo gebruikt tweemaal zoveel gegevens als mono), maar Animate kan 8- en 16-bits geluid op bemonsteringsfrequenties van 11, 22 of 44 kHz importeren. Geluiden die in een andere indeling dan veelvouden van 11 kHz zijn opgenomen (zoals 8, 32 of 96 kHz), worden opnieuw bemonsterd wanneer ze in Animate worden geïmporteerd. Animate kan geluiden bij export in een lagere bemonsteringsfrequentie omzetten.

Wanneer u effecten aan geluiden in Animate wilt toevoegen, kunt u het beste 16-bits geluiden importeren. Als uw RAM beperkt is, moet u uw geluidsclips kort houden of met 8-bits geluiden werken in plaats van 16-bits.

opmerking: (Alleen Animate CC) Om geluiden te importeren of af te spelen in Animate, is een voorinstallatie van QuickTime of iTunes niet nodig.

 

Ondersteunde indelingen voor geluidsbestanden

U kunt de volgende indelingen voor geluidsbestanden in Animate importeren:

  • Adobe-geluid (.asnd). Dit is de eigen geluidsindeling van Adobe® Soundbooth™.

  • Wave (.wav)

  • AIFF (.aif, .aifc)

  • MP3

    U kunt deze bijkomende geluidsbestandsindelingen importeren:

  • Sound Designer® II (.sd2)

  • Sun AU (.au, .snd)

  • FLAC (.flac)

  • Ogg Vorbis (.ogg, .oga)

Opmerking:

  • De ASND-indeling is een niet-destructieve audiobestandsindeling, die bij Adobe Soundbooth hoort. ASND-bestanden kunnen audiogegevens bevatten met effecten die u later kunt wijzigen, Soundbooth-sessies met meer tracks, en momentopnamen waarmee u kunt terugkeren naar een eerdere status van het ASND-bestand.
  • WebGL en HTML5 Canvas-documenttypen bieden alleen ondersteuning voor de indelingen MP3 en WAV.

Geluiden rechtstreeks vanaf de computer toevoegen op de tijdlijn

U kunt audiobestanden rechtstreeks vanaf uw computer importeren naar de tijdlijn. Gebruik hiervoor een van de volgende methoden:

  • Selecteer Bestand > Importeren > Importeren naar werkgebied en selecteer het audiobestand dat u wilt importeren.
  • Sleep het audiobestand en zet het neer op het werkgebied/tijdlijn. 

Let op: u kunt slechts één audiobestand tegelijkertijd toevoegen. Als u meerdere audiobestanden sleept en neerzet, wordt er slechts één audiobestand naar de tijdlijn geïmporteerd.

Geluiden toevoegen van de bibliotheek naar de tijdlijn

U kunt een geluid aan een document toevoegen met behulp van een bibliotheek, of u kunt een geluid bij uitvoering in een SWF-bestand laden met de methode loadSound van het object Sound. Zie loadSound (Sound.loadSound-methode) in de Naslaggids voor ActionScript 2.0 of Sound-klasse in de Naslaggids voor ActionScript 3.0.

  1. Importeer het geluid in de bibliotheek als dat nog niet het geval is.
  2. Selecteer Invoegen > Tijdlijn > Laag.
  3. Wanner de nieuwe geluidslaag is geselecteerd, kunt u het geluid uit het deelvenster Bibliotheek naar het werkgebied slepen. Het geluid wordt aan de huidige laag toegevoegd.

    U kunt meerdere geluiden op een enkele laag plaatsen of op lagen die andere objecten bevatten. Het wordt echter aanbevolen elk geluid op een afzonderlijke laag te plaatsen. Elke laag fungeert als een afzonderlijk geluidskanaal. De geluiden op alle lagen worden gecombineerd wanneer u het SWF-bestand afspeelt.

  4. Selecteer het eerste frame in de tijdlijn dat het geluidsbestand bevat.
  5. Selecteer Venster > Eigenschappen en klik op de pijl in de rechterbenedenhoek om Eigenschapcontrole uit te vouwen.
  6. Selecteer het geluidsbestand in het pop-upmenu Geluid in Eigenschapcontrole.
  7. Selecteer een effectoptie in het pop-upmenu Effecten:

    Geen

    - past geen effecten op het geluidsbestand toe. Selecteer deze optie om eerder toegepaste effecten te verwijderen.

    Linkerkanaal/Rechterkanaal

    - speelt het geluid alleen in het linker- of rechterkanaal af.

    Links naar rechts faden/Rechts naar links faden

    - verplaatst het geluid van het ene kanaal naar het andere kanaal.

    Infaden

    - verhoogt geleidelijk het volume van het geluid tijdens de duur.

    Uitfaden

    - verlaagt geleidelijk het volume van het geluid tijdens de duur.

    Aangepast

    - hiermee kunt u met Volumecurve bewerken aangepaste in- en uitpunten voor geluiden maken.

    Opmerking:

    Effecten worden niet ondersteund op WebGL- en HTML5 Canvas-documenten.

  8. Selecteer een synchronisatieoptie in het pop-upmenu Sync:

    Gebeurtenis

    - synchroniseert geluid met een gebeurtenis. Een gebeurtenisgeluid wordt afgespeeld wanneer het beginhoofdframe van het geluid voor het eerst verschijnt en wordt volledig afgespeeld, ongeacht de afspeelkop in de tijdlijn, ook als het SWF-bestand wordt onderbroken. Gebeurtenisgeluiden worden door elkaar afgespeeld wanneer u uw gepubliceerde SWF-bestand afspeelt.

    Wanneer een gebeurtenisgeluid wordt afgespeeld en het geluid opnieuw in gang wordt gezet (wanneer de gebruiker bijvoorbeeld weer op een knop klikt of als de afspeelkop het beginhoofdframe van het geluid passeert), blijft de eerste instantie van het geluid doorspelen en begint een tweede instantie van hetzelfde geluid tegelijk ook met afspelen. Onthoud dit wanneer u langere geluiden gebruikt, aangezien deze elkaar mogelijk overlappen en dat leidt tot ongewenste geluidseffecten.

    Begin

    - gelijk aan Gebeurtenis, behalve dat wanneer het geluid al wordt afgespeeld, geen nieuwe instantie van het geluid wordt afgespeeld.

    Stoppen

    - stopt het opgegeven geluid.

    Streamen

    - synchroniseert het geluid voor afspelen op een website. Animate dwingt de animatie gelijke tred te houden met streaming geluiden. Wanneer Animate de animatieframes niet snel genoeg kan tekenen, worden frames overgeslagen. In tegenstelling tot gebeurtenisgeluiden, stoppen streaming geluiden wanner het SWF-bestand stopt met afspelen. Een streaming geluid kan bovendien nooit langer afspelen dan de lengte van de frames die het bezet. Streaming geluiden worden door elkaar afgespeeld wanneer u uw SWF-bestand publiceert.

    Een voorbeeld van een streaming geluid is de stem van een personage in een animatie dat in meerdere frames speelt.

    Opmerking: Wanneer u een MP3-geluid als streaminggeluid gebruikt, moet u het geluid voor export opnieuw comprimeren. U kunt het geluid als een MP3-bestand exporteren met dezelfde compressie-instellingen die het bij importeren had.

    Deze keuzes worden uitgelegd en geïllustreerd in de videozelfstudie van Andy Anderson, die werkzaam is bij InfiniteSkills.com.

    Animate onthoudt de opties voor audiosynchronisatie in de Eigenschapcontrole. Als u een geluid selecteert in de sectie Geluid van de Eigenschapcontrole en vervolgens een ander geluid wilt instellen op een nieuw hoofdframe vanuit de Eigenschapcontrole, onthoudt Animate de synchronisatieopties Stream of Gebeurtenis van het voorgaande geluid.

    Opmerking:

    De instelling voor streaming wordt niet ondersteund in WebGL- en HTML5 Canvas-documenten.

  9. Voer een waarde in voor Herhalen om het aantal keren op te geven dat een geluid moet worden herhaald, of selecteer Lus om het geluid continu te herhalen.

    Voer voor in lus afspelen een getal in dat groot genoeg is om het geluid langere tijd af te spelen. Wanneer u een geluid van 15 seconden gedurende 15 minuten wilt herhalen, voert u 60 in. Het herhalen van streaming geluiden wordt niet aanbevolen. Wanneer een streaming geluid op herhalen is ingesteld, worden frames aan het bestand toegevoegd en neemt de bestandsgrootte toe met het aantal keren dat het geluid wordt herhaald.

  10. Sleep de afspeelkop over de frames die het geluid bevatten of gebruik de opdrachten in Bediening of het menu Besturing om het geluid te testen.

Geluid verwijderen van de tijdlijn

  1. Selecteer in de tijdlijnlaag die het geluid bevat een frame dat het geluid ook bevat.
  2. Ga in de Eigenschapcontrole naar het gedeelte Geluid en selecteer Geen in het menu Naam.

    Animate verwijdert het geluid uit de tijdlijnlaag.

Geluid aan een knop toevoegen

U kunt geluiden aan de verschillende toestanden van een knopsymbool koppelen. Aangezien de geluiden met het symbool worden opgeslagen, werken ze voor alle instanties van het symbool.

  1. Selecteer de knop in het deelvenster Bibliotheek.
  2. Selecteer Bewerken in het optiemenu in de rechterbovenhoek van het deelvenster.
  3. Voeg een laag toe voor geluid in de tijdlijn van de knop (Invoegen > Tijdlijn > Laag).
  4. Maak in de geluidslaag een normaal of leeg hoofdframe dat overeenkomt met de knoptoestand waaraan u het geluid wilt toevoegen (Invoegen > Tijdlijn > Hoofdframe of Invoegen > Tijdlijn > Leeg hoofdframe).

    Wanneer u bijvoorbeeld een geluid wilt toevoegen dat wordt afgespeeld wanneer u op de knop drukt, maakt u een hoofdframe in het frame met het label Omlaag.

  5. Klik op het hoofdframe dat u hebt gemaakt.
  6. Selecteer Venster > Eigenschappen.
  7. Selecteer een geluidsbestand in het pop-upmenu Geluid in Eigenschapcontrole.
  8. Selecteer Gebeurtenis in het pop-upmenu Sync.

    Als u een ander geluid wilt koppelen aan elk hoofdframe van de knop, kunt u een leeg hoofdframe maken voor elk hoofdframe en er een geluid aan toevoegen. U kunt ook hetzelfde geluidsbestand gebruiken en een ander geluidseffect toepassen voor elk hoofdframe van de knop.

Geluid synchroniseren met animatie

Wanneer u geluid met animatie wilt synchroniseren, kunt u het geluid bij hoofdframes starten en stoppen.

  1. Voeg een geluid in een eigen laag toe aan de tijdlijn (zie hierboven voor instructies).
  2. U kunt dit geluid synchroniseren met een gebeurtenis in de scène door een beginhoofdframe te maken voor het geluid dat overeenkomt met het hoofdframe van de gebeurtenis in de scène dat het geluid moet activeren. U kunt elke van de zojuist beschreven synchronisatieopties selecteren (zie Geluid toevoegen aan de tijdlijn).
  3. Maak een hoofdframe in de tijdlijn van de geluidslaag bij het frame waar u het geluid wilt laten eindigen. Een representatie van het geluidsbestand wordt in de tijdlijn weergegeven.
  4. Selecteer Venster > Eigenschappen en klik op de pijl in de rechterbenedenhoek om Eigenschapcontrole uit te vouwen.
  5. Selecteer hetzelfde geluid in het pop-upmenu Geluid in Eigenschapcontrole.
  6. Blijf in de Eigenschapcontrole en selecteer Stoppen in het pop-upmenu Sync.

    Wanneer u het SWF-bestand afspeelt, wordt het geluid gestopt wanneer het eindhoofdframe is bereikt.

  7. Sleep de afspeelkop in de tijdlijn om het geluid af te spelen.

Geluiden bewerken in Animate

In Animate kunt u het beginpunt van een geluid definiëren, of het volume regelen van geluid dat wordt afgespeeld. U kunt ook het punt wijzigen waarop een geluid begint en stopt met afspelen. Dit is nuttig om geluidsbestanden kleiner te maken door ongebruikte gedeelten te verwijderen.

  1. Voeg een geluid toe aan een frame of selecteer een frame dat al een geluid bevat.
  2. Selecteer Venster > Eigenschappen.
  3. Klik op de knop Bewerken rechts in Eigenschapcontrole.
  4. Ga als volgt te werk:
    • Sleep de besturingselementen Uittijd en Intijd naar Volumecurve bewerken om het start- en eindpunt van een geluid te wijzigen.

    • Wanneer u de volumecurve van het geluid wilt wijzigen, sleept u de volumecurvegrepen om niveaus op verschillende punten in het geluid te wijzigen. Volumecurvelijnen geven het volume van het geluid weer terwijl het wordt afgespeeld. Klik op de volumecurvelijnen wanneer u extra volumecurvegrepen wilt maken (maximaal acht). Wanneer u een volumecurvegreep wilt verwijderen, kunt u deze uit het venster slepen.

    • Wanneer u minder of meer van het geluid in het venster wilt weergeven, kunt u op de knoppen Inzoomen of Uitzoomen klikken.

    • Klik op de knoppen Seconden en Frames om tussen de tijdseenheden seconden en frames te wisselen.

  5. Klik op de knop Afspelen om het bewerkte geluid te beluisteren.

Geluid splitsen op de tijdlijn

U kunt streamingaudio die op de tijdlijn is ingesloten, opsplitsen met het contextmenu Audio splitsen. Met de functie Audio splitsen kunt u de audio op het juiste punt pauzeren en weer afspelen vanaf een later frame op de tijdlijn.

Een audioclip splitsen op uw tijdlijn:

  1. Selecteer Bestand > Importeren > Importeren naar bibliotheek. 
  2. Selecteer de audioclip en importeer de clip naar de bibliotheek. 
  3. Maak een nieuwe laag op uw tijdlijn en voeg de clip toe aan deze laag. 
  4. Selecteer het synchronisatietype Streaming onder Eigenschappen > Geluid.
  5. Klik met de rechtermuisknop op het frame waar u de audio wilt splitsen en klik op Audio splitsen. 

Geluid doorlopend herhalen op de tijdlijn

Bij een geluidslus wordt een klein geluidsfragment continu herhaald op een aantal frames op de tijdlijn. Als u de lusoptie hebt ingeschakeld op de tijdlijn, kunt u streaming audio doorlopend herhalen binnen een aantal frames, samen met andere animaties.

Als u een lus wilt maken, hoeft u alleen maar de lusoptie op de tijdlijn in te schakelen, als volgt:

De knop voor audio herhalen op de tijdlijn

Geluiden bewerken in Soundbooth 

Als u Adobe Soundbooth hebt geïnstalleerd, kunt u met Soundbooth geluiden bewerken die u hebt geïmporteerd in uw Animate-bestand. Als u wijzigingen in het bestand hebt aangebracht in Soundbooth, het bestand opslaat en het originele bestand overschrijft, worden de wijzigingen automatisch weerspiegeld in het Animate-bestand.

Als u de bestandsnaam of de indeling van het geluid verandert nadat u het geluid hebt bewerkt, moet u het opnieuw importeren in Animate.

Zie Werken met Soundbooth en Flash op www.adobe.com/go/lrvid4100_xp_nl voor een videozelfstudie over het gebruik van Animate samen met Soundbooth.

Opmerking:

Soundbooth is alleen beschikbaar op Windows-computers en Intel®-Mac's.

U bewerkt als volgt een geïmporteerd geluid in Soundbooth:

  1. Klik met de rechtermuisknop (Windows) of klik terwijl u Ctrl ingedrukt houdt (Macintosh) op het geluid in het deelvenster Bibliotheek.
  2. Kies Bewerken in Soundbooth in het contextmenu. Het bestand wordt geopend in Soundbooth.
  3. Bewerk het bestand in Soundbooth.
  4. Sla het bestand op wanneer u klaar bent. Als u de wijzigingen wilt opslaan in een niet-destructieve indeling, kiest u de indeling ASND.

    Als u het bestand opslaat in een andere indeling dan de oorspronkelijke, moet u het geluidsbestand opnieuw importeren in Flash Professional.

  5. Ga terug naar Flash Professional om de bewerkte versie van het geluidsbestand te zien in het deelvenster Bibliotheek.

Opmerking:

U kunt geen geluiden uit de geluidenbibliotheek (Venster > Algemene bibliotheken > Geluiden) bewerken met de opdracht Bewerken in Soundbooth. Als u deze geluiden wilt bewerken in Soundbooth, opent u Soundbooth en selecteert u het geluid in het deelvenster Resource Central. Bewerk het geluid en importeer het vervolgens in Flash Professional.

Geluiden gebruiken in Flash Lite

Adobe® Flash® Lite ondersteunt twee soorten geluid: standaard Flash Professional-geluiden, zoals de geluiden die worden gebruikt in Flash Professional-bureaubladtoepassingen, en apparaatgeluiden. Flash Lite 1.0 ondersteunt alleen apparaatgeluiden; Flash Lite1.1 en 2.x ondersteunt zowel standaardgeluiden als apparaatgeluiden.

Apparaatgeluiden worden opgeslagen in het gepubliceerde SWF-bestand in hun native audio-indeling (zoals MIDI of MFi); tijdens het afspelen geeft Flash Lite geluidsgegevens door aan het apparaat dat het geluid decodeert en afspeelt. Aangezien u de meeste audio-indelingen voor apparaten niet in Flash Professional kunt importeren, importeert u in plaats daarvan een proxygeluid in een ondersteunde indeling (zoals MP3 of AIFF) dat wordt vervangen door een extern apparaatgeluid dat u opgeeft.

U kunt apparaatgeluiden alleen als gebeurtenisgeluiden gebruiken—u kunt apparaatgeluiden niet synchroniseren met de tijdlijn zoals een standaardgeluid.

Flash Lite 1.0 en Flash Lite 1.1 ondersteunen de volgende kenmerken die beschikbaar zijn in de bureaubladversie van Flash Player niet:

  • Het ActionScript-object Sound

  • Het laden van externe MP3-bestanden

  • De compressieoptie Spraak

Raadpleeg 'Werken met geluid, video en afbeeldingen' in Toepassingen voor Flash Lite 2.x ontwikkelen of 'Werken met geluid' in Toepassingen voor Flash Lite 1.x ontwikkelen voor meer informatie.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid