Gebruik het deelvenster Historie in Dreamweaver om stappen te herhalen en te automatiseren. Maak, gebruik en sla opdrachten op uit de historiestappen.

Opmerking:

Het deelvenster Historie is verwijderd uit Dreamweaver CC 2017 en hoger. 

Taakautomatisering

In het deelvenster Historie worden de stappen vastgelegd die u uitvoert om een bepaalde taak te voltooien. Automatiseer een vaak uitgevoerde taak door deze stappen uit te voeren vanuit het deelvenster Historie of door een nieuwe opdracht te maken die de stappen automatisch uitvoert.

Bepaalde muisbewegingen, zoals selecteren door middel van klikken in het documentvenster, kunnen niet worden afgespeeld of opgeslagen. Wanneer u een dergelijke beweging maakt, verschijnt er een zwarte lijn in het deelvenster Historie (de lijn wordt pas zichtbaar wanneer u een andere actie uitvoert). Als u dit wilt voorkomen, gebruikt u de pijltoetsen in plaats van de muis om de invoegpositie binnen in het documentvenster te verplaatsen.

Bepaalde andere stappen ook kunnen niet worden herhaald, zoals het slepen van een pagina-element naar een andere plaats op de pagina. Wanneer u een dergelijke stap uitvoert, verschijnt er een pictogram met een kleine rode X in het deelvenster Historie.

Opgeslagen opdrachten worden permanent vastgehouden (tenzij u deze verwijdert), terwijl vastgelegde opdrachten worden gewist wanneer u Adobe Dreamweaver afsluit. Gekopieerde reeksen stappen worden gewist wanneer u iets anders kopieert.

Het deelvenster Historie gebruiken

Het deelvenster Historie (Venster > Historie) toont een lijst van de stappen die u hebt uitgevoerd in het actieve document sinds u dat document hebt gemaakt of geopend (maar niet de stappen die u hebt uitgevoerd in andere frames, in andere Document-vensters of in het paneel Site). Gebruik het deelvenster Historie om meerdere stappen tegelijkertijd ongedaan te maken en om taken te automatiseren.

Het deelvenster Historie
Het deelvenster Historie

A. Schuifregelaar B. Stappen C. Knop Opnieuw afspelen D. Knop Stappen kopiëren E. Knop Opslaan als opdracht 

De schuifregelaar in het deelvenster Historie wijst in eerste instantie de laatste stap aan, die u hebt uitgevoerd.

Opmerking:

U kunt de volgorde van de stappen in het deelvenster Historie niet veranderen. U moet het deelvenster Historie niet beschouwen als een verzameling willekeurige opdrachten, maar eerder als een manier om de door u uitgevoerde stappen weer te geven, in de volgorde waarin u deze hebt uitgevoerd.

De laatste stap ongedaan maken

  1. Voer een van de volgende handelingen uit:
    • Selecteer Bewerken > Ongedaan maken.

    • Sleep de schuifregelaar van het deelvenster Historie één stap terug in de lijst.

    Opmerking:

    Als u automatisch naar een bepaalde stap wilt scrollen, dient u links van de stap te klikken; door op de stap zelf te klikken selecteert u de stap. Het selecteren van een stap is anders dan teruggaan naar die stap in uw historie van ongedaan maken.

Meerdere stappen tegelijkertijd ongedaan maken

  1. Sleep de schuifregelaar dusdanig dat deze een willekeurige stap aanwijst, of klik links van een stap op het pad van de schuifregelaar.

    De schuifregelaar scrollt automatisch naar die stap, waarbij stappen tijdens het scrollen ongedaan worden gemaakt.

    Opmerking:

    Evenals bij het ongedaan maken van één stap kunt u de ongedaan gemaakte stappen niet opnieuw uitvoeren als u een reeks stappen ongedaan maakt en vervolgens iets nieuws in het document uitvoert; deze stappen verdwijnen volledig uit het deelvenster Historie.

Het aantal stappen instellen dat het deelvenster Historie vasthoudt en weergeeft

Voor de behoeften van de meeste gebruikers is het standaardaantal stappen voldoende. Hoe groter het aantal, des te meer geheugen het deelvenster Historie vereist, hetgeen de prestaties negatief kan beïnvloeden en uw computer aanmerkelijk langzamer kan maken.

  1. Selecteer Bewerken > Voorkeuren (Windows) of Dreamweaver > Voorkeuren (Macintosh).
  2. Selecteer Algemeen in de lijst Categorie aan de linkerkant.
  3. Geef een aantal op voor Maximumaantal historiestappen.

    Wanneer het deelvenster Historie het maximumaantal stappen bereikt, worden de vroegste stappen gewist.

De historielijst voor het huidige document wissen:

  1. Selecteer in het contextmenu van het deelvenster Historie de optie Historie wissen.

    Met deze opdracht wist u voor het huidige document ook alle informatie over het ongedaan maken van bewerkingen. Na het kiezen van Historie wissen kunt u daarom de stappen die zijn gewist, niet meer ongedaan maken. Historie wissen maakt stappen niet ongedaan; deze opdracht verwijdert de vastgelegde informatie over deze stappen uit het geheugen.

Stappen herhalen

Gebruik het deelvenster Historie om de laatst uitgevoerde stap te herhalen, om een reeks opeenvolgende stappen te herhalen of om een reeks niet-opeenvolgende stappen te herhalen. Herhaal de stappen rechtstreeks vanuit het deelvenster Historie.

Eén stap herhalen

  1. Voer een van de volgende handelingen uit:
    • Selecteer Bewerken > Opnieuw.

    • Selecteer een stap in het deelvenster Historie en klik op de knop Opnieuw afspelen. Deze stap wordt opnieuw afgespeeld en in het deelvenster Historie wordt een kopie ervan weergegeven.

Een reeks stappen herhalen

  1. Selecteer stappen in het deelvenster Historie:
    • Als u opeenvolgende stappen wilt selecteren, sleept u van de ene stap naar de andere (maar zonder de schuifregelaar te slepen; sleep alleen van het tekstlabel van de ene stap naar het tekstlabel van een andere stap). U kunt ook de eerste stap selecteren en vervolgens terwijl u Shift ingedrukt houdt op de laatste stap klikken.

    • Voor de selectie van niet-opeenvolgende stappen selecteert u een stap en klikt u met Control ingedrukt (Windows) of Command ingedrukt (Macintosh) op andere stappen om deze te selecteren of om de selectie ervan op te heffen.

      De stappen die worden afgespeeld zijn de geselecteerde (gemarkeerde) stappen, dus niet noodzakelijkerwijs de stap die op dat moment wordt aangewezen door de schuifregelaar.

    Opmerking:

    Hoewel u een reeks stappen kunt selecteren waarin een zwarte lijn is opgenomen (die aangeeft dat die stap niet kan worden vastgelegd), wordt deze stap overgeslagen wanneer u de stappen opnieuw afspeelt.  

  2. Klik op Opnieuw afspelen.

    De stappen worden op volgorde afgespeeld en er verschijnt een nieuwe stap, Stappen opnieuw afspelen, in het deelvenster Historie.

Een selectie maken of uitbreiden

  1. Houd Shift ingedrukt terwijl u op een pijltoets drukt.

    Opmerking:

    Als er een zwarte lijn verschijnt om een muisbeweging aan te geven terwijl u een taak uitvoert die u later wilt herhalen, kunt u vóór die stap een bewerking voor ongedaan maken uitvoeren en een andere benadering proberen, bijvoorbeeld door de pijltoetsen te gebruiken.

Stappen in het deelvenster Historie toepassen op objecten

U kunt een reeks stappen uit het deelvenster Historie toepassen op een willekeurig object in het documentvenster.

Als u meerdere objecten selecteert en er vervolgens stappen uit het deelvenster Historie op toepast, worden de objecten als één selectie beschouwd en probeert Dreamweaver de stappen toe te passen op de gecombineerde selectie. U kunt een reeks stappen echter ook toepassen op één object tegelijk.

Als u de stappen wilt toepassen op elk object in een reeks objecten, dient u ervoor te zorgen dat de laatste stap in de reeks het volgende object in de groep selecteert. De tweede werkwijze demonstreert dit principe in een bepaald scenario: het instellen van de verticale en horizontale afstand in een reeks afbeeldingen.

Stappen toepassen op één ander object

  1. Selecteer het object.
  2. Selecteer de relevante stappen in het deelvenster Historie en klik op Opnieuw afspelen.

Stappen toepassen op meerdere objecten

  1. Open een document waarin elke regel bestaat uit een kleine afbeelding (zoals een bullet met een afbeelding of een pictogram) gevolgd door tekst.

    Het doel is om de afbeeldingen door middel van wat ruimte zowel van de tekst als van de andere afbeeldingen erboven en eronder te scheiden.

    Elke regel bestaat uit een kleine afbeelding
    Elke regel bestaat uit een kleine afbeelding

  2. Open de eigenschappencontrole (Venster > Eigenschappen), als deze nog niet is geopend.
  3. Selecteer de eerste afbeelding.
  4. Geef in de eigenschappencontrole getallen op in de vakken V-ruimte en H-ruimte om de afstanden van de afbeelding in te stellen.
  5. Klik opnieuw op de afbeelding om het documentvenster actief te maken zonder de invoegpositie te verplaatsen.
  6. Druk op de pijltoets links om de invoegpositie te verplaatsen en links van de afbeelding te zetten.
  7. Druk op de pijltoets omlaag om de invoegpositie één regel naar onderen te verplaatsen, zodat het net links van de tweede afbeelding in de reeks komt te staan.
  8. Druk op Shift+pijltoets rechts om de tweede afbeelding te selecteren.

    Opmerking:

    Selecteer de afbeelding niet door erop te klikken; als u dit doet, kunt u niet alle stappen opnieuw afspelen.

  9. Selecteer in het deelvenster Historie de stappen die overeenkomen met het instellen van de afstanden van de afbeelding en het selecteren van de volgende afbeelding. Klik op Opnieuw afspelen om die stappen opnieuw af te spelen.
    Klik op Opnieuw afspelen om stappen opnieuw af te spelen
    Klik op Opnieuw afspelen om stappen opnieuw af te spelen

    De afstanden van de huidige afbeelding worden gewijzigd en de volgende afbeelding wordt geselecteerd.

    De afstand van de huidige afbeelding wijzigt
    De afstand van de huidige afbeelding wijzigt

  10. Blijf klikken op Opnieuw afspelen totdat alle afbeeldingen zijn voorzien van de juiste afstanden.

Stappen kopiëren en plakken tussen documenten

Elk open document heeft zijn eigen historie van stappen. U kunt stappen kopiëren uit het ene document en deze plakken in een ander document.

Door een document te sluiten wist u de historie ervan. Als u weet dat u stappen uit een document later wilt gebruiken, kopieert u de stappen (of slaat u deze op) voordat u het document sluit.

  1. Selecteer in het document met de stappen die u wilt hergebruiken, de stappen in het deelvenster Historie.
  2. Klik op Stappen kopiëren in het deelvenster Historie .

    Opmerking:

    De knop Stappen kopiëren in het deelvenster Historie is anders dan de opdracht Kopiëren in het menu Bewerken. U kunt geen gebruikmaken van Bewerken > Kopiëren voor het kopiëren van stappen, maar u kunt wel Bewerken > Plakken gebruiken om stappen te plakken.

    Wees voorzichtig wanneer u stappen kopieert die een opdracht Kopiëren of Plakken bevatten:

    • Gebruik Stappen kopiëren niet als een van de stappen bestaat uit de opdracht Kopiëren. Mogelijk kunt u dergelijke stappen niet op de gewenste manier plakken.

    • Als uw stappen de opdracht Plakken bevatten, kunt u deze stappen alleen plakken wanneer de stappen zelf ook de opdracht Kopiëren vóór de opdracht Plakken bevatten.

  3. Open het andere document.
  4. Plaats de invoegpositie op de gewenste locatie of selecteer een object waarop u de stappen wilt toepassen
  5. Selecteer Bewerken > Plakken.

    De stappen worden opnieuw afgespeeld terwijl ze worden geplakt in het deelvenster Historie van het document. Het deelvenster Historie geeft deze als één stap weer, onder de naam Stappen plakken.

    Als u stappen hebt geplakt in een teksteditor, de codeweergave of de codecontrole, zien ze eruit als JavaScript-code. Dit kan handig zijn om u uw eigen scripts te leren schrijven.

Opdrachten uit historiestappen maken en gebruiken

Sla een reeks historiestappen op als een benoemde opdracht, die vervolgens beschikbaar komt in het menu Opdrachten. Maak een nieuwe opdracht en sla deze op als u de reeks stappen de volgende keer dat u Dreamweaver start mogelijk opnieuw kunt gebruiken.

Een opdracht maken

  1. Selecteer een stap of een reeks stappen in het deelvenster Historie.
  2. Klik op de knop Opslaan als opdracht of kies Opslaan als opdracht in het contextmenu van deelvenster Historie.
  3. Geef een naam op voor de opdracht en klik op OK.

    De opdracht verschijnt in het menu Opdrachten.

    Opmerking:

    De opdracht wordt opgeslagen als een JavaScript-bestand (of soms als HTML-bestand) in uw map Dreamweaver/Configuratie/Opdrachten. Als u Dreamweaver gebruikt onder een besturingssysteem voor meerdere gebruikers, wordt het bestand opgeslagen in de map Opdrachten van die bepaalde gebruiker.

Een opgeslagen opdracht gebruiken

  1. Selecteer een object waarop de opdracht moet worden toegepast of plaats de invoegpositie op de plaats waar u de opdracht wilt toepassen.
  2. Selecteer de opdracht in het menu Opdrachten.

De naam van een opdracht bewerken

  1. Selecteer Opdrachten > Opdrachtlijst bewerken.
  2. Selecteer een opdracht waarvan u de naam wilt wijzigen, geef een nieuwe naam voor de opdracht op en klik op Sluiten.

Een naam verwijderen uit het menu Opdrachten

  1. Selecteer Opdrachten > Opdrachtlijst bewerken.
  2. Selecteer een opdracht.
  3. Klik op Verwijderen en vervolgens op Sluiten.

Opdrachten vastleggen en opslaan

Leg een tijdelijke opdracht vast voor gebruik op de korte termijn of leg een opdracht vast en sla deze op voor gebruik later. Dreamweaver houdt slechts één vastgelegde opdracht tegelijk vast. Zodra u begint met het vastleggen van een nieuwe opdracht, gaat de vorige opdracht verloren, tenzij u deze hebt opgeslagen voordat u de nieuwe opdracht vastlegde.

Een reeks stappen tijdelijk vastleggen

  1. Selecteer Opdrachten > Opname starten of druk op Control+Shift+X (Windows) of Command+Shift+X (Macintosh).

    De aanwijzer verandert van vorm om aan te geven dat u bezig bent met het vastleggen van een opdracht.

  2. Wanneer u klaar bent met opnemen (vastleggen), selecteert u Opdrachten > Opname stoppen of drukt u op Control+Shift+X (Windows) of Command+Shift+X (Macintosh).

Een vastgelegde opdracht afspelen

  1. Selecteer Opdrachten > Opgenomen opdracht afspelen.

Een vastgelegde opdracht opslaan

  1. Selecteer Opdrachten > Opgenomen opdracht afspelen.
  2. Selecteer de stap Opdracht uitvoeren die in de stappenlijst van het deelvenster Historie verschijnt en klik vervolgens op de knop Opslaan als opdracht.
  3. Geef een naam op voor de opdracht en klik op OK.

    De opdracht verschijnt in het menu Opdrachten.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid