Импорт на SVG файлове

Последна актуализация на 11.09.2026 г.

Научете как да импортирате SVG файлове като собствени, редактируеми слоеве за форма, които са готови за анимиране без необходимост от преобразуване.

Кликнете двукратно в панела Проект или използвайте Файл > Импорт > Файл, за да прегледате и импортирате SVG файла.

Бележка

Най-новата версия на After Effects ви дава възможност да импортирате файла като материал или композиция.

Плъзнете и пуснете импортирания SVG файл в панела Timeline.

Изберете слоя, за да използвате раздела Съдържание на слоя в панела Свойства, за да видите структурата на SVG файла.

Панелът „Свойства" е отворен и под „Съдържание на слоя" са изброени съдържанията на SVG файла.
Използвайте панела „Свойства", за да прегледате съдържанието на SVG файла и да коригирате свойствата му.

Може също да изберете стрелката до слоя, за да го разгънете, след което разширете раздела Съдържание.Ще видите всички отделни елементи и техните свойства, като Път, Запълване и Трансформиране.

Слоят с SVG файла е избран и разделът „Съдържание" е разширен, за да покаже свойствата му, включително „Път", „Запълване" и „Трансформирам".
Разширете раздела „Съдържание" на SVG слоя, за да получите достъп и да редактирате свойствата му, включително „Път", „Запълване" и „Трансформирам".

Можете да използвате тези свойства за анимиране точно като всеки друг слой за форма.Например:

  • Анимирайте Пътя, за да създадете морфинг Ефекти
  • Променяйте цвета на запълването с времето за динамични преходи
  • Използвайте свойствата Трансформиране, за да мащабирате, завъртате или премествате елементи независимо

Ако слоевете имат градиентни запълвания и щрихи, можете да използвате свойствата Мащаб и Завъртане, за да анимирате градиента.

Един от слоевете с градиентен елемент е избран и „Градиентно запълване 1" е подчертано.
Използвайте свойствата на „Градиентно запълване", за да коригирате градиента или да ги анимирате.

Импортирайте SVG файл като материал или като композиция

Импортът на SVG в After Effects предлага гъвкавост и по-добър контрол върху начина, по който SVG файловете се импортират във вашия проект.С най-новата версия, когато импортирате SVG файл, можете да изберете да го импортирате като материал или като композиция.

Импортиране като материал

Импортиране като композиция

Импортира SVG файла като един непрекъснато растеризуем векторен слой.

Импортира SVG файла като композиция, съставена от редактируеми слоеве за форми.

Поддържа връзка с външния SVG файл.

Всеки елемент се преобразува в своя собствена редактируема форма.

Подходящо за еднослойни векторни изображения, когато не е необходимо да се разбива творбата на части.

Подходящо за редактиране на пътеки, форми и детайли на ниво слой, когато е необходимо да се анимират отделни елементи.

Можете да контролирате кой подход за импортиране се използва по подразбиране при импортирането на SVG файлове чрез задаването на опцията Плъзгане на множество файлови елементи като в настройките за Импортиране.

  • macOS: After Effects > Настройки > Импортиране > Плъзгане на множество файлови елементи като
  • Windows: Редактиране > Предпочитания > Импортиране > Плъзгане на множество файлови елементи като
Диалоговият прозорец с предпочитания е отворен.В раздела „Импортиране" падащото меню „Превлачане на множество файлови елементи като" е отворено и предлага опции за избор на метод на импортиране.
Задайте предпочитанието по подразбиране за импортиране на SVG файл, като изберете дали да се импортира като видеоматериал или като композиция.

Направете двоен клик в панела Проект или използвайте Файл > Импортиране > Файл, за да прегледате и импортирате SVG файла.

Използвайте падащото меню Импортиране като в диалоговия прозорец Импортиране на файл, за да изберете една от следните опции:

  • Видеоклип
  • Композиция - запазване на размерите на слоевете

Изборът на Видеоклип импортира файла като един сплющен слой без достъп до отделни елементи, което го прави подходящ за статично използване или когато не е необходима анимация.Изборът на Композиция – запазване на размерите на слоевете създава нова композиция, в която всеки изходен слой се импортира отделно с размер според действителното си съдържание, което прави опорните точки по-чисти и трансформациите по-лесни за анимация.

macOS

Диалоговият прозорец „Импортиране на файл" е отворен и има опции за импортиране на файла като видеоклип или като композиция.

Windows

Диалоговият прозорец „Импортиране на файл" е отворен и има опции за импортиране на файла като видеоклип или като композиция.

Изберете следните опции, ако е приложимо:

  • Създаване на композиция: Създава нова композиция с настройки по подразбиране и автоматично поставя импортирания SVG файл — или като видеоматериал, или като композиция със слоеве за форми — в хронологията, което ви спестява необходимостта ръчно да създавате композиция и да плъзгате SVG файла в нея.
  • Серия от мащабируеми векторни изображения: Импортира множество номерирани SVG файлове и ги третира като серия векторни изображения кадър по кадър.

Използвайте раздела Layer Contents в панела Properties или раздела Contents на слоя в хронологията, за да прегледате и работите с отделни елементи и техните свойства, ако сте импортирали SVG файла като композиция. Ако е импортиран като материал, се държи като обикновен слой и може да се регулира с помощта на стандартните свойства Transform.

Както при Illustrator файловете, ако векторният файл е импортиран като материал, можете да изберете слоя в хронологията, след това да щракнете с десния бутон и да изберете Create > Create Shapes and Text from Vector Layer, за да го конвертирате в редактируеми слоеве, което ви позволява да анимирате отделни пътеки, контури и запълвания. В най-новата After Effects бета версия текстът в изходния файл се конвертира в редактируеми текстови слоеве, които запазват шрифта, размера, запълването, позицията, стиловете, контурите и настройките за променливи шрифтове. 

Когато импортирате SVG като материал, After Effects поддържа активна връзка към оригиналния файл, така че всички промени, които правите в този SVG извън приложението, автоматично се актуализират в проекта ви.

Преобразуване на текст от Illustrator в редактируеми текстови слоеве

Използване на нови бета функции

Редактируемият текст от Illustrator файлове вече е достъпен за тестване и обратна връзка. Опитайте го сега в After Effects (бета).

В най-новата After Effects бета версия, когато Illustrator слой е импортиран като материал, всеки текст в изходния файл се конвертира в свой собствен редактируем текстов слой, вместо да бъде сплеснат в контури на форми. Това означава, че шрифтът, размерът, запълването, позицията, стиловете (като получер и курсив), контурите и настройките за променливи шрифтове се прехвърлят, така че можете да продължите да редактирате текста директно в After Effects, вместо да го пресъздавате от нулата или да се връщате към Illustrator за промени.

Изберете File > Import > File и след това Illustrator файла, който искате да импортирате.

В диалоговия прозорец Import File се уверете, че Import As е зададен на Footage при избора на файла за импортиране.

В диалоговия прозорец за импортиране потвърдете, че Import Kind е зададен на Footage и изберете Layer Options въз основа на това, което искате да импортирате от Illustrator файла.

Плъзнете импортирания файл към панела Timeline.

Щракнете с десния бутон върху Illustrator слоя и изберете Create > Create Shapes and Text from Vector Layer, или използвайте Layer > Create > Create Shapes and Text from Vector Layer.

Подменю Layer > Create с осветено Create Shapes and Text from Vector Layer, конвертиращо векторен текст в редактируеми текстови слоеве.
Изберете Create Shapes and Text from Vector Layer, за да преобразувате текста от Illustrator в редактируеми текстови слоеве на After Effects вместо във форми.

Текстът се конвертира в редактируем текстов слой, който точно съответства на шрифта, размера, запълването и позицията на оригиналния файл. След това можете да редактирате и коригирате текста директно в After Effects.

Текстов слой Brightness върху графика с пламък, с панел Character, показващ шрифт Adobe Clean Italic, размер 74px и активирано Fill.
След конвертирането текстът остава напълно редактируем — шрифтът, стилът, размерът и запълването все още могат да се променят в панела Character.

Бележка

Текст само с контур все още се конвертира като пътеки, а не като редактируем текстов слой. 

Нетекстовото векторно съдържание все още се конвертира в слоеве с форми, както преди, и ако файлът на Illustrator съдържа и двете, ще получите смес от текстови слоеве и слоеве с форми.

Включете се в дискусията в нашата общност за After Effects (Beta) относно поддръжката за редактируем текст от файлове на Illustrator.

Копиране и поставяне на съдържание от Illustrator и SVG

SVG съдържанието в системния буфер вече може да се постави в After Effects чрез Редактиране > Поставяне.Съдържанието се импортира като собствени, редактируеми слоеве за форма, готови за анимиране, без да е необходима междинна стъпка за импортиране.

Копиране на съдържание от Illustrator

Отворете изображението си в Adobe Illustrator.

Потвърдете, че е избрана настройката Include SVG Code .

  • macOS: Изберете Illustrator > Settings > Clipboard Handling и изберете Include SVG Code.
  • Windows: Изберете Редактиране > Настройки > Clipboard Handling и изберете Include SVG Code.
Диалоговият прозорец за настройки е отворен в Illustrator и е избрана опцията Includes SVG Code.
Активирайте Include SVG Code, за да запазите изображението си редактируемо и с високо качество в други приложения на Adobe.

Изберете изображението, което искате да копирате.

Съвет

Конвертирайте всеки SVG текст в криви преди копирането, тъй като SVG текстът не се поддържа при поставянето.

Изберете Редактиране > Копиране.

Превключете към After Effects и направете едно от следните в зависимост от състоянието на проекта ви:

  • Ако няма отворен проект, изберете Редактиране > Поставяне, за да създадете нов проект с композиция, съдържаща SVG съдържанието като слой за форма.
  • Ако има отворен проект, но няма избрана композиция, изберете Редактиране > Поставяне, за да създадете нова композиция в текущия проект, съдържаща поставеното съдържание.
Опцията „Редактиране" > „Поставяне" е избрана и съдържанието се импортира като собствени, редактируеми слоеве за форма, готови за анимиране.
„Редактиране" > „Поставяне" внася съдържанието като редактируеми слоеве за форма, готови за анимация.

Ако е избрана композиция в After Effects, изберете Редактиране > Поставяне, за да добавите SVG съдържанието като нов слой за форма в тази композиция.

Поставяне на SVG от други приложения

SVG съдържанието, копирано от всяко приложение, което записва SVG в системния буфер, може да се постави с помощта на същия работен процес Редактиране > Поставяне.Поддръжката зависи от това дали изходното приложение поставя валидни SVG данни в системния буфер.