Utilizzare i menu di collegamento per creare collegamenti a documenti, email, grafica, o a qualsiasi tipo di file che può essere aperto in un browser.

Informazioni sui menu di collegamento

Un menu di collegamento è un menu a comparsa di un documento visibile ai visitatori del sito, che elenca i collegamenti ai documenti o file. Potete creare collegamenti a documenti del vostro sito Web, collegamenti a documenti di altri siti Web, collegamenti e-mail, collegamenti a immagini o a qualunque tipo di file visualizzabile da un browser.

Ciascuna opzione di un menu di collegamento è associata a un URL. Quando gli utenti scelgono un'opzione, vengono reindirizzati (“collegati”) all'URL associato. I menu di collegamento vengono inseriti nell'oggetto di modulo Menu di collegamento.

Un menu di collegamento può contenere tre componenti:

  • (Opzionale) Una richiesta di selezione da menu, come le descrizioni delle categorie delle voci di menu oppure delle istruzioni, ad esempio “Selezionare una voce”.

  • (Obbligatorio) Un elenco di voci di menu collegate: l'utente seleziona un'opzione e viene aperto il documento o il file collegato.

  • (Opzionale) Un pulsante Vai.

Inserire un menu di collegamento

  1. Aprite un documento, quindi collocate il punto di inserimento all'interno della finestra del documento.
  2. Effettuate una delle operazioni seguenti:
    • Selezionate Inserisci > Modulo > Menu di collegamento.

    • Nella categoria Moduli del pannello Inserisci, fate clic sul pulsante Menu di collegamento.

  3. Inserite i dati desiderati nella finestra di dialogo Inserisci menu di collegamento e fate clic su OK. Di seguito è riportato un elenco parziale delle opzioni:

    Pulsanti più (+) e meno (-)

    Fate clic sul pulsante più (+) per inserire una voce. Ripetete il passaggio per inserire altre voci. Per eliminare una voce, selezionatela e fate clic sul pulsante meno (-).

    Pulsanti freccia

    Selezionate una voce e fate clic sulle frecce per spostarla verso l'alto o il basso nell'elenco.

    Testo

    Digitate il nome per una voce senza nome. Se il menu include una richiesta di selezione (come “Selezionare una voce:”), digitatela qui per impostarla come prima voce del menu (in tal caso, è necessario selezionare anche l'opzione Seleziona la prima opzione dopo la modifica dell'URL che si trova nella parte inferiore).

    Dopo una selezione, accedi all'URL

    Individuate il file di destinazione oppure digitatene il percorso.

    Apri gli URL in

    Specificate se aprire il file nella stessa finestra o nello stesso frame. Se il frame che desiderate designare come destinazione non viene visualizzato nel menu a comparsa, uscite dalla finestra di dialogo Inserisci menu di collegamento e assegnate un nome al frame.

    Inserisci pulsante Vai dopo il menu

    Consente di inserire un pulsante Vai invece di una richiesta di selezione da menu.

    Seleziona la prima opzione dopo la modifica dell'URL

    Selezionarla se è stata inserita una richiesta di selezione da menu (“Scegliere una voce:”) come prima voce del menu.

Modificare le voci del menu di collegamento

Potete modificare l'ordine delle voci nel menu o il file a cui una voce è collegata, oppure aggiungere, eliminare o rinominare una voce.

Per cambiare la posizione in cui viene aperto un file collegato o per aggiungere o modificare una richiesta di selezione da un menu, è necessario applicare un comportamento Menu di collegamento nel pannello Comportamenti.

  1. Se la finestra di ispezione Proprietà non è già aperta, scegliete Finestra > Proprietà.
  2. Nella vista Progettazione della finestra del documento, fate clic sull'oggetto Menu di collegamento per selezionarlo.
  3. Nella finestra di ispezione Proprietà, fate clic sul pulsante Elenco valori.
  4. Utilizzate la finestra di dialogo Elenco valori per apportare le modifiche alle voci del menu, quindi fate clic su OK.

Risoluzione dei problemi relativi ai menu di collegamento

Una volta selezionata una voce del menu di collegamento da parte di un utente, non c'è modo di riselezionarla se si ritorna a quella pagina oppure se nella casella Apri gli URL in è specificato un frame. Esistono due modi per risolvere questo inconveniente:

  • Utilizzate una richiesta di selezione da menu (ad esempio, una categoria) o un'istruzione per l'utente (ad esempio, “Selezionare una voce:”). Una richiesta di selezione da menu viene riselezionata automaticamente dopo ogni selezione dal menu.

  • Utilizzate un pulsante Vai, che consente a un utente di rivisitare il collegamento attualmente selezionato. quando usate un pulsante Vai con un menu di collegamento, il pulsante Vai diventa l'unico meccanismo che consente all'utente di accedere all'URL associato alla selezione effettuata nel menu. La selezione di una voce di menu nel menu di collegamento non esegue più il reindirizzamento automatico dell'utente a un'altra pagina o frame.

Nota:

selezionate una sola di queste opzioni per ciascun menu di collegamento nella finestra di dialogo Inserisci menu di collegamento, in quanto le opzioni sono valide per l'intero menu.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online