Una vez optimizado un gráfico o documento, podrá proceder a exportarlo (o a guardarlo, en función del tipo de archivo original).

Es posible exportar (o guardar, según el caso) un documento como una imagen en formato GIF, JPEG u otro archivo gráfico. También se puede exportar el documento entero como archivo HTML y los archivos de imagen asociados, sólo las divisiones seleccionadas o el área especificada. Además, también es posible exportar estados y capas de Fireworks como archivos de imágenes independientes.

La ubicación en la que Fireworks exporta los archivos de forma predeterminada se establece según los siguientes factores y en este orden:

  1. Las preferencias de exportación actuales del documento, que están definidas si alguna vez ha exportado el documento y, a continuación, lo ha guardado como archivo PNG.

  2. La ubicación actual para exportar/guardar, que se define cada vez que elige una ubicación diferente a la presentada de forma predeterminada en los cuadros de diálogo Guardar, Guardar como o Exportar.

  3. La ubicación del archivo actual.

  4. La ubicación predeterminada en la que se guardan las imágenes o documentos nuevos en el sistema operativo.

    No obstante, Fireworks establece una ubicación predeterminada para guardar documentos de acuerdo con unos criterios diferentes. Para obtener más información, consulte Almacenamiento de archivos de Fireworks.

Exportar páginas como archivos de imagen

  1. Seleccione Archivo > Exportar.

  2. Elija la ubicación de los archivos de exportación.

  3. Siga uno de estos procedimientos:

    • Seleccione Sólo imágenes en el menú emergente Exportar y seleccione o anule la selección de la casilla de verificación Sólo página actual. Las páginas se exportan al formato de imagen establecido en el panel Optimizar.

    • Seleccione Páginas en archivos en el menú emergente Exportar y seleccione Imágenes en el menú emergente Exportar como. Las páginas se exportan al formato de imagen establecido en el panel Optimizar.

    • Seleccione Páginas en archivos en el menú emergente Exportar y seleccione PNG de Fireworks en el menú emergente Exportar como. Cada página se exporta como un archivo PNG individual que será compatible con versiones anteriores de Fireworks 8.

    Nota:

    Si desea exportar todas las páginas en el formato seleccionado, seleccione todas las páginas y posteriormente optimice la configuración.

Exportar una única imagen

Si está trabajando con una imagen existente que abrió en Fireworks, puede guardarla en lugar de exportarla. Para obtener más información, consulte Guardar documentos en otros formatos.

Nota:

Para exportar sólo ciertas imágenes de un documento, primero debe crear divisiones en el documento y exportar las que considere oportuno.

  1. En el panel Optimizar, seleccione un formato de archivo y establezca las opciones específicas del formato.

  2. Seleccione Archivo > Exportar.

  3. Seleccione una ubicación para el archivo de imagen que se va a exportar.

    En el caso de los gráficos Web, la mejor ubicación es normalmente una carpeta dentro del sitio web local.

  4. Especifique un nombre de archivo sin extensión. Se añadirá una extensión durante la exportación en función del tipo de archivo.

  5. Seleccione Sólo imágenes en el menú emergente Exportar.

  6. Haga clic en Guardar.

Exportar un documento con divisiones

De forma predeterminada, cuando exporta un documento de Fireworks con divisiones, se exporta un archivo HTML y las imágenes asociadas. El archivo HTML exportado puede verse en un navegador Web o importarse en otras aplicaciones para seguir modificándolo.

Antes de realizar la exportación asegúrese de seleccionar el estilo HTML adecuado en el cuadro de diálogo Configuración de HTML. Consulte Ajustar las opciones de exportación de HTML.

Exportar todas las divisiones

  1. Seleccione Archivo > Exportar.

  2. Desplácese a una carpeta del disco duro en la que se exportará el archivo.

  3. En el menú emergente Exportar, seleccione HTML e imágenes.

  4. Escriba un nombre de archivo en el cuadro Nombre de archivo (Windows) o Guardar como (Mac OS).

  5. En el menú emergente HTML, seleccione Exportar archivo HTML.

  6. En el menú emergente Divisiones, seleccione Exportar divisiones.

  7. (Opcional) Seleccione Colocar imágenes en subcarpeta.

  8. Haga clic en Guardar.

Exportar divisiones seleccionadas

  1. Presione la tecla Mayús y haga clic para seleccionar varias divisiones.

  2. Seleccione Archivo > Exportar.

  3. Seleccione una ubicación en la que se almacenarán los archivos exportados, como por ejemplo una carpeta dentro del sitio web local.

  4. En el menú emergente Exportar, seleccione HTML e imágenes.

  5. Especifique un nombre de archivo sin extensión. Se añadirá una extensión durante la exportación en función del tipo de archivo.

    Si desea exportar varias divisiones, Fireworks utilizará el nombre que introduzca como nombre base para todos los gráficos exportados, a excepción de aquellos que haya asignado en el panel Capas o en el Inspector de propiedades.

  6. En el menú emergente Divisiones, seleccione Exportar divisiones.

  7. Para exportar sólo las divisiones seleccionadas antes de la exportación, elija Sólo divisiones seleccionadas y asegúrese de que la opción Incluir áreas sin divisiones no está seleccionada.

  8. Haga clic en Guardar.

Actualizar una división

Si ya ha exportado un documento con divisiones y, posteriormente, ha realizado cambios al documento original en Fireworks, puede actualizar sólo la imagen o división que ha cambiado. Para facilitar la ubicación de la división de sustitución, personalice el nombre de las divisiones.

  1. Oculte la división y edite el área que se encuentra debajo.

  2. Visualice la división de nuevo.

  3. Haga clic con el botón derecho (Windows) o presione la tecla Control (Mac OS) y haga clic en la división y seleccione Exportar división seleccionada.

  4. Seleccione la misma carpeta que la división original utilizando el mismo nombre base y haga clic en Guardar.

  5. Haga clic en Aceptar cuando se le pregunte si desea reemplazar el archivo existente.

    Nota:

    Procure no asignar un tamaño de división mayor que el de la exportación original en Fireworks, de este modo evitará resultados inesperados en el documento HTML tras actualizar la división.

Exportar una animación

Tras crear y optimizar una animación, podrá exportarla. Es posible exportar una animación con cualquiera de los siguientes tipos de archivos:

GIF animados

Estos archivos ofrecen los mejores resultados en imágenes tipo ilustración o dibujos animados.

SWF de Flash o PNG de Fireworks (no se necesita exportación)

Exporte una animación como un archivo SWF para su importación en Flash. También se puede omitir el paso de exportación importando un PNG origen de Fireworks directamente a Flash. Mediante este método directo, se pueden importar todas las capas y todos los estados de la animación y, a continuación, seguir editándolos en Flash. Consulte Funcionamiento con Flash.

Varios archivos

La exportación de estados o capas de animación como varios archivos es útil cuando se dispone de muchos símbolos en capas diferentes para el mismo objeto. Por ejemplo, puede exportar un titular publicitario como varios archivos si cada letra de un nombre de empresa está animada en una imagen. Consulte Exportar estados o capas como varios archivos.

Si su documento contiene más de una animación, puede insertar divisiones para exportar cada una utilizando diferentes ajustes de animación como bucles y demoras de estado.

Exportar un GIF animado

  1. Elija Seleccionar > Anular selección para anular la selección de todas las divisiones y objetos y seleccione GIF Animado como formato de archivo en el panel Optimizar.

  2. Seleccione Archivo > Exportar.

  3. Escriba un nombre para el archivo y seleccione el destino.

  4. Haga clic en Guardar.

Exportar varios GIF animados con diferentes ajustes de animación

  1. Seleccione todas las animaciones que desee haciendo clic con la tecla Mayús pulsada.

  2. Seleccione Edición > Insertar > División rectangular o División poligonal.

  3. En el cuadro de mensaje, haga clic en Varios.

  4. Seleccione cada división y utilice el panel Estados para definir diferentes ajustes de animación en cada una.

  5. Seleccione las divisiones que desea animar y escoja GIF Animado como formato de archivo en el panel Optimizar.

  6. Haga clic con el botón derecho (Windows) o presione la tecla Control (Mac OS) y haga clic en cada división y seleccione Exportar división seleccionada. En el cuadro de diálogo Exportar, escriba un nombre para cada archivo, seleccione una ubicación y haga clic en Guardar.

Exportar estados o capas como varios archivos

Fireworks puede exportar cada estado o capa de un documento como un archivo de imagen independiente y utilizar los ajustes de optimización especificados en el panel Optimizar. El nombre de la capa o del estado determina el nombre de archivo de cada archivo exportado. Este método de exportación se utiliza a veces para exportar animaciones.

  1. Seleccione Archivo > Exportar.

  2. Escriba un nombre de archivo y elija una carpeta de destino.

  3. En el menú emergente Exportar, seleccione una opción:

    Estados en archivos

    Exporta estados como varios archivos.

    Capas en archivos

    Exporta capas como varios archivos.

    Nota: de este modo se exportan todas las capas del estado actual.

  4. Para recortar de forma automática cada imagen exportada a fin de incluir sólo los objetos de cada estado, seleccione Recortar imágenes. Por el contrario, para incluir todo el lienzo (incluidas las áreas en blanco situadas más allá de los objetos), anule la selección de esta opción.

  5. Haga clic en Guardar.

Exportar una área de un documento

  1. En el panel Herramientas, seleccione la herramienta Exportar área .

  2. Arrastre un recuadro que defina la parte del documento que desee exportar.

    Nota:

    Es posible ajustar la posición del recuadro mientras lo arrastra. Mientras mantiene pulsado el botón del ratón, presione y mantenga presionada la barra espaciadora y arrastre el recuadro a otro lugar del lienzo. Suelte la barra espaciadora para continuar el dibujo del recuadro.

    Después de soltar el botón del ratón, el área a exportar permanece seleccionada.

  3. Si lo desea, puede cambiar el tamaño del área que desee exportar:

    • Para cambiar el tamaño del recuadro del área de exportación de forma proporcional, presione la tecla Mayús y arrastre un tirador.

    • Para cambiar el tamaño del recuadro desde el centro, presione la tecla Alt (Windows) o la tecla Opción (Mac OS) y arrastre un tirador.

    • Para restringir las proporciones y cambiar el tamaño desde el centro, mantenga presionadas las teclas Alt+Mayús (Windows) u Opción+Mayús (Mac OS) y arrastre un tirador.

  4. Haga doble clic en el interior del área seleccionada que va a exportar para abrir la presentación preliminar de imagen.

  5. Ajuste las configuraciones en la presentación preliminar de imagen y haga clic en Exportar.

  6. Escriba un nombre de archivo y elija una carpeta de destino.

  7. Seleccione Sólo imágenes en el menú emergente Exportar.

  8. Haga clic en Guardar.

    Nota:

    Para cancelar la operación sin llegar a exportar, haga doble clic fuera del recuadro de selección del área que se pretendía exportar, presione Esc o seleccione una herramienta diferente.

Exportación de HTML

Salvo que especifique lo contrario, al exportar un documento de Fireworks con divisiones, lo que se exporta es un archivo HTML y sus imágenes. Para definir cómo exporta Fireworks el código HTML, debe utilizar el cuadro de diálogo Configuración de HTML.

Fireworks genera código HTML puro que la mayoría de los navegadores Web y editores de HTML pueden leer. De forma predeterminada, la exportación especifica la codificación UTF-8.

Fireworks puede exportar HTML de varias formas:

  • Puede exportar un archivo HTML y abrirlo después en un editor de HTML para su edición.

  • Es posible exportar cada página de un archivo de Fireworks en un archivo HTML diferente.

  • Puede copiar el código HTML en el portapapeles desde Fireworks y pegar dicho código directamente en un documento HTML existente.

  • Es posible exportar un archivo HTML, abrirlo en un editor de HTML, copiar manualmente secciones del código del archivo y pegarlas en otro documento HTML.

  • Se puede exportar código HTML como capas CSS (Cascading Style Sheet) y como XHTML.

  • También se puede utilizar el comando Actualizar HTML para modificar un archivo HTML creado anteriormente.

    Fireworks permite exportar código HTML en formato genérico y en formatos de Dreamweaver, Microsoft® FrontPage® y Adobe GoLive®.

    Nota:  Adobe Dreamweaver se integra perfectamente con Fireworks. Fireworks controla la exportación del código HTML a Dreamweaver de forma diferente a como lo hace para otros editores de HTML. Si se exporta HTML de Fireworks a Dreamweaver, consulte Funcionamiento con Dreamweaver.

    El método utilizado para incorporar código HTML de Fireworks en otras aplicaciones resulta conveniente si trabaja en un entorno de equipo. Este método segmenta el flujo de trabajo de forma que un usuario puede empezar una tarea en una aplicación y otro la puede continuar más tarde en otra aplicación distinta.

Incluir comentarios en el código HTML exportado

Los comentarios HTML de Fireworks se abren con <!-- y terminan con -->. Cualquier texto contenido entre dichos marcadores no se interpreta como código HTML o JavaScript.

  1. Antes de realizar la exportación, elija la opción Incluir comentarios HTML en la ficha General del cuadro de diálogo Configuración de HTML.

Resultados de la exportación

Al exportar o copiar HTML desde Fireworks, se crea lo siguiente:

  • El código HTML necesario para volver a crear las imágenes divididas y cualquier código JavaScript si el documento contiene elementos interactivos. El código HTML de Fireworks contiene vínculos a las imágenes exportadas y define el color de fondo de la página web con el color del lienzo.

  • Uno o varios archivos de imagen, según el número de divisiones creadas en el documento y de estados incluidos en los botones.

  • Un archivo denominado Spacer.gif, si fuera necesario. Spacer.gif es un archivo GIF transparente de 1x1 píxel que Fireworks utiliza para solucionar problemas de espaciado al reorganizar imágenes con divisiones en una tabla HTML. Puede decidir si Fireworks debe exportar o no un espaciador.

  • Si se exportan menús emergentes, se exportarán los siguientes archivos: mm_css_menu.js y un archivo .css que contiene el código de menú emergente de CSS. Además, si los menús emergentes contienen submenús, se exportará también el archivo arrows.gif.

  • Si exporta o copia código HTML en Dreamweaver, se crean archivos de notas que facilitan la integración entre Fireworks y Dreamweaver. Estos archivos tienen la extensión .mno.

Exportar HTML de Fireworks

  1. Seleccione Archivo > Exportar.

  2. Desplácese a una carpeta del disco duro en la que se exportará el archivo.

  3. En el menú emergente Exportar, seleccione HTML e imágenes.

  4. Haga clic en el botón Opciones y elija su editor de HTML en el menú emergente Estilo de HTML de la ficha General del cuadro de diálogo Configuración de HTML. Si su editor de HTML no aparece, elija Genérico.

    Nota:

    Es importante que elija su editor HTML como estilo de HTML de modo que sea posible que los elementos interactivos como los botones y los rollovers funcionen correctamente al importarlos en su editor HTML.

  5. Haga clic en Aceptar.

  6. En el menú emergente HTML, seleccione Exportar archivo HTML.

  7. Elija Exportar divisiones en el menú emergente Divisiones si su documento contiene divisiones.

  8. Para almacenar imágenes en una carpeta independiente, seleccione Colocar imágenes en subcarpeta. Puede seleccionar una carpeta específica o utilizar la carpeta de imágenes predeterminada de Fireworks.

  9. Si va a exportar un documento de Fireworks con varias páginas, anule la selección de la casilla Sólo página actual para exportar todas las páginas en documentos HTML independientes.

  10. Haga clic en Guardar.

    Tras la exportación, los archivos de Fireworks aparecen en su unidad de disco duro. Las imágenes y un archivo HTML se crean en la ubicación que especifique en el cuadro de diálogo Exportar.

Copiar código HTML al Portapapeles

Puede copiar código HTML al Portapapeles de Fireworks de dos formas distintas. Utilice el comando Copiar código HTML o seleccione la opción Copiar al Portapapeles en el cuadro de diálogo Exportar. Después puede pegar este código HTML en un documento en su editor de HTML preferido.

Al determinar la forma en que se pondrán los HTML de Fireworks en otras aplicaciones, tenga en cuenta los siguientes inconvenientes de copiar código HTML al Portapapeles:

  • No tiene la opción de guardar las imágenes en una subcarpeta. Deben residir en la misma carpeta que el archivo HTML en el que pega el código HTML. Una excepción es el código HTML copiado en Dreamweaver.

  • Todos los vínculos o rutas de acceso utilizados en los menús emergentes de Fireworks se asignarán a rutas de acceso de su disco duro. El código HTML copiado en Dreamweaver constituye una excepción.

  • Si utiliza un editor de HTML distinto de Dreamweaver o Microsoft FrontPage, el código JavaScript asociado con botones, comportamientos e imágenes de rollover se copia, pero es posible que no funcione correctamente.

    Si esto le constituye un problema, utilice la opción Exportar Archivo HTML en lugar de copiar el código HTML en el Portapapeles.

    Nota:  antes de copiar el código HTML, asegúrese de seleccionar el estilo HTML adecuado y de seleccionar la opción Incluir comentarios HTML en la ficha General del cuadro de diálogo Configuración de HTML.

Copiar HTML de Fireworks mediante la opción Copiar código HTML

  1. Seleccione Edición > Copiar código HTML.

  2. Siga las instrucciones del asistente. Cuando el sistema lo solicite, especifique una carpeta como destino de las imágenes exportadas. Esta debe ser la ubicación en la que residirá el archivo HTML.

    Nota:

    Si desea pegar el código HTML en Dreamweaver, no importa el lugar en que exporte las imágenes, siempre que residan en el mismo sitio de Dreamweaver que el archivo HTML en el que pegue el código.

Copiar código HTML de Fireworks utilizando el cuadro de diálogo Exportar

  1. Seleccione Archivo > Exportar.

  2. En el cuadro de diálogo Exportar, especifique una carpeta destino para las imágenes exportadas. Esta debe ser la misma ubicación que la del archivo HTML.

    Nota:

    si desea pegar el código HTML en Dreamweaver, no importa el lugar al que exporte las imágenes, siempre que residan en el mismo sitio de Dreamweaver que el archivo HTML en el que pegue el código.

  3. En el menú emergente Exportar, seleccione HTML e imágenes.

  4. Desde el menú emergente HTML, seleccione Copiar al Portapapeles.

  5. Elija Exportar divisiones en el menú emergente Divisiones si su documento contiene divisiones.

  6. Haga clic en el botón Opciones, elija el editor de HTML en el cuadro de diálogo Configuración de HTML y haga clic en Aceptar.

  7. Haga clic en Guardar.

Pegar el código HTML copiado de Fireworks en un documento HTML

  1. En el editor de HTML, abra un documento HTML existente o cree uno nuevo. Guarde el documento en la misma ubicación en la que exportó las imágenes.

    Nota:

    No es necesario guardar el archivo HTML en la misma ubicación que las imágenes exportadas si utiliza Dreamweaver. Siempre que exporte las imágenes de Fireworks a un sitio Dreamweaver y guarde el archivo HTML en una ubicación perteneciente al sitio, Dreamweaver actualizará las rutas de acceso de las imágenes asociadas.

  2. Consulte el código HTML y coloque el punto de inserción entre las etiquetas <BODY> .

    Nota:

    El código HTML copiado desde Fireworks no incluye las etiquetas de apertura y cierre <HTML> ni <BODY>.

  3. Pegue el código HTML.

    Si es posible, cuando copie en el portapapeles, exporte las imágenes a la ubicación en la que residirán en el sitio web. Fireworks utiliza direcciones URL relativas en los documentos, de manera que si el código HTML o las imágenes se mueven, los vínculos URL se rompen.

Copiar código de un archivo Fireworks exportado y pegarlo en otro documento HTML

  1. Abra el archivo HTML de Fireworks que ha exportado en un editor de HTML.

  2. Seleccione el código necesario y cópielo en el Portapapeles.

  3. Abra un documento HTML existente o cree uno nuevo.

  4. Pegue el código en el nuevo archivo HTML. No es necesario copiar las etiquetas <HTML> y <BODY>, puesto que ya se encuentran en el documento HTML destino.

    Si eligió Incluir comentarios HTML en el cuadro de diálogo Configuración de HTML en Fireworks, siga las instrucciones incluidas en los comentarios para copiar y pegar el código en la ubicación adecuada.

  5. Si el documento de Fireworks contiene elementos interactivos, copie el código JavaScript.

    El código de JavaScript incluye etiquetas <SCRIPT> y se encuentra en la sección <HEAD> del documento. Copie y pegue toda la sección <SCRIPT>, a menos que el documento destino ya tenga una sección <SCRIPT>. Si es así, copie y pegue sólo el contenido de la sección <SCRIPT> en la sección <SCRIPT> existente, con cuidado de no sobrescribir el contenido de dicha sección. Además, deberá comprobar que no hay funciones JavaScript duplicadas en la sección <SCRIPT> después de pegar el código.

Actualizar HTML exportado

La actualización permite realizar cambios en un documento HTML de Fireworks que se haya exportado con anterioridad. Resulta útil si desea actualizar sólo una porción de un documento.

Nota:

Actualizar HTML funciona de forma diferente en documentos de Dreamweaver que con otros documentos HTML. Para obtener más información, consulte Funcionamiento con Dreamweaver.

Cuando actualice, puede elegir sustituir sólo las imágenes modificadas o sobrescribir todo el código y las imágenes. Si elige reemplazar sólo las imágenes modificadas, se conservará cualquier cambio realizado en el archivo HTML fuera de Fireworks.

Nota:

En los casos en que se cambie considerablemente el diseño del documento, realice las modificaciones en Fireworks y vuelva exportar el archivo HTML.

  1. Seleccione Archivo > Actualizar HTML.

  2. Seleccione el archivo que desea actualizar.

  3. Haga clic en Abrir.

  4. Siga uno de estos procedimientos:

    • Si no se encuentra un documento HTML generado por Fireworks, haga clic en Aceptar para insertar el nuevo código HTML al final del documento.

    • Si se encuentra un documento HTML de Fireworks, realice una de las acciones siguientes y haga clic en Aceptar:

      Reemplazar imágenes y su código HTML

      Sustituye el HTML anterior de Fireworks.

      Actualizar sólo imágenes

      Sobrescribe únicamente las imágenes.

  5. Si aparece el cuadro de diálogo Seleccionar carpeta de imágenes, elija una carpeta y haga clic en Abrir.

Exportar capas CSS

Las capas CSS pueden superponerse y apilarse unas encima de otras. En Fireworks, el resultado HTML normal no se superpone.

  1. Seleccione Archivo > Exportar.

  2. Escriba un nombre de archivo y elija una carpeta de destino.

  3. En el menú emergente Exportar, seleccione CSS e imágenes.

    • Para exportar sólo el estado actual, seleccione Sólo estado actual.

    • Para exportar sólo la página actual, seleccione Sólo página actual.

    • Para seleccionar una carpeta para las imágenes, seleccione Colocar imágenes en subcarpeta.

  4. Haga clic en Opciones para configurar las propiedades de las páginas HTML.

  5. Haga clic en Examinar para especificar una imagen de fondo y establecer el mosaico de la imagen de fondo:

    • Seleccione sin repetición para mostrar la imagen sólo una vez.

    • Seleccione repetir para repetir o mostrar la imagen en mosaico horizontal o vertical.

    • Seleccione repetir-x para mostrar la imagen en mosaico horizontal.

    • Seleccione repetir-y para mostrar la imagen en mosaico vertical.

  6. Seleccione la alineación de la página en el explorador: izquierda, centro o derecha.

  7. Haga clic en Aceptar y, a continuación, en Guardar.

Exportar XHTML

XHTML es una combinación de HTML, el estándar actual para asignar formatos a páginas Web y mostrarlas, y de XML (Extensible Markup Language). XHTML es compatible con versiones anteriores de la mayoría de los navegadores Web y puede leerse en cualquier dispositivo capaz de mostrar contenido XML, como los PDA, teléfonos móviles y otros dispositivos portátiles.

Fireworks también puede importar XHTML. Consulte Creación de archivos PNG de Fireworks a partir de archivos HTML.

Para obtener más información sobre XHTML, consulte las especificaciones para XHTML en la página del World Wide Web Consortium (W3C) en www.w3.org.

  1. Elija Archivo > Configuración de HTML, seleccione un estilo XHTML en el menú emergente Estilo de HTML en la ficha General y, a continuación, haga clic en Aceptar.

  2. Exporte el documento utilizando cualquiera de los métodos disponibles para exportar o copiar código HTML. Consulte Exportar HTML.

    Nota:

    Fireworks utiliza la codificación UTF-8 al exportar a XHTML.

Exportar archivos con y sin codificación UTF-8

UTF-8, acrónimo de Universal Character Set Transformation Format-8, es un método de codificación de texto que permite a los navegadores Web mostrar diferentes conjuntos de caracteres (por ejemplo, texto en chino y texto en inglés) en la misma página HTML. La codificación UTF-8 está activada de forma predeterminada.

Fireworks también puede importar documentos que utilizan la codificación UTF-8. Consulte Creación de archivos PNG de Fireworks a partir de archivos HTML.

Exportar documentos sin codificación UTF-8

  1. Elija Archivo > Configuración de HTML.

  2. En la ficha Específico del documento, desactive la casilla de verificación Codificación UTF-8 y haga clic en Aceptar.

  3. Exporte el documento utilizando cualquiera de los métodos disponibles para exportar o copiar código HTML.

Ajustar las opciones de exportación de HTML

El cuadro de diálogo Configuración de HTML permite definir cómo se exporta el código HTML de Fireworks. Los cambios realizados en la ficha Específico del documento sólo afectan al documento actual. Los ajustes General y Tabla son preferencias globales que afectan a todos los documentos nuevos.

  1. Siga uno de estos procedimientos:

    • Elija Archivo > Configuración de HTML.

    • Haga clic en el botón Opciones del cuadro de diálogo Exportar.

  2. En la ficha General, seleccione las opciones que prefiera.

    Estilo HTML

    Seleccione el estilo para el HTML exportado.

    El formato HTML genérico funciona en todos los editores de HTML. Sin embargo, si el documento contiene comportamientos u otro contenido interactivo, elija un editor específico si aparece en la lista.

    Para exportar el documento con el estándar XHTML, elija el estilo XHTML adecuado en el menú emergente.

    Extensión

    Elija una extensión de archivo en el menú emergente o introduzca una nueva.

    Incluir comentarios HTML

    Seleccione el lugar donde copiar y pegar los comentarios en el HTML. Se recomienda esta opción si el documento contiene elementos interactivos como botones, comportamientos o imágenes de rollover.

    Nombre de archivo en minúsculas

    Seleccione esta opción para que el nombre del archivo HTML y el de los archivos de imagen asociados aparezcan en minúsculas tras la exportación.

    Nota: esta opción no cambiará la extensión del archivo HTML a minúsculas si eligió mayúsculas en el menú emergente Extensión.

    Usar CSS para los menús emergentes

    Seleccione esta opción para utilizar CSS en lugar de JavaScript para el código de los menús emergentes. Es posible utilizar Dreamweaver para indizar los menús, así como para actualizar los vínculos del código.

    Escribir CSS en un archivo externo

    Seleccione esta opción para que el código CSS se escriba en un archivo .css externo que se exportará a la misma ubicación que el archivo HTML. El nombre del archivo .css coincide con el del archivo HTML (excepto por la extensión). Al elegir esta opción, también se exporta un archivo con el nombre mm_css_menu.js en la misma ubicación que el archivo HTML.

    Nota: esta opción sólo está disponible si se ha seleccionado la opción Usar CSS para los menús emergentes.

    Creador de archivo (Mac OS)

    Seleccione una aplicación asociada desde el menú emergente. Si hace doble clic en el archivo HTML exportado del disco duro, se abre automáticamente en la aplicación seleccionada.

  3. En la ficha Tabla, elija la configuración de las tablas HTML. Para más información, consulte Definir cómo se exportan las tablas HTML.

  4. En la ficha Específico del documento, elija una de las opciones siguientes:

    Nombres de archivos de división

    Seleccione una fórmula para la denominación automática de las divisiones en los menús emergentes. Puede utilizar la configuración predeterminada o utilizar sus propias opciones.

    Nota: si selecciona Ninguno para los tres primeros menús, Fireworks exporta archivos de división que se sobrescribirán, dando lugar a un único archivo gráfico y una tabla que mostrará este gráfico en cada celda.

    Etiqueta ALT predeterminada

    Introduzca el texto que aparecerá en lugar de la imagen mientras ésta se descarga de la Web o en lugar del gráfico cuando la imagen no se descarga correctamente. En algunos navegadores, puede aparecer también como texto informativo cuando se pasa el puntero sobre la imagen. Esto también constituye una ayuda para los usuarios Web con problemas de visión.

    Exportar varios archivos HTML de Bar Nav (para utilizar sin conjuntos de marcos)

    Seleccione esta opción al exportar una barra de navegación que vincula varias páginas. Fireworks exporta páginas adicionales para cada botón de la barra de navegación.

    Incluir áreas sin divisiones

    Seleccione esta opción si desea incluir áreas del lienzo que no estén cubiertas por las divisiones.

    Codificación UTF-8

    Opción activada de forma predeterminada. Permite que el documento exportado muestre caracteres procedentes de varios conjuntos de caracteres. Para desactivar esta opción, anule la selección de la casilla de verificación.

  5. Para guardar estos ajustes como ajustes globales predeterminados, haga clic en Fijar predeterminados..

Exportar archivos PDF de Adobe

Cuando desee imprimir un diseño de Fireworks o distribuirlo para su revisión, expórtelo a PDF de Adobe. Así, los revisores pueden añadir comentarios o responder a otros comentarios en Adobe Reader® o Acrobat®. Para obtener información sobre la configuración de las revisiones de archivos PDF, consulte la Ayuda de Acrobat.

Los archivos PDF exportados conservan todas las páginas y todos los vínculos de hipertexto, lo que permite que los revisores naveguen del mismo modo que lo harían en la Web. Sin embargo, al contrario que los prototipos HTML, PDF de Adobe ofrece ajustes de seguridad que impiden que los revisores editen o copien los diseños.

  1. Elija Archivo > Exportar.

  2. En el menú emergente Exportar, elija Adobe PDF.

  3. Seleccione las páginas que desee exportar y seleccione Ver PDF tras la exportación para que el PDF se abra de manera automática en Adobe Reader o Acrobat.

  4. Para personalizar el PDF, haga clic en Opciones y ajuste las siguientes configuraciones:

    Compatibilidad

    Determina las aplicaciones de PDF de Adobe que pueden abrir el archivo exportado.

    Compresión

    Determina el tipo de compresión de la imagen, lo cual reducirá el tamaño del archivo. En general, la compresión JPEG y JPEG2000 proporciona mejores resultados en imágenes como fotografías con transiciones graduales de color a color. ZIP resulta la mejor elección para las ilustraciones con grandes zonas de colores planos y uniformes.

    Calidad

    Para la compresión JPEG o JPEG2000, ofrece ajustes de calidad de imagen. Si se selecciona una calidad alta, se obtiene un archivo de gran tamaño pero con buena calidad de imagen.

    Convertir en escala de grises

    Convierte todas las imágenes a una escala de grises, lo que reduce el tamaño del archivo.

    Activar selección de texto

    Permite a los revisores copiar texto del archivo exportado. Desactive esta opción para reducir considerablemente el tamaño de los archivos.

    Valor de sangrado

    Determina la anchura de píxeles del borde blanco que rodea la imagen en cada página. Por ejemplo, el valor 20 rodea cada imagen con un borde de 20 píxeles.

    Contraseña de usuario para abrir el documento

    Requiere Contraseña de apertura para abrir el archivo exportado.

    Contraseña de usuario para limitar tareas

    Requiere Contraseña de seguridad para realizar las siguientes tareas: Impresión, edición, copia y comentarios.

  5. Haga clic en Aceptar para cerrar el cuadro de diálogo Opciones.

  6. Especifique un nombre de archivo y una ubicación y, a continuación, haga clic en Guardar.

    Nota:

    Si las páginas del documento de Fireworks tienen un lienzo transparente, los objetos que tengan aplicada transparencia pierden esta característica al realizar la exportación a PDF. Para evitarlo, defina un fondo que no sea transparente para el lienzo antes de empezar la exportación a PDF.

Vídeo

Creación de pruebas para clientes como archivos PDF o HTML mediante Fireworks (00:05:32)

Aprenda a utilizar el menú Exportar de Fireworks para preparar un documento PDF o HTML para el proceso de aprobación del cliente o la revisión del equipo.

Por Tom Green

Cuando se visualicen los archivos PDF exportados en Adobe Acrobat o Adobe Reader, utilice la siguiente configuración:

  1. En Adobe Acrobat o Adobe Reader, seleccione Edición > Preferencias.

  2. Seleccione Presentación de página en el panel izquierdo.

  3. Establezca la resolución personalizada en 72 píxeles por pulgada.

  4. Establezca el valor de ampliación y reducción en 100%.

Exportación de archivos FXG

FXG es un formato de archivo compatible con Flash Catalyst, Fireworks, Illustrator y Photoshop. Cuando se exporta un archivo que contiene imágenes de mapa de bits y vectoriales utilizando la exportación FXG, se crea una carpeta independiente denominada <filename.assets>. La carpeta contiene las imágenes de mapa de bits asociadas con el archivo.

Se producirá un error en la operación de importación si algún archivo asociado se elimina de esta carpeta.

Nota:

Los elementos, filtros, modos de mezcla, degradados y máscaras para los que no existe etiqueta de asignación correspondiente en FXG se exportan como gráficos de mapa de bits.

  1. Seleccione Archivo > Exportar y desplácese a la ubicación donde desee guardar los archivos.

  2. Indique un nombre para el archivo FXG.

  3. En el cuadro de diálogo Exportar, seleccione FXG e imágenes en el menú Exportar.

  4. Haga clic en Guardar.

Nota:

Los objetos que se amplían más allá del lienzo en Fireworks se muestran por completo cuando el archivo FXG exportado se abre en Flash Catalyst.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea