Las instrucciones siguientes hacen referencia a determinadas versiones de los SDK de Flex y AIR: Flex SDK 4.6.0 y AIR SDK 3.4; no obstante, las instrucciones son de carácter general. Puede seguir estas instrucciones para superponer cualquier versión del SDK de AIR en cualquier versión del SDK de Flex.

Nota:

Si el SDK de Flex es más nuevo que el SDK de AIR, puede depender de funciones de AIR que no están presentes, y generar errores de compilación y de tiempo de ejecución.

  1. Salga de Flash Builder.

  2. (Opcional) Haga una copia de seguridad del SDK de Flex copiando el directorio completo.

    En Flash Builder, por ejemplo, copie el directorio en:

    • Windows: C:/Archivos de programa/Adobe/Flash Builder 4.7/sdks/4.6.0

    • Mac OS: /Aplicaciones/Adobe Flash Builder 4.7/sdks/4.6.0

  3. Descargue el archivo de SDK de AIR correspondiente a su sistema operativo de http://www.adobe.com/products/air/sdk/; a continuación, guárdelo en el directorio raíz del SDK de Flex.

    •  Windows: AdobeAIRSDK.zip

    •  Mac OS: AdobeAIRSDK.dmg

  4. Extraiga el contenido del archivo del SDK de AIR y sobrescriba los archivos del SDK existentes.

    • Windows: haga clic con el botón derecho del ratón en el archivo ZIP y seleccione Extraer todo, o use una herramienta de descompresión de su elección.

    • Mac OS: en Terminal, ejecute estos comandos:

      • hdiutil attach AdobeAIRSDK.dmg
      • cp -rf /Volumes/AIR\ SDK/* /path-to-empty-FLEXSDK-directory
    • Si tiene problemas para sobrescribir los archivos debido a los permisos de archivo, pruebe este comando, pruebe estos comandos:

      • sudo hdiutil attach AdobeAIRSDK.dmg
      • sudo cp -rf /Volumes/AIR\ SDK/* /path-to-empty-FLEXSDK-directory
  5. (Opcional) Para poder acceder a las nuevas API de AIR 3.4, actualice el archivo descriptor de la aplicación al espacio de nombres 3.4.

    Para actualizar el espacio de nombres, en el archivo descriptor de la aplicación, cambie el atributo xmlns por: <application xmlns="http://ns.adobe.com/air/application/3.4">

  6. (Opcional) Para asegurarse de que el archivo SWF apunte a la versión 17 del SWF, transfiera un argumento adicional al compilador: -swf-version=17.

    Para obtener instrucciones detalladas, consulte este artículo.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea