Tuo SVG-tiedostot

Päivitetty viimeksi 11. syyskuuta 2026

Opi tuomaan SVG-tiedostot alkuperäisinä, muokattavina muototasoina, jotka ovat valmiita animointiin ilman muunnoksia.

Kaksoisnapsauta Projekti-paneelia tai käytä Tiedosto > Tuonti > Tiedosto selataksesi ja tuodaksesi SVG-tiedoston.

Muistiinpano

Adobe After Effectsin uusin versio antaa sinun tuoda tiedoston materiaalina tai kokoonpanona.

Vedä ja pudota tuotu SVG-tiedosto aikajana-paneeliin.

Valitse taso, jolloin voit käyttää Tason sisältö-osiota Ominaisuudet-paneelissa SVG:n rakenteen tarkastelemiseen.

Ominaisuudet-paneeli on auki ja Tason sisällön alla SVG-sisältö on listattu.
Käytä Ominaisuudet-paneelia tarkastellaksesi SVG-tiedoston sisältö ja säätääksesi niiden ominaisuuksia.

Voit myös valita tason vieressä olevan nuolen avataksesi sen ja laajentaaksesi Sisältö-osion.Näet kaikki yksittäiset elementit ja niiden ominaisuudet, kuten Polku, Täyttö ja Muunnos.

SVG-tiedoston sisältävä taso on valittu ja Sisältö-osio on laajennettu näyttämään sen ominaisuudet, mukaan lukien Polku, Täyttö ja Muunnos.
Laajenna SVG-tason Sisältö-osio, jotta voit käyttää ja muokata sen ominaisuuksia, kuten Polku, Täyttö ja Muunnos.

Voit käyttää näitä ominaisuuksia animointiin aivan kuten mitä tahansa muuta muototasoa.Esimerkiksi:

  • Animoi Polku luodaksesi morphing-tehosteet
  • Muuta täyttöväriä ajan myötä dynaamisia siirtymiä varten
  • Käytä Muunnos-ominaisuuksia skaalataksesi, kiertääksesi tai liikuttaaksesi elementtejä itsenäisesti

Jos tasoilla on liukuväritäyttöjä ja viivoja, voit käyttää Mittakaava ja Kierto-ominaisuuksia animoidaksesi liukuvärin.

Yksi tasoista, jossa on liukuväri-elementti, on valittu ja liukuväritäyttö 1 on korostettu.
Käytä liukuväritäytön ominaisuuksia säätääksesi liukuväriä tai animoidaksesi niitä.

Tuo SVG-tiedosto materiaalina tai kokoonpanona

SVG:n tuonti Adobe After Effectsissa tarjoaa joustavan ja paremman hallinnan siihen, miten SVG-tiedostot tuodaan projektiisi.Uusimmassa versiossa voit SVG-tiedoston tuodessasi valita, tuodaanko se materiaalina vai kokoonpanona.

Tuo materiaalina

Tuo komposiitiona

Tuo SVG:n yhtenä jatkuvasti rasteroitavana vektoritasona.

Tuo SVG:n komposiitiona, joka koostuu muokattavista muototasoista.

Säilyttää yhteyden ulkoiseen SVG-tiedostoon.

Jokainen elementti muunnetaan omaksi muokattavaksi muodoksi.

Sopii yksitasoisille vektorikuvaille, kun taideteosta ei tarvitse jakaa osiin.

Sopii polkujen, muotojen ja tason yksityiskohtien muokkaamiseen, kun yksittäisiä elementtejä täytyy animoida.

Voit määrittää, mitä tuontitapaa käytetään oletuksena SVG-tiedostoja tuotaessa, asettamalla Vedä useita tiedostokohteita muodossa -vaihtoehdon Tuonti-asetuksissa.

  • macOS: After Effects > Asetukset > Tuonti > Vedä useita tiedostokohteita muodossa
  • Windows: Muokkaa > Asetukset > Tuonti > Vedä useita tiedostokohteita muodossa
Asetukset-valintaikkuna on auki. Tuonti-välilehdessä Vedä useita tiedostokohteita muodossa -pudotusvalikko on auki ja tarjoaa vaihtoehtoja tuontimenetelmän valitsemiseksi.
Aseta oletusasetus SVG-tiedoston tuomiseksi ja valitse, tuodaanko se materiaalina vai komposiitiona.

Kaksoisnapsauta Projekti-paneelissa tai käytä Tiedosto > Tuonti > Tiedosto selailaksesi ja tuodaksesi SVG-tiedoston.

Käytä Tuo muodossa -pudotusvalikkoa Tuo tiedosto -valintaikkunassa ja valitse jokin seuraavista:

  • Materiaali
  • Kompositio - Säilytä tasokoot

Materiaali tuo tiedoston yhtenä litistettynä tasona, jossa ei ole pääsyä yksittäisiin elementteihin. Sopii staattiseen käyttöön tai kun animaatiota ei tarvita. Komposiitio – Säilytä tasokoot luo uuden komposition, jossa jokainen lähdetaso tuodaan erikseen ja mitoitetaan sen todellisen sisällön mukaan. Tämä tekee tukipisteistä siistimpiä ja muunnoksista helpompia animaatiolle.

macOS

Tuo tiedosto -valintaikkuna on auki ja siinä on vaihtoehdot tiedoston tuomiseksi materiaalina tai komposiitiona.

Windows

Tuo tiedosto -valintaikkuna on auki ja siinä on vaihtoehdot tiedoston tuomiseksi materiaalina tai komposiitiona.

Valitse seuraavat vaihtoehdot tarvittaessa:

  • Luo kompositio: Luo uuden komposition oletusasetuksilla ja sijoittaa tuodun SVG:n automaattisesti (joko materiaalina tai komposiitiona muototasoineen) aikajanalle. Säästyt luomasta kompositiota manuaalisesti ja vetämästä SVG-tiedostoa siihen.
  • Skaalautuvan vektorigrafiikan sarja: Tuo useita numeroituja SVG-tiedostoja ja käsittelee ne kuva kuvalta -vektorikuvien sarjana.

Jos toit SVG-tiedoston koosteena, tarkastele yksittäisiä elementtejä ja niiden ominaisuuksia ja käsittele niitä Properties-paneelin Layer Contents -osiosta tai aikajanan tason Contents -osiosta.Jos tiedosto tuodaan materiaalina, se toimii tavallisen tason tavoin, ja sitä voi säätää tavallisilla Transform-ominaisuuksilla.

Kuten Illustrator-tiedostojen kohdalla, jos vektoritiedosto tuodaan materiaalina, voit valita tason aikajanalla, napsauttaa sitä hiiren kakkospainikkeella ja valita Create > Create Shapes and Text from Vector Layer. Näin muunnat sen muokattaviksi tasoiksi, jolloin voit animoida yksittäisiä polkuja, viivoja ja täyttöjä. After Effects Betan uusimmassa versiossa lähdetiedoston teksti muunnetaan muokattaviksi tekstitasoiksi, jotka säilyttävät kirjasimen, koon, täytön, sijainnin, tyylit, viivat ja muuttuvan kirjasimen asetukset. 

Kun tuot SVG:n materiaalina, After Effects säilyttää reaaliaikaisen linkin alkuperäiseen tiedostoon, joten kaikki sovelluksen ulkopuolella SVG:hen tekemäsi muutokset päivittyvät automaattisesti projektiin.

Muunna Illustrator-teksti muokattaviksi tekstitasoiksi

  Käytä uusia beta-ominaisuuksia

Illustrator-tiedostojen muokattava teksti on nyt saatavilla testattavaksi ja palautetta varten. Kokeile nyt After Effectsissä (beta).

After Effects Betan uusimmassa versiossa, kun Illustrator-taso tuodaan materiaalina, kaikki lähdetiedoston teksti muunnetaan omaksi muokattavaksi tekstitasokseen sen sijaan, että se litistettäisiin muotojen ääriviivoiksi. Tämä tarkoittaa, että kirjasin, koko, täyttö, sijainti, tyylit (kuten lihavoitu ja kursiivi), viivat ja muuttuvan kirjasimen asetukset säilyvät mukana. Voit siis jatkaa tekstin muokkaamista suoraan After Effectsissä sen sijaan, että loisit sen uudelleen alusta tai palaisit Illustratoriin tekemään muutoksia.

Valitse File > Tuonti > File ja sitten Illustrator-tiedosto, jonka haluat tuoda.

Varmista Import File -valintaikkunassa, että Import As -asetuksena on Footage, kun valitset tuotavaa tiedostoa.

Vahvista tuontivalintaikkunassa, että Import Kind -asetuksena on Footage, ja valitse Layer Options sen mukaan, mitä haluat tuoda Illustrator-tiedostosta.

Vedä tuotu tiedosto Timeline-paneeliin.

Napsauta Illustrator-tasoa hiiren kakkospainikkeella ja valitse Create > Create Shapes and Text from Vector Layer tai käytä komentoa Layer > Create > Create Shapes and Text from Vector Layer.

Taso > Luo -alivalikko, jossa Create Shapes and Text from Vector Layer on korostettuna ja vektoriteksti muunnetaan muokattaviksi tekstitasoiksi.
Valitse Create Shapes and Text from Vector Layer, jotta Illustrator-teksti muunnetaan muokattaviksi After Effects -tekstitasoiksi muotojen sijaan.

Teksti muunnetaan muokattavaksi tekstitasoksi, joka vastaa tarkasti alkuperäisen tiedoston kirjasinta, kokoa, täyttöä ja sijaintia. Voit sitten muokata ja säätää tekstiä suoraan After Effectsissä.

Brightness-tekstitaso liekkigrafiikan päällä, ja Character-paneelissa näkyvät Adobe Clean Italic -kirjasin, koko 74 px ja käytössä oleva Fill.
Muunnoksen jälkeen teksti pysyy täysin muokattavana — kirjasinta, tyyliä, kokoa ja täyttöä voi edelleen muuttaa Character-paneelissa.

Muistiinpano

Vain viivasta koostuva teksti muunnetaan edelleen poluiksi eikä muokattavaksi tekstitasoksi. 

Muu kuin tekstimuotoinen vektorisisältö muunnetaan edelleen muototasoiksi kuten ennenkin, ja jos Illustrator-tiedosto sisältää molempia, saat yhdistelmän teksti- ja muototasoja.

Liity keskusteluun After Effects (Beta) -yhteisössämme koskien muokattavan tekstin tukea Illustrator-tiedostoista.

Kopioi ja liitä Illustrator- ja SVG-sisältöä

SVG-sisältö leikepöydältä voidaan nyt liittää After Effects -ohjelmaan käyttämällä Muokkaa > Liitä.Sisältö tuodaan alkuperäisinä, muokattavina muototasoina, jotka ovat valmiita animointiin ilman erillistä tuontitoimenpidettä.

Kopioi sisältöä Illustratorista

Avaa kuvituksesi Adobe Illustratorissa.

Varmista, että Sisällytä SVG-koodi -asetus on valittuna.

  • macOS: valitse Illustrator > Asetukset > Leikepöydän käsittely ja valitse Sisällytä SVG-koodi.
  • Windows: valitse Muokkaa > Asetukset > Leikepöydän käsittely ja valitse Sisällytä SVG-koodi.
Asetukset-valintaikkuna on avoin Illustratorissa ja Sisällytä SVG-koodi -vaihtoehto on valittuna.
Ota käyttöön Sisällytä SVG-koodi -toiminto, jotta kuvituksesi pysyy muokattavana ja korkealaatuisena muissa Adobe-sovelluksissa.

valitse kuvitus, jonka haluat kopioida.

Vihje

Muunna kaikki SVG-teksti käyriksi ennen kopiointia, sillä SVG-tekstiä ei tueta liittämisen yhteydessä.

valitse Muokkaa > Kopioi.

Siirry After Effectsiin ja tee jokin seuraavista projektin tilan mukaan:

  • Jos projektia ei ole avattu, valitse Muokkaa > Liitä luodaksesi uuden projektin, jossa on koostumus, joka sisältää SVG-sisällön muototasona.
  • Jos projekti on avoinna, mutta koostumusta ei ole valittu, valitse Muokkaa > Liitä luodaksesi uuden koostumuksen nykyiseen projektiin, joka sisältää liitetyn sisällön.
Muokkaa > Liitä -vaihtoehto on valittu, ja sisältö tuodaan alkuperäisinä, muokattavina muototasoina, jotka ovat valmiita animointiin.
Muokkaa > Liitä tuo sisällön muokattavina muototasoina, valmiina animointiin.

Jos koostumus on valittu After Effectsiss, valitse Muokkaa > Liitä lisätäksesi SVG-sisällön uutena muototasona kyseiseen koostumukseen.

Liitä SVG muista sovelluksista

SVG-sisältö, joka on kopioitu mistä tahansa sovelluksesta, joka kirjoittaa SVG:tä järjestelmän leikepöydälle, voidaan liittää käyttämällä samaa Muokkaa > Liitä -työnkulkua. Tuki riippuu siitä, sijoittaako lähdesovellus kelvollista SVG-dataa leikepöydälle.