Troubleshooting tips for problems that arise when you try to convert a PDF in FrameMaker.

You can create PDF files in Adobe FrameMaker by saving a FrameMaker document as a PDF file or by printing to the Adobe PDF printer. Both methods use Acrobat Distiller. You can install it by using the FrameMaker installation media. It's also available from a compatible version of Adobe Acrobat on the system. This document can help you determine the cause and resolve PDF creation problems. To benefit most from this document, perform the tasks in order.

Troubleshoot Acrobat Distiller

You can create PDF files in Adobe FrameMaker by saving a FrameMaker document as a PDF file or by printing to the Adobe PDF printer. Both methods use Acrobat Distiller, which is installed with FrameMaker. Perform the tasks below to determine if Acrobat Distiller is responsible for the problem.

1. Make sure that you use a version of Acrobat Distiller that is compatible with FrameMaker.

FrameMaker 8 and 9 are compatible with Distiller versions 7.0, 8.0, and 9.0. To determine which version of Acrobat Distiller is installed, start Acrobat Distiller and choose Help > About Acrobat Distiller.

Important: Adobe FrameMaker 8 and 9 include the Adobe PDF Creation Add-On to enable FrameMaker to create PDF files. For the purposes of this document, the Adobe PDF Creation Add-On is synonymous with Acrobat Distiller.

If you use a version of Acrobat Distiller that's not compatible with FrameMaker, update or upgrade FrameMaker. Or, remove Distiller and reinstall FrameMaker with the version of Distiller included with FrameMaker installer.

2. Check to see if Acrobat Distiller functions with another program.

Create a PDF file from another application (for example, Microsoft Word) by printing a document to the Adobe PDF printer. If you can create a PDF file from another application using Acrobat Distiller, there could be a problem with FrameMaker or with the specific document or book you're converting.

  • If a PDF file is successfully created, then skip to the Troubleshoot FrameMaker section in this document.
  • If PDF is not produced, proceed to the next task.

3. Open the Adobe PDF printer's print queue and remove/delete any stopped or stuck print jobs.

To open the Adobe PDF printer's print queue, do the following:

  1. Open the Run line (keyboard shortcut: Windows key + r).
  2. In the Run field, type "control printers" (without the quotes) and then press the Enter key.
  3. Double-click Adobe PDF printer.

4. Make sure that the printer is not set to work offline.

To check if the Adobe PDF printer is set to work offline, do the following:

  1. With the Adobe PDF printer queue still visible, click Printer on the menu bar.
  2. Locate Use Printer Offline in the pop-up menu.
  3. If a check mark appears to the left of Use Printer Offline, deselect that option.
  4. Close the Adobe PDF window.

5. Close all programs. Then, set the Adobe PDF printer to be the default printer on the computer and remove or uninstall any other PDF printers on system.

Additional PDF printers or drivers can sometimes interfere or conflict with the Adobe PDF printer.

To set the Adobe PDF printer to be the default printer, do the following:

  1. In the Printer control panel, right-click the Adobe PDF printer.
  2. Select "Set as Default Printer" in the context menu list.

6. Change the default PDF job option before printing to the Adobe PDF printer.

To determine if corrupt job option is the cause, select a different job option when you print in FrameMaker:

  1. Choose File > Print.
  2. Click PDF Setup.
  3. Click the Down Arrow to the right of the box labeled PDF Job Options. Then, choose a different job option from the PDF job options menu, and click Set.
  4. Click Print.
  5. If you're able to create a PDF file using a different job option, delete the damaged/corrupted Job Option in Acrobat Distiller and use an alternative one.

7. Check the messages.log file.

The messages.log file could include information (for example, PostScript errors) that you can use to troubleshoot the problem. If the file lists a PostScript error, troubleshoot the error according to Troubleshoot PostScript errors. To locate the messages.log file on your system, do the following:

On Windows 2000 and Windows XP, the location of the messages.log file is on the hard drive in: Documents and Settings\[user profile]\Application Data\Adobe\Acrobat\Distiller [version number].

On Windows Vista, the location of the messages.log file is on the hard drive inside: Users\[user profile]\AppData\Roaming\Adobe\Acrobat\Distiller [version number].

Important: There is an alternative route that you can use to produce a PDF file. If you have the Adobe PDF Creation Add-On or Acrobat Distiller installed, you can convert documents to PDF using a two-step process. First, convert the FrameMaker document into a PostScript file and then manually add the PostScript file to Acrobat Distiller which converts the PostScript file into a PDF.

To create a PDF using the two-step process, do the following:

  1. Choose File > Print.
  2. In print dialog box, enable the Print to File option.
  3. To the right of the Print to File check mark box, click Browse.
  4. To the right of the "Look in" field (at the top of the "Browse" window), click the Down Arrow and choose Desktop.
  5. Click OK.
  6. In the print dialog box, click Print.
  7. Close the program when the file is done being produced.

The procedure above results in a PostScript file. Follow the next two steps to convert the PostScript file (.ps) to a PDF.

  1. Right-click the PostScript file created on the desktop and choose "Convert to Adobe PDF" in the context menu.
  2. Click Save in the Save PDF File As dialog box to complete process.

8. Ensure that a "File Port" is present in your computer's Print Server Properties Control panel.

9. If none of the steps above resolved the failure to create a PDF file, additional assistance is available. Contact Adobe Technical Support.

To find support options and additional documentation, use this link to the Adobe website: http://www.adobe.com/support/framemaker.

Troubleshoot FrameMaker

If you can create a PDF file from another application using Adobe Distiller, there could be a problem with FrameMaker. Perform the tasks below to determine if FrameMaker causes the problem.

1. Set the Adobe PDF or the Acrobat Distiller printer as the default printer. Then, try to create a PDF file in FrameMaker.

  1. Choose Start > Printers and Faxes (Windows 2000 and XP) or Control Panel > Printers (Windows Vista).
  2. Right-click the Adobe PDF printer and choose Set As Default Printer.
  3. In FrameMaker, choose File > Print, and then click Print.

2. If "Save As PDF" didn't generate a PDF file, try printing to the Adobe PDF printer.

  1. In FrameMaker, choose File > Print.
  2. Click Setup, choose Adobe PDF, and then click OK.
  3. Click Print.

3. Deselect Generate Acrobat Data in the Print Document dialog box.

PDF features, such as bookmarks, hyperlinks, and tags, sometimes cause problems with the creation of PDF files. Disable these features to determine if they are at the root of the problem.

  1. In FrameMaker, choose File > Print.
  2. Deselect Generate Acrobat Data, and then click Print.

4. Try printing with a different job option.

To determine if corrupt PDF job options are the cause, select a different job option when you print in FrameMaker. If you're able to create a PDF file using a different job option, troubleshoot the problem job option in Acrobat Distiller by changing each setting and printing until you find the setting that causes the problem.

To select a different job option in FrameMaker, do the following:

  1. Choose Format > Document > PDF Setup.
  2. Change the PDF Job Option and then click Set.
  3. On FrameMaker's menu bar, choose File > Print.
  4. Click PDF Setup.
  5. Select the Settings tab, and make sure that the Job Option selected is the same as the one chosen in step. Click the Set button.
  6. Click Print.

If Acrobat Distiller successfully creates a PDF file, proceed to the section, Troubleshoot the FrameMaker document.

If Acrobat Distiller doesn't create a PDF file, proceed to the next task.

5. Try using a different Acrobat Distiller job option.

An Acrobat Distiller job option can sometime become damaged and unusable.

To isolate whether a specific job option in Acrobat Distiller is responsible, do the following:

  1. Start Acrobat Distiller.
  2. Next to the "Default Settings" field, click the Down Arrow and choose a different job option.
  3. Try printing to the Adobe PDF printer.

If you can print a new file that contains a single word of text as a PDF file in FrameMaker, your document may be corrupt; Proceed to the "Troubleshoot the FrameMaker document" section, in this document.

If the new file does not print, remove and reinstall FrameMaker and Acrobat Distiller. If Acrobat is installed, remove and reinstall it by using the Add/Remove Programs control panel (Windows XP) or the Programs and Features control panel (Windows Vista) before reinstalling FrameMaker.

Contact Adobe Technical Support using the contact information included with your Adobe software or see the Adobe website for Adobe Technical Support options (www.adobe.com/support).

Troubleshoot a FrameMaker Document

Perform the tasks below to determine if the problem is specific to the FrameMaker document you are attempting to convert.

1. Create an empty FrameMaker document add a single word to it and then choose Save As PDF.

If a new FrameMaker document can be converted into a PDF successfully, continue with the next troubleshooting step, otherwise, skip to section: Troubleshoot FrameMaker.

2. Open all documents in a book before you create a PDF file.

To open all FrameMaker files contained in a book and create a PDF:

  1. Choose File > Open and choose the Book file.
  2. Hold down the Shift key and choose File > Open All Files in Book.
  3. Choose File > Save as PDF.

FrameMaker requires access to all the FrameMaker files. Also, it must be able to open them without error to successfully convert them into a PDF.

If any errors occur while opening the files contained within the book, resolve those errors before attempting to convert the files to PDF.

3. Move files to local hard drive if files are stored in network location.

Using files across a network introduces variables, such as slower access speeds, less reliable data verification, network interruptions, and permission issues that not present when files are stored on an internal hard disk. These variables can contribute to an unstable communication and lead to data loss, file corruption, and failure to successfully create PDF files.

4. Attempt to create a PDF from the individual files contained within the book.

If the individual FrameMaker files can be successful be converted to PDF then the book file has become corrupted. Create a book file and add the files referenced in their previous book to the new book.

5. Save the file in Maker Interchange Format before creating a PDF file.

When FrameMaker converts documents into Maker Interchange Format (MIF), the file is rewritten as an ASCII-based text file and can eliminate problem elements or corruptions that have appeared in a FrameMaker file. You can resave the MIF file as a FrameMaker file, if needed.

To save document in MIF form, do the following:

  1. Open the file in FrameMaker and choose File > Save As.
  2. Choose MIF (*.mif) from the Save as Type menu, and then click Save.
  3. Open the MIF version of the file and choose File > Save as PDF.
  4. Choose Start > Printers and Faxes (Windows 2000 and XP) or Start > Control Panel > Printers (Vista).
  5. Right-click the Adobe PDF printer and choose Set As Default Printer.
  6. In FrameMaker, choose File > Print, and then click Print.

6. Set the Adobe PDF printer as the default printer. Then, try to create a PDF file in FrameMaker.

FrameMaker restricts its output to be congruent with the default printer's abilities. For example, if you start a FrameMaker session with a black-and-white (that is, grayscale) printer set as the default printer, FrameMaker restricts itself to print documents without color.

When FrameMaker launches, it queries the default printer and gathers its printing information from that printer's PPD (PostScript Printer Description) file. The PPD contain information about a printer's features, such as available memory, resolution, paper trays, ROM-resident fonts, and whether it supports color output.

FrameMaker queries the default printer at startup. Consequently, if you start FrameMaker while a grayscale printer is targeted as the default, even if you specify a color printer during the FrameMaker session, FrameMaker uses the PPD file for the grayscale printer for output.

7. If you use Save As PDF to create PDF files, try printing to the Adobe PDF printer without generating Adobe data.

PDF features, such as bookmarks, hyperlinks, and tags, could cause problems with the creation of PDF files. Disable these features to determine if they cause the problem.

  1. In FrameMaker, choose File > Print.
  2. Click Setup, choose the Adobe PDF printer, and then click OK.
  3. Deselect Generate Adobe Data, and then click Print.

8. Troubleshoot the fonts used in the document.

To troubleshoot potential font problems use applicable steps in Troubleshoot font problems (Windows). Download and install Microsoft's hot fix for font cache issues in Windows XP and Vista: http://support.microsoft.com/?id=952909.

9. If the document contains conditional text, set all conditional text tags to "Show" and then save the document.

Sometimes an inconsistency can occur between conditional text settings among files in a FrameMaker book or in an individual FrameMaker file; Setting all conditionally tagged paragraphs to show and resaving the files can remove a corruption that prevents Distiller from generating a PDF or FrameMaker from being able to update a book file.

To set all conditionally tagged paragraphs to be visible in an individual FrameMaker file, do the following:

  1. Open the problematic file in FrameMaker.
  2. Choose Special > Conditional Text > Show/Hide Conditional Text.
  3. Set the option to Show All.
  4. Move each condition listed in "Hide" column to the "Show" column using the arrow button until no conditions remain listed in the Hide column.
  5. Enable check mark box in front of "Show Condition Indicators" and then click Set.
  6. Save the file and then attempt to create a PDF.

To set all conditionally tagged paragraphs to be shown in the chapters within a FrameMaker book file:

  1. Open the FrameMaker book file.
  2. Open all files listed in the book.
  3. In the book window, highlight problematic chapter or chapters and choose View > Show/Hide Conditional Text.
  4. Enable check mark box for Show All.
  5. Move all conditions listed in the "Hide" column to "Show" column using the arrow button.
  6. Enable checkbox in front of "Show Condition Indicators" and then click Set.
    Note: If a Conditional Text Inconsistency Error Messages occurs, follow the applicable steps in document: "Conditional Text Inconsistency Error Messages When Printing or Updating a FrameMaker Book File."
  7. Save all files in the book.
  8. Update the book.
  9. Create a PDF file.

10. Locate incomplete markers or incorrect markers and correct them or remove them from the document.

To locate all the markers in the document, check the links, and make adjustments, do the following:

  1. Open the FrameMaker file, and select Special > List Of > Markers.
  2. Choose the option to create a stand-alone List Of Markers (Click the Yes button).
  3. Move Hypertext, Cross Reference, and Conditional Text to the Include Markers of Type text box. Select Create Hypertext Links and then click Set. A stand-alone List Of Markers file should have been produced with each mark's syntax and page number by last step and should be used to complete the process.
  4. Toggle document to View Only which Locks the LOM file and make the hyper links active. A keyboard shortcut also exists to lock the document; By pressing Esc, F (Shift + f), l (lowercase L), and then k key in sequence the file is set to View Only.
  5. Click each link entry and verify that marker is properly connected to a source.
  6. In the original FrameMaker document, delete the marker if you don't need it. If you do need it, correct it. To correct an incomplete or incorrect marker:
    1. Choose Special > Marker to display the marker dialog box.
    2. Choose the corresponding Marker Type.
    3. Edit the syntax to include the correct destination information.
    4. Click "Edit Marker" to complete the adjustment.
  7. Save the file and then print it or save it as a PDF file.

11. If none of the steps above resolved the failure to create an Adobe PDF file, additional assistance is available. Contact Adobe Technical Support.

To find support options and additional documentation, use this link to the Adobe website: http://www.adobe.com/support/framemaker.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy