DICOM-fájlok – ismertető

Megjegyzés:

A következő címen megtekinthet egy, a DICOM-fájlokat bemutató videót: www.adobe.com/go/vid0028_hu.

Megjegyzés:

A DICOM (Digital Imaging and Communications in Medicine elnevezésből alkotott mozaikszó) az orvosi célú beolvasott képek fogadásához leggyakrabban használt szabvány. A Photoshop lehetővé teszi a DICOM szabványú (.dc3, .dcm és .dic kiterjesztésű, illetve kiterjesztés nélküli) fájlok megnyitását és a velük való munkát. A DICOM-fájlok több szeletet vagy képkockát tartalmazhatnak, amelyek a letapogatás különböző rétegeinek felelnek meg.

A Photoshop beolvassa a DICOM-fájl összes képkockáját, és Photoshop-rétegekké alakítja őket. A Photoshop képes arra is, hogy minden DICOM képkockát elhelyezzen a rácsvonal egy rétegén vagy képkockákat nyisson meg 3D-térfogatként, melyet elforgathat a 3D-térben. Az alkalmazás 8, 10, 12 és 16 bites DICOM-fájlok beolvasására képes. (A 10 és a 12 bites fájlokat 16 bitesekké alakítja.)

Megnyitásuk után a DICOM-fájlokat a Photoshop eszközeivel javíthatja, illetve jelölésekkel és megjegyzésekkel láthatja el. A Jegyzet eszközzel például megjegyzést adhat a fájlokhoz, a Ceruza eszközzel megjelölheti a kép egyes területeit, a Por és karcok szűrő alkalmazásával pedig eltávolíthatja róla a port és a karcolásokat. A Vonalzó vagy a kijelölés eszközök segítségével méréseket végezhet a kép tartalmán.

Megjegyzés:

A DICOM-fájlban található mértéklépték-készlet automatikusan importálásra kerül a fájllal együtt. Lépték hiányában a program az alapértelmezett 1 képpont = 1 mm skálát alkalmazza egyéni mértékléptékként. Lásd: Mértéklépték beállítása (Photoshop Extended).

A 8 bites DICOM-fájlokat a Photoshop által támogatott valamennyi fájlformátumban mentheti (a 16 bites fájlok DICOM, Large Document Format, Photoshop, Photoshop PDF, Photoshop Raw, PNG vagy TIFF formátumban menthetők).

Megjegyzés:

A DICOM formátumba mentett fájlokból a rétegstílusokat, a korrekciókat, a keverési módokat és a maszkokat a program törli.

A DICOM-fájlok metaadatait a Bridge alkalmazásban és a Photoshop Fájlinformációk párbeszédpanelén megtekintheti és szerkesztheti. DICOM-fájlok támogatják a külső automatizálás szkripteken keresztül (lásd: Szkriptek).

DICOM-fájlok megnyitása

DICOM-fájl megnyitása előtt meghatározhatja a DICOM-képkockák megnyitásának a módját (rétegekként, rácsvonalon vagy 3D-térfogatként, valamint megadhatja a beállításokat (a DICOM-fájl importálása párbeszédpanelen a páciens metaadatainak az anonimizálásához és az átfedések megjelenítéséhez. Importálás közben eltolásokat, nagyítást/kicsinyítést, és ablakolást is alkalmazhat.

A DICOM-fájlok importálására szolgáló párbeszédpanel a DICOM fejléc-információit is megjeleníti. Ezek a fájl szöveges adatai, a méretek és az adatfelbontás mellett például arról nyújtanak tájékoztatást, hogy az adatokat tömörítették-e.

Megjegyzés:

Az Új videoréteg fájlból parancs használatával egy egy képkockát tartalmazó DICOM-fájlokból álló sorozatot importálhat egy többrétegű Photoshop-fájlba. Lásd: Képsorozatok importálása (Photoshop Extended).

 

  1. A Fájl menüben kattintson a Megnyitás parancsra, jelölje ki a kívánt DICOM-fájlt, és kattintson a Megnyitás gombra.
  2. Jelölje ki a megnyitni kívánt képkockákat. A Shift billentyű nyomva tartásával kattintva több, egymást követő képkockát jelölhet ki. Több, nem egymást követő képkocka kijelöléséhez kattintás közben tartsa lenyomva a Ctrl (Windows), illetve a Command (Mac OS) billentyűt. Az összes képkocka kijelöléséhez kattintson Az összes kijelölése gombra.

    Megjegyzés:

    A képkockák közötti gyors görgetéshez használja az egér görgetőkerekét (Windows), vagy kattintson a nagy előnézeti mező alatt lévő jobbra vagy balra mutató nyílra.

  3. Adja meg az alábbi beállításokat, és kattintson a Megnyitás gombra.

    Képkocka-importálás

    A Képkockák importálása rétegekként beállítást választva a program a DICOM-fájlok képkockáit rétegekre helyezi. A Többoldalas konfiguráció választógombot bejelölve a program rácsszerűen jeleníti meg a képkockákat (a Sorok és az Oszlopok mezőben megadhatja a rács magasságát és szélességét). Az Importálás térfogatként parancs térfogatként nyitja meg a DICOM-képkockákat, melyeken a z távolságot a DICOM beállítások határozzák meg, az adatok pedig a képkockák között interpolálásra kerülnek. A térfogatot tetszőleges szögből megtekintheti, az adatok kiemeléséhez különféle leképezési módokat alkalmazva.

    DICOM-adatkészlet

    Az Anonimizálás jelölőnégyzetet bejelölve a program „anonimizálja” (név nélkülivé teszi) a beteg metaadatait. Az Átfedések megjelenítése jelölőnégyzetet bejelölve a program megjeleníti a megjegyzéseket, a görbéket és a szöveget.

    Ablakbeállítások

    A képkocka kontrasztjának (Ablakszélesség) és fényességének (Ablakszint) beállításához válassza az Ablakbeállítások megjelenítése lehetőséget. Más megoldásként az Ablakszint eszköz felfelé és lefelé húzásával a szintet, jobbra és balra húzásával a szélességet igazíthatja. Az Ablakkészlet menüből általános radiológiai készletekből (Alapbeállítás, Tüdő, Csont vagy Has) is választhat. A Kép megfordítása jelölőnégyzetet bejelölve a fényerőértékek inverzét állíthatja be a képkockához.

    Megjegyzés:

    A fájl nagyításához vagy kicsinyítéséhez jelölje ki a megfelelő értéket a Nagyítás kiválasztása menüben (vagy a pluszjelre kattintva nagyíthatja, a mínuszjelre kattintva kicsinyítheti a képet). A kép eltolásához válassza a párbeszédpanel tetején lévő Kéz eszközt, és húzza el a képkockán.

3D-térfogat létrehozása DICOM-képkockákból

  1. A Fájl menüben kattintson a Megnyitás parancsra, jelölje ki a kívánt DICOM-fájlt, és kattintson a Megnyitás gombra.
  2. Jelölje ki a 3D-térfogattá konvertálni kívánt képkockákat. A Shift billentyű nyomva tartásával kattintva több, egymást követő képkockát jelölhet ki. Több, nem egymást követő képkocka kijelöléséhez kattintás közben tartsa lenyomva a Ctrl (Windows), illetve a Command (Mac OS) billentyűt. Az összes képkocka kijelöléséhez kattintson Az összes kijelölése gombra.
  3. A Képkocka-importálás beállításai pontban jelölje ki az Importálás térfogatként lehetőséget, majd kattintson a Megnyitás gombra.

A Photoshop létrehozza a DICOM-képkockák 3D-térfogatát, és elhelyezi egy 3D-rétegen a Rétegek panelen. A Photoshop térbeli pozíció eszközeivel tetszőleges szögből megtekintheti a 3D-térfogatot, vagy módosíthatja is a leképezési beállításokat az adatok jobb megjelenítéséhez.

  • A program az eredeti DICOM-fájlt megtartja a 3D-térfogatréteghez társított szórt textúrarétegként. Információ a 3D-textúrákról: 3D-textúra szerkesztése (Photoshop Extended).

  • Kattintson duplán a textúrarétegre a DICOM-fájl saját dokumentumablakban, intelligens objektumként történő megnyitásához. A DICOM képkockák külön rétegként jelennek meg a Rétegek panelen.

  • Az egyes rétegekre alkalmazott módosítások az intelligens objektum bezárásakor és mentésekor rendelődnek hozzá a 3D-térfogathoz.

A 3D-térfogat mentéséhez exportálhatja a 3D-réteget vagy PSD-formátumban mentheti a fájlt. Lásd: 3D-fájlok mentése és exportálása.

Megjegyzés:

A 3D-tartalom DICOM-képkockákból történő létrehozását bemutató videó a következő címen tekinthető meg: www.adobe.com/go/lrvid4006_ps_hu. (A DICOM-képkockák használatának ismertetése 1:30-nál kezdődik.)

3D-térfogat megtekintése különböző szögekből

  1. Jelölje ki a 3D-réteget tartalmazó DICOM-térfogatot a Rétegek panelen.
  2. Válassza az Eszközök panelen található Térbeli pozíció eszközre vagy valamelyik 3D-kamera eszközre.
  3. Az eszköztár térbeli pozíció vagy kamera eszközeivel elforgathatja, áthelyezheti vagy átméretezheti a 3D-térfogatot. Lásd: 3D objektumok és kameraeszközök (Photoshop Extended).

    Megjegyzés:

    Ha rendszerén engedélyezve van az OpenGL támogatása, akkor a 3D-tengellyel elforgathatja, áthelyezheti vagy átméretezheti a 3D térfogatot. Lásd: 3D tengely (Photoshop Extended).

3D-térfogat megtekintése különböző leképezési módokkal

  1. Jelölje ki a 3D-réteget tartalmazó DICOM-térfogatot a Rétegek panelen.
  2. Az Ablak menü 3D parancsára kattintva nyissa meg a 3D panelt.
  3. Jelöljön ki egy leképezési módot a 3D panel alsó részén a Készlet menüből.

    Megjegyzés:

    Az átmeneti függvényt használó leképezési módok Photoshop színátmenetet használnak az értékek térfogatbeli leképezéséhez. A színátmenet színe és fedettségi értékei a térfogatban a szürkeárnyalatos értékekkel egyesítve optimalizálják vagy kiemelik a különböző típusú tartalmakat. Átmeneti függvényt használó leképezési módok csak szürkeárnyalatos DICOM-képekhez érhetők el.

    Kiemelt határolók

    A homogén területek fedettségét csökkenti, a határolókét változatlanul hagyja. A térfogaton belüli zaj csökkentésére is használható.

    Teljes tartományú színskála

    Teljes „szivárvány” Photoshop színátmenetet alkalmazó átmeneti függvény.

    Magas tartományú csúcsfények

    A teljes színtartományban a fehér színt, az alacsony tartományba eső értékekre zéró fedettséget, a magas tartományba eső értékekre pedig magas fedettséget alkalmazó átmeneti függvény.

    Alacsony tartományú csúcsfények

    A teljes színtartományban a fehér színt, a magas tartományba eső értékekre zéró fedettséget, az alacsony tartományba eső értékekre pedig magas fedettséget alkalmazó átmeneti függvény.

    Maximális intenzitású kivetítés

    Megjeleníti a maximális értékeket a térfogatban, gyors áttekintést nyújtva a térfogat struktúrájáról. Nem biztosít mélységjelzőket.

    Vörös-kék színskála

    Teljes piros-kék színátmenetet alkalmazó átmeneti függvény.

    Vékony izovonalak

    Az izoértékek megjelenítéséhez állandó színt alkalmazó átmeneti függvény, ahol a fedettségi komponens egy több tüskét tartalmazó függvény.

    Átvilágítás

    Röntgensugár számára áttetsző közegen keresztül közelíti meg a röntgensugár átmenetét. Ez a hatás olyankor hasznos, ha CT-letapogatásból származó képet állít elő, amely az azonos objektumról készített röntgenképhez hasonlít.

    Fehér-fekete színskála

    Fekete-fehér színösszetevőt használó átmeneti függvény.

  4. (Nem kötelező lépés) Egyedi leképezési mód létrehozásához kattintson a 3D panelen a Leképezési beállítások pontra a 3D-leképezés beállításai párbeszédpanel megnyitásához. Adja meg a beállításokat a párbeszédpanel Kiterjedés stílusa részén. Lásd: Renderelési beállítások testreszabása.

DICOM-képkockák exportálása JPEG formátumba

  1. Nyisson meg egy DICOM-fájlt, és adja meg a megfelelő beállításokat a DICOM-fájlok importálására szolgáló párbeszédpanelen (lásd: DICOM-fájlok megnyitása (Photoshop Extended)).
  2. Jelölje ki a megfelelő képkockákat a DICOM-fájlok importálási párbeszédpanelén: Egymást követő képkockák kijelöléséhez kattintás közben tartsa lenyomva a Shift, nem egymást követő képkockák kijelöléséhez a Ctrl (Windows), illetve a Command (Mac OS) billentyűt, vagy az összes képkocka kijelöléséhez kattintson Az összes kijelölése gombra.
  3. Az Exportálási beállítások csoport Előtag mezőjében adjon meg egy előtagot.
  4. Kattintson a Bemutató exportálása (JPEG) gombra, válasszon egy mappát, majd kattintson a Kijelölés gombra.

    A program a megadott előtaggal a kijelölt helyre menti a JPEG-fájlokat. Több képkocka kijelölése esetén a Photoshop az egyes fájlnevek végéhez egymást követő számokat fűz (például DICOM képkocka1, DICOM képkocka2, DICOM képkocka3).

DICOM-metaadatok

A Photoshop Fájlinformációk párbeszédpanelén megtekintheti és szerkesztheti a DICOM-metaadatok különféle kategóriáit.

A betegek adatai

Ez a kategória a beteg nevét, azonosítóját, nemét és születési dátumát tartalmazza.

Vizsgálati adatok

Ez a kategória a vizsgálat azonosítóját, az orvos nevét, a vizsgálat dátumát és időpontját, valamint a vizsgálat leírását tartalmazza.

A sorozat adatai

Ez a kategória a sorozat számát, dátumát és időpontját, a modalitást, valamint a sorozat leírását tartalmazza.

A berendezés adatai

Ez a kategória a berendezés intézményét és gyártóját tartalmazza.

A kép adatai

Ez a kategória az átviteli szintaxist, a fotometrikus kiértékelést, a kép szélességét és magasságát, a képpontokkénti bitértéket, valamint a képkockák számát tartalmazza. (Ezek a mezők nem szerkeszthetők.)

DICOM-fájlok animálása

Ha egy DICOM-fájl szeleteit vagy képkockáit animálni szeretné, jelölje ki az összes DICOM-réteget, és az Animáció (idővonal) panel menüjében válassza a Képkockák készítése rétegekből parancsot.

Miután az Animáció (idővonal) panelen létrehozta a megfelelő képkockákat, a DICOM-fájlokat QuickTime-mozgóképekként mentheti (a szürkeárnyalatos DICOM-fájlokat alakítsa RGB színmódúvá, majd renderelje mozgóképpé). A képkockákat animált GIF-fájlokként is mentheti (a Fájl menüben válassza a Mentés webre és eszközökre parancsot).

Az Idővonal panelen DICOM-fájlból létrehozott 3D-térfogatok is animálhatók. Lásd: 3D objektumok és animációk létrehozása (Photoshop Extended).

Megjegyzés:

A következő címen megtekinthet egy, a DICOM-fájlok animálását bemutató videót: www.adobe.com/go/vid0028_hu. (Az animáció ismertetése 2:30-nál kezdődik.)

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat