Crear un diseño Flex

Última actualización el 12 nov. 2026

Aprende a crear diseños Flex en Adobe InDesign usando contenedores vacíos, objetos existentes y marcos de texto de cambio de tamaño automático.

Adobe InDesign deeplink-gen-fill

Pruébalo en la aplicación
Trabaja con un archivo de muestra y aprende a trabajar con Flex Layout.

Crear un diseño Flex vacío

Selecciona múltiples objetos en tu documento.

Selecciona el icono Flex Layout del panel Propiedades. Los objetos seleccionados se agregan a un Flex Container.

Arrastra y suelta objetos en el contenedor. Los elementos del contenedor se ajustan automáticamente según la configuración del Flex Container: dirección, alineación, justificación y espaciado.

  • Flex Layout admite scripts.
  • Pulsa Esc para mover la selección de un objeto secundario al objeto principal dentro de un Flex Layout.

Cambiar automáticamente el tamaño del marco de texto usando las Opciones de marco de texto

Añade un marco de texto como elemento secundario flex en un Flex Layout o selecciona un marco de texto Flex Layout Child.

Ve a Objeto > Opciones de marco de texto y selecciona la opción Tamaño automático en el cuadro de diálogo Opciones de marco de texto.

Selecciona Solo altura, Solo anchura, Altura y anchura o Altura y anchura (mantener proporciones). La opción predeterminada es Desactivado.

Cambiar automáticamente el tamaño del marco de texto usando las opciones de Flex Layout Child

Añade un marco de texto como elemento secundario flex en un Flex Layout o selecciona un marco de texto Flex Layout Child.

En las opciones Flex Layout Child del panel Propiedades, selecciona la opción Auto para A o Al. El marco ahora cambia de tamaño automáticamente para ajustarse a su contenido en lugar de desbordarse.

Captura de pantalla de un marco de texto seleccionado dentro de un Flex Layout y las opciones de Flex Layout Child resaltadas en el panel Propiedades.
Actualiza la Anchura y Altura a Auto en las opciones de Flex Layout Child.

Crear un diseño Flex en un documento existente

Cuando conviertes una selección a un diseño Flex, InDesign analiza la alineación y el espaciado para aplicar el comportamiento de diseño adecuado. Esto ayuda a que tus diseños respondan de manera consistente a los cambios de contenido.

Selecciona varios objetos o grupos que quieras incluir en un Flex Layout.

Para grupos: Haz clic con el botón derecho en el grupo seleccionado y selecciona Flex Layout > Convertir en Flex Layout.

Para varios objetos: Haz clic con el botón derecho en los objetos seleccionados y selecciona Flex Layout > Añadir a Flex Layout.

Nota

InDesign detecta automáticamente la dirección y las propiedades para Flex Layout. Para activarlo o desactivarlo, selecciona Edición > Preferencias > General (Windows) o InDesign > Preferencias > General (macOS), luego selecciona o deselecciona la opción Detectar automáticamente y aplicar configuración de Flex Layout y selecciona Aceptar.

Al usar la detección automática para convertir un grupo de elementos de diferentes tamaños a un Flex Layout ya no se reordenarán

por tamaño. Ahora puedes usarlo para preservar la disposición original sin alterar tu diseño visual previsto.

InDesign detecta las propiedades de diseño basándose en cómo están alineados los objetos seleccionados:

  • Selecciones alineadas: La dirección del contenedor coincide con la alineación, el dimensionado se establece en Automático a lo largo de ese eje, y el espaciado se establece en Espacio entre.
  • Selecciones no alineadas: Ajustar contenido está activado, y el contenedor utiliza un tamaño fijo en el eje principal y dimensionado automático en el eje secundario.

Puedes ajustar la dirección, justificación, espaciado, ajuste y alineación.

Espacio de trabajo de InDesign con el panel Flex Layout mostrando las propiedades para el ajuste, abierto sobre un contenedor flex convertido.
Refinar las propiedades de Flex Layout mediante el panel de Flex Layout.

Convierte elementos principales en configuración usando los Flex Layouts para generar estructuras anidadas.

Añadir o eliminar elementos para ver cómo responde el diseño y refinar hasta que se adapte suavemente.

Nota

La detección automática no crea Flex Layouts anidados. Los grupos que ya contienen un Flex Layout se tratan como objetos únicos, por lo que se deben convertir los grupos internos manualmente antes o después de crear el contenedor externo.