Which versions of Lightroom are compatible with macOS Catalina?

Lightroom 2.4.1 and later versions work with macOS 10.15 (Catalina) but have these known compatibility issues. You may want to remain on your current version of macOS until these issues have been resolved.

Adobe strongly recommends that customers do their own testing on a non-production partition to ensure that new operating systems work with their current hardware and drivers. 

If you do encounter issues not already documented here, feel free to report them on our feedback site.

Are older versions of Lightroom compatible with macOS Catalina?

No, older versions of Lightroom were neither designed nor tested to work on macOS Catalina. They are not supported in any way for use on macOS Catalina.

Adobe does not recommend that customers using old versions of Lightroom upgrade to macOS Catalina.

Older versions use 32-bit licensing components and installers. Therefore, they cannot be installed and activated after upgrading to macOS Catalina. Although upgrading to macOS Catalina with an older version already installed on your computer may allow the app to function in some capacity, you will not be able to reinstall or activate the app after the macOS upgrade.


Before upgrading to macOS Catalina, you may uninstall the older versions as the uninstaller will not work after upgrading. If you have already upgraded to macOS Catalina, you can use the Creative Cloud Cleaner Tool to uninstall older versions.

Known compatibility issues

Adobe has discovered the compatibility issues listed below with running Lightroom 2.4.1 with macOS 10.15 (Catalina).

Error: /[volume name]/ is disconnected. Please reconnect to finish syncing.

When you launch Lightroom on macOS 10.15, a red banner appears on top stating /[volume name]/ is disconnected. Please reconnect to finish syncing.

Affected versions: Lightroom 2.2 and earlier

Solution

To resolve this issue, upgrade to Lightroom 2.4. For information on updating your app, see Update Creative Cloud apps

Apple Photos migration to Lightroom Desktop fails with error message

When you select File > Migrate From… > Apple Photos Library migration fails with "Migration was not successful" dialog.

We are working with Apple to correct this issue. 

Lens Profile Creator does not run

The Lens Profile Creator is currently 32-bit, but we are investigating updating it to be a 64-bit utility.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy