Make quick selections

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Migrate presets, actions, and settings
    8. Get to know Photoshop
  3. Photoshop and Adobe services
    1. Photoshop and Adobe Stock
    2. Creative Cloud Libraries
    3. Creative Cloud Libraries in Photoshop
    4. Grid and guides
    5. Creating actions
    6. Undo and history
    7. Default keyboard shortcuts
    8. Touch capabilities and customizable workspaces
    9. Use the Touch Bar with Photoshop
    10. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export cloud documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. System requirements 1.x | Photoshop on the iPad
    23. System requirements 2.x | Photoshop on the iPad
    24. Edit your image size
    25. Livestream as you create in Photoshop on the iPad
    26. Correct imperfections with the Healing Brush
    27. Create brushes in Capture and use them in Photoshop
  5. Photoshop on the web
    1. Photoshop on the web | Common questions    
    2. Introduction to the workspace
    3. System requirements | Photoshop on the web
    4. Keyboard shortcuts | Photoshop on the web
    5. Supported file types | Photoshop on the web
    6. Open and work with cloud documents
    7. Collaborate with stakeholders
    8. Apply limited edits to your cloud documents
  6. Cloud documents
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Share access and edit your cloud documents
  7. Workspace
    1. Workspace basics
    2. Create documents
    3. Use the Touch Bar with Photoshop
    4. Microsoft Dial support in Photoshop
    5. Tool galleries
    6. Performance preferences
    7. Use tools
    8. Touch gestures
    9. Touch capabilities and customizable workspaces
    10. Technology previews
    11. Metadata and notes
    12. Quickly share your creations
    13. Place Photoshop images in other applications
    14. Preferences
    15. Default keyboard shortcuts
    16. Rulers
    17. Show or hide non-printing Extras
    18. Specify columns for an image
    19. Undo and history
    20. Panels and menus
    21. Place files
    22. Position elements with snapping
    23. Position with the Ruler tool
    24. Presets
    25. Customize keyboard shortcuts
    26. Grid and guides
  8. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Export files in Photoshop
    4. Device Preview
    5. Copy CSS from layers
    6. Slice web pages
    7. HTML options for slices
    8. Modify slice layout
    9. Work with web graphics
    10. Create web photo galleries
  9. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  10. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
    26. Layer
    27. Flattening
    28. Composite
    29. Background
  11. Selections
    1. Select and Mask workspace
    2. Make quick selections
    3. Get started with selections
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Select a color range in an image
    7. Adjust pixel selections
    8. Convert between paths and selection borders
    9. Channel basics
    10. Move, copy, and delete selected pixels
    11. Create a temporary quick mask
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
    16. Selection
    17. Bounding box
  12. Image adjustments
    1. Perspective warp
    2. Reduce camera shake blurring
    3. Healing brush examples
    4. Export color lookup tables
    5. Adjust image sharpness and blur
    6. Understand color adjustments
    7. Apply a Brightness/Contrast adjustment
    8. Adjust shadow and highlight detail
    9. Levels adjustment
    10. Adjust hue and saturation
    11. Adjust vibrance
    12. Adjust color saturation in image areas
    13. Make quick tonal adjustments
    14. Apply special color effects to images
    15. Enhance your image with color balance adjustments
    16. High dynamic range images
    17. View histograms and pixel values
    18. Match colors in your image
    19. How to crop and straighten photos
    20. Convert a color image to black and white
    21. Adjustment and fill layers
    22. Curves adjustment
    23. Blending modes
    24. Target images for press
    25. Adjust color and tone with Levels and Curves eyedroppers
    26. Adjust HDR exposure and toning
    27. Filter
    28. Blur
    29. Dodge or burn image areas
    30. Make selective color adjustments
    31. Replace object colors
  13. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. How to make non-destructive edits in Camera Raw
    10. Radial Filter in Camera Raw
    11. Manage Camera Raw settings
    12. Open, process, and save images in Camera Raw
    13. Repair images with the Enhanced Spot Removal tool in Camera Raw
    14. Rotate, crop, and adjust images
    15. Adjust color rendering in Camera Raw
    16. Feature summary | Adobe Camera Raw | 2018 releases
    17. New features summary
    18. Process versions in Camera Raw
    19. Make local adjustments in Camera Raw
  14. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  15. Image transformations
    1. Transform objects
    2. Adjust crop, rotation, and canvas size
    3. How to crop and straighten photos
    4. Create and edit panoramic images
    5. Warp images, shapes, and paths
    6. Vanishing Point
    7. Use the Liquify filter
    8. Content-aware scaling
    9. Transform images, shapes, and paths
    10. Warp
    11. Transform
    12. Panorama
  16. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Fill and stroke selections, layers, and paths
    14. Draw with the Pen tools
    15. Create patterns
    16. Generate a pattern using the Pattern Maker
    17. Manage paths
    18. Manage pattern libraries and presets
    19. Draw or paint with a graphics tablet
    20. Create textured brushes
    21. Add dynamic elements to brushes
    22. Gradient
    23. Paint stylized strokes with the Art History Brush
    24. Paint with a pattern
    25. Sync presets on multiple devices
  17. Text
    1. Work with OpenType SVG fonts
    2. Format characters
    3. Format paragraphs
    4. How to create type effects
    5. Edit text
    6. Line and character spacing
    7. Arabic and Hebrew type
    8. Fonts
    9. Troubleshoot fonts
    10. Asian type
    11. Create type
    12. Text Engine error using Type tool in Photoshop | Windows 8
    13. World-Ready composer for Asian Scripts
    14. How to add and edit text in Photoshop
  18. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  19. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  20. Saving and exporting
    1. Save files in graphics formats
    2. Save your files in Photoshop
    3. File formats
    4. Save and export video and animations
    5. Save PDF files
    6. Digimarc copyright protection
  21. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Duotones
    8. Print images to a commercial printing press
    9. Improve color prints from Photoshop
    10. Troubleshoot printing problems | Photoshop
  22. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  23. 3D and technical imaging
    1. Creative Cloud 3D Animation (Preview)
    2. Print 3D objects
    3. 3D painting
    4. 3D panel enhancements | Photoshop
    5. Essential 3D concepts and tools
    6. 3D rendering and saving
    7. Create 3D objects and animations
    8. Image stacks
    9. 3D workflow
    10. Measurement
    11. DICOM files
    12. Photoshop and MATLAB
    13. Count objects in an image
    14. Combine and convert 3D objects
    15. 3D texture editing
    16. Adjust HDR exposure and toning
    17. 3D panel settings
  24. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Work with color profiles
    5. Color-managing documents for online viewing
    6. Color-managing documents when printing
    7. Color-managing imported images
    8. Proofing colors

Use the Object Selection tool, Select Subject, Quick Selection, or Magic Wand tools to make quick selections in Photoshop.

With selections, define an area that you can further edit to enhance your images and composites. You can easily use any of the various selection tools in Photoshop to quickly make a selection.

Auto-select an object an hover

Object Selection tool
Updated in Photoshop 23.0 (October 2021 release)

The Object Selection tool simplifies the process of selecting a single object or part of an object in an image—people, cars, furniture, pets, clothes, and more. You simply draw a rectangular region or a lasso around the object, the Object Selection tool automatically selects the object inside the defined region. The tool works better on well-defined objects than on regions without contrast. Selections made with the Object Selection tool are now more accurate and preserve more details in the edges of the selection, which means you spend less time getting those perfect selections.

You can access the Object Selection tool at the following locations:

Object select on hover

Pastaba:

Not seeing the Object Selection tool in your toolbar? See Tools missing from the toolbar.

To select objects in an image using the Object Selection tool, follow the steps below:

  1. Select the Object Selection tool from the toolbar.

  2. Ensure the Object Finder is enabled and hover over the desired object

    Object Selection tool options bar

    In the options bar, ensure that the Object Finder is enabled (default behavior: ON). You can then simply hover your pointer over the object in your image that you want to select. Photoshop automatically selects the object as you hover. Click to make the selection.

    If you don't want to use the automatic selection, turn off the Object Finder and choose a selection Mode: Rectangle or Lasso and drag along the object to make your selection.

    • Rectangle: Drag the pointer to define a rectangular region around the object.
    • Lasso: Draw a rough lasso outside the boundary of the object.
  3. Subtract from or add to the selection

    In the options bar, click one of the selection options: New, Add To, Subtract From, or Intersect With the selection. New is the default option if nothing is selected. After making the initial selection, the option changes automatically to Add To

    Add to the selection: Hold the Shift key or select Add To Selection in the options bar, then hover over/draw a new rectangle or a lasso around the missing region. Repeat this process for all the missing regions you want to add to the selection.

    Subtract from the selection: There are two options to subtract from the selection: 

    • Use the Subtract From Selection option in the options bar: Hold the Option (Mac)/ Alt (Win) key or select Subtract From Selection in the options bar, then hover over/draw an exact rectangle or a lasso around the boundary of the region you want to subtract from the selection. 
    • Enable Object Subtract from the additional options (gear icon in the options bar)Object Subtract is especially useful when removing the background regions inside the current object selection. You can think of the Object Subtract option as equivalent to Object Selection inverted. Turn ON the Object Subtract option in the options bar. Hold the Option (Mac)/ Alt (Win) key or select Subtract From Selection in the options bar, then hover over or draw a rough rectangle or a lasso around the region you want to subtract from the selection.
  4. Choose object selection options

    Sample All Layers: Creates a selection based on all layers instead of just the currently selected layer.

    Hard Edge: Enables hard edges on the selection boundary.

  5. Further refine the selection edge in the Select And Mask workspace

    To further adjust the selection boundary or view the selection against different backgrounds or as a mask, click Select And Mask in the options bar.

Feedback dialog for object selection

Also, make use of the Selection Feedback dialog to share details about the selection achieved using the Object Selection tool and help us improve.

Mask all objects in a layer in a single click

Use this huge timesaver that leverages the power of Adobe Sensei to generate masks for all objects in the desired layer in a single click.

Choose Layer > Mask All Objects and watch Photoshop easily generate masks for all the objects detected within your layer with just a single click.

Mask all objects in a layer
Choose "Mask All Objects"

masked object layer created
Layer mask created for all objects detected in your layer in a single click.

How is the Object Selection tool different from the Select Subject command?

The Object Selection tool is useful when you only need to select one of the objects or part of an object within an image that contains multiple objects. While the Select Subject command is designed to select all the main subjects in the image.

Select Subject

Optimized for better portrait selections in Photoshop 21.2 (June 2020 release)

Select Subject in Photoshop

The Select Subject command lets you select the most prominent subject in an image in a single click. Powered by advanced machine learning technology, Select Subject is trained to identify a variety of objects in an image—people, animals, vehicles, toys, and more. 

  1. Select subjects automatically

    Select Subject automatically selects the prominent subjects in your image. To access Select Subject, do one of the following:

    • While editing an image, choose Select > Subject.
    • While using the Object Selection, Quick Selection, or Magic Wand tools, click Select Subject in the options bar.
    • While using the Object  Selection or Quick Selection tools in the Select & Mask workspace, click Select Subject in the options bar.
    Pastaba:

    Beginning with Photoshop 21.2 (June 2020 release), Select Subject is now content-aware and applies new custom algorithms when it detects a person is in the image. When creating a selection on portrait images, treatment around hair area has been vastly improved to create a detailed selection of hair. To temporarily turn off the content-awareness, you can press and hold the Shift key while performing Select Subject.  

  2. Add to or subtract from the selection

    Use any of the Selection tools with their Add to selection and Subtract from selection options to clean up the initial selection, if necessary. See Adjust selections manually.

  3. Fine-tune the selection in the Select and Mask workspace

    Choose Select > Select and Mask to open the image in the Select and Mask workspace. Use the tools and sliders in the workspace to clean up the selection further. 

    See Select and Mask workspace.

Quick Selection tool

You can use the Quick Selection tool  to quickly "paint" a selection using an adjustable round brush tip. As you drag, the selection expands outward and automatically finds and follows defined edges in the image.

  1. Select the Quick Selection tool  . (If the tool isn't visible, hold down the Magic Wand tool  .)
  2. In the options bar, click one of the selection options: New, Add To, or Subtract From.

    New is the default option if nothing is selected. After making the initial selection, the option changes automatically to Add To.

  3. To change the brush tip size, click the Brush pop-up menu in the options bar, and type in a pixel size or drag the slider. Use the Size pop‑up menu options to make the brush tip size sensitive to pen pressure or a stylus wheel.
    Pastaba:

    When creating a selection, press the right bracket (]) to increase the Quick Selection tool brush tip size; press the left bracket ([) to decrease the brush tip size.

  4. Choose Quick Selection options:

    Sample All Layers: Creates a selection based on all layers instead of just the currently selected layer.

    Enhance Edge: Reduces roughness and blockiness in the selection boundary. Enhance Edge automatically flows the selection further toward image edges and applies some of the edge refinement you can apply manually in the Select and Mask workspace.

  5. Paint inside the part of the image you want to select. The selection grows as you paint. If updating is slow, continue to drag to allow time to complete work on the selection. As you paint near the edges of a shape, the selection area extends to follow the contours of the shape edge.

    Photoshop Paint with the Quick Selection tool
    Painting with the Quick Selection tool to extend the selection

    • To subtract from a selection, click the Subtract From option in the options bar, then drag over the existing selection.
    • To temporarily switch between add and subtract modes, hold down the Alt (Win) or Option (Mac) key.
    • To change the tool cursor, choose Edit > Preferences > Cursors > Painting Cursors (Win) or Photoshop > Preferences > Cursors > Painting Cursors (Mac). Normal Brush Tip displays the standard Quick Selection cursor with a plus or minus sign to show the selection mode.
    Pastaba:

    If you stop dragging and then click or drag in a nearby area, the selection will grow to include the new area.

  6. Click Select and Mask to further adjust the selection boundary. 

Magic Wand tool

The Magic Wand tool lets you select a consistently colored area (for example, a red flower) without having to trace its outline. You specify the selected color range, or tolerance, relative to the original color you click.

Pastaba:

You cannot use the Magic Wand tool on an image in Bitmap mode or on 32‑bits-per-channel images.

  1. Select the Magic Wand tool  . (If the tool isn't visible, access it by holding down the Quick Selection tool  .)
  2. Specify one of the selection options in the options bar. The Magic Wand tool's pointer changes depending on which option is selected.
    Photoshop Selection options
    Selection options

    A. New B. Add To C. Subtract From D. Intersect With 

  3. In the options bar, specify any of the following:

    Tolerance: Determines the color range of selected pixels. Enter a value in pixels, ranging from 0 to 255. A low value selects the few colors very similar to the pixel you click. A higher value selects a broader range of colors.

    Anti-aliased: Creates a smoother-edged selection.

    Contiguous: Selects only adjacent areas using the same colors. Otherwise, all pixels in the entire image using the same colors are selected.

    Sample All Layers: Selects colors using data from all the visible layers. Otherwise, the Magic Wand tool selects colors from the active layer only.

  4. In the image, click the color you want to select. If Contiguous is selected, all adjacent pixels within the tolerance range are selected. Otherwise, all pixels in the tolerance range are selected.
  5. Click Select and Mask to further adjust the selection boundary or view the selection against different backgrounds or as a mask. 

„Adobe“ logotipas

Prisijunkite prie savo paskyros