Les instructions ci-dessous font référence aux versions spécifiques des SDK Flex et AIR : SDK Flex 4.6.0 et SDK AIR 3.4. Les instructions sont toutefois générales. Suivez ces instructions pour intégrer toute version du SDK AIR dans toute version du SDK Flex.

Remarque :

Si le SDK Flex est plus récent que le SDK AIR, il peut se fier à une fonctionnalité AIR qui n’est pas présente, ce qui entraîne des erreurs lors de la compilation ou de l’exécution.

  1. Quittez Flash Builder.

  2. (Facultatif) Enregistrez le SDK Flex en copiant l’intégralité du répertoire.

    Par exemple, dans Flash Builder, copiez le répertoire dans :

    • Windows : C:/Program Files/Adobe/Flash Builder 4.7/sdks/4.6.0

    • Mac OS : /Applications/Adobe Flash Builder 4.7/sdks/4.6.0

  3. Téléchargez le fichier approprié du SDK AIR pour votre système d’exploitation depuis la page http://www.adobe.com/fr/products/air/sdk/ et enregistrez-le dans le répertoire racine du SDK Flex.

    •  Windows : AdobeAIRSDK.zip

    •  Mac OS : AdobeAIRSDK.dmg

  4. Extrayez le contenu de l’archive du SDK AIR et remplacez les fichiers SDK existants.

    • Windows : cliquez avec le bouton droit sur le fichier ZIP et sélectionnez Extraire tout, ou utilisez l’outil de décompression de votre choix.

    • Mac OS : dans Terminal, exécutez ces commandes :

      • hdiutil attach AdobeAIRSDK.dmg
      • cp -rf /Volumes/AIR\ SDK/* /path-to-empty-FLEXSDK-directory
    • Si vous rencontrez des problèmes en écrasant les fichiers en raison d’autorisations de fichier, essayez ces commandes :

      • sudo hdiutil attach AdobeAIRSDK.dmg
      • sudo cp -rf /Volumes/AIR\ SDK/* /path-to-empty-FLEXSDK-directory
  5. (Facultatif) Pour accéder aux nouvelles API AIR 3.4, mettez à jour le fichier descripteur de votre application vers la version 3.4 de l’espace de noms.

    Pour mettre à jour l’espace de noms, remplacez l’attribut xmlns dans votre descripteur d’application par : <application xmlns="http://ns.adobe.com/air/application/3.4">

  6. (Facultatif) Pour vérifier que le fichier SWF de sortie cible la version 17 du fichier SWF, transmettez un argument de compilateur supplémentaire : -swf-version=17.

    Pour obtenir des instructions détaillées, consultez cet article.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne