The encoding process

To encode a video or audio item, add the item to the encoding queue in Adobe Media Encoder, and then select encoding presets or create your own custom settings. You can instruct the application to start encoding after you add an item to the queue, or you can tell the application to wait until you decide to start encoding.

Add an item to the encoding queue - Drag video or audio files into the queue in Adobe Media Encoder.

Encode the item using presets - Select formats and presets from the Format and Presets pop-up menus with the item in the queue. Or choose a preset from the Preset Browser and drag it to any item in the Queue. For more information, see Encode using presets.

Encode the item using custom settings - Select the item and select Edit > Export Settings, and then choose your settings. For more information, see Encode using custom settings.

To start encoding items in the queue automatically (or to turn off the feature), select or deselect the Start Queue Automatically When Idle For option in the Preferences dialog box. For more information, see the Preferences article.

AME screen
Adobe Media Encoder main window

Import items into the encoding queue

  • To add video or audio files, do one of the following:
    • Drag one more files into the queue from the desktop or the media browser.
    • Click the Add Source button and choose one or more files.
    • Double-click an open area in the Queue panel and choose one or more files.
  • To add a Adobe Premiere Pro sequence, do one of the following:
    • Navigate within an Adobe Premiere Pro project in the Media Browser and click drag sequences to the Queue.
    • Choose File>Add Premiere Pro Sequence, select a Premiere Pro project, and select one or more sequences from that project.
    • Click drag a sequence from the Project panel in Adobe Premiere Pro into the queue.
    • Click drag a Premiere Pro project from the desktop on the Queue.
  • To add an Adobe After Effects composition, do one of the following:
    • Navigate within an Adobe After Effects project in the Media Browser and drag-and-drop compositions to the Queue.
    • Choose File>Add After Effects Composition, select an After Effects project, and select a composition from that project.
    • Click drag a composition from the Project panel in After Effects into the queue.
    • Click drag an After Effects project from the desktop on the Queue.

Stop encoding

  • Choose File>Stop Current File to stop encoding the current item. Adobe Media Encoder continues encoding the remaining items in the Queue.
  • Choose File>Stop Queue to stop encoding all items in the Queue.

Interpret items in the encoding queue

When Adobe Media Encoder imports a video asset, it attempts to determine the pixel aspect ratio, frame rate, and field order for that asset, as well as how to interpret the alpha channel (transparency) information. If Adobe Media Encoder is wrong about any of these characteristics, you can explicitly assign the correct interpretation.

  1. Select one or more items in the encoding queue.

  2. Choose File>Interpret Footage. You can also right click the file and choose Interpret Footage.

    interpret selection
    Interpret Footage selection

  3. Choose the appropriate interpretation settings.

    iterpret window
    Interpret Footage dialog box

Identify missing items in the encoding queue

You can identify sources and outputs in the queue that contain missing items before you encode. This helps you identify and fix issues before you encode. A warning status is displayed next to the source or output that contains any missing items. Hover over the icon to view a summary of the error which is associated with this problem. 

Adobe Media Encoder shows a warning icon in the following cases:

  • Premiere Pro projects contain offline media. In this case, Adobe Media Encoder uses proxy media in the place of the missing set. If there are no proxies, a graphic that displays 'Media Offline' message is used.
  • Some fonts are missing from Premiere Pro projects.
  • Some effects are missing in Premiere Pro projects.
  • Some files are missing in Overlay effects. 
Identify missing items
Identify missing items

Watch folders in Adobe Media Encoder  

You can configure Adobe Media Encoder to look for files in certain folders called watch folders. When Adobe Media Encoder finds a video or audio file in a watch folder, it encodes the file using the encoding settings assigned to the folder, and then exports the encoded file to an Output folder created inside the watch folder.

The Watch Folders panel in In Adobe Media Encoder can be used to add and manage folders. You can add a watch folder in one of the following ways:

  1. Choose File>Add Watch Folder and select a folder.
  2. Double-click an empty area in the Watch Folders panel and select a folder.
  3. Create a folder in Explorer (Windows) or Finder (Mac OS), and then drag it to the Watch Folders panel.

You can see the name of the folder in the left column of the Watch Folders panel after you have created it.

The items added to the encoding queue by the watch folder will be encoded along with other items in the queue when you start the queue.

Note:

If you have the “start queue automatically when idle for” preference selected, encoding begins when the specified amount of time has elapsed after the watch folder has added a new item to the encoding queue.

Note:

Keep the Auto-Encode Watch Folders check box enabled to automatically encode items when they are added to the watch folder.

Adding presets

You can choose a format and preset from the pop-up menus in the watch folder next to the folder name. Or drag a preset to the watch folder from the preset browser.

Create output in multiple formats from a single source item using watch folders

You can generate multiple outputs with a single operation by using watch folders. For example, you want to generate an AVI movie, and a JPEG thumbnail image whenever you transcode a video asset. Follow these steps to create these files with a single user operation:

  1. Create a folder using Explorer (Windows) or Finder (Macintosh) called, “My_WatchFolder,” for example.

  2. Create a watch folder by clicking the Add Folder button, and then navigate to the folder you just made, “My_Watchfolder.”

    1. Click Format and Select MPEG4 as the format from the pop-up menu.

    2. Click Preset and select the desired setting from the Preset pop-up menu.

      preset and format
      Format and Preset pop-up menu

    3. Click Output Folder. Select a location where you would like the result to be generated.

      Output Folder
      Output Folder

  3. Create a Watch Folder item that also points to the folder “My_Watchfolder,” just like you created in Step 2.

    1. Select AVI as the format from the Format menu.

    2. Select a preset from the Preset Menu, and then click OK.

    3. Click Output Folder. Select a location where you would like the result to be generated.

  4. Create a Watch Folder item that also points to the folder “My_Watchfolder,” just like you created in Step 2 and Step 3.

    1. Select JPEG as the format from the Format menu.

    2. Select a preset from the Preset Menu, and then click OK.

    3. Click Output Folder. Select a location where you would like the result to be generated.

  5. Click drag the source file into “My_WatchFolder,” and then click the Start Queue button. The encoding process begins automatically if the Auto-Encode Watch Folders is enabled.

When complete, each file is in its expected output locations.

Note:

The preset should be custom and the Export As Sequence option must be deselected. This will only export the first frame of the video, which is often black.

Note:

Still Image Sequences are not supported as source footage through Watch Folders. If a set of still images is placed in the folder being watched, each individual still file is added as a separate item to the Queue rather than the entire sequence as a single piece of footage.

Save the encoding queue

The encoding queue and all encoding settings are saved automatically when you exit Adobe Media Encoder.

The encoding queue is also saved automatically when a user starts an encoding.

To manually save the encoding queue, choose File > Save Queue.

Note:

Turn off the Preferences > Remove completed files from the queue on exit check box if you want to keep completed encoded items in the Queue when you close and restart Adobe Media Encoder.

Remove items from the encoding queue

  1. Select the item, or items that you want to remove from the encoding queue.

  2. Click the Remove button, choose Edit > Clear, or press the Delete key.

    Delete file new
    Delete items from Encoding queue

Duplicate items in the encoding queue

  1. Select the item, or items that you want to duplicate in the encoding queue.

  2. Do one of the following:

    • Click the Duplicate button, choose Edit > Duplicate
    • Press Ctrl-D (Windows), or Command-D (Mac OS)
    • Right-click the file and choose Duplicate.
    Duplicate item
    Duplicate item

Skip items in the encoding queue

Skip items

  1. Select the item, or items that you want to skip in the encoding queue.

  2. Choose Edit > Skip Selection or you can right-click the file and choose Skip Selection.

    Skip selection
    Skip Selection

Reset a skipped file for encoding

  1. Select the items in the encoding queue that you want to reset to the Ready state.

  2. Choose Edit>Reset Status or you can also right-click the file and choose Edit>Reset Status.

    Reset status
    Reset Status of skipped file

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy