Queue and Watch Folders: Independent handling of source and output

Source and output are now handled independent of each other. This independent handling allows a given source to be configured with multiple outputs. Among the advantages, Adobe Media Encoder can simultaneously encode multiple outputs of a given source. Compared to individually encoding each output, simultaneous encoding is faster.

Preset browser

The new Preset Browser provides you with options that help streamline your workflow in Adobe Media Encoder.

System presets in the browser are organized as categories based on their use (such as Broadcast, Web Video) and device destination (such as DVD, Blu-ray, Camera, Tablet). You can modify these presets to create custom presets, also called User Presets.

In the Preset Browser, you can quickly find a preset using search, or using the enhanced navigation provided by the collapsible folder structure.

User presets, preset groups, and aliases

You can modify system presets to create user presets. You can organize user presets in separate folders called as preset groups. Preset groups allow you to apply multiple presets to a source in a single step.

Aliases allow you to create multiple instances of a preset for use in multiple preset groups.

For example, if you want a preset to exist in more than one preset group, create aliases to the preset instead of duplicating it. Then, add the aliases to other preset groups. When you edit the preset, the changes are applied to all its aliases.

Managing Presets

To manage presets, use the Preset menu or the options in The Preset Browser (Window>Preset Browser). You can also right-click a preset in the Preset Browser to view the context menu for the available options.

Preset Browser
The Preset Browser

A. User preset B. Alias created to a preset C. Preset group D. Create new preset E. Delete preset F. Create new preset group G. Preset settings H. Import presets I. Export presets J. Search for presets 

Create presets, preset groups, and aliases

Preset Groups can contain user presets, aliases to presets, or other preset groups.

  • Select Preset > Create Preset to create a preset.
  • Select Preset > Create Group to create a preset group.
  • To create a preset alias, right-click the preset in the Preset Browser, and select Create Alias.
  • To quickly create an alias to a system preset, drag the system preset to the User Presets and Groups section. 
  • To quickly create an alias to a user preset, Alt -drag (Win) or Opt - drag (Mac OS) the user preset to a preset group.

Modify user presets

  • To rename a preset, click the name of a selected preset. Type a name for the preset and press Enter. Alternatively, select Preset > Rename to rename a preset.
  • To modify preset settings, select a preset, and select Preset > Settings.
  • To delete a preset, select the preset and press Delete. Alternatively, select Preset > Delete.

Note:

Only user presets can be edited. Changes to system presets can be saved as new user presets by clicking the Save A Copy button in the Preset Settings dialog.

Apply presets or preset groups to the Queue

To apply presets to sources in the Queue, do one of the following:

  • Drag presets, preset groups, or aliases from the Preset Browser and drop them on sources or outputs in the Queue.
    • Dropping a preset on a source adds an output to the source.
    • Dropping a preset on an existing output replaces the settings of the output with the settings of the preset.
  • To add an output to the source, drag a source from the Queue to a preset, preset group, or alias in the Preset Browser
  • To replace the settings of the output with the settings of the preset, drag an output from the Queue to a preset, preset group, or alias in the Preset Browser.
  • Select a source in the Queue and double-click a preset, preset group, or alias in the Preset Browser.
  • Select a source in the Queue. Select presets, preset groups, or aliases selected in the Preset Browser. Click Apply Preset.

Apply presets or preset groups to Watch Folders

To apply presets to watch folders in the Watch Folders panel, do one of the following:

  • Drag presets, preset groups, or aliases from the Preset Browser and drop them on watch folders or outputs in the Watch Folders panel.
    • Dropping presets on a watch folder adds new outputs to the watch folder.
    • Dropping presets on an existing output replaces the settings of the output with the settings of the preset.
  • To add an ouput to the watch folder, drag a watch folder from the Watch Folders panel to a preset, preset group, or alias in the Preset Browser.
  • To replace the settings of the output with the settings of the preset, drag an output from the Watch Folders panel to a preset, preset group, or alias in the Preset Browser.
  • Select a watch folder in the Watch Folders panel. Alt + double-click (Win) or Opt + double-click (Mac) a preset, preset group, or alias in the Preset Browser.
  • Select a watch folder in the Watch Folders panel. Select presets, preset groups, or aliases in the Preset Browser. Alt + click (Win) or Opt + click (Mac) the Apply Preset button.

Apply presets to Premiere Pro sequences, After Effects compositions, and media assets during import

Apply presets to Adobe Premiere Pro sequences

Drag a sequence from the Project panel of an open Adobe Premiere Pro project and drop it on a preset, alias, or preset group in the Preset Browser.

Note:

This procedure is the only way to add multiple presets to Adobe Premiere Pro sequences in a single step. The Export Settings dialog in Adobe Premiere Pro allows you to apply single presets when exporting sequences to Adobe Media Encoder.

Apply presets to After Effects compositions

Drag a composition from the Project panel of an open After Effects project to a preset, preset group, or alias in the Preset Browser.

Apply presets to video and audio assets

Drag video and audio assets from Finder or Windows Explorer and drop them on a preset, preset group, or alias in the Preset Browser.

Important considerations when applying presets

  • Dropping a single preset on an output replaces the output. The new outputs inherit the output path, output name, and source range settings from the targeted output
  • Dropping a single preset on a source adds an output.
  • Dropping a preset group (or multiple selected presets) on an output adds outputs. The new outputs inherit the output path, output name, and source range settings from the targeted output.
  • Dropping a preset group (or multiple selected presets) on a source adds outputs. Settings such as output path from existing outputs are not inherited.

Import and export presets

Presets can be imported and exported as EPR files. EPR files are saved in the XML format.

  • Select Preset > Import to import EPR files. Imported presets appear in the User Presets and Groups section.
  • Select Preset > Export to export selected presets as EPR files.

Note:

You can also drag-and-drop EPR files on an existing preset in the Preset Browser to import them.

Show the location of a preset in Finder or Explorer

Right-click the preset in the Preset Browser and select Reveal Preset File.

Quickly find a preset in the browser

As you type in the search field , the Preset Browser filters the preset list to match your search string. All columns are scanned for matching results.

Improved scaling of source frames

Source Scaling options
Source Scaling options

In Adobe Media Encoder CS6, it is not necessary that you enable a crop before using this option. Also, this setting is available for any output format with editable frame dimensions.

Use the options in the Source Scaling menu of the Export Settings dialog for better scaling of source frames within output frames of a different size.

Scale To Fit

Scales the source frame to fit within the output frame while maintaining pixel aspect ratio of the source. Source frames are letter-boxed or pillar-boxed within the output frame as necessary.

Scale To Fill

Scales the source frame to completely fill the output frame while cropping the source frame as necessary. Pixel aspect ratio of the source frame is maintained.

Stretch To Fill

Resizes the source frame to completely fill the output frame. Pixel aspect ratio of the source is not maintained.

Scale To Fit With Black Borders

Source frame, including the cropped area, is fit within the output frame. Pixel aspect ratio is maintained.

Note:

This option is the same as the Black Borders option in the Crop Settings menu of Adobe Media Encoder CS5.5.

Change Output Size To Match Source

Overrides the output frame size settings to match the crop settings of the source.

Note:

This option is the same as Change Output Size in the Crop Settings menu of Adobe Media Encoder CS5.5.

Creating custom workspaces

In the new interface, you can group panels as tabs in a single frame or float them as separate panels.

  1. Move the panels by clicking them and dragging them around. To group panels, drag the panel to the topmost section of another panel. Release the mouse when a purple patch appears in the center of the host panel.
  2. After you customize the workspace to your requirements, select Window > Workspace > New Workspace to create a custom workspace.

The new Workspace is added to the Workspace menu. You can now use the options in the Window > Workspace menu to switch workspaces.

Workflow enhancements

  • Sources are still encoded in sequence, but all outputs of a source are now encoded in parallel. To disable parallel encoding, select Edit > Preferences, and deselect Enable Parallel Encoding.
  • For multiple outputs, the Encoding panel displays a thumbnail preview, progress bar, and the completion time estimate of each encoding output
  • In certain cases, export settings require an output to encode in serial rather than in parallel mode. In such cases, the queue returns to parallel encoding after temporary serial encoding is complete.
The Queue Panel
A. Add Source B. Add Output C. Remove Source/Output D. Duplicate 
  • You can associate multiple outputs with a source. Each output can have a different format, preset, and output file location assigned to it.
  • You can reorder outputs in the output list. However, you cannot move them to other sources.
  • Clicking the output file path opens the folder containing the encoded file. Previous to encoding, however, the Save As dialog appears.
    • To change the output path and filename, click the Output File link for that output. 
    • To access an encoded file, click the Output File link for that output
  • Use the Add Output button to quickly add an output to a source.
  • Both sources and outputs can be duplicated. A duplicated source uses all the outputs from the original source.

Changes to exporters

For better performance, the following exporters have been updated for this release:

  • AAC Audio ("Audio Only" in previous versions)
  • H.264
  • H.264 Blu-ray
  • MPEG4
  • Windows Media (Windows only)

For compatibility reasons, older versions of the following CS5.5 exporters have been included in CS6:

H.264 (Legacy)

Dolby Digital Surcode audio encoding is not available in the new exporter.

H.264 Blu-ray (Legacy)

Preserves support for Match Source presets and Surcode for Dolby.

MPEG4 (Legacy)

 

Presets created in previous versions of Adobe Media Encoder can be imported into Adobe Media Encoder CS6. However, presets for H.264 and H.264 Blu-ray apply only to legacy exporters. Presets for the Audio Only or Windows Media exporters from previous versions cannot be imported.

Change render settings for an After Effects composition

Adobe Media Encoder CS6 allows you to modify the Guide Layers render setting for an After Effects composition. To enable or disable guide layer visibility, select an After Effects comp source, and select File > Source Settings.

Keyboard shortcuts

Result Windows Mac OS
Add item to queue
Ctrl+I Cmd+I
Start/pause queue
Enter
Return
Stop queue
Esc Esc
Open Preferences dialog
Ctrl+,(comma) Cmd+,(comma)
Save queue
Ctrl+S
Cmd+S
Quit
Ctrl+Q
Cmd+Q
Duplicate selected items Ctrl+D Cmd+D
Select all items in current list Ctrl+A Cmd+A
Open the Export Settings dialog Ctrl+E Cmd+E
Undo Ctrl+Z Cmd+Z
Redo Ctrl+Y Cmd+Y
Adobe Media Encoder Help F1 F1

Export Settings dialog

Result Windows Mac OS
Moves playhead one frame earlier/later
Left/Right arrows
Left/Right arrows
Move playhead to the start/end frame
Home/End
Home/End
Set source range In Point to playhead's current position
I I
Set source range Out Point to playhead's current position
O O
Move playhead to the In Point
Q
Q
Move playhead to the Out Point
W W
Zooms in frame preview
Ctrl++(plus) Cmd++(plus)
Zooms out frame preview
Ctrl+-(minus)
Cmd+-(minus)
Exports preset as an EPR file
Alt+click Save Preset button
Opt+click Save Preset button

New keyboard shortcuts in CS6

Customize keyboard shortcuts

Select  Edit > Keyboard Shortcuts (Windows) or Application > Keyboard Shortcuts (Mac OS) to customize keyboard shortcuts in Adobe Media Encoder CS6.

For example, to change the keyboard shortcut for the cut operation from Ctrl+x to Ctrl+t, do the following:

  1. Select Edit > Keyboard Shortcuts.
  2. In the Keyboard Shortcuts panel, expand the Edit menu by clicking it.
  3. Select Cut.
  4. Click next to Ctrl+x to delete the existing command.
  5. Click Add.
  6. Press Ctrl+t.
  7. Click OK.

File menu

Result Windows Mac OS
Add watch folder

Ctrl+Alt+I Cmd+Opt+I
Stop current item

Ctrl+ - (minus sign)

Cmd+ - (minus sign)
Show log Ctrl+L Ctrl+L
Show errors Ctrl+Alt+L Cmd+Opt+L

Edit menu

Result Windows Mac OS
Redo
Ctrl+Shift+Z Cmd+Shift+Z
Reset status
Ctrl+ . (period)
Cmd+.(period)
Skip selection
Ctrl+Shift+. (period)
Cmd+Shift+.(period)
Show errors Ctrl+Alt+L Cmd+Opt+L
Open Keyboard Shortcuts dialog Ctrl+Alt+Shift+K Cmd+Opt+Shift+K

Preset menu

Result Windows Mac OS
Open Preset Settings dialog

Ctrl+Alt+E Cmd+Opt+E
Apply to queue

Ctrl+U

Cmd+U
Apply to watch folders

Ctrl+Alt+U

Cmd+Opt+U
Create preset

Ctrl+N Cmd+N
Create preset group

Ctrl+G Cmd+G
Create alias to preset

Ctrl+B Cmd+B
Rename user preset or preset group Ctrl+R Cmd+R

Window menu

Result Windows Mac OS
Queue panel

Ctrl+1 Cmd+1
Encoding panel

Ctrl+2

Cmd+2
Watch folders panel

Ctrl+3

Cmd+3
Preset browser

Ctrl+4 Cmd+4

Main user interface

Result Windows Mac OS
Close the current panel

Ctrl+W Cmd+W
Maximize/Restore the panel under the pointer cursor

` (backtick sign under tilde)

` (backtick sign under tilde)
Maximize or restore current panel

Shift+` (bactick sign under tilde)

Shift+` (bactick sign under tilde)
Maximize/Restore panel under the pointer cursor (non-English keyboards)

< <
Maximize or restore current panel  (non-English keyboards) Shift+ < Shift+ <
Select previous/next item in list

Up and Down Arrows Up and Down Arrows
Add previous/next item in list to current selection

Shift + Up/Down Arrows

Shift + Up/Down Arrows
Select previous/next item in list. If a folder is selected, Right Arrow opens the folder and Left Arrow closes it. Right and Left Arrows Right and Left Arrows
Add previous/next item in list to current selection. If a folder is selected, Right Arrow opens folder and Left Arrow closes it. Shift+Right and Left Arrows Shift+Right and Left Arrows

Export Settings dialog

Numeric field with whole numbers (ex. Frame Width setting):  
Result Windows Mac OS
Increase or decrease current value by 1

Up and Down Arrows

Up and Down Arrows
Increase or decrease current value by 10

Shift+Up/Down Arrows

Shift+Up/Down Arrows
Increase or decrease current value by 10

Ctrl+Up/Down Arrows

Cmd+Up/Down Arrows
Increase or decrease current value by 100

Ctrl+Shift+Up/Down Arrows

Cmd+Shift+Up/Down Arrows
Bit rate field in Mbps:  
Result Windows Mac OS
Increase or decrease current value by 1

Shift+Up/Down Arrows

Shift+Up/Down Arrows
Increase or decrease current value by .1

Up and Down Arrows

Up and Down Arrows
Increase or decrease current value by .01

Ctrl+Up/Down Arrows

Cmd+Up/Down Arrows
Increase or decrease current value by .001

Ctrl+Alt+Up/Down Arrows

Cmd+Opt+Up/Down Arrows
Bit rate field in Kbps:

 
Result Windows Mac OS
Increase or decrease current value by 10

Shift+Up/Down Arrows

Shift+Up/Down Arrows
Increase or decrease current value by 1

Up and Down Arrows

Up and Down Arrows
Increase or decrease current value by .1

Ctrl+Up/Down Arrows

Cmd+Up/Down Arrows
Increase or decrease current value by .01

Ctrl+Alt+Up/Down Arrows

Cmd+Opt+Up/Down Arrows

Keyboard Shortcuts dialog

Result Windows Mac OS
Expand/Collapse all categories in dialog Alt+Click Category heading Opt+Click Category heading

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy