Dwi-klik dalam panel Projek atau gunakan Fail > Import > Fail untuk menyemak imbas dan mengimport fail SVG.
Ketahui cara mengimport fail SVG sebagai lapisan bentuk asli yang boleh diedit dan sedia untuk dianimasikan tanpa memerlukan penukaran.
Versi terkini After Effects membolehkan anda mengimport fail sebagai bahagian filem atau komposisi.
Seret dan lepas fail SVG yang diimport ke dalam panel Timeline.
Pilih lapisan untuk menggunakan bahagian Kandungan Lapisan dalam panel Properties untuk melihat struktur SVG.
Anda juga boleh pilih anak panah di sebelah Lapisan untuk membuka lipatannya, kemudian kembangkan bahagian Kandungan.Anda akan melihat semua elemen individu dan sifat mereka, seperti Laluan, Isi, dan ubah.
Anda boleh menggunakan sifat ini untuk menganimasikan seperti mana-mana lapisan bentuk lain.Contohnya:
- Animasikan Laluan untuk mencipta Kesan morphing
- Tukar warna isi dari masa ke masa untuk peralihan dinamik
- Gunakan sifat ubah untuk mengukur, memutar, atau menggerakkan elemen secara bebas
Jika Lapisan mempunyai isi gradien dan strok, anda boleh menggunakan sifat Skala dan Putaran untuk menganimasikan gradien.
Import SVG dalam After Effects menawarkan kawalan yang fleksibel dan lebih baik ke atas cara fail SVG diimport dalam projek anda.Dengan versi terkini, apabila anda mengimport fail SVG, anda boleh memilih untuk membawanya masuk sebagai bahagian filem atau sebagai komposisi.
|
Import sebagai bahagian filem |
Import sebagai komposisi |
|---|---|
|
Mengimport SVG sebagai lapisan vektor tunggal yang boleh diraster secara berterusan. |
Mengimport SVG sebagai komposisi yang diperbuat daripada lapisan bentuk yang boleh diedit. |
|
Mengekalkan sambungan kepada fail SVG luaran. |
Setiap elemen ditukar kepada bentuk boleh edit tersendiri. |
|
Baik untuk grafik vektor lapisan tunggal apabila anda tidak perlu memecahkan karya seni kepada bahagian. |
Baik untuk mengedit laluan, bentuk dan butiran peringkat lapisan apabila anda perlu menganimasikan elemen individu. |
Anda boleh mengawal pendekatan import yang digunakan secara lalai semasa mengimport fail SVG dengan menetapkan pilihan Drag Multiple File Items As di bawah keutamaan Import.
- macOS: After Effects > Tetapan > Import > Drag Multiple File Items As
- Windows: Edit > Preferences > Import > Drag Multiple File Items As
Dwi-klik di dalam panel Projek atau gunakan File > Import > File untuk melayari dan mengimport fail SVG.
Gunakan dropdown menu Import As dalam kotak dialog Import file untuk memilih salah satu daripada yang berikut:
- Bahagian filem
- Komposisi - Kekalkan Saiz Lapisan
Memilih Bahagian filem mengimport fail sebagai lapisan rata tunggal tanpa akses kepada elemen individu, menjadikannya sesuai untuk kegunaan statik atau apabila tiada animasi diperlukan. Memilih Komposisi – Kekalkan Saiz Lapisan mencipta komposisi baru di mana setiap lapisan sumber diimport secara berasingan, bersaiz kepada kandungan sebenar, menjadikan titik penambat lebih bersih dan transformasi lebih mudah untuk animasi.
macOS
Windows
Pilih pilihan berikut jika berkenaan:
- Cipta Komposisi: Mencipta komposisi baru menggunakan tetapan lalai dan secara automatik meletakkan SVG yang diimport, sama ada sebagai bahagian filem atau sebagai komposisi dengan lapisan bentuk, ke dalam garis masa, menjimatkan anda daripada perlu mencipta komposisi secara manual dan menyeret fail SVG ke dalamnya.
- Scalable Vector Graphics Sequence: Mengimport berbilang fail SVG bernombor dan menganggapnya sebagai urutan imej vektor bingkai demi bingkai.
Gunakan bahagian Layer Contents dalam panel Properties atau bahagian Contents lapisan dalam garis masa untuk melihat dan bekerja dengan elemen individu dan sifat-sifatnya jika anda telah mengimport fail SVG sebagai komposisi. Jika diimport sebagai bahagian filem, ia berkelakuan seperti lapisan biasa dan boleh dilaraskan menggunakan sifat Transform standard.
Seperti dengan fail Illustrator, jika fail vektor diimport sebagai bahagian filem, anda boleh memilih lapisan dalam garis masa, kemudian klik kanan dan pilih Create > Create Shapes and Text from Vector Layer untuk menukarnya kepada lapisan boleh diedit, membolehkan anda menganimasikan laluan, strok, dan isian individu. Dalam After Effects beta terkini, teks dalam fail sumber menukar kepada lapisan teks boleh edit yang mengekalkan fon, saiz, isian, kedudukan, gaya, strok, dan tetapan fon berubah.
Apabila anda mengimport SVG sebagai bahagian filem, After Effects mengekalkan pautan langsung ke fail asal, jadi sebarang perubahan yang anda buat pada SVG tersebut di luar aplikasi secara automatik dikemas kini dalam projek anda.
Gunakan ciri Beta baharu
Teks boleh edit dari fail Illustrator kini tersedia untuk ujian dan maklum balas. Cuba sekarang dalam After Effects (Beta).
Dalam After Effects Beta terkini, apabila lapisan Illustrator diimport sebagai bahagian filem, sebarang teks dalam fail sumber menukar kepada lapisan teks boleh editnya sendiri dan bukannya diratakan kepada bentuk garis luar. Ini bermakna fon, saiz, isian, kedudukan, gaya (seperti Tebal dan italic), strok, dan tetapan fon berubah semuanya dipindahkan, jadi anda boleh terus mengedit teks secara langsung dalam After Effects dan bukannya mencipta semula dari awal atau kembali ke Illustrator untuk membuat perubahan.
Pilih File > Import > File dan kemudian fail Illustrator yang anda mahu import.
Dalam kotak dialog Import File, pastikan Import As ditetapkan kepada Footage apabila memilih fail untuk diimport.
Dalam kotak dialog import, sahkan bahawa Import Kind ditetapkan kepada Footage dan pilih Layer Options berdasarkan apa yang anda mahu import dari fail Illustrator.
Seret fail yang diimport ke panel Timeline.
Klik kanan lapisan Illustrator dan pilih Create > Create Shapes and Text from Vector Layer, atau gunakan Layer > Create > Create Shapes and Text from Vector Layer.
Teks menukar kepada lapisan teks boleh edit yang hampir sepadan dengan fon, saiz, isian, dan kedudukan fail asal. Anda kemudian boleh mengedit dan menyesuaikan teks secara langsung dalam After Effects.
Teks strok sahaja masih ditukar sebagai laluan dan bukannya lapisan teks boleh diedit.
Kandungan vektor bukan teks masih menukar kepada lapisan bentuk seperti sebelumnya, dan jika fail Illustrator mengandungi kedua-duanya, anda akan mendapat campuran lapisan teks dan bentuk.
Sertai perbincangan dalam komuniti After Effects (Beta) kami tentang sokongan untuk teks boleh edit daripada fail Illustrator.
Kandungan SVG pada papan klip kini boleh ditampal ke dalam After Effects menggunakan Edit > Paste. Kandungan diimport sebagai lapisan bentuk asli dan boleh edit yang sedia untuk animasi, tanpa memerlukan langkah import perantaraan.
Salin kandungan daripada Illustrator
Buka karya seni anda dalam Adobe Illustrator.
Sahkan bahawa keutamaan Include SVG Code dipilih.
- macOS: Pilih Illustrator > Settings > Clipboard Handling dan pilih Include SVG Code.
- Windows: Pilih Edit > Preferences > Clipboard Handling dan pilih Include SVG Code.
Pilih karya seni yang ingin anda salin.
Tukar sebarang teks SVG kepada lengkung sebelum menyalin, kerana teks SVG tidak disokong semasa tampal.
Pilih Edit > Copy.
Tukar ke After Effects dan lakukan salah satu daripada yang berikut bergantung pada keadaan projek anda:
- Jika tiada projek dibuka, pilih Edit > Paste untuk mencipta projek baharu dengan komposisi yang mengandungi kandungan SVG sebagai lapisan bentuk.
- Jika projek dibuka tetapi tiada komposisi dipilih, pilih Edit > Paste untuk mencipta komposisi baharu dalam projek semasa yang mengandungi kandungan yang ditampal.
Jika komposisi dipilih dalam After Effects, pilih Edit > Paste untuk menambah kandungan SVG sebagai lapisan bentuk baharu dalam komposisi tersebut.
Tampal SVG daripada aplikasi lain
Kandungan SVG yang disalin daripada sebarang aplikasi yang menulis SVG ke papan klip sistem boleh ditampal menggunakan aliran kerja Edit > Paste yang sama. Sokongan bergantung pada sama ada aplikasi sumber meletakkan data SVG yang sah pada papan klip.
Cipta animasi 3D yang menakjubkan dalam After Effects
Animasikan watak dan ilustrasi, tambahkan gerakan pada teks dan banyak lagi.