Create and manage layers and groups

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Migrate presets, actions, and settings
    8. Get to know Photoshop
  3. Photoshop and Adobe services
    1. Photoshop and Adobe Stock
    2. Creative Cloud Libraries
    3. Creative Cloud Libraries in Photoshop
    4. Grid and guides
    5. Creating actions
    6. Undo and history
    7. Default keyboard shortcuts
    8. Touch capabilities and customizable workspaces
    9. Use the Touch Bar with Photoshop
    10. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export cloud documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. System requirements 1.x | Photoshop on the iPad
    23. System requirements 2.x | Photoshop on the iPad
    24. Edit your image size
    25. Livestream as you create in Photoshop on the iPad
    26. Correct imperfections with the Healing Brush
    27. Create brushes in Capture and use them in Photoshop
  5. Cloud documents
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud doc sync logs
    8. Share access and edit your cloud documents
  6. Workspace
    1. Workspace basics
    2. Create documents
    3. Use the Touch Bar with Photoshop
    4. Microsoft Dial support in Photoshop
    5. Tool galleries
    6. Performance preferences
    7. Use tools
    8. Touch gestures
    9. Touch capabilities and customizable workspaces
    10. Technology previews
    11. Metadata and notes
    12. Quickly share your creations
    13. Place Photoshop images in other applications
    14. Preferences
    15. Default keyboard shortcuts
    16. Rulers
    17. Show or hide non-printing Extras
    18. Specify columns for an image
    19. Undo and history
    20. Panels and menus
    21. Place files
    22. Position elements with snapping
    23. Position with the Ruler tool
    24. Presets
    25. Customize keyboard shortcuts
    26. Grid and guides
  7. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Export files in Photoshop
    4. Device Preview
    5. Copy CSS from layers
    6. Slice web pages
    7. HTML options for slices
    8. Modify slice layout
    9. Work with web graphics
    10. Create web photo galleries
  8. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  9. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
    26. Layer
    27. Flattening
    28. Composite
    29. Background
  10. Selections
    1. Select and Mask workspace
    2. Make quick selections
    3. Get started with selections
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Select a color range in an image
    7. Adjust pixel selections
    8. Convert between paths and selection borders
    9. Channel basics
    10. Move, copy, and delete selected pixels
    11. Create a temporary quick mask
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
    16. Selection
    17. Bounding box
  11. Image adjustments
    1. Perspective warp
    2. Reduce camera shake blurring
    3. Healing brush examples
    4. Export color lookup tables
    5. Adjust image sharpness and blur
    6. Understand color adjustments
    7. Apply a Brightness/Contrast adjustment
    8. Adjust shadow and highlight detail
    9. Levels adjustment
    10. Adjust hue and saturation
    11. Adjust vibrance
    12. Adjust color saturation in image areas
    13. Make quick tonal adjustments
    14. Apply special color effects to images
    15. Enhance your image with color balance adjustments
    16. High dynamic range images
    17. View histograms and pixel values
    18. Match colors in your image
    19. How to crop and straighten photos
    20. Convert a color image to black and white
    21. Adjustment and fill layers
    22. Curves adjustment
    23. Blending modes
    24. Target images for press
    25. Adjust color and tone with Levels and Curves eyedroppers
    26. Adjust HDR exposure and toning
    27. Filter
    28. Blur
    29. Dodge or burn image areas
    30. Make selective color adjustments
    31. Replace object colors
  12. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. How to make non-destructive edits in Camera Raw
    10. Radial Filter in Camera Raw
    11. Manage Camera Raw settings
    12. Open, process, and save images in Camera Raw
    13. Repair images with the Enhanced Spot Removal tool in Camera Raw
    14. Rotate, crop, and adjust images
    15. Adjust color rendering in Camera Raw
    16. Feature summary | Adobe Camera Raw | 2018 releases
    17. New features summary
    18. Process versions in Camera Raw
    19. Make local adjustments in Camera Raw
  13. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  14. Image transformations
    1. Transform objects
    2. Adjust crop, rotation, and canvas size
    3. How to crop and straighten photos
    4. Create and edit panoramic images
    5. Warp images, shapes, and paths
    6. Vanishing Point
    7. Use the Liquify filter
    8. Content-aware scaling
    9. Transform images, shapes, and paths
    10. Warp
    11. Transform
    12. Panorama
  15. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Fill and stroke selections, layers, and paths
    14. Draw with the Pen tools
    15. Create patterns
    16. Generate a pattern using the Pattern Maker
    17. Manage paths
    18. Manage pattern libraries and presets
    19. Draw or paint with a graphics tablet
    20. Create textured brushes
    21. Add dynamic elements to brushes
    22. Gradient
    23. Paint stylized strokes with the Art History Brush
    24. Paint with a pattern
    25. Sync presets on multiple devices
  16. Text
    1. Work with OpenType SVG fonts
    2. Format characters
    3. Format paragraphs
    4. How to create type effects
    5. Edit text
    6. Line and character spacing
    7. Arabic and Hebrew type
    8. Fonts
    9. Troubleshoot fonts
    10. Asian type
    11. Create type
    12. Text Engine error using Type tool in Photoshop | Windows 8
    13. World-Ready composer for Asian Scripts
    14. How to add and edit text in Photoshop
  17. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  18. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  19. Saving and exporting
    1. Save files in graphics formats
    2. Save your files in Photoshop
    3. File formats
    4. Save and export video and animations
    5. Save PDF files
    6. Digimarc copyright protection
  20. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Duotones
    8. Print images to a commercial printing press
    9. Improve color prints from Photoshop
    10. Troubleshoot printing problems | Photoshop
  21. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  22. 3D and technical imaging
    1. Creative Cloud 3D Animation (Preview)
    2. Print 3D objects
    3. 3D painting
    4. 3D panel enhancements | Photoshop
    5. Essential 3D concepts and tools
    6. 3D rendering and saving
    7. Create 3D objects and animations
    8. Image stacks
    9. 3D workflow
    10. Measurement
    11. DICOM files
    12. Photoshop and MATLAB
    13. Count objects in an image
    14. Combine and convert 3D objects
    15. 3D texture editing
    16. Adjust HDR exposure and toning
    17. 3D panel settings
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Work with color profiles
    5. Color-managing documents for online viewing
    6. Color-managing documents when printing
    7. Color-managing imported images
    8. Proofing colors

Create layers and groups

A new layer appears either above the selected layer or within the selected group in the Layers panel.

Create a new layer or group

  1. Do one of the following:

    • To create a new layer or group using default options, click the Create A New Layer button  or New Group button  in the Layers panel.

    • Choose Layer > New > Layer or choose Layer > New > Group.

    • Choose New Layer or New Group from the Layers panel menu.

    • Alt-click (Windows) or Option-click (Mac OS) the Create A New Layer button or New Group button in the Layers panel to display the New Layer dialog box and set layer options.

    • Ctrl-click (Windows) or Command-click (Mac OS) the Create A New Layer button or New Group button in the Layers panel to add a layer below the currently selected layer.

  2. Set layer options, and click OK:

    Name

    Specifies a name for the layer or group.

    Use Previous Layer to Create Clipping Mask

    This option is not available for groups. (See Mask layers with clipping masks.)

    Color

    Assigns a color to the layer or group in the Layers panel.

    Mode

    Specifies a blending mode for the layer or group. (See Blending modes.)

    Opacity

    Specifies an opacity level for the layer or group.

    Fill With Mode-Neutral Color

    Fills the layer with a preset, neutral color.

    Note:

    To add currently selected layers to a new group, choose Layer > Group Layers, or Shift-click the New Group button at the bottom of the Layers panel.

Create a layer from an existing file

  1. Drag the file icon from Windows or Mac OS onto an open image in Photoshop.

  2. Move, scale, or rotate the imported image. (See Place a file in Photoshop.)

  3. Press Enter or Return.

    By default, Photoshop creates a Smart Object layer. To create standard layers from dragged files, deselect Place Or Drag Raster Images As Smart Objects in the General preferences.

    Note:

    If the placed file is a multilayer image, a flattened version appears on the new layer. To instead copy separate layers, duplicate them in another image. (See Duplicate layers.)

Create a layer with effects from another layer

  1. Select the existing layer in the Layers panel.

  2. Drag the layer to the Create A New Layer button at the bottom of the Layers panel. The newly created layer contains all the effects of the existing one.

Convert a selection into a new layer

  1. Make a selection.

  2. Do one of the following:

    • Choose Layer > New > Layer Via Copy to copy the selection into a new layer.

    • Choose Layer > New > Layer Via Cut to cut the selection and paste it into a new layer.

    Note:

    You must rasterize Smart Objects or shape layers to enable these commands.

View layers and groups within a group

  1. Do one of the following to open the group:
    • Click the triangle to the left of the folder icon .

    • Right-click (Windows) or Control-click (Mac OS) the triangle to the left of the folder icon and choose Open This Group.

    • Alt-click (Windows) or Option-click (Mac OS) the triangle to open or close a group and the groups nested within it.

Show or hide a layer, group, or style

Showing or hiding layers, groups, or styles lets you isolate or view only certain portions of your image for easy editing.

  1. Do one of the following in the Layers panel:
    • Click the eye icon  next to a layer, group, or layer effect to hide its content in the document window. Click in the column again to redisplay the content. To view the eye icon for styles and effects, click the Reveal Effects In panel icon .

    • Choose Show Layers or Hide Layers from the Layers menu.

    • Alt-click (Windows) or Option-click (Mac OS) an eye icon  to display only the contents of that layer or group. Photoshop remembers the visibility states of all layers before hiding them. If you don’t change the visibility of any other layer, Alt-clicking (Windows) or Option-clicking (Mac OS) the same eye icon restores the original visibility settings.

    • Drag through the eye column to change the visibility of multiple items in the Layers panel.

    Note:

    Only visible layers are printed.

Copy/paste layers

You can now copy and paste layers in Photoshop—inside a document and between documents. Depending on your color management settings and the color profile associated with the file (or imported data), Photoshop may prompt you for directions to handle color information in the imported data.

Caution:

Any edit you make to a copy-pasted Smart Object layer does not update the original Smart Object layer and vice versa. This is a known limitation. As a workaround, create Linked Smart Objects.

Copy-paste commands

Copy

(Edit > Copy or Cmd/Ctrl+C) Copies the selected layers

Paste

(Edit > Paste or Cmd/Ctrl+V) Pastes the copied layers into the chosen document in the center of that document. Pasting creates a duplicate layer, including all bitmap and vector masks, and layer effects.

Paste In Place

(Edit > Paste Special > Paste In Place or Cmd/Ctrl+Shift+V) Pastes the copied layers into the targeted document in a position relative to its position in the original document. For example, a layer containing content from the bottom-right corner of a large document pastes into the new document in the bottom-right corner. In all cases, Photoshop tries to keep at least some piece of the pasted layers visible in the destination document, so that you can reposition it as desired.

Note:

If you copy a layer and then create a new document, you can make use of the Clipboard option in the New Document dialog. Choosing this option creates a new document the size of the layers you’ve copied. You can then easily paste your copied layers into the new document

Note:

Cut is grayed out when you have a layer or layers selected. Delete layers directly in the Layers panel.

Considerations for copy/pasting layers containing paths

Copy behaviors

  • If you copy a layer that contains paths—i.e. a Shape layer—but no paths are selected, then the layer is copied to the clipboard. Pasting creates a duplicate shape layer, including all bitmap and vector masks, and layer effects.
  • If you copy a layer that contains paths—i.e. a Shape layer—and the paths are selected on canvas, then the path is copied to the clipboard. 
  • If you copy a layer with a vector mask, but the vector mask is not selected, then all layer data is copied to the clipboard. Pasting creates a duplicate layer, including all bitmap and vector masks, and layer effects.
  • If you copy a layer with a vector mask, and the vector mask is selected, then the path data is copied to the clipboard. Pasting depends on the context.

Paste behaviors

  • If you paste a layer between documents with different resolutions, the pasted layer retains its pixel dimensions. This behavior can make the pasted portion appear out of proportion to the new image. Use the Image Size command to make the source and destination images the same resolution before copying and pasting, or use the Free Transform command to resize the pasted content.
  • If you select a layer that contains no paths—for example, a bitmap layer, pasting the path data creates a new vector mask.
  • If you select a layer that contains paths—for example, a Shape layer—but no paths are selected, then pasting replaces the current Shape in the layer.
  • If you select a Shape layer and select the path, then pasting pastes the path data into the existing Shape layer, combining it with the existing path.
  • If you select a layer with a vector mask, but the vector mask is not selected, then pasting path data replaces the Vector Mask path.
  • If you select a layer with a vector mask, and the vector mask is selected, then pasting pastes the path data into the vector mask, combining it with the existing path.

Copy Merged

This command makes a merged copy of all the visible layers in the selected area.

More like this

Adobe logo

Sign in to your account