Haga doble clic dentro del panel Proyecto o utilice Archivo > Importar > Archivo para examinar e importar el archivo SVG.
Obtenga información sobre cómo importar archivos SVG, como capas de forma nativas y editables, listas para animar sin necesidad de conversión.
La versión más reciente de After Effects le permite importar el archivo como material de archivo o como composición.
Arrastre y suelte el archivo SVG importado en el panel Cronología.
Seleccione la capa para usar la sección Contenido de capa en el panel Propiedades para ver la estructura del SVG.
También puede seleccionar la flecha junto a la capa para desplegarla y luego expandir la sección Contenidos. Verá todos los elementos individuales y sus propiedades, como Ruta, Relleno y Transformación.
Puede usar estas propiedades para animar, como cualquier otra capa de forma. Por ejemplo:
- Anime la Ruta para crear efectos de transformación
- Cambia el color de relleno a lo largo del tiempo para transiciones dinámicas
- Usa las propiedades de Transform para escalar, rotar o mover elementos de forma independiente
Si las capas tienen rellenos y trazos con degradado, puede usar las propiedades Escala y Rotación para animar el degradado.
La importación de SVG en After Effects ofrece un control flexible y mejorado sobre cómo se importan los archivos SVG en su proyecto. Con la versión más reciente, cuando importa un archivo SVG, puede incluirlo como material de archivo o como composición.
|
Importar como material de archivo |
Importar como una composición |
|---|---|
|
Importe el SVG como una sola capa vectorial que se puede rasterizar de forma continua. |
Importa el SVG como una composición formada por capas de forma editables. |
|
Mantiene una conexión con el archivo SVG externo. |
Cada elemento se convierte en su propia forma editable. |
|
Ideal para gráficos vectoriales de una sola capa cuando no necesita dividir la ilustración en partes. |
Ideal para editar rutas, formas y detalles a nivel de capa cuando necesita animar elementos individuales. |
Puede controlar qué enfoque de importación se usa de forma predeterminada al importar archivos SVG configurando la opción Arrastrar varios elementos de archivo como en las preferencias de Importación.
- macOS: After Effects > Configuración > Importación > Arrastrar varios elementos de archivo como
- Windows: Edición > Preferencias > Importación > Arrastrar varios elementos de archivo como
Haga doble clic dentro del panel Proyecto o utilice Archivo > Importar > Archivo para examinar e importar el archivo SVG.
Use el menú desplegable Importar como en el cuadro de diálogo Importar archivo para seleccionar una de las siguientes opciones:
- Material de archivo
- Composición, conservar tamaños de capa
Elegir Material de archivo importa el archivo como una sola capa aplanada sin acceso a elementos individuales, lo que lo hace adecuado para uso estático o cuando no se requiere animación. Seleccionar Composición - Conservar tamaños de capa crea una nueva composición donde cada capa de origen se importa por separado, dimensionada según su contenido real, haciendo que los puntos de ancla sean más limpios y las transformaciones más fáciles para la animación.
macOS
Windows
Seleccione las siguientes opciones si corresponde:
- Crear composición: crea una nueva composición usando configuración predeterminada y coloca automáticamente el SVG importado, ya sea como material de archivo o como composición con capas de forma, en la cronología, evitando que tenga que crear manualmente una composición y arrastrar el archivo SVG a ella.
- Secuencia de gráficos vectoriales escalables: importa varios archivos SVG numerados y los trata como una secuencia de imágenes vectoriales fotograma a fotograma.
Utiliza la sección Contenido de capa del panel Propiedades o la sección Contenido de la capa en la cronología para ver y trabajar con elementos individuales y sus propiedades si has importado el archivo SVG como composición.Si se importa como material de archivo, se comporta como una capa normal y se puede ajustar usando las propiedades estándar de Transformación.
Al igual que con los archivos de Illustrator, si el archivo vectorial se importa como material de archivo, puedes seleccionar la capa en la cronología, hacer clic derecho y seleccionar Crear > Crear formas y texto a partir de capa vectorial para convertirla en capas editables, lo que te permite animar rutas, trazos y rellenos individuales.En la última versión beta de After Effects, el texto del archivo fuente se convierte en capas de texto editables que conservan la fuente, el tamaño, el relleno, la posición, los estilos, los trazos y la configuración de fuente variable.
Cuando importa un SVG como material de archivo, After Effects mantiene un vínculo activo con el archivo original, por lo que cualquier cambio que hagas a ese SVG fuera de la aplicación se actualiza automáticamente dentro de su proyecto.
Uso de las nuevas funciones beta
El texto editable de archivos de Illustrator ya está disponible para pruebas y comentarios. Pruébelo ahora en After Effects (beta).
En la última versión beta de After Effects, cuando una capa de Illustrator se importa como material de archivo, cualquier texto del archivo fuente se convierte en su propia capa de texto editable en lugar de quedar aplanado en contornos de forma.Esto significa que la fuente, tamaño, relleno, posición, estilos (como negrita y cursiva), trazos y configuración de fuentes variables se transfieren, para que puedas seguir editando el texto directamente en After Effects en lugar de recrearlo desde cero o volver a Illustrator para hacer cambios.
Selecciona Archivo > Importación > Archivo y luego el archivo de Illustrator que quieres importar.
En el cuadro de diálogo Importar archivo, asegúrate de que Importar como esté establecido en Material de archivo al seleccionar el archivo a importar.
En el cuadro de diálogo de importación, confirma que Tipo de importación esté establecido en Material de archivo y selecciona las Opciones de capa según lo que quieras importar del archivo de Illustrator.
Arrastra el archivo importado al panel Cronología.
Haz clic derecho en la capa de Illustrator y selecciona Crear > Crear formas y texto a partir de capa vectorial, o usa Capa > Crear > Crear formas y texto a partir de capa vectorial.
El texto se convierte en una capa de texto editable que coincide estrechamente con la fuente, tamaño, relleno y posición del archivo original. Luego puedes editar y ajustar el texto directamente en After Effects.
El texto solo con trazo aún se convierte como rutas en lugar de una capa de texto editable.
El contenido vectorial que no es texto aún se convierte en capas de forma como antes, y si el archivo de Illustrator contiene ambos, se obtendrá una mezcla de capas de texto y de forma.
Únete a la conversación en nuestra comunidad After Effects (Beta) sobre compatibilidad con texto editable de archivos de Illustrator.
El contenido SVG del portapapeles ahora se puede pegar en After Effects usando Edición > Pegar. El contenido se importa como capas de forma nativas y editables que están listas para animar, sin necesidad de pasos de importación intermedios.
Copiar contenido de Illustrator
Abrir la ilustración en Adobe Illustrator.
Confirme que la preferencia Incluir código SVG esté seleccionada.
- macOS: Seleccionar Illustrator > Configuración > Gestión del portapapeles y seleccionar Incluir código SVG.
- Windows: Seleccione editar > Preferencias > Gestión del portapapeles y seleccione Incluir código svg.
Seleccionar la ilustración que se desea copiar.
Convertir cualquier texto SVG en curvas antes de copiarlo, ya que el texto SVG no es compatible al pegarlo.
SeleccioneEditar > Copiar.
Cambie a After Effects y realice una de las siguientes acciones según el estado del proyecto:
- Si no hay ningún proyecto abierto, seleccione Editar > Pegar para crear un nuevo proyecto con una composición que contenga el contenido SVG como una capa de forma.
- Si hay un proyecto abierto pero no hay ninguna composición seleccionada, seleccionar Editar > Pegar para crear una nueva composición en el proyecto actual que contenga el contenido pegado.
Si se selecciona una composición en After Effects, seleccione Edición > Pegar para añadir el contenido SVG como una nueva capa de forma en esa composición.
Pegar SVG desde otras aplicaciones
El contenido SVG copiado desde cualquier aplicación que escriba SVG en el portapapeles del sistema se puede pegar usando el mismo flujo de trabajo Edición > Pegar. La compatibilidad depende de si la aplicación de origen coloca datos SVG válidos en el portapapeles.
Crear impresionantes animaciones 3D en After Effects
Anima personajes e ilustraciones, añade movimiento al texto y mucho más.