Efeito Máscara de diferença de cor

Observação:

Embora os efeitos de mascaramento de cor incorporados no After Effects possam ser úteis para alguns casos, convém tentar fazer mascaramento com o Keylight antes de tentar usar esses efeitos de mascaramento embutidos. Alguns efeitos de mascaramento foram substituídos por efeitos mais modernos, como o Keylight.

Para obter informações sobre o mascaramento em geral, incluindo links para tutoriais e outros recursos, consulte Introdução e recursos de mascaramento.

O efeito Máscara de diferença de cor cria transparência dos pontos de partida opostos dividindo uma imagem em dois foscos, Parcial fosco A e Parcial fosco B. O Parcial fosco B se baseia na transparência da cor chave especificada, e o Parcial fosco A na transparência em áreas da imagem que não contêm uma segunda cor diferente. Ao combinar dois foscos em um terceiro fosco, chamado de fosco alfa a Máscara de diferença de cor cria valores bem definidos de transparência.

A Máscara de diferença de cor produz um mascaramento de alta qualidade para todos os itens de gravação bem iluminados filmados contra uma tela azul ou uma tela verde e funciona especialmente bem com imagens que contêm áreas transparentes ou semitransparentes, como fumaça, sombras ou vidro.

Esse efeito funciona com cor a 8 bpc e 16 bpc.

Use o efeito Máscara de diferença de cor

  1. Selecione a camada que deseja tornar parcialmente transparentes e escolha Efeito > Mascaramento > Máscara de diferença de cor.

    Observação:

    Para usar um dos conta-gotas no painel Camada, escolha Máscara de diferença de cor no menu Exibir no painel Camada.

  2. No painel Controles do efeito, escolha Fosco corrigido no menu Exibir. Para ver e comparar a imagem de origem, os dois foscos parciais e o fosco final ao mesmo tempo, escolha [A, B, Fosco] Corrigido, Final no menu Exibir. Outras visualizações disponíveis no menu Exibir está descritas na etapa 10.
  3. Selecione a cor chave apropriada: para remover uma tela azul, use a cor azul padrão. Para remover uma tela que não seja azul, selecione uma cor chave de uma das seguintes maneiras:
    • Conta-gotas de miniatura: selecione e clique no painel Composição ou na imagem original em miniatura em uma área correta.

    • Conta-gotas de cores de máscara: selecione e clique no painel Composição ou Camada em uma área correta.

    • Amostra de cor da máscara: clique para selecionar uma cor do espaço de cores especificado.

    Observação:

    As ferramentas de conta-gotas movem os controles deslizantes adequadamente. Use os controles deslizantes da etapa 9 para definir os resultados de mascaramento.

  4. Clique no botão fosco para exibir o fosco final combinado na miniatura da máscara.
  5. Selecione o conta-gotas Preto, clique na miniatura do fosco na área mais clara de preto para especificar as áreas transparentes. Os valores de transparência na miniatura e no painel Composição são ajustados.
  6. Selecione o conta-gotas Preto, clique na miniatura do fosco na área mais escura de branco para especificar as áreas opacas. Os valores opacos na miniatura e no painel Composição é ajustado.

    Observação:

    Para produzir a melhor máscara possível, torne as áreas em preto e branco o mais diferentes possível para que a imagem mantenha a maior quantidade de tons de cinza possível.

  7. Selecione uma precisão correspondente do menu Precisão de correspondência de cores. Escolha Mais rápido, a menos que você use uma tela que não seja uma cor primária (vermelho, azul ou amarelo). Para essas telas, escolha Mais precisos, o que aumenta o tempo de renderização, mas produz melhores resultados.
  8. Para ajustar mais valores de transparência, repita as etapas 5 e 6 para um ou os dois foscos parciais. Clique no botão Fosco parcial B ou Fosco parcial A para selecionar uma máscara parcial e repita as etapas.
  9. Ajuste os valores de transparência para cada fosco parcial e para o fosco final arrastando um ou mais dos seguintes controles deslizantes na seção Controles de fosco:
    • Os controles deslizantes ajustam os níveis de transparência de cada fosco. Você pode ajustar os mesmos níveis usando o conta-gotas Preto.

    • Os controles deslizantes ajustam os níveis opacos de cada fosco. Você pode ajustar os mesmos níveis usando o conta-gotas Branco.

    • Os controles deslizantes Gama determinam a proximidade em que os valores de transparência seguem uma progressão linear. Em um valor de 1 (padrão), o progresso é linear. Outros valores produzem progressões não lineares para ajustes ou efeitos visuais específicos.

  10. Ao ajustar foscos individuais, escolha no menu Exibir comparar os foscos com e sem ajustes:
    • Escolha Não corrigido para ver um fosco sem ajustes.

    • Escolha Corrigido para exibir um fosco com todos os ajustes.

  11. Antes de fechar o painel Controles do efeito, selecione Saída final no menu Exibir. A saída final deve ser selecionada para o After Effects renderizar com a transparência.

    Observação:

    Para remover os traços da cor chave refletida da imagem, aplique o Supressor de derramamento usando Melhor para precisão de cores. Se a imagem ainda estiver muito colorida, aplique o efeito Redução simples ou Redução de fosco.

Efeito Máscara de cor

Observação:

A partir da versão de outubro de 2013 do After Effects CC, o efeito Chave de cor foi movido para a categoria de efeitos Obsoleta. Use outros efeitos como o efeito Keylight em vez disso.

Para obter informações sobre o mascaramento em geral, incluindo links para tutoriais e outros recursos, consulte Introdução e recursos de mascaramento.

O efeito Máscara de cor codifica todos os pixels de imagens que são similares a uma cor chave especificada. Esse efeito altera somente o canal alfa de uma camada.

Esse efeito funciona com cor a 8 bpc e 16 bpc.

Codificar uma cor simples com o efeito Máscara de cor

  1. Selecione a camada que deseja tornar parcialmente transparentes e escolha Efeito > Mascaramento > Máscara de cores.
  2. No painel Controles do efeito, especifique uma cor chave de duas maneiras:
    • Clique na amostra Cor chave cor de código para abrir a caixa de diálogo Cores e especifique uma cor.

    • Clique no conta-gotas e em uma cor na tela.

  3. Arraste o controle deslizante Tolerância de cor para especificar a gama de cores a remover. Valores mais baixos removem um intervalo menor de cores por cor chave próximo à cor chave. Valores mais baixos removem um intervalo maior de cores por cor chave.
  4. Arraste o controle deslizante Borda fina para ajustar a largura da borda da área codificada. Valores positivos aumentam a máscara, aumentando a área transparente. Valores negativos diminuem a máscara, diminuindo a área transparente.
  5. Arraste o controle deslizante Difusão de borda para especificar a suavidade das bordas. Valores mais altos criam uma borda mais suave, mas levam mais tempo para renderizar.

Efeito Gama de cores

Observação:

Embora os efeitos de mascaramento de cor incorporados no After Effects possam ser úteis para alguns casos, convém tentar fazer mascaramento com o Keylight antes de tentar usar esses efeitos de mascaramento embutidos. Alguns efeitos de mascaramento foram substituídos por efeitos mais modernos, como o Keylight.

Para obter informações sobre o mascaramento em geral, incluindo links para tutoriais e outros recursos, consulte Introdução e recursos de mascaramento.

O efeito Gama de cores cria transparências codificando um intervalo especificado de cores no espaço de cores Lab, YUV ou RGB. Você pode usar essa chave em telas que consistem em mais de uma cor ou em telas azuis ou em telas verdes que foram iluminadas de maneira desigual e contêm sombras diferentes da mesma cor.

Esse efeito funciona com cor a 8 bpc.

Efeito Gama de cores
A tela verde mal iluminada (superior à esquerda) e a camada de plano de fundo (inferior à esquerda) são combinadas usando a Chave da gama de cores (inferior à direita).

Use o efeito Gama de cores

  1. Selecione a camada que deseja tornar parcialmente transparente e escolha Efeito > Mascaramento > Gama de cores.
  2. Escolha Lab, YUV ou RGB no menu Espaço de cores. Escolha Lab, YUV ou RGB no menu Espaço de cores. Se tiver problemas para isolar o termo usando um espaço de cores, tente usar um diferente.
  3. Selecione o conta-gotas Chave de cor e clique na miniatura do fosco para selecionar a área correspondente a uma cor no painel Composição que deseja tornar transparente. Normalmente, a primeira cor é aquela que abrange a área maior da imagem.

    Observação:

    Para usar um dos conta-gotas no painel Camada, escolha Gama de cores no menu Exibir no painel Camada.

  4. Selecione o conta-gotas com sinal de adição, clique em outras áreas na miniatura do fosco para adicionar outras cores ou sombras à gama de cores codificados para transparência.
  5. Selecione o conta-gotas com sinal de subtração, clique nas áreas na miniatura do fosco para subtrair outras cores ou sombras da gama de cores codificadas.
  6. Arraste o controle deslizante Imprecisão para suavizar as bordas entre áreas transparentes e opacas.
  7. Use os controles deslizantes nos controles Mín e Máx para definir a gama de cores selecionado com o conta-gotas com sinal de mais e de menos. Os controles deslizantes L, Y e R controlam o primeiro componente do espaço de cores especificado; os controles deslizantes U e G controlam o segundo componente; e os controles deslizantes b. V e B controlam o terceiro componente. Arraste os controles deslizantes Mín para definir o início da gama de cores. Arraste os controles deslizantes Máx para definir o final da gama de cores.

Efeito Fosco de diferença

O efeito Fosco de diferença cria transparências comparando uma camada de origem com uma camada de diferença e codificando pixels na camada que correspondam à posição e à cor na camada de diferença. Normalmente, ele é usado para remover um plano fundo estático por trás de um objeto em movimento, que é então colocado em um plano de fundo diferente. Geralmente, a camada de diferença é simplesmente um quadro de gravação de plano de fundo (antes de mover o objeto que entrou na cena). Por esse motivo, o efeito Fosco de diferença é mais adequado para cenas que foram filmadas com uma câmera estacionária e plano de fundo estático.

Esse efeito funciona com cor a 8 bpc e 16 bpc.

Efeito Chave de fosco de diferença
Efeito Chave de fosco de diferença

A. Imagem original B. Imagem do fundo C. nova imagem do fundo D. Imagem composta final 

Usar o efeito Fosco de diferença

  1. Selecione uma camada de gravação animada na camada de origem.
  2. Na camada de origem, localize um quadro que contenha apenas plano de fundo e salve o quadro de fundo como um arquivo de imagem. (Consulte Renderizar e exportar um único quadro de uma composição.)
  3. Importe o arquivo de imagem para o After Effects e adicione-o à composição.

    A imagem importada se torna a camada de diferença. Certifique-se de que a duração seja no mínimo tão longa quanto a duração da camada de origem.

    Observação:

    Se a filmagem não tiver um quadro de plano de fundo completo, talvez seja possível montar o plano de fundo combinando partes de vários quadros no After Effects ou no Photoshop. Por exemplo, é possível usar a ferramenta Carimbo para obter uma amostra de fundo em um quadro, e depois pintar a amostra na parte do plano de fundo em outro quadro.

  4. Desative a exibição de camada de diferença clicando no botão Vídeo do painel Linha de tempo.
  5. Verifique se a camada de origem está selecionada, e depois selecione Efeito > Máscara > Fosco de diferença.
  6. No painel Controles do efeito, escolha Saída final ou Somente fosco no menu Exibir. (Use a exibição Somente fosco para verificar se há furos na transparência. Para preencher os furos indesejados após concluir o processo de mascaramento, consulte Fechar um furo em um fosco.)
  7. Selecione o arquivo de plano de fundo no menu Camada de diferença.
  8. Se a camada de diferença não tiver o mesmo tamanho que a camada de origem, escolha um dos controles seguintes no menu Se os tamanhos das camadas forem diferentes:

    Centro

    Coloca a camada de diferença no centro da camada de origem. Se a camada de diferença for menor que a camada de origem, o resto da camada é preenchida com preto.

    Esticar para ajustar

    Estica ou diminui a camada de diferença para o tamanho da camada de origem. As imagens de plano de fundo podem ficar distorcidas.

  9. Ajuste o controle deslizante Tolerância de correspondência para especificar a quantidade de transparência com base no quão rigorosamente as cores devem corresponder entre camadas. Valores mais baixos geram menos transparência; valores mais altos produzem mais transparência.
  10. Ajuste o controle deslizante Suavização de correspondência para suavizar as bordas entre áreas transparentes e opacas. Valores mais altos tornam os pixels correspondentes mais transparentes, mas não aumentam o número de pixels correspondentes.
  11. Se a máscara ainda contiver pixels estranhos, ajuste o controle deslizante Desfoque antes de diferença. Esse controle deslizante suprime ruídos desfocando um pouco as camadas antes da comparação ser efetuada.

    Observação:

    O desfoque ocorre somente para comparação e não desfoca a saída final.

  12. Antes de fechar o painel Controles do efeito, certifique-se de selecionar Saída final no menu Exibir para garantir que o After Effects renderize a transparência.

Efeito Extrair

O efeito Extrair cria transparências codificando um intervalo de brilho especificado, com base em um histograma de um canal especificado. É mais adequado usá-lo para criar transparência em uma imagem feita contra um plano de fundo preto ou branco ou um plano de fundo que seja escuro ou claro, mas seja composta por mais de uma cor.

Observação:

Os controles para esse efeito são semelhantes aos controles do efeito Extrair no Adobe Premiere Pro, mas a finalidade e os resultados do efeito são diferentes.

Esse efeito funciona com cor a 8 bpc e 16 bpc.

Usar o efeito Extrair

No painel Controles do efeito, o efeito Extrair exibe um histograma de um canal especificado no menu Canal. O histograma exibe uma representação dos níveis de brilho da camada, indicando o número relacionado de pixels em cada nível. Da esquerda para a direita, o histograma se estende do mais escuro (um valor de 0) ao mais claro (um valor de 255).

Usando a barra de controle de transparência abaixo do histograma, é possível ajustar o intervalo de pixels que são transparentes. A posição e a forma de barra em relação ao histograma determinam a transparência. Os pixels correspondentes à área coberta pela barra continuam opacos; os pixels correspondentes às áreas não cobertas pela barra se tornam transparentes.

  1. Selecione a camada que deseja tornar parcialmente transparente e escolha Efeito > Mascaramento > Extrair.
  2. Se estiver codificando as áreas claras ou escuras, escolha Luminância no menu Canal. Para criar efeitos visuais, escolha Vermelho, Verde, Azul ou alfa.
  3. Ajuste a intensidade da transparência arrastando a barra de controle de transparência das seguintes maneiras:
    • Arraste as alças de seleção da parte superior esquerda ou direita para definir o comprimento da barra e para diminuir ou aumentar o intervalo de transparência. Também é possível definir o comprimento movendo os controles deslizantes Ponto branco e Ponto preto. Valores acima do ponto branco e abaixo do ponto preto se tornam transparentes.

    • Arraste as alças de seleção da parte inferior direita ou esquerda de afilar a barra. O afilamento da barra à esquerda afeta a suavidade da transparência nas áreas mais escuras da imagem; afilar à direita afeta a suavidade das áreas mais claras. Também é possível definir os níveis de suavidade ajustando Suavidade de branco (áreas mais claras) e a Suavidade de preto (áreas mais escuras).

    Observação:

    Para afilar as bordas da barra de controle de transparência, diminua a barra de transparência primeiro.

    • Arraste a barra inteira para a esquerda ou para a direita para posicioná-la no histograma.

Efeito Chave interna/externa

Observação:

Embora os efeitos de mascaramento de cor incorporados no After Effects possam ser úteis para alguns casos, convém tentar fazer mascaramento com o Keylight antes de tentar usar esses efeitos de mascaramento embutidos. Alguns efeitos de mascaramento foram substituídos por efeitos mais modernos, como o Keylight.

Para obter informações sobre o mascaramento em geral, incluindo links para tutoriais e outros recursos, consulte Introdução e recursos de mascaramento.

O efeito Chave interna/externa isola um objeto de primeiro plano do seu plano de fundo.

Esse efeito funciona com cor a 8 bpc e 16 bpc.

Use o efeito Chave interna/externa

Para usar a Chave interna/externa, crie uma máscara para definir a borda interna e externa do objeto que deseja isolar. A máscara pode ser bem áspero; ela não precisa se ajustar exatamente em torno das bordas do objetos.

Além da máscara de um objeto com borda suave de seu plano de fundo, a Chave interna/externa altera as cores da borda para remover a contaminação das cores de fundo. Esse processo de descontaminação de cores determina a contribuição do plano de fundo para a cor de cada pixel de borda, e remove essa contribuição, removendo, assim, o halo que pode aparecer quando um objeto com borda suave se torna fosco contra um novo plano de fundo.

  1. Selecione borda do objeto que deseja extrair seguindo um destes procedimentos:
    • Desenhe uma única máscara fechada próximo à borda do objeto e selecione a máscara no menu Primeiro plano e deixe o menu Plano de fundo definido como Nenhum. Ajuste Raio do realce de máscara única para controlar o tamanho da borda em torno da máscara. Esse método funciona bem apenas em objetos com bordas simples.

    • Desenhe duas máscaras fechadas: uma máscara interna bem dentro do objeto e uma máscara externa fora do objeto. Verifique se todas as áreas distorcidas ou inconstantes do objeto estão dentro dessas duas máscaras. Selecione a máscara interna no menu Primeiro plano e a máscara externa no menu Plano de fundo.

    Observação:

    Verifique se o modo de mascaramento de todas as máscaras está definido como Nenhum.

  2. Se desejar, mova as máscaras aos redor para encontrar o local que proporciona os melhores resultados.
  3. Para extrair mais de um objeto ou para criar um furo em um objeto, desenhe máscaras adicionais e as selecione nos menus Primeiro plano adicional e Plano de fundo adicional. Por exemplo, para remover o cabelo de uma pessoa voando ao vento contra um céu azul, desenhe a máscara interna na cabeça, desenhe a máscara externa em torno da borda externa do cabelo e desenhe uma máscara adicional em torno da brecha no cabelo onde você pode visualizar o céu. Selecione a máscara no menu Primeiro plano adicional para extrair a brecha e remover a imagem do fundo.
  4. Crie máscaras adicionais abertas ou fechadas para limpar outras áreas da imagem e, em seguida, selecione-as no menu Limpar primeiro plano ou Limpar segundo plano. As máscaras Limpar primeiro plano aumentam a opacidade ao longo da máscara; as máscaras Limpar segundo plano diminuem a opacidade ao longo da máscara. Use as opções Raio do pincel ou Pressão do pincel para controlar o tamanho e a densidade de cada traçado.

    Observação:

    Você pode selecionar uma máscara de Plano de fundo (externa) como uma máscara de fundo Limpar segundo plano das partes do plano de fundo da imagem.

  5. Defina Borda fina para especificar o quanto da borda do fosco é afetado pelo mascaramento. Um valor positivo move a borda para longe da região transparente, aumentando a área transparente; um valor negativo move a borda para a área transparente e aumenta o tamanho da área do primeiro plano.
  6. Aumente os valores de Difusão de borda para suavizar as bordas da área codificada. Os valores altos de Difusão de borda levam mais tempo para renderizar.
  7. Especifique o Limite de borda, que é um corte suave para remover pixels de baixa opacidade que podem causar ruídos indesejados no plano de fundo da imagem.
  8. Selecione Inverter extração para inverter as áreas de primeiro plano e de plano de fundo.
  9. Defina Mesclar com original para especificar o grau em que a imagem extraída se mistura com a imagem original.

Efeito Máscara de cor linear

Observação:

Embora os efeitos de mascaramento de cor incorporados no After Effects possam ser úteis para alguns casos, convém tentar fazer mascaramento com o Keylight antes de tentar usar esses efeitos de mascaramento embutidos. Alguns efeitos de mascaramento foram substituídos por efeitos mais modernos, como o Keylight.

Para obter informações sobre o mascaramento em geral, incluindo links para tutoriais e outros recursos, consulte Introdução e recursos de mascaramento.

Máscaras lineares criam um intervalo de transparência em uma imagem. Uma máscara linear compara cada pixel na imagem com as cores chave especificadas por você. Se a cor de um pixel se aproximar bastante da cor chave, ela se tornará completamente transparente. Os pixels que não correspondem também se tornam menos transparente, e os pixels que não correspondem de maneira alguma ficam opacos. O intervalo de valores de transparência, consequentemente, forma uma progressão linear.

O efeito Máscara de cor linear usa RGB, matiz ou informações de croma para criar transparência de uma cor chave especificada.

Esse efeito funciona com cor a 8 bpc, 16 bpc e 32 bpc.

Aplicar o efeito Máscara de cor linear

No painel Controles do efeito, o Máscara de cor linear exibe duas imagens em miniatura; a imagem à esquerda da miniatura representa uma imagem de origem inalterada, e a imagem à direita representa a exibição selecionada no menu Exibir.

É possível definir a cor chave, a tolerância de correspondência e a suavidade correspondente. A tolerância de correspondência especifica o quanto os pixels devem corresponder à cor chave antes que comecem a se tornar transparentes. A suavidade correspondente controla a suavidade das bordas entre a imagem e a cor chave.

Você também poderá reaplicar essa máscara para preservar uma cor que se tornou transparente pela primeira aplicação da máscara. Por exemplo, se remover a tela de cor azul média, você poderá perder parte ou toda a parte azul clara da roupa que o seu objeto está vestindo. É possível recuperar a cor azul clara aplicando outra instância da Máscara de cor linear e escolher Manter esta cor no menu Operação de chave.

  1. Selecione uma camada como a camada de origem, escolha Efeito > Máscara > Máscara de cor linear.
  2. No painel Controles do efeito, escolha Cores chave no menu Operação de chave.
  3. Escolha um espaço de cores no menu Corresponder cores. Na maioria dos casos, use a configuração RGB padrão. Se tiver problemas para isolar o termo usando um espaço de cores, tente usar um espaço de cores diferente.
  4. No painel Controles do efeito, escolha a Saída final no menu Exibir. A exibição escolhida aparece na miniatura à direita e no painel Composição. Para exibir outros resultados, trabalhe em uma das outras exibições:

    Somente origem

    Mostra a imagem original sem a máscara aplicada.

    Somente fosco

    Mostra a máscara do canal alfa. Use essa exibição para ver se há furos na transparência. Para preencher furos indesejados após concluir o processo de mascaramento, consulte Fechar um furo em um fosco.

  5. Selecione uma cor chave de uma das seguintes maneiras:
    • Selecione o conta-gotas Miniatura, clique em uma área apropriada no painel Composição ou na imagem original em miniatura.

    • Selecione o conta-gotas Cor chave e clique em uma área apropriada no painel Composição ou no painel Camada.

    • Para visualizar a transparência de cores diferentes, selecione o conta-gotas Cor chave, mantenha pressionada a tecla Alt (Windows) ou a tecla Option (Mac OS), e mova o ponteiro para áreas diferentes do painel Composição ou a imagem original em miniatura. A transparência da imagem no painel Composição muda quando o ponteiro se move sobre cores ou máscaras diferentes. Clique para selecionar a cor.

    • Clique na amostra Cor chave para selecionar uma cor no espaço de cores especificado. A cor selecionada se torna transparente.

      observação: As ferramentas de conta-gotas movem os controles deslizantes adequadamente. Use os controles deslizantes das etapas 6 e 7 para definir os resultados de mascaramento. Para usar conta-gotas no painel Camada, escolha Máscara de cor linear no menu Exibir no painel Camada.

  6. Ajuste a tolerância de correspondência de uma das seguintes maneiras:
    • Selecione o conta-gotas de Adição (+) ou Subtração (-) e clique em uma cor na imagem esquerda da miniatura. O conta-gotas Adição adiciona a cor especificada à gama de cores chave, aumentando a tolerância de correspondência e o nível de transparência. O conta-gotas Subtração subtrai a cor especificada da gama de cores chave, diminuindo a tolerância de correspondência e o nível de transparência.

    • Arraste o controle deslizante de tolerância de correspondência. Um valor de 0 torna a imagem inteira opaca; um valor 100 torna toda a imagem transparente.

  7. Arraste o controle deslizante Suavização de correspondência para suavizar a tolerância de correspondência afilando o valor de tolerância. Geralmente, os valores abaixo de 20% produzem os melhores resultados.
  8. Antes de fechar o painel Controles do efeito, certifique-se de selecionar Saída final no menu Exibir para garantir que o After Effects renderize a transparência.

Preservar uma cor depois de aplicar a Máscara de cor linear

  1. No painel Controles do efeito ou do painel Linha de tempo, desative todas as instâncias atuais de máscaras ou dos efeitos de fosco desmarcando a opção Efeito à esquerda do nome da máscara ou do nome da ferramenta. Desmarcar a opção faz com que a imagem original apareça no painel Composição para que você possa selecionar uma cor para preservar.
  2. Escolha Efeito > Máscara > Máscara de cor linear. Um segundo grupo de controles de Máscara de cor linear aparece no painel Controles do efeito abaixo do primeiro conjunto.
  3. No painel Controles do efeito, escolha Manter cores no menu principal Operação de chave.
  4. Selecione a cor que deseja manter.
  5. Na primeira aplicação do efeito Máscara de cor linear, escolha a Saída final no menu exibir do painel Controles do efeito e ative novamente outras instâncias do efeito Chave de cor linear para examinar a transparência. Talvez seja necessário ajustar as cores ou reaplicar a máscara uma terceira vez para obter os resultados desejados.

Efeito Chave de luma

Observação:

A partir da versão de outubro de 2013 do After Effects CC, o efeito Chave de luma foi movido para a categoria de efeitos Obsoletos, e os usuários são recomendados a usar outros efeitos, como o efeito Keylight.

Para obter informações sobre o mascaramento em geral, incluindo links para tutoriais e outros recursos, consulte Introdução e recursos de mascaramento.

O efeito Chave de luma codifica todas as áreas de uma camada com uma luminância ou um brilho especificado. A configuração de qualidade da camada não influencia o efeito Chave de luma.

Use esse efeito se o objeto a partir do qual deseja criar uma máscara tiver uma luminância muito diferente do fundo. Por exemplo, se você quiser criar um fosco para notas musicais em um plano de fundo branco, é possível remover os valores mais claros; as notas musicais escuras tornam-se as únicas áreas opacas.

Esse efeito funciona com cor a 8 bpc e 16 bpc.

Efeito Chave de luma
O plano de fundo branco do original (superior à esquerdo e inferior à esquerda) é removido usando a Chave de luma e composta em camada subjacente (inferior à direita).

Codificar um valor de luminância com o efeito Chave de luma

  1. Selecione a camada que deseja tornar parcialmente transparentes e escolha Efeito > Mascaramento > Chave de luma.
  2. Selecione um Tipo de chave para especificar o intervalo a ser codificado.
  3. Arraste o controle deslizante Limite no painel Controles do efeito para definir o valor de luminância em que deseja basear o fosco.
  4. Arraste o controle deslizante Tolerância para especificar o intervalo de valores a ser codificado. Valores mais baixos removem um intervalo menor de valores perto do limite. Valores mais altos removem um intervalo maior de valores.
  5. Arraste o controle deslizante Borda fina para ajustar a largura da borda da área codificada. Valores positivos tornam a máscara crescer, aumentando a área transparente. Valores negativos diminuem a máscara.
  6. Arraste o controle deslizante Difusão de borda para especificar a suavidade das bordas. Valores mais altos criam uma borda mais suave, mas levam mais tempo para renderizar.

Efeito Supressor de derramamento

Observação:

Desde a versão de junho de 2014 do After Effects CC, o efeito Supressor de espalhamento foi movido para a categoria efeitos obsoletos e recomenda-se que os usuários usem o efeito Supressor de espalhamento avançado.

Efeito Limpador de chave e Supressor de espalhamento avançado

Efeito Limpador de chave

O efeito Limpador de chave recupera detalhes do canal alfa de uma cena delimitada por um efeito de codificação típico, incluindo recuperar detalhes perdidos em produtos manufaturados de compactação.

Observação:

Se você perceber que efeitos de semitransparência indesejados sejam estendidos ao longo das bordas que devem ser em que deve ser suavizadas, use uma máscara de efeito (com um pouco de suavização de máscara) para restringir o efeito Limpador de chave para a área desejada.

Efeito Supressor de derramamento avançado

O efeito avançado de supressor de espalhamento remove o espalhamento de cor em um objeto de primeiro plano de fundo colorido usado para fechar cores.

O efeito avançado de supressor de espalhamento tem dois métodos para exclusão de espalhamento:

  1. Padrão - o método Padrão é mais simples, detecta automaticamente a cor-chave dominante, e requer menos entrada do usuário.
  2. Ultra - o método Ultra é baseado na exclusão de espalhamento em vigor Ultra Key no Premiere Pro. Consulte a seção Chave ultra no Premiere Pro para obter detalhes sobre a Chave ultra.

Uma maneira fácil de aplicar esses efeitos é usando a predefinição de animaçãoLimpador Keylight + Limpador de chave +Supressor de espalhamento.

Observação:

Desde a versão de junho de 2014 do After Effects CC, o efeito Supressor de espalhamento foi movido para a categoria efeitos obsoletos e recomenda-se que os usuários usem o efeito Supressor de espalhamento avançado.

Efeito Keylight

O After Effects inclui vários efeitos de máscara embutidos, bem como o efeito vencedor de um prêmio Keylight que surpreende no mascaramento de cor de qualidade profissional. Para obter informações sobre o efeito Keylight, consulte a documentação na pasta em que o plug-in do Keylight está instalado. (Consulte Plug-ins.)

Para obter informações sobre o mascaramento em geral, incluindo links para tutoriais e outros recursos, consulte Introdução e recursos de mascaramento.

Observação:

A propriedade Cor-chave já está vinculada com uma expressão para propriedade de cor da tela doefeito de Keylight e não precisará ser alterado a menos que você deseje usar uma cor diferente para o processo de despill. Para usar uma cor diferente para o processo de despill, apenas desativar ou remova a expressão Keylight.

Use a predefinição de animação do Keylight + Limpador de chave + Supressor de espalhamento avançado

Predefinição do Keylight
Predefinição do Keylight

Efeitos Keylight, Paleta chave e Supressor de espalhamento avançado
Efeitos Keylight, Paleta chave e Supressor de espalhamento avançado


Siga as etapas a seguir para aplicar o efeito Keylight com os efeitos Limpador de chave e Supressor de espalhamento avançado:

  1. Use a configuração de animação Keylight + Key Cleaner + Advanced Spill Suppressor (na pasta Imagem-Recursos nas configurações de animação) para aplicar os três efeitos em ordem. O efeito Advanced Spill Suppressor fica desativado por padrão para permitir uma amostragem na cor no efeito Keylight ou caso a gravação não possua uma cor para ser removida.
  2. Use o conta-gotas de cor da tela do efeito de Keylight a cor da camada no painel de composição. Definir outras configurações de efeitos de Keylight como de costume obteria os melhores resultados.
  3. Ativar a alternância de efeito para o efeito Supressor de espalhamento avançadopara remover o espalhamento de cor da cena, se necessário.

Observação:

Se você vir alguma semitransparência indesejada ao longo das bordas que devem ser nítidas, use uma máscara de efeito (com um pouco de suavização de máscara) para restringir o Limpador de chave para a área desejada.

Consulte os artigos Difusão da máscara de largura variável e Suavizar as bordas de uma máscara para obter informações sobre a difusão de máscara

Uso dos efeitos Limpador de chave e Supressor de espalhamento avançado com outros efeitos de aplicação de máscara   

Execute as etapas a seguir para aplicar os efeitos Supressor de espalhamento avançado e Paleta chave em um efeito de codificação diferente do efeito Keylight:

  1. Aplicar Efeito da camada.
  2. Definir o efeito ao equivalente da configuração Resultado indeterminado do efeito doKeylight, assim o efeito de aplicação de máscara oferece o resultado RGB completo sem executar sua própria exclusão de espalhamento.
  3. Aplicar o efeito principal da Limpador chave após efeito de codificação.
  4. Aplicar o efeito Supressor de espalhamento avançado do efeito chave da paleta.

Tutorial de aprendizagem

espalhamento-supressor

Assista a este vídeo para saber como obter os melhores resultados de codificação a partir de gravação de tela verde ruim ou compactada com o novo efeito Limpador de chave e remover o espalhamento de cores com os controles do Supressor de espalhamento avançado.


Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online