Создавайте, открывайте, редактируйте, сохраняйте и восстанавливайте файлы в Dreamweaver. Создавайте шаблоны и открывайте связанные файлы.

Dreamweaver предлагает гибкую среду для работы с различными веб-документами. Помимо HTML-документов, можно создавать и открывать различные текстовые документы, например JavaScript, PHP и таблицы каскадных стилей (CSS).

Dreamweaver предоставляет несколько способов создания нового документа. Можно создать следующие документы:

  • новый пустой документ или шаблон;

  • документ на основе макета страницы, поставляемого с Dreamweaver, в том числе более тридцати макетов на основе CSS;

  • документ, созданный по одному из существующих шаблонов.

    Можно также задать установки документа. Например, если обычно используется один тип документа, можно для новых страниц задать этот тип в качестве типа документа по умолчанию.

    Можно легко задавать такие свойства документа, как метатеги, заголовок документа, цвета фона, и некоторые другие свойства страницы в представлении «Дизайн» или «Код».

Типы файлов, поддерживаемые Dreamweaver

Dreamweaver позволяет работать с различными типами файлов. Исходным форматом рабочих файлов является HTML. HTML-файлы — или файлы языка гипертекстовой разметки — содержат язык на основе тегов, который используется для отображения веб-страницы в браузере. HTML-файлы сохраняются с расширением .html или .htm. По умолчанию Dreamweaver сохраняет файлы с расширением .html.

В Dreamweaver можно создавать и редактировать веб-страницы на основе HTML5. Также доступны макеты шаблонов для создания HTML5-страниц с нуля.

Ниже перечислены другие стандартные типы файлов, которые доступны для работы в Dreamweaver.

CSS

Файлы каскадных таблиц стилей имеют расширение .css. Эти файлы используются для форматирования HTML-содержимого и управляют расположением различных элементов страницы.

GIF

Файлы формата графического обмена (GIF) имеют расширение .gif. Формат GIF — это используемый в Интернете популярный графический формат для создания рисованного изображения, логотипов, изображений с прозрачными областями и анимации. Изображения в формате GIF содержат не более 256 цветов.

JPEG

Файлы формата JPEG (по имени объединенной группы экспертов по машинной обработке фотографических изображений) имеют расширение .jpg и обычно используются для работы с фотографиями или высококачественными цветовыми изображениями. Формат JPEG наилучшим образом подходит для цифровых или сканированных изображений, изображений, использующих текстуры, изображений с плавными переходами цвета и любых изображений, которым необходимо более 256 цветов.

XML

Файлы в формате расширяемого языка разметки имеют расширение .xml. Файлы содержат данные в исходной форме, которые подлежат форматированию с использованием языка XSL (расширяемого языка стилей).

Диалоговое окно «Создать документ»

В диалоговом окне «Создать документ» отображаются все поддерживаемые типы файлов документов, включая PHP, XML и SVG.

Из этого диалогового окна можно также работать с предустановленными макетами, шаблонами и фреймворками.

Примечание.

Все представленные макеты шаблонов разработаны для поддержки адаптивных веб-сайтов и совместимы со стандартом HTML-5.

Создание макета HTML на основе пустой страницы

Можно создать страницу, которая содержит предварительно разработанный макет CSS, или создать пустую страницу, а затем собственный макет.

  1. Выберите Файл > Создать.

  2. В категории Создать документ выберите тип создаваемой страницы в столбце Тип документа. Например, для создания простой страницы HTML выберите HTML.

  3. Выберите тип документа из всплывающего меню Тип документа. В большинстве случаев следует использовать тип по умолчанию — HTML5.

  4. Выберите дополнительные параметры в зависимости от типа страницы, которую необходимо создать.

    • Нет. Выберите этот вариант, если нужно создать простую веб-страницу без использования какого-либо фреймворка.
    • Bootstrap. Шаблоны Bootstrap представляют собой заранее определенные макеты, использующие фреймворк Bootstrap. Выберите этот вариант, если необходимо создать адаптивную веб-страницу с помощью фреймворка Bootstrap.

    Примечание.

    Если планируется создание адаптивных веб-страниц, выберите фреймворк Bootstrap.

  5. Если не используется фреймворк:

    • Название документа. Если ввести название документа в этом поле, то Dreamweaver автоматически добавит его в раздел <head> документа.
    • Тип документа. Выберите тип документа из всплывающего меню «Тип документа». В большинстве случаев следует использовать тип по умолчанию — HTML5.

    Выбор одного из определений типа документа XHTML в меню «Тип документа» (DTD) делает страницу совместимой с XHTML. Например, можно сделать HTML-документ совместимым с XHTML, выбрав в меню тип «Переходный XHTML 1.0» или «Строгий XHTML 1.0». XHTML (Расширяемый язык гипертекстовой разметки) представляет собой переработку HTML, используемую в качестве приложения XML. Применение XHTML предоставляет преимущества XML, одновременно обеспечивая обратную и будущую совместимость веб-документов.

    Примечание.

    Подробную информацию о XHTML можно найти на странице World Wide Web Consortium (W3C), которая содержит спецификацию XHTML 1.1 — модульного XHTML (www.w3.org/TR/xhtml11/) и XHTML 1.0 (www.w3c.org/TR/xhtml1/), а также сайты для проверки XHTML для файлов, размещенных в сети Интернет (http://validator.w3.org/) и локально (http://validator.w3.org/file-upload.html).

    • Присоединить CSS. Присоединить существующий макет CSS к странице.  Для этого щелкните по значку «Присоединить таблицу стилей»  рядом с областью «Присоединить CSS-файл» и выберите существующую таблицу стилей CSS.
    Создание новой страницы HTML без использования какого-либо фреймворка
    Создание новой страницы HTML без использования какого-либо фреймворка

    Если необходимо создать новую страницу на основе композиции Photoshop, выберите «Использовать Extract» для создания страницы из композиций Photoshop. 

    При выборе этого варианта откроется панель Extract, где можно загрузить файл PSD и начать создание страницы HTML.

  6. Если необходимо создавать адаптивные веб-страницы с помощью фреймворка Bootstrap:

    • Bootstrap CSS. Возможность создать новый CSS-файл Bootstrap или использовать существующий файл CSS. Если вы используете существующий файл CSS, укажите путь к файлу. Убедитесь, что файл CSS находится в пределах корневой папки сайта.
    • Присоединить CSS. Присоединить существующий макет CSS к странице.  Для этого щелкните по значку «Присоединить таблицу стилей»  рядом с областью «Присоединить CSS-файл» и выберите существующую таблицу стилей CSS.
    • Включить предварительно подготовленный макет. Выберите этот вариант, если у вас уже есть макет. Щелкните «Настройка», чтобы изменить значения сетки и точки останова.
    Создание новой страницы HTML с помощью фреймворка Bootstrap
    Создание новой страницы HTML с помощью фреймворка Bootstrap

    Если необходимо создать новую страницу на основе композиции Photoshop, выберите «Использовать Extract» для создания страницы из композиций Photoshop. 

    При выборе этого варианта откроется панель Extract, где можно загрузить файл PSD и начать создание страницы HTML.

  7. Нажмите кнопку «Настройки», чтобы задать установки документа по умолчанию, как, например, тип документа, кодировка и расширение файла.

  8. Нажмите кнопку «Создать».

  9. Сохраните новый документ (Файл > Сохранить).

  10. В открывшемся диалоговом окне укажите папку, в которой следует сохранить файл.

    Примечание.

    Рекомендуется сохранять файл в месте размещения сайта Dreamweaver.

  11. В поле «Имя файла» введите имя файла.

    Не следует использовать пробелы и специальные символы в наименованиях файлов и папок, а также начинать имя файла с цифры. В частности, не используйте специальные символы (такие как é, ç или ¥), а также знаки пунктуации (такие как двоеточие, косая черта или точка) в именах файлов, которые планируется поместить на удаленный сервер. Многие серверы заменяют данные символы при загрузке файла, что приводит к повреждению ссылок на файл.

Создание пустого шаблона

Можно использовать диалоговое окно «Создать документ» для создания шаблонов Dreamweaver. По умолчанию шаблоны сохраняются в папке Templates сайта.

Примечание.

Нельзя создать шаблон без предварительного создания сайта. Дополнительные сведения о сайтах, а также об их создании см. в разделе О сайтах Dreamweaver.

  1. Выберите Файл > Создать.

  2. В диалоговом окне Создать документ выберите категорию Шаблоны сайта.

  3. Выберите тип документа из всплывающего меню «Тип документа». В большинстве случаев следует использовать тип по умолчанию, «Переходный XHTML 1.0».

    Выбор одного из определений типа документа XHTML в меню «Тип документа» (DTD) делает страницу совместимой с XHTML. Например, можно сделать HTML-документ совместимым с XHTML, выбрав в меню тип «Переходный XHTML 1.0» или «Строгий XHTML 1.0». XHTML (Расширяемый язык гипертекстовой разметки) представляет собой переработку HTML, используемую в качестве приложения XML. Применение XHTML предоставляет преимущества XML, одновременно обеспечивая обратную и будущую совместимость веб-документов.

    Примечание.

    Подробную информацию о XHTML можно найти на странице World Wide Web Consortium (W3C), которая содержит спецификацию XHTML 1.1 — модульного XHTML (www.w3.org/TR/xhtml11/) и XHTML 1.0 (www.w3c.org/TR/xhtml1/), а также сайты для проверки XHTML для файлов, размещенных в сети Интернет (http://validator.w3.org/) и локально (http://validator.w3.org/file-upload.html).

  4. Выберите «Обновлять страницу при изменении шаблона», если необходимо включить автоматическое обновление страницы при изменении шаблона.

  5. Нажмите кнопку «Создать».

  6. Сохраните новый документ (Файл > Сохранить). Если в шаблон еще не добавлены редактируемые области, появится диалоговое окно с соответствующим сообщением. Нажмите «ОК», чтобы закрыть диалоговое окно.

  7. В диалоговом окне «Сохранить как» выберите сайт, в котором нужно сохранить шаблон.
  8. В поле «Имя файла» введите имя нового шаблона. Нет необходимости добавлять расширение файла к имени шаблона. При нажатии кнопки «Сохранить» новому шаблону присваивается расширение .dwt и шаблон сохраняется в папке Templates данного сайта.

    Не следует использовать пробелы и специальные символы в наименованиях файлов и папок, а также начинать имя файла с цифры. В частности, не используйте специальные символы (такие как é, ç или ¥), а также знаки пунктуации (такие как двоеточие, косая черта или точка) в именах файлов, которые планируется поместить на удаленный сервер. Многие серверы заменяют данные символы при загрузке файла, что приводит к повреждению ссылок на файл.

Создание страницы на основе шаблона

Можно выбрать, просмотреть и создать новый документ, используя один из существующих шаблонов или начальные шаблоны Dreamweaver. Можно использовать диалоговое окно «Создать документ», чтобы выбрать шаблон из любого сайта, определенного средствами Dreamweaver, или воспользоваться панелью «Ресурсы», чтобы создать новый документ по существующему шаблону.

Создание документа по шаблону

  1. Выберите Файл > Создать.

  2. В диалоговом окне «Создать документ» выберите категорию «Страница из шаблона».

  3. В столбце «Веб-сайт» выберите сайт Dreamweaver, который содержит необходимый шаблон, а затем выберите шаблон из списка справа.

  4. Снимите флажок «Обновлять страницу при изменении шаблона», если не хотите обновлять данную страницу каждый раз, когда вносите изменения в базовый шаблон.

  5. Нажмите кнопку «Настройки», чтобы задать установки документа по умолчанию, как, например, тип документа, кодировка и расширение файла.

  6. Щелкните Получить дополнительное содержимое, чтобы открыть Dreamweaver Exchange, где можно получить больше содержимого для оформления страницы.

  7. Нажмите кнопку Создать и сохраните документ (Файл > Сохранить).

Создание документа по шаблону из панели «Ресурсы»

  1. Откройте панель «Ресурсы» (меню «Окно» > «Ресурсы»), если она еще не открыта.

  2. На панели Ресурсы щелкните значок «Шаблоны»  слева, чтобы просмотреть список шаблонов на текущем сайте.

    Примечание.

    Если шаблон, который надо применить, только что был создан, может понадобиться нажать кнопку «Обновить», чтобы увидеть его.

  3. Щелкните по шаблону, который необходимо применить, правой кнопкой мыши (Windows) или щелкните по нему при нажатой клавише Control (Macintosh), а затем выберите «Создать из шаблона».

    Документ откроется в области «Окно документа».

  4. Сохраните документ.

Создание страницы на основе начального шаблона Dreamweaver

В состав Dreamweaver включено несколько разработанных профессионалами начальных файлов для мобильных приложений. Можно использовать файлы образца в качестве отправной точки для разработки страниц своего сайта.

При создании документа на основе начального шаблона Dreamweaver создает копию файла, поэтому файлы начальных шаблонов не будут перезаписаны.

Можно предварительно просмотреть файл образца и прочитать краткое описание элементов оформления страницы в диалоговом окне Создать документ.

  1. Выберите Файл > Создать.

  2. В диалоговом окне Создать документ выберите категорию «Начальные шаблоны».

    Начальные шаблоны в Dreamweaver
    Начальные шаблоны в Dreamweaver

    Можно просмотреть информацию об образце страницы и ее внешний вид на правой стороне панели при выборе различных параметров.

  3. Нажмите кнопку «Создать».

    Новый документ и все связанные с ним файлы открываются в окне Документ.

  4. Сохраните документ (Файл > Сохранить).

Создание новых файлов с кодом для различных языков программирования

В Dreamweaver можно создавать файлы с кодом для ряда языков программирования.

Дополнительные сведения о поддержке программирования в Dreamweaver см. в разделе О программировании в Dreamweaver.

Чтобы создать новый файл с кодом в Dreamweaver, выполните следующие действия.

  1. Выберите Файл > Создать документ.

  2. В меню «Тип документа» выберите файл с кодом, который нужно создать.

  3. Выберите тип документа, который нужно создать, в столбце Тип документа (например, файл PHP).

    Создание новой страницы PHP
    Создание новой страницы PHP

  4. В зависимости от выбранного типа файлов при создании документа будут доступны дополнительные параметры. 

    Например, при создании файла PHP можно выбрать параметры DocType и некоторые параметры CSS.

  5. Нажмите кнопку «Создать». После этого сохраните документ (Файл > Сохранить).

Сохранение и восстановление документов

Можно сохранить документ под текущим именем и в текущем расположении или создать его копию с другим именем и в другом расположении.

Примечание.

При именовании файлов избегайте использования пробелов и специальных символов в именах файлов и папок. В частности, не используйте специальные символы (такие как é, ç или ¥), а также знаки пунктуации (такие как двоеточие, косая черта или точка) в именах файлов, которые планируется поместить на удаленный сервер. Многие серверы заменяют данные символы при загрузке файла, что приводит к повреждению ссылок на файл. Также имя файла не следует начинать с цифры.

Сохранение документа

  1. Выполните одно из следующих действий.
    • Чтобы перезаписать текущую версию на диске и сохранить внесенные изменения, выберите меню Файл > Сохранить.
    • Чтобы сохранить файл в другой папке или с другим именем, выберите меню Файл > Сохранить как.
  2. В открывшемся диалоговом окне «Сохранить как» перейдите к папке, в которой следует сохранить файл.
  3. В текстовом поле «Имя файла» введите имя для файла.

  4. Нажмите кнопку «Сохранить», чтобы сохранить файл.

Сохранение всех открытых документов

  1. Выберите меню Файл > Сохранить все.

  2. Если имеются несохраненные документы, для каждого из них отображается диалоговое окно «Сохранить как».

    В открывшемся диалоговом окне укажите папку, в которой следует сохранить файл.

  3. В текстовом поле «Имя файла» введите имя для файла и нажмите кнопку «Сохранить».

Возврат к последней сохраненной версии документа

  1. Выберите меню Файл > Вернуться.

    Появится диалоговое окно с запросом отклонить изменения и вернуться к предыдущей сохраненной версии.

  2. Чтобы вернуться к предыдущей версии, нажмите кнопку «Да»; чтобы сохранить изменения, нажмите кнопку «Нет».

    Примечание.

    Если сохранить документ, а затем выйти из Dreamweaver, после перезапуска Dreamweaver вернуться к предыдущей версии документа будет невозможно.

Задание типа и кодировки документов по умолчанию установки

Если большинство страниц сайта составляют файлы одного типа (например, HTML, PHP или JavaScript), можно задать установки для автоматического создания новых документов с указанным типом файла.

  1. Выберите меню «Правка» > «Настройки» (Windows) или Dreamweaver > «Настройки» (Macintosh).

    Примечание.

    Также можно нажать кнопку «Настройки» в диалоговом окне «Создать документ», чтобы задать параметры для нового документа при его создании.

  2. Выберите «Создать документ» из списка категорий слева.

  3. Задайте или измените установки, где необходимо, и нажмите кнопку «ОК», чтобы сохранить их.

    Документ по умолчанию

    Выберите тип документа, который будет использован для создаваемых страниц.

    Расширение по умолчанию

    Укажите предпочтительное расширение файла (.htm или .html) для создаваемых HTML-страниц.

    Примечание. Данный параметр неактивен для других типов файлов.

    Тип документа по умолчанию (DDT)

    Выберите одно из определений типа документа XHTML, чтобы сделать новые страницы совместимыми с XHTML. Например, можно сделать HTML-документ совместимым с XHTML, выбрав в меню тип «Переходный XHTML 1.0» или «Строгий XHTML 1.0».

    Кодировка по умолчанию

    Укажите кодировку, которую необходимо использовать при создании новой страницы, а также при открытии документа, который не содержит указания на кодировку.

    Если выбрать для документа кодировку Юникод (UTF‑8), кодировка сущностей не требуется, так как в UTF‑8 представлены все символы. При выборе другой кодировки документа кодировка сущностей может понадобиться для представления определенных символов. Подробную информацию о символьных сущностях см. в разделе www.w3.org/TR/REC-html40/sgml/entities.html.

    При выборе Юникод (UTF-8) в качестве кодировки по умолчанию можно включить в документ метку порядка байтов (BOM), выбрав параметр «Включить подпись Unicode (BOM)».

    Меткой порядка байтов (BOM) называют 2-4 байта в начале текстового файла, которые определяют его как файл в кодировке Юникод, а также порядок байтов для всех последующих байтов. Так как в UTF‑8 не существует порядка байтов, добавлять BOM для этой кодировки не обязательно. Добавление метки является обязательным для UTF-16 и UTF-32.

    Форма стандартизации Юникода

    Выберите один из следующих параметров, если в качестве кодировки по умолчанию указывается Юникод (UTF-8).

    Существует четыре формы стандартизации Юникода. Наиболее важной является форма приведения C, так как данная форма наиболее часто используется в модели символов в Интернете. Для полноты информации Adobe предоставляет и другие три формы стандартизации Юникода.

    Параметр «Показать диалоговое окно «Создать документ» после нажатия Ctrl + N»

    Отмените данный параметр («on Command+N» для Macintosh), чтобы автоматически создавать документ с типом документа по умолчанию при использовании клавишной команды.

    В Юникоде существуют внешне сходные символы, которые могут храниться в документе разными способами. Например, символ «ë» (e-умлаут) может быть представлен в виде одного символа «e-умлаут» или в виде двух символов — «обычное латинское e» + «комбинируемый умлаут». Комбинируемый символ в Юникоде используется вместе с предыдущим, таким образом умлаут отобразится над «латинским e». Обе формы представления будут выглядеть внешне одинаково, но вид записи в файле будет различаться.

    Под приведением понимается процесс, в рамках которого все символы, которые могут храниться по-разному, сохраняются с использованием одной формы. Таким образом, все символы «ë» в документе будут сохранены как отдельный «e-умлаут» или как «e» + «комбинируемый умлаут», а не как обе формы в одном документе.

    Подробную информацию о стандартизации Юникода и использовании особых форм см. на веб-сайте Unicode по адресу www.unicode.org/reports/tr15.

Открытие и редактирование существующих документов

Можно открыть веб-страницу или текстовый документ, независимо от того, был ли он создан в Dreamweaver, и изменить его в представлении «Дизайн» или «Код».

Если открывается файл Microsoft Word, сохраненный как HTML-документ, то можно использовать команду «Инструменты > Исправить HTML-код Word» для удаления всех лишних тегов, которые создает Word в HTML-файлах.

Чтобы очистить HTML- или XHTML-файл, созданный другим приложением, используйте команду «Инструменты > Исправить HTML-код». Дополнительные сведения см. в разделе Очистка HTML-файлов, созданных в Microsoft Word.

Можно также открыть текстовые файлы в формате отличном от HTML, как например файлы JavaScript, XML, таблицы стилей CSS или текстовые файлы, созданные в текстовых процессорах или редакторах.

  1. Выберите меню «Файл» > «Открыть».

    Примечание.

    Для открытия файлов можно использовать панель «Файлы».

  2. Перейдите к файлу, который необходимо открыть, и выберите его.

    Примечание.

    Если вы еще не сделали это, рекомендуется перенести файлы, с которыми предстоит работать, в сайт Dreamweaver из другого местоположения. Дополнительные сведения о сайтах Dreamweaver см. в разделе О сайтах Dreamweaver.

  3. Нажмите кнопку «Открыть».

    Документ открывается в области «Окно документа». Файлы JavaScript, текстовые файлы и таблицы стилей CSS по умолчанию открываются в представлении «Код». Можно обновить документ при работе с Dreamweaver, а затем сохранить изменения в файле.

Dreamweaver позволяет просматривать файлы, связанные с основным документом, сохраняя активность последнего. Например, если к основному документу приложены файлы CSS и JavaScript, среда Dreamweaver позволяет просматривать и редактировать эти связанные файлы в окне «Документ», оставляя основной документ видимым.

Дополнительные сведения о динамически связанных файлах см. в разделе Открытие динамически связанных файлов.

Примечание.

При работе с файлами HTML, если нужно внести быстрые изменения в связанные файлы CSS, JavaScript или PHP без перехода к ним, можно использовать функцию «Быстрое редактирование». Дополнительные сведения см. в разделе Быстрое редактирование.

По умолчанию Dreamweaver отображает имена всех файлов, связанных с основным документом, на панели инструментов «Связанные файлы» под заголовком основного документа. Порядок расположения кнопок на панели инструментов отражает порядок ссылок на связанные файлы в основном документе.

Примечание.

Даже если связанный файл отсутствует, соответствующая ему кнопка на панели инструментов Dreamweaver «Связанные файлы» по-прежнему отображается. Однако при нажатии этой кнопки Dreamweaver ничего не отобразит.

Dreamweaver поддерживает следующие типы связанных файлов.

  • Файлы клиентских сценариев
  • Серверные включения
  • Внешние таблицы стилей CSS (включая вложенные таблицы стилей)

Выполните одно из следующих действий.

  • Щелкните на панели инструментов Связанные файлы в верхней части документа имя связанного файла, который необходимо открыть.

  • Щелкните правой кнопкой на панели инструментов «Связанные файлы» имя связанного файла, который необходимо открыть, и выберите пункт «Открыть как отдельный файл» в контекстном меню. Если открыть связанный файл таким методом, основной документ не остается видимым одновременно со вновь открытым.

  1. Поместите курсор вставки на строке или в области, на которую оказывает воздействие связанный файл.

  2. Дождитесь появления индикатора навигатора по коду и щелкните его, чтобы открыть навигатор по коду.

  3. Задержите курсор над элементами, отображаемыми в навигаторе по коду, чтобы просмотреть дополнительные сведения о них. Например, чтобы изменить отдельное свойство цвета в таблице стилей, не зная правила, которым оно определяется, это свойство можно найти, последовательно наводя курсор на доступные правила в навигаторе по коду.

  4. Щелкните нужный элемент, чтобы открыть соответствующий связанный файл.

Возвращение в исходный код основного документа

  1. Щелкните кнопку «Исходный код» на панели инструментов «Связанные файлы».

Если связанный файл открыт в представлении Дизайн или представлениях Код и Дизайн (разделение), связанный файл будет отображен в представлении «Разделение».

Для настройки представления «Разделение» можно выбрать в меню «Просмотр > Разделить» требуемые параметры разделенного представления.

Если необходимо просматривать связанные файлы только в представлении «Код», выберите «Код» в верхней части панели инструментов.

Примечание.

Стандартное представление кода не позволяет отображать связанные документы одновременно с исходным кодом основного документа.

Примечание.

Представление кода в параметрах отображения обозначает исходный код основного документа. Например, если выбрать меню «Просмотр > Представление "Код" наверху», то Dreamweaver отображает исходный код основного документа в верхней половине окна документа. Если выбрать меню «Просмотр > Представление "Код" слева», то Dreamweaver отображает исходный код основного документа в левой части окна документа.

По умолчанию при открытии HTML-файла Dreamweaver отображает связанные файлы в отдельных вкладках. Если нужно отключить эту функцию, то это можно сделать на панели «Настройки».

  1. Выберите меню Правка > Настройки (Windows) или Dreamweaver > Настройки (Macintosh).

  2. В категории Общие снимите флажок Включить связанные файлы.

Функция «Динамически связанные файлы» расширяет возможности функции «Связанные файлы», позволяя видеть связанные файлы динамических страниц на панели инструментов Связанные файлы. В частности, функция «Динамически связанные файлы» позволяет видеть различные динамические включения, требуемые для создания динамического кода для таких популярных открытых PHP-платформ CMS, как WordPress, Drupal и Joomla!

Для использования функции «Динамически связанные файлы» требуется иметь доступ к локальному или удаленному серверу приложений PHP на платформе WordPress, Drupal или Joomla! Одним из распространенных методов тестирования страниц является настройка локального сервера приложений PHP и локальное тестирование страниц.

Перед началом тестирования страниц необходимо выполнить следующие действия.

  • Настройте веб-сайт Dreamweaver и убедитесь в том, что текстовое поле «URL-адрес» в диалоговом окне «Настройка сайта» заполнено.

  • Настройте сервер приложений PHP.

    Примечание. Прежде чем начинать работу с динамически связанными файлами в Dreamweaver, необходимо запустить сервер.

  • Установите WordPress, Drupal или Joomla! на сервере приложений. Более подробно об этом см. в разделах:

  • В Dreamweaver укажите локальную папку, в которую будут загружены файлы CMS.

  • Укажите местоположение установленных файлов WordPress, Drupal или Joomla в качестве удаленной папки тестирования.

  • Загрузите (получите) файлы CMS из удаленной папки.

При открытии страницы, связанной с динамически связанными файлами, Dreamweaver обнаружит эти файлы автоматически или даст возможность найти их вручную (щелкнув ссылку на панели «Сведения» над страницей). По умолчанию задано обнаружение вручную.

  1. Выберите «Правка» > «Настройки» (Windows) или Dreamweaver > «Настройки» (Macintosh OS).

  2. В категории «Общие» убедитесь в том, что выбран параметр «Разрешить связанные файлы».

  3. Во всплывающем меню «Динамически связанные файлы» выберите «Вручную» или «Автоматически». Обнаружение можно отключить полностью, выбрав параметр «Отключено».

  1. Откройте страницу, имеющую динамически связанные файлы (например, страницу корня сайта index.php page платформы WordPress, Drupal или Joomla!) .

  2. Если обнаружение динамически связанных файлов выполняется вручную (по умолчанию), перейдите по ссылке «Обнаружение» на панели «Сведения», которая появляется над страницей в окне «Документ».

    Если обнаружение динамически связанных файлов выполняется автоматически, то список динамически связанных файлов появится на панели «Связанные файлы».

Связанные и динамически связанные файлы расположены на панели Связанные файлы в следующем порядке.

  • Статически связанные файлы (т. е. связанные файлы, не требующие никакой динамической обработки)
  • Внешние связанные файлы (файлы .css и .js), присоединенные к файлам серверных включений с динамическим путем
  • Файлы серверных включений с динамическим путем (файлы .php, .inc и .module).

Поскольку связанных и динамически связанных файлов часто бывает много, Dreamweaver позволяет фильтровать их, чтобы можно было точно определить расположение необходимых для работы файлов.

  1. Откройте страницу, имеющую связанные файлы.

  2. При необходимости найдите динамически связанные файлы.

  3. Щелкните значок «Фильтрация связанных файлов» в правой части панели «Связанные файлы».

  4. Выберите типы файлов, которые должны быть видны на панели «Связанные файлы». По умолчанию Dreamweaver выбирает все связанные файлы.

  5. Для создания пользовательского фильтра щелкните значок «Фильтрация связанных файлов» и выберите «Пользовательский фильтр».

    Диалоговое окно «Пользовательский фильтр» позволяет выполнять фильтрацию только по точным именам файлов (style.css), расширениям файлов (.php) и подстановочным выражениям со звездочками (*menu*). Можно выполнять фильтрацию по нескольким подстановочным выражениям, отделяя каждое из них точкой с запятой (например, style.css;*.js;*tpl.php).

Примечание.

Настройки фильтра сбрасываются после закрытия файла.

Очистка HTML-файлов, созданных в Microsoft Word

Можно открыть документы, сохраненные приложением Microsoft Word (версии Microsoft Word 97 или выше) в формате HTML-файлов, а затем использовать команду «Инструменты > Исправить HTML-код Word» для удаления всех лишних тегов, которые создает Word в HTML-файлах.

Код, который удаляет Dreamweaver, используется приложением Word для форматирования и отображения документов в Word и на самом деле не требуется для отображения HTML-файла.

Сохраните резервную копию файла-оригинала (.doc), так как HTML-документ после очистки HTML-файла может быть недоступен для открытия в программе Word.

Примечание.

Чтобы очистить HTML- или XHTML-файл, созданный другим приложением, используйте команду «Инструменты > Исправить HTML-код».

  1. Сохраните документ Microsoft Word в виде HTML-файла.

    Примечание.

    При работе в Windows закройте файл в приложении Word, чтобы избежать конфликта коллективного пользования файлами.

  2. Откройте HTML-файл в Dreamweaver.

    Чтобы просмотреть HTML-код, созданный Word, переключитесь в представление кода («Просмотр» > «Код»).

  3. Выберите пункт меню Инструменты > Исправить HTML-код Word.

    Примечание.

    В случае если Dreamweaver не может определить, какая версия Word была использована для сохранения файла, выберите правильный вариант из всплывающего меню.

  4. Задайте (или отмените) параметры исправления. Введенные вами установки сохраняются как параметры исправления по умолчанию.

    Dreamweaver применяет настройки очистки к HTML-документу, при этом отображается журнал изменений (если данный параметр не был отменен в диалоговом окне).

    Параметры очистки файлов HTML, созданных в Microsoft Word
    Параметры очистки файлов HTML, созданных в Microsoft Word

    Удалить всю разметку, связанную с указанным словом

    Удаляет весь HTML-код, созданный приложением Microsoft Word, в том числе XML, из тегов HTML, пользовательские метаданные Word и теги ссылок в заголовке документа, XML разметку, созданную Word, условные теги и их содержимое, а также пустые параграфы и поля из стилей. Можно выбрать каждый из данных параметров по отдельности на вкладке «Подробно».

    Исправить стили CSS

    Удаляет, когда возможно, все элементы CSS, созданные приложением Word, в том числе встроенные стили CSS (где родительский стиль имеет те же свойства стиля); атрибуты стиля, начинающиеся с «mso»; объявления стиля не в формате CSS; атрибуты стиля CSS из таблиц; а также все неиспользуемые определения стиля из заголовка. Можно настроить параметры на закладке «Подробно»

    Исправить теги <font>

    Удаляет все HTML-теги, преобразуя основной текст по умолчанию в HTML-текст второго размера.

    Согласовать недопустимо вложенные теги

    Удаляет все теги разметки шрифта, помещенные приложением Word вне тегов параграфа и заголовка (на уровне блоков).

    Применение исходного форматирования

    Применяет к документу параметры исходного форматирования, которые задаются пользователем в установках «Формат HTML» и в файле SourceFormat.txt.

    Отображение журнала по завершении.

    Отображает окно с подробными сведениями об изменениях, которые были сделаны в документе, сразу после завершения исправления.

  5. Нажмите «ОК» или перейдите на вкладку «Подробно» для более подробного определения параметров «Удалить всю разметку Word и исправить настройки CSS», затем нажмите кнопку «ОК».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет