Узнайте, как использовать панель «Файлы» для управления файлами и папками и их передачи и синхронизации между локальным и удаленным сайтами в Dreamweaver. Узнайте, как работает функция автоматического восстановления в Dreamweaver.

Панель «Файлы» в Dreamweaver обеспечивает доступ к файлам, связанным с веб-сайтом, а также управление ими. Вы можете переключаться между представлением FTP и представлением Git на панели «Файлы», чтобы управлять файлами через сервер FTP или репозитории Git.

Чтобы открыть панель «Файлы», откройте меню «Окно > Файлы» или нажмите клавишу F8 (в Windows) или Shift-⌘-F (на Mac).

Примечание.

Если сайт не настроен, то на панели «Файлы» просто перечисляются все диски или папки в вашей системе. Можно использовать панель только для просмотра файлов. Перемещать файлы из удаленной системы в локальную систему и обратно нельзя. 

Чтобы узнать подробнее о преимуществах настройки сайта, а также ознакомиться с инструкциями о том, как создать веб-сайт, перейдите в раздел О сайтах Dreamweaver.

Узнать больше об использовании панели «Файлы» в каждом из этих представлений можно в следующих разделах.

Работа с панелью «Файлы» в представлении FTP

Представление FTP позволяет просматривать файлы и папки, проверять, связаны ли они с сайтом Dreamweaver, а также выполнять стандартные операции с файлами, такие как открытие или перемещение. На панели «Файлы» можно также управлять файлами, а также передавать их на удаленный сервер и обратно.

После настройки сайта в Dreamweaver панель «Файлы» можно использовать следующими способами:

  • Доступ к сайтам, серверу и локальным дискам
  • Просмотр файлов и папок
  • Управление файлами и папками на панели «Файлы»
  • Синхронизация файлов и папок между локальным и удаленным серверами

Подробнее узнать об использовании панели «Файлы» можно в следующих разделах.

Параметры на панели «Файлы»

В простейшем случае панель «Файлы» отображает список только локальных файлов на вашем компьютере. При дальнейшей работе с панелью «Файлы» (настройка веб-сайта, установка подключения к удаленным серверам, включение извлечения и возврата файлов) в ней появляются дополнительные параметры.

Вот как выглядит панель «Файлы»:

  • Когда не настроен сайт в Dreamweaver
  • Когда сайт уже настроен, а сервер еще нет
  • Когда сайт настроен, подключения к серверу установлены, возврат и извлечение файлов включены

Дополнительные сведения о настройке сайта и сервера см. в разделе О сайтах Dreamweaver.

Когда не настроен сайт в Dreamweaver

Как выглядит панель «Файлы», когда не настроен сайт в Dreamweaver
Как выглядит панель «Файлы», когда не настроен сайт в Dreamweaver

Когда сайт уже настроен, а сервер еще нет

При настройке веб-сайта в Dreamweaver отображаются файлы, находящиеся внутри этого сайта. Панель «Файлы» также содержит кнопку «Задать серверы», которая предназначена для начала настройки подключений к удаленным и тестовым серверам.

Как выглядит панель «Файлы», когда сайт уже настроен в Dreamweaver, а серверы еще нет
Как выглядит панель «Файлы», когда сайт уже настроен в Dreamweaver, а серверы еще нет

Когда сайт и серверы настроены, возврат и извлечение файлов включены

Все параметры на панели «Файлы» становятся доступны для использования после того, как настроены сайт и сервер. Если включены возврат и извлечение файлов, то эти параметры также доступны для использования.

Дополнительные сведения о том, что можно делать на панели «Файлы», см. ниже.

Дополнительные сведения о включении возврата и извлечения файлов см. в разделе Возврат и извлечение файлов.

Панель «Файлы», когда настроен сайт, установлены подключения к удаленным серверам, а также включены возврат и извлечение файлов
Панель «Файлы», когда настроен сайт, установлены подключения к удаленным серверам, а также включены возврат и извлечение файлов

A. Всплывающее меню «Сайт» B. Представление «Файл» C. Подключение к удаленному серверу D. Получение файлов с удаленного сервера E. Отправка файлов на удаленный сервер F. Извлечение файлов G. Возврат файлов H. Синхронизация с удаленным сервером I. Развернуть/свернуть J. Кнопка «Обновить» K. Обработка файлов 

Можно перемещать панель «Файлы», если необходимо, и задавать установки панели.

Примечание.

Представления «Файлы сайта», «Тестовый сервер» и кнопки «Синхронизировать» отображаются на панели «Файлы» только в том случае, если она развернута.

Всплывающее меню «Сайт»

Позволяет выбрать сайт Dreamweaver и отобразить файлы сайта. Можно также использовать меню «Сайт» для доступа ко всем файлам на локальном диске. Данный инструмент аналогичен программе Проводник (Windows) или Finder (Macintosh).

Представление «Файл»

Позволяет просматривать файлы, находящиеся в корне локального сайта, на удаленном или тестовом сервере. Выберите параметр из всплывающего меню, чтобы просмотреть файлы в соответствующем представлении.

Подключение к удаленному серверу

Выполняет подключение к удаленному сайту или отключение от него (по протоколам FTP, RDS и WebDAV). По умолчанию в Dreamweaver происходит разрыв соединения с удаленным сайтом, если соединение неактивно в течение более 30 минут (действительно только для FTP). Чтобы изменить порог, выберите меню «Правка» > «Настройки» (Windows) или «Dreamweaver» > «Настройки» (Macintosh), а затем в списке категорий слева выберите «Сайт».

Получение файлов с удаленного сервера

Копирует выбранные файлы из удаленного сайта на локальный сайт (с перезаписью существующей локальной копии файла, если необходимо). Если включен параметр «Включить извлечение и возврат файлов», локальные копии файлов доступны только для чтения; файлы доступны для извлечения на удаленном сайте другим участникам рабочей группы. Если функция «Включить извлечение и возврат файлов» отключена, то копии файла будут доступны для чтения и записи.

Отправка файлов на удаленный сервер

Копирует выбранные файлы с локального на удаленный сайт.

Извлечение файлов

Переносит копию файла с удаленного сервера на локальный сайт (при наличии локальной копии файла она будет перезаписана) и помечает файл как извлеченный с сервера. Данное действие недоступно, если параметр «Включить извлечение и возврат файлов» отключен для данного сайта.

Возврат файлов

Переносит копию локального файла на удаленный сервер и делает файл доступным для редактирования. Локальный файл при этом доступен только для чтения. Данное действие недоступно, если параметр «Включить извлечение и возврат файлов» отключен для данного сайта.

Кнопка «Синхронизация» с удаленным сервером

Синхронизирует файлы в локальной и удаленной папках.

Развернуть/свернуть

Разворачивает или сворачивает панель «Файлы» для отображения одной или двух областей. В расширенном представлении также доступен дополнительный параметр — «Просмотр журнала FTP-сайта». Когда панель «Файлы» свернута, она отображает содержимое локального сайта, удаленного сайта или тестового сервера в виде списка файлов. В развернутом виде на панели отображается локальный сайт, удаленный сайт или тестовый сервер.

Кнопка «Обновить»

Обновляет списки локальных и удаленных каталогов. Используйте данную кнопку для ручного обновления списков каталогов, если отменили параметр «Обновлять список локальных файлов автоматически» или «Автоматически обновлять список удаленных файлов» в диалоговом окне «Определение веб-сайта».

Обработка файлов

Показывает фоновую обработку файлов.

Просмотр журнала FTP-сайта становится доступен, если развернуть панель «Файл», щелкнув по значку «Развернуть/свернуть».

Просмотр журнала FTP-сайта

Отображает файловую структуру удаленного и локальных сайтов в областях панели «Файлы». (Установки определяют, какой сайт отображает в левой области, а какой — справа.) Режим просмотра «Файлы веб-сайта» используется на панели «Файлы» по умолчанию.

Примечание.

Файлы, которые копирует Dreamweaver, выбираются на активной панели «Файлы». Если активна область «Удаленные», выбранные файлы, расположенные на удаленном или тестовом сервере, копируются на локальный сайт; если активна область «Локальные», Dreamweaver обновляет файлы, выбранные на локальном сайте, с удаленного или тестового сервера.

Примечание.

Файлы, которые копирует Dreamweaver, выбираются на активной панели «Файлы». Если активна область «Локальные», выбранные локальные файлы копируются на удаленный сайт или тестовый сервер; если активна область «Удаленные», Dreamweaver обновляет файлы, выбранные на удаленном сайте или тестовом сервере, соответствующими файлами с локального сайта.

Если размещается файл, который не существует на удаленном сервере, а параметр «Включить извлечение и возврат файлов» включен, файл добавляется на удаленный сайт в статусе «извлечен с сервера». Нажмите кнопку «Вернуть файлы на сервер», если хотите добавить файлы без данного статуса.

Просмотр файлов и папок

Панель «Файлы» позволяет просматривать файлы и папки независимо от того, связаны они с сайтом Dreamweaver или нет. При просмотре сайтов, файлов или папок на панели «Файлы» можно менять размер области просмотра и для сайтов Dreamweaver разворачивать или сворачивать панель «Файлы».

Для сайтов Dreamweaver можно также настроить панель «Файлы», изменив способ ее отображения по умолчанию в свернутом состоянии (как для локального, так и для удаленного сайта). Можно также переключаться между представлениями содержимого на развернутой панели «Файлы» с помощью параметра «Всегда показывать».

Поиск файлов на панели файлов (Mac OS, только для пользователей Creative Cloud)

Используйте функцию интерактивного поиска, чтобы определить местонахождение файлов по имени или тексту, содержащемуся в файлах. Для поиска используется расположение, выбранное на панели «Файлы». Если расположение на панели не выбрано, функция поиска не появляется. Для получения дополнительной информации см. статью Поиск файлов по имени файла или содержимому.

Изменение размера области просмотра на развернутой панели «Файлы».

На развернутой панели «Файлы» (Окно > Файлы) перетащите линейку, которая разделяет два представления, чтобы увеличить или уменьшить область просмотра левой или правой панели.

Изменение вида сайта на панели «Файлы» (только для сайтов Dreamweaver)

Панель «Файлы» можно использовать для просмотра файлов, находящихся в корне локального сайта, на удаленном или тестовом сервере.

На свернутой панели «Файлы» (Окно > Файлы) выберите пункты «Локальный просмотр», «Удаленный сервер» или «Тестовый сервер» из всплывающего меню «Просмотр веб-сайта».

По умолчанию в меню «Просмотр веб-сайта» появляется пункт «Локальный просмотр».

Просмотр файлов в корне локального сайта, на удаленном и тестовом серверах
Просмотр файлов в корне локального сайта, на удаленном и тестовом серверах

Просмотр файлов за пределами сайта Dreamweaver

Можно также использовать всплывающее меню «Веб-сайт» для навигации по файлам локального компьютера. Данный инструмент аналогичен проводнику Windows Explorer (Windows) или Finder (Macintosh).

Работа с файлами в представлении FTP

С файлами можно выполнять следующие операции: открывать, переименовывать, добавлять, перемещать или удалять, а также можно обновлять панель «Файлы» после внесения изменений.

Для сайтов Dreamweaver можно также определять, какие файлы (на локальном или на удаленном сайте) были обновлены с момента их последней передачи.

Открытие файла

  1. На панели «Файлы» («Окно» > «Файлы») выберите сайт, сервер или диск из всплывающего меню (в котором отображается текущий сайт, сервер или диск).
  2. Перейдите к нужному файлу.
  3. Выполните одно из следующих действий.
    • Дважды щелкните значок файла.

    • Щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) значок файла и выберите команду «Открыть».

      Dreamweaver откроет файл в окне «Документ».

Создание файла или папки

  1. На панели «Файлы» («Окно» > «Файлы») выберите файл или папку.

    Dreamweaver создаст новый файл или папку внутри текущей выбранной папки или в папке, где находится выбранный файл.

  2. Щелкните правой кнопкой мыши (в Windows) или щелкните при нажатой клавише Control (Macintosh) и выберите команду «Создать файл» или «Создать папку».
  3. Введите имя новой папки или файла.
  4. Нажмите клавишу Enter (Windows) или Return (Macintosh).

Удаление файла или папки

  1. На панели «Файлы» («Окно» > «Файлы») выберите файл или папку, которые необходимо удалить.
  2. Щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) и выберите команды «Правка» > «Удалить».

Переименование файла или папки

  1. На панели «Файлы» («Окно» > «Файлы») выберите файл или папку, которые необходимо переименовать.
  2. Выполните одно из следующих действий, чтобы активировать имя папки или файла.
    • Щелкните имя файла, а затем после короткой паузы щелкните его еще раз.

    • Щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) значок файла и выберите команды «Правка» > «Переименовать».

  3. Введите новое имя поверх существующего.
  4. Нажмите клавишу Enter (Windows) или Return (Macintosh).

Перемещение файла или папки

  1. На панели «Файлы» («Окно» > «Файлы») выберите файл или папку, которые необходимо переместить.
  2. Выполните одно из следующих действий.
    • Скопируйте файл или папку и вставьте в новом месте.

    • Перетяните файл или папку в новое место.

  3. Для того чтобы перемещенная папка или файл отобразились в новом месте, обновите панель «Файлы».

Обновление содержимого панели «Файлы»

Чтобы обновить вид панели «Файлы», выполните одно из следующих действий.

  • Щелкните правой кнопкой мыши (в Windows) или щелкните при нажатой клавише Control (в Macintosh) любой файл или папку и выберите команду «Обновить».
  • (Только для сайтов Dreamweaver) На панели инструментов панели «Файлы» нажмите кнопку «Обновить» (при этом обновляются обе панели).

Примечание.

Dreamweaver обновляет панель «Файлы» после внесения изменений в другом приложении и возврата к работе с Dreamweaver.

Поиск файлов на сайте Dreamweaver

Dreamweaver обеспечивает быстрый поиск выбранных, открытых, извлеченных или недавно измененных файлов сайта. Также можно выполнять поиск самых новых файлов на локальном или удаленном сайте.

Поиск открытого файла на сайте

  1. Откройте файл в области «Окно документа».
  2. Выберите «Веб-сайт» > «Обнаружить на веб-сайте».

    Dreamweaver выделяет файл на панели «Файлы».

    Примечание.

    Если файл, открытый в окне «Документ», не является частью текущего сайта на панели «Файлы», Dreamweaver пытается определить, к какому из сайтов принадлежит этот файл; если текущий файл принадлежит только одному локальному сайту, Dreamweaver открывает этот сайт на панели «Файлы» и выделяет его.

Поиск и выбор извлеченных файлов на сайте Dreamweaver

На свернутой панели «Файлы» («Окно» > «Файлы») в правом верхнем углу щелкните меню «Параметры», выберите «Правка» > «Выбрать извлеченные файлы».

Dreamweaver выделяет файлы на панели «Файлы».

Поиск выбранного файла на локальном или удаленном сайте

  1. Выберите файл в локальном или удаленном представлении на панели «Файлы» («Окно» > «Файлы»).
  2. Щелкните по файлу правой кнопкой мыши (в Windows) или щелкните, удерживая нажатой клавишу Control (в Macintosh), и выберите команду «Найти на локальном веб-сайте» или «Найти на удаленном сервере» (в зависимости от того, где был выбран файл).

    Dreamweaver выделяет файл на панели «Файлы».

Поиск и выбор более новых локальных файлов

На свернутой панели «Файлы» («Окно» > «Файлы») в правом верхнем углу щелкните меню «Параметры», выберите «Правка» > «Выбрать новый локальный».

Dreamweaver выделяет файлы на панели «Файлы».

Поиск и выбор более новых удаленных файлов

На свернутой панели «Файлы» («Окно» > «Файлы») в правом верхнем углу щелкните меню «Параметры», выберите «Правка» > «Выбрать более новый удаленный».

Dreamweaver выделяет файлы на панели «Файлы».

Поиск недавно измененных файлов на сайте

  1. На свернутой панели «Файлы» («Окно» > «Файлы») в правом верхнем углу щелкните меню «Параметры», выберите «Правка» > «Выбрать недавно измененные».
  2. Выполните одно из следующих действий, чтобы указать даты поиска для отчета.
    • Чтобы создать отчет обо всех файлах, измененных в течение последних нескольких дней, введите число в поле «Файлы, созданные или недавно измененные:».

    • Чтобы включить в отчет файлы, измененные в определенный промежуток времени, установите переключатель «Файлы, созданные или измененные между», а затем укажите диапазон дат.

    Поиск недавно измененных файлов
    Поиск недавно измененных файлов

  3. В поле «Автор изменений» введите имя пользователя, чтобы ограничить поиск по файлам, которые были изменены определенным пользователем в пределах указанного диапазона дат (необязательно).

    Примечание.

    Этот параметр доступен только для отчетов о сайтах Contribute.

  4. Чтобы указать место просмотра файлов, перечисленных в отчете, при необходимости установите один из следующих переключателей.

    Локальный компьютер,

    если сайт содержит статические страницы.

    Тестовый сервер,

    если сайт содержит динамические страницы.

    Другое расположение,

    если в текстовом поле необходимо указать путь.

    Примечание.

    Этот переключатель предполагает, что в диалоговом окне «Определение веб-сайта» был выбран тестовый сервер. Этот переключатель недоступен, если тестовый сервер не был определен и для этого сервера был введен префикс URL-адреса. Он также недоступен при выполнении отчета для нескольких сайтов.

  5. Чтобы сохранить параметры, нажмите кнопку «ОК».

    Dreamweaver выделяет файлы, измененные в выбранный промежуток времени, на панели «Файлы».

Поиск и удаление неиспользуемых файлов

Файлы, которые больше не используются другими файлами сайта, можно найти и удалить.

  1. Выберите «Веб-сайт > Параметры веб-сайта > Проверить ссылки на всем веб-сайте».

    Dreamweaver проверяет все ссылки на сайте и отображает нарушенные ссылки на панели «Результаты».

  2. На панели «Проверка ссылок» в меню выберите пункт «Потерянные файлы».
    Просмотр потерянных файлов — файлов без входящих ссылок
    Просмотр потерянных файлов — файлов без входящих ссылок

    Dreamweaver отображает все файлы без входящих ссылок. Это означает, что на сайте нет файлов, ссылающихся на эти файлы.

  3. Выберите файлы, которые требуется удалить, и нажмите клавишу Delete.

    Примечание.

    Хотя на эти файлы сайта не ссылаются другие файлы, некоторые из перечисленных в списке файлов могут сами ссылаться на другие файлы. Будьте внимательны при удалении этих файлов.

Доступ к сайтам, серверу и локальным дискам

К файлам и папкам сайтов Dreamweaver можно получать доступ, изменять их и сохранять. Это относится и к папкам, и к файлам, не являющимися частью сайта Dreamweaver. Наряду с сайтами Dreamweaver можно также получать доступ к серверу, локальному диску и рабочему столу.

Прежде чем получить доступ к удаленному серверу, необходимо настроить Dreamweaver для работы с этим сервером.

Примечание.

Наиболее удобный способ управления файлами — это создание сайта Dreamweaver. Дополнительные сведения о преимуществах создания сайтов, а также информацию об их создании см. в разделе О сайтах Dreamweaver.

Открытие существующего сайта Dreamweaver

На панели «Файлы» («Окно» > «Файлы») выберите сайт во всплывающем меню (в котором отображается текущий сайт, сервер или диск).
Открытие существующего сайта Dreamweaver
Открытие существующего сайта Dreamweaver

Открытие папки на удаленном сервере FTP или RDS

  1. На панели «Файлы» («Окно» > «Файлы») выберите имя сервера во всплывающем меню (в котором отображается текущий сайт, сервер или диск).

    Примечание.

    Отображаются имена тех серверов, для работы с которыми был настроен Dreamweaver.

  2. Перейдите к файлам и отредактируйте их в обычном порядке.

Получение доступа к локальному диску или к рабочему столу

  1. На панели «Файлы» («Окно» > «Файлы») выберите в меню один из пунктов «Рабочий стол». «Локальный диск» или «CD-дисковод» (в котором отображается текущий сайт, сервер или диск).
  2. Перейдите к файлу и выполните одно из следующих действий.
    • Откройте файлы в Dreamweaver или в другом приложении.
    • Переименуйте файлы.
    • Скопируйте файлы.
    • Удалите файлы.
    • Перетащите файлы.
      • При перетаскивании файла из одного сайта Dreamweaver в другой сайт или в папку, не являющуюся частью сайта Dreamweaver, Dreamweaver копирует файл в нужное расположение. 
      • При перетаскивании файла внутри одного сайта Dreamweaver перемещает файл в нужное расположение. 
      • При перетаскивании файла, который не является частью сайта Dreamweaver, в папку, которая также не является частью сайта Dreamweaver, Dreamweaver перемещает файл в нужное место.

    Примечание.

    Чтобы переместить файл, который Dreamweaver по умолчанию копирует, при перетаскивании удерживайте нажатой клавишу Shift (в Windows) или Command (в Macintosh). Чтобы скопировать файл, который Dreamweaver по умолчанию перемещает, при перетаскивании удерживайте нажатой клавишу Control (в Windows) или Option (в Macintosh).

Настройка сведений о файле и папке, отображаемых на панели «Файлы»

При просмотре сайта Dreamweaver на панели «Файлы» по умолчанию отображаются только файлы и структура папок. Но можно настроить внешний вид панели «Файлы», чтобы отображались следующие сведения.

  • Заметки
  • Размер
  • Тип
  • Дата последнего изменения файла
  • Сведения о возврате
Чтобы включить эти столбцы в представлении панели «Файлы», щелкните правой кнопкой мыши на панели инструментов и выберите нужные параметры.
Отображение и скрытие сведений о файле или папке на панели «Файлы»
Отображение и скрытие сведений о файле или папке на панели «Файлы»

Дополнительную настройку столбцов можно выполнить в диалоговом окне «Управление сайтами > Дополнительные параметры > Столбцы представления файлов»:

Настройка столбцов представления «Файлы» в диалоговом окне «Управление сайтами > Дополнительные параметры > Столбцы представления файлов»
Настройка столбцов представления «Файлы» в диалоговом окне «Управление сайтами > Дополнительные параметры > Столбцы представления файлов»

Изменение порядка столбцов

На панели «Управление сайтами > Дополнительные параметры > Столбцы представления файлов» выберите имя столбца, а затем нажмите кнопку со стрелкой вниз или вверх, чтобы изменить положение выбранного столбца.

Примечание.

Можно изменить порядок отображения любого столбца, за исключением столбца «Имя», который всегда отображается первым.

Добавление, удаление или изменение сведений столбцов

  1. Выберите «Веб-сайт» > «Управление веб-сайтами».
  2. Выберите сайт и нажмите кнопку «Изменить».
  3. Разверните «Дополнительные параметры» и выберите категорию «Колонки представления файлов».
  4. Выберите столбец и нажмите кнопку со знаком «плюс» (+), чтобы добавить новый столбец.

  5. В поле «Имя столбца» введите имя.
    Добавление пользовательских столбцов
    Добавление пользовательских столбцов

  6. В меню «Связать с заметками разработчика» выберите значение или укажите свое.

    Примечание.

    Новую колонку необходимо связывать с заметкой разработчика, чтобы данные отображались на панели «Файлы».

  7. Выберите тип выравнивания, чтобы выровнять текст внутри колонки.
  8. Поставьте или уберите флажок «Показать», чтобы показать или скрыть колонку.
  9. Выберите «Совместное использование для всех пользователей этого сайта», чтобы совместно использовать эту колонку со всеми пользователями, подключающимися к сайту.

Чтобы удалить столбец, выберите его и нажмите на кнопку «минус» (–). 

Примечание.

Столбец удаляется немедленно и без предупреждения, поэтому будьте внимательны, нажимая кнопку со знаком «минус» (–).

Сортировка столбцов на панели «Файлы»

Щелкните на панели «Файлы» по заголовку столбца, по которому необходимо отсортировать данные.

Примечание.

Щелкните по заголовку снова, чтобы вернуть предыдущий порядок сортировки (по возрастанию или по убыванию).

Автоматическое восстановление файлов

Если приложение Dreamweaver неожиданно завершило свою работу из-за системных ошибок, отключения электропитания или других проблем, то можно восстановить все несохраненные изменения, внесенные в файлы, с которыми вы работали.

Функция автоматического восстановления автоматически создает резервные копии всех несохраненных файлов в Dreamweaver. Если возник сбой, то при следующем запуске Dreamweaver на экране будет отображено следующее диалоговое окно.

Примечание.

Необходимо сохранить файл хотя бы один раз, чтобы иметь возможность восстановить его в Dreamweaver.

Автоматическое восстановление в Dreamweaver
Автоматическое восстановление в Dreamweaver

При открытии Dreamweaver после сбоя необходимо выполнить восстановление файла или отменить последние изменения:

  • Восстановить — выберите этот параметр, чтобы открыть автоматически сохраненную версию файла.
  • Отменить — выберите этот параметр, чтобы открыть последнюю сохраненную версию файла.

Примечание.

В Dreamweaver автоматическое сохранение выполняется примерно раз в 5 секунд (в зависимости от операционной системы).

Работа с панелью «Файлы» в представлении Git

Представление Git на панели «Файлы» позволяет подключаться к репозиториям Git и управлять файлами с помощью Git. Панель «Файлы» выполняет роль интерфейса для выполнения таких операций, как фиксация, подготовка, отмена подготовки, добавление в .gitignore и прочих.

Представление Git можно использовать для выполнения следующих действий:

  • Просмотр файлов, связанных с сайтом, в репозиториях Git
  • Синхронизация файлов и папок между локальным репозиторием и Git
  • Просмотр отслеживаемых, подготовленных и зафиксированных файлов
  • Доступ к терминалу Git

На этой панели можно также инициализировать репозиторий Git, если это еще не было сделано. При создании сайта в Dreamweaver можно связать с ним репозиторий Git. Если эта операция не была выполнена во время создания сайта, можно инициализировать репозиторий Git на панели «Файлы».

Чтобы инициализировать репозиторий, щелкните Инициализация репозитория Git на панели «Файлы». При этом файлы, связанные с вашим веб-сайтом, будут немедленно отображены в представлении Git вместе со своим статусом.

Инициализация репозиториев Git на панели «Файлы»
Инициализация репозиториев Git на панели «Файлы»

Просмотр состояния файлов

На панели «Файлы» можно просмотреть статусы файлов, связанных с репозиторием Git. После инициализации репозитория Git файлы отображаются зеленым цветом. Это означает, что файлы не отслеживаются и еще не находятся под управлением Git.

После фиксации файла он отображается белым цветом в панели «Файлы». Это означает, что для файла была выполнена операция фиксации в выбранном репозитории Git. 

Теперь, после выполнения операции фиксации, при редактировании и сохранении этого файла его цвет в панели «Файлы» меняется на желтый. Это означает, что файлы в локальном репозитории и репозитории Git не синхронизированы.

Дополнительные сведения о процессе управления версиями в Git см. в разделе Использование Git для управления версиями.

Создание веток и управление ими

На панели «Файлы» можно создавать ветки и управлять ими локально. Чтобы создать ветку, выберите раскрывающийся список в верхней части панели. Выберите «Управление ветками», а затем щелкните значок «+» в диалоговом окне «Управление ветками».

При этом можно выбрать исходную ветку и создать на ее основе новую ветку. Можно также удалять ветки и объединять одну ветку с другой.

Дополнительные сведения об управлении локальными ветками с помощью панели «Файлы» см. в разделе Создание веток и управление ими.

Выполнение базовых операций Git

Помимо инициализации и управления ветками на панели «Файлы» также можно выполнять различные операции Git. Выберите файл в панели «Файлы», щелкните его правой кнопкой мыши и выполните одно из следующих действий.

  • Выберите «Добавить в .gitignore», чтобы добавить выбранный файл или файлы в папку gitignore. Эти файлы не будут обрабатываться Git и никакие действия над ними не будут выполняться.
  • Выберите «Удалить из .gitignore», чтобы удалить файл из папки gitignore.
  • Выберите «Подготовить», чтобы подготовить указанный файл к фиксации. Подготовка является одним из шагов при выполнении операции фиксации файла в Git.
  • Выберите «Отменить подготовку», чтобы отменить подготовку указанного файла к фиксации.
  • Выберите «Подготовить все файлы», чтобы подготовить все файлы к фиксации.
  • Выберите «Отменить подготовку всех файлов», чтобы отменить подготовку всех файлов в репозитории к фиксации.
  • Выберите «Изменения», чтобы просмотреть изменения в файле между предыдущей операцией фиксации и текущей версией.
  • Выберите «История файла», чтобы просмотреть историю изменений и операций фиксации для выбранного файла.
  • Выберите «Восстановить файл», чтобы отменить все изменения, внесенные в файл, и восстановить предыдущую зафиксированную версию.
  • Выберите «Фиксация всех подготовленных файлов», чтобы выполнить операцию фиксации для всех подготовленных файлов в этом репозитории.
Выполнение операций Git на панели «Файлы»
Выполнение операций Git на панели «Файлы»

Подробнее о каждой из этих операций, а также о работе с Git в Dreamweaver, можно в разделе Использование Git в Dreamweaver.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет