Возвращайте файлы на локальный и удаленный серверы и извлекайте их обратно с помощью системы возврата и извлечения файлов Dreamweaver, WebDAV или Subversion.

При работе с другими пользователями файлы можно возвращать на удаленные и локальные серверы и извлекать с них. Если вы — единственный пользователь, работающий на удаленном сайте, команды «Разместить» и «Получить» можно использовать без возврата или извлечения файлов.

Примечание.

Функциональность «Получить» и «Разместить» можно использовать с тестовым сервером, но с ним нельзя использовать систему возврата и извлечения с сервера.

Извлечение файла равносильно объявлению «Я работаю сейчас с этим файлом, не трогайте его!» Когда файл извлечен, имя пользователя, извлекшего файл, отображается на панели «Файлы». а рядом со значком файла отображается красная галочка (если файл извлечен членом команды) или зеленая галочка (если файл извлекли вы).

Возврат файла на сервер делает его доступным для других членов и позволяет им извлекать и редактировать этот файл. Когда файл возвращается на сервер после редактирования, локальная версия файла становится доступной только для чтения, а на панели «Файлы» рядом с файлом отображается замок, предотвращающий его изменение.

На удаленном сервере Dreamweaver не делает извлеченные файлы доступными только для чтения. Если файлы передаются с помощью другого приложения (не Dreamweaver), извлеченные файлы можно перезаписать. Однако в сторонних приложениях в структуре файлов рядом с извлеченным файлом отображается файл LCK, что помогает предотвратить такую возможность.

Настройка системы возврата и извлечения

Прежде чем использовать систему возврата и извлечения с сервера, необходимо связать локальный сайт с удаленным сервером.

  1. Выберите «Веб-сайт» > «Управление веб-сайтами».
  2. Выберите сайт и нажмите кнопку «Редактировать».
  3. В диалоговом окне «Настройка сайта» выберите категорию «Серверы» и выполните одно из следующих действий:
    • нажмите кнопку «Добавить сервер» для добавления нового сервера;

    • Выберите существующий сервер и нажмите кнопку «Изменить существующий сервер».

  4. Укажите необходимые основные параметры и нажмите кнопку «Дополнительно».
  5. Нажмите кнопку «Включить извлечение файлов» при работе в групповой среде (или при самостоятельной работе, но с нескольких разных компьютеров). Отключите этот параметр, если необходимо отключить систему возврата и извлечения с сервера для сайта.

    Этот параметр предназначен для уведомления других пользователей о том, что файл извлечен для редактирования, или для уведомления вас о том, что, возможно, на другом компьютере сохранена более новая версия файла.

    Если параметры возврата и извлечения с сервера не отображаются, это значит, что удаленный сервер не был настроен.

  6. Чтобы автоматически извлекать файлы при открытии двойным щелчком мыши на панели «Файлы». выберите параметр «Извлекать файлы при открытии».

    Если этот параметр не выбран, при открытии файла с помощью команды «Открыть» в меню «Файл». извлечения не происходит.

  7. Установка остальных параметров

    Имя извлечения

    Извлеченное имя отображается на панели «Файлы» рядом с извлеченными файлами; это позволяет участникам группы взаимодействовать с определенным пользователем, которому необходим извлеченный файл.

    Примечание.

    При самостоятельной работе с нескольких различных компьютеров используйте разные имена извлечения на каждом компьютере (например, AmyR-HomeMac или AmyR-OfficePC), чтобы знать, где находится последняя версия файла, на случай, если вы забудете вернуть его.

    Адрес электронной почты

    Если при извлечении файла пользователь указывает свой электронный адрес, его имя отображается возле этого файла на панели «Файлы» в виде ссылки (синим цветом с подчеркиванием). Если член команды щелкнет по этой ссылке, в программе для работы с электронной почтой по умолчанию откроется окно сообщения с указанием электронного адреса пользователя и темой, соответствующей этому файлу и имени сайта.

Извлечение файлов из удаленной папки и отправка их обратно

Настроив систему возврата и извлечения с сервера, можно возвращать файлы на удаленный сервер и извлекать их оттуда при помощи панели «Файлы» или области «Окно документа».

Извлечение файлов при помощи панели «Файлы»

  1. На панели «Файлы» («Окно» > «Файлы») выберите файлы, которые нужно извлечь с удаленного сервера.

    Примечание.

    Файлы можно выбрать в локальном или удаленном представлении, но не в представлении тестового сервера.

    Красная галочка указывает на то, что другой член команды уже извлек файл, а значок замка сообщает о том, что файл доступен только для чтения (в Windows) или заблокирован (в Macintosh).

  2. Чтобы извлечь файлы, выполните одно из следующих действий.
    • На панели инструментов панели «Файлы» нажмите кнопку «Извлечь».

    • Щелкните правой кнопкой мыши (в Windows) или щелкните при нажатой клавише Control (в Macintosh), а затем выберите команду «Извлечь» в появившемся контекстном меню.

  3. В диалоговом окне «Зависимые файлы» нажмите кнопку «Да». чтобы загрузить зависимые файлы вместе с выбранными файлами, в противном случае нажмите «Нет». По умолчанию зависимые файлы не загружаются. Это можно сделать через меню «Правка» > «Настройки» > «Веб-сайт».

    Примечание.

    Как правило, рекомендуется загружать зависимые файлы при извлечении нового файла, но если самые последние версии зависимых файлов уже имеются на локальном диске, нет необходимости загружать их снова.

    Возле значка локального файла отображается зеленая галочка, указывающая на то, что файл извлечен.

    Примечание.

    При извлечении файла, который в настоящее время обрабатывается, текущая версия файла заменяется новой извлеченной версией.

Возврат файлов с сервера при помощи панели «Файлы»

  1. На панели «Файлы» («Окно» > «Файлы») выберите извлеченный или новый файл (или файлы).

    Примечание.

    Файлы можно выбрать в локальном или удаленном представлении, но не в представлении тестового сервера.

  2. Чтобы вернуть с сервера файлы, выполните одно из следующих действий.
    • На панели инструментов панели «Файлы» нажмите кнопку «Вернуть документ».

    • Щелкните правой кнопкой мыши (в Windows) или щелкните при нажатой клавише Control (в Macintosh), а затем выберите команду «Вернуть документ» в появившемся контекстном меню.

  3. Нажмите кнопку «Да», чтобы передать зависимые файлы вместе с выбранными файлами, в противном случае нажмите «Нет». По умолчанию зависимые файлы не передаются. Это можно сделать через меню «Правка» > «Настройки» > «Веб-сайт».

    Примечание.

    Как правило, при возврате нового файла рекомендуется передавать зависимые файлы, но если самые последние версии зависимых файлов уже находятся на удаленном сервере, то нет необходимости передавать их снова.

    Возле значка файла отображается замок, указывающий на то, что файл доступен только для чтения.

    Примечание.

    При возврате на сервер активного в настоящий момент файла он может быть автоматически сохранен перед возвратом, в зависимости от установленных параметров.

Возврат с сервера открытого файла из области «Окно документа»

  1. Убедитесь, что файл, который необходимо вернуть на сервер, открыт в области «Окно документа».

    Примечание.

    За один раз можно вернуть на сервер только один файл.

  2. Выполните одно из следующих действий.
    • В меню «Веб-сайт» выберите команду «Вернуть документ».

    • Щелкните значок «Управление файлом» на панели инструментов области «Окно документа» и в появившемся меню выберите команду «Вернуть документ».

      Если текущий файл не является частью активного сайта на панели «Файлы», Dreamweaver пытается определить, к какому определенному локальному сайту он относится. Если текущий файл не принадлежит сайту, который активен на панели «Файлы», Dreamweaver открывает этот сайт, а затем выполняет операцию возврата на сервер.

    Примечание.

    При возврате на сервер активного в настоящий момент файла он может быть автоматически сохранен перед возвратом, в зависимости от установленных параметров.  

Отмена извлечения файла

Выполнив извлечение сайта, а потом передумав его редактировать (или решив отменить сделанные изменения), можно отменить операцию извлечения. При этом файл возвращается в исходное состояние.

Чтобы отменить извлечение файла, выполните одно из следующих действий.

  • Откройте файл в области «Окно документа». а затем в меню «Веб-сайт» выберите команду «Отменить извлечение».

  • На панели «Файлы» («Окно» > «Файлы») щелкните правой кнопкой мыши (в Windows) или щелкните при нажатой клавише Control (в Macintosh), а затем выберите «Отменить извлечение».

    Локальная копия файла становится доступной только для чтения и все внесенные в нее изменения утрачиваются.

Использование протокола WebDAV для возврата и извлечения файлов с сервера

Dreamweaver может подключаться к серверу, использующему протокол WebDAV (Web-based Distributed Authoring and Versioning), который является набором расширений для протокола HTTP и позволяет пользователям совместно редактировать файлы и управлять ими на удаленных веб-серверах. Дополнительные сведения см. по адресу: www.webdav.org.

  1. Определите сайт Dreamweaver, который задает локальную папку, используемую для хранения файлов проекта, если эта процедура не была выполнена ранее.
  2. В меню «Веб-сайт» выберите «Управление веб-сайтами». а затем дважды щелкните свой сайт в списке.
  3. В диалоговом окне «Настройка сайта» выберите категорию «Серверы» и выполните одно из следующих действий:
    • нажмите кнопку «Добавить сервер» для добавления нового сервера;

    • Выберите существующий сервер и нажмите кнопку «Изменить существующий сервер».

  4. на экране «Основные» выберите WebDAV из всплывающего меню «Подключение с помощью», затем заполните, как требуется, оставшиеся параметры на экране «Основные».
  5. Нажмите кнопку «Дополнительно».
  6. Выберите параметр «Включить извлечение файлов» и введите следующую информацию.
    • В поле «Имя извлечения» введите имя, по которому вас будут идентифицировать другие члены команды.

    • В поле «Адрес электронной почты» введите ваш адрес электронной почты.

      Имя и адрес электронной почты используются для владельца на сервере WebDAV и отображаются на панели «Файлы» в качестве контактной информации.

  7. Нажмите кнопку «Сохранить».

    Dreamweaver выполняет настройку сайта для доступа к серверу WebDAV. При использовании команд «Вернуть документ» или «Извлечь» для любого файла сайта этот файл передается по протоколу WebDAV.

    Примечание.

    Возможно, протокол WebDAV не сможет правильно извлечь файлы с динамическим содержимым, например с тегами PHP или SSI, поскольку функция HTTP GET загружает их при извлечении.

Использование Subversion (SVN) для получения и возврата файлов

Примечание.

В Dreamweaver CC 2017 и более поздних версиях отсутствует поддержка Subversion (SVN).

Dreamweaver может подключаться к серверу, на котором используется система управления версиями Subversion (SVN), позволяющая пользователям совместно редактировать файлы и управлять ими на удаленных веб-серверах. Dreamweaver не является полнофункциональным клиентом SVN, но позволяет пользователям получать последние версии файлов, производить изменения и отправлять их измененные версии на сервер.

Примечание.

Dreamweaver CS5 использует клиентскую библиотеку Subversion 1.6.6, а Dreamweaver CS5.5 — клиентскую библиотеку 1.6.9. Более поздние версии клиентской библиотеки Subversion не обладают обратной совместимостью. Следует иметь в виду, что при обновлении стороннего клиентского приложения (например, TortoiseSVN) для работы с более поздней версией Subversion обновленное приложение Subversion обновит локальные метаданные Subversion, и Dreamweaver больше не сможет обмениваться данными с Subversion. Эта проблема не затрагивает обновления сервера Subversion, т. к. они обладают обратной совместимостью. Если обновление стороннего клиентского приложения, работающего с Subversion 1.7 или более поздней версией, не производится, то необходимо проверить обновления Adobe перед повторным использованием Subversion вместе с Dreamweaver. Дополнительные сведения по этому вопросу см. по адресу: www.adobe.com/go/dw_svn_en.

Компания Adobe рекомендует использовать инструмент сравнения файлов стороннего разработчика во время работы с файлами, находящимися под контролем версий SVN. При сравнении файлов на предмет различий можно узнать, какие именно изменения были внесены в файлы другими пользователями. Для получения дополнительных сведений об инструментах сравнения файлов воспользуйтесь поисковой системой Интернета, например Google Search, набрав в строке поиска фразу «сравнение файлов» или «программы обнаружения различий». Dreamweaver поддерживает большинство инструментов сравнения файлов сторонних разработчиков.

Видеообзор работы с SVN и Dreamweaver см. по адресу: www.adobe.com/go/lrvid4049_dw.

Установка SVN-подключения

Прежде чем использовать систему управления версиями Subversion (SVN) с программой Dreamweaver, необходимо настроить подключение к серверу SVN. Подключение к SVN-серверу настраивается в категории «Управление версиями» диалогового окна «Определение сайта».

SVN-сервер является репозиторием (хранилищем) файлов, из которого файлы могут извлекаться пользователем и в которое пользователи «фиксируют» изменения файлов. Он отличается от удаленного сервера, который обычно используется в работе с Dreamweaver. Когда используется SVN, удаленный сервер продолжает выполнять роль «интерактивного» сервера для веб-страниц, а SVN-сервер предназначается для хранения репозитория файлов, для которых пользователь хочет поддерживать управление версиями. Типичный рабочий процесс состоит в получении файлов с SVN-сервера и фиксации их изменений обратно на SVN-сервере, с последующей публикацией файлов на удаленный сервер из Dreamweaver . Установка удаленного сервера полностью отделена от установки SVN.

Перед началом этой установки необходимо получить доступ к SVN-серверу и SVN-репозиторию. Дополнительные сведения об SVN см. на веб-сайте Subversion по адресу: http://subversion.apache.org/.

Чтобы установить SVN-подключение, выполните следующие действия.

  1. Выберите команду «Веб-сайт» > «Управление веб-сайтами», выберите сайт, для которого требуется настроить управление версиями, и нажмите кнопку «Редактировать».

    Примечание.

    Если для сайта Dreamweaver еще не установлены локальные и удаленные папки, необходимо как минимум настроить локальный сайт, прежде чем продолжить. (Удаленный сайт на этом этапе не требуется, но его все же необходимо будет установить перед публикацией файлов в Интернете.) Дополнительную информацию см. на сайте Работа с Dreamweaver.

  2. В диалоговом окне «Настройка сайта» выберите категорию «Управление версиями».

  3. Выберите «Subversion» во всплывающем меню «Доступ».

  4. Настройте параметры доступа следующим образом.

    • Выберите протокол во всплывающем меню «Протокол». Доступны следующие протоколы: HTTP, HTTPS, SVN и SVN+SSH.

    Примечание.

    Для использования протокола SVN+SSH требуется специальная настройка. Дополнительные сведения см. по адресу: www.adobe.com/go/learn_dw_svn_ssh_en.

    • В текстовом поле «Адрес сервера» укажите адрес SVN-сервера (обычно используется формат имя_сервера.домен.com).

    • В текстовом поле «Путь к репозиторию» укажите путь к репозиторию на сервере SVN (обычно используется формат /svn/корневой_каталог). Имя корневой папки для репозитория SVN присваивается администратором сервера.

    • Если необходимо использовать серверный порт, отличный от установленного по умолчанию, выберите «Не по умолчанию» и введите номер порта в текстовое поле (необязательно).

    • Введите имя пользователя и пароль для SVN-сервера.

  5. Нажмите кнопку «Тест», чтобы протестировать подключение, или «ОК», чтобы закрыть диалоговое окно. Затем нажмите кнопку «Готово», чтобы закрыть диалоговое окно «Управление сайтами».

После установки подключения к серверу SVN-репозиторий будет доступен для просмотра на панели «Файлы». Для его просмотра выберите пункт «Репозиторий» во всплывающем меню «Просмотр» или нажмите кнопку «Файлы репозитория»  на развернутой панели «Файлы».

Получение последних версий файлов

При получении последней версии файла из SVN-репозитория Dreamweaver объединяет содержимое этого файла с содержимым соответствующей его локальной копии. (Иными словами, если кто-либо другой внес в файл поправки после совершения Вами последней фиксации изменений, эти поправки будут объединены с локальной версией файла на вашем компьютере.) Если файл еще не существует на локальном жестком диске, Dreamweaver попросту получит его.

Примечание.

При первом получении файлов из репозитория необходимо работать с локальным пустым каталогом или локальным каталогом, который не содержит файлов с такими же именами, что и у файлов, хранящихся в репозитории. Приложение Dreamweaver не выполнит монтирование файлов репозитория к локальному диску с первой попытки, если на локальном диске размещены файлы, имена которых совпадают с именами файлов, хранящихся в удаленном репозитории.

  1. Убедитесь, что SVN-подключение успешно установлено.

  2. Выполните одно из следующих действий.

    • Отобразите локальную версию файлов SVN на панели «Файлы», выбрав «Локальное представление» во всплывающем меню «Вид». (При работе с развернутой панелью «Файлы» локальное представление отображается автоматически.) Затем щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) нужные файлы или папку и выберите команду «Управление версиями» > «Получить последние версии».

    • Отобразите файлы SVN-репозитория, выбрав пункт «Репозиторий» во всплывающем меню «Вид» на панели «Файлы» или нажав кнопку «Файлы репозитория» на развернутой панели «Файлы». Затем щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) нужные файлы или папку и выберите команду «Получить последние версии».

Примечание.

Также можно щелкнуть файл правой кнопкой мыши и выбрать в контекстном меню команду «Извлечь» или выделить файл и нажать кнопку «Извлечь», чтобы получить последнюю версию файла. Однако, поскольку SVN не поддерживает рабочий процесс извлечения, это действие фактически не приведет к извлечению файла в привычном понимании.

Фиксация файлов

  1. Убедитесь, что SVN-подключение успешно установлено.

  2. Выполните одно из следующих действий.

    • Отобразите локальную версию файлов SVN на панели «Файлы», выбрав «Локальное представление» во всплывающем меню «Вид». (При работе с развернутой панелью «Файлы» локальное представление отображается автоматически.) Затем выберите фиксируемый файл и нажмите кнопку «Вернуть документ».

    • Отобразите файлы SVN-репозитория, выбрав пункт «Репозиторий» во всплывающем меню «Вид» на панели «Файлы» или нажав кнопку «Файлы репозитория» на развернутой панели «Файлы». Затем щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) файл, который необходимо зафиксировать, и выберите команду «Вернуть документ».

  3. Просмотрите действия в диалоговом окне «Фиксация», внесите необходимые изменения и нажмите кнопку «ОК».

    Для изменения действия, выберите файл (действие над которым необходимо изменить) и нажмите соответствующую кнопку внизу диалогового окна «Фиксация». На выбор доступны два действия: фиксация и игнорирование.

Примечание.

Зеленый флажок у имени файла на панели «Файлы» обозначает измененный файл, который еще не был зафиксирован в репозитории.

Обновление состояния файлов или папок в репозитории

Можно обновить состояние SVN отдельного файла или папки. Данная операция не обновляет весь экран.

  1. Убедитесь, что SVN-подключение успешно установлено.

  2. Отобразите файлы SVN-репозитория, выбрав пункт «Репозиторий» во всплывающем меню «Вид» на панели «Файлы» или нажав кнопку «Файлы репозитория» на развернутой панели «Файлы».

  3. Щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) любой файл или папку из репозитория и выберите команду «Обновить статус».

Обновление состояния локального файла или папок

Можно обновить состояние SVN отдельного файла или папки. Данная операция не обновляет весь экран.

  1. Убедитесь, что SVN-подключение успешно установлено.

  2. Отобразите локальную версию файлов SVN на панели «Файлы», выбрав «Локальное представление» во всплывающем меню «Вид». (При работе с развернутой панелью «Файлы» локальное представление отображается автоматически.)

  3. Щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) любой файл или папку на панели «Файлы» и выберите команду «Обновить статус».

Просмотр редакций файла

  1. Убедитесь, что SVN-подключение успешно установлено.

  2. Выполните одно из следующих действий.

    • Отобразите локальную версию файлов SVN на панели «Файлы», выбрав «Локальное представление» во всплывающем меню «Вид». (При работе с развернутой панелью «Файлы» локальное представление отображается автоматически.) Затем щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) файл, редакции которого необходимо просмотреть, и выберите меню «Управление версиями» > «Показать версии».

    • Отобразите файлы SVN-репозитория, выбрав пункт «Репозиторий» во всплывающем меню «Вид» на панели «Файлы» или нажав кнопку «Файлы репозитория» на развернутой панели «Файлы». Затем щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) файл, редакции которого необходимо просмотреть, и выберите команду «Показать версии».

  3. В диалоговом окне «Журнал версий» выделите нужную редакцию или редакции и выполните одно из следующих действий.

    • Нажмите кнопку «Сравнить с локальным», чтобы сравнить выделенную редакцию с локальной версией файла.

    Примечание.

    Для сравнения файлов нужно установить инструмент сравнения файлов сторонней разработки. Для получения дополнительных сведений об инструментах сравнения файлов воспользуйтесь поисковой системой Интернета, например Google Search, набрав в строке поиска фразу «сравнение файлов» или «программы обнаружения различий». Dreamweaver поддерживает большинство инструментов сравнения файлов сторонних разработчиков.

    • Нажмите кнопку «Сравнить», чтобы сравнить две выделенные редакции. Чтобы одновременно выделить две версии, щелкните их при нажатой клавише Ctrl.

    • Нажмите кнопку «Просмотр», чтобы просмотреть выделенную редакцию. Это действие не приводит к перезаписи текущей локальной копии того же файла. Выделенную редакцию можно сохранить на жестком диске, как любой другой файл.

    • Нажмите кнопку «Преобразовать», чтобы сделать выделенную редакцию последней редакцией в репозитории.

Блокировка и разблокировка файлов

Блокирование файла в репозитории SVN указывает другим пользователям на то, что вы работаете с этим файлом. Другие пользователи по-прежнему смогут локально редактировать этот файл, но не смогут выполнить фиксацию файла, пока он не будет разблокирован. При блокировке файла в репозитории на нем отображается значок открытого замка. Другие пользователи видят значок закрытого замка.

  1. Убедитесь, что SVN-подключение успешно установлено.

  2. Выполните одно из следующих действий.

    • Отобразите файлы SVN-репозитория, выбрав пункт «Репозиторий» во всплывающем меню «Вид» на панели «Файлы» или нажав кнопку «Файлы репозитория» на развернутой панели «Файлы». Затем щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) нужные файлы или папку и выберите команду «Заблокировать» или «Разблокировать».

    • Отобразите локальную версию файлов SVN на панели «Файлы», выбрав «Локальное представление» во всплывающем меню «Вид». (При работе с развернутой панелью «Файлы» локальное представление отображается автоматически.) Затем щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) нужные файлы или папку и выберите команду «Заблокировать» или «Разблокировать».

Добавление нового файла в репозиторий

Синий значок «плюс» на файле в панели «Файлы» обозначает файл, которого еще не существует в репозитории SVN.

  1. Убедитесь, что SVN-подключение успешно установлено.

  2. На панели «Файлы» выберите файл, который необходимо добавить в репозиторий, и нажмите кнопку «Вернуть документ».

  3. Убедитесь, что файл выбран для фиксации в диалоговом окне «Фиксация», и нажмите кнопку «ОК».

Перенос, копирование, удаление и возврат к сохраненным файлам

  • Чтобы перенести файл, перетащите его в целевую папку на локальном сайте.

    При переносе файла Dreamweaver отмечает этот файл в новом расположении значком «Добавить с историей», а в старом расположении — значком «Удалить». При фиксации файл в старом расположении удаляется.

  • Чтобы скопировать файл, выберите его, скопируйте («Правка» > «Копировать») и вставьте в новом расположении («Правка» > «Вставить»).

    При копировании и вставке файла Dreamweaver отмечает этот файл в новом расположении значком «Добавить с историей».

  • Чтобы удалить файл, выберите его и нажмите клавишу Delete.

    Dreamweaver предоставляет возможность удалить только локальную копию файла или локальную копию вместе с копией на SVN-сервере. Если выбрать удаление только локальной копии, файл на SVN-сервере не затрагивается. Если выбрать удаление копии и на SVN-сервере, локальная копия отмечается значком «Удалить», после чего необходимо выполнить фиксацию файлов, чтобы завершить удаление.

  • Чтобы вернуть скопированный или перенесенный файл в исходное расположение, щелкните его правой кнопкой мыши и выберите «Управление версиями» > «Вернуться».

Разрешение конфликтов между файлами

Если данный файл конфликтует с другим файлом, расположенным на сервере, его можно отредактировать, а затем пометить как разрешенный. Например, при попытке выполнить возврат файла, который конфликтует с изменениями другого пользователя, система SVN не позволит зафиксировать этот файл. Из репозитория можно получить последнюю версию файла, вручную внести изменения в рабочую копию, а затем пометить свой файл как разрешенный, чтобы его можно было зафиксировать.

  1. Убедитесь, что SVN-подключение успешно установлено.

  2. Отобразите локальную версию файлов SVN на панели «Файлы», выбрав «Локальное представление» во всплывающем меню «Вид». (При работе с развернутой панелью «Файлы» локальное представление отображается автоматически.)

  3. Щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) файл, для которого необходимо разрешить конфликт, и выберите команду «Управление версиями» > «Пометить как разрешенные».

Переход в автономный режим

Может быть полезно предотвратить доступ к репозиторию во время других действий по передаче файлов, перейдя в автономный режим. Dreamweaver повторно подключится к репозиторию SVN сразу после вызова действия, которому требуется подключение («Получить последние версии», «Фиксация» и т.д.).

  1. Убедитесь, что SVN-подключение успешно установлено.

  2. Отобразите локальную версию файлов SVN на панели «Файлы», выбрав «Локальное представление» во всплывающем меню «Вид». (При работе с развернутой панелью «Файлы» локальное представление отображается автоматически.)

  3. Щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) любой файл или папку на панели «Файлы» и выберите команду «Управление версиями» > «Перейти в автономный режим».

Очистить локальный сайт SVN

С помощью этой команды можно снять замки с файлов, чтобы возобновить незаконченные операции. Эту команду следует использовать для удаления старых замков в случае получения ошибок «рабочая копия заблокирована».

  1. Убедитесь, что SVN-подключение успешно установлено.

  2. Отобразите локальную версию файлов SVN на панели «Файлы», выбрав «Локальное представление» во всплывающем меню «Вид». (При работе с развернутой панелью «Файлы» локальное представление отображается автоматически.)

  3. Щелкните правой кнопкой мыши (Windows) или щелкните при нажатой клавише Control (Macintosh) файл, который необходимо очистить, и выберите команду «Управление версиями» > «Очистить».

О перемещении файлов и папок на сайтах под управлением Subversion

Перемещение локальных версий файлов или папок на сайте под управлением Subversion создает риск возникновения проблем для других пользователей, осуществляющих синхронизацию с SVN-репозиторием. Например, если переместить файл локально и не зафиксировать его в репозитории в течение ближайших нескольких часов, другой пользователь может попытаться получить последнюю версию файла из старого расположения. По этой причине следует всегда фиксировать файлы на SVN-сервере сразу после их локального перемещения.

Файлы и папки остаются на SVN-сервере до тех пор, пока их не удалят вручную. Поэтому, даже если переместить файл в другую локальную папку и зафиксировать его, старая версия файла останется в предыдущем расположении на сервере. Во избежание недоразумений следует удалять старые копии перемещенных файлов и папок.

При локальном перемещении файла и его фиксации на SVN-сервере история версий файла будет утеряна.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет