Узнайте, как интегрировать Photoshop в Dreamweaver. Работайте со смарт-объектами в процессах Photoshop и Dreamweaver.

Сведения об интеграции Photoshop

Файлы изображений Photoshop (формат PSD) можно вставить на веб-страницу в Dreamweaver и оптимизировать их для веб (форматы GIF, JPEG или PNG) с помощью Dreamweaver. В результате этого Dreamweaver вставляет изображение как смарт-объект и поддерживает активное соединение с исходным PSD-файлом.

Кроме того, на веб-страницу в Dreamweaver можно добавить многослойные или многофрагментные изображения Photoshop (все или частично). Однако при копировании и вставке из Photoshop активное соединение с исходным файлом не поддерживается. Чтобы обновить изображение, выполните изменения в Photoshop, а затем повторите копирование и вставку.

Примечание.

При интенсивном использовании функции интеграции выгоднее сохранить файлы Photoshop на сайте Dreamweaver, чтобы ускорить доступ к ним. В этом случае не забудьте скрыть их, чтобы закрыть доступ к исходным ресурсам и исключить лишнюю передачу данных между локальным сайтом и удаленным сервером.

Руководство, посвященное интеграции Photoshop с Dreamweaver, см. в разделе Интеграция Dreamweaver с Photoshop.

Сведения о рабочих процессах смарт-объекта и Photoshop-Dreamweaver

При работе с файлами Photoshop в Dreamweaver существует два основных рабочих процесса: процесс копирования/вставки из буфера и процесс смарт-объекта.

Процесс копирования/вставки из буфера

Процесс копирования/вставки из буфера позволяет выбирать фрагменты или слои в файле Photoshop, а затем использовать Dreamweaver для вставки их как изображений, готовых для работы с Интернетом. Если необходимо обновить содержание позднее, следует открыть исходный файл Photoshop, внести изменения, повторно скопировать фрагмент или слой в буфер, а затем вставить обновленный фрагмент или уровень в Dreamweaver. Этот процесс рекомендуется использовать только в тех случаях, когда часть файла Photoshop (например, раздел плана разработки) необходимо вставить как изображение на веб-странице.

Процесс смарт-объекта

При работе с завершенными файлами Photoshop Adobe рекомендует использовать процесс смарт-объекта. Смарт-объект в Dreamweaver — это ресурс изображений, помещенный на веб-странице, на которой имеется активное подключение к исходному файлу Photoshop (PSD). В представлении «Дизайн» в Dreamweaver смарт-объект обозначается значком в верхнем левом углу изображения.

Смарт-объект
Смарт-объект

Если веб-изображение (т. е. изображение на странице Dreamweaver) не соответствует исходному файлу Photoshop, Dreamweaver определяет обновление исходного файла и отображает один из значков смарт-объекта красным цветом. Если выбрать веб-изображение в представлении «Дизайн» и нажать кнопку «Обновить из оригинала» в инспекторе свойств, то изображение обновится автоматически с учетом всех изменений, внесенных в исходный файл Photoshop.

При использовании процесса смарт-объекта для обновления веб-изображения не нужно открывать Photoshop. Кроме того, все обновления смарт-объекта в Dreamweaver не оказывают негативного влияния на остальные процессы. Таким образом поддерживается возможность внесения изменений в веб-версию изображения на странице, при этом исходное изображение Photoshop не затрагивается.

Также можно обновить смарт-объект, не выбирая веб-изображение в представлении «Дизайн». Панель «Ресурсы» используется для обновления всех смарт-объектов, включая изображения, для которых может быть заблокирована возможность выбора в окне документа (например, фоновые изображения CSS).

Параметры оптимизации изображения

Для процесса копирования/вставки из буфера и процесса смарт-объекта можно указать параметры оптимизации в диалоговом окне Оптимизация изображения. Это диалоговое окно позволяет указывать формат файла и качество изображения. При копировании фрагмента или слоя или при вставке файла Photoshop как смарт-объекта Dreamweaver отображает это диалоговое окно, в котором можно с легкостью создать веб-изображение.

При копировании и вставке из буфера обновления определенного фрагмента или слоя Dreamweaver запоминает исходные параметры и восстанавливает веб-изображение с использованием этих настроек. Точно так же при обновлении смарт-объекта с помощью инспектора свойств Dreamweaver использует те же настройки, которые использовались при вставке изображения в первый раз. Параметры изображения можно изменить в любой момент, выбрав веб-изображение в представлении «Дизайн» и нажав кнопку Изменить параметры изображения в инспекторе свойств.

Хранение файлов Photoshop

При вставке веб-изображения, если исходный файл Photoshop не сохранен на сайте Dreamweaver, то Dreamweaver распознает путь к исходному файлу как абсолютный локальный путь к файлу (это же относится и к процессу копирования/вставки из буфера, и к процессу смарт-объекта). Например, если путь к сайту Dreamweaver прописан как C:\Sites\mySite, а файл Photoshop сохранен в C:\Images\Photoshop, Dreameaver не распознает исходный ресурс как часть сайта mySite. Это может привести к затруднениям при необходимости общего доступа к файлу Photoshop для других участников рабочей группы, поскольку Dreamweaver определит файл как доступный только на определенном локальном диске.

Однако при сохранении файла Photoshop на сайте Dreamweaver устанавливает путь к файлу через сайт. Все пользователи, которые имеют доступ к сайту, смогут установить правильный путь к файлу при условии, что для загрузки был предоставлен исходный файл.

Для просмотра видеоруководства о двунаправленном редактировании в Photoshop см. раздел Двунаправленное редактирование с помощью Photoshop.

Создание смарт-объекта

При вставке в страницу изображения Photoshop (PSD-файла) Dreamweaver создает смарт-объект. Смарт-объект — это готовое для веб-публикации изображение, для которого поддерживается активное соединение с исходным изображением Photoshop. При изменении в Photoshop исходного изображения Dreamweaver дает возможность обновить изображение в Dreamweaver нажатием единственной кнопки.

  1. В Dreamweaver (в представлении кода или «Дизайн») поместите курсор вставки в то место на странице, куда следует вставить изображение.
  2. Выберите пункт меню Вставка > Изображение.

    Примечание.

    Можно также перетащить на страницу PSD-файл с панели «Файлы», если файлы Photoshop хранятся на веб-сайте. В этом случае следующий шаг можно пропустить.

  3. Укажите файл изображения Photoshop PSD в диалоговом окне Выбрать исходный файл изображения. Для этого нажмите кнопку «Обзор» и перейдите в нужную папку.

  4. В открывшемся диалоговом окне Оптимизация изображения задайте параметры оптимизации и нажмите кнопку «ОК».

  5. Сохраните подготовленные для веб файлы изображений в корневой папке веб-сайта.

Dreamweaver создает смарт-объект на основе заданных параметров оптимизации и помещает на страницу готовую для веб-публикации версию изображения. Смарт-объект поддерживает активное соединение с исходным изображением и отражает рассинхронизацию этих двух изображений.

Примечание.

Если впоследствии понадобится изменить параметры оптимизации для изображений, размещенных на страницах, выделите изображение, нажмите кнопку Изменить параметры изображения в инспекторе свойств и внесите изменения в диалоговом окне Оптимизация изображения. Изменения, внесенные в диалоговом окне Оптимизация изображения, применяются недеструктивно. Это означает, что Dreamweaver никогда не изменяет исходный файл Photoshop, всегда пересоздавая веб-изображение на основе исходных данных.

Для просмотра видеоруководства о двунаправленном редактировании в Photoshop см. раздел Двунаправленное редактирование с помощью Photoshop.

Обновление смарт-объекта

При изменении файла Photoshop, на который указывает смарт-объект, Dreamweaver уведомляет о том, что веб-изображение рассинхронизировалось с исходным изображением. Смарт-объекты в Dreamweaver обозначаются значком в верхнем левом углу изображения. Если веб-изображение Dreamweaver синхронизировано с исходным файлом Photoshop, то обе стрелки этого значка будут зелеными. Если веб-изображение рассинхронизировалось с исходным файлом Photoshop, то одна из стрелок значка будет красной.

  1. Чтобы обновить смарт-объект текущим содержимым исходного файла Photoshop, выделите его в окне документа и нажмите в инспекторе свойств кнопку Обновить из оригинала.

Примечание.

Для выполнения этого обновления из Dreamweaver установка Photoshop не требуется.

Обновление нескольких смарт-объектов

Можно обновить несколько смарт-объектов одновременно с помощью панели «Ресурсы». Эта панель также позволяет просматривать смарт-объекты, которые невозможно выделить в окне документа (например, фоновые изображения CSS).

  1. Откройте на панели «Файлы» вкладку «Ресурсы», которая содержит список ресурсов веб-сайта.
  2. Убедитесь, что выбрано представление «Изображения». Если выбрано другое представление, нажмите кнопку Изображения.

  3. На панели «Изображения» можно выбрать любое изображение. При выборе смарт-объекта в его верхнем левом углу появится значок. Обычные изображения его не имеют.
  4. Для каждого из смарт-объектов, которые необходимо обновить, щелкните имя файла правой кнопкой мыши и выберите «Обновить из оригинала». Можно также выделить несколько файлов, удерживая нажатой клавишу Control, а затем одновременно их обновить.

Примечание.

Для выполнения этого обновления из Dreamweaver установка Photoshop не требуется.

Изменение размера смарт-объекта

Изменение размера смарт-объекта производится в окне документа точно таким же образом, как и любого другого изображения.

  1. Выделите смарт-объект в окне документа и перетаскивайте элементы управления размером. Чтобы сохранить пропорции ширины и высоты, удерживайте при этом нажатой клавишу Shift.
  2. Нажмите кнопку Обновить из оригинала в инспекторе свойств.

    При обновлении смарт-объекта производится недеструктивный повторный рендеринг веб-изображения по новому размеру на основе текущего содержимого исходного файла и исходных параметров оптимизации.

Редактирование исходного файла Photoshop для смарт-объекта

После создания на странице Dreamweaver смарт-объекта его исходный PSD-файл можно изменять в Photoshop. После сохранения изменений в Photoshop можно легко обновить веб-изображение в Dreamweaver.

Примечание.

Убедитесь, что Photoshop назначен основным внешним редактором изображений.

  1. Выделите смарт-объект в окне документа.
  2. Нажмите кнопку Изменить в инспекторе свойств.

  3. Внесите изменения в Photoshop и сохраните результат в новый PSD-файл.
  4. В Dreamweaver снова выделите смарт-объект и нажмите кнопку Обновить из оригинала.

Примечание.

Если в Photoshop был изменен размер изображения, то необходимо сбросить размер веб-изображения в Dreamweaver. Dreamweaver обновляет только содержимое смарт-объекта, но не его размеры. Чтобы синхронизировать размеры веб-изображения с размером исходного файла Photoshop, щелкните изображение правой кнопкой мыши и выберите пункт Восстановить исходный размер.

Состояния смарт-объекта

В следующей таблице приведены значения различных состояний смарт-объектов.

Состояние смарт-объекта

Описание

Рекомендуемое действие

Изображения синхронизированы

Веб-изображение синхронизировано с текущим содержимым исходного файла Photoshop. Атрибуты высоты и ширины в HTML-коде соответствуют размерам веб-изображения.

Нет

Исходный ресурс изменен

Исходный файл Photoshop был изменен после создания веб-изображения в Dreamweaver.

Чтобы синхронизировать два изображения, нажмите кнопку Обновить из оригинала в инспекторе свойств.

Размеры веб-изображения отличаются от выбранных значений ширины и высоты HTML

Атрибуты ширины и высоты в HTML-коде отличаются от размеров веб-изображения, созданного Dreamweaver при вставке. Если размеры веб-изображения меньше, чем выбранные значения ширины и высоты в HTML-коде, то веб-изображение может отображаться некачественно.

Нажмите кнопку «Обновить из оригинала» в инспекторе свойств, чтобы пересоздать веб-изображение на основе исходного файла Photoshop. Dreamweaver использует при повторном создании изображения текущую, заданную в HTML-коде ширину и высоту.

Размеры исходного ресурса слишком малы для выбранных значений ширины и высоты HTML

Атрибуты ширины и высоты в HTML-коде больше, чем размеры исходного файла Photoshop. Веб-изображение может отображаться некачественно.

Не создавайте веб-изображения с размерами больше исходного файла Photoshop.

Исходный ресурс не найден

Dreamweaver не удалось найти исходный файл Photoshop, указанный в поле «Исходный» инспектора свойств.

Измените путь к файлу в поле «Исходный» инспектора свойств или переместите файл Photoshop в текущее указанное местоположение.

Копирование и вставка выделенного фрагмента из Photoshop

Можно скопировать все или несколько изображений Photoshop и вставить их на страницу Dreamweaver уже подготовленными для веб. Можно скопировать один слой или набор слоев для выделенной области изображения, а также фрагмент изображения. Однако при этом Dreamweaver не создаст смарт-объект.

Примечание.

Функция «Обновить из оригинала» для вставленных изображений будет недоступна, но тем не менее исходный файл Photoshop можно будет открыть, выделив вставленное изображение и нажав кнопку Изменить в инспекторе свойств.

  1. В Photoshop выполните одно из перечисленных ниже действий.
    • Целиком или частично скопируйте один слой, выделив с помощью инструмента «Область» часть изображения, которую необходимо скопировать, а затем выберите меню Редактирование > Копировать. При этом для выбранной области в буфер обмена копируется только активный слой. Эффекты на основе слоев не копируются.
    • Скопируйте и объедините несколько слоев с помощью инструмента «Область», чтобы выделить часть изображения, которую необходимо скопировать, а затем выберите меню Редактирование > Скопировать совмещенные данные. При этом слой выделенной области и все слои под ним сводятся и копируются в буфер обмена. Успешно копируются эффекты на основе слоев и связанные с любым из этих слоев.
    • Скопируйте фрагмент, выделив его с помощью инструмента «Выделение фрагмента» и выбрав меню Редактирование > Копировать. При этом активный слой фрагмента и все слои под ним сводятся и копируются в буфер обмена.

    Примечание.

    Чтобы быстро выделить изображение полностью, выберите меню Выделение > Все.

  2. В Dreamweaver (в представлении кода или «Дизайн») поместите курсор вставки в то место на странице, куда следует вставить изображение.
  3. Выберите Редактирование > Вставить.

  4. В диалоговом окне Просмотр изображения настройте параметры оптимизации и нажмите кнопку «ОК».

  5. Сохраните подготовленные для веб файлы изображений в корневой папке веб-сайта.

Dreamweaver определяет изображение согласно настройкам оптимизации и размещает подготовленный вариант изображения на странице. Такие сведения об изображении, как расположение исходного PSD-файла, сохраняются в заметках разработчика независимо от их доступности на сайте. Заметки разработчика позволяют вернуть для редактирования первоначальный исходный файл из Dreamweaver.

Редактирование вставленных изображений

После вставки на страницу Dreamweaver изображения Photoshop исходный PSD-файл можно изменять в Photoshop. Чтобы сохранить целостность исходного файла, при использовании техники копирования-вставки рекомендуется всегда вносить изменения в исходный PSD-файл (а не в веб-изображение), а затем выполнять вставку заново.

Примечание.

Убедитесь, что Photoshop назначен первичным внешним редактором изображений для соответствующего типа файла.

  1. В Dreamweaver выберите подготовленное для веб изображение, которое первоначально создано в Photoshop, и выполните один из следующих шагов.
    • Нажмите кнопку Изменить в инспекторе свойств изображения.
    • Нажмите клавишу Control (Windows) или Command (Macintosh) и дважды щелкните файл.
    • Щелкните изображение правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу Control (Macintosh), а затем в контекстном меню выберите команду «Редактировать оригинал с помощью» > Photoshop.

    Примечание.

    Для этого необходимо, чтобы Photoshop был установлен в качестве основного внешнего графического редактор для файлов изображений PSD. Кроме того, Photoshop можно установить в качестве редактора по умолчанию и для других типов файлов JPEG, GIF и PNG.

  2. Измените файл в Photoshop.
  3. Вернитесь в Dreamweaver и вставьте в страницу обновленное изображение или выделение.

Если в какой-то момент времени потребуется выполнить повторную оптимизацию изображения, выделите изображение и нажмите в инспекторе свойств кнопку Изменить параметры изображения.

Настройка параметров в диалоговом окне «Оптимизация изображения»

При создании смарт-объекта или вставке выделения из Photoshop Dreamweaver отображает диалоговое окно Оптимизация изображения. (оно отображается также для любого другого типа изображения, если выделить изображение и нажать в инспекторе свойств кнопку Изменить параметры изображения). В этом диалоговом окне можно задать и просмотреть параметры для веб-изображений, подобрав цвета, параметры сжатия и качества.

Изображение, подготовленное для веб, — это изображение, которое отображается одинаково во всех современных веб-браузерах на любых ОС. Обычно приходится искать компромисс между качеством и размером файла.

Примечание.

Любые выбранные параметры влияют только на импортируемый файл изображения. Исходный файл Photoshop PSD или Fireworks PNG всегда остается неизменным.

Стиль

Выберите самые подходящие установки. Размер файла изображения изменяется в соответствии с выбранными установками. Мгновенный просмотр изображения с примененными настройками доступен в фоновом режиме.

Например, для изображений, которые должны отображаться с высокой степенью четкости, выберите PNG24 для фотографий (резкие детали).  Выберите GIF для фоновых изображений (Узоры) для вставки узора, который послужит фоном страницы.

При выборе установок отображаются настраиваемые параметры этих установок. Для дополнительной настройки параметров оптимизации измените значения этих параметров.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет