О заметках разработчика

Заметки разработчика — примечания, создаваемые для файла. Эти заметки связаны с определенным файлом, но хранятся в отдельном файле. Чтобы увидеть, какие файлы имеют заметки разработчика, раскройте панель «Файлы». При наличии заметок в столбце «Заметки разработчика» отображается соответствующий значок.

Заметки разработчика можно использовать для хранения дополнительной информации о документах, например имен исходных файлов изображений или комментариев о состоянии файлов. Например, если документ был скопирован с другого сайта, в заметках разработчика для данного документа можно добавить комментарий о том, что исходный документ расположен на другом сайте.

Кроме того, заметки разработчика можно использовать для хранения конфиденциальной информации, которую не рекомендуется хранить в документе по причинам безопасности. Например, это может быть информация о методике выбора цен или конфигурации, о рыночных факторах, повлиявших на дизайнерское решение.

Если открыть файл в Adobe® Fireworks® или Flash и экспортировать его в другой формат, то исходное имя файла будет автоматически сохранено в файле заметок разработчика. Например, если с помощью программы Fireworks файл myhouse.png экспортирован в файл myhouse.gif, то при этом Fireworks создаст файл заметок разработчика с именем myhouse.gif.mno. В указанный файл заметок имя исходного файла записывается в виде абсолютного file: URL-адрес. Таким образом, заметки разработчика для файла myhouse.gif могут содержать следующую строку.

fw_source="file:///Mydisk/sites/assets/orig/myhouse.png"

Заметки разработчика, созданные программой Flash, могут содержать следующую строку.

fl_source="file:///Mydisk/sites/assets/orig/myhouse.fla"

Примечание.

Чтобы открыть общий доступ к заметкам разработчика, пользователи должны задать одинаковый путь к корню сайта (например, sites/assets/orig).

При импорте графики в Dreamweaver файл заметок разработчика автоматически копируется на сайт вместе с файлами графических изображений. При выборе изображения в Dreamweaver для редактирования с помощью Fireworks будет открыт исходный файл.

Включение и отключение заметок разработчика для сайта

Заметки разработчика представляют собой примечания, связанные с соответствующим файлом, но хранящиеся в отдельном файле. Заметки разработчика можно использовать для хранения дополнительной информации о документах, например для хранения имен исходных файлов изображений или комментариев о состоянии файлов.

Включить или отключить использование заметок разработчика для сайта можно с помощью категории «Заметки разработчика» диалогового окна «Определение веб-сайта». Если включены заметки разработчика, то существует возможность при желании передавать их другим пользователям.

  1. Выберите «Веб-сайт» > «Управление веб-сайтами».
  2. В диалоговом окне «Управление веб-сайтами» выберите нужный сайт и нажмите кнопку «Редактировать».
  3. В диалоговом окне «Настройка сайта» разверните «Дополнительные параметры» и выберите категорию «Заметки разработчика».
  4. Чтобы включить либо отключить использование заметок разработчика, установите либо снимите флажок «Сохранять заметки разработчика».
  5. Чтобы удалить все заметки разработчика, хранящиеся на локальном компьютере, нажмите кнопку «Очистить», затем кнопку «Да». (Удаленные файлы заметок разработчика могут быть удалены только вручную.)

    Примечание.

    Команда «Очистить заметки разработчика» удаляет только файлы MNO (файлы заметок разработчика). При этом ни папка _notes, ни содержащийся в ней файл dwsync.xml не удаляются. Dreamweaver хранит в файле dwsync.xml сведения о синхронизации узла.

  6. Установите флажок «Включить параметр «Передать «Заметки разработчика» для совместного использования», чтобы вместе с документами передавались и заметки разработчика, связанные с данным сайтом, а затем нажмите кнопку «ОК».
    • В этом случае заметки разработчика будут доступны для всей группы, работающей над проектом. При размещении или получении файла Dreamweaver автоматически размещает или получает соответствующий файл заметок разработчика.

    • Если данный параметр не выбран, Dreamweaver сохраняет заметки разработчика на локальном компьютере и не загружает их вместе с файлами. Если разработка сайта выполняется одним разработчиком, отключение данного параметра улучшает производительность. В этом случае заметки разработчика не передаются на удаленный сайт при возврате и размещении файлов. При этом все добавления и изменения заметок для сайта будут сохраняться на локальном компьютере.

Связывание заметок разработчика с файлами

Файл заметок разработчика можно создать для каждого документа или шаблона сайта. Заметки разработчика можно также создавать для апплетов, элементов управления ActiveX, изображений, Flash-содержимого, объектов Shockwave и полей для изображений в документах.

Примечание.

Если заметки разработчика добавлены в файл шаблона, документы, создаваемые на его основе, не будут наследовать эти заметки.

  1. Выполните одно из следующих действий.
    • Откройте файл в области «Окно документа» и выберите команды «Файл» > «Заметки разработчика».

    • На панели «Файлы» щелкните файл правой кнопкой мыши (в Windows) или щелкните при нажатой клавише Control (в Macintosh) и выберите пункт «Заметки разработчика».

    Примечание.

    Если файл находится на удаленном сайте, его сначала нужно извлечь или получить, а уже потом выбирать из локальной папки.

  2. Перейдите на вкладку «Базовые сведения» и выберите в меню «Состояние» соответствующее состояние для документа.
  3. Чтобы вставить в заметки текущую локальную дату, щелкните значок даты над полем «Заметки».
  4. В поле «Заметки» введите требуемую информацию.
  5. Установите флажок «Показывать, когда файл открыт», чтобы каждый раз при открытии файла отображался соответствующий файл заметок разработчика.
  6. Перейдите на вкладку «Все сведения» и нажмите кнопку со знаком «плюс» (+), чтобы добавить новую пару «ключ-значение», или нажмите кнопку со знаком «минус» (–), чтобы ее удалить.

    Например, ключу можно присвоить имя Author (в поле «Имя») и задать значение Heidi (в поле «Значение»).

  7. Нажмите кнопку «ОК», чтобы сохранить заметки.

    Dreamweaver сохраняет заметки в папке _notes в том же месте, в котором расположен текущий файл. Имя файла заметок формируется из имени соответствующего файла, к которому добавляется расширение MNO. Например, если имя файла index.html, то соответствующий файл заметок разработчика будет называться index.html.mno.

Работа с заметками разработчика

После связывания заметки разработчика с файлом ее можно открыть для изменения состояния или удаления.

Открытие заметок разработчика, связанных с файлом

  1. Чтобы открыть заметки разработчика, выполните одно из следующих действий.
    • Откройте файл в области «Окно документа» и выберите команды «Файл» > «Заметки разработчика».

    • На панели «Файлы» щелкните файл правой кнопкой мыши (в Windows) или щелкните при нажатой клавише Control (в Macintosh) и выберите пункт «Заметки разработчика».

    • В столбце «Заметки» панели «Файлы» дважды щелкните желтый значок заметок разработчика.

    Примечание.

    Чтобы отобразить желтые значки заметок разработчика, выберите «Cайт» > «Управление сайтами» > [название сайта] > «Правка» > «Дополнительные параметры» > «Колонки представления файлов». На панели списка выберите «Заметки» и щелкните «Показать». При нажатии кнопки «Развернуть» на панели инструментов «Файлы» для отображения и локального, и удаленного сайта в столбце «Заметки» локального сайта будет отображен желтый значок для каждого файла, который имеет заметки разработчика.

Назначение заказного состояния заметок разработчика

  1. Откройте заметки разработчика для файла или другого объекта (см. предыдущую процедуру).
  2. Перейдите на вкладку «Все сведения».
  3. Нажмите кнопку со знаком «плюс» (+).
  4. В поле «Имя» введите слово status.
  5. В поле «Значение» введите состояние.

    Если такое состояние уже существует, оно будет заменено новым.

  6. Перейдите на вкладку «Базовые сведения» и убедитесь, что новое состояние добавлено во всплывающее меню «Состояние».

    Примечание.

    Одновременно в меню состояния может отображаться только одно заказное значение. Если еще раз выполнить ту же процедуру, Dreamweaver заменит предыдущее состояние новым.

Удаление с сайта несвязанных заметок разработчика

  1. Выберите «Веб-сайт» > «Управление веб-сайтами».
  2. Выберите сайт и нажмите кнопку «Редактировать».
  3. В диалоговом окне «Определение веб-сайта» выберите категорию «Заметки разработчика» в списке слева.
  4. Нажмите кнопку «Очистить».

    В Dreamweaver будет предложено подтвердить удаление заметок разработчика, которые не связаны ни с каким файлом на сайте.

    Если удаление файла с заметками разработчика выполняется в среде Dreamweaver, то файл заметок удаляется Dreamweaver автоматически. Таким образом, появление несвязанных файлов заметок разработчика происходит лишь в случае удаления или переименования файлов другими средствами, а не Dreamweaver.

    Примечание.

    Если перед нажатием кнопки «Очистить» отменить выбор параметра «Сохранять заметки разработчика», Dreamweaver удалит с сайта все файлы заметок разработчика.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет